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Preface
Introduction
This guide describes how to use the VERITAS Volume Manager™ Graphical User
Interface (GUI).

Audience
This guide is intended for system administrators responsible for configuring and
maintaining systems using the VERITAS Volume Manager (VxVM) with the VERITAS
Enterprise Administrator (VEA). This guide assumes the following:

◆ A basic understanding of system administration

◆ A working knowledge of the UNIX operating system

◆ Familiarity with VxVM and related concepts

Organization
This guide is organized as follows:

◆ Chapter 1, “Introducing the VEA GUI,” describes the main components of the GUI.

◆ Chapter 2, “Getting Started with VxVM VEA,”  describes how to set up and start
using VxVM with VEA.

◆ Chapter 3, “Disk Tasks,” describes how to set up and use disks using VxVM with
VEA.

◆ Chapter 4, “Volume Tasks,” describes how to create and use volumes and related
objects using VxVM with VEA.

◆ Chapter 5, “File System Tasks,” describes the tasks associated with file systems.

◆ Chapter 6, “Cluster Tasks,”  describes the tasks associated with clusters.
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Related Documents
◆ Chapter 7, “Troubleshooting,” provides information about VxVM alerts, object states,
and other troubleshooting topics.

◆ Chapter 8, “Icons,” lists the icons available with VxVM.

◆ The Glossary defines terms that relate to VxVM.

Related Documents
The following documents provide related information:

◆ VERITAS Volume Manager Administrator’s Guide

◆ VERITAS Volume Manager Troubleshooting Guide

◆ VERITAS Volume Manager Hardware Notes

◆ VERITAS Volume Manager Installation Guide

◆ VERITAS Volume Manager Release Notes

◆ VERITAS Volume Manager manual pages

The following table describes terms associated with the use of the mouse:

Getting Help
If you have any comments or problems with the VERITAS products, contact VERITAS
Technical Support:

◆ U.S. and Canadian Customers: 1-800-342-0652

◆ International Customers: +1 (650) 527-8555

◆ E-mail: support@veritas.com

Term Definition

Click Press and release the mouse button.

Double-click Click the mouse button twice (quickly).

Right-click Press and release the right mouse button.

Press and Hold Press and continue to hold down the mouse button.

Point Move the cursor onto an item on the screen.

Select Click the mouse button while the pointer is directly over the item to be
selected.

Drag Select the object and drag it while pressing the mouse button.
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Getting Help
For license information (U.S. and Canadian Customers):

◆ Phone: 1-925-931-2464

◆ E-mail: license@veritas.com

◆ Fax: 1-925-931-2487

For software updates:

◆ E-mail: swupdate@veritas.com

For additional technical support information, such as TechNotes, product alerts, and
hardware compatibility lists, visit the VERITAS Technical Support Web site at:

◆ http://support.veritas.com (U.S. and Canada Customers)

For additional information about VERITAS and VERITAS products, visit the Web site at:

◆ http://www.veritas.com

Downloading and Running VRTSexplorer

If you have access to the Internet, you can use the VRTSexplorer program to assist
Technical Support in diagnosing the cause of your problem. Refer to the VERITAS Volume
Manager Release Notes for information on using the VRTSexplorer program.
Preface xi
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Introducing the VEA GUI
 1

Before using the VERITAS Volume Manager VEA GUI, you should familiarize yourself
with the following introductory topics:

◆ VxVM VEA Features

◆ Main Window

◆ Task Roadmap

VxVM VEA Features
You use the VxVM VEA to administer disks, volumes, and file systems on local or remote
machines.

VxVM VEA is a Java-based interface that consists of a server and a client. The server runs
on a UNIX machine that is running VxVM. The client runs on any machine that supports
the Java Runtime Environment.

VxVM VEA provides the following features:

◆ Accessibility - Using the Mouse and Keyboard

Accelerators and mnemonics are provided as alternatives to using the mouse (refer to
the VEA online help for more information).

◆ Ease of Use

The task-based user interface provides access to tasks through menus or a task list.
Administrators can easily navigate and configure their systems, and browse through
all of the objects on the system or view detailed information about a specific object.

◆ Remote Administration

Administrators can perform VxVM administration remotely or locally. The VEA client
runs on UNIX or Windows machines.

◆ Java-based Interface

A pure Java-based interface is used. Administrators can run VxVM VEA as a Java
application.
1



Main Window
◆ Scalability

VxVM VEA can handle systems containing large numbers of disks. Administrators
can view all of the objects on the system, or focus on a specific object or set of objects.

◆ Security

VxVM VEA does not support communication between the client and server across a
firewall.

◆ Multiple VEA Support

The VxVM VEA client can provide simultaneous access to multiple host machines.
The administrator can use a single client session to connect to multiple hosts, view the
objects on each host, and perform administrative tasks on each host. Each host
machine must be running the VxVM VEA server.

◆ Multiple Views of Objects

VxVM VEA provides multiple views of objects:

- The main window tree and grid view lists objects on the system.

- The Disk View window displays a graphical view of volumes, disks, and other
objects in a disk group.

- The Volume View window displays a graphical view of the volumes on a host.

- The Volume to Disk Mapping window shows the relationships between volumes
and their underlying disks.

Main Window
The VxVM VEA Main Window consists of:

◆ The Object Tree and Grid

◆ The Menu Bar

◆ The Toolbar

◆ The Status Area
2 VERITAS Volume Manager User’s Guide - VEA



Main Window
Main Window

The toolbar can be separated from and reattached to the main window (this is known as
docking). The grid can be replicated in a separate window.

The Object Tree and Grid
The VxVM VEA main window is divided into two main panes:

◆ Left Pane (Object Tree)

The following object groups typically appear as nodes in the object tree:

- Hosts – Any host machines connected to the current VxVM VEA client session.

- Controllers – All controllers on the system.

- Disk Groups – All disk groups on the system.

- Disks – All disks on the system.

- Enclosures – All enclosures (disk arrays) on the system.

- File Systems – All mounted file systems on the system.

- Volumes – All volumes on the system.
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Main Window
◆ Right Pane (Grid)

The right pane contains a grid, which is a tabular display of objects and their
properties. The grid displays objects that belong to the group icon that is currently
selected in the object tree (left pane).

The splitter is the vertical bar that separates the object tree from the grid. You can resize
the left and right panes by pressing and holding the mouse button over the splitter and
dragging the splitter to the left or right.

The Menu Bar
The menu bar at the top of the main window contains the following menus:

◆ File

The File menu establishes new host connections, closes the main window, provides
access to an object Properties window, or exits VEA.

◆ Tools

The Tools menu saves or loads user preferences, removes any alert icons from the
status area, and sets VxVM VEA to read-only mode.

◆ Actions

The Actions menu is a context-sensitive menu that launches tasks on a selected
object. It is inactive until you connect to a host. The Actions menu is dynamic and
changes its options based on the type of object that is selected. When an object is
selected, the Actions menu provides access to tasks appropriate for the selected
object.

◆ Help

The Help menu provides access to online help for VxVM VEA.

The Toolbar
The toolbar provides quick access for performing some of the program’s most common
tasks.

Connect Brings up the Connection Dialog.
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Task Roadmap
The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to
separate the toolbar from the main window or move the toolbar to the bottom, side, or top
of the main window. To reposition the toolbar, press and hold the mouse button over the
toolbar handle and drag the toolbar to its new location.

The Status Area
The status area is at the bottom of the main window. When an object fails or experiences
an error, an alert (error) icon appears in the status area. The Alert Monitor window
provides details about the error. You can access the Alert Monitor window by clicking on
the alert icon in the status area.

Task Roadmap
VxVM VEA tasks are grouped into:

◆ Setup Tasks

◆ Maintenance Tasks

◆ Repair/Recovery Tasks

Setup Tasks
If you are using VxVM and VEA for the first time, you need to install both products, place
your disks under VxVM control, and create volumes.

▼ Setting Up Your System

◆ Installing and initializing VxVM.

◆ Installing VEA.

◆ Starting VEA.

These tasks are described in the VERITAS Volume Manager Installation Guide.

Disconnect Disconnects from selected machine.

Search Brings up the Search Wizard.
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Task Roadmap
▼ To set up disks

◆ Placing disks under VxVM control.

◆ Creating additional disk groups for the new disks (optional).

◆ Designating one or more disks as hot-relocation spares (optional).

These tasks are described in Chapter 3, “Disk Tasks.”

▼ To set up volumes

◆ Creating volumes.

◆ Creating mirrors for any volumes that need to be redundant.

These tasks are described in Chapter 4, “Volume Tasks.”

▼ To set up file systems

◆ Placing file systems on volumes.

◆ Mounting a file system.

These tasks are described in Chapter 5, “File System Tasks.”

▼ To set up clusters

◆ Setting up a shared disk group.

◆ Starting a cluster.

These tasks are described in Chapter 6, “Cluster Tasks.”

Maintenance Tasks
After you have set up your disks and volumes, you need to perform some or all of the
following maintenance tasks.

▼ Monitor objects

◆ Use the Main Window tree (left pane) and grid (right pane) to view disks, volumes,
file systems, and other objects on the system.

◆ Use the Disk View Window to display a graphical view of disks, volumes, and other
objects in a particular disk group.

◆ Use the Volume View window to display a graphical view of the volumes for a host.

◆ Use the Volume to Disk Mapping Window to view the relationships between volumes
and their underlying disks.
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Task Roadmap
◆ Use the Object Properties Window to view detailed information about a selected
object.

◆ Use the Alert Tab to view information about errors or failures associated with objects
that are marked with alert icons.

(Windows are described in Chapter 2, “Getting Started with VxVM.”)

▼ Maintain disks

◆ Adding a Disk to VxVM.

◆ Creating a Dynamic Disk Group.

◆ Upgrading a Dynamic Disk Group Version.

These tasks are described in Chapter 3, “Disk Tasks.”

Note “Dynamic Disk Groups” were formerly known as “Disk Groups.” They are still
sometimes referred to as “Disk Groups” in menu displays and the CLI.

▼ Maintain volumes

◆ Resizing a Dynamic Volume as users and applications require more space.

◆ Changing a Volume Layout.

◆ Adding a Mirror to a Volume to any unmirrored volume that should be redundant.

These tasks are described in Chapter 4, “Volume Tasks.”

▼ Maintain file systems

◆ Adding a New File System to a Volume.

◆ Increase the size of file systems as users and applications require more space.

◆ Create snapshot copies of file systems and then back up the file systems.

These tasks are described in Chapter 5, ““File System Tasks.”

▼ Maintain clusters

◆ Creating a Shared Dynamic Disk Group

◆ Importing a Shared Dynamic Disk Group

These tasks are described in Chapter 6, “Cluster Tasks.”
Chapter 1, Introducing the VEA GUI 7



Task Roadmap
Repair/Recovery Tasks
If disk and/or system failures occur, VxVM generally performs any necessary recovery
operations automatically. However, depending on the circumstances, you may need to
attempt to recover from the situation as follows.

▼ Protect volumes from disk failure

◆ Adding a Disk to VxVM.

◆ Replacing Disk.

These tasks are described in Chapter 3, “Disk Tasks.”

▼ Repair/recover volumes

◆ Recovering a Volume.

◆ Recover all volumes on a failed disk.

◆ Recovering Volumes in Dynamic Disk Groups.

◆ If a volume is not recoverable, restore the volume from backup.

These tasks are described in Chapter 3, “Disk Tasks,” and Chapter 4, “Volume Tasks.”

▼ Repair/recover file systems

◆ Perform a file system consistency check on any file systems that may be damaged.

(Refer to Chapter 5, “File System Tasks.”)
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Getting Started with VxVM VEA
 2

Before using VEA, you need to familiarize yourself with the following:

◆ Setting Up Your System

◆ Starting VEA

◆ Viewing Objects and Object Properties

- Tree and Grid View

- Disk View Window

- Volume View Window

- Volume Layout Details Window

- Volume to Disk Mapping Window

◆ Viewing Task History

◆ Command Log

◆ Search/Report

◆ Performance Tuning

◆ Load Balancing

◆ Setting Preferences

◆ Disk Failure or Removal

Setting Up Your System
VEA consists of a server (vxsvc) and a client (vea). You must install and run the VEA
server on a UNIX machine running VxVM. You can install and run the VEA client on any
machine that supports the Java Runtime Environment.

Before you can use VEA, you need to:
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Starting VEA
1. Install VxVM on the machine to be administered.

2. Install the VEA server and client on the machine to be administered. Run vxinstall
to create the rootdg disk group and initialize at least one disk.

3. If users other than root need to access VEA, set up security to specify which users can
run VEA.

4. If you plan to run the VEA client from a machine other than the machine to be
administered, install the VEA client on the machine where the client will run.

5. Start the VEA server on the machine to be administered.

6. Start the VEA client.

Refer to the VERITAS Volume Manager Installation Guide for details on how to install and
set up VEA.

Starting VEA
Only users with appropriate privileges can run VEA. Refer to the VERITAS Volume
Manager Installation Guide for information on security and access permissions.

You can use VEA to administer the local machine or a remote machine. The VxVM
daemon (vxconfigd) and the VEA server (vxsvc) must be running on the machine to be
administered. Once VEA is installed, the VEA server starts up automatically at system
startup.

Viewing Objects and Object Properties
VEA provides the following views of objects and their properties:

- Tree and Grid View

The main window tree and grid view displays volumes, disks, file systems, and other
objects on the system. The grid also displays a limited set of properties for listed
objects.

- Disk View Window

The Disk View window displays a graphical view of disks, volumes, and other objects
in a particular disk group.

- Volume View Window
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Viewing Objects and Object Properties
The Volume Layout Details window displays a close-up graphical view of a single
volume and its components (mirrors/plexes and subdisks).

- Volume to Disk Mapping Window

The Volume to Disk Mapping window shows the relationships between volumes and
their underlying disks.

- Object Properties Window

The object Properties window contains detailed information about a specific object.

Tree and Grid View
The main window tree and grid view displays volumes, disks, file systems, and other
objects on the system. The object tree is a hierarchical display of object groups. The grid is
a tabular display of objects and a limited set of properties. VEA constantly monitors
objects on the system and makes appropriate changes to the tree and grid displays.

Disk Usage Legend
The disk usage legend is displayed at the bottom of the right pane; and shows how to
interpret the colors with respect to Disk Usage (Normal Usage, High Usage, and Critical
Usage).

Disk View Window
The Disk View window displays a graphical view of disks. It is dynamic, so the objects
displayed in this window are automatically updated when their properties change. You
can select objects or perform tasks on objects in the Disk View window.

The Disk View window can be accessed by clicking on a disk and selecting Actions >
Disk View.

You can move the horizontal splitter to adjust the relative heights of both panes. To resize
the volume and disk panes, place the pointer over the horizontal splitter and then press
and hold the mouse button to drag the splitter to the desired position.

Using the Menu Bar

The menu bar at the top of the Disk View window contains the following menus:

◆ File

The File menu enables you to:
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Viewing Objects and Object Properties
- Access to the page setup menu

- Print the properties of a selected object

- Close the Disk View window

- Access the Properties window

- Display selected disks

◆ Options

The Options menu provides you with the following selections:

- Refresh View

- Collapse—provides basic information for all disks in the view

- Expand—provides detailed information for all disks in the view

- Vol Details—basic volume information

- Full Volume Display—volume objects also display the volume size, free space,
and state of the volume

- Projection—highlights associated objects

With the exception of Refresh View and Full Volume Display, these options are also
available from the icons under the Disk View menu bar.

◆ Action

The Action menu provides all the tasks available on the corresponding object in the
main window.

Using the Toolbar

The toolbar at the top of the Disk View window has the following set of buttons:

◆ Expand

The Expand button shows more detailed information about all disks in the Disk View,
including subdisks and free space. This button displays objects in layout mode or
detailed mode, depending on the previous mode.

◆ Collapse

The Collapse button hides details for all disks in the Disk View. This button displays
objects in layout mode or basic mode, depending on the previous mode.
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Viewing Objects and Object Properties
.

◆ Projection

The Projection button highlights objects associated with the selected subdisk or
volume.

Projection shows the relationships between objects by highlighting objects that are
related to or part of a specific object. When disks are in layout mode or detailed mode,
clicking on a subdisk highlights the location of the subdisk on the corresponding disk.
Chapter 2, Getting Started with VxVM VEA 13



Viewing Objects and Object Properties
◆ Print

The Print button prints the properties of the selected object.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to
separate the toolbar from the window or move the toolbar to the bottom, side, or top of
the window. To reposition the toolbar, press and hold the mouse button over the toolbar
handle and drag the toolbar to its new location.

In the Disk View, you can move subdisks by dragging the subdisk icons to their new
locations. You can drag a subdisk to another disk or a gap on the same disk. To move a
subdisk, place the pointer over the subdisk and then press and hold the mouse button to
drag the subdisk to another location.

Caution Moving subdisks reorganizes volume disk space and must be done with care.

The Disk View window displays plexes and subdisks that are associated with volumes. To
view Volume Manager objects that are not associated with volumes (such as dissociated
plexes), open the Dissociated Object View window (see Dissociated Plex View Window).
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Viewing Objects and Object Properties
Mapping Disks to Volumes

You can map a disk to the associated volume by bringing up both the Disk View and the
Volume View (see Volume View Window). When you click on the disk in the Disk View,
the corresponding plex in the Volume View is highlighted.

Volume View Window
The Volume View window gives the characteristics of the volumes on the disks.

The Volume View window can be accessed by clicking on a volume and selecting
Actions > Volume View.
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Viewing Objects and Object Properties
You can move the horizontal splitter to adjust the relative heights of both panes. To resize
the volume and disk panes, place the pointer over the horizontal splitter and then press
and hold the mouse button to drag the splitter to the desired position.

The menu bar at the top of the Volume View window contains the following menus:

◆ File

The File menu prints the properties of a selected object, closes the Volume View
window, and provides access to the Properties window.

◆ Action

The Action menu provides access to all the tasks available on the corresponding
object in the main window.

The toolbar at the top of the Volume View window has the following set of buttons:

◆ Collapse all volumes

The Collapse Volume button hides details for all volumes in the Volume View. This
button displays objects in layout mode or basic mode, depending on the previous
mode.

◆ Expand all volumes

The Expand Volume button shows more detailed information about all disks in the
Volume View. This button displays objects in layout mode or detailed mode,
depending on the previous mode.

◆ New volume

The New Volume button brings up the create volume dialog box.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to
separate the toolbar from the window or move the toolbar to the bottom, side, or top
of the window. To reposition the toolbar, press and hold the mouse button over the
toolbar handle and drag the toolbar to its new location.
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Viewing Objects and Object Properties
Dissociated Plex View Window
The Dissociated Plex View window shows the dissociated plexes for a particular disk
group.

The Dissociated Plex View window can be displayed by clicking on a disk group and
selecting Actions > Dissociated Plex View.
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Viewing Objects and Object Properties
Volume Layout Details Window
The Volume Layout Details window displays a graphical view of the selected volume’s
layout, components, and properties. You can select objects or perform tasks on objects in
the Volume Layout Details window. The Volume Layout Details window is dynamic, so
the objects displayed in this window are automatically updated when the volume’s
properties change.

The View menu changes the way objects are displayed in this window. To access the
popup menu for an object, right-click on the object, or use the Actions menu.

Volume Layout Details Window

You can view objects in the Volume Layout Details window in the following ways:

❖ To display the Volume Layout Details window for a volume, click on the volume (in
the main window grid) and then choose Actions > Layout View.

❖ To view a different volume, go back to the main window and select the required
volume.

❖ To zoom in and out of the view, use the scroll bar on the left side of the window.

◆ To access the popup menu for an object, right-click on the object.

Use the File menu to close the window.

Volume to Disk Mapping Window
The Volume to Disk Mapping Window displays a tabular view of volumes and their
underlying disks. Volumes are listed in the top row of the table and disks are listed in the
left column of the table. Each circle icon in the table indicates that part of the
corresponding volume is located on the corresponding disk.

This window can also display details such as the subdisks and gaps (free space) on each
disk. Each subdisk or gap is listed with its disk offset and length. When subdisks are
shown, circles show the relationship between volumes and subdisks.

The Volume to Disk Mapping window is dynamic, so the contents of this window are
automatically updated when objects are added, removed, or changed. For instructions on
navigating the Volume to Disk Mapping window, see “Navigating the Volume to Disk
Mapping Window” on page 19.

❖ To display the Volume to Disk Mappng window, click on the disk group (in the main
window grid) and then choose Actions > Disk/Volume Map.

The File menu displays volume and disk property information, or closes the window.
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Viewing Objects and Object Properties
The View menu changes the way objects appear in the Volume to Disk Mapping window,
and allows you to set up collection of statistics for the disk group.

The context-sensitive Actions menu allows you to perform tasks for a selected object. To
access the popup menu for an object, right-click on the object.

The Volume to Disk Mapping window has a performance monitoring feature that ranks
volume response time. When performance monitoring is turned on, the icons in the table
change. The volumes with the slowest reads/writes are shown as red icons. Volumes with
relatively slow response time are shown as yellow icons. All other volumes are shown as
green icons.

“Volume to Disk Mapping Window” shows the relationships between volumes and disks.

Volume to Disk Mapping Window

Navigating the Volume to Disk Mapping Window

You can view volumes and their associated disks using the following procedures:

◆ To display the Volume to Disk Mapping window for all volumes in a disk group, click
on the disk group (in the main window grid) and then choose Actions >
Disk/Volume Map.
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Viewing Objects and Object Properties
◆ To display all of the subdisks and gaps on a particular disk, click the arrow to the left
of the disk name. Any subdisks and gaps are listed below the disk name. To hide the
subdisks and gaps, click the arrow again.

◆ To display all of the subdisks and gaps on all disks, choose View > Expand All. To
hide all of the subdisks and gaps on all disks, choose View > Collapse All.

◆ To use the statistics collection feature, see Viewing Real-Time Statistics.

◆ To highlight a disk row, click on the disk name. To highlight a volume column, click
on the volume name. To highlight both the disk and volume associated with a
particular circle, click on the circle.

◆ Volumes with relatively slow read/write performance are shown as circular red icons.

◆ To change the criteria that determine which disks are displayed as slow performers,
see Monitoring Performance.

◆ To print the properties of a particular object, select the object and then choose File >
Print and complete the Print dialog box.

Mapping Volumes to Disks

You can map a plex to the associated disk by bringing up both the Volume View and the
Disk View. When you click on the plex in the Volume View, the corresponding disk in the
Disk View is highlighted.

Object Properties Window
The Object Properties window contains detailed information about the selected object.
The Properties window contains a set of tabbed pages, each of which contains information
about the object and related objects. The tab labels and page contents vary, depending on
the type of object selected. You can display a different page by clicking on the appropriate
tab label. Some object properties can be changed through the Properties window for the
object. For instructions on navigating the Object Properties window, see “Navigating the
Object Properties Window” on page 22.

“Volume Properties Window” shows how a volume appears in the Volume Properties
window.
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Viewing Objects and Object Properties
Volume Properties Window
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Multiple Selections
Navigating the Object Properties Window

You can view object properties using the following procedures:

◆ To view the properties of an object, click on the object (in the main window grid) and
then choose Properties from the Selected or popup menu. You can also access the
Properties window by double-clicking on the object.

Example:

To display volume properties, either click on a volume and then choose Volumes >
Properties or double-click on a volume.

Note Double-clicking on an object that has children may display the children of the object
instead of the Properties window.

◆ To go to a tab in a properties window, click the appropriate tab label.

◆ To update the contents of the Properties window to reflect current properties for the
object, click Refresh.

◆ To change any of the editable items in the Properties window, make the appropriate
changes and then click OK. This changes the settings for all properties tabs in the
Properties window.

Multiple Selections
You can select more than one object from a list (for example, when you need to add
several disks into a disk group) using the SHIFT and CONTROL keys in conjunction with
the left mouse button.

Use the SHIFT key to select a range of objects.

Use the CONTROL key to select individual objects.

Accessing Tasks
Most VEA tasks are performed by selecting objects and/or tasks and then completing the
resulting dialog boxes. With VEA, you can access tasks from the menu bar and from a
context-sensitive popup menu.
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Viewing Task History
Viewing Task History
VEA logs all task requests. You can view the task history (including tasks in progress)
using the Task History window, or the Command Log file.

The Task History window displays a history of tasks performed in the current session
(and any other sessions running on the machine). Each task is listed with properties such
as the task name, the task status, and the start/finish times.

To display the Task History window, click on Tasks at the bottom of the main window.

For a selected task, you can use the popup menu options: Abort Task to cancel the task;
Pause Task to temporarily stop a task, Resume Task to continue the task; and Throttle
Task to throttle a task.

Task Throttling
Task Throttling causes an operation to pause for the allowed amount of time whenever a
disk I/O is performed, allowing the CPU to perform other tasks.
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Command Log
Select the popup menu option Throttle Task to change the task priority. You can change
the priority for a single task, or select Throttle All Tasks to apply the priority to all
Volume Manager Tasks. Click Ok to complete your selection.

Clearing Finished Tasks
Tasks are persistent in the Tasks console. To remove completed tasks from the window,
select Clear All Finished Tasks from the popup menu.

Viewing Task Properties
To view task properties and the low-level commands used to perform a task, select the
task and choose Properties from the popup menu. You can also access task properties by
double-clicking on the task.

Command Log
The command log file contains a history of VEA tasks performed in the current session
and previous sessions. It contains a description of each task, along with properties such as
the start/finish times and the low-level commands used to perform the task. For failed
tasks, the command log includes any relevant error messages. The command log file
resides, and can be viewed, at /var/vx/isis/command.log.

The following example shows a sample command log file entry:

Description: Add Log to Volume
Date: Wed April 17 4:36:11 2002
Command: /usr/sbin/vxassist  -g datadg addlog data vol
Output: vxvm:vxassist: ERROR: Volume datavol-L01: Volume’s logging
type not supported
Exit Code: 20

Search/Report
The Search/Report feature allows you to search for objects on the system running VxVM.

To invoke the Search/Report feature, choose Tools > Search. This brings up the “Search
on Host” dialog.
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Search/Report
How to use the Search/Report Feature

1. In order to find an object, you must first select the object type (under Look for:).

Object types include:

- Volumes

- Disks

- Dynamic Disk Groups

- Controllers

- Enclosures

- File systems

2. Once you have chosen the object type, you define the search criteria (under Define
Criteria):

The criteria menu selection is based on the object type you have selected.

If you chose Volumes, the available Attributes are:

- Name

- Dynamic group name

- Size
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Search/Report
- Status

- Disk

- Device

If you chose Disks, the available Attributes are:

- Name

- Dynamic group name

- Size

- Status

- Device name

- Free space

If you chose Dynamic Disk Group, the available Attributes are:

- Name

- Imported

- Size

- Free space

3. Once you have chosen an Attribute, you must choose how to compare the object.

The possible ways to compare the object change with your previous selections, and
are limited to:

- Any

- Contains

- Starts with

- Ends with

- Is

- Is not

- True

- False

- Greater than

- Less than

- Equal to
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Performance Tuning
4. If you did not select the Status or Imported attribute, you must enter a number into
the value box. The attribute of the object type you selected will be compared with the
value you enter in the way you selected. If you selected the Status attribute, you will
need to select a value from Unitialized, Healthy, Stopped, Degraded, and Failed.

5. If you selected the Size or Free space attribute, you will also need to define the unit of
measurement (Sectors, KB, MB, GB, TB).

6. Use the Add and Remove buttons to add and remove search statements.

7. Click the Search Now button to perform the search.

Example:

If you search for a Volume (object type), with a Size (attribute), of greater than (compare),
10 MB(value), the search will only display volumes with a capacity of greater than 10 MB.

8. If you wish to save the search results, click the Save Results button.

- The Save Dialog box appears. Select the path or folder you want the file to save to.

- Enter a name for the file into the File name field.

- Click Save to save the file and close the dialog box.

Note If you save the file with the .XML file extension, the file will be in XML format.

Performance Tuning
When a program or device uses too much disk I/O, bottlenecks can occur, creating a hot
spot and degrading performance. You can make adjustments by moving subdisks from an
area of high I/O usage to another disk that has lower usage.

The VxVM statistics function provides I/O statistics to allow you to do performance
tuning to improve overall disk and system performance.

You can improve disk and system performance by identifying I/O bottlenecks, or hot
spots; then moving data among physical drives to evenly balance the I/O load among the
disk drives. This is known as load balancing.

See also:

◆ Real-time Statistics Collection and Display

◆ Load Balancing

◆ Disk Failure or Removal

◆ Disk Phaseout
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Real-time Statistics Collection and Display
To set up real-time statistics collection and display, you need to Select Online Display
Options.

Select Online Display Options

Use the following procedure to set the display options.

▼ To select the online data display options:

1. Choose Tools > Statistics > Online Data Display Options to bring up the Online
Display Options window.

2. Select the checkboxes for the required statistics parameters.

- Read Requests/Second

The number of read requests per second for selected storage objects.

- Write Requests/Second

The number of write requests per second for selected storage objects.

- Read Blocks/Second
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Performance Tuning
The amount of read request data (in blocks per second) that is processed for
selected storage objects. It is the throughput on the read requests made.

- Write Blocks/Second

The amount of write request data (in blocks per second) that is processed for
selected storage objects. It is the throughput on the write requests made.

- Avg Time (microseconds)/Read Block

The average time in microseconds that it takes to process a read block from the
time a request is made until the data is returned.

- Avg Time (microseconds)/Write Block

The average time in microseconds that it takes to process a read block from the
time a request is made until the data is returned.

By default, all the statistical parameters will be enabled.

3. Set I/O Refresh Rate/Sec.

This is the time interval of the refresh of the data collection screen display. The
program continuously runs the actual statistics in the background, but changes the
display of them on the Online Monitoring according to the refresh rate you set.

4. Set Threshold.

The Threshold is the minimum amount of I/O per second that a disk or subdisk has
to have to display a color other than blue. Blue is the lowest state, Low I/O activity.
The default threshold is 15.

5. Set Hot spot indicator based on category.

6. When you are finished with your changes, click OK.

Viewing Real-Time Statistics

You can view real-time statistics in the Volume to Disk Mapping Window. By default, the
Volume to Disk Mapping Window comes up with statistics collection switched off. To turn
it on, you need to:

◆ Select the disk group to be monitored

◆ Select Actions > Disk/Vol Map

◆ Select:

- View > Collect Statistics
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Load Balancing
Statistics are accumulated from when they were reset (usually they are reset when
the system boots/reboots, or at object creation, whichever is most recent).

- View > Compare on Refresh

Each statistic request is compared with the last one to determine where the
current high I/O activity is occurring.

Monitoring Performance

You can change the criteria that determine which disks are displayed as slow performers.
Select View > Perf. Monitoring Parameters and complete the Performance Monitoring
Parameters dialog box. This dialog box allows you to configure how many disks are
shown as slowest and next slowest performers, the sampling interval, and whether to
show the slowest performers for reading, for writing, or for both reading and writing.

Load Balancing
If disk activities are heavily concentrated on one or a small number of disks in the storage
subsystem, it may create bottlenecks. You can use the Moving a Subdisk and possibly the
Splitting a Subdisk features to spread out disk accesses more evenly across all the disks
to balance the load.

If a disk has High or Critical I/O activity (shown by a red or yellow pie symbol), you may
consider moving one or more of its subdisks to another disk that shows below average
I/O activity (shown by a blue pie symbol). The idea is to move just enough activity to
achieve balance. A careful study of the statistics for the disk with Critical activity may
identify the best subdisks to move. You should move subdisks only when a disk has High
or Critical I/O activity over a prolonged period of time and performance is affected.
Moving a subdisk to another disk has an effect on I/O as well, but it should be
compensated for by the other disk having much lower I/O activity. You would need to
look at the statistics after the subdisk move to see whether the move was effective in
balancing the load.

Disk Failure or Removal
Moving a subdisk for redundant volumes (mirrored or RAID-5) will use the redundant
data to recreate the subdisk on the healthy disk. However, for nonredundant volumes
(concatenated or striped), the data cannot be recreated and doing subdisk move will
therefore lose data, which could be recovered if the disk can be repaired. Thus, when you
attempt to move a subdisk from a failed or missing disk that has nonredundant data, a
dialog box comes up that asks you if you want to force the move. You may want to force
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Setting Preferences
the move if you don't need the data anymore or you can no longer recover the data. By
doing so, you will retain the volume structure but there is no guarantee that the data will
be recoverable.

Use the Moving a Subdisk feature to move the part of a volume that is on a failed or
missing disk to a healthy one.

Disk Phaseout
When a disk starts getting intermittent I/O errors and shows signs of hardware fatigue,
you can use the Moving a Subdisk feature to move all its subdisks to healthier disks. The
benefit of moving subdisks instead of copying the volumes is that you need only enough
space on the receiving disks for the subdisks on the one failed disk, not for entire volumes
that may span multiple disks. Another advantage is that there is no interruption in I/O.

Moving subdisks provides you a flexible means of making adjustments in your storage
system while it is up and running.

Setting Preferences
To set VxVM view and dialog preferences, select Tools > Preferences > then select the
Volume Manager tab. The VxVM Preferences window appears. When you have made
your changes:

◆ Press Apply to apply the changes.

◆ Press Reset to revert back the changes.

◆ Press OK to apply and dispose the Preference window.

◆ Press Cancel to discard and close the Preference window.
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Preferences Window

Enable Wizard Mode
Check this box if you want to use the VxVM wizards.

Show Inline Disk View
Check this box if you want to show the disk view tab on any objects that have associated
disks. (This view can take a long time to render in a configuration having a large number
of objects.)

Show Dialog Top Information Panel
Check this box if you want to show information about an object selected in the tree while
you are viewing its related objects in the table.
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Setting Preferences
Launch Task Dialogs as Modal
Check this box if you want to prevent access to other dialogs until the task dialog box is
closed.

Enable Subdisk Drag and Drop
Check this box if you want to use the drag and drop feature for subdisks.
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Disk Tasks
 3

VxVM VEA provides you with easy-to-use interfaces for performing tasks and procedures
associated with:

◆ Managing Disks

◆ Managing Dynamic Disk Groups

The Disk Task Roadmap summarizes these tasks.

Managing Disks
The following tasks are associated with disk management:

- Adding a Disk to VxVM

- Scanning Disks

- Commands for Hot Relocation

- Reserving a Disk

- Renaming a Disk

- Onlining a Disk

- Mirroring a Disk

- Evacuating a Disk

- Disconnecting a Disk

- Replacing Disk

- Recovering Volumes on a Disk

- Removing a Disk from a Dynamic Disk Group

- Forcing Initialization of a Disk

- Viewing Disk Properties

- Disabling a Controller
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Managing Dynamic Disk Groups
- Enabling a Controller

- Renaming an Enclosure

Managing Dynamic Disk Groups

Note “dynamic disk groups” are sometimes referred to as “disk groups” in CLI and
menu displays.

The following tasks are associated with dynamic disk group management:

- Creating a Dynamic Disk Group

- Upgrading a Dynamic Disk Group Version

- Renaming Dynamic Disk Groups

- Deporting Dynamic Disk Groups

- Importing Dynamic Disk Groups

- Recovering Volumes in Dynamic Disk Groups

- Clearing Relocation Information for Dynamic Disk Groups

- Destroying a Dynamic Disk Group

- Moving Objects Between Dynamic Disk Groups

- Splitting A Dynamic Disk Group

- Joining Dynamic Disk Groups

- Activating Dynamic Disk Groups

- Viewing Dynamic Disk Group Properties
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Disk Task Roadmap
Disk Task Roadmap
The following table provides a summary of common VxVM disk and dynamic disk group
tasks.

To perform this task … Use this procedure …

Disk Setup Tasks:

Place new disks under VERITAS Volume
Manager (VxVM) control

Adding a Disk to VxVM

Set up new dynamic disk groups Creating a Dynamic Disk Group

Precautionary Tasks:

Place the boot (root) disk under Volume
Manager control

Make an alternate boot (root) disk

Adding a Disk to VxVM

Mirroring a Disk

Maintenance Tasks:

Place additional disks under VxVM control Adding a Disk to VxVM

Add more disk space to a dynamic disk group Adding a Disk to VxVM

Create additional dynamic disk groups Creating a Dynamic Disk Group

Upgrade a dynamic disk group Upgrading a Dynamic Disk Group Version

Recovery Tasks:

Move volumes off failing disks Evacuating a Disk

Replace failed disks To replace a disk drive

Attempt to recover all volumes on a disk Recovering Volumes on a Disk

Attempt to recover all volumes in a dynamic
disk group

Recovering Volumes in Dynamic Disk Groups

Other Tasks:

Change a disk name Renaming a Disk

Change a dynamic disk group name Renaming Dynamic Disk Groups

Move objects between dynamic disk groups Moving Objects Between Dynamic Disk Groups

Split a dynamic disk group Splitting A Dynamic Disk Group

Join dynamic disk groups Joining Dynamic Disk Groups

Restore access to an offline disk Onlining a Disk
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Adding a Disk to VxVM
Adding a Disk to VxVM
New disks must be set up on the system, placed under VxVM control, then added to a
dynamic disk group before they can be used for volumes. The Actions > Rescan task
scans for new devices.

When you place a disk under VxVM control, the disk is either encapsulated (if your
system supports encapsulation) or initialized. Encapsulation preserves any existing data
on the disk in volumes. Initialization destroys any existing data on the disk. (You can
encapsulate a disk to preserve the data.)

This task assigns a default VxVM disk name to the disk. Once the disk is under VxVM
control, you can use the Rename Disk task (Renaming a Disk) to change the VxVM disk
name (see “Renaming a Disk” on page 41).

Adding a Disk to a Dynamic Disk Group
Select the uninitialized disk to be placed under VxVM control.

1. Choose Actions > Add Disk to Dynamic Group. The Add Disk to Dynamic Group
wizard appears. Click Next to continue.

2. Complete the Add Disk to Dynamic Group wizard as follows:

Temporarily prevent access to a dynamic disk
group

Deporting Dynamic Disk Groups

Restore access to a deported dynamic disk
group

Importing Dynamic Disk Groups

Remove a disk from VxVM control Removing a Disk from a Dynamic Disk Group

Destroy a dynamic disk group (permanently) Destroying a Dynamic Disk Group

To perform this task … Use this procedure …

Dynamic disk group
name:

Select the dynamic disk group into which the disks will be added.

To add the disk(s) to a new dynamic disk group, select New
dynamic disk group , and enter the name of the new dynamic disk
group in the new dialog box.

Available disks:

Selected disks:

Move the disks to be added from Available disks to Selected disks.
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Scanning Disks
When you have provided all necessary information in the dialog box, click Next.

3. When the confirmation dialog box appears, click Yes to confirm your selection.

4. Click Finish to add the disk to the selected group.

5. If your system supports encapsulation, you now indicate whether the disk should be
initialized or encapsulated. (It is necessary to reboot the system before encapsulation
takes effect.)

Scanning Disks
When VxVM rescans disks, it scans all attached disks for disk configuration changes. It
also updates information on removable media, CD-ROM drives, basic volumes, file
systems, and drive letters.

Rescanning disks can take several minutes, depending on the number of hardware
devices installed.

- You should rescan disks when you remove disks from or add disks to a computer.

- From the Actions menu, select Rescan.

A dialog box comes up with the message “Getting hardware configuration. Please
wait.” The box also displays a progress bar showing the percentage of completion
for the rescan process.

Notes:

◆ The Add Disk to Dynamic Group task sets up disks for VxVM use. Disks must be
under VxVM control and in a dynamic disk group before they can be used to create
volumes.

◆ Disks must be online before they can be added to a dynamic disk group.

◆ Disks that already belong to a dynamic disk group cannot be added to another dynamic
disk group.

◆ Disks cannot be added to deported dynamic disk groups.
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Reserving a Disk
The Set Disk Usage feature can be used to designate a disk as a reserved disk. A reserved
disk is not considered part of the free space pool. If you perform a task that requires disk
space and you do not specify a disk, VxVM VEA allocates space from disks other than the
reserved disk.

▼ To reserve a disk

1. Follow the instructions in Adding a Disk to VxVM to place the disk under VxVM
control and in a dynamic disk group.

2. Select the disk to be reserved.

3. Choose Action > Set Disk Usage.

4. In the Set Disk Usage window, check the Reserve Disk option. Click OK.

(To cancel the disk reservation, open the Set Usage window, and uncheck the Reserve
Disk option.)

Notes:

◆ Before you select the Reserve Disk option, make sure the disk is under VxVM control
and in a dynamic disk group.

◆ A reserved disk is not available for general use.

◆ A reserved disk can only be used if you specify the reserved disk when you perform a
task.
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Renaming a Disk
The Rename Disk procedure changes the VxVM name assigned to a disk. The VxVM disk
name is the name given to the disk by the administrator or VxVM. This procedure does
not change the physical disk name (device name).

▼ To rename a disk

1. Select the disk to be renamed.

2. Choose Actions > Rename Disk.

3. Complete the Rename Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field, enter
the disk name to be changed.

New Name: Enter the new VxVM disk name.

Notes:

◆ The Rename Disk task requires the current disk name and a new disk name.

◆ The new disk name must be unique within the dynamic disk group.

◆ The disk must be in an imported dynamic disk group.
Chapter 3, Disk Tasks 41



Onlining a Disk
Onlining a Disk
The Online Disk procedure restores access to a disk that has been taken offline. The disk is
made accessible to VxVM again. After bringing a disk back online, the disk must be added
to a dynamic disk group before it can be used for volumes (see “Adding a Disk to VxVM,”
).

▼ To bring a disk online

1. Select the disk to be brought online.

2. Choose Actions > Online Disk.

3. Enter Yes to confirm disk offline.

Notes:

◆ When a disk is brought online, the disk is accessible again.

◆ Only disks in the offline state can be brought online.
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Mirroring a Disk
Mirroring a Disk
The Mirror Disk procedure mirrors (copies) all concatenated and striped volumes on a
disk onto another disk. You can use this procedure to mirror any disk that contains
concatenated or striped volumes.

▼ To mirror all volumes on a disk

1. Select the disk that contains the volumes to be mirrored onto another disk.

2. Choose Actions > Mirror Disk.

3. Enter the target disk name in the Mirror Disk. Click OK.

Notes:

- The Disk Mirror task requires a disk name.

- Only concatenated and striped volumes that reside on a single disk are mirrored onto the
other disk. Any RAID-5 or spanned volumes on the disk are ignored.

- Only disks in the same dynamic disk group can be used to create the new mirrors.

- The target disk must contain sufficient space to accommodate the mirrors.

- A new mirror cannot be created on a disk that already contains a copy of the volume.

- If no disks are assigned, VxVM uses available disk space to create the mirrors.
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Evacuating a Disk
This feature is similar to disk replacement, but it involves moving the contents of the
volumes on one dynamic disk to another dynamic disk. If a disk begins to fail, you can
attempt to protect/preserve the volumes on that disk by evacuating the disk. You can also
evacuate a disk if you plan to remove the disk or use the disk elsewhere. The other
dynamic disk does not have to be empty. The active redundant volumes on the
replacement disk will be synchoronized automatically.

To Evacuate a disk:

1. Right click on the disk you wish to evacuate.

2. Select Evacuate Disk.

3. The Evacuate Disk dialog will appear. Select either “Auto Assign destinations disks”
or “Manually assign destination disks”.

a. If you chose “Manually assign destination disks” add the destination disks by
clicking on the disk and clicking the Add button.

Remove disks from the selected destination disks by clicking on the disk and
clicking the Remove button.

4. Click the OK button to Evacuate the disk.

When you have provided all necessary information in the dialog box, click OK.

Notes:

◆ The contents of a disk must be evacuated/moved to another disk in the same dynamic
disk group with sufficient free space.

◆ If no target disk is specified, VxVM uses an available disk with sufficient free space.

◆ If the disk being evacuated contains part of a mirrored, striped, or RAID-5 volume, do not
move the contents of the disk to another disk containing a copy of the mirrored volume or
part of the striped/RAID-5 volume.
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Disconnecting a Disk
Disconnecting a Disk
The Disconnect Disk procedure disconnects a VxVM disk from its underlying physical
disk. You can disconnect a disk in preparation for the replacement of a physical disk. After
disconnecting a disk, you can use the Replacing Disk task to reconnect the disk (see
“Replacing Disk” on page 46).

▼ To disconnect a disk

1. Select the disk to be disconnected.

2. Choose Actions > Disconnect Disk.

3. Press OK to confirm disconnection.

Notes:

◆ Disconnecting a disk that contains volumes can result in loss of data or redundancy.
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Replacing Disk
Disks most often need replacing when they fail or start to behave strangely. A failed or
removed dynamic disk can be replaced, and active redundant volumes (mirrored and
RAID-5) on the replaced disk will be resynchronized automatically after disk
replacement.

Failed volumes on the replaced disk, however, will stay failed after disk replacement
because no valid data is available for copy. These underlying steps are handled
automatically when the disk replacement is performed using VxVM VEA.

Caution This operation alters the partitioning of a disk.

The disk replacement procedure can only be performed on a disk that has failed. VxVM VEA
indicates a failed disk by renaming it “Missing Disk”. If the disk replacement is successful,
the replacement disk will take on the attributes of the failed disk, including the Disk
Name.

Note This option is only available on Missing Disks.

To replace a disk drive

1. Right click on the missing disk.

2. Select Replace Disk.

A Dialog box appears containing a list of Empty Basic Disks.

3. Select the Disk you wish to use to replace the Missing Disk. To select a disk, click on
the corresponding circle next to the Disk or Disks.
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Replacing Disk
4. Click OK to perform the Disk Replacement.

Notes:

◆ The Replace Disk task requires the name of the disk to be replaced and the replacement
disk name.

◆ The disk to be replaced must be disconnected or removed from its dynamic disk group. If
the disk has not failed, remove the disk from its dynamic disk group before you replace
the disk.

◆ The new disk can be a disk in the free disk pool or an uninitialized disk. If the new disk is
uninitialized, the Replace Disk task places the disk under Volume Manager control.

◆ The new disk is placed in the dynamic disk group of the old disk.
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Recovering Volumes on a Disk
The Recover Disk procedure performs any necessary volume recovery operations on the
volumes on a given disk. The recovery operations depend on the types of volumes on the
disk and include starting disabled volumes, resynchronizing mirrors in mirrored
volumes, and resynchronizing parity in RAID-5 volumes. After successful recovery, the
volumes are again available for use.

Alert icons and the Alert Monitor window may provide clues to let you know that volume
recovery is needed.

▼ To recover all volumes on a disk

1. Select the disk containing the volumes to be recovered.

2. Choose Actions > Recover Disk.

3. Click OK to complete the recover disk procedure.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to
restore the volume from backup.
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Removing a Disk from a Dynamic Disk Group
You can remove a disk from a dynamic disk group if there are no volumes on the disk. If
volumes exist, you must delete them before you can revert the disk. Disks shown in
Volume Manager to be Unreadable as well as Foreign can be removed, but doing so
causes you to lose all existing data on the disk that is removed from the group. If a disk
has failed and is marked as Missing, you can also remove it from the dynamic disk group.

To remove a disk from a dynamic disk group, use the Remove Disk from Dynamic Disk
Group command.

Note You cannot remove the last disk from a disk group.

The steps for removing a disk from a dynamic disk group are as follows:

1. Right-click on the selected disk or on the Dynamic Disk Group and select Remove
Disk from Dynamic Disk Group.

2. The first screen of the Remove Disk wizard appears. Click Next to continue.

3. Make sure the proper disk or disks that you want to remove are showing in the right
pane of the window and click Next to continue.

The Remove Disk from Dynamic Disk Group procedure removes the disk from VxVM
control. If the disk to be removed contains volumes, you must evacuate the disk before
you remove the disk.

When you have provided all necessary information in the dialog box, click OK.

Notes:

◆ If the disk contains a volume that has only one mirror and either has a mounted file
system or is used as a swap area, you must evacuate the disk before you remove it.

◆ When a disk is removed from a dynamic disk group or VxVM control, the disk cannot be
accessed.

◆ A disk that is in use (that is., contains volumes) must not be removed. Removing a disk
with volumes can result in loss of data or data redundancy. If volumes exist on the disk to
be removed, use the Evacuate Disks task to move the volumes to another disk.

◆ The last disk in a dynamic disk group cannot be removed. To remove the last disk in a
dynamic disk group, the dynamic disk group must be destroyed. The last disk in the
rootdg dynamic disk group can never be removed.

◆ Any non-redundant volumes on the removed disk become disabled.
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Forcing Initialization of a Disk

Caution Forcing the initialization or reinitialization of a disk can result in data loss.

The Initialize Disk procedure forces the initialization of a disk. This task is intended for
use in troubleshooting disks that have already been placed under VxVM control. To
initialize a disk for VxVM use, use the Add Disks task instead (see Adding a Disk to
VxVM).

▼ To (re)initialize a disk

1. Select the disk to be initialized.

2. Choose Actions > Initialize Disk.

3. Complete the Initialize Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field, enter
the disk name.

Notes:

◆ The Initialize Disk task requires a disk name.

◆ The Initialize Disk task forces the (re)initialization of a disk and can result in data loss.

◆ The Initialize Disk task overwrites existing disk header and configuration information
on the disk. Any volume copies or regions located on the disk are not accessible after you
reinitialize the disk.
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Viewing Disk Properties
The Disk Properties window contains detailed information about the selected disk. The
following information is displayed.

Category Description

Disk Name of disk in VxVM.

Group Name Name of dynamic disk group associated with the disk.

Type Field is Dynamic.

Status Fields are Imported and Deported.

Capacity Size in megabytes or gigabytes

Unallocated Space Amount of free space that is available to create a partition or
volume.

Spare Indicates whether or not the disk has been designated as a hot
spare.

Reserved Indicates whether the disk is reserved Not to be used as a
dynamic disk.

No Hot Use Indicates whether the disk is not to be used as a hot spare or to
receive volumes from the Hot Relocation procedure.
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Disabling a Controller
The controller Disable procedure disables I/O to a controller.

Caution If your system supports the Dynamic Multipathing (DMP) feature; it should be
noted that performing the controller Disable procedure will prevent DMP from
accessing the paths associated with a controller.

You can disable access to a controller in preparation for hardware maintenance.

▼ To disable a controller

1. Select the controller to be disabled.

2. Choose Actions > Disable.

3. Complete the Disable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Options ◆ To disable all enclosures (disk arrays) associated with this
controller, select All Enclosures.

◆ To disable specific enclosures associated with this controller,
enter the enclosure names in the Selected Enclosures field.

Notes:

◆ For systems that support rootability, the specified controller cannot contain the last
enabled path to the root disk.
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Enabling a Controller
The controller Enable procedure enables I/O to a controller. (If your system supports the
DMP feature, and if DMP is enabled, then the Enable procedure also restores access to the
paths associated with a controller.)

▼ To enable a controller

1. Select the controller to be enabled.

2. Choose Actions > Enable.

3. Complete the Enable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Options ◆ To enable all enclosures (disk arrays) associated with this
controller, select All Enclosures.

◆ To enable specific enclosures associated with this controller,
enter the enclosure names in the Selected Enclosures field.
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Renaming an Enclosure
The Enclosure Rename procedure changes the name of an enclosure (disk array).

▼ To rename an enclosure

1. Select the enclosure to be renamed.

2. Choose Actions > Enclosure Rename.

3. Complete the Rename Enclosure dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Enclosure Name: If the correct enclosure name does not already display in this field,
enter the name.

New Name: Enter the new enclosure name.

Notes:

◆ The Enclosure Rename task requires the current enclosure name and a new enclosure
name.

◆ The new enclosure name must be unique within the dynamic disk group.
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Creating a Dynamic Disk Group
The New Dynamic Disk Group procedure creates an additional dynamic disk group.
Disks must be placed in dynamic disk groups before they can be used by VxVM. The
default disk group (rootdg) is usually created during VxVM installation and always
exists on a system running VxVM. You can create additional dynamic disk groups to
organize your disks into logical sets of disks.

When you place a disk under VxVM control, the disk is initialized. Initialization destroys
any existing data on the disk. (If your system supports encapsulation, you can use
encapsulation to preserve disk data.)

The steps for creating a new dynamic disk group are:

1. Select the Disk Groups folder, or select a disk.

2. Select Actions > New Dynamic Disk Group.

The New Dynamic Disk Group wizard screen appears.

3. Click Next to continue. A new screen appears.

4. Enter a name for the dynamic disk group and select which disks you want to include
in the group. Make sure the disks you want to include are in the right pane of the
window, and click Next.

When you have provided all necessary information in the dialog box, click OK.

5. The next screen confirms the disks you have selected. Choose Next to continue if you
are satisfied with the disk selection. If you are not satisfied, you can click the Back
button to go back to the previous screen in order to modify your disk choices.

6. Normally, you would add all the disks you want in the group at this point. You can
always add more disks later with the Add Disk to Dynamic Disk Group command.

Indicate whether the disk should be initialized or encapsulated. If you initialize the
disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any
existing data will be preserved in volumes.

7. If you chose to encapsulate the disk, reboot the system.
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Notes:

◆ The New Dynamic Disk Group task requires a dynamic disk group name and the
name of at least one disk.

◆ The dynamic disk group name must be unique.

◆ The new dynamic disk group must contain at least one disk.

◆ Only disks that are online and do not belong to a dynamic disk group can be used to
create a dynamic disk group.

◆ The Volume Manager disk name must be unique within the dynamic disk group.

◆ If multiple disks are specified in the Disk Device(s) field and only one disk name is
specified in Disk Name(s) field, VxVM appends numbers to the disk name so that each
disk name is unique within its dynamic disk group.
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Upgrading a Dynamic Disk Group Version

Note This procedure is not to be confused with upgrading to a dynamic disk.

The Dynamic Disk Group Upgrade procedure upgrades a dynamic disk group to the
dynamic disk group version that is compatible with the current VxVM release. Some new
features and tasks only work on dynamic disk groups with the current dynamic disk
group version, so you must upgrade existing dynamic disk groups before you perform
these tasks. However, after you upgrade a dynamic disk group, you cannot access that
dynamic disk group from machines running earlier releases of VxVM that do not support
a higher current disk group version.

To determine if a dynamic disk group needs to be upgraded, select the dynamic disk
group and open the Disk Group Properties window. The Version field of the Properties
window indicates whether the dynamic disk group has been upgraded to the current
dynamic disk group version.

▼ To upgrade a dynamic disk group

1. Select the disk group to be upgraded to the current version.

2. Choose Actions > Upgrade Dynamic Disk Group Version).

3. Confirm the upgrade by clicking OK.

Notes:

◆ If you have dynamic disk groups created with earlier releases of VxVM, these must be
upgraded before they can take advantage of new features and tasks in the current release.

◆ If a dynamic disk group is upgraded to the current dynamic disk group version, you
cannot import that dynamic disk group on a machine running an earlier VxVM release.
Disk groups that must remain backward compatible with earlier releases of VxVM must
not be upgraded.
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Renaming Dynamic Disk Groups
The Rename Dynamic Disk Group procedure changes the name of an existing dynamic
disk group. You can rename a dynamic disk group to provide a more appropriate name or
to avoid a name conflict with a dynamic disk group to be imported.

▼ To rename a dynamic disk group

1. Select the dynamic disk group to be renamed.

2. Choose Actions > Rename Dynamic Disks Group.

3. Complete the Rename Dynamic Disk Group dialog box.

4. When you have provided all necessary information in the dialog box, click OK.

Notes:

◆ The Rename Dynamic Disk Group task requires the current dynamic disk group
name and a new dynamic disk group name.

◆ The new dynamic disk group name must be unique.

◆ The Rename Dynamic Disk Group task deports and re-imports the dynamic disk
group. If volumes in the dynamic disk group are in use, the deport fails and the dynamic
disk group is not renamed.

◆ The Rename Dynamic Disk Group task updates the file system table file, if necessary.

◆ If the dynamic disk group contains volumes with mounted file systems, you may need to
unmount the file systems.
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Deporting Dynamic Disk Groups
The Deport Dynamic Disk Group procedure makes a dynamic disk group and its
volumes inaccessible. Once deported, a dynamic disk group cannot be used until it is
imported. You can deport a dynamic disk group to make the dynamic disk group
temporarily unavailable.

While a dynamic disk group is deported, you cannot remove and reuse any of its disks. To
remove disks, you must import the dynamic disk group and then either destroy the
dynamic disk group (to remove all of its disks) or remove selected disks from the dynamic
disk group.

▼ To deport a dynamic disk group

1. Select the dynamic disk group to be deported.

2. Choose Actions > Deport Dynamic Disk Group.

3. Click OK to complete the deportation.

Notes:

◆ The Deport Dynamic Disk Group task requires a dynamic disk group name.

◆ A deported dynamic disk group cannot be accessed. To access a deported dynamic disk
group, the dynamic disk group must be imported.

◆ The rootdg disk group cannot be deported.

◆ A dynamic disk group cannot be deported if any volumes in that dynamic disk group are
in use (open).

◆ When a dynamic disk group is deported, the host ID stored on all disks in the dynamic
disk group is cleared and the dynamic disk group is not re-imported automatically when
the system is rebooted. However, if you specify a host in New Host option, the specified
host imports the dynamic disk group at reboot.
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Importing Dynamic Disk Groups
The Import Dynamic Disk Group procedure makes a deported (inaccessible) dynamic
disk group and its volumes accessible again. To import a deported dynamic disk group,
you must know the former name of the dynamic disk group, and this name must not be in
use. In addition, at least one disk name formerly assigned to the deported dynamic disk
group must not be in use.

▼ To import a dynamic disk group

1. Select the appropriate host machine node.

2. Choose Actions > Import Dynamic Disk Group.

3. Complete the Import Dynamic Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

New Name: Enter a new dynamic disk group name in the New Name field. to
change the name of the dynamic disk group at import.

Clear host ID Select Clear host ID to clear the existing host ID stamp on all
disks in the dynamic disk group at import, Do not use this option if
another host is using any disks in the dynamic disk group.

Force Select Force to force the dynamic disk group import when the
host cannot access all disks in the dynamic disk group This option
can be used to import a dynamic disk group that contains a failed
disk, but can lead to dynamic disk group inconsistency if all disks
are still usable.

Notes:

◆ Only deported dynamic disk groups can be imported.

◆ A deported dynamic disk group cannot be imported if another dynamic disk group with
the same name has been created since the dynamic disk group was deported.

◆ When a dynamic disk group is imported, the system stamps its host ID on all disks in the
dynamic disk group. A dynamic disk group import fails if one of the disks is stamped
with a host ID that does not match the others. This ensures that dual-ported disks cannot
be managed (and possibly corrupted) by two systems at the same time. If you are sure that
the dynamic disk group is not in use by another host, you can clear the host IDs and
import the dynamic disk group by selecting the Clear host ID option.
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Recovering Volumes in Dynamic Disk Groups
The Recover Dynamic Disk Group procedure performs any necessary volume recovery
operations on the volumes in a given dynamic disk group. The recovery operations
depend on the types of volumes in the group and include starting disabled volumes,
resynchronizing mirrors in mirrored volumes, and resynchronizing parity in RAID-5
volumes. After successful recovery, the volumes are again available for use.

Alert icons and the Alert Monitor window may provide clues to let you know that volume
recovery is needed.

▼ To recover all volumes in a dynamic disk group

1. Select the dynamic disk group containing the volumes to be recovered.

2. Enter the dynamic disk group name if the correct dynamic disk group name is not
shown in the dialog box.

3. Choose Actions > Recover Dynamic Disk Group.

4. Click OK.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to
restore the volume from backup.
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Commands for Hot Relocation
The Hot Spare and Hot Relocation procedures enable a system to automatically react to
I/O failures on redundant (mirrored or RAID-5) volumes, and to restore redundancy and
access to those volumes. The following commands can be used to perform relocation
tasks:

◆ Undoing Hot Relocation

◆ Clearing Relocation Information for Dynamic Disk Groups

◆ Customizing Disks for Hot Relocation

Note The Hot Relocation and Hot Spare operations are only performed for redundant
(mirrored or RAID-5) subdisks on a failed disk. Non-redundant subdisks on a failed
disk are not relocated, but the system administrator is notified of their failure.

About Hot Spare and Hot Relocation
One or more disks in each dynamic disk group can be designated as hot spares by using
the “set disk usage” command. These hot spare disks provide a location where data can be
moved from failed disks or volumes.

In Hot Spare mode, all subdisks containing redundant volumes will be moved together
from a failed disk to a spare disk. In order for the Hot Spare operation to occur, there must
be enough free space on the spare disk for all the redundant volumes from the original
disk.

When a disk fails, hot relocation automatically moves all subdisks containing redundant
volumes from the failed disk to hot spare disks. If no disks have been designated as spares
or there is not enough spare disk space, a combination of spare space and free space is
used. Depending on available disk space, the subdisks are not always all moved to the
same disk, but may be scattered within the dynamic disk group.

When a partial disk failure occurs (that is, a failure affecting only some subdisks on a
disk), redundant data on the failed portion of the disk is relocated and the existing
volumes comprised of the unaffected portions of the disk remain accessible.

When selecting space for relocation, hot relocation preserves the redundancy
characteristics of the Volume Manager object that the relocated subdisk belongs to. For
example, hot relocation ensures that subdisks from a failed plex are not relocated to a disk
containing a mirror of the failed plex. If redundancy cannot be preserved using any
available spare disks or free space, hot-relocation does not take place. If relocation is not
possible, the system administrator is notified and no further action is taken.
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Undoing Hot Relocation
When hot relocation takes place, the failed subdisk is removed from the configuration
database and Volume Manager takes precautions to ensure that the disk space used by the
failed subdisk is not recycled as free space.

Undoing Hot Relocation
The Undo Hot Relocation procedure relocates subdisks back to their repaired original
disk or replacement disk and restores a system to its original configuration. If hot
relocation scattered subdisks from a failed disk to several disks within a dynamic disk
group, the undo hot relocation command will summon all of them back to a single disk
without you having to find and move each one individually.

Note The Undo Hot Relocation procedure is only available after a hot relocation or hot
sparing procedure has occurred.

1. Right-click on the dynamic disk group that contains the hot relocated volumes.

2. Select Actions > Undo Hot Relocation.

A window appears showing the disks that failed and from which subdisks were hot
relocated.

3. Select the disks you wish to unrelocate by clicking on the corresponding circle in the
column under the check mark. The hot relocated subdisks will return to this disk.

4. Click OK.
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Clearing Relocation Information for Dynamic Disk Groups
The Clear Hot Relocation Info command deletes the information that describes the
original location of any subdisks that have been hot relocated. Use this command if you
do not plan to move the subdisks back to their original configuration.

1. Right-click on a disk group that contains hot relocated subdisks.

2. Select Actions > Clear Hot Relocation Info.

3. A dialog box will appear asking if you are sure you want to clear the relocation
information on the dynamic disk group. Click Yes if you want to clear the hot
relocation information.

Caution Once you clear the Hot Relocation Information, you will not be able to perform
an Undo Hot Relocation on that dynamic disk group.

Customizing Disks for Hot Relocation
You can customize your disks in the following ways:

◆ Specify individual disks to act as Hot Spares

◆ Prevent a disk from being used for Hot Relocation or Hot Spare

◆ Mark a disk as Reserved

Each disk must be customized individually, you cannot set disk usage for a group of
disks:

Notes:

◆ The Clear the Relocation Info procedure requires the name of the original disk (even
if an alternate disk is specified).

◆ When a disk fails, the hot-relocation feature attempts to move subdisks from the failed
disk to other disks. The Clear the Relocation Info procedure can be used to return the
relocated subdisks to their original disk locations after the original disk is repaired or
replaced.

◆ It is not possible to return relocated subdisks to their original disks after their dynamic
disk group relocation information has been cleared with the Clear the Relocation Info
task.
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Customizing Disks for Hot Relocation
1. Click on the disk to be customized.

2. Choose Actions > Set Disk Usage.

A window appears offering three options. The default is no options are selected.

The Reserved disk option allows a disk to be marked so that it will not be used in
automatic selection operations. For example, if a disk is marked as reserved, during
the create new volume wizard using the default option to auto select disks, the
volume would not be created on the reserved disk. However, if you wish to create a
volume on that specific disk, you could choose the option to manually select the disks
for the new volume and then select that disk.

3. A disk can be marked for use for spare only, or for neither hot spare or hot relocation.
When you are satisfied with your selection, click OK.

You can review the settings for all your disks by selecting the Disks folder in the tree pane
and then viewing Disks tab in the right pane. The settings for each disk are listed in the
Spare, Reserved, and Hot Use columns.
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Destroying a Dynamic Disk Group

Caution Destroying a dynamic disk group can result in data loss.

The Destroy Dynamic Disk Group procedure permanently removes a dynamic disk
group from VxVM control. This procedure also reinitializes all of the disks in the dynamic
disk group as empty disks and places them in the free disk pool for reuse.

Destroy a dynamic disk group only if you are sure that you no longer need the volumes
and data in the dynamic disk group. Since the last disk in a dynamic disk group cannot be
removed, destroying a dynamic disk group is useful for freeing the last disk in a dynamic
disk group for reuse.

▼ To destroy a dynamic disk group

1. Right-click on the appropriate host machine node.

2. Choose Destroy Dynamic Disk Group.

3. Complete the Destroy Dynamic Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Enter the name of the dynamic disk group to be destroyed.

Notes:

◆ Use the Destroy Dynamic Disk Group task with caution. Destroying a dynamic disk
group permanently removes the dynamic disk group from VxVM control and can result
in data loss.

◆ When a dynamic disk group is destroyed, its disks are returned to the free disk pool. Any
volumes in the dynamic disk group are removed.

◆ The rootdg disk group cannot be destroyed.

◆ A dynamic disk group cannot be destroyed if any volumes in that dynamic disk group are
in use (open) and/or contain mounted file systems.
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Moving Objects Between Dynamic Disk Groups
The following procedure moves a self-contained set of VxVM VEA objects between
imported dynamic disk groups. This operation is performed on VxVM VEA objects such
as disks or top-level volumes, and includes all component objects such as sub-volumes,
plexes and subdisks.

▼ To perform a dynamic disk group move operation:

1. Right-click on the dynamic disk group to be moved.

2. Select Move Dynamic Disk Groups.

3. Complete the Move Dynamic Disk Group Dialog Box as follows:

Disk Group Name: Enter the name of the dynamic disk group from which objects are
to be moved or click Browse to select the dynamic disk group.

Target Disk Group
Name:

Enter the name of the dynamic disk group into which objects are to
be moved.

Select Objects to move: Enter the objects to be moved.

◆ To select volumes to move, click Move dynamic disk group
by volumes. To select all of the listed volumes, click Add All.

◆ To select disks to move, click Move dynamic disk group by
disks.

◆ Click on OK.

Expand: Click Expand to specify that the objects to be moved should
include all other disks that contain subdisks that are associated
with the specified objects or with objects that they contain. For
example, if you specify that disk01 should be moved and disk01
contains vol1 which is also located on disk02, then by using the
Expand button, you ensure that disk02 will also be moved.

Show Dependencies: Click Show Dependencies to display the objects affected
by the move.
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Notes:

◆ Before moving volumes between dynamic disk groups, stop all applications that are
accessing the volumes, and unmount all file systems that are configured in the volumes.

◆ The objects to be moved must be self-contained, meaning that the disks that are moved
must not contain any other objects that are not intended for the move.

◆ This operation fails if it would remove all the disks from the source dynamic disk group.

◆ Volume states are preserved across the move.

◆ The reconfiguration must involve an integral number of physical disks.

◆ Objects to be moved must not contain open volumes.

◆ Data change objects (DCOs) and snap objects that have been dissociated by Persistent
FastResync cannot be moved between dynamic disk groups.

◆ If your system supports VERITAS Volume Replicator (VVR), then it should be noted that
VVR objects cannot be moved between dynamic disk groups.

◆ For a dynamic disk group move to succeed, the source dynamic disk group must contain
at least one disk that can store copies of the configuration database after the move.

◆ For a dynamic disk group move to succeed, the configuration database in the target
dynamic disk group must be able to accommodate information about all the objects in the
enlarged dynamic disk group.

◆ The operation can only be performed on the master node of a cluster if either the source
dynamic disk group or the target dynamic disk group is shared.
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Splitting A Dynamic Disk Group
The dynamic disk group split operation involves splitting the contents of an imported
dynamic disk group and creating a new dynamic disk group (the Target dynamic disk
group) with the objects defined in the dialog box. This operation is performed on VxVM
VEA objects such as disks or top-level volumes, and includes all component objects such
as sub-volumes, plexes and subdisks.

▼ To perform a dynamic disk group split operation:

1. Select the dynamic disk group to be split.

2. Select Actions > Split Dynamic Disk Groups.

3. Complete the Split Dynamic Disk Group Dialog Box as follows:

Disk Group Name: Enter the name of the dynamic disk group from which objects are
to be split.

Target Disk Group
Name:

Enter the name of the target dynamic disk group which will consist
of the objects to be split.

Select Objects to move: ◆ To select volumes to move, click the checkbox Split dynamic
disk group by volume, and choose from the displayed list.

◆ To select disks to move, click the checkbox Split dynamic
disk group by disk, and choose from the displayed list.

Expand: Click Expand to specify that the objects to be split should include
all other disks that contain subdisks that are associated with the
specified objects or with objects that they contain. For example, if
you specify that disk01 should be split off and disk01 contains vol1
which is also located on disk02, then by using the Expand button,
you ensure that disk02 will also be split off.
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Notes:

◆ Before carrying out the split operation, stop all applications that are accessing the
volumes, and unmount all file systems that are configured in the volumes.

◆ The objects to be split off must be self-contained, meaning that the disks that are split
must not contain any other objects that are not intended for the move.

◆ This operation fails if it would remove all the disks from the source dynamic disk group.

◆ Volume states are preserved across the split.

◆ An existing deported dynamic disk group is destroyed if it has the same name as the
target dynamic disk group.

◆ The reconfiguration must involve an integral number of physical disks.

◆ Objects to be split off must not contain open volumes.

◆ Data change objects (DCOs) and snap objects that have been dissociated by Persistent
FastResync cannot be moved between dynamic disk groups.

◆ If your system supports VVR, then it should be noted that VVR objects cannot be moved
between dynamic disk groups.
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Joining Dynamic Disk Groups
This procedure joins two dynamic disk groups by moving all VxVM objects from an
imported source dynamic disk group to an imported target dynamic disk group. The
source dynamic disk group is removed when the join is complete. This operation is
performed on VxVM VEA objects such as disks or top-level volumes, and includes all
component objects such as sub-volumes, plexes and subdisks.

▼ To perform a dynamic disk group join operation:

1. Select the dynamic disk group to be joined.

2. Select Actions > Join Dynamic Disk Group.

3. Use the source dynamic disk group name shown or replace it with one from the
pull-down menu.

4. Use the target dynamic disk group name shown, or replace it with one from the
pull-down menu.

5. Click OK.

Note:

◆ Before performing a join operation, stop all applications that are accessing the volumes,
and unmount all file systems that are configured in the volumes.

◆ The reconfiguration must involve an integral number of physical disks.

◆ Objects to be joined must not contain open volumes.

◆ Data change objects (DCOs) and snap objects that have been dissociated by Persistent
FastResync cannot be moved between dynamic disk groups.

◆ If your system supports VVR, then it should be noted that VVR objects cannot be moved
between dynamic disk groups.

◆ For a dynamic disk group join to succeed, both the source and target dynamic disk groups
must contain at least one disk that can store copies of the configuration database after the
split.
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Activating Dynamic Disk Groups
If supported on your platform, the Disk Groups Activation procedure sets the activation
mode for a dynamic disk group. The dynamic disk group activation mode controls read
and write access to volumes in the specified dynamic disk group.

▼ To activate a dynamic disk group

1. Select the dynamic disk group to be activated.

2. Choose Disk Groups > Activation.

3. Complete the Activate Disk Group dialog box as follows:

Disk Group Name: Enter the name of the dynamic disk group to be activated.

Activation Mode: Select one of the following dynamic disk group activation modes:

◆ To disallow read and write access for volumes in the dynamic
disk group, select Off.

◆ To allow read and write access for volumes in the dynamic disk
group, select Read Write.

◆ To allow read only access for volumes in the dynamic disk
group, select Read Only.

If your system supports a cluster environment, you can select one
of the following additional options for shared dynamic disk
groups:

◆ To give the current node exclusive write access for volumes in
the shared dynamic disk group, select Exclusive Write. No
other nodes in the cluster can have write access to the dynamic
disk group.

◆ To give the current node write access for volumes in the shared
dynamic disk group, select Shared Write. Other nodes in the
cluster can share write access to this dynamic disk group.

◆ To give the current node read access for volumes in the shared
dynamic disk group, select Shared Read. The current node
cannot have write access to the dynamic disk group, but other
nodes in the cluster may have write access.
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When you have provided all necessary information in the dialog box, click OK.

Notes:

◆ The Disk Groups Activation task requires a dynamic disk group name.

◆ In a cluster environment, you must specify the dynamic disk group activation mode on a
per-node basis.

◆ If your system supports a cluster environment, then the Exclusive Write, Shared
Write, and Shared Read modes are also applicable. The Read Write mode is not
available for shared dynamic disk groups.

◆ For shared dynamic disk groups, the default activation mode is Off. For non-shared
dynamic disk groups, the default activation mode is Read Write.

◆ Disk group activation settings are not persistent, so you may need to reset the activation
mode after rebooting the machine.
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Viewing Dynamic Disk Group Properties
The Disk Group Properties window contains detailed information about the selected
dynamic disk group.

◆ To view the properties of a dynamic disk group, select the dynamic disk group and
then choose Properties from the popup menu.

Setting Disk Usage
This command is used to exclude a disk from certain operations by marking it as a spare,
excluding it from Hot Relocation, or marking it as a reserved disk.

To set disk usage:

1. Right click on the disk you wish to modify.

2. Select Set Disk Usage.

3. The Set Disk Usage dialog will appear. Select any options you wish to implement.

4. Click Ok.
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 4

VxVM Volumes tasks include:

- Creating a Dynamic Volume

- Resizing a Dynamic Volume

- Renaming a Volume

- Changing a Volume Layout

- Adding a Mirror to a Volume

- Adding a Log to a Volume

- Stopping and Restarting a Volume

- Using the Volume Snapshot Feature

- Recovering a Volume

- Removing a Mirror From a Volume

- Removing a Log From a Volume

- Deleting a Volume

- Associating a Plex

- Moving, Splitting, and Joining Subdisks

- Viewing Volume Properties
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Volume Task Roadmap
The following table provides a summary of common VxVM volume tasks.

To perform this task … Use this procedure …

Volume Setup Tasks:

Create new volumes Creating a Dynamic Volume

Precautionary Tasks:

Mirror (copy) volumes onto other disks for
redundancy

Adding a Mirror to a Volume

Create mirrored volumes Creating a Dynamic Volume

Add a log to a volume Adding a Log to a Volume

Maintenance Tasks:

Add space to volumes Resizing a Dynamic Volume

Change volume layouts Changing a Volume Layout

Add mirrors to volumes that should be
redundant

Adding a Mirror to a Volume

Create a snapshot copy of a volume for backup Using the Volume Snapshot Feature

Merge a snapshot copy of a volume with the
original volume

Merging a Snapshot Volume (Volume
Snapback)

Permanently break the association between a
snapshot and its original volume

Dissociating a Snapshot Volume (Volume Snap
Clear)

Abort the taking of a snapshot Aborting a Snapshot

Move portions of volumes to other disk space Moving a Subdisk

Recovery Tasks:

Attempt to recover a volume Recovering a Volume

Attempt to recover all volumes on a disk Recovering Volumes on a Disk (see Chapter 3)

Attempt to recover all volumes in a disk group Recovering Volumes in Dynamic Disk Groups
(see Chapter 3)

Prepare to restore a volume from backup Aborting a Snapshot
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Other Tasks:

Change a volume name Renaming a Volume

Restore access to a stopped volume Recovering a Volume

Remove a mirror from a volume Removing a Mirror From a Volume

Remove a DRL log from a volume Removing a Log From a Volume

Remove a RAID-5 log from a volume Removing a Log From a Volume

Remove a volume Deleting a Volume

Starting a volume Recovering a Volume

Temporarily prevent access to a volume Stopping and Restarting a Volume

Temporarily prevent access to a volume mirror Removing a Mirror From a Volume

To perform this task … Use this procedure …
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VxVM Volumes
VxVM uses logical volumes to organize and manage disk space. A volume is made up of
portions of one or more physical disks, so it does not have the physical limitations of a
physical disk.

A volume can provide greater capacity and better availability and performance than a
single physical disk. A volume can be extended (grown) across multiple disks to increase
capacity, mirrored (copied) on another disk to provide data redundancy, and/or striped
across multiple disks to improve I/O performance.

You can use VxVM to create the following types of volumes:

◆ Concatenated Volume

A concatenated volume is made up of one or more disk regions that are linked
together (concatenated) in a linear fashion. A concatenated volume can consist of disk
regions on multiple disks; a concatenated volume that extends across two or more
disks is also known as a spanned volume.

Note Data in this type of volume cannot be recovered if the underlying disk fails.
However, a concatenated volume can be mirrored (copied) onto other disks to
protect its data against disk failure.

◆ Striped Volume

Striped volume data is interleaved (striped) across two or more physical disks.
Striped volume data is spread across the disks alternately and evenly in small,
equal-sized portions of data called stripe units. Striping improves performance.

Note Data in this type of volume cannot be recovered if one of the underlying disks fails.
However, a striped volume can be mirrored (copied) onto other disks to protect its
data against disk failure.

◆ RAID-5 Volume

RAID-5 volume data is interleaved (striped) across three or more physical disks.
Within each stripe across the set of disks, the data on one of the disks is parity data. If
one of the physical disks fails, the parity data can be used to reconstruct and recover
the lost data.

Note RAID-5 volumes cannot be mirrored.
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◆ Mirrored Volume

Volumes with concatenated or striped layouts can be mirrored to increase data
availability. All of the data in a mirrored volume is duplicated on at least one other
physical disk. If one of the disks fails, the data can still be accessed from one of the
remaining disks.

The plexes in a mirrored volume typically have the same layout, but a volume can
consist of plexes with different layouts. A mirrored volume has a “mixed” layout if
the plexes in the volume have different layouts.

◆ Layered Volume

A layered volume is built on one or more other volumes. The underlying volumes are
typically mirrored. In layered volumes, mirroring is done at a lower level and with
smaller granularity than with non-layered volumes, so each mirror covers a relatively
small storage region.

Layered volumes tolerate disk failure better than non-layered volumes and provide
improved data redundancy. If a disk in a layered volume fails, only a portion of the
redundancy is lost and recovery time is usually quicker than it would be for a
non-layered volume. Layered volumes also reduce the chance that two disk failures
will result in lost data.

The underlying volumes in a layered volume are used exclusively by VxVM and are
not intended for user manipulation.

With VxVM, you can create the following types of layered volumes:

- Concatenated Pro Volume

A concatenated pro volume is a layered volume that concatenates several
underlying mirror volumes.

- Striped Pro Volume

A striped pro volume is a layered volume that stripes several underlying mirror
volumes.
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The following table summarizes the advantages and disadvantages of each volume
layout.

Layout Comparison

Layout Advantages Disadvantages

Concatenated - The volume can consist of disk
regions that are not adjacent.

- The volume can span multiple
disks. A spanned volume can
have a greater capacity than a
single disk.

- The volume can be mirrored to
protect data against disk failure
and reduce the risk of data loss.

- There is a risk of data loss if the
volume is not mirrored.

- Spanning a volume across multiple
disks increases the chance that a
disk failure will result in the failure
of the volume.

- Concatenation does not improve
I/O performance.

Striped - Striping provides improved
read and write performance.

- Striping can help to balance the
I/O load from multi-user
applications across multiple
disks.

- The volume can be mirrored to
protect data against disk failure.

- There is a risk of data loss if the
volume is not mirrored.

- Striping a volume across multiple
disks increases the chance that a
disk failure will result in the failure
of the volume.

- A striped volume requires at least
two disks.

RAID-5 - RAID-5 provides protection
against disk failure and reduces
the risk of data loss.

- RAID-5 provides data
redundancy by storing parity (a
calculated value) on the disks. If
a disk fails, the parity is used to
reconstruct the missing data.

- RAID-5 requires less storage
space than mirroring.

- RAID-5 provides improved read
performance.

- RAID-5 provides relatively slow
write performance.

- RAID-5 volumes cannot be
mirrored.

- A RAID-5 volume requires at least
three disks. If logging is enabled, a
RAID-5 volume requires at least
four disks.

- A RAID-5 volume cannot survive
multiple disk failures. However,
optional RAID-5 logs reduce this
risk.

- If one of the volume disks is
inaccessible, performance is
degraded.
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Mirrored - Mirroring provides protection
against disk failure and reduces
the risk of data loss.

- Mirroring provides data
redundancy by maintaining
multiple complete copies of
volume data on different disks.

- Mirroring provides improved
read performance.

- A mirrored volume requires extra
disk space. Each mirror requires
enough disk space to contain a
complete copy of the volume.

Concatenated Pro - The volume is layered, and
concatenates several underlying
mirror volumes. This provides
improved data redundancy and
reduces the impact of disk
failures. This type of volume is
also known as a
concatenated-mirror volume.

- Recovery time is quicker than
with regular concatenated
volumes that are mirrored.

- The volume can consist of disk
regions that are not adjacent.

- The volume can span multiple
disks. A spanned volume can
have a greater capacity than a
single disk.

- A concatenated pro volume
requires at least two disks.

- Concatenation does not improve
I/O performance.

- Layered volumes consist of more
VxVM objects than non-layered
volumes and are likely to fill up the
disk group configuration database
sooner. When the configuration
database is full, you cannot create
more volumes in the disk group.

Striped Pro - The volume is layered, and
stripes several underlying
mirror volumes. This provides
improved data redundancy and
reduces the impact of disk
failures. This type of volume is
also known as a striped-mirror
volume.

- Recovery time is quicker than
with regular striped volumes
that are mirrored.

- Striping provides improved
read and write performance.

- Striping can help to balance the
I/O load from multi-user
applications across multiple
disks.

- A striped pro volume requires at
least four disks.

- Layered volumes consist of more
VxVM objects than non-layered
volumes and are likely to fill up the
disk group configuration database
sooner. When the configuration
database is full, you cannot create
more volumes in the disk group.

Layout Comparison

Layout Advantages Disadvantages
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Note The total volume size you indicate for the volume in the Create Volume Wizard is
the usable size for storing the data. Depending on the layout type, the volume can
take more space on the disk. The size shown in the Wizard for simple, striped, and
spanned volumes is the actual volume size on the disk. A RAID-5 volume requires
additional space for parity information, and a mirrored volume is a multiple of the
space taken by the original plex of the volume. The Wizard provides a Query Max
Size button to determine the size of the volume. Again, this is the usable size of the
volume rather than the actual size taken by the volume on the disk.
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Creating a Dynamic Volume
You can create the following dynamic volumes:

◆ Concatenated (Concatenated and Concatenated Pro)

◆ Striped (Striped and Striped Pro)

◆ RAID-5

◆ Mirrored

▼ To create a dynamic volume

1. Right-click a dynamic disk group in the tree view the right pane, and select New
Volume from the context menu. The Create Volume wizard appears.

You can also select the command from the Actions menu or click the New Volume tool
on the toolbar (the third tool from the left side of the toolbar).

2. Click Next to continue.

The screen for selecting attributes comes up next. Your screen should be similar to the
sample screen that follows.
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3. If necessary, select the dynamic Group name for the volume from the pull-down list.

4. Type in the Volume Name. This is a Volume Manager-specific name that is used in
some Volume Manager commands. It is different from the volume label for the file
system.

5. Specify the volume size, or select Maxsize.

The Maxsize button works differently, depending on whether you have a disk
selected.

- If you do not have a disk selected when you start the Create Volume wizard,
no figure displays in the volume size box. If you then click on a volume type
and also click the Maxsize button, a size appears in the volume size box that
represents the maximum volume for that layout for all disks in the dynamic
group.
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- If you do have a disk selected when you start the Create Volume wizard, a
size is shown in the volume size box that represents the maximum
concatenated (simple or spanned) volume size on the selected disk. If you
then click the Maxsize button, a new number appears in the volume size box
that represents the maximum size for a spanned volume that spans all the
disks in the dynamic group. You can also click on another volume layout and
then click the Maxsize button to get the maximum size for that layout that
involves unallocated space on all disks in the dynamic group.

If you choose Striped or RAID-5, Number of Columns and Stripe Unit Size need
to have an entry. Defaults are provided.

6. Select the volume type:

◆ Concatenated (Concatenated and Concatenated Pro)

◆ Striped (Striped and Striped Pro)

◆ RAID-5

◆ Mirrored

7. Make your selections in the Select disks for use for volume screen.

The default setting is for Volume Manager to assign the disks for you. To manually
select the disks, click the “Manually select disks to create volume” radio button. The
disks that you select should be in the right pane when you click Next.

8. Check your selections in the final screen. When you are satisfied with your choices,
click Finish.

By clicking the Previous button, you can go back and make changes before you click
Finish.

Notes:

- If you select disks manually, you can specify that the volume is to be mirrored or striped
across controllers, trays, targets, or enclosures. You can also select ordered allocation.
Ordered allocation uses the specified storage to first concatenate disks, then to form
columns, and finally to form mirrors.
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Concatenated
A concatenated volume consists of one or more regions of the specified disks. You have
the option of placing a file system on the new volume or mirroring the volume. You can
create a regular concatenated volume or a concatenated pro volume. A concatenated pro
volume is layered and mirrored.

Layout: Choose Concatenated or Concatenated Pro for the volume
layout.

Options: - To mirror the volume, select Mirrored. In the Total Number of
Mirrors field, enter the total number of mirrors for the volume.

Note Concatenated pro volumes are mirrored by default.

To enable logging for a mirrored volume, select Enable
Logging.

- To place a file system on the volume, click Create a file
system and specify the file system type and mount point in
the New File System dialog box.

- To clear the volume before enabling it for general use, select
Initialize Zero.

- To prevent the creation of a layered volume, select No
Layered Volumes. In cases where a layered volume layout is
appropriate, VxVM can create a layered volume when a
non-layered layout is specified. This option ensures that the
volume has a non-layered layout. If a layered (Pro) layout is
selected, this option is ignored.

Notes:

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- The data in a concatenated volume is not protected against disk failure unless the volume
is mirrored. At least one additional disk is required to mirror a concatenated volume.

- Concatenated pro volumes are mirrored by default, so a concatenated pro volume
requires more disks than an unmirrored concatenated volume.

- If your system supports root volumes, then it should be noted that you cannot use a
concatenated pro volume for a root volume.

- You cannot use a concatenated pro volume for a swap volume.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file
system table file automatically updates.
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Striped
A striped volume spreads across two or more disks. You have the option of placing a file
system on the new volume or mirroring the volume. You can create a regular striped
volume or a striped pro volume. A striped pro volume is layered and mirrored.

Layout: Choose Striped or Striped Pro for the volume layout.

In the Number of Columns field, specify the number of columns
(disks) across which the volume should be striped. A striped
volume requires at least two disks.

To specify a stripe unit size other than the default, enter the stripe
unit size in the Stripe Unit Size field. To specify a size unit, attach
an s (sectors), k (kilobytes), m (megabytes), or g (gigabytes) to the
size.

Options: - To mirror the volume, select Mirrored. In the Total Number of
Mirrors field, enter the total number of mirrors for the volume.

Note Striped pro volumes are mirrored by default.

To enable logging for a mirrored volume, select Enable
Logging.

- To place a file system on the volume, click Create a file
system and specify the file system type and mount point in
the New File System dialog box.

- To clear the volume before enabling it for general use, select
Initialize Zero.

- To prevent the creation of a layered volume, select No
Layered Volumes. In cases where a layered volume layout is
appropriate, VxVM can create a layered volume when a
non-layered layout is specified. This option ensures that the
volume has a non-layered layout. If a layered (Pro) layout is
selected, this option is ignored.
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Notes:

- A striped volume requires at least two disks.

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- The data in a striped volume is not protected against disk failure unless the volume is
mirrored. At least one additional disk is required to mirror a striped volume.

- Striped pro volumes are mirrored by default, so a striped pro volume requires more disks
than an unmirrored striped volume.

- If your system supports root volumes, then it should be noted that you cannot use a
striped pro volume for a root volume.

- You cannot use a striped pro volume for a swap volume.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file
system table file is automatically updated.
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RAID-5
A RAID-5 volume spreads across two or more disks, and contains parity information. You
have the option of placing a file system on the new volume.

Layout: Choose RAID-5 for the volume layout.

In the Number of Columns field, specify the number of columns
(disks) across which the volume should be striped. A RAID-5
volume requires at least three disks (or four disks if logging is
enabled).

To specify a stripe unit size other than the default, enter the stripe
unit size in the Stripe Unit Size field. To specify a size unit, attach
an s (sectors), k (kilobytes), m (megabytes), or g (gigabytes) to the
size.

Options: - To place a file system on the volume, click Create a file
system and specify the file system type and mount point in
the New File System dialog box.

- To enable RAID-5 logging for the volume, select Enable
Logging. VxVM adds an appropriate number of logs to the
volume.

- To clear the volume before enabling it for general use, select
Initialize Zero.

Notes:

- A RAID-5 volume requires at least three disks. If logging is enabled, a RAID-5 volume
requires at least four disks.

- RAID-5 volumes cannot be mirrored.

- For a RAID-5 volume, the size specified in the Size field is the usable space in the volume.
Volume Manager allocates additional space for the volume parity information. The disks
across which the RAID-5 volume is striped must, therefore, contain additional free space
for the volume parity information.

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file
system table file is automatically updated.
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Mirrored
A concatenated or striped volume is mirrored (copied) on at least one other disk. If one of
the disks fails, data on the volume can be accessed from the surviving disks. Concatenated
pro and striped pro volumes are layered and mirrored by default.

Layout: Choose Concatenated, Striped, Concatenated Pro, or
Striped Pro for the volume layout.

For a striped or striped pro volume, provide the following
information:

- In the Number of Columns field, specify the number of
columns (disks) across which the volume should be striped. A
striped volume requires at least two disks.

- To specify a stripe unit size other than the default, enter the
stripe unit size in the Stripe Unit Size field. To specify a size
unit, attach an s (sectors), k (kilobytes), m (megabytes), or g
(gigabytes) to the size.

Mirror Info: Select Mirrored. In the Total Number of Mirrors field, enter the
total number of mirrors for the volume.

Options: - To place a file system on the volume, click Create a file
system and specify the file system type and mount point in
the New File System dialog box.

- To enable Dirty Region Logging (DRL) for the volume, select
Enable Logging. VxVM adds an appropriate number of
logs to the volume.

- To clear the volume before enabling it for general use, select
Initialize Zero.

- To prevent the creation of a layered volume, select No
Layered Volumes. In cases where a layered volume layout is
appropriate, VxVM can create a layered volume when a
non-layered layout is specified. This option ensures that the
volume has a non-layered layout. If a layered (Pro) layout is
selected, this option is ignored.

Notes:

- A mirrored volume requires at least two disks. If logging is enabled, the volume requires
at least one additional disk.

- Only concatenated or striped volumes can be mirrored.
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Resizing a Dynamic Volume
The Resize Volume procedure changes the size of a volume. If users require more space
on a volume, you can use this procedure to increase the size of the volume. If a volume
contains unused space that you need to use elsewhere, you can use this procedure to
shrink the volume. If the volume contains a file system, this procedure also resizes the file
system.

▼ To resize a volume

1. Select the volume to be resized.

2. Choose Actions > Resize Volumes.
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3. Complete the Resize Volume wizard as follows:

Renaming a Volume
The Rename Volume procedure changes the name of a volume. If the volume has a file
system, this procedure also makes the necessary changes to the file system table file and
allows you to specify a new mount point for the file system.

New Size: Specify one of the following:

- To increase the volume size by a specific amount of space, use
the Add By field to specify how much space should be added to
the volume.

- To decrease the volume size by a specific amount of space, use
the Subtract By field to specify how much space should be
removed from the volume.

- To specify the new volume size, enter the size in the New
Volume Size field.

To determine the largest possible size for the volume, click Max
Size after choosing options.

Options: To use a specific disk for the additional space, click Manually
assign destination disks, then use the buttons for adding and
removing disks to move the disk or disks you want assigned as a
destination disk to the right pane of the window.

Notes:

- The Resize Volume task requires either the desired size or the amount of space to add
to or subtract from the volume size.

- A volume containing a file system other than VxFS cannot be shrunk.

- Shrinking a volume with an unmounted file system can result in data loss, so a volume
containing an unmounted file system cannot be shrunk.

- When a volume is shrunk, the resulting extra space is returned to the free space pool.

- When the volume size is increased, sufficient disk space must be available. When
increasing the size of a volume, VxVM assigns the necessary new space from available
disks..
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▼ To rename a volume

1. Select the volume to be renamed.

2. Choose Actions > Rename Volume.

3. Complete the Rename Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,
enter the volume name.

New Name: Enter the new name for the volume.

Notes:

- The Rename Volume task requires the current volume name and a new volume name.

- The new volume name must be unique within the disk group.

- If the volume contains a file system, the file system table file is automatically updated (if
necessary).

- The Rename Volume task requires umount file system if a file system is mounted.
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Changing a Volume Layout
The volume Change Layout procedure changes the layout of a volume without
interrupting access to data. You can use this task to change the redundancy or
performance characteristics of an existing volume.

You can view the progress of the relayout task through the Relayout Status Monitor
window. You can also use the Relayout Status Monitor window to pause, abort, continue,
or reverse the relayout task. The Relayout Status Monitor appears automatically when a
relayout task begins. When a volume relayout is in progress, paused, or aborted, you can
also access the Relayout Status Monitor through the Volume Properties window.

▼ To change a volume layout

1. Select the volume to be changed to a different layout.

2. Choose Actions > Change Layout.

3. Complete the Change Volume Layout dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,
enter the volume name.

Layout: Choose the new volume layout (Concatenated, Striped,
RAID-5, Concatenated Pro, or Striped Pro.)

For a striped, RAID-5, or striped pro volume, provide the
following information:

- In the Number of Columns field, specify the number of
columns (disks) across which the volume should be striped.

- The stripe unit size in the Stripe Unit Size field. To specify a size
unit, attach an s (sectors), k (kilobytes), m (megabytes), or g
(gigabytes) to the size.
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4. After you have provided all necessary information in the dialog box, click OK. The
Relayout Status Monitor window appears. This window provides you with the
following information:

Options: Click Show Options to access the optional settings for this task.

- To retain the original volume size when the volume layout
changes, click Retain volume size at completion.

- To specify the size of the pieces of data that are copied to
temporary space during the volume relayout, enter the size in
the Temp space size field.

- To specify additional disk space to be used for the new
volume layout (if needed), specify the disk in the disk(s) field .

- To specify the temporary disk space to be used during the
volume layout change, specify the disk in the temp disk(s)
field.

- If the volume contains plexes with different layouts, specify the
plex to be changed to the new layout in the Target Plex field.

Volume Name: The name of the volume that is undergoing a layout change.

Initial Layout: The original layout of the volume.

Desired Layout: The new layout for the volume.

Status: The status of the relayout task.

% Complete: The progress of the relayout task.
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If you need to pause, abort, continue, or reverse a relayout task after you close the
Relayout Status Monitor window, you can access the Relayout Status Monitor
through the Volume Properties window.

Notes:

- The Volume Change Layout task requires a volume name and a different volume
layout.

- Volumes remain accessible during online relayout.

- This task may take a long time, depending on the volume size and other factors. The
Relayout Status Monitor shows the progress of the layout change and allows you to abort,
pause, or reverse the task.

- If no disk space is specified, VxVM uses available space on disks in the current disk
group.

- If the temporary space size is not specified, VxVM uses an appropriate size. Specifying a
larger temporary space size speeds up the layout change process because larger pieces of
data are copied at a time. If the specified temporary space size is too small, VxVM uses a
larger size.

- If all of the plexes in the volume have identical layouts, VxVM changes all plexes (except
log plexes) to the new layout. If the volume contains plexes with different layouts, a target
plex must be specified. When a target plex is specified, VxVM changes the layout of the
target plex and leaves the other plexes in the volume alone.

- Log plex layouts do not change. VxVM removes and/or replaces log plexes, depending
on the new layout.

- If the volume length changes as a result of the layout change and the volume contains a
file system, the file system length is automatically adjusted (if possible).

- A volume cannot undergo multiple relayouts at the same time.

- This task cannot be used to change the layout of a volume with a sparse plex.

- This task may fail for volumes that were not created by VxVM or the vxassist
command.

- If the relayout is reversed, the volume returns to its original layout. However, data in the
volume may not return to its original storage location.

- During a relayout, many other tasks are unavailable for the volume.

- A mirrored or striped volume requires at least two disks.

- A RAID-5 volume requires at least three disks.
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Adding a Mirror to a Volume
The volume Add Mirror procedure creates a mirror (copy) of a volume on a disk that is not
already being used by the volume. If one of the disks fails, the volume data can be
accessed from the surviving disks. A volume can have multiple mirrors.

◆ To create a mirror on an existing volume, use the Add Mirror Wizard.

◆ To create a new mirrored volume, use the Create Volume Wizard. You select a
mirrored layout when you create the volume. See “VxVM Volumes.”

Note The mirroring process is disabled if the volume cannot be mirrored or if there is no
unallocated space on another dynamic disk large enough to mirror the volume. A
RAID-5 volume cannot be mirrored.

▼ To add a mirror to an existing volume

1. Select the volume to be mirrored.

2. Choose Actions > Mirror > Add.

3. Complete the Add Mirror dialog box as follows:

Options: - To add more than one mirror, enter the number of mirrors in
the Mirror Quantity field.

- To place the mirror on a specific disk, select Manually select
disks for use by this volume, and assign the
destination disks for the mirrors.

- To specify the layout for the mirror, select Mirror Across or
Stripe Across. For a striped mirror, specify the number of
columns and stripe unit size.
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After you have provided all necessary information in the dialog box, click OK.
Adding a mirror requires resynchronization, so this task may take some time.

Notes:

- The Mirror Add task requires a volume name.

- Once mirrored, the data in the volume is redundant. If a disk fails, the data remains
available on the surviving mirror (on another disk).

- The new mirror cannot be created on a disk that already contains a copy of the volume.
Each mirror must reside on a separate disk.

- Sufficient disk space must be available to accommodate the additional mirrors.

- Only disks in the same disk group as the volume can be used to create the new mirror.

- If no disks are assigned, VxVM uses available disk space to create the mirror.

- A RAID-5 volume cannot be mirrored.

- If your system supports root volumes, then you can mirror the root volume (and other
volumes required to boot the system) onto an alternate boot disk, use the Mirror Disk
task.

- A volume can contain up to 32 plexes (mirrors).

- If you create more than one mirror at a time, you may see inconsistent information on the
progress bar. Also, the generation of multiple mirrors does affect system resources. After
creating a mirror, you may want to wait until it has finished generating before creating
another mirror.
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Adding a Log to a Volume
The volume Add Log procedure adds the appropriate type of log to a mirrored or RAID-5
volume.

When used to add a Dirty Region Logging (DRL) log to a mirrored volume, DRL uses this
log to track the regions of the volume that change due to I/O writes. If a system failure
occurs, DRL uses the information in the log to recover only the portions of the volume
that need recovery. This speeds up recovery time for mirrored volumes.

For DRL to be in effect, a mirrored volume must have at least one DRL log. You can create
additional DRL logs (on different disks) to mirror the DRL information.

When used to add a log to a RAID-5 volume, the log speeds up the resynchronization time
for RAID-5 volumes after a system failure. A RAID-5 log maintains a copy of the data and
parity being written to the volume at any given time. If a system failure occurs, VxVM can
“replay” the RAID-5 log to resynchronize the volume. This copies the data and parity that
was being written at the time of failure from the log to the appropriate areas of the RAID-5
volume. You can create multiple RAID-5 logs (on different disks) to mirror the log
information. Ideally, each RAID-5 volume has at least two logs.

1. Select the mirrored volume or RAID-5 volume to contain the log.

2. Select Actions > Log > Add.

3. By default the “Auto assign destination disks” option will be selected. To manually
assign the destination disks, select the “Manually assign destination disks” option.

Available disks will appear in the left window. To add destination disks, select them
in the left window and click the Add button. To add all of the available disks, click the
Add All button.

To remove destination disks, select them in the right window and then click the
Remove button. To remove all of the destination disks, click the Remove All button.

4. Click Apply to create the Log then OK.

Notes:

- When a log is added to a mirrored volume, DRL is activated for that volume.
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Stopping and Restarting a Volume
The Stop Volume procedure disables a volume. When a volume is stopped, it is not
available for use until it is restarted (refer to “Recovering a Volume” on page 107).
Stopping a volume is a safe way of temporarily preventing access to a volume.

▼ To stop a volume

1. Select the volume to be stopped.

2. Choose Actions > Stop Volume.

3. In reply to the message “Are you sure you want to stop the volume ...,” click OK. The
volume state changes to STOPPED.

Using the Volume Snapshot Feature
The snapshot feature can be used to take a snapshot of a mirrored or an unmirrored
volume, but snapshot is not supported for RAID-5 volumes.

Note To take a snapshot of a volume, you must have an empty dynamic disk in the
volume’s disk group.

The snapshot feature enables quick and efficient online backup of volumes, with
minimum disruption to the user. Snapshot automatically enables FastResync (FR) and
creates a snapshot image of a volume, which can be detached from the volume. The
detached snapshot image can be used for backup, or other purposes, while the original
volume remains in service. The snapshot can then be quickly reattached and
resynchronized with the volume, through the FR reconnection capability. The snapshot
volume can also be permanently disconnected from the original volume.

You can attach more than one snapshot plex to a volume, by issuing successive snapstart
commands on the volume. This enables you to take multiple snapshots of a single
volume.

You can attach a snapshot to either the original volume or the snapshot volume.

The following five snapshot commands are supported by VxVM, and are accessed
through the Volume context menu:

Note:

A volume cannot be stopped if it is in use (open) or it has a mounted file system.
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- Snap Start - Creating a Snapshot Copy of a Volume

Attaches the snapshot mirror to the original volume.

- Snap Shot - Creating the New Volume

Detaches the snapshot mirror from the original volume and creates a snapshot
volume that is associated with the snapshot mirror.

- Snap Back - Merging a Snapshot Volume (Volume Snapback)

Reattaches the snapshot mirror to the original volume.

- Snap Clear - Dissociating a Snapshot Volume (Volume Snap Clear)

Permanently removes the snapshot mirror from the original volume and releases
its space.

- Snap Abort - Aborting a Snapshot

Aborts the snapshot operation after issuing the Snap Start command. Snap
Abort permanently removes the snapshot mirror from the volume and releases its
space.

The five snapshot commands are subcommands of the Snap command on the Volume
context menu.

Using Snapshot
In summary, the snapshot procedure consists of three steps:

1. Attaching a snapshot mirror to a volume, using Snap Start.

2. Detaching the snapshot mirror and creating the snapshot volume that is associated
with the snapshot mirror. The Snap Shot command is used for this step.

3. Either reattaching the snapshot to the volume after you are done using it, or
permanently disconnecting it from the volume. Snap Back reattaches the snapshot
mirror; Snap Clear permanently disconnects the snapshot mirror from the volume,
removing the association between the snapshot volume and the original volume.

Snap Abort aborts the snapshot operation after issuing the Snap Start command.

Creating a Snapshot Copy of a Volume

Snap Start creates a snap mirror or plex, which is attached to and synchronized with a
volume. Once the snap mirror is synchronized, its status, as displayed on the Mirrors tab
of the GUI, changes to Snap Ready.
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After the snap mirror is synchronized with the volume, it can be used as a snapshot
mirror. The synchronization process can take a while, but it does not interfere with use of
the volume. If the Snap Start process fails, the snapshot mirror is removed and its space is
released. After the mirror is synchronized, it continues to be updated until it is detached.

Note To create a snapshot mirror on a dynamic volume, you must have an empty
dynamic disk in the dynamic disk group of that volume.

▼ To create a snapshot mirror, do the following:

1. Right-click on the volume that you want to take a snapshot of.

A context menu is displayed.

2. Select Snap > Snap Start.

A new snapshot mirror is attached to the volume.

The new mirror is added to the Mirrors tab for the volume. The mirror is identified as
a Snapshot plex and is identified with the Snapshot icon. After the mirror is
synchronized with the volume, its status becomes Snap Ready.

The DCO (disk change object) volume is created to track the regions on a volume that
are changed while a mirror is detached. The DCO volume is not included in the tree
view of the Volume Manager GUI. To view the DCO volume, you must use the Disk
View. To access the Disk View, click the Disk View tab in the right pane or select Disk
View from a disk’s context menu.

Note The Break Mirror and Remove Mirror commands do not work with the snapshot
mirror.

Creating the New Volume

Snap Shot detaches the snapshot mirror and creates a new volume that is associated with
that mirror. This process takes a relatively short time, typically less than a minute, during
which users can be requested to not access the original volume. After the snapshot
volume is detached, it can be used for backup or other purposes.

To take a snapshot, do the following:

1. Right-click on the volume with the snapshot mirror.

A context menu is displayed.

2. Select Snap > Snap Shot.
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The Snapshot Volume dialog box is displayed. You are asked to select the snapshot
mirror to be used to create the snapshot volume.

3. Select the mirror and click OK.

When there is only one snapshot mirror, “Automatic select mirror to add snapshot”
will be highlighted. If there are multiple mirrors and you want to select the mirror to
be used, click to select “Manual select which mirror to add snapshot.” You then can
select the mirror from the list on the screen.

Click OK.

The snapshot mirror is detached from the original volume and a new volume is
created that is associated with the snapshot mirror.

The snapshot mirror is no longer displayed on the Mirrors tab for the original volume.
The new snapshot volume is displayed under the Volumes folder in the tree view. The
program assigns it the next available drive letter. You can now use the snapshot
volume for backup or other purposes.

Merging a Snapshot Volume (Volume Snapback)

The volume Snap Back procedure merges a snapshot copy of a volume with the original
volume. The snapshot plex is detached from the snapshot volume and attached to the
original volume. The snapshot volume is removed. This task resynchronizes the data in
the volume so that the plexes are consistent. By default, the data in the original plex is
used for the merged volume.

Notes:

- FastResync is not supported for RAID-5 volumes

- The Volume Snapshot Interactive task requires a volume name and a snapshot
name.

- The snapshot volume is an exact copy of the original volume at the time the snapshot
phase of the procedure starts.

- After you create the snapshot copy of the volume, remember to back it up to tape or some
other media. Remove the snapshot volume when it is no longer needed.

- The snapstart phase of this task may take a long time, depending on the size of the
volume.

- If you remove the snapshot mirror, you cannot create a snapshot volume until you repeat
the snapstart phase of the procedure.
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To reattach a snapshot mirror to the original volume, do the following:

1. Right-click the volume whose snapshot you want to reattach.

A context menu is displayed.

2. Select Snap > Snap Back.

3. Specify whether the snapshot volume is resynchronized with the original volume, or
the original volume is synchronized to the snapshot volume and click OK.

Note One situation where you might want to resynchronize to the snapshot volume
rather than the original volume is the case where something has happened to the
original volume so that its data integrity is no longer sound.

The snapshot mirror is reattached to the original volume and the snapshot volume is
deleted if it is the last plex of the volume. (If the snapshot volume has other mirrors
associated with it, it is not deleted.)

Dissociating a Snapshot Volume (Volume Snap Clear)

The volume Snap Clear procedure permanently breaks the association between a
snapshot and its original volume. The snapshot volume becomes an independent volume.

Snap Clear permanently removes a snapshot mirror from a volume. Snap Clear can be
specified only after the snapshot command has been issued.

▼ To permanently remove a snapshot mirror from a volume, do the following:

1. Right-click on the volume, whose snapshot mirror you are removing.

A context mirror is displayed.

2. Select Snap>Snap Clear.

A message box is displayed asking you to confirm the snap clear operation for the
specified volume.

3. Click Yes.

The snapshot mirror is permanently disconnected from the original volume and is no
longer displayed on the Volume Manager console.
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Aborting a Snapshot

The volume Snap Abort procedure allows you to abort the snapshot procedure before it
completes. If you have started the procedure, through Snap Start, but have not yet
clicked on Snap Shot to complete the procedure, you can select Snap Abort to abort the
procedure.

▼ To abort a snapshot operation begun with snap start, do the following:

1. Right-click on the volume that you want to abort the snapshot operation on.

A context menu is displayed.

2. Select Snap > Snap Abort.

A message box is displayed asking you to confirm the snap abort operation for the
specified volume.

3. Click OK.

The snapshot process is aborted.

Preparing to Restore a Volume From Backup
The Volume Prepare Restore procedure stops the volume, sets the volume to an
uninitialized state, and restarts the volume (without resynchronizing the volume mirrors).
The volume can then be reloaded from backup.

This procedure is intended for raw image backups and is not appropriate for file system
backups. This procedure is useful for disaster recovery. If the data on a volume is
corrupted and you know that you need to restore the volume from backup, you can use
this procedure to prepare the volume for restoration.

▼ To prepare a volume for a restore from backup

1. Select the volume to be restored from backup.

2. Choose Volumes > Prepare For Restore.

3. Complete the Prepare Volume For Restore dialog box as follows:

Volume(s): If the correct volume name does not already display in this field,
enter the volume name.
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After you have provided all necessary information in the dialog box, click OK. After
you have completed this task, you can restore the volume data from backup.

Note:

If the volume contains a mounted file system, the file system must be unmounted before
this task can proceed. This task does not remount the file system.
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Recovering a Volume
The Recover Volume procedure performs any necessary volume recovery operations on
a volume. The recovery operations depend on the type of volume and include starting
disabled volumes, resynchronizing mirrors in mirrored volumes, and resynchronizing
parity in RAID-5 volumes. After successful recovery, the volume is again available for use.

Alert icons and the Alert Monitor window can provide clues to let you know that volume
recovery is needed.

▼ To recover a failed volume

1. Select the volume to be recovered.

2. Choose Actions > Recover Volume.

3. In reply to the message “Are you sure you want to recover volume ...,” click OK.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to
restore the volume from backup.
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Removing a Mirror From a Volume

Caution Removing a mirror can result in loss of data redundancy.

The Mirror Remove procedure removes a mirror from its volume. This procedure breaks
the link between the mirror and its volume and returns the mirror disk space to the free
space pool for reuse. You can remove an extra mirror from a volume to make the
underlying disk space available for use elsewhere. However, this may leave the volume
unmirrored and unprotected against disk failure.

▼ To remove a mirror from a volume

1. Select the volume that contains the mirror to be removed.

2. Choose Actions > Mirror > Remove.

3. Complete the Remove Mirror dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,
enter the volume name or select the volume from the drop-down
menu.

Removal Method: Specify the mirrors and/or number of mirrors to be removed:

- To specify how many mirrors should be removed, select By
Quantity/Disk. Enter the number of mirrors to be removed in
the Mirror quantity field.

- To specify the disks on which mirrors should be preserved,
select By quantity/disk.

- Specify the names of disks or mirrors to be removed from the
list of available disks or mirrors.
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After you have provided all necessary information in the dialog box, click OK.

Notes:

- The Mirror Remove task requires a volume name. This task also requires the number of
mirrors to remove, a disk name, or a mirror name.

- If a volume only has two mirrors and one mirror is removed, the volume is no longer
redundant.

- The last mirror (plex) cannot be removed from a volume.

- When a mirror is removed, the space occupied by that mirror is returned to the free space
pool.
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Removing a Log From a Volume
The Log Remove procedure removes a log from a mirrored or RAID-5 volume. For a
mirrored volume, this removes a DRL log from the volume. For a RAID-5 volume, this
removes a RAID-5 log from the volume.

▼ To remove a log from a volume

1. Select the volume that contains the RAID-5 or DRL log to be removed.

2. Select Actions > Log > Remove.

3. Complete the Remove Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,
select the volume name from the drop-down menu.

Removal Method: Specify the logs and/or number of logs to be removed:

- To specify how many logs should be removed, select By
Quantity/Disk. Enter the number of logs to be removed in the
Log quantity field.

- To specify the disks on which logs should be preserved, select
By Quantity/Disk. Select the disk names from the list of
available disks.

- To specify the name of the log to be removed, select Log, then
select the log names from the list of available logs.

Notes:

- This task requires a volume name.

- If the only log is removed from a volume, logging (either dirty region logging or RAID-5
logging) is no longer in effect for that volume. When logging is disabled, recovery time
increases.
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Deleting a Volume

Caution Deleting a volume can result in data loss.

This procedure permanently removes a volume and all of its data. You should only
remove a volume if you are sure that you do not need the data in the volume (or the data
is backed up elsewhere). You can remove a volume to make the underlying disk space
available for use elsewhere.

▼ To delete a volume

1. Select the volume to be deleted.

2. Choose Actions > Delete Volume.

3. Respond Yes when the Confirm deletion dialog appears.

Notes:

- Removing a volume destroys all of the data in that volume.

- When a volume is removed, the space it occupied is returned to the free space pool.
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Associating a Plex
The Plex Associate procedure associates (attaches) a plex to a volume. This involves
copying data from an active mirror on the volume to the new plex (mirror).

▼ To associate a plex

1. Choose Plex Associate.

2. Complete the Associate Plex dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Moving, Splitting, and Joining Subdisks
The commands Subdisk Move, Split, and Join, enable you to move subdisks to other
locations within the dynamic group, split subdisks, and join them back together. The
flexibility of moving subdisks, splitting them, and joining them lets you make best use of
your disk space.

- Moving a Subdisk

- Splitting a Subdisk

- Joining a Subdisk

Plex Name: Enter the plex name.

Volume Name: Enter the name of the volume to be associated with the plex or click
Browse to select a volume.

Notes:

The Plex Associate task:

- Requires a plex name and a volume name.

- Connects a plex to a volume.

- Can take a long time, depending on the amount of data in the volume.
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Moving a Subdisk

Note You are not allowed to move a subdisk that is part of a boot or system volume.

The Subdisk Move procedure moves the contents of a volume subdisk from one disk to
another. This is useful for moving portions of a volume to a different disk for improved
performance.

If disk activities are heavily concentrated on one or a small number of disks in the storage
subsystem, it may create bottlenecks. You can use the Subdisk Move and possibly the
Subdisk Split command to spread out disk accesses more evenly across all the disks to
balance the load.

You can use the Subdisk Move command to move all subdisks to healthier disks. The
benefit of moving subdisks instead of copying the volumes is that you need only enough
space on the receiving disks for the subdisks on the one failed disk, not for entire volumes
that may span multiple disks. Another advantage is that there is no interruption in I/O.

Moving subdisks provides you with a flexible means of making adjustments in your
storage system while it is up and running.

▼ To perform a subdisk move operation:

You can use the Object View window (Disk Groups > Object View) or the Volume to
Disk Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks and
gaps on disks in a disk group. In the Object View window, you can move a subdisk by
placing the pointer over the subdisk and then pressing and holding the mouse button
to drag the subdisk to another location.

To display the subdisk in the right pane, click on its volume in the tree view, and then
click on the Subdisks tab in the right pane. The subdisks for that volume will display.
You can use the Subdisks Properties command to further identify the characteristics of
a volume’s subdisks.

1. Identify the subdisk that you want to move and display it in the right pane.
Right-click on the subdisk you want to move to bring up its context menu.

2. Select Move from the context menu.

3. The welcome screen of the Subdisk Move wizard appears. Click Next to continue.

4. In the screen that appears next, choose either automatic or manual selection of the
destination disk for the subdisk to be moved and click Next.

Leave the default value of “Auto assign destination disks” if you want the program to
assign the destination disk.

If you want to select the destination disk, click “Manually assign destinations disks.
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5. If you selected the manual assignment of the destination disk, an extra screen
appears. Select the hard disk you wish to move the subdisk to and click Next.

Note VxVM automatically checks the state of the data before beginning the subdisk
move. If the data is degraded, the subdisk can still be moved. After moving, you
will need to reactivate the disk to clear the degraded setting.

6. The final screen of the Subdisk Move wizard appears. Click Finish to complete the
command.

After you have provided all necessary information in the dialog box, click OK.

Splitting a Subdisk
The Subdisk Split command allows you to split a subdisk. After the subdisk is split, the
resulting two subdisks will reside on the same section of the same disk. You can then use
the Subdisk Move command to move one or both subdisks to other disks. You may want
to split and move a subdisk to make the best use of your disk space. A split subdisk can be
joined back together again with the Subdisk Join command.

You can use the Object View window (Disk Groups > Object View) or the Volume to Disk
Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks in a disk
group. You can use the Volume Layout Details window (Volumes > Show Layout) to
view subdisks in a specific volume.

▼ To split a subdisk into multiple subdisks

1. Identify the subdisk that you want to split and display it in the right pane.

2. Right-click on the subdisk you want to split to bring up its context menu.

3. Select Split from the context menu.

Notes:

- Subdisks are typically moved to reorganize disk space.

- The disk space occupied by the original subdisk is returned to the free space pool.

- A subdisk in a mirrored, striped, or RAID-5 volume should not be moved to a disk that
already contains a copy or part of that volume.

- If the Subdisk Move task fails and leaves some unused subdisks (that is, subdisks that
are not associated with a volume) on the system, you can use the Subdisk Remove task
to free the space occupied by the unused subdisks.
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4. The welcome screen of the Subdisk Split wizard appears. Click Next to continue.

5. In the next screen that comes up, specify the subdisk size for the first of the two
subdisks and Click Next.

The remaining space left over will be assigned to the second subdisk. For example, if
the original subdisk was 100 MB and you assigned 40 MB to the first subdisk, the
other subdisk will be 60 MB.

6. The final screen of the Subdisk Split wizard appears. Click Finish to complete the
command.

After a few moments, two subdisks will appear in the right pane of the Volume
Manager GUI.

Joining a Subdisk
The Subdisk Join procedure joins two or more subdisks together to form a single larger
subdisk. Subdisks can only be joined together if they belong to the same volume and
occupy adjacent regions of the same disk and mirror. You can join two subdisks that had
been one subdisk but that were split by the Subdisk Split command. You cannot split a
subdisk and join it back to another subdisk that it was not split from. There also has to be
room on the disk for the two subdisks.

You can use the Object View window (Disk Groups > Object View) or the Volume to Disk
Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks in a disk
group. You can use the Volume Layout Details window (Volumes > Show Layout) to
view subdisks in a specific volume.

Notes:

- The name of the first subdisk remains the same as the selected subdisk. Other subdisks
are automatically named by VxVM.

- The new, smaller subdisks occupy the same regions of the disk that the original subdisk
occupied.

- The original subdisk must contain a sufficient number of sectors for the specified split to
work.

- A Dirty Region Logging log subdisk cannot be split.
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▼ To join subdisks

1. Identify one of the two subdisks that you want to join and display it in the right pane.

2. Right-click on the subdisk you want to join to bring up its context menu.

3. Select Join from the context menu.

4. The welcome screen of the Subdisk Join wizard appears. Click Next to continue.

5. In the screen that comes up next, select the subdisks to be joined together and click
Next.

6. The final screen of the Subdisk Join wizard appears. Click Finish to complete the
command.

Within a short time, the two subdisks will be replaced in the right pane of the Volume
Manager GUI with one subdisk.

After you have provided all necessary information in the dialog box, click OK.

Subdisk Properties

Name

Subdisks on a disk are assigned numbers in a sequence, such as 1-01, 1-02, 1-03 or 12-01,
12-02, 12-03. The subdisk number is an internal number generated by the program. There
is no particular significance to the one or two digits before the dash except that, for any
one disk, the first one or two numbers identifying its subdisks must be the same. The

Notes:

- The Subdisk Join task requires two or more existing subdisk names and a new (joined)
subdisk name.

- Only contiguous subdisks on the same disk can be joined.

- The subdisks to be joined must belong to the same volume and mirror.

- For a striped volume, the subdisks must be in the same column.

- The joined subdisk name can be the name of one of the subdisks being joined.
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numbers after the dash represent a number for the subdisk within the disk. Thus, if the
subdisk was the first one created for a particular disk, it would have 01 after the dash, the
second disk created would have 02 after the dash, and so on.

Size

This field displays the size of the subdisk.

Column

Column displays the column that the subdisk occupies in the volume. Striped and RAID-5
volumes have multiple columns.

Disk Offset

This is the offset where the subdisk starts on the disk. The reason this is included in the
Properties window is because for a subdisk to be split, it must be a contiguous to the
subdisk next to it. By looking at the offsets, you can determine which subdisks are
contiguous.

Plex Offset

This is the offset of a subdisk within a plex. It shows the distance from the start of a plex to
the start of a specific subdisk. The first subdisk within a plex will have an offset of "0." The
second subdisk will be offset by the size of the first subdisk.

After you have provided all necessary information in the dialog box, click OK.
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Viewing Volume Properties
The Volume Properties window contains detailed information about the selected volume.
The Properties window contains a set of tabbed pages, each of which contains information
about the volume and related objects. You can display a different page by clicking on the
appropriate tab label.

◆ To view the properties of a volume, select the volume and then choose Properties
from the Volumes or popup menu. You can also access the Volume Properties
window by double-clicking on the volume.

◆ To update the contents of the Properties window to reflect current properties for the
volume, click Refresh.
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File System Tasks
 5

File system tasks include:

- Adding a New File System to a Volume

- Mounting a File System

- Unmounting a File System

- Removing a File System from the File System Table

- Defragmenting a File System

- Creating a Snapshot Copy of a File System

- Checking a File System

- Viewing File System Properties

- Using the QuickLog Feature

- Unmounting a File System from a Cluster Node

- Removing Resource Information for a Cluster File System
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File System Task Roadmap
The following table provides a summary of common VEA file system tasks.

To perform this task … Use this procedure …

File System Setup Tasks:

Add a new file system to a volume Adding a New File System to a Volume

Mount a file system Mounting a File System

Maintenance Tasks:

Defragment a file system Defragmenting a File System

Create a snapshot copy of a file system for
backup

Creating a Snapshot Copy of a File System

Recovery Tasks:

Perform a file system consistency check Checking a File System

Other Tasks:

Unmount a file system Unmounting a File System

Cluster mounting a file system Mounting a File System

Removing cluster file system resource
information

Removing Resource Information for a Cluster
File System

Create a QuickLog volume Creating a QuickLog Volume

Enable a QuickLog device Enabling a QuickLog Device for a File System

Disable a QuickLog device Disabling a QuickLog Device for a File System

Remove a QuickLog volume Removing a QuickLog Volume
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Adding a New File System to a Volume
Adding a New File System to a Volume
You can use the Volume Manager New File System procedure to place a file system onto
an existing volume and mount the file system. This also updates the file system table file,
if necessary.

▼ To add a new file system to an existing volume

1. Select the volume to contain the file system.

2. Choose Actions > File System > New File System.

3. Complete the New File System dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

File system type: Select the file system type from the options shown.

Create Options: - See Allocation Unit/Block size for allocation and block and
settings.

- To specify create details, click New File System Details
and specify any additional options in the New File System
Details dialog box (see Create Options).

Compress (checkbox) - If your platform supports file compression, then you can select
Compress to compress the files on your file system.

Mount Options: - Enter the mount point for the file system, if you want the file
system mounted at system startup.

- Select the Create mount point checkbox if you want the
system to create the mount point if it does not already exist.

- Select the Read only and Honor setuid checkboxes, as
required.

- Select the Add to file system table and Mount at boot
checkboxes to update the system table file and mount the file
system at system startup.

- Select the Add to file system table checkbox, and leave the
Mount at boot checkbox unselected to update the system
table file, and not mount the file system at system startup.

- To specify mount details, click Mount File System Details
and specify any additional options using the checkboxes and
Extra Options entry in the Mount Details dialog box (see
Mount Options).
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Adding a New File System to a Volume
Allocation Unit/Block size

Create Options

File System Allocation Unit Values Block Size Values

ufs 512, 1024, 2048, 4096, 8192 4096, 8192

vxfs same as block size 1024, 2048, 4096, 8192

jfs, jfs2 512, 1024, 2048, 4096 512, 1024, 2048, 4096

ext2, ext3 1024, 2048, 4096 1024, 2048, 4096

hfs 1024, 2048, 4096, 8192, 16384,
65536

1024, 2048, 4096, 8192, 16384,
65536

Option File Systems Description

largefiles/nolargefiles vxfs, jfs, fs2 File system contains/does not
contain files equal or greater
than 2 GBytes.

logsize vxfs Activity logging area size.
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Adding a New File System to a Volume
Mount Options

Option File Systems Description

largefiles/nolargefiles vxfs, jfs, fs2 File system contains/does not
contain files equal or greater
than 2 GBytes.

Quick I/O (checkbox) vxfs Enables/disables the
VERITAS Quick I/O for
Databases option for the
filesystem.

QuickLog device
(checkbox)

vxfs Enables the filesystem to use
VERITAS QuickLog. Select
also the log device number to
be used (1 to 31).

Cluster mount
(checkbox). This is
present in the Mount
File System Details
dialog only if the
optional cluster
functionality is
available.

vxfs Mounts the filesystem in
shared mode.

Select the nodes to be
mounted.

log/delaylog/tmplog jfs, jfs2 Controls intent logging. To
maintain filesystem integrity
after a system failure, logging
must be enabled.

blkclear vxfs Clears all data extents
before file allocation.

mincache vxfs File system caching policy

Note that, while the
tmpcache option to
mincache improves
performance, it reduces
integrity.
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Adding a New File System to a Volume
noatime vxfs Disables access time

recording.

Notes:

- The New File System task requires a file system type.

- If the file system is to be mounted at startup, a file system mount point is required.

- If the Add to file system table checkbox is selected, then the file system table is
automatically updated when the file system is mounted.

- The mount point must be an absolute pathname (that is, it must begin with /).
124 VERITAS Volume Manager User’s Guide - VEA



Mounting a File System
Mounting a File System
The Mount File System procedure mounts a file system and updates the file system table
file, if necessary.

▼ To mount a file system on an existing volume

1. Select the volume that contains the file system to be mounted.

2. Choose Actions > File System > Mount File System.

3. Complete the Mount File System dialog box

▼ To mount any file system

1. Select the file system to be mounted.

2. Choose Actions > Mount File System.

3. Complete the Mount File System dialog box as follows:

FS Type: Select the file system type.

Mount Options:

(refer to Adding a New
File System to a Volume
for available options)

- If you want the system to use the mount options defined in the
system table, check Mount using options in the file
system table.

- Enter the mount point for the file system, if you want the file
system mounted at system startup.

- Select the Create mount point checkbox if you want the
system to create the mount point if it does not already exist.

- Select the Read only and Honor setuid checkboxes, as
required.

- To specify mount details, click Mount File System Details
and specify any additional options using the checkboxes and
Extra Options entry in the Mount Details dialog box (see
Mount Options).
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Unmounting a File System
After you have provided all necessary information in the dialog box, click OK.

Unmounting a File System
The Unmount File System procedure unmounts a file system.

▼ To unmount a file system on a volume

1. Select the volume containing the file system to be unmounted.

2. Choose Actions > File System > Unmount File System.

3. Click Yes in the Unmount File System dialog to confirm that you want the file system
unmounted.

▼ To unmount any file system

1. Select the file system to be unmounted.

2. Choose Actions > Unmount File System.

3. Click Yes in the Unmount File System dialog to confirm that you want the file system
unmounted.

Notes:

- The specified volume must contain a file system.

- The mount point must be an absolute pathname (that is, it must begin with /).
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Removing a File System from the File System Table
The file systems Remove from File System Table procedure removes its resource
information from the file system table.

▼ To remove file system information from the file system table

1. Select the file system to be removed.

2. Choose Actions > Remove from File System Table.

3. Click Yes in the Remove File System dialog to confirm that you want the file system
information removed.

Defragmenting a File System
The Defrag File System procedure defragments a file system and the underlying volume,
removing disjointed extents, and so on.

▼ To defragment a file system on a volume

1. Select the volume containing the file system to be defragmented.

2. Choose Actions > File System > Defrag File System.

3. Select Yes in the displayed dialog box

▼ To defragment any file system

1. Select the file system to be defragmented.

2. Choose Actions > Defrag File System.

3. Select Yes in the displayed dialog box.
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Creating a Snapshot Copy of a File System
The File System Snapshot procedure prepares VxFS for online backup by creating a
snapshot copy of the file system. This is done by creating a new volume, mounting a
snapshot file system on the new volume, and copying the contents of the original file
system to the snapshot file system. The snapshot file system is a consistent copy of the
original file system at the time the snapshot was made. You can use the snapshot file
system to make a backup of the original file system at a convenient time. After the backup
is made, you can remove the snapshot file system by removing the underlying snapshot
volume.

▼ To create a snapshot copy of file system data

1. Select the file system to be backed up.

2. Choose Actions > Snapshot > Create...

3. Complete the Snapshot File System dialog box as follows:

New Volume Name: By default, the new volume name displayed is composed of the
name of the file system to be backed up and the suffix _vxfssnap
(for example, Vol5_vxfssnap). You can replace the default name
with the volume name of your choice.

Snapshot Mount Point: By default, the new snapshot mount point displayed is composed
of the mount point of the file system to be backed up and the suffix
_vxfssnap (for example, /Vol5_vxfssnap). You can replace the
default name with the mount point of your choice.

Snapshot Size: Enter the size of the snapshot copy of the file system.

Select disks to use for
the volume:

Select the disks for Volume screen.

The default setting is for Volume Manager to assign the disks for
you. To manually select the disks, click the “Manually select which
disks to use for volume” radio button. The disks that you select
should be in the right pane when you click Apply.

Cluster node (displayed
only if your node is part
of a cluster):

If your node is part of a cluster, you can now select the node in the
cluster to contain the file system.

If the node you select is not displayed in the current window, then
it resides on a remote node. In order to remove this snapshot, you
will have to open the remote node and display the created file
system before removing it.
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Checking a File System
After you have provided all necessary information in the dialog box, click OK.

Checking a File System
The Check File System procedure checks an unmounted file system for consistency
(using the fsck command). See the fsck_vxfs(1M) manual page for more information
on file system checking.

▼ To check a file system on a volume

1. Select the volume containing the file system to be checked.

2. Choose Actions > File System > Check File System.

3. Click Yes in the Check File System dialog to confirm that you want the file system
checked.

▼ To check any file system

1. Select the file system to be checked.

2. Choose Actions > Check File System.

Notes:

- The File System Snapshot task requires a file system name, a snapshot mount point,
and a snapshot size.

- The File System Snapshot task is only available for VxFS file systems.

- The snapshot file system is an exact copy of the original file system at the time the
snapshot was created.

- After you create the snapshot copy of the file system, remember to back it up to tape or
some other media. Remove the snapshot file system when it is no longer needed.

- Users can continue to use the original file system during this snapshot backup procedure.

- Refer to the VERITAS File System Administrator’s Guide for guidelines on choosing the
snapshot file system size.
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Checking a File System
3. Click Yes in the Check File System dialog to confirm that you want the file system
checked.

Notes:

- The file system must be unmounted.

- VxVM assumes that fsck does not require user input. If user input is required, this task
fails and fsck must be run at the command line.
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Monitoring File System Capacity
Monitoring File System Capacity
The Set Usage Threshold procedure enables you to monitor the capacity of a file system
on a mounted volume.

▼ To monitor the capacity of a file system

1. Select the file system to be monitored.

2. Choose Actions > Set Usage Threshold.

3. Complete the Set Usage Threshold dialog box as follows:

Monitor Capacity Select the Monitor Capacity checkbox to initiate capacity
monitoring on the file system. The File Systems Tabular View
indicates if capacity monitoring is Enabled or Disabled.

Threshold Percentage Select the Threshold Percentage value. When usage crosses
this value, an alert will be logged.

Alert Interval
(vxfs systems only):

Specifies the minimum time between recording alerts. (Avoids
multiple recordings if events are moving back and forth over the
boundary.)

Notes:

For systems other than vxfs, alert thresholds are not persistent (that is, the information is lost
when the server restarts). This means that:

- File system objects on the bus reflect the threshold and enabled status for alerts

- Once an alert is fired, the status on the bus is disabled so that the alert is not refired at
every periodic rescan

(This can be avoided by allocating a low value to Threshold Percentage.)
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Viewing File System Properties
The File System Properties window contains detailed information about the selected file
system. Select File Systems then Properties.

You can also view the properties associated with each mount point under the file systems.

◆ To view the properties of a particular file system mount point, select File Systems,
then choose the mount point and Properties from the popup menu.

◆ To update the contents of the Properties window to reflect current properties for the
file system, click Refresh.
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Using the QuickLog Feature
Using the QuickLog Feature
◆ Creating a QuickLog Volume

◆ Enabling a QuickLog Device for a File System

◆ Disabling a QuickLog Device for a File System

◆ Removing a QuickLog Volume

Creating a QuickLog Volume
The Make Log procedure designates a volume as a QuickLogTM volume. After setting up a
QuickLog volume, you can enable a QuickLog device for a file system.

▼ To designate a volume as a QuickLog volume

1. Select the volume to be used for the QuickLog device.

2. Choose Actions > QuickLog > Make Log

3. Complete the Make QuickLog Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: Check that the correct volume name is displayed in this field.

Log Device Number: Select the number of the log device to attach to the volume. Log
devices are listed in /dev/qlog.

Create Cluster Quicklog
checkbox (shown only
if the volume is part of a
cluster):

Check this box is you want the Quicklog volume to be available to
the cluster..

Notes:

- The Make Log task is only available if QuickLog is installed/licensed.

- The Make Log task requires a log device number (1-31).

- Only VxFS file systems can be used with a QuickLog device.

- The specified volume cannot contain a file system.

- The size of the specified volume must be at least 32MB.
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Enabling a QuickLog Device for a File System
The QuickLog Enable procedure enables a QuickLog device on a VxFS file system. Before
you enable a QuickLog device, you must designate a volume as a QuickLog volume.

Note You can enable QuickLog on the file system automatically at system startup by
selecting Mount at Boot, and specifying the appropriate options when completing
the New File System dialog box (see Adding a New File System to a Volume).

▼ To enable a QuickLog device for a file system

1. Select the file system on which to enable a QuickLog device.

2. Choose Actions > QuickLog > Enable

3. Complete the Enable QuickLog dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

File System Name: Check that the correct file system name is displayed in this field.

Log Device Number: Select the number of the log device to be enabled for the file
system. Log devices are listed in /dev/qlog.

Make QuickLog enable
persistent (checkbox):

Check to enable QuickLog whenver the File System is mounted.

Notes:

- This task is only available if QuickLog is installed/licensed.

- This task requires a file system name.

- Only VxFS file systems can be used with a QuickLog device.

- The specified QuickLog device must already have a designated QuickLog volume.

- If no log device number is specified, the least-loaded device is used.
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Disabling a QuickLog Device for a File System
The QuickLog Disable procedure disables QuickLog for a VxFS file system.

▼ To disable a QuickLog device for a file system

1. Select the file system to have QuickLog disabled.

2. Choose Actions > QuickLog > Disable.

3. Check that the correct file system name is displayed in the Disable QuickLog dialog
box, then click OK.

Notes:

- The QuickLog Disable task is only available if QuickLog is installed/licensed.

- The QuickLog Disable task requires a file system name.
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Removing a QuickLog Volume
The Quicklog Remove procedure detaches a QuickLog volume from a QuickLog device.
Before you remove a QuickLog volume, you must disable QuickLog for all
QuickLog-enabled file systems using that QuickLog device.

▼ To remove a QuickLog volume

1. Select the QuickLog volume to be detached.

2. Choose Actions > QuickLog > Remove Log.

Check that the correct volume name is displayed in the QuickLog Remove Log dialog box,
then click OK.

Notes:

- The QuickLog Remove task is available only if QuickLog is installed/licensed.

- QuickLog must be disabled for all QuickLog-enabled file systems using the QuickLog
device before the QuickLog volume can be detached.
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Unmounting a File System from a Cluster Node
Unmounting a File System from a Cluster Node
Use the Unmount File System procedure to unmount a VxFS file system on a selected
volume in cluster (shared) mode.

▼ To unmount a cluster file system from a particular volume

1. Select the volume containing the cluster file system to be unmounted.

2. Choose Actions > File System > Unmount File System...

3. Select the nodes to be unmounted from the Unmount Cluster File System dialog box.

▼ To unmount any cluster file system

1. Select the File Systems node; then select the volume that containing the cluster file
system to be mounted.

2. Choose Actions > Unmount File System...

3. Select the nodes to be unmounted from the Unmount Cluster File System dialog box.
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Removing Resource Information for a Cluster File System
The Remove Cluster Mount procedure removes cluster file system resource information
from the cluster configuration file.

Note The cluster file system must be unmounted before performing the Remove Cluster
Mount procedure.

▼ To remove a cluster file system resource information

1. Select the file system.

2. Choose Actions > Remove Cluster Mount.

3. Click Yes to remove the cluster file system resource information from the cluster
configuration file and dissociate the shared volume from the mount point.
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Cluster Tasks
 6

VxVM provides access to cluster-related features only if the optional cluster functionality
is present.

The following tasks are associated with clusters:

◆ Working with Clusters

◆ Creating a Shared Dynamic Disk Group

◆ Importing a Shared Dynamic Disk Group

The Cluster Task Roadmap shows a summary of common cluster tasks.
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Cluster Task Roadmap
The following table provides a summary of common VxVM cluster tasks.

To perform this task … Use this procedure…

Setup Tasks:

Set up a shared disk group Creating a Shared Dynamic Disk Group

Other Tasks:

Access a deported disk group for cluster use Importing a Shared Dynamic Disk Group
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Working with Clusters
VxVM includes an optional cluster feature that enables VxVM to be used in a cluster
environment. To activate the cluster feature, you must obtain a license for the VxVM
cluster functionality.

After adding the cluster license to the machine, you must restart the VxVM server to
enable cluster support. When a cluster license is present on a machine, VxVM displays a
Clusters icon in the object tree (even if the machine is not currently set up as a node in a
cluster). When a cluster is shown in the tree, all active/inactive nodes that are members of
the cluster are displayed in the tree, as shown in “Tree/Grid View of a Cluster.”

Tree/Grid View of a Cluster

◆ To display the objects in a cluster, expand the cluster hierarchy (by clicking on the plus
sign next to the Clusters icon).

◆ To determine which node is the master in a cluster, expand the cluster hierarchy for
the appropriate cluster and select Hosts from the cluster hierarchy. The grid displays
the names and properties of the nodes in the cluster. The Type column indicates which
node is the master.

The Cluster Properties window also indicates which node is the master. To access this
window, select a cluster and choose Properties from the Selected or popup window.
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Working with Clusters
Notes:

- When VxVM is connected to a single host, that host is auto-expanded; that is, the
hierarchy of objects under that host is fully displayed in the dialog.

- If VxVM is connected to more than one host, the hierarchy of objects is not
auto-expanded.
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Creating a Shared Dynamic Disk Group
The New Dynamic Disk Group procedure creates an additional dynamic disk group.
Disks must be placed in dynamic disk groups before they can be used by VxVM. The
default disk group (rootdg) is usually created during VxVM installation and always
exists on a system running VxVM. You can create additional dynamic disk groups to
organize your disks into logical sets of disks.

When you place a disk under VxVM control, the disk is initialized. Initialization destroys
any existing data on the disk. (You can use encapsulation to preserve disk data.)

The steps for creating a new dynamic disk group are:

1. Right-click the Disk Groups folder, or right-click a disk.

2. Select Actions > New Dynamic Disk Group.

The New Dynamic Disk Group wizard screen appears.

3. Click Next to continue. A new screen appears.

4. Enter a name for the dynamic disk group and check the Create Cluster Group
checkbox.

5. If your system supports Activation Mode, then select Activation Mode and choose
the mode from the displayed submenu. Click OK.

6. Select which disks you want to include in the group. Make sure the disks you want to
include are in the right pane of the window, and click Next.

When you have provided all necessary information in the dialog box, click OK.

7. The next screen confirms the disks you have selected. Choose Yes to continue if you
are satisfied with the disk selection. If you are not satisfied, you can click the No
button to go back to the previous screen in order to modify your disk choices.

8. Normally, you would add all the disks you want in the group at this point. You can
always add more disks later with the Add Disk to Dynamic Disk Group command.

Indicate whether the disk should be initialized or encapsulated. If you initialize the
disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any
existing data will be preserved in volumes.

9. If you chose to encapsulate the disk, reboot the system.
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Creating a Shared Dynamic Disk Group
Notes:

u The Add Disk to Dynamic Disk Group task requires a dynamic disk group name and
the name of at least one disk.

u The dynamic disk group name must be unique.

u The new dynamic disk group must contain at least one disk.

u Only disks that are online and do not belong to a dynamic disk group can be used to
create a dynamic disk group.

u The Volume Manager disk name must be unique within the dynamic disk group.

u If multiple disks are specified in the Disk Device(s) field and only one disk name is
specified in Disk Name(s) field, VxVM appends numbers to the disk name so that each
disk name is unique within its dynamic disk group.
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Importing a Shared Dynamic Disk Group
The Import Dynamic Disk Group procedure makes a deported (inaccessible) shared
dynamic disk group and its volumes accessible again. To import a deported dynamic disk
group, you must know the former name of the dynamic disk group, and this name must
not be in use. In addition, at least one disk name formerly assigned to the deported
dynamic disk group must not be in use.

▼ To import a shared dynamic disk group

1. Select the appropriate host machine node.

2. Choose Actions > Import Dynamic Disk Group.

3. Complete the Import Dynamic Disk Group dialog box as follows:

New Name: Enter a new dynamic disk group name in the New Name field. to
change the name of the dynamic disk group at import.

Clear host ID Select Clear host ID to clear the existing host ID stamp on all
disks in the dynamic disk group at import, Do not use this option if
another host is using any disks in the dynamic disk group.

Force Select Force to force the dynamic disk group import when the
host cannot access all disks in the dynamic disk group This option
can be used to import a dynamic disk group that contains a failed
disk, but can lead to dynamic disk group inconsistency if all disks
are still usable.

Import Shared Select Import Shared to import the dynamic disk group as a
shared dynamic disk group, This option is only applicable in a
cluster environment.
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When you have provided all necessary information in the dialog box, click OK.

Notes:

u Only deported dynamic disk groups can be imported.

u A deported dynamic disk group cannot be imported if another dynamic disk group with
the same name has been created since the dynamic disk group was deported.

u When a dynamic disk group is imported, the system stamps its host ID on all disks in the
dynamic disk group. A dynamic disk group import fails if one of the disks is stamped
with a host ID that does not match the others. This ensures that dual-ported disks cannot
be managed (and possibly corrupted) by two systems at the same time. If you are sure that
the dynamic disk group is not in use by another host, you can clear the host IDs and
import the dynamic disk group by selecting the Clear Host ID option.
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Troubleshooting
 7

Select one of the following options for information on alerts, object states, and other
troubleshooting topics. If you are unable to resolve a problem by following the
instructions provided, please contact Customer Support for additional information.

◆ Alerts

◆ Disk Troubleshooting

◆ Volume Troubleshooting

◆ General Troubleshooting

- Client/Server Problems

- Configuration Changes

Alerts
When an object fails or experiences an error, an alert icon appears on the object and the
object state usually changes to an unhealthy state. The unhealthy object also appears in
the Alert Monitor window, which summarizes the problem and indicates whether any
associated objects have problems. When an object enters an unhealthy state and has an
alert, you should review the contents of the Alert Monitor window and then try to correct
the problem. For more information about an object listed in the Alert Monitor window,
review the object Properties window.

❖ To display the Alert Monitor window, click the Alert button in the toolbar.

❖ To view the properties of an object listed in the Alert Monitor window, select the
object and choose Object Properties from the Alert or popup menu. You can also
access object properties by double-clicking on the object.
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Client Java Exceptions and Errors
Client Java Exceptions and Errors
When a client Java exception or error occurs, an error alert icon is displayed on the bottom
of the main window.

Click on this icon to display the Java console containing the text of the errors or
exceptions.
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Disk Troubleshooting
Disk Troubleshooting
The disk state indicates the current condition of a disk. The disk state appears in the state
column of the grid and in the Disk Properties window. When a disk is unhealthy, an alert
icon appears on the disk and the disk is listed in the Alert Monitor window. Disk states
can be one of the following:

- Disk State: Imported

- Disk State: Free

- Disk State: Not Setup

- Disk State: Import Failed

- Disk State: Disconnected

- Disk State: Deported

- Disk State: Offline
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Disk Troubleshooting
- Disk State: Not Initialized

- Disk State: Locked

- Disk State: Inactive

- Disk State: Foreign Owned

Disk State: Imported

The disk is accessible and has no known problems. The disk is under VxVM control and
belongs to a dynamic disk group. This is the normal disk state. No user action is required.

Disk State: Free

The disk is freely available. A disk that is freely available is under VxVM control, but does
not belong to a dynamic disk group.

◆ To make the disk available for VxVM use, add the disk to a dynamic disk group.
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Disk Troubleshooting
Disk State: Not Setup

The disk is not under VxVM control.

❖ To make the disk available for VxVM use, place the disk under VxVM control and add
the disk to a dynamic disk group.

Disk State: Import Failed

The disk was previously under VxVM control, but VxVM cannot access the disk and/or
configuration information for the disk. The disk is not available for use. This can happen
after you upgrade VxVM. This can also happen if some disks are inaccessible at system
startup.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the
computer. Repair any disk, controller, or cable problems. Scan the disks on the system
(Actions > Rescan) to make sure that VxVM recognizes all attached hardware. Try to
import the dynamic disk group for the disk.

❖ If the dynamic disk group is imported and the disk does not have a VxVM disk name,
place the disk under VxVM control and add the disk to a dynamic disk group.

Disk State: Disconnected

The connection between the VxVM disk and the underlying physical disk (device) is
broken. This can occur when a disk fails or when you disconnect a disk.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the
computer. Repair any disk, controller, or cable problems. Scan the disks on the system
(Actions > Rescan) to make sure that VxVM recognizes any newly attached
hardware.

❖ Try to reconnect the disconnected VxVM disk to its physical disk (using the Replace
Disk task).

❖ If you cannot fix the problem, replace the disk with another physical disk.
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Disk State: Deported

The disk belongs to a dynamic disk group that is currently deported. The disk is not
available for use in the deported dynamic disk group and cannot be added to a new
dynamic disk group.

❖ To return the disk to a usable state, import the dynamic disk group for the disk.

❖ To move the disk to another dynamic disk group, import the current disk group,
remove the disk, and add the disk to a new dynamic disk group.

❖ If the disk group import fails and you want to free the disk space for use in other
dynamic disk groups, you can use the Initialize Disk task.

Caution This command overwrites the disk header and configuration information on
the disk. Any volume copies or regions located on the disk are not accessible
after you reinitialize the disk.

Disk State: Offline

VxVM cannot access the disk.

❖ To return the disk to an accessible state, bring the disk online.

Disk State: Not Initialized

A configuration error prevents the disk from being used.

❖ To make the disk available for VxVM use, place the disk under VxVM control and add
the disk to a dynamic disk group.

❖ If the disk cannot be added to VxVM, it can be necessary to reinitialize the disk with
the Initialize Disk task.

Caution This command overwrites the disk header and configuration information on
the disk. Any volume copies or regions located on the disk are not accessible
after you reinitialize the disk.

Disk State: Locked

The disk belongs to a dynamic disk group that is currently imported by another machine
or was last imported by another machine and was not deported cleanly. The disk is not
currently usable on the local machine.
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❖ To make all of the disks in the dynamic disk group available for use on the local
machine, deport the disk group on the remote machine and then import the dynamic
disk group on the local machine.

❖ To make one disk available for use on the local machine, remove the disk from its
dynamic disk group (on the other machine) and add it to a dynamic disk group on the
local machine.

❖ If the dynamic disk group is not imported on another machine, it can be necessary to
re-import the dynamic disk group and clear the host ID on all disks in the dynamic
disk group. You can do this by selecting the Clear Host ID option in the Import Disk
Group dialog box.

Caution If any of the disks in the dynamic disk group are in use by another machine, this
command can cause the disks to be managed by two systems at the same time,
which can lead to corruption.

Disk State: Inactive

The disk appears to belong to a dynamic disk group, but is not active in the disk group.
The disk may have become (temporarily) inaccessible. Alternatively, the disk may have
been inaccessible at dynamic disk group import, but may be accessible now.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the
computer. Repair any disk, controller, or cable problems. Scan the disks on the system
(Rescan) to make sure that VxVM recognizes any newly attached hardware.

❖ It may be necessary to reattach the disk to its dynamic disk group with the Replace
Disk task.

After a successful reattach, volume recovery can be necessary.

❖ If the reattach fails and you want to free the disk space for use, you can use the
Initialize Disk task.

Caution This command overwrites the disk header and configuration information on
the disk. Any volume copies or regions located on the disk is not accessible after
you reinitialize the disk.

Disk State: Foreign Owned

The disk is under the control of another disk management product. The disk is not
available for use with VxVM.
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❖ To make the disk available for VxVM use, remove the disk from the other disk
management product control and place the disk under VxVM control.
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Volume Troubleshooting
Volume Troubleshooting
The volume state indicates the current condition of a volume. The volume state appears in
the state column of the grid and in the Volume Properties window. When a volume is
unhealthy, an alert icon appears on the volume and the volume is listed in the Alert
Monitor window. Unhealthy states include:

◆ Volume State: Started

◆ Volume State: Stopped

◆ Volume State: Uninitialized

◆ Volume State: Degraded

◆ Volume State: Unusable

Volume State: Started

The volume is accessible and has no known problems. This is the normal volume state. No
user action is required.

Volume State: Stopped

The volume is disabled and is not available for use.

❖ To return the volume to a usable state, start the volume.

Volume State: Uninitialized

The volume is enabled, but is not initialized. If this state appears during volume creation,
no user action is necessary.

❖ To put the volume in a usable state, start the volume.
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Volume State: Degraded

The RAID-5 volume is in a degraded mode. This usually occurs when one or more
subdisks are unavailable and read requests require data reconstruction. An underlying
disk may have failed completely or there may be I/O errors on part of a disk.
Alternatively, an underlying disk may be disconnected.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the
computer. Repair any disk, controller, or cable problems. Scan the disks on the system
(Rescan) to make sure that VxVM recognizes any newly attached hardware.

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If there has been a partial or complete disk failure, either replace the disk or move the
affected subdisks to another disk.

Volume State: Unusable

The RAID-5 volume is unusable. This usually occurs when there is a double disk failure
(that is, when two subdisks in the same stripe or the parity and one subdisk in a stripe are
damaged or inaccessible). The underlying disks may have failed or become inaccessible.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the
computer. Repair any disk, controller, or cable problems. Scan the disks on the system
(Rescan) to ensure that VxVM recognizes any newly attached hardware.

Run the following command to reattach the disks to their disk group:

# /etc/vx/bin/vxreattach [device_name]

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If two of the volume disks have failed, the RAID-5 volume data is unusable. Replace
the failed disks and then try to restart the volume by running the following command:

# vxvol -f start volume_name

Restore the volume from backup.

To prevent this problem in the future, enable logging for RAID-5 volumes.

General Troubleshooting
General troubleshooting includes:

◆ Client/Server Problems

◆ Configuration Changes
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Client/Server Problems

User is not authorized to connect to the server.

This error can occur for the following reasons:

◆ The user name is incorrect.

◆ The password is incorrect.

◆ The user does not have an account on the machine.

◆ The password and group files or NIS tables do not contain entries for the user.

◆ The user is not listed in the vrtsadm group entry.

❖ Enter the user name and password again. If the same error appears, ask the
administrator of the machine to make sure that your user name is included in the
vrtsadm group entry and your user name and password are entered correctly in the
appropriate password and group files or NIS tables.

There is no such server.

The specified host machine does not exist or is not in the Domain Name System (DNS).

❖ Check the machine name and enter the machine name again.

Unable to connect to the server.

The VEA system may not be running on the machine to be administered.

❖ Make sure the server is running and the client and server are properly configured. If
necessary, restart the VEA system.

Possible client/server versions mismatch.

The VEA client and server versions may be incompatible.

❖ Check the client and server versions using the following commands:

# vea -V
# vxsvc -V

If necessary, upgrade the client or server.

Server connection lost.

The VEA service has been stopped.
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❖ Restart the server.

The server seems to have multiple addresses.

The server (host) may be known by multiple addresses.

❖ Try to specify one of the server IP addresses as the server host name.

Configuration Changes
VxVM is dynamic, so it automatically displays new objects or changes to existing objects
on the system. These changes or additions are usually reflected in VEA immediately (or
within a short time).

If you add objects (such as new disks) to the system and VxVM does not display these
objects within a short time, you can force VxVM to check for new objects in one of the
following ways:

1. Scan the disks on the system (Rescan Disks) to make sure that VxVM recognizes any
newly attached hardware.

2. Update the system configuration database.
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Icons
 8

The following tables show icons that appear in VxVM VEA:

◆ Object Icons

◆ Toolbar Icons

◆ Task Status Icons

◆ Performance Monitoring Icons

◆ Miscellaneous Icon

Object Icons

Icon Description

host

connect/disconnect host

mirror

log

disk
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Object Icons
subdisk

disk group

volume

new volume

Stopped volume

Quicklog volume

task log

controller

enclosure (disk array)

file system - snapshot

file system - not mounted

file system - mounted

cluster node

Icon Description
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Toolbar Icons
Toolbar Icons

Icon Description

Alert Monitor window

Search

Properties

Search window

New Volume dialog box

Print dialog box

collapse/expand disks

collapse/expand volumes

projection
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Task Status Icons
Task Status Icons

Performance Monitoring Icons

Miscellaneous Icon

Icon Description

Exited task

Icon Description

Low I/O Activity

Normal I/O Activity

High I/O Activity

Critical I/O Activity
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Miscellaneous Icon
Icon Description

alert

error message

information

question

warning
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Glossary
alert

An indication that an error or failure has occurred on an object on the system. When an object fails

or experiences an error, an alert icon appears.

alert icon

An icon that indicates that an error or failure has occurred on an object on the system. Alert icons

usually appear in the status area of the main window and on the group icon of the affected object.

Alert Monitor

A window that provides information about objects that have failed or experienced errors.

browse dialog box

A dialog box that is used to view and/or select existing objects on the system. Most browse dialog

boxes consist of a tree and grid.

button

A window control that the user clicks to initiate a task or display another object (such as a window

or menu).

CFS

Cluster file system. A VxFS file system mounted on a selected volume in cluster (shared)
mode.

check box

A control button used to select optional settings. A check mark usually indicates that a check box is

selected.

children

Objects that belong to an object group.
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cluster

A set of host machines (nodes) that shares a set of disks.

cluster file system

See CFS.

command log

A log file that contains a history of VERITAS Volume Manager (VxVM) tasks performed in the

current session and previous sessions. Each task is listed with the task originator, the start/finish

times, the task status, and the low-level commands used to perform the task.

device name

The physical disk device name (or disk access name).

dialog box

A window in which the user submits information to VxVM. Dialog boxes can contain selectable

buttons and/or fields that accept information.

disk group

A set of disks that are under VxVM control and share a common configuration. A disk group

configuration is a set of records containing detailed information on existing VERITAS Volume

Manager objects (such as disk and volume attributes) and their relationships. Each disk group has

an administrator-assigned name. The root disk group (rootdg) is a special private disk group that

always exists. Volumes can only be created on disks that belong to disk groups.

disk name

The VERITAS Volume Manager disk name (or disk media name). This is the logical name given to

the disk by VxVM or the administrator.

dock

To separate or attach the main window and a subwindow.

enclosure

A disk array.

gap

A disk region that does not contain VERITAS Volume Manager objects (subdisks).
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graphical view

A window that displays a graphical view of objects. In VxVM, the graphical views include the

Object View window and the Volume Layout Details window.

grid

A tabular display of objects and their properties. The grid lists VERITAS Volume Manager objects,

disks, controllers, or file systems. The grid displays objects that belong to the group icon that is

currently selected in the object tree. The grid is dynamic and constantly updates its contents to

reflect changes to objects.

group icon

The icon that represents a specific object group.

GUI

Graphical User Interface.

host

A machine or system.

launch

To start a task or open a window.

main window

The main VERITAS Volume Manager window. This window contains a tree and grid that display

volumes, disks, and other objects on the system. The main window also has a menu bar, a toolbar,

and an optional Command Launcher.

menu

A list of options or tasks. A menu item is selected by pointing to the item and clicking the mouse.

menu bar

A bar that contains a set of menus for the current window. The menu bar is typically placed across

the top of a window.

mirror

A copy of a volume and its data. There can be several mirrors per volume. The terms mirror and

plex are used synonymously.
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node

In the VxVM tree, a node is an element attached to the tree.

In a cluster environment, a node is a host machine in a cluster.

object group

A group of objects of the same type. Each object group has a group icon and a group name. In

VxVM, object groups include disk groups, disks, volumes, controllers, free disk pool disks,

uninitialized disks, and file systems.

object tree

A dynamic hierarchical display of VERITAS Volume Manager objects and other objects on the

system. Each node in the tree represents a group of objects of the same type.

Object View Window

A window that displays a graphical view of the volumes, disks, and other objects in a particular

disk group. The objects displayed in this window are automatically updated when object properties

change. This window can display detailed or basic information about volumes and disks.

plex

A copy of a volume and its data. There can be several plexes per volume. The terms mirror and plex
are used synonymously.

popup menu

A context-sensitive menu that only appears when you click on a specific object or area.

properties window

A window that displays detailed information about a selected object.

radio buttons

A set of buttons used to select optional settings. Only one radio button in the set can be selected at

any given time. These buttons toggle on or off.

read-only mode

Read-only mode allows you to view objects on the system through VxVM, but prevents

administrative actions from taking effect.

scroll bar

A sliding control that is used to display different portions of the contents of a window.
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Search window

The VERITAS Volume Manager search tool. The Search window provides a set of search options

that can be used to search for objects on the system.

Selected menu

A context-sensitive menu that changes its menu options to match the type of object that is selected.

By default, the Selected menu is greyed out. When an object is selected, the Selected menu

provides access to tasks appropriate for the selected object.

splitter

A bar that separates two panes of a window (such as the object tree and the grid). A splitter can be

used to adjust the sizes of the panes.

status area

An area of the main window that displays an alert icon when an object fails or experiences some

other error.

subdisk

A set of contiguous disk blocks that form a logical disk segment. Subdisks are associated with

plexes (mirrors) to form volumes.

task properties window

A window that displays detailed information about a task listed in the Task Request Monitor

window.

Task Request Monitor

A window that displays a history of tasks performed in the current VERITAS Volume Manager

session. Each task is listed with the task originator, the task status, and the start/ finish times for the

task.

toolbar

A set of buttons used to access VERITAS Volume Manager windows. These include another main

window, a task request monitor, an alert monitor, a search window, and a customize window.

tree

A dynamic hierarchical display of objects on the system. Each node in the tree represents a group

of objects of the same type.

uninitialized disks

Disks that are not under VxVM control.
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volume

A virtual disk or entity that is made up of portions of one or more physical disks.

Volume Layout Details Window

A window that displays a graphical view of a volume and its components. The objects displayed in

this window are not automatically updated when the volume properties change.

Volume to Disk Mapping Window

A window that displays a tabular view of volumes and their underlying disks. This window can also

display details such as the subdisks and gaps on each disk.

VxFS

VERITAS File System.

VxVM

VERITAS Volume Manager.
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Index
A
activating dynamic disk groups 72
activation mode 143
adding

disks 38
file systems 121

alert interval 131
alerts

icons 5
on disks 149
on volumes 155

associating plexes 112

B
backing up file systems 128
boot disk

mirroring 43

C
changing volume layouts 94
checking file systems 129
client 9
cluster file system

unmounting 137
cluster nodes

cluster mounting file system on 125
clusters

creating shared disk groups 143
importing disk groups 145

command log 24
commands, viewing 23
concatenated volumes 78, 83
controllers

disabling 52
enabling 53

creating
dynamic disk groups 55
file systems 121
shared disk groups 143

volumes 78, 83
Critical Usage 11

D
deporting dynamic disk groups 59
destroying dynamic disk groups 66
dialog information panel 32
dialog preferences 31
dirty region logging 99
disabling

controllers 52
disconnecting

disks 45
disk

phaseout 31
disk arrays, renaming 54
disk groups

creating 143
importing 145
restoring access 145
task roadmap 37

disk usage 11
disk view 32
disks

adding 38
adding to Volume Manager 38
alternate boot disk 43
boot 43
changing names 54
disconnecting 45
encapsulating 39
forced initialization 50
initializing 39, 50
maintenance tasks 7
mirroring 43
names, changing 41
new 38
online 42
placing under Volume Manager control
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38
properties 20, 51
recovering 48
reinitializing 50
removing 49
renaming 41
restoring access 42
setup tasks 6
states 149
task roadmap 37
troubleshooting 50, 149
Volume Manager 38
volume mapping 11, 18

displaying
commands 23
disk properties 51
dissociated objects 14
dynamic disk group properties 74
file system properties 132
object properties 10
Object Properties window 20
objects 10
volume properties 118

dissociated objects, displaying 14
drag and drop subdisks 33
dynamic disk group name, changing 58
dynamic disk group versions 57
dynamic disk groups

activating 72
adding disks 38
clearing hot relocation information 64
creating 55
deporting 59
destroying 66
importing 60
joining 71
moving objects between 67
preventing access 59
properties 74
recovering volumes 61
removing 66
removing disks 49
renaming 58
restoring access 60
splitting 67, 69
upgrading 57

Dynamic volumes
extending 91

E
enabling controllers 53
encapsulating disks 39
enclosures, renaming 54
errors. See alerts
Extend a dynamic volume 91
Extend Volume command 91

F
File 4
File menu 4
file system size, changing 127
file system task roadmap 120
file systems

and volumes 121, 125
backup 128
checking 129
creating 121
maintenance tasks 7
monitoring capacity 131
repair tasks 8
repairing 129
resizing 127
setup tasks 6
snapshot copies 128
task roadmap 120
unmounting 126, 127, 138

free space 18

G
graphical view

object view window 10, 11
volume layout details 15, 17

grid
and tree view 10, 11
defined 4

H
help 4
Help menu 4
High Usage 11
hosts

accessing multiple hosts 2
defined 3

hot relocation 62
clearing dynamic disk group
information 64

hot spares 62

I
icons
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Task Status 162
If 39
importing

dynamic disk groups 60
shared disk groups 145

initializing disks 39, 50

J
joining

dynamic disk groups 71

L
layered volumes 79
Load balancing

subdisk move 30
logs

adding to volumes 99
command log 24
disabling 110
QuickLog 133, 134
removing 110

M
main window

description of 2
status area 5

maintenance tasks 6
making multiple selections 22
menus

Help 4
Options 4
preferences 4
types of 4
window 4

mirrored 90
mirrored volumes 79
mirroring

disks 43
volumes 97

mirrors
adding to volumes 97
removing 108

mixed layout volumes 79
monitoring

alerts 5
performance 19

monitoring capacity 131
mounting file systems 125
moving

subdisks 14

Moving a subdisk 113
multiple host support 2

N
Normal Usage 11

O
object properties

displaying 20, 51, 74, 118, 132
in grid 11
window 20

object tree 3
objects

displaying 10
viewing 10

online disks 42
Options menu 4

P
performance monitoring 19
Performance tuning

Statistics tab display 28
placing disks under Volume Manager
control 38
plexes

See also mirrors
associating 112

preferences 31
Options menu 4
setting 4

projection 13
properties 11

 118
disk 51
Disk Properties window 51
dynamic disk groups 74
File System Properties window 132
in grid 11
viewing objects

properties 20, 74
volumes 118, 132

Q
QuickLog 133

device 134

R
RAID-5 89
RAID-5 logging 99
RAID-5 volumes 78
recovering
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disks 48
volumes 8, 48, 61, 107

recovery tasks 8
relayout 94
remote administration 1
removing

disks 49
dynamic disk groups 66
logs 110
volumes 111

renaming
disk arrays 54
disks 41
dynamic disk groups 58
enclosures 54
volumes 92

resizing
file systems 127

restarting and recovering volumes 100
roadmap, disk task 37
root disk

mirroring 43

S
Search/Report 24
security 10
selecting objects 22
selections

multiple 22
server 9
setting up your system 9
setting usage threshold 131
setup tasks 5
shared disk groups 143, 145
snapshot copies of file systems 128
snapshot copies of volumes 100
snapshots

copy of file system 128
copy of volume 100
dissociating 104, 105
merging 103

splitter 4
splitting

dynamic disk groups 67, 69
subdisks 114

splitting subdisks 114
starting VEA 10
statistics

viewing 29, 30

Statistics tab view 28
status area 5
stopping volumes 100
striped 87
striped volumes 78
Subdisk Move command 113
Subdisks

numbering 116
subdisks

graphical view 15, 17
moving 14, 113
splitting 114
viewing 15, 17

system
setup 9

T
task dialogs 33
tasks

disk maintenance 7
disk setup 6
displaying 23
file system maintenance 7
list 5
maintenance 6
properties 24
recovery 8
repair 8
request monitor window 23
roadmap 5
setup 5
throttling 24
viewing 23
volume maintenance 7
volume recovery 8
volume repair 8
volume setup 6

threshold percentage 131
Toolbar 4
tree

and grid view 10, 11
object 3

troubleshooting
disk states 149
volume states 155

U
unmounting file systems 126, 127, 138
usage legend 11
174 VERITAS Volume Manager User’s Guide - VEA



V
VEA

starting 10
view preferences 31
viewing commands 23
viewing objects

and object properties 10
graphical view 15, 17
properties 51, 118, 132
tree and grid 11

viewing real-time statistics 29, 30
viewing tasks 23
Volume Layout Details window

described 10, 15, 17
volume layouts 78, 94
volume name, changing 92
volume states 155
volume task roadmap 76
volume to disk mapping window 11, 18
volumes

adding file systems 121
adding logs 99
adding mirrors 97
and file systems 121, 125
associating plexes 112
backup and restore 105
changing layout 94
concatenated 78, 83
concatenated pro 79
creating 78, 83
disabling 100
disk mapping 11, 18
dissociating snapshots 104, 105
graphical view 10, 15, 17
layered 79
layout 10
maintenance tasks 7
merging snapshots 103
mirrored 79, 90
mixed layout 79

mounting file systems 125
preparing to restore 105
properties 20, 118, 132
RAID-5 78, 89
recovering 48, 61, 107
recovering/restarting 100
recovery tasks 8
relayout 94
removing logs 110
removing mirrors 108
removing volumes 111
renaming 92
repair tasks 8
setup tasks 6
snapshot copies 100
splitting subdisks 114
stopping 100
striped 78, 87
striped pro 79
task roadmap 76
troubleshooting 155
underlying disks 11, 18
unmounting file systems 126, 127, 138

VRTSexplorer xi
VxVM

obtaining system information xi

W
window menu 4
window preferences 31
windows

graphical view 15, 17
main window 2
object properties 11, 20
object view 11
resizing 4
volume layout details 15, 17
volume to disk mapping window 18

wizard mode 32
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