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Preface

Introduction
This guide describes how to use the VERITAS Volume Manager Storage Administrator™

(VMSA). The VERITAS Volume Manager Storage Administrator is the graphical user

interface (GUI) for the VERITAS Volume Manager™ (VxVM).

Audience
This guide is intended for system administrators responsible for configuring and

maintaining systems using VxVM. This guide assumes the following:

◆ A basic understanding of system administration

◆ A working knowledge of the UNIX operating system

◆ Familiarity with VxVM and related concepts

Organization
This guide is organized as follows:

◆ Chapter 1, “Introduction to the Storage Administrator,” describes the main

components of VMSA.

◆ Chapter 2, “Getting Started,” describes how to set up and start using VERITAS

Volume Manager Storage Administrator.

◆ Chapter 3, “Disk Tasks,” describes how to set up and use disks with VERITAS Volume

Manager Storage Administrator.

◆ Chapter 4, “Volume Tasks,” describes how to create and use volumes and related

objects with VERITAS Volume Manager Storage Administrator.

◆ Chapter 5, “Host and Cluster Tasks,” describes how to access and use hosts and

clusters with VERITAS Volume Manager Storage Administrator.
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◆ Chapter 6, “Troubleshooting,” provides information about VERITAS Volume

Manager Storage Administrator alerts, object states, and other troubleshooting topics.

◆ The Glossary defines terms that relate to VERITAS Volume Manager Storage

Administrator.

Related Documents
The following documents provide related information:

◆ VERITAS Volume Manager Administrator’s Guide

◆ VERITAS Volume Manager Troubleshooting Guide

◆ VERITAS Volume Manager Installation Guide

◆ VERITAS Volume Manager Release Notes

◆ VERITAS Volume Manager Hardware Notes

◆ VERITAS Volume Manager and VERITAS Volume Manager Storage Administrator

manual pages
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Conventions

Conventions
The following table describes the typographic conventions used in this guide.

The following table describes terms associated with the use of the mouse:

Typeface Usage Examples

monospace Computer output, file contents,

files, directories, software

elements such as command

options, function names, and

parameters

Read tunables from the

/etc/vx/tunefstab  file.

See the ls (1) manual page for more

information.

italic New terms, book titles,

emphasis, variables to be

replaced by a name or value

See the User’s Guide for details.

The variable ncsize determines the

value of...

monospace
(bold )

User input; the “#” symbol

indicates a command prompt

# mount -F vxfs /h/filesys

monospace
(bold and italic )

Variables to be replaced by a

name or value in user input

# mount -F fstype mount_point

Symbol Usage Examples

% C shell prompt

$ Bourne/Korn/Bash shell

prompt

# Superuser prompt (all shells)

\ Continued input on the

following line

# mount -F vxfs \

/h/filesys

 [] In a command synopsis, brackets

indicates an optional argument

ls [ -a  ]

 | In a command synopsis, a

vertical bar separates mutually

exclusive arguments

mount [suid  | nosuid ]

Term Definition

Click Press and release the mouse button.

Double-click Click the mouse button twice (quickly).

Right-click Press and release the right mouse button.



Conventions

xiv VERITAS Volume Manager Storage Administrator Administrator’s Guide

Press and Hold Press and continue to hold down the mouse button.

Point Move the tip of the pointer onto an item on the screen.

Select Click the mouse button while the pointer is directly over the item to be

selected.

Drag Slide the mouse while pressing a mouse button.

Term Definition
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Getting Help
If you have any comments or problems with the VERITAS products, contact the VERITAS

Technical Support:

◆ U.S. and Canadian Customers: 1-800-342-0652

◆ International Customers: +1 (650) 527-8555

◆ Email: support@veritas.com

For license information (U.S. and Canadian Customers):

◆ Phone: 1-925-931-2464

◆ Email: license@veritas.com

◆ Fax: 1-925-931-2487

For software updates:

◆ Email: swupdate@veritas.com

For additional technical support information, such as TechNotes, product alerts, and

hardware compatibility lists, visit the VERITAS Technical Support Web site at:

◆ http://support.veritas.com (U.S. and Canada Customers)

For additional information about VERITAS and VERITAS products, visit the Web site at:

◆ http://www.veritas.com

Downloading and Running VRTSexplorer

If you have access to the Internet, you can use the VRTSexplorer  program to assist

Technical Support in diagnosing the cause of your problem as follows:

1. Use a web browser or the ftp program to download the VRTSexplorer program at

the following URL:

ftp://ftp.veritas.com/pub/support/vxexplore.tar.Z

Save the file to a temporary directory such as /tmp  as shown in these instructions. If

you download the file to a different directory, substitute its pathname for /tmp
throughout .

2. Log in as root on the affected system, and use the following commands to extract

the contents of the downloaded file to the directory /tmp/VRTSexplorer :

# cd /tmp
# zcat vxexplore.tar.Z | tar xvf -

http://support.veritas.com
http://www.veritas.com
ftp://ftp.veritas.com/pub/support/vxexplore.tar.Z
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3. Run the VRTSexplorer  program located in the VRTSexplorer directory by entering

the following command:

# /tmp/VRTSexplorer/VRTSexplorer

4. When VRTSexplorer  prompts you for a destination directory for the information

that it collects, press Return to accept the default directory /tmp , or enter a pathname

of your own choice. VRTSexplorer  writes the results of its investigations to a

compressed tar file named VRTSexplorer. case_number.tar.Z  in the specified

directory.

5. Use the file upload facility of your web browser or the ftp program to transfer the file

output by VRTSexplorer  to the VERITAS Customer Support anonymous FTP site:

ftp://ftp.veritas.com/incoming

6. Call VERITAS Customer Support on 1-800-342-0652, inform them that you have run

VRTSexplorer and tell them the name of the file that you transferred to the FTP site.

Alternatively, if you have already been assigned a call ID number by Customer

Support, e-mail support@veritas.com  including your case ID number in the

subject line.

For more information about the VRTSexplorer program, consult the READMEfile located

in the VRTSexplorer  directory.

ftp://ftp.veritas.com/incoming
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Introduction

This chapter provides a brief introduction to the VERITAS Volume Manager Storage

Administrator (VERITAS Volume Manager Storage Administrator). This chapter

describes the main components of VERITAS Volume Manager Storage Administrator and

contains a summary of common tasks.

The following topics are discussed in this chapter:

◆ The Volume Manager Storage Administrator

- Storage Administrator Features

◆ The Main Window

- The Object Tree and Grid

- The Menu Bar

- The Toolbar

- The Status Area

- The Command Launcher

◆ Storage Administrator Icons

◆ Task Roadmap

- Setup Tasks

- Maintenance Tasks

- Repair/Recovery Tasks
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The Volume Manager Storage Administrator
VERITAS Volume Manager Storage Administrator is the graphical user interface for

VERITAS Volume Manager (VxVM). You can use VERITAS Volume Manager Storage

Administrator to administer disks, volumes, and file systems on local or remote machines.

VERITAS Volume Manager Storage Administrator is a Java-based interface that consists

of a server and a client. The VERITAS Volume Manager Storage Administrator server runs

on a UNIX machine that is running VxVM. The VERITAS Volume Manager Storage

Administrator client runs on any machine that supports the Java Runtime Environment.

Storage Administrator Features
VERITAS Volume Manager Storage Administrator provides the following features:

◆ Ease of Use

VERITAS Volume Manager Storage Administrator is a task-based user interface that

provides access to tasks through menus or a task list. With VERITAS Volume Manager

Storage Administrator, administrators can easily navigate and configure their

systems. Administrators can use VERITAS Volume Manager Storage Administrator to

browse through all of the objects on the system or view detailed information about a

specific object.

◆ Remote Administration

With VERITAS Volume Manager Storage Administrator, administrators can perform

VxVM administration remotely or locally. The VERITAS Volume Manager Storage

Administrator client runs on UNIX or Windows machines.

◆ Java-based Interface

The VERITAS Volume Manager Storage Administrator client is a pure Java-based

interface. Administrators can run VERITAS Volume Manager Storage Administrator

as a Java application.

◆ Scalability

VERITAS Volume Manager Storage Administrator can handle systems containing a

large number of disks. Administrators can view all of the objects on the system or

focus on a specific object or set of objects.

◆ Security

VERITAS Volume Manager Storage Administrator can only be run by users with

appropriate privileges. Administrators can restrict the use of VERITAS Volume

Manager Storage Administrator to a specific set of users. VERITAS Volume Manager

Storage Administrator does not support communication between the client and

server across a firewall.
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The Volume Manager Storage Administrator

◆ Read-only Mode

Administrators can run VERITAS Volume Manager Storage Administrator in

read-only mode, which is useful for monitoring, training, or browsing purposes.

Read-only mode allows administrators to view objects on the system, but prevents

administrative actions from taking effect.
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◆ Multiple Host Support

The VERITAS Volume Manager Storage Administrator client can provide

simultaneous access to multiple host machines. The administrator can use a single

VERITAS Volume Manager Storage Administrator client session to connect to

multiple hosts, view the objects on each host, and perform administrative tasks on

each host. Each host machine must be running the VERITAS Volume Manager Storage

Administrator server.

◆ Multiple Views of Objects

VERITAS Volume Manager Storage Administrator provides multiple views of objects:

- The main window tree and grid view lists objects on the system.

- The Object View window displays a graphical view of volumes, disks, and other

objects in a disk group.

- The Volume Layout Details window displays a close-up graphical view of a single

volume and its components.

- The Volume to Disk Mapping window shows the relationships between volumes

and their underlying disks.
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The Main Window

The Main Window
The VERITAS Volume Manager Storage Administrator main window (see “Main

Window” on page 6) consists of:

◆ a hierarchical tree of objects

◆ a grid that lists objects and their properties

◆ a menu bar

◆ a toolbar

◆ a status area

◆ a Command Launcher (hidden by default)

The toolbar and Command Launcher can be separated from and reattached to the main

window (this is known as docking). The grid can be replicated in a separate window.
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Main Window

Grid

Menu Bar

Toolbar

Object
Tree

Splitters

Command
Launcher
(optional)

Status Area
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The Main Window

The Object Tree and Grid
The VERITAS Volume Manager Storage Administrator main window is divided into two

main panes:

◆ Left Pane (Object Tree)

The left pane contains the object tree, which is a dynamic hierarchical display of

VERITAS Volume Manager objects and other objects on the system. Each node in the

tree represents a group of objects of the same type. Each object group has a group icon

and a group name.

The following object groups typically appear as nodes in the object tree:

- Hosts  – Any host machines connected to the current VERITAS Volume Manager

Storage Administrator client session.

- Controllers  – All controllers on the system.

- Disk Groups  – All disk groups on the system.

- Disks  – All disks on the system.

- Enclosures  – All enclosures (disk arrays) on the system.

- File Systems  – All mounted file systems on the system.

- Free Disk Pool  – Any disks that are under VxVM control, but do not belong to a

disk group.

- Uninitialized Disks  – Any disks that are not under VxVM control.

- Volumes  – All volumes on the system.

- Clusters (optional) – Sets of hosts that share sets of disks. Clusters are only visible

in a cluster environment with the optional VERITAS Volume Manager cluster

functionality.

You can expand nodes (by clicking on the plus sign) to reveal the hierarchy under

each node. When you select a group icon (or node) in the object tree, objects of that

type appear in the right pane.

◆ Right Pane (Grid)

The right pane contains a grid, which is a tabular display of objects and their

properties. The grid displays objects that belong to the group icon that is currently

selected in the object tree (left pane). The grid is dynamic and constantly updates its

contents to reflect changes to objects.

You can sort the contents of a property column in the grid by clicking on the column

heading. You can reverse the sort order by clicking on the column heading again.
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The splitter is the vertical bar that separates the object tree from the grid. You can resize

the left and right panes by pressing and holding the mouse button over the splitter and

dragging the splitter to the left or right.

The Menu Bar
The menu bar at the top of the main window contains the following menus:

◆ File

The File menu provides access to the New menu, which creates volumes, disk groups,

and file systems. The File  menu also establishes new host connections, prints the

contents of the main window, closes the main window, provides access to an object

Properties window, or exits VERITAS Volume Manager Storage Administrator.

◆ Options

The Options  menu provides access to the Customize window, which displays and

sets user preferences for the VERITAS Volume Manager Storage Administrator

components. The Options  menu also saves or loads user preferences, removes any

alert icons from the status area, and sets VERITAS Volume Manager Storage

Administrator to read-only mode.

◆ Window

The Window  menu opens (launches) another VERITAS Volume Manager Storage

Administrator main window, the Task Request Monitor window, the Alert Monitor

window, the Object Search window, a copy of the main grid, or the Command

Launcher.

◆ Selected  (context sensitive)

The Selected  menu is a context-sensitive menu that launches tasks on a selected

object. The Selected  menu is dynamic and changes its options based on the type of

object that is selected. By default, the Selected menu is greyed out. When an object is

selected, the Selected  menu is renamed and provides access to tasks appropriate for

the selected object. For example, Selected  becomes Volumes  when a volume is

selected. The Volumes  menu provides access to volume tasks.

◆ Help

The Help menu provides access to online help for VERITAS Volume Manager Storage

Administrator.
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The Main Window

The Toolbar
The toolbar consists of the following set of buttons:

◆ Volume Manager Storage Administrator (VERITAS Volume Manager Storage

Administrator)

The VERITAS Volume Manager Storage Administrator button launches an additional

VERITAS Volume Manager Storage Administrator main window.

◆ Task

The Task  button launches the Task Request Monitor window. The Task Request

Monitor window displays a list of tasks performed in the current session. Each task is

listed with the user who performed the task, the task status, and the start and finish

times for the task.

◆ Alert

The Alert  button launches the Alert Monitor window. The Alert Monitor window

identifies any objects that have experienced failures or errors and describes the

problems. When an object fails or experiences an error, an alert icon appears in the

status area of the main window and/or on the object icon.

◆ Search

The Search  button launches the Object Search window, which is used to search for

objects on the system. The Object Search window contains a set of tabbed pages, each

of which contains search options for a particular type of object.

◆ Grid

The Grid  button launches a window that contains a copy of the main grid. The new

grid window continues to display and update the objects shown when the grid copy

was created.

◆ New

The New button launches the New Volume dialog box. This dialog box is used to

create a volume.

◆ Host

The Host  button launches the Connect to Host dialog box. This dialog box is used to

establish a connection to a host machine.

◆ Properties (Props )

The Props  button launches the Object Properties window for a selected object. The

Object Properties window displays detailed information about the selected object and

related objects.
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◆ Print

The Print button launches the Print dialog box for a selected object. This dialog box is

used to print details about a specific object.

◆ Customize (Custm )

The Custm  button launches the Customize window, which is used to set user

preferences. The Customize window allows you to customize the appearance of the

components of VERITAS Volume Manager Storage Administrator. The Customize

window contains a set of tabbed pages, each of which contains preference options for

a particular aspect of VERITAS Volume Manager Storage Administrator.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to

separate the toolbar from the main window or move the toolbar to the bottom, side, or top

of the main window. To reposition the toolbar, press and hold the mouse button over the

toolbar handle and drag the toolbar to its new location.

The Status Area
The status area is at the bottom of the main window. When an object fails or experiences

an error, an alert (error) icon appears in the status area. The Alert Monitor window

provides details about the error. You can access the Alert Monitor window by clicking on

the alert icon in the status area.

The Command Launcher
The Command Launcher displays a list of tasks that can be performed on objects. Each

task is listed with the object type, the command (action), and a description of the task.

When you click on a task in the Command Launcher list, the task is launched (started) and

the dialog box for the task appears.

The Command Launcher is hidden by default. You can display or hide the Command

Launcher by choosing Window  > Command Launcher . You can separate or attach the

Command Launcher and the main window by choosing Options  > Customize  and

clicking Dock Command Launcher in the Customize window Main Window tab.

The splitter is the horizontal bar that separates the Command Launcher from the object

tree and grid. When the Command Launcher is attached to the main window, you can

adjust the Command Launcher height by placing the pointer over the horizontal splitter

and then pressing and holding the mouse button to drag the splitter to the desired

position.

You can sort the items listed in the Command Launcher by object type, command, or task

description by clicking on the appropriate column heading. You can reverse the sort order

by clicking on the column heading again.
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Storage Administrator Icons

Storage Administrator Icons
The following table shows icons that appear in VERITAS Volume Manager Storage

Administrator.

Icon Description

Object Icons:

Volume Manager

host

disconnected host

disk

free disk

foreign disk

offline disk

uninitialized disk

disk group

deported disk group

volume
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plex

mirror

snapshot

log

subdisk

controller

enclosure (disk array)

subpath (Dynamic Multipathing)

file system

cluster

cluster node (host)

shared disk groups

cluster-shareable disk group

Icon Description
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Storage Administrator Icons

QuickLog file system

QuickLog volume

Object View Icons:

concatenated layout

striped layout

RAID-5 layout

concatenated pro layout

striped pro layout

mirrored layout

mixed layout

Toolbar Icons:

Storage Administrator window

Task Request Monitor window

Alert Monitor window

Icon Description
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Search window

Grid Copy window

New Volume dialog box

Host connection dialog box

Object Properties window

Customize window

Print dialog box

expand disks

collapse disks

expand volumes

collapse volumes

projection

Icon Description
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Storage Administrator Icons

Task Status Icons:

task in progress

successful task

failed task

paused task

cancelled task

exited task

Performance Monitoring Icons:

slowest response time

slow response time

default

Miscellaneous Icons:

alert

error message

Icon Description
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Task Roadmap
This section provides a summary of common VERITAS Volume Manager Storage

Administrator tasks. The tasks are grouped into setup tasks, ongoing maintenance tasks,

and repair or recovery tasks. The procedures for these and other tasks are included in later

chapters.

Setup Tasks
If you are using VxVM and VERITAS Volume Manager Storage Administrator for the first

time, you need to install both products, place your disks under VERITAS Volume

Manager control, and create volumes.

▼ To install and set up the Storage Administrator

◆ Install and initialize VxVM.

◆ Install VERITAS Volume Manager Storage Administrator.

◆ Start VERITAS Volume Manager Storage Administrator.

information

question

warning

Command Launcher task

customization change

check mark

Icon Description
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These tasks are described in Chapter 2 and the VERITAS Volume Manager Installation
Guide.

▼ To set up disks

◆ Place uninitialized disks under VERITAS Volume Manager control.

◆ Create additional disk groups for the new disks (optional).

◆ Designate one or more disks as hot-relocation spares (optional).

These tasks are described in Chapter 3.

▼ To set up volumes and file systems

◆ Create volumes.

◆ Place file systems on volumes (optional).

◆ Create mirrors for any volumes that need to be redundant.

These tasks are described in Chapter 4.

▼ To access hosts and clusters

◆ Connect to additional host machines.

◆ Create shared disk groups.

These tasks are described in Chapter 5.

Maintenance Tasks
After you have set up your disks and volumes, you need to perform some or all of the

following maintenance tasks.

▼ To monitor objects

◆ Use the main window tree (left pane) and grid (right pane) to view disks, volumes,

file systems, and other objects on the system.

◆ Use the Object View window to display a graphical view of disks, volumes, and other

objects in a particular disk group.

◆ Use the Volume to Disk Mapping window to view the relationships between volumes

and their underlying disks.

◆ Use the Volume Layout Details window to display a graphical view of a particular

volume and its components.

◆ Use the object Properties window to view detailed information about a selected

object.
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◆ Use the Alert Monitor window to view information about errors or failures associated

with objects that are marked with alert icons.

These windows are described in Chapter 2.

▼ To maintain disks

◆ Place more disks under VERITAS Volume Manager control.

◆ Create more disk groups.

◆ Upgrade disk groups to the current disk group version.

These tasks are described in Chapter 3.

▼ To maintain volumes

◆ Increase the size of volumes as users and applications require more space.

◆ Change the layouts of volumes.

◆ Add mirrors to any unmirrored volumes that should be redundant.

◆ Create snapshot copies of volumes and then back up the volumes.

◆ Reorganize the space occupied by volumes (by moving subdisks to other disks).

These tasks are described in Chapter 4.

▼ To maintain file systems

◆ Place additional file systems on volumes.

◆ Increase the size of file systems as users and applications require more space.

◆ Create snapshot copies of vxfs  file systems and then back up the file systems.

These tasks are described in Chapter 4.

Repair/Recovery Tasks
If disk and/or system failures occur, VxVM generally performs any necessary recovery

operations automatically. However, depending on the circumstances, you may need to

attempt to recover from the situation as follows.

▼ To protect volumes from disk failure

◆ Evacuate a failing disk.

◆ Replace a failed disk.

These tasks are described in Chapter 3.
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▼ To repair/recover volumes

◆ Recover a volume.

◆ Recover all volumes on a failed disk.

◆ Recover all volumes in a disk group.

◆ Start a volume.

◆ If a volume is not recoverable, restore the volume from backup.

These tasks are described in Chapter 3, Chapter 4, and Chapter 6.

▼ To repair/recover file systems

◆ Perform a file system consistency check on any file systems that may be damaged.

These tasks are described in Chapter 4.
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Getting Started 2
Introduction

This chapter describes how to set up and start using the VERITAS Volume Manager

Storage Administrator (VERITAS Volume Manager Storage Administrator). This chapter

focuses on how to use the main components of VERITAS Volume Manager Storage

Administrator.

The following topics are discussed in this chapter:

◆ Installation and Setup

◆ Starting VERITAS Volume Manager Storage Administrator

◆ Running VERITAS Volume Manager Storage Administrator in Read-Only Mode

◆ Selecting Objects

◆ Viewing Objects and Object Properties

- The Tree and Grid View

- The Object View Window

- The Volume Layout Details Window

◆ The Volume to Disk Mapping Window

- The Object Properties Window

◆ Accessing Tasks

- Running Tasks From the Menu Bar

- Running Tasks From a Popup Menu

- Running Tasks From the Command Launcher

◆ Using Dialog Boxes

- Specifying Objects in Dialog Boxes

◆ Viewing Commands

- The Task Request Monitor Window
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- The Command Log

◆ Setting User Preferences

- The Customize Window

◆ Searching for Objects or Free Space

◆ Responding to Alerts

◆ Printing

◆ Exiting the Storage Administrator
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Installation and Setup
VERITAS Volume Manager Storage Administrator consists of a server (vmsa_server )

and a client (vmsa). You must install and run the VERITAS Volume Manager Storage

Administrator server on a UNIX machine running VERITAS Volume Manager (VxVM).

You can install and run the VERITAS Volume Manager Storage Administrator client on

any machine that supports the Java Runtime Environment.

Before you can use VERITAS Volume Manager Storage Administrator, perform the

following procedures:

1. Install VxVM on the machine to be administered. Run vxinstall  to create the

rootdg  disk group and initialize at least one disk.

2. Install the VERITAS Volume Manager Storage Administrator server and client on the

machine to be administered.

3. If users other than root need to access VERITAS Volume Manager Storage

Administrator, set up security to specify which users can run VERITAS Volume

Manager Storage Administrator.

4. If you plan to run the VERITAS Volume Manager Storage Administrator client from a

machine other than the machine to be administered, install the VERITAS Volume

Manager Storage Administrator client on the machine where the client will run.

5. Start the VERITAS Volume Manager Storage Administrator server on the machine to

be administered.

6. Start the VERITAS Volume Manager Storage Administrator client.

Refer to the VERITAS Volume Manager Installation Guide for details on how to install and

set up VxVM and VERITAS Volume Manager Storage Administrator.
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Starting VERITAS Volume Manager Storage Administrator
Only users with appropriate privileges can run VERITAS Volume Manager Storage

Administrator. Refer to the VERITAS Volume Manager Installation Guide for information

on VERITAS Volume Manager Storage Administrator security and access permissions.

You can use VERITAS Volume Manager Storage Administrator to administer the local

machine or a remote machine. The VERITAS Volume Manager daemon (vxconfigd ) and

the VERITAS Volume Manager Storage Administrator server (vmsa_server ) must be

running on the machine to be administered. Once VERITAS Volume Manager Storage

Administrator is installed, the VERITAS Volume Manager Storage Administrator server

starts up automatically at system startup.

▼ To start the VERITAS Volume Manager Storage Administrator server

❖ If the VERITAS Volume Manager Storage Administrator server is not already

running, enter the following command to start it:

# vmsa_server &

❖ To confirm that the VERITAS Volume Manager Storage Administrator server is

running, use the following command:

# vmsa_server -q

Note If you are using the sh shell, start the command as follows to allow the VMSA

server to continue running after you logout:

# nohup ./vmsa_server &

Auto-start Mode

The VMSA server has an auto-start mode that starts the server on an as-needed basis. In

auto-start mode, the VMSA server automatically starts whenever a VMSA client tries to

connect to the server and the server is not already running. If no VMSA clients are

connected for a certain amount of time (15 minutes, by default), the server automatically

terminates and restarts at the next client connection.

1. To start the server in auto-start mode, use the following command:

autostart on

2. To confirm that auto-start mode is enabled, run the following:

netstat -a | grep vmsa

The output should show that a VMSA service has a LISTEN state:
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*.vmsa *.* 0      0     0      0 LISTEN

3. Auto-start mode remains in effect across system reboots. To disable auto-start mode,

use the following command:

autostart off

For more information about auto-start mode, refer to the autostart (1M) manual page.

▼ To start the VERITAS Volume Manager Storage Administrator client

UNIX

❖ To administer the local UNIX machine, use the following command:

# vmsa

❖ To administer a remote UNIX machine, use the following command:

# vmsa remote_machine_name

Windows

❖ To administer a remote UNIX machine, choose Start  > Programs  >

VERITAS Volume Manager Storage Administrator  > VERITAS Volume Manager
Storage Administrator .

At startup, the VERITAS Volume Manager Storage Administrator client displays the

Connect to Host dialog box. To start the VERITAS Volume Manager Storage

Administrator session, complete this dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

VERITAS Volume Manager Storage Administrator main window appears.

Server Host: Enter the name of the machine to be administered. Both the VxVM and

the VERITAS Volume Manager Storage Administrator server must

be running on this machine.

User Name: Enter your login name. Only users with appropriate privileges can run

VERITAS Volume Manager Storage Administrator.

Password: Enter your password.

Options To use the specified user as the default setting for any future host

connections from this VERITAS Volume Manager Storage
Administrator client session, select Default User .
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Note Entries for your user name and password must exist in the password file or

corresponding NIS (Network Information Name Service) table on the machine to be

administered. Your user name must also be included in the VERITAS group entry

(vrtsadm , by default) in the group file or NIS group table. If the vrtsadm  entry

does not exist, only root  can run VERITAS Volume Manager Storage

Administrator.

The VERITAS Volume Manager Storage Administrator client can provide simultaneous

access to multiple host machines. After you have started VERITAS Volume Manager

Storage Administrator on one host, you can connect to additional hosts from the same

session. Each host machine must be running the VERITAS Volume Manager Storage

Administrator server.
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Running VERITAS Volume Manager Storage Administrator
in Read-Only Mode

VERITAS Volume Manager Storage Administrator can be run in a read-only mode that is

useful for monitoring, training, or browsing purposes. Read-only mode allows you to

view objects on the system through VERITAS Volume Manager Storage Administrator,

but prevents administrative actions from taking effect. When VERITAS Volume Manager

Storage Administrator is in read-only mode, the main window and dialog box title bars

contain the string [Read-only Mode] .

The default mode for VERITAS Volume Manager Storage Administrator is full

operational mode. Read-only mode can be enabled on a per-host or per-user basis. The

VERITAS Volume Manager Storage Administrator server and/or client can be set to

read-only mode. All client connections to a read-only server are in read-only mode.

To specify a list of users who are only permitted to run VERITAS Volume Manager

Storage Administrator in read-only mode, add a group named vrtsro  to the

/etc/group  file or NIS Network Information Name Service (NIS) group table on the

machine to be administered. The vrtsro group must include the names of any users who

are allowed to run VERITAS Volume Manager Storage Administrator in read-only mode,

but are not allowed to run it in full operational mode.

You can run VERITAS Volume Manager Storage Administrator in read-only mode using

one of the following procedures:

❖ From the main window, choose Options  > Read-Only Mode  to turn read-only mode

on (or off) for the current session.

❖ Start the server in read-only mode using the following command:

# vmsa_server -r

Read-only mode remains in effect until you stop and restart the server. To stop the

server, use the following command:

# vmsa_server -k

❖ Start the client in read-only mode using the following command:

# vmsa -r

❖ Connect to a host machine as a user who only has permission to run VERITAS Volume

Manager Storage Administrator in read-only mode on that host. This enables

read-only mode on the specified host machine.
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Selecting Objects
You can select objects in most VERITAS Volume Manager Storage Administrator windows

using the following procedures:

❖ To select a single object, click on the object.

❖ To select multiple objects, hold down the Control key while selecting the objects. The

objects that you select in this way do not have to be adjacent.

❖ To select a range of adjacent objects, select the first object and then hold down the

Shift key while selecting the last object in the range. You can also select multiple

adjacent objects by pressing and holding the mouse button while dragging the pointer

over the desired objects.

For information on how to select objects from dialog boxes, refer to “Using Dialog Boxes”

on page 48.

Viewing Objects and Object Properties
VERITAS Volume Manager Storage Administrator provides the following views of objects

and their properties:

◆ Tree and Grid View

The main window tree and grid view displays volumes, disks, file systems, and other

objects on the system. The grid also displays a limited set of properties for listed

objects.

◆ Object View Window

The Object View window displays a graphical view of disks, volumes, and other

objects in a particular disk group.

◆ Volume Layout Details Window

The Volume Layout Details window displays a close-up graphical view of a single

volume and its components (mirrors/plexes and subdisks).

◆ Volume to Disk Mapping Window

The Volume to Disk Mapping window shows the relationships between volumes and

their underlying disks.

◆ Object Properties Window

The object Properties window contains detailed information about a specific object.

This section describes how to use these views to display objects and their properties.
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The Tree and Grid View
The main window tree and grid view displays volumes, disks, file systems, and other

objects on the system. The object tree is a hierarchical display of object groups. The grid is

a tabular display of objects and a limited set of properties. VERITAS Volume Manager

Storage Administrator constantly monitors objects on the system and makes appropriate

changes to the tree and grid displays.

The File menu creates new objects or connections, prints information from the window, or

accesses an object properties window. The File  menu also closes the window or exits

VERITAS Volume Manager Storage Administrator. The Options  menu accesses user

preferences and sets VERITAS Volume Manager Storage Administrator to read-only

mode. The Window  menu and the toolbar buttons launch other VERITAS Volume

Manager Storage Administrator windows. The context-sensitive Selected  and popup

menus access tasks or properties for a selected object. To access the popup menu for an

object, right-click on the object.

For more information about this view, see the description of the object tree and grid in

Chapter 1.

“Tree/Grid View of Volumes” shows how a volume appears in the tree and grid view. The

object tree is in the left pane and the grid is in the right pane.
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Tree/Grid View of Volumes
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You can view objects in the tree and grid using the following procedures:

❖ To expand or collapse the hierarchy under a particular object group node in the tree,

click on the plus sign (+) or minus sign (-) icon next to that node.

❖ To display the objects in an object group, click on the appropriate object group in the

object tree. All objects that belong to the selected object group appear in the grid.

Examples:

To display all volumes, click on Volumes in the object tree. All volumes on the system

appear in the grid. Each volume is listed with a set of properties.

To display all volumes in the rootdg  disk group, expand the Disk Groups  node (by

clicking +), then expand the rootdg  node and click on the Volumes  group under

rootdg . Only volumes in the rootdg  disk group appear in the grid.

❖ To display the objects in an object group that is listed in the grid, double-click on the

object group in the grid. All objects that belong to the object group appear in the grid.

Example:

To display the volumes in a disk group listed in the grid, go to the grid and

double-click on the disk group name, then double-click on Volumes . All volumes in

the disk group appear in the grid.

Note that double-clicking on an object that does not contain other objects (children)

displays the Properties window for the object instead of its children.

❖ To sort the objects in the grid by a specific property, click on the appropriate property

column heading. To reverse the sort order, click on the column heading again.

Example:

To sort volumes by size, click on the Size column heading in the grid.

❖ To resize a grid column, place the pointer over the line that divides the column

headings and then press and hold the mouse button to drag the column divider to the

desired position.

❖ To resize the left (tree) and right (grid) panes, place the pointer over the vertical

splitter and then press and hold the mouse button to drag the splitter to the desired

position.

❖ To make a copy of the contents of the grid, choose Window > Copy Main Grid . A copy

of the grid appears in a separate window. The new grid window continues to display

and update the objects that were shown when you created the grid copy. You can
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create multiple copies of the grid and use these grid windows to display different sets

of objects. For example, you can display volumes in one grid window and disks in

another.

❖ To print the contents of the grid, choose File  > Print Grid  and complete the Print

dialog box. To print details about a specific object displayed in the grid, select the

object, choose File  > Print , and then complete the Print dialog box.

The Object View Window
The Object View window displays a graphical view of the volumes, disks, and other

objects in a particular disk group. The Object View window is dynamic, so the objects

displayed in this window are automatically updated when object properties change. You

can select objects or perform tasks on objects in the Object View window. For instructions

on navigating the Object View window, see “Navigating the Object View Window” on

page 36.

The Object View window consists of two main panes, as follows:

◆ Volume Pane (top)

The volume pane is a graphical display of volumes in a particular disk group. This

pane can display various levels of detail for volumes. You can display volumes in one

of the following modes:

- Basic mode—minimal information about a volume. This mode displays a

compressed view of volumes.

- Layout mode—volume components and layout. This mode displays volume

subdisks and mirrors, as well as any columns or logs.

- Expanded (detailed) mode— detailed information about a volume and its

components. This mode displays volume and component properties.

◆ Disk Pane (bottom)

The disk pane is a graphical display of disks in a particular disk group. This pane can

display various levels of detail for disks. You can display disks in one of the following

modes:

- Basic mode—minimal information about a disk. This mode displays a compressed

view of disks.

- Layout mode—disk regions and layout. This mode displays the subdisks and free

space on a disk.

- Expanded (detailed) mode—detailed information about a disk, its subdisks, and free

space. This mode displays properties of the disk and its regions.
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You can move the horizontal splitter to adjust the relative heights of both panes. To resize

the volume and disk panes, place the pointer over the horizontal splitter and then press

and hold the mouse button to drag the splitter to the desired position.

The menu bar at the top of the Object View window contains the following menus:

◆ File

The File  menu provides access to the New menu, which creates volumes and file

systems. The File  menu also displays another disk group, prints the properties of a

selected object, closes the Object View window, or provides access to an object

Properties window.

◆ Options

The Options  menu provides access to the Volumes  and Disks  menus, which set the

display mode for all volumes or disks in the Object View and expand or collapse all

volumes or disks. The Options  menu also clears projection settings.

◆ Window

The Window  menu launches a window that displays any dissociated objects or

launches the Projection window.

◆ Selected  (context sensitive)

The context-sensitive Selected menu accesses tasks or properties for a selected object.

The Selected  menu name and options depend on the type of object that is selected.

The toolbar at the top of the Object View window has the following set of buttons:

◆ Expand Volume

The Expand Volume  button shows more detailed information about all volumes in

the Object View. This button displays objects in layout mode or detailed mode,

depending on the previous mode.

◆ Collapse Volume

The Collapse Volume  button hides details for all volumes in the Object View. This

button displays objects in layout mode or basic mode, depending on the previous

mode.

◆ Expand Disk

The Expand Disk  button shows more detailed information about all disks in the

Object View. This button displays objects in layout mode or detailed mode,

depending on the previous mode.

◆ Collapse Disk

The Collapse Disk  button hides details for all disks in the Object View. This button

displays objects in layout mode or basic mode, depending on the previous mode.
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◆ Project

The Project  button launches the Projection window.

◆ Print

The Print  button prints the properties of a selected object.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to

separate the toolbar from the window or move the toolbar to the bottom, side, or top of

the window. To reposition the toolbar, press and hold the mouse button over the toolbar

handle and drag the toolbar to its new location.

Projection shows the relationships between objects by highlighting objects that are related

to or part of a specific object. When both disks and volumes are in layout mode or detailed

mode, clicking on a subdisk in a volume (or disk) highlights the location of the subdisk on

the corresponding disk (or volume). To access additional projection options, select an

object in the Object View and then use the Projection window (Window  > Projection ) to

choose the type of object to be highlighted.

In the Object View, you can move subdisks by dragging the subdisk icons to their new

locations. You can drag a subdisk to another disk or a gap on the same disk. To move a

subdisk, place the pointer over the subdisk and then press and hold the mouse button to

drag the subdisk to another location. Note that moving subdisks reorganizes volume disk

space and must be done with caution.

The Object View window displays plexes and subdisks that are associated with volumes.

To view Volume Manager objects that are not associated with volumes (such as

dissociated plexes), open the Dissociated Object View window (Window  > Show
Dissociated ).

“Object View Window” on page 35 shows how volumes and disks appear in the Object

View.
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“Volume in Object View” shows how the components of a volume appear in the Object

View.

Volume in Object View

Navigating the Object View Window

You can view objects in the Object View window using the following procedures:

❖ To display the Object View window, select a disk group (in the main window grid)

and then choose Disk Groups  (Selected  menu) > Object View .

❖ To show the layouts and components of all volumes in the Object View window

(layout mode), choose Options  > Volumes  > Layout .

❖ To compress all volumes in the Object View and show minimal information about

each volume (basic mode), choose Options  > Volumes  > Basic .

❖ To show detailed information about all volumes in the Object View (detailed mode),

choose Options > Volumes > Layout and then Options > Volumes > Expand All . To

hide some of the details about the volumes, choose Options  > Volumes  > Collapse
All .

❖ To show or hide details about a particular volume in the Object View, click on the

volume icon on the left side of the volume. This expands or collapses the volume.

❖ To show the layouts and regions of all disks in the Object View window (layout

mode), choose Options  > Disks  > Layout .

Layout

Columns

Mirrors

Subdisk

Log
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❖ To compress all disks in the Object View and show minimal information about each

disk (basic mode), choose Options  > Disks  > Basic .

❖ To show detailed information about all disks in the Object View (detailed mode),

choose Options  > Disks  > Layout  and then Options  > Disks  > Expand All . To hide

some of the details about the disks, choose Options  > Disks  > Collapse All .

❖ To show or hide details about a particular disk in the Object View, click on the disk

icon on the left side of the disk. This expands or collapses the disk.

❖ To perform a task on an object in the Object View window, select the object and choose

a task from the Selected  or popup menu. To access the popup menu for an object,

right-click on the object.

❖ To refresh the Object View window, right-click on the background area of the window

and choose Reset Server from the popup window. Click OK in the Reset Server dialog

box. This should update the contents of the Object View window and fix any display

problems. Under normal circumstances, the Object View window automatically

updates its contents to reflect object changes and does not require a manual refresh.

❖ To view the properties window for an object in the Object View window, select the

object and choose Properties  from the Selected  or popup menu.

❖ To print the properties of a particular object, select the object and then choose File  >

Print .

❖ To close the Object View window, choose File  > Close .
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The Volume Layout Details Window
The Volume Layout Details window displays a graphical view of layout, components, and

properties of the selected volume. You can select objects or perform tasks on objects in the

Volume Layout Details window. The Volume Layout Details window is not dynamic, so

the objects displayed in this window are not automatically updated when the volume

properties change. For instructions on navigating the Volume Layout Details window,

see“Navigating the Volume Layout Details Window.”

The File  menu changes or updates the contents of the Volume Layout Details window,

prints information from the window, or closes the window. The View  menu changes the

way objects are displayed in this window. The context-sensitive Selected  and popup

menus access tasks or properties for a selected object. To access the popup menu for an

object, right-click on the object.

“Volume Layout Details Window” shows how a volume appears in the Volume Layout

Details view.

Volume Layout Details Window

Navigating the Volume Layout Details Window

You can view objects in the Volume Layout Details window using the following

procedures:

❖ To display the Volume Layout Details window for a volume, click on the volume (in

the main window grid) and then choose Volumes  (Selected  menu) > Show Layout .
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❖ To update (refresh) the graphical view to show any recent changes to the current

volume, choose File  > Update . The Volume Layout Details window does not update

object properties automatically.

❖ To view a different volume, choose File  > Open  and then specify another volume in

the Open Volume dialog box.

❖ To hide the detailed information within each object, choose View  > Compress
Display . To show details for a particular object in the compressed display, click on that

object.

❖ To highlight objects that are related to or part of a specific object, choose View  >

Project On Selection  and then click on an object. To highlight any subdisks on the

same disk as a specific subdisk, choose View > Subdisk Projection and then click on

a subdisk.

❖ To print the properties of a particular object, select the object and then choose File  >

Print  and complete the Print dialog box.

The Volume to Disk Mapping Window
The Volume to Disk Mapping window displays a tabular view of volumes and their

underlying disks. Volumes are listed in the top row of the table and disks are listed in the

left column of the table. Each circle icon in the table indicates that part of the

corresponding volume is located on the corresponding disk.

This window can also display details such as the subdisks and gaps (free space) on each

disk. Each subdisk or gap is listed with its disk offset and length. When subdisks are

shown, circles show the relationship between volumes and subdisks.

The Volume to Disk Mapping window is dynamic, so the contents of this window are

automatically updated when objects are added, removed, or changed.For instructions on

navigating the Volume to Disk Mapping window, see “Navigating the Volume to Disk

Mapping Window” on page 40.

The File menu prints information from the window or closes the window. The View menu

changes the way objects appear in the Volume to Disk Mapping window. The

context-sensitive Selected  and popup menus access tasks or properties for a selected

object. To access the popup menu for an object, right-click on the object.

The Volume to Disk Mapping window has a performance monitoring feature that ranks

volume response time. When performance monitoring is turned on (View > Performance
Monitoring ), the icons in the table change. The volumes with the slowest reads/writes are

shown as red icons. Volumes with relatively slow response time are shown as yellow

icons. All other volumes are shown as green icons.
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“Volume to Disk Mapping Window” on page 40 shows how the relationships between

volumes and disks are shown in the Volume to Disk Mapping window.

Volume to Disk Mapping Window

Navigating the Volume to Disk Mapping Window

You can view volumes and their associated disks using the following procedures:

❖ To display the Volume to Disk Mapping window for all volumes in a disk group, click

on the disk group (in the main window grid) and then choose Disk Groups (Selected
menu) > Disk/Volume Map .

❖ To display all of the subdisks and gaps on a particular disk, click the arrow to the left

of the disk name. Any subdisks and gaps are listed below the disk name. To hide the

subdisks and gaps, click the arrow again.

❖ To display all of the subdisks and gaps on all disks, choose View  > Expand All . To

hide all of the subdisks and gaps on all disks, choose View  > Collapse All .

❖ To highlight a disk row, click on the disk name. To highlight a volume column, click

on the volume name. To highlight both the disk and volume associated with a

particular circle, click on the circle.
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❖ To activate the performance monitoring feature, choose View  > Performance
Monitoring . Volumes with relatively slow read/write performance are shown as

circular red icons.

❖ To change the criteria that determine which disks are displayed as slow performers,

select View  > Perf. Monitoring Parameters  and complete the Performance

Monitoring Parameters dialog box. This dialog box allows you to configure how

many disks are shown as slowest and next slowest performers, the sampling interval,

and whether to show the slowest performers for reading, for writing, or for both

reading and writing.

❖ To print the properties of a particular object, select the object and then choose File  >

Print  and complete the Print dialog box.

The Object Properties Window
The Object Properties window contains detailed information about the selected object.

The Properties window contains a set of tabbed pages, each of which contains information

about the object and related objects. The tab labels and page contents vary, depending on

the type of object selected. You can display a different page by clicking on the appropriate

tab label. Some object properties can be changed through the Properties window for the

object. For instructions on navigating the Object Properties window, see “Navigating the

Object Properties Window” on page 43.

“Volume Properties Window” shows how a volume appears in the Volume Properties

window.
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Volume Properties Window
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Navigating the Object Properties Window

You can view object properties using the following procedures:

❖ To view the properties of an object, click on the object (in the main window grid) and

then choose Properties  from the Selected  or popup menu. You can also access the

Properties window by double-clicking on the object.

Example:

To display volume properties, either click on a volume and then choose Volumes  >

Properties  or double-click on a volume.

Note that double-clicking on an object that has children may display the children of

the object instead of the Properties window.

❖ To go to a tab in a properties window, click the appropriate tab label.

❖ To update the contents of the Properties window to reflect current properties for the

object, click Refresh.

❖ To change any of the editable items in the Properties window, make the appropriate

changes and then click OK. This changes the settings for all properties tabs in the

Properties window.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
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Accessing Tasks
Most VERITAS Volume Manager Storage Administrator tasks are performed by selecting

objects and/or tasks and then completing the resulting dialog boxes. With VERITAS

Volume Manager Storage Administrator, you can access tasks from the following:

◆ the menu bar

◆ a context-sensitive popup menu

◆ the Command Launcher

This section describes how to run tasks from menus and the Command Launcher.

Running Tasks From the Menu Bar
You can launch tasks from the File and Selected menus in the main window menu bar, as

shown in “Menu Bar.”  The File  > New menu creates new VERITAS Volume Manager

objects (volumes and disk groups) and file systems. The context-sensitive Selected menu

launches tasks on a selected object. The Selected  menu is dynamic and changes its name

and options based on the type of object that is selected in the tree or grid.

Menu Bar

❖ To create a new object, choose the type of object to be created from the File  > New
menu. This launches a dialog box.

Example:

To create a volume, choose File  > New > Volume . Complete the New Volume dialog

box.

❖ To perform a task on an object with the Selected  menu, select the object and choose

the appropriate task from the Selected  menu. If this launches a dialog box, complete

the dialog box.

Example:

To change a volume name, select the volume in the grid. Choose Volumes > Rename
from the Selected  menu. Enter the new volume name in the Rename Volume dialog

box; then click OK.
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Running Tasks From a Popup Menu
A context-sensitive popup menu, as shown in “Context-Sensitive Popup Menu,”

launches tasks on the selected object. A popup menu provides access to tasks or options

appropriate for the selected object. Popup menus are available in the main window and

most other windows.

Context-Sensitive Popup Menu

❖ To perform a task on an object with the popup menu, right-click on the object and

choose the appropriate task in the popup menu. If this launches a dialog box,

complete the dialog box.



Accessing Tasks

46 VERITAS Volume Manager Storage Administrator Administrator’s Guide

Running Tasks From the Command Launcher
The Command Launcher window, as shown in “Command Launcher” on page 46,

launches tasks from a list of objects and associated Storage Administrator tasks. The

Command Launcher lists each task with an object type and a task description.

The Command Launcher can be displayed as part of the main window (docked) or as a

separate window. The Command Launcher can also be hidden. When the Command

Launcher is attached to the main window, tasks are context sensitive. However, tasks are

not context sensitive when the Command Launcher is separated from the main window.

The File  menu attaches (docks) the Command Launcher to the main window and closes

the Command Launcher window.

Command Launcher

You can use the Command Launcher as follows:

❖ To display the Command Launcher, choose Window  > Command Launcher  (from

the main window). To hide the Command Launcher, choose Window  > Command
Launcher  again. You can also show or hide the Command Launcher by choosing

Options  > Customize  and clicking Show Command Launcher in the Main Window

tab of the Customize window.

❖ To perform a task on a specific type of object, select the appropriate object-task

combination from the Command Launcher list. Make sure that the Hosts  field

contains the name of the host machine where the task will be performed.

Example:

To add a disk, choose Disk Add from the Command Launcher list. Complete the Add

Disk dialog box.
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❖ To sort the items listed in the Command Launcher by object type, command, or task

description, click on the appropriate column heading. To reverse the sort order in a

column, click on the column heading again.

❖ To separate or attach (dock) the Command Launcher and the main window, choose

Options  > Customize  and click Dock Command Launcher in the Main Window tab

of the Customize window.

❖ To adjust the height of the Command Launcher when it is attached to the main

window, choose Options  > Customize  and specify the new height (in pixels) in the

Docked Command Launcher Height field in the Main Window tab of the Customize

window. Alternatively, you can place the pointer over the horizontal splitter and then

press and hold the mouse button to drag the splitter to the desired position.
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Using Dialog Boxes
Administrators typically use dialog boxes to submit tasks or other requests to VERITAS

Volume Manager Storage Administrator. Dialog boxes can contain selectable buttons

and/or fields that accept information. Some dialog box fields contain default values that

can be changed. Items that are not applicable are greyed out.

❖ To use a dialog box, select the appropriate items and/or enter the appropriate

information and then click one of the following buttons to initiate or cancel the

task/request:

Some dialog boxes contain the following buttons:

OK Perform the current task/request and close the dialog box.

Apply Perform the current task/request and continue to display the

dialog box.

Cancel Cancel the current task/request and close the dialog box. (If you

have already clicked Apply, this does not cancel the task that is in

progress.)

Browse View and select existing objects.

Exit Exit from VERITAS Volume Manager Storage Administrator.

Help Display information about the contents of the dialog box.

Reset Reset the contents of the dialog box (and any associated dialog

boxes) to the default settings.

Show Options Show optional settings for this task.

View View existing objects.
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Specifying Objects in Dialog Boxes
Most VERITAS Volume Manager Storage Administrator dialog boxes contain one or more

object name fields. If you select an object before you launch the task, the resulting dialog

box may include the name of the selected object. If the object name field is empty, you can

specify an object using one of the following procedures:

◆ Enter the name of the object.

◆ Click the Browse  button next to the object name field and then select the object from

the resulting browse dialog box. Most browse dialog boxes consist of a tree (left pane)

and grid (right pane). To select an object in a browse dialog box, click on the

appropriate object group in the tree and then click on the desired object in the grid.

“Browse Dialog Box” shows a sample browse dialog box.

Browse Dialog Box

In some cases, you can specify multiple objects (separated by white space) in a single field.

To select multiple objects from a browse dialog box, hold down the Control key and click

on each object. To select a range of adjacent objects, select the first object and then hold

down the Shift key while selecting the last object in the range.

Specifying Disks and Disk Groups in Dialog Boxes

You can specify the disk group for an object by preceding the object name with the disk

group name (diskgroup_name/ object_name). The disk group name is required if there

are multiple objects with the same name (in different disk groups) on the system.
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Disks in disk groups have two names, as follows:

◆ device name

The physical disk device name (or disk access name).

◆ disk name

The VERITAS Volume Manager disk name (or disk media name). This is the logical

name given to the disk by the VERITAS Volume Manager or the administrator.

Some dialog box fields require the device name and others require the VERITAS Volume

Manager disk name.

Specifying Object Sizes in Dialog Boxes

When you enter the size of an object in an input field, you can specify sectors, kilobytes,

megabytes, or gigabytes by appending an s , k , m, or g to the size. If you do not specify a

size unit, the size defaults to sectors.

Viewing Commands
VERITAS Volume Manager Storage Administrator logs all task requests. You can view the

VERITAS Volume Manager Storage Administrator task history (including tasks in

progress) in either of these locations:

◆ The Task Request Monitor Window

◆ The Command Log File

The Task Request Monitor Window
The Task Request Monitor window, as shown in “Task Request Monitor” on page 51,

displays a history of tasks performed in the current session (and any other sessions

running on the machine). Each task is listed with properties such as the user who

performed the task, the task status, and the start/finish times.

The File menu removes finished tasks or closes the window. The Tasks and popup menus

stop/restart tasks and access task properties.
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Task Request Monitor

You can use the Task Request Monitor window as follows:

❖ To display the Task Request Monitor, choose Window  > Tasks  (from the main

window) or click on the Task  button in the toolbar.

❖ To cancel a selected task, choose Tasks  > Abort . To temporarily stop a task, choose

Tasks  > Pause . To continue a task, choose Tasks  > Resume .

❖ To view task properties and the low-level commands used to perform a task, select the

task and choose Properties  from the Tasks  or popup menu. You can also access task

properties by double-clicking on the task.

❖ To sort the tasks by task type, click on the Task column heading. To sort the tasks by

property, click on the appropriate property column heading. To reverse the sort order,

click on the column heading again.

❖ To remove completed tasks from the window, choose File > Remove Finished Tasks .

❖ To print the contents of this window, choose File  > Print Grid  and complete the Print

dialog box. To print details about a specific task, select the task, choose File  > Print ,

and then complete the Print dialog box.
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The Task Properties window, as shown in “Task Properties Window,” shows information

about a specific task. Task properties include the user who performed the task, the task

status, the start/finish times, and the low-level commands used to perform the task. For

failed tasks, the Task Properties window includes any relevant error messages. You can

copy commands from the Executed Commands field to the command line or a script file.

Task Properties Window
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The Command Log
The command log file contains a history of VERITAS Volume Manager Storage

Administrator tasks performed in the current session and previous sessions. The

command log file contains a description of each task, along with properties such as the

user who performed the task, the task status, the start/finish times, and the low-level

commands used to perform the task. For failed tasks, the command log includes any

relevant error messages.

By default, the command log is located in /var/opt/vmsa/logs/command  on the

server. You can view the command log file through the VERITAS Volume Manager

Storage Administrator Command Log View window.

The following example shows some sample command log file entries:

Create Volume
Description: Create Volume
User: root
Started: November 18, 2000 4:36:11 PM PDT
Finished: November 18, 2000 4:36:12 PM PDT
State: Successful
Executed Commands:
        /usr/sbin/vxassist  -g rootdg   make vol15 3m layout=nostripe

Create Volume  FAILED!
Description: Create Volume
User: root
Started: November 18, 2000 4:36:56 PM PDT
Finished: November 18, 2000 4:36:56 PM PDT
State: Failed
Executed Commands:

/usr/sbin/vxassist -g rootdg make vol16 13g layout=nostripe
Failed Command: /usr/sbin/vxassist  -g rootdg   make vol16 13g
layout=nostripe
Error Message: vxvm:vxassist: ERROR: Cannot allocate space for
27262976 block volume

❖ To access the Command Log View window, select a host and choose Hosts  > View
Command Log .

❖ To update the contents of the Command Log View window, choose File  > Refresh .

❖ To search for some specific text in the Command Log View window, choose Window
> Find  and complete the Find dialog box.

❖ To close the Command Log View window, choose File  > Close .
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Setting User Preferences
You can change the way items appear in VERITAS Volume Manager Storage

Administrator windows. This section describes how to use the Customize window to

customize the way VERITAS Volume Manager Storage Administrator appears.

The Customize Window
The Customize window, as shown in “Customize Window,”  displays current user

preferences for the components of VERITAS Volume Manager Storage Administrator and

allows you to change these settings. The Customize window contains a set of tabbed

pages, each of which contains preference options for a particular aspect of VERITAS

Volume Manager Storage Administrator. You can display a different page by clicking on

the appropriate tab label.

Customize Window

You can use the Customize window as follows:

❖ To display the Customize window, choose Options  > Customize  (from the main

window) or click on the Customize  button in the toolbar.

❖ To change preference settings, make the appropriate selections in the Customize

window, then click OK. This changes the settings for all tabs in the Customize

window. To reset the settings to the previous settings, click Reset  (before you click

OK).



Chapter 2, Getting Started 55

Setting User Preferences

When you change preference settings, the customization change icon appears in the

tab label of the tab that contains changes. This icon disappears when you click OK,

Apply , or Reset . The customization change icon also appears in the status area of the

main window.

❖ To save your preference settings and apply them to future VERITAS Volume Manager

Storage Administrator sessions, choose Options  > Save Customization. You can also

save your preference settings by clicking the customization change icon in the status

area.

If the Auto-Save Preferences on Exit preference is set (in the General  tab), VERITAS

Volume Manager Storage Administrator saves all of your preference settings when

you exit VERITAS Volume Manager Storage Administrator using the File  menu.

VERITAS Volume Manager Storage Administrator saves user preferences in

user’s_home_directory/.vmsa/VMpreference.prf  on the machine where the

client is running.

❖ To reload your previously saved preferences, choose Options > Load Customization .

The Customize window contains the following preference tabs:

◆ General

◆ Main Window

◆ Font

◆ Color

◆ Object View Color

◆ Geometry

◆ Tree/Grid

◆ Toolbar

◆ Layout Details

◆ Object View

◆ Hosts

The following sections summarize the preference settings available in each of these tabs.
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General

Set the following general preferences:

Set Text Field Input to

Replace Mode

Set user input to replace mode. This highlights any

existing text in a field and replaces that text with the

new text.

Show Task Options Show/hide optional settings in task dialog boxes.

Show Confirmation Dialogs Show/hide confirmation dialogs for tasks that may

have serious consequences (such as data loss).

Confirmation dialogs require users to confirm that a

task should be performed. Confirmation dialogs

typically appear for tasks that remove objects.

Note If you hide confirmation dialogs, most tasks are

performed immediately and without any form of

confirmation.

Auto-Save Preferences on

Exit

Save all current user preferences when the user exits

VERITAS Volume Manager Storage Administrator

using File  > Exit .

Flush Images Draw images slightly slower than usual to prevent the

X server from growing. This is recommended if you

plan to leave VERITAS Volume Manager Storage

Administrator running for long periods of time.

Dynamic Splitter Redraw the contents of the window panes while the

splitter is being moved to resize the panes.

Default Display Unit Set the default size unit for areas that display object

sizes. If Best Choice is set, VERITAS Volume Manager

Storage Administrator uses an appropriate size unit.

Summary Decimal Precision Set the decimal point precision for object sizes

displayed in the grid and other areas that display

summaries.

Task Decimal Precision Set the decimal point precision for object sizes

displayed in task-related dialog boxes and areas that

display detailed information.
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Main Window

Set the following preferences for the main window:

Font

Set the font size, family, and style for the following:

❖ To access the Font Selector, click Change . Change the font size using the Size slider.

Use the Family and Style options to change the font family and style.

Show Status Bar Show/hide the status bar area (at the bottom of the

main window). The status bar displays alert icons

when failures or errors occur.

Show Command Launcher Show/hide the Command Launcher. The Command

Launcher contains a list of selectable tasks.

Dock Command Launcher Attach/detach the Command Launcher and the main

window.

Docked Command Launcher

Height

Set the height of the Command Launcher portion of

the main window.

User Font Set the font for user input and objects displayed in the

tree and grid.

System Font Set the font for labels, menus, buttons, and other items

displayed by VERITAS Volume Manager Storage

Administrator.

Grid Heading Font Set the font for grid headings.

Grid Heading Highlight

Font

Set the font for grid headings that are highlighted for

sorting purposes.

Toolbar Font Set the font for the toolbar buttons.

Graphical Display Font Set the font for objects in the Volume Layout Details

window.
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Color

Set the following preferences for colors:

❖ To access the Color Selector, click Change . Change colors by clicking on a color in the

color wheel or sliding the Red, Green , Blue , and Brightness  sliders to the

appropriate positions.

Background Color Set the background color for all VERITAS Volume

Manager Storage Administrator windows.

Foreground Color Set the color for foreground text in VERITAS Volume

Manager Storage Administrator windows.

Tree/Grid Color Set the background color for the tree and grid.

Connecting Line Color Set the color for the lines that connect items in the tree.

Selection Color Set the color for selected items.

Selection Foreground Color Set the color for foreground text in selected items.

Focus Highlight Color Set the color for the item that has input focus.

Link Color Set the color for links (such as the links to tasks in the

Command Launcher).

Projection Color Set the color for the lines that show object relationships

in the Volume Layout Details window.
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Object View Color

Set the following preferences for colors in the Object View window:

❖ To access the Color Selector, click Change . Change colors by clicking on a color in the

color wheel or sliding the Red, Green , Blue , and Brightness  sliders to the

appropriate positions.

Disk Titlebar Color Set the color of the titlebar for disks in the Object View.

Disk Body Color Set the background color for disks in the Object View.

Disk Gap Color Set the color for gaps (free space) on disks in the Object

View.

Plex Gap Color Set the color for gaps in plexes in the Object View.

Dissociated Subdisk Color Set the color for dissociated subdisks in the Object

View.

Odd Column Color Set the color for odd-numbered columns in volumes in

the Object View.

Even Column Color Set the color for even-numbered columns in volumes

in the Object View.

Plex Body Color Set the background color for plexes in the Object View.

Dissociated Plex Color Set the color for dissociated plexes in the Object View.

Volume Titlebar Color Set the color of the titlebar for volumes in the Object

View.

Volume Body Color Set the background color for volumes in the Object

View.

Unavailable Volume Color Set the color for inaccessible volumes in the Object

View.

Object Border Color Set the color for object borders in the Object View.
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Geometry

Set the width and height (in pixels) for the following windows:

◆ Main Window

◆ Object Search Window

◆ Alert Monitor Window

◆ Task Request Monitor Window

◆ Volume Layout Details Window

◆ Command Launcher Window

◆ Grid Copy Window

◆ Object View Window

◆ Dissociated Object View Window

If you resize one of these windows via your window manager, the Geometry preference

for that window changes to the new size automatically.

Tree/Grid

Set the following tree and grid preferences:

Display Full Path Display path information in the tree and grid.

Auto Scroll Grid When an object is added or changed, scroll through the

objects until the new/changed object is visible in the

grid.

Double-Click Always

Displays Properties

When the administrator double-clicks on an object,

always display the properties window for the object. If

this preference is not set, double-clicking on an object

with children (such as a disk group) displays the object

children instead of its properties window.

Splitter Position Move the splitter to adjust the relative sizes of the tree

and grid panes.

Column Header Alignment Align column headings above the data in each column

(best fit) or at the left, right, or center of each column.

Selector Tree/Grid Width Set the width (in pixels) of the tree and grid in browse

dialog boxes that contain a tree and a grid.
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Toolbar

Set the following preferences for the toolbar:

Layout Details

Set the following preferences for the Volume Layout Details window:

Selector Grid Width Set the width (in pixels) of the grid in browse dialog

boxes that contain a grid only.

Visible Selector Rows Set the number of rows displayed in the tree and grid

in browse dialog boxes.

Show Toolbar Show/hide the toolbar.

Position Place the docked toolbar at the top, bottom, or side of

the main window.

Presentation Display icons and/or labels on the buttons in the

toolbar.

Compress Display Compress the graphical display of objects so that

details are hidden.

Projection on Selection When an object is selected, highlight objects that are

related to or part of that object.

Subdisk Projection When a subdisk is selected, highlight other subdisks

on the same disk.
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Object View

Set the following preferences for the Object View window:

Hosts

Set the following preferences for accessing and displaying host machines:

❖ To specify a host machine, click Add  and enter the host machine name in the Hosts

column of the grid. To select a preference for the host, click in the appropriate column.

Check marks indicate which preferences are selected for the corresponding host. To

turn off a host preference setting, click on the appropriate check mark.

❖ To remove a host machine from the host preferences list, select the host and click

Delete .

Use Volume Basic Mode Display volumes in basic mode by default.

Expand Volumes Within

Mode

Display expanded view of volumes (layout mode) by

default.

Use Disk Basic Mode Display disks in basic mode by default.

Expand Disks Within Mode Display expanded view of disks (layout mode) by

default.

Enable Drag and Drop Allow administrators to move subdisks by dragging

subdisk icons to new locations within the Object View.

Splitter Position Move the splitter to adjust the relative sizes of the

volume and disk panes.

Start Drag Tolerance Set the number of pixels the mouse must move before

drag and drop is activated.

Connect Automatically connect to the specified host at

VERITAS Volume Manager Storage Administrator

startup.

Default Host Use this host machine as the default host.

Auto-Expand In the main window object tree, expand the specified

host node and display the hierarchy under that host.
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❖ To clear the settings for all hosts in the preferences list, click Clear.

❖ To turn on the Connect setting for all listed hosts, click Connect All .

❖ To change a host name, select the host and either click the Edit  button or use the

following keys:

F2 Insert mode

Any key Replace mode

Return Apply change

Esc Cancel change
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Searching for Objects or Free Space
The Search window, as shown in “Object Search Window,”  searches the specified host

machines for objects that match the specified search criteria. Any objects that match the

search criteria are listed in the grid in the lower half of the search window, along with

their properties. Objects displayed in the search window are monitored and removed

from the window if they no longer meet the current search criteria.

The Search window contains a set of tabbed pages, each of which contains search options

for a particular type of object. You can display a different page by clicking on the tab label.

The Search window has menus similar to those in the main menu. The File menu prints

information from the window or closes the window. The Window menu opens other

windows or a copy of the current search results grid. The context-sensitive Selected  and

popup menus access tasks or properties for a selected object in the search results grid. To

access the popup menu for an object, right-click on the object in the lower half of the

Search window.

Object Search Window
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You can use the Search window as follows:

❖ To display the Search window, choose Window > Search (from the main window) or

click on the Search button in the toolbar.

❖ To begin a search, enter your search criteria and then click Search . Make sure that the

Hosts field contains the name of the host machines where the search will be

performed.

❖ To sort the objects in the search results grid by name or property, click on the

appropriate column heading. To reverse the sort order, click on the column heading

again.

❖ To view the properties of an object listed in the search results grid, select the object

and choose Properties  from the Selected  or popup menu. You can also access object

properties by double-clicking on the object.

❖ To open a window that contains a copy of the current search results grid, choose

Window  > Copy Search Grid . To open another Search window, choose Window  >

Search .

❖ To perform a task on an object listed in the search results grid, select the object and

choose a task from the Selected  or popup menu.

❖ To print the contents of the search results grid, choose File > Print Grid and complete

the Print dialog box. To print details about a specific object displayed in the search

results grid, select the object, choose File  > Print , and then complete the Print dialog

box.

Responding to Alerts
When an object fails or experiences an error, an alert icon appears in the status area of the

main window and/or on the object icon (see “Alerts for a Volume” on page 66). If an alert

icon appears, you should review the contents of the Alert Monitor window. The Alert

Monitor window lists information about objects that have failed or experienced other

errors (see “Alert Monitor Window” on page 67). Each object is listed with a description of

the failure or error.

After you review the alerts listed in the Alert Monitor window, the alert icon at the bottom

of the main window changes to a check mark to let you know that you have reviewed

current alerts. If more alerts are added to the Alert Monitor window, the check mark icon

changes to the alert icon to let you know that there are new alerts.
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The File  menu accesses properties for objects with alerts or closes the window.

Context-sensitive popup menus also access properties for objects with alerts. To access a

popup menu, right-click on an object with an alert.

After reviewing the alerts in the Alert Monitor window, you should try to correct the

problem. For more information about an object listed in the Alert Monitor window, go to

the Properties window for the object.

Alerts for a Volume

alerts
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Alert Monitor Window

You can use the Alert Monitor window as follows:

❖ To display the Alert Monitor window, choose Window  > Alerts  (from the main

window) or click on the Alert button in the toolbar. You can also access the Alert

Monitor window by clicking on the alert icon in the status area.

❖ To sort alerts by object or description, click on the appropriate column heading. To

reverse the sort order, click on the column heading again.

❖ To view the properties of an object with an alert, select the object and choose Object
Properties  from the File  or popup menu. You can also access object properties by

double-clicking on the object.

❖ To acknowledge and clear the alert icon displayed in the status area of the main

window, choose Options  > Clear Alert Status .
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Printing
You can print the contents of some VERITAS Volume Manager Storage Administrator

windows. In some cases, you can print information about a specific object instead of the

contents of the window.

❖ To print the contents of a VERITAS Volume Manager Storage Administrator window,

choose File  > Print Grid  and complete the Print dialog box.

❖ To print details about a specific object displayed in the window, select the object,

choose File > Print , and then complete the Print dialog box.

❖ To print the contents of a Properties window, click the Print  button and complete the

Print dialog box.

Exiting the Storage Administrator

❖ To exit the VERITAS Volume Manager Storage Administrator client, choose File  >

Exit .
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Disk Tasks 3
Introduction

This chapter describes how to set up and use disks and disk groups with the VERITAS

Volume Manager Storage Administrator (VERITAS Volume Manager Storage

Administrator). The Disk Task Roadmap at the beginning of this chapter contains a

summary of common disk and disk group tasks.

The following disk tasks are discussed in this chapter:

◆ Adding a Disk to VxVM

◆ Scanning Disks

◆ Designating a Disk as a Hot-Relocation Spare

◆ Reserving a Disk

◆ Renaming a Disk

◆ Offlining a Disk

◆ Onlining a Disk

◆ Mirroring a Disk

◆ Evacuating a Disk

◆ Disconnecting a Disk

◆ Replacing a Disk

◆ Unrelocating a Disk

◆ Recovering Volumes on a Disk

◆ Removing a Disk

◆ Forcing Initialization of a Disk

◆ Viewing Disk Properties

◆ Disabling a Controller

◆ Enabling a Controller
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◆ Renaming an Enclosure

The following disk group tasks are discussed in this chapter:

◆ Creating a Disk Group

◆ Upgrading a Disk Group

◆ Renaming a Disk Group

◆ Deporting a Disk Group

◆ Importing a Disk Group

◆ Recovering Volumes in a Disk Group

◆ Clearing Relocation Information for a Disk Group

◆ Destroying a Disk Group

◆ Moving Objects Between Disk Groups

◆ Splitting A Disk Group

◆ Joining Disk Groups

◆ Activating a Disk Group

◆ Viewing Disk Group Properties
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Disk Task Roadmap

Disk Task Roadmap
The following table provides a summary of common VERITAS Volume Manager Storage

Administrator disk and disk group tasks.

To perform this task … Use this procedure …

Disk Setup Tasks:

Place new disks under VERITAS Volume

Manager (VxVM) control

Adding a Disk to VxVM

Set up new disk groups Creating a Disk Group

Precautionary Tasks:

Add disks as hot-relocation spares Designating a Disk as a Hot-Relocation Spare

Place the boot (root) disk under Volume

Manager control

Make an alternate boot (root) disk

Adding a Disk to VxVM

Mirroring a Disk

Maintenance Tasks:

Place additional disks under VxVM control Adding a Disk to VxVM

Add more disk space to a disk group Adding a Disk to VxVM

Create additional disk groups Creating a Disk Group

Upgrade a disk group Upgrading a Disk Group

Recovery Tasks:

Move volumes off failing disks Evacuating a Disk

Replace failed disks Replacing a Disk

Attempt to recover all volumes on a disk Recovering Volumes on a Disk

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group

Other Tasks:

Change a disk name Renaming a Disk

Change a disk group name Renaming a Disk Group

Move objects between disk groups Moving Objects Between Disk Groups

Split a disk group Splitting A Disk Group

Join disk groups Joining Disk Groups

Temporarily prevent access to a disk Offlining a Disk

Restore access to an offline disk Onlining a Disk



Disk Task Roadmap

72 VERITAS Volume Manager Storage Administrator Administrator’s Guide

Temporarily prevent access to a disk group Deporting a Disk Group

Restore access to a deported disk group Importing a Disk Group

Remove a disk from VxVM control Removing a Disk

Destroy a disk group (permanently) Destroying a Disk Group

To perform this task … Use this procedure …



Chapter 3, Disk Tasks 73

Adding a Disk to VxVM

Adding a Disk to VxVM
New disks must be set up on the system, placed under VxVM control, and added to a disk

group before they can be used for volumes. The Disks > Add task performs these tasks to

prepare new disks for VxVM use. You can also use this task to add a disk to a disk group.

When you place a disk under VxVM control, the disk is either encapsulated or initialized.

Encapsulation preserves any existing data on the disk in volumes. Initialization destroys

any existing data on the disk.

If you place the root disk under VxVM control, you must encapsulate the disk. If you want

to create an alternate boot disk, you can mirror the encapsulated root disk (see “Mirroring

a Disk” on page 83).

This task assigns a default VERITAS Volume Manager disk name to the disk. Once the

disk is under VxVM control, you can use the Rename Disk  task to change the VERITAS

Volume Manager disk name (see “Renaming a Disk” on page 80).

▼ To add a disk to the Volume Manager

1. If the disk is brand new, select the appropriate host machine node and choose Hosts >

Scan Disks  (Selected  menu) to set up the disk on the system. This runs the disk

setup commands appropriate for the operating system.

2. Select the uninitialized disk to be placed under VxVM control.

3. Choose Disks  > Add  (Selected  menu) or Disk Add  (Command Launcher).

4. Complete the Add Disk(s) dialog box as follows:

Disk Device(s): If the correct disk (device) name does not already display in this

field, enter the disk device name or click Browse to select the disk.

To set up any new disks on the system, click Scan Disks . The

Scan Disks procedure runs the disk setup commands

appropriate for the operating system.
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When you have provided all necessary information in the dialog box, click OK.

5. Indicate whether the disk should be initialized or encapsulated. If you initialize the

disk, any existing data on the disk is destroyed. If you encapsulate the disk, any

existing data is preserved in volumes.

6. If you chose to encapsulate the disk, reboot the system.

▼ To place the root disk under VxVM control

1. Select the root (boot) disk.

2. Choose Disks > Add (Selected  menu) or Disk Add  (Command Launcher).

Add Disk(s) to: Specify where to place the disk(s):

- To add the disk(s) to an existing disk group, select Existing
Disk Group . Enter the disk group name in the Disk Group

Name field or click Browse  to select a disk group.

- To add the disk(s) to a new disk group, select New Disk
Group . Enter the name of the new disk group in the Disk

Group Name field. The new disk group is created for the new

disk.

- To place the disk(s) in the free disk pool, select Free Disk
Pool . Disks in the free disk pool are under VxVM control, but

do not belong to a disk group and cannot be used to create

volumes.

Options Click Show Options  to access the optional settings for this task.

- To create a shared disk group for the disk(s), select New Disk
Group  and Create Shared . The Create Shared  option is

only applicable in a cluster environment.

- To specify the VERITAS Volume Manager disk name for the

disk, enter a disk name in the Disk Name(s) field. If no

VERITAS Volume Manager disk name is specified, VxVM

assigns a default name to the disk.

- To set the disk group activation mode, click Activation Mode
and complete the Activate Disk Group dialog box. The

activation mode controls read and write access to volumes in

the disk group.

- To apply a comment attribute to disks that are placed in a disk

group, enter the information in the Comment field.
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Adding a Disk to VxVM

3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

4. Indicate that the root disk should be encapsulated. When you encapsulate the disk, any

existing data is preserved in volumes.

5. Reboot the system.

After placing the root disk under VxVM control, it is recommended that you create an

alternate boot disk by mirroring the root disk (see “Mirroring a Disk” on page 83).

▼ To add a disk to a disk group

1. Select the disk to be added to a disk group.

2. Choose Disks  > Add  (Selected menu) or Disk Add  (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

Disk Device(s): If the correct disk (device) name does not already display in this

field, enter the root disk name or click Browse  to select the disk.

Add Disk(s) to: Specify that the root disk should be placed in the root disk group.

Select Existing Disk Group . Enter the root disk group name

(rootdg ) in the Disk Group Name field.

Disk Device(s): If the correct disk (device) name is not already displayed in this

field, enter the disk name or click Browse  to select the disk.

Add Disk(s) to: Specify where the disks should be placed:

- To add the disks to an existing disk group, select Existing Disk
Group . Enter the disk group name in the Disk Group Name

field or click Browse  to select a disk group.

- To add the disks to a new disk group, select New Disk Group .

Enter the name of the new disk group in the Disk Group Name

field. The new disk group is created for the new disk.
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When you have provided all necessary information in the dialog box, click OK.

Options Click Show Options  to access the optional settings for this task.

- To create a shared disk group for the disks, select New Disk
Group  and Create Shared . The Create Shared  option is

only applicable in a cluster environment.

- To specify the VERITAS Volume Manager disk name for the disk,

enter a disk name in the Disk Name(s) field. If no VERITAS

Volume Manager disk name is specified, VxVM assigns a default

name to the disk.

- To apply a comment attribute to the disk, enter the information

in the Comment field.

Notes:

- The Disks > Add task requires a disk device name and the location for the new disk (that

is, a disk group or the free space pool).

- The Disks  > Add  task sets up disks for VxVM use. Disks must be under VxVM control

and in a disk group before they can be used to create volumes.

- When a disk is placed under VxVM control, the disk is either initialized or encapsulated.

Encapsulation preserves any existing data on the disk in the form of volumes.

Initialization destroys any existing data on the disk. Encapsulation is recommended for

the root/boot disk and any other disks that contain valuable data.

- Disk encapsulation requires a system reboot.

- Disks in the free disk pool must be added to a disk group before they can be used to create

volumes.

- Disks must be online before they can be added to a disk group or the free disk pool.

- Disks that already belong to a disk group cannot be added to another disk group or

placed in the free disk pool.

- Disks cannot be added to deported disk groups.

- The root disk must be placed in the root disk group (rootdg ). If the root disk is placed in

any other disk group, the root disk cannot be used to boot the system.

- The VERITAS Volume Manager disk name must be unique within the disk group.

- If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, VxVM appends numbers to the disk name so that each

disk name is unique within the disk group.
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Scanning Disks

Scanning Disks
The Scan Disks  procedure checks for new disks and runs the appropriate commands to

set up any new disks. You can use this task to make sure that VxVM recognizes any new

hardware.

▼ To scan disks

1. Select the host machine to be scanned for new disks.

2. Choose Hosts  > Scan Disks  (Selected  menu) or Disk Scan  (Command Launcher).

3. Complete the Scan Disk dialog box as follows:

Host(s): If the correct host name does not already display in this field, enter

the host name or click Browse  to select the host.

Notes:

- New disks must be set up on the system before they can be used by VxVM.

- The Scan Disks  task scans the system for new disks. If any new disks are found, this

task runs the appropriate commands to set up the new disks on the system.
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Designating a Disk as a Hot-Relocation Spare
The Spare option adds a disk to the pool of spare disks available to the hot-relocation

feature. If an I/O failure occurs, hot-relocation automatically relocates any redundant

(mirrored or RAID-5) subdisks to spare disks and restores the affected VERITAS Volume

Manager objects and data. The system administrator is notified of the failure and

relocation details via electronic mail. After successful relocation, you can replace the failed

disk (see “Replacing a Disk” on page 86).

▼ To designate a disk as a hot-relocation spare

1. Follow the instructions in “Adding a Disk to VxVM” on page 73 to place the disk

under VxVM control and in a disk group.

2. Select the disk to be designated as a hot-relocation spare.

3. Choose Disks  > Properties  (Selected  menu).

4. In the Disk Properties window, go to the General  tab and select Spare . Click OK.

To remove the disk from the pool of hot-relocation spares, open the Disk Properties

window and select Spare  again.

Notes:

- Before you select the Spare  option, make sure the disk is under VxVM control and in a

disk group.

- Any disk in the same disk group can use the spare disk.

- To ensure that sufficient space is available for relocation, provide at least one

hot-relocation spare disk per disk group.
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Reserving a Disk

Reserving a Disk
The Reserve option designates a disk as a reserved disk. A reserved disk is not

considered part of the free space pool. If you perform a task that requires disk space and

you do not specify a disk, VERITAS Volume Manager Storage Administrator allocates

space from disks other than the reserved disk.

▼ To reserve a disk

1. Follow the instructions in “Adding a Disk to VxVM” on page 73 to place the disk

under VxVM control and in a disk group.

2. Select the disk to be reserved.

3. Choose Disks  > Properties  (Selected  menu).

4. In the Disk Properties window, go to the General  tab and select Reserve . Click OK.

To return a reserved disk to the free space pool, open the Disk Properties window and

select Reserve  again.

Notes:

- Before you select the Spare  option, make sure the disk is under VxVM control and in a

disk group.

- A reserved disk does not belong to the free space pool and is not available for general use.

- A reserved disk can only be used if you specify the reserved disk when you perform a

task.
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Renaming a Disk
The Disk Rename procedure changes the VERITAS Volume Manager name assigned to a

disk. The VERITAS Volume Manager disk name is the name given to the disk by the

administrator or VxVM. This procedure does not change the physical disk name (device

name).

▼ To rename a disk

1. Select the disk to be renamed.

2. Choose Disks  > Rename  (Selected  menu) or Disk Rename  (Command Launcher).

3. Complete the Rename Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

New Name: Enter the new VERITAS Volume Manager disk name.

Notes:

- The Disk Rename  task requires the current disk name and a new disk name.

- The new disk name must be unique within the disk group.

- The disk must be in an imported disk group.
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Offlining a Disk

Offlining a Disk
The Disk Offline procedure prevents VxVM from accessing a disk. A disk must be

removed from its disk group before it can be taken offline (see “Removing a Disk” on

page 91). An offline disk remains unavailable until you restore access to the disk (see

“Onlining a Disk” on page 82).

▼ To take a disk offline

1. Select the disk to be taken offline.

2. Choose Disks  > Offline  (Selected  menu) or Disk Offline  (Command Launcher).

3. Complete the Offline Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

Notes:

- When a disk is offline, the disk cannot be accessed by VxVM.

- A disk can be taken offline to protect it from unintentional use. Disks should be taken

offline if they are not accessible and attempts to access them may have a negative effect on

the system.

- Only disks that do not belong to a disk group can be taken offline.

- Disks that are in use cannot be taken offline.
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Onlining a Disk
The Disk Online procedure restores access to a disk that has been taken offline. The disk is

placed in the free disk pool and is accessible to VxVM again. After bringing a disk back

online, the disk must be added to a disk group before it can be used for volumes (see

“Adding a Disk to VxVM” on page 73).

▼ To bring a disk online

1. Select the disk to be brought online.

2. Choose Disks  > Online  (Selected  menu) or Disk Online  (Command Launcher).

3. Complete the Online Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

Notes:

- When a disk is brought online, the disk is accessible again.

- Only disks in the offline state can be brought online.
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Mirroring a Disk

Mirroring a Disk
The Disk Mirror procedure mirrors (copies) all concatenated volumes on a disk onto

another disk and sets up the target disk as a boot disk. This is a convenient way of creating

an alternate boot (root) disk, which can be used to boot the system if the original boot disk

fails. You can use this procedure to mirror any disk that contains concatenated volumes.

▼ To mirror all concatenated volumes on a disk

1. Select the disk that contains the concatenated volumes to be mirrored onto another

disk.

2. Choose Disks > Mirror  (Selected  menu) or Disk Mirror  (Command Launcher).

3. Complete the Mirror Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

Options To specify the disk to contain the new mirrors, click the Browse
button next to the Target Disk(s) field and select a disk.

Notes:

- The Disk Mirror  task requires a disk name.

- The Disk Mirror  task is typically used to mirror the contents of the boot disk onto

another disk, which can be used as an alternate boot disk. After mirroring the root and

swap volumes (which must be named rootvol  and swapvol , respectively), this task

sets up the target disk as a boot disk.

- Only concatenated volumes that reside on a single disk are mirrored onto the other disk.

Any RAID-5, striped, or spanned volumes on the disk are ignored.

- Only disks in the same disk group can be used to create the new mirrors.

- The target disk must contain sufficient space to accommodate the mirrors.

- A new mirror cannot be created on a disk that already contains a copy of the volume.

- If no disks are assigned, VxVM uses available disk space to create the mirrors.
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Evacuating a Disk
The Disk Evacuate procedure moves the contents of the volumes on a disk to another

disk. If a disk begins to fail, you can attempt to protect/preserve the volumes on that disk

by evacuating the disk. You can also evacuate a disk if you plan to remove the disk or use

the disk elsewhere.

▼ To evacuate a disk

1. Select the disk that contains the objects and data to be moved to another disk.

2. Choose Disks > Evacuate (Selected menu) or Disk Evacuate (Command Launcher).

3. Complete the Evacuate Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field,

enter the disk name or click Browse  to select the disk.

Options To specify the disks to which the contents of the evacuated disk

should be moved, click the Browse  button next to the Target

Disk(s) field and select a disk.

Notes:

- The Disk Evacuate  task requires a disk name.

- The contents of a disk must be evacuated/moved to another disks in the same disk group

with sufficient free space.

- If no target disk is specified, VxVM uses an available disks with sufficient free space.

- If the disk being evacuated contains part of a mirrored, striped, or RAID-5 volume, do not

move the contents of the disk to another disk containing a copy of the mirrored volume or

part of the striped/RAID-5 volume.
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Disconnecting a Disk

Disconnecting a Disk
The Disconnect Disk procedure disconnects a VERITAS Volume Manager disk from its

underlying physical disk. You can disconnect a disk in preparation for the replacement of

a physical disk. After disconnecting a disk, you can use the Replace Disk  task to

reconnect the disk (see “Replacing a Disk” on page 86).

▼ To disconnect a disk

1. Select the disk to be disconnected.

2. Choose Hosts  > Disconnect Disk  (Selected  menu) or Disk Disconnect  (Command

Launcher).

3. Complete the Disconnect Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk: If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

Notes:

- The Disconnect Disk  task requires a disk name.

- Disconnecting a disk that contains volumes can result in loss of data or redundancy.
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Replacing a Disk
The Disk Replace procedure replaces an existing disk with a new physical disk, moves

any volumes to the new disk, and attempts to recover any redundant (mirrored or

RAID-5) volumes on the disk. Non-redundant volumes cannot be recovered and must be

restored from backup, if possible. If the disk being replaced is a boot disk, the Disk
Replace procedure also sets up the new disk as a boot disk.

You may need to replace a disk if the disk fails and/or needs to be removed and repaired.

You can use this task to reconnect a disk that has been disconnected in preparation for

replacement (see “Disconnecting a Disk” on page 85).

If you replace a healthy disk, remove the disk from its disk group and place it in the free

disk pool before you replace the disk (see “Removing a Disk” on page 91). If the disk to be

replaced has failed and is disconnected, you do not need to remove the disk.

▼ To replace a disk

1. Select the disk to be replaced.

2. Choose Disks  > Replace  (Selected  menu) or Disk Replace  (Command Launcher).

3. Complete the Replace Disk dialog box as follows:

Disk Name: If the correct disk name does not already display in this field, enter

the VERITAS Volume Manager disk name for the disk to be

replaced or click Browse  to select the disk.

New Physical Disk: Enter the physical disk name for the new (replacement) disk or

click Browse  to select a disk.

Options To set up any new disks on the system, click Scan Disks . The

Scan Disks option runs the disk setup commands appropriate

for the operating system.
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Replacing a Disk

When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Disk Replace task requires the name of the disk to be replaced and the replacement

disk name.

- The disk to be replaced must be disconnected or removed from its disk group. If the disk

has not failed, remove the disk from its disk group and put it in the free disk pool before

you replace the disk.

- The new disk can be a disk in the free disk pool or an uninitialized disk. If the new disk is

uninitialized, the Disk Replace task places the disk under Volume Manager control.

- The new disk is placed in the disk group of the old disk.



Unrelocating a Disk

88 VERITAS Volume Manager Storage Administrator Administrator’s Guide

Unrelocating a Disk
The Disk Unrelocate procedure moves relocated subdisks back to the original disk. When

a disk fails, the hot-relocation feature attempts to move subdisks from the failed disk to

other disks. The Disk Unrelocate  task can be used to return the relocated subdisks to

their original disk locations after the original disk is repaired or replaced.

▼ To move relocated subdisks back to a disk

1. Select the disk that contained the subdisks before hot-relocation.

2. Choose Disks  > Unrelocate  (Selected menu) or Disk Unrelocate  (Command

Launcher).

3. Complete the Unrelocate Disk dialog box as follows:

Disk Name: If the original disk name does not already display in this field,

enter the disk name or click Browse to select the disk. This is the

disk that contained the subdisks before they were relocated.

Options - To view subdisks that were relocated by the hot-relocation

feature, click View Relocations .

- To move the relocated subdisks to a disk other than the

original disk, specify an alternate disk in the Alternate

Destination Disk field.

- To move the subdisks back to their original locations on the

original disk, click Use Exact Offsets . If the original

locations are not available, it may be necessary to turn off

this option so that the subdisks can be moved to any

available space on the disk.
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Unrelocating a Disk

When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Disk Unrelocate task requires the name of the original disk (even if an alternate

disk is specified).

- When a disk fails, the hot-relocation feature attempts to move subdisks from the failed

disk to other disks. The Disk Unrelocate  task can be used to return the relocated

subdisks to their original disk locations after the original disk is repaired or replaced.

- It is not possible to return relocated subdisks to their original disks after their disk group

relocation information has been cleared with the Clear Disk Group Relocation
Information  task.
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Recovering Volumes on a Disk
The Disk Recover procedure performs any necessary volume recovery operations on the

volumes on a given disk. The recovery operations depend on the types of volumes on the

disk and include starting disabled volumes, resynchronizing mirrors in mirrored

volumes, and resynchronizing parity in RAID-5 volumes. After successful recovery, the

volumes are again available for use.

Alert icons and the Alert Monitor window may provide clues to let you know that volume

recovery is needed.

▼ To recover all volumes on a disk

1. Select the disk containing the volumes to be recovered.

2. Choose Disks  > Recover  (Selected  menu) or Disk Recover  (Command Launcher).

3. Complete the Recover Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name does not already display in this field,

enter the disk name or click Browse  to select the disk.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to

restore the volume from backup.
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Removing a Disk

Removing a Disk
The Disk Remove procedure removes a disk from its disk group and either places the

disk in the free disk pool or removes the disk from VxVM control. If the disk is returned to

the free space pool, the disk must be added to a disk group before it can be used for

volumes (see “Adding a Disk to VxVM” on page 73).

If the disk to be removed contains volumes, you must evacuate the disk before you

remove the disk.

▼ To remove a disk from a disk group or from VxVM control

1. Select the disk to be removed.

2. Choose Disks  > Remove  (Selected  menu) or Disk Remove  (Command Launcher).

3. Complete the Remove Disk dialog box as follows:

Disk Name(s): If the correct disk name does not already display in this field,

enter the disk name or click Browse  to select the disk.

Select a destination for

the disks:

Specify where to place the disk after removal:

- To remove the disk from its disk group and place it in the free

disk pool, select Free Disk Pool . The disk remains under

VxVM control.

- To remove the disk from VxVM control, select Uninitialized
State .
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When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Disk Remove  task requires a disk name. You must also specify whether the disk is

placed in the free disk pool or removed from VxVM control.

- If the disk contains a volume that has only one mirror and either has a mounted file

system or is used as a swap area, you must evacuate the disk before you remove it.

- When a disk is removed from a disk group or VxVM control, the disk cannot be accessed.

- A disk that is in use (i.e., contains volumes) must not be removed. Removing a disk with

volumes can result in loss of data or data redundancy. If volumes exist on the disk to be

removed, use the Evacuate Disks  task to move the volumes to another disk.

- The last disk in a disk group cannot be removed. To remove the last disk in a disk group,

the disk group must be destroyed. The last disk in the rootdg  disk group can never be

removed.

- Any non-redundant volumes on the removed disk become disabled.
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Forcing Initialization of a Disk

Caution Forcing the initialization or reinitialization of a disk can result in data loss.

The Initialize Disk procedure forces the initialization of a disk. This procedure can be

used to reinitialize a disk. This task is intended for use in troubleshooting disks that have

already been placed under VxVM control. To initialize a disk for VxVM use, use the Add
Disks  task instead (see “Adding a Disk to VxVM” on page 73).

▼ To (re)initialize a disk

1. Select the disk to be initialized.

2. Choose Hosts  > Initialize Disk  (Selected  menu) or Disk Initialize  (Command

Launcher).

3. Complete the Initialize Disk  dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name does not already display in this field, enter

the disk name or click Browse  to select the disk.

Notes:

- The Initialize Disk  task requires a disk name.

- The Initialize Disk  task forces the (re)initialization of a disk and can result in data loss.

- The Initialize Disk  task overwrites existing disk header and configuration information

on the disk. Any volume copies or regions located on the disk are not accessible after you

reinitialize the disk.
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Viewing Disk Properties
The Disk Properties window contains detailed information about the selected disk. The

Properties window contains a set of tabbed pages, each of which contains information

about the disk and related objects. You can display a different page by clicking on the

appropriate tab label.

❖ To view the properties of a disk, select the disk and then choose Properties  from the

Disks  or popup menu. You can also access the Disk Properties window by

double-clicking on the disk.

❖ To find available space on the disk, click on the Subdisks  tab. Areas of free space are

listed as “gaps” in the Subdisks  tab. To sort the subdisks and gaps by their location

on the disk, click the Disk Offset  column heading.

❖ To update the contents of the Properties window to reflect current properties for the

disk, click Refresh .

❖ To print the contents of the Properties window, click Print  and complete the Print

dialog box.
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Disabling a Controller
The Controller Disable procedure disables I/O to a controller. This procedure also

prevents the Dynamic Multipathing (DMP) feature from accessing the paths associated

with a controller. You can disable access to a controller in preparation for hardware

maintenance.

▼ To enable a controller

1. Select the controller to be disabled.

2. Choose Controller Disable  (Command Launcher).

3. Complete the Disable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Controller Name(s): If the correct controller name does not already display in this field,

enter the controller name or click Browse  to select the controller.

Options Click Show Options  to access the optional settings for this task.

- To disable all enclosures (disk arrays) associated with this

controller, select All Enclosures .

- To disable specific enclosures associated with this controller,

enter the enclosure names in the Selected Enclosures field or

click Browse  to select the enclosures.

Notes:

- The Controller Disable  task requires a controller name.

- The Controller Disable  task prevents I/O and the DMP feature from accessing the

paths associated with the specified controller.

- The specified controller cannot contain the last enabled path to the root disk.
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Enabling a Controller
The Controller Enable procedure enables I/O to a controller. If the Dynamic

Multipathing (DMP) feature is enabled, this procedure also restores access to the paths

associated with a controller.

▼ To enable a controller

1. Select the controller to be enabled.

2. Choose Controller Enable  (Command Launcher).

3. Complete the Enable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Controller Name(s): If the correct controller name does not already display in this field,

enter the controller name or click Browse  to select the controller.

Options Click Show Options  to access the optional settings for this task.

- To enable all enclosures (disk arrays) associated with this

controller, select All Enclosures .

- To enable specific enclosures associated with this controller,

enter the enclosure names in the Selected Enclosures field or

click Browse  to select the enclosures.

Notes:

- The Controller Enable  task requires a controller name.

- The Controller Enable  task makes the paths associated with the specified controller

available to I/O and the DMP feature.
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Renaming an Enclosure
The Enclosure Rename procedure changes the name of an enclosure (disk array).

▼ To rename an enclosure

1. Select the enclosure to be renamed.

2. Choose Enclosures  > Rename (Selected  menu) or Enclosure Rename  (Command

Launcher).

3. Complete the Rename Enclosure dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Enclosure Name: If the correct enclosure name does not already display in this field,

enter the name or click Browse  to select the enclosure.

New Name: Enter the new enclosure name.

Notes:

- The Enclosure Rename task requires the current enclosure name and a new enclosure

name.

- The new enclosure name must be unique within the disk group.
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Creating a Disk Group
The Disk Group Create procedure creates an additional disk group. Disks must be placed

in disk groups before they can be used by VxVM. The default disk group (rootdg ) is

usually created during VxVM installation and always exists on a system running VxVM.

You can create additional disk groups to organize your disks into logical sets of disks.

When you place a disk under VxVM control, the disk is either encapsulated or initialized.

Encapsulation preserves any existing data on the disk in volumes. Initialization destroys

any existing data on the disk.

▼ To create a disk group

1. Select the appropriate host machine.

2. Choose File  > New > Disk Group  (Selected  menu) or Disk Group Create
(Command Launcher).

3. Complete the New Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Enter the name of the disk group to be created. Click View to view

the names of existing disk groups.

To set up any new disks on the system, click Scan Disks . This

runs the disk setup commands appropriate for the operating

system.

Disk Device(s): Select the disks to be placed in the new disk group.

Options Click Show Options  to access the optional settings for this task.

- To create a shared disk group, select Create Shared . This

option is only applicable in a cluster environment.

- To specify the VERITAS Volume Manager disk name for the

disk, enter a disk name in the Disk Name(s) field. If no

VERITAS Volume Manager disk name is specified, VxVM

assigns a default name to the disk.

- To set the disk group activation mode, click Activation Mode
and complete the Activate Disk Group dialog box. The

activation mode controls read and write access to volumes in

the disk group.

- To apply a comment or attribute to disks that are placed in the

disk group, enter the information in the Comment field.
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4. Indicate whether the disk should be initialized or encapsulated. If you initialize the

disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any

existing data will be preserved in volumes.

5. If you chose to encapsulate the disk, reboot the system.

Notes:

- The Disk Group Create task requires a disk group name and the name of at least one

disk.

- The disk group name must be unique.

- The new disk group must contain at least one disk.

- Only disks that are online and do not belong to a disk group can be used to create a disk

group.

- When a disk is placed under VxVM control, the disk is either initialized or encapsulated.

Encapsulation preserves any existing data on the disk in the form of volumes.

Initialization destroys any existing data on the disk. Encapsulation is recommended for

the root/boot disk and any other disks that contain valuable data.

- The Volume Manager disk name must be unique within the disk group.

- If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, VxVM appends numbers to the disk name so that each

disk name is unique within its disk group.
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Upgrading a Disk Group
The Disk Group Upgrade procedure upgrades a disk group to the disk group version

that is compatible with the current VERITAS Volume Manager release. Some new features

and tasks only work on disk groups with the current disk group version, so you must

upgrade existing disk groups before you perform these tasks. However, after you upgrade

a disk group, you cannot access that disk group from machines running earlier releases of

VxVM.

To determine if a disk group needs to be upgraded, select the disk group and open the

Disk Group Properties window. The Version field of the Properties window indicates

whether the disk group has been upgraded to the current disk group version.

▼ To upgrade a disk group

1. Select the disk to be upgraded to the current version.

2. Choose Disks Groups  > Upgrade  (Selected  menu) or Disk Group Upgrade
(Command Launcher).

3. Complete the Upgrade Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name does not already display in this field,

enter the disk group name or click Browse to select the disk group.

Notes:

- Disk groups created with earlier releases of VxVM must be upgraded before they can take

advantage of new features and tasks in the current release.

- If a disk group is upgraded to the current disk group version, you cannot import that disk

group on a machine running an earlier VERITAS Volume Manager release. Disk groups

that must remain backward compatible with earlier releases of VxVM must not be

upgraded.
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Renaming a Disk Group
The Disk Group Rename procedure changes the name of an existing disk group. You can

rename a disk group to provide a more appropriate name or to avoid a name conflict with

a disk group to be imported.

▼ To rename a disk group

1. Select the disk group to be renamed.

2. Choose Disks Groups  > Rename  (Selected  menu) or Disk Group Rename
(Command Launcher).

3. Complete the Rename Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: If the correct disk group name does not already display in this

field, enter the disk group name or click Browse to select the disk

group.

New Name: Enter the new name for the disk group.

Notes:

- The Disk Group Rename  task requires the current disk group name and a new disk

group name.

- The new disk group name must be unique.

- The Disk Group Rename task deports and re-imports the disk group. If volumes in the

disk group are in use, the deport fails and the disk group is not renamed.

- The Disk Group Rename  task updates the file system table file, if necessary.

- If the disk group contains volumes with mounted file systems, you may need to unmount

the file systems.
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Deporting a Disk Group
The Disk Group Deport procedure makes a disk group and its volumes inaccessible.

Once deported, a disk group cannot be used until it is imported. You can deport a disk

group to make the disk group temporarily unavailable.

While a disk group is deported, you cannot remove and reuse any of its disks. To remove

disks, you must import the disk group and then either destroy the disk group (to remove

all of its disks) or remove selected disks from the disk group.

▼ To deport a disk group

1. Select the disk group to be deported.

2. Choose Disk Groups  > Deport  (Selected  menu) or Disk Group Deport  (Command

Launcher).

3. Complete the Deport Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: If the correct disk group name does not already display in this

field, enter the disk group name or click Browse to select the disk

group.

Options Click Show Options  to access the optional settings for this task.

- To change the name of the disk group at deport, enter a new

disk group name in the New Name field.

- To set up a host machine to import the deported disk group at

reboot, enter the host ID in the New Host field.

Notes:

- The Disk Group Deport  task requires a disk group name.

- A deported disk group cannot be accessed. To access a deported disk group, the disk

group must be imported.

- The rootdg  disk group cannot be deported.

- A disk group cannot be deported if any volumes in that disk group are in use (open).

- When a disk group is deported, the host ID stored on all disks in the disk group is cleared

and the disk group is not re-imported automatically when the system is rebooted.

However, if you specify a host in New Host option, the specified host imports the disk

group at reboot.
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Importing a Disk Group
The Import Disk Group procedure makes a deported (inaccessible) disk group and its

volumes accessible again. To import a deported disk group, you must know the disk

group former name and this disk group name must remain unused. In addition, at least

one disk formerly assigned to the deported disk group must remain unused.

▼ To import a disk group

1. Select the appropriate host machine node.

2. Choose Hosts  > Import Disk Group  (Selected  menu) or Disk Group Import
(Command Launcher).

3. Complete the Import Disk Group dialog box as follows:

Disk Group Name: Enter the name of the disk group to be imported or click Browse
to select the disk group.

Options Click Show Options  to access the optional settings for the

Import Disk Group  task.

- To start all volumes in the disk group at import, select Start
All Volumes .

- To clear the existing host ID stamp on all disks in the disk

group at import, select Clear Host ID . Do not use this option

if another host is using any disks in the disk group.

- To force the disk group import when the host cannot access all

disks in the disk group, select Force Import . This option can

be used to import a disk group that contains a failed disk, but

can lead to disk group inconsistency if all disks are still usable.

- To import the disk group as a shared disk group, select Import
Shared . This option is only applicable in a cluster

environment.

- To change the name of the disk group at import, enter a new

disk group name in the New Name field. To indicate that the

name change is temporary, select Use New Name  as

Temporary .
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When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Import Disk Group task requires a disk group name.

- Only deported disk groups can be imported.

- A deported disk group cannot be imported if another disk group with the same name has

been created since the disk group was deported.

- A disk group import can fail if the host cannot find one or more disks in the disk group. If

the import fails because a disk has failed, you can import the disk group by selecting the

Force Import  option. If the import fails for another reason, a forced import can cause

serious problems.

- When a disk group is imported, the system stamps its host ID on all disks in the disk

group. A disk group import fails if one of the disks is stamped with a host ID that does

not match the others. This ensures that dual-ported disks cannot be managed (and

possibly corrupted) by two systems at the same time. If you are sure that the disk group is

not in use by another host, you can clear the host IDs and import the disk group by

selecting the Clear Host ID  option.
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Recovering Volumes in a Disk Group
The Disk Group Recover procedure performs any necessary volume recovery operations

on the volumes in a given disk group. The recovery operations depend on the types of

volumes in the disk group and include starting disabled volumes, resynchronizing

mirrors in mirrored volumes, and resynchronizing parity in RAID-5 volumes. After

successful recovery, the volumes are again available for use.

Alert icons and the Alert Monitor window may provide clues to let you know that volume

recovery is needed.

▼ To recover all volumes in a disk group

1. Select the disk group containing the volumes to be recovered.

2. Choose Disk Groups  > Recover  (Selected  menu) or Disk Group Recover
(Command Launcher).

3. Complete the Recover Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name does not already display in this field,

enter the disk group name or click Browse to select the disk group.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to

restore the volume from backup.
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Clearing Relocation Information for a Disk Group
The Disk Groups Clear Relocation Information procedure clears hot-relocation alerts

and removes relocation data from a disk group.

▼ To clear relocation information for a disk group

1. Select the disk group containing hot-relocation information to be cleared.

2. Choose Disk Groups  > Clear Relocation Information  (Selected  menu) or Disk
Group Clear Relocation Info  (Command Launcher).

3. Complete the Clear Disk Group Relocation Information dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name does not already display in this

field, enter the disk group name or click Browse to select the disk

group.

Notes:

- Hot-relocation automatically relocates subdisks from a failed disk to other disks. The disk

group records information about the hot-relocation and former subdisk locations. After

successful hot-relocation, alerts can remain on objects in VERITAS Volume Manager

Storage Administrator. The Disk Groups Clear Relocation Information  task

removes all records of the former subdisk locations from the disk group and clears any

alerts.

- After the disk group relocation information has been cleared, it is not possible to use the

Disk Unrelocate task to return the relocated subdisks to their original disks.
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Destroying a Disk Group

Caution Destroying a disk group can result in data loss.

The Destroy Disk Group procedure permanently removes a disk group from VxVM

control. This procedure also reinitializes all of the disks in the disk group as empty disks

and places them in the free disk pool for reuse.

Destroy a disk group only if you are sure that you no longer need the volumes and data in

the disk group. Since the last disk in a disk group cannot be removed, destroying a disk

group is useful for freeing the last disk in a disk group for reuse.

▼ To destroy a disk group

1. Select the appropriate host machine node.

2. Choose Hosts  > Destroy Disk Group  (Selected  menu) or Disk Group Destroy
(Command Launcher).

3. Complete the Destroy Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Enter the name of the disk group to be destroyed or click Browse
to select the disk group.

Notes:

- Use the Destroy Disk Group  task with caution. Destroying a disk group permanently

removes the disk group from VxVM control and can result in data loss.

- When a disk group is destroyed, its disks are returned to the free disk pool. Any volumes

in the disk group are removed.

- The rootdg  disk group cannot be destroyed.

- A disk group cannot be destroyed if any volumes in that disk group are in use (open)

and/or contain mounted file systems.
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Moving Objects Between Disk Groups
The following procedure moves a self-contained set of VERITAS Volume Manager Storage

Administrator objects between imported disk groups. This operation is performed on

VERITAS Volume Manager Storage Administrator objects such as disks or top-level

volumes, and includes all component objects such as sub-volumes, plexes and subdisks.

▼ To perform a disk group move operation:

1. Select Disk Groups  > Move .

2. Complete the Move Disk Group Dialog Box as follows:

Disk Group Name: Enter the name of the disk group from which objects are to be

moved or click Browse  to select the disk group.

Target Disk Group

Name

Enter the name of the disk group into which objects are to be

moved, or click Browse  to select the disk group.

Select Objects to move Enter the objects to be moved, or click Browse  to select the disk

objects. If you click Browse , a further dialog box will be displayed

with the following options:

- To select volumes to move, click Select Volumes, and choose

from the displayed list. To select all of the listed volumes, click

Select All.
- To select disks to move, click Select disks, and choose from

the displayed list.

- Click on OK.

Expand Click Expand to specify that the objects that are actually moved

should include all other disks that contain subdisks that are

associated with the specified objects or with objects that they

contain. For example, if you specify that disk01 should be moved

and disk01 contains vol1 which is also located on disk02, then by

using the Expand button, you ensure that disk02 will also be

moved.

Show Dependencies Click Show Dependencies  to display the objects affected

by the move.
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Note:

- Before moving volumes between disk groups, stop all applications that are accessing the

volumes, and unmount all file systems that are configured in the volumes.

- The objects to be moved must be self-contained, meaning that the disks that are moved

must not contain any other objects that are not intended for the move.

- This operation fails if it would remove all the disks from the source disk group. Volume

states are preserved across the move.

- The reconfiguration must involve an integral number of physical disks.

- Objects to be moved must not contain open volumes.

- Data change objects (DCOs) and snap objects that have been dissociated by Persistent

FastResync cannot be moved between disk groups.

- VERITAS Volume Replicator (VVR) objects cannot be moved between disk groups.

- For a disk group move to succeed, the source disk group must contain at least one disk

that can store copies of the configuration database after the move.

- For a disk group move to succeed, the configuration database in the target disk group

must be able to accommodate information about all the objects in the enlarged disk group.

- The operation can only be performed on the master node of a cluster if either the source

disk group or the target disk group is shared.
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Splitting A Disk Group
The disk group split operation involves splitting the contents of an imported disk group

and creating a new disk group (the Target disk group) with the objects defined in the

dialog box. This operation is performed on VERITAS Volume Manager Storage

Administrator objects such as disks or top-level volumes, and includes all component

objects such as sub-volumes, plexes and subdisks.

▼ To perform a disk group split operation:

1. Select Disk Groups  > Split .

2. Complete the Split Disk Group Dialog Box as follows:

Disk Group Name: Enter the name of the disk group from which objects are to be split

or click Browse  to select the disk group.

Target Disk Group

Name

Enter the name of the target disk group which will consist of the

objects to be split.

Select Objects to move Enter the objects to be split, or click Browse  to select the disk

objects. If you click Browse , a further dialog box will be displayed

with the following options:

- To select volumes to move, click Select Volumes, and choose

from the displayed list. To select all of the listed volumes, click

Select All.
- To select disks to move, click Select disks, and choose from

the displayed list.

- Click on OK.

Expand Click Expand to specify that the objects that are actually split

should include all other disks that contain subdisks that are

associated with the specified objects or with objects that they

contain. For example, if you specify that disk01 should be split of

and disk01 contains vol1 which is also located on disk02, then by

using the Expand button, you ensure that disk02 will also be split

off.

Show Dependencies Click Show Dependencies  to display the objects affected

by the split.
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.

Note:

- Before carrying out the split operation, stop all applications that are accessing the

volumes, and unmount all file systems that are configured in the volumes.

- The objects to be split off d must be self-contained, meaning that the disks that are split

must not contain any other objects that are not intended for the move.

- This operation fails if it would remove all the disks from the source disk group. Volume

states are preserved across the split.

- An existing deported disk group is destroyed if it has the same name as the target disk

group.

- The reconfiguration must involve an integral number of physical disks.

- Objects to be split off must not contain open volumes.

- Data change objects (DCOs) and snap objects that have been dissociated by Persistent

FastResync cannot be moved between disk groups.

- VERITAS Volume Replicator (VVR) objects cannot be moved between disk groups.

- The operation can only be performed on the master node of a cluster if either the source

disk group or the target disk group is shared.
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Joining Disk Groups
The following procedure joins two disk groups by moving all VERITAS Volume Manager

objects from an imported source disk group to an imported target disk group. The source

disk group is removed when the join is complete. This operation is performed on

VERITAS Volume Manager Storage Administrator objects such as disks or top-level

volumes, and includes all component objects such as sub-volumes, plexes and subdisks.

▼ To perform a disk group join operation:

1. Select Disk Groups  > Join .

2. Use the disk group name shown or use Browse to list available disk groups and then

select one of them.

3. Enter the target disk group name or use Browse to list available disk groups and then

select one of them.

Note:

- Before performing a join operation, stop all applications that are accessing the volumes,

and unmount all file systems that are configured in the volumes.

- The reconfiguration must involve an integral number of physical disks.

- Objects to be joined must not contain open volumes.

- Data change objects (DCOs) and snap objects that have been dissociated by Persistent

FastResync cannot be moved between disk groups.

- VERITAS Volume Replicator (VVR) objects cannot be moved between disk groups.

- For a disk group join to succeed, both the source and target disk groups must contain at

least one disk that can store copies of the configuration database after the split.

- The operation can only be performed on the master node of a cluster if either the source

disk group or the target disk group is shared.
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Activating a Disk Group
The Disk Group Activation procedure sets the activation mode for a disk group. The disk

group activation mode controls read and write access to volumes in the specified disk

group.

▼ To activate a disk group

1. Select the disk group to be activated.

2. Choose Disk Groups > Activation  (Selected  menu) or Disk Group
Activate/Deactivate  (Command Launcher).

3. Complete the Activate Disk Group dialog box as follows:

Disk Group Name: Enter the name of the disk group to be activated or click Browse
to select the disk group.

Activation Mode: Select one of the following disk group activation modes:

- To disallow read and write access for volumes in the disk

group, select Off .

- To allow read and write access for volumes in the disk group,

select Read Write .

- To allow read only access for volumes in the disk group, select

Read Only .

In a cluster environment, you can select one of the following

additional options for shared disk groups:

- To give the current node exclusive write access for volumes in

the shared disk group, select Exclusive Write . No other

nodes in the cluster can have write access to the disk group.

- To give the current node write access for volumes in the shared

disk group, select Shared Write . Other nodes in the cluster

can share write access to this disk group.

- To give the current node read access for volumes in the shared

disk group, select Shared Read . The current node cannot

have write access to the disk group, but other nodes in the

cluster may have write access.
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When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Disk Groups Activation  task requires a disk group name.

- In a cluster environment, you must specify the disk group activation mode on a per-node

basis.

- The Exclusive Write , Shared Write , and Shared Read  modes are only applicable

for shared disk groups in a cluster environment. The Read Write  mode is not available

for shared disk groups.

- For shared disk groups, the default activation mode is Off . For non-shared disk groups,

the default activation mode is Read Write .

- Disk group activation settings are not persistent, so you may need to reset the activation

mode when you reboot the machine.
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Viewing Disk Group Properties
The Disk Group Properties window contains detailed information about the selected disk

group. The Properties window contains a set of tabbed pages, each of which contains

information about the disk group and related objects. You can display a different page by

clicking on the appropriate tab label.

❖ To view the properties of a disk group, select the disk group and then choose

Properties  from the Disk Groups  or popup menu.

❖ To update the contents of the Properties window to reflect current properties for the

disk group, click Refresh .

❖ To print the contents of the Properties window, click Print  and complete the Print

dialog box.



Viewing Disk Group Properties

116 VERITAS Volume Manager Storage Administrator Administrator’s Guide



117

Volume Tasks 4
Introduction

This chapter describes how to create and use volumes with the VERITAS Volume

Manager Storage Administrator (VERITAS Volume Manager Storage Administrator). It

also includes information on how to use file systems with volumes. The Volume Task

Roadmap and File System Task Roadmap at the beginning of this chapter contain

summaries of common volume and file system tasks.

The following volume tasks are discussed in this chapter:

◆ Creating a Volume

◆ Resizing a Volume

◆ Renaming a Volume

◆ Changing a Volume Layout

◆ Adding a Mirror to a Volume

◆ Adding a Log to a Volume

◆ Stopping a Volume

◆ Starting a Volume

◆ Creating a Snapshot Copy of a Volume

◆ Merging a Snapshot Volume

◆ Dissociating a Snapshot Volume

◆ Aborting a Snapshot

◆ Aborting a Snapshot

◆ Recovering a Volume

◆ Repairing a Mirror

◆ Disabling a Mirror

◆ Removing a Mirror From a Volume
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◆ Removing a Log From a Volume

◆ Removing a Volume

◆ Associating a Plex

◆ Associating a Plex

◆ Moving a Subdisk

◆ Splitting a Subdisk

◆ Joining Subdisks

◆ Removing a Subdisk

◆ Viewing Volume Properties

The following file system tasks are discussed in this chapter:

◆ Adding a File System to a Volume

◆ Mounting a File System on a Volume

◆ Cluster Mounting a File System on a Cluster Node

◆ Unmounting a File System on a Volume

◆ Removing a Cluster Mounted File System

◆ Removing a Cluster Mounted File System

◆ Creating a Snapshot Copy of a File System

◆ Checking a File System on a Volume

◆ Viewing File System Properties

The following VERITAS QuickLog tasks are discussed in this chapter:

◆ Creating a QuickLog Volume

◆ Enabling a QuickLog Device for a File System

◆ Disabling a QuickLog Device for a File System

◆ Removing a QuickLog Volume
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Volume Task Roadmap

Volume Task Roadmap
The following table provides a summary of common VERITAS Volume Manager Storage

Administrator volume tasks.

To perform this task … Use this procedure …

Volume Setup Tasks:

Create new volumes Creating a Volume

Precautionary Tasks:

Mirror (copy) volumes onto other disks for

redundancy

Adding a Mirror to a Volume

Create mirrored volumes Creating a Volume

Add a log to a mirrored volume Adding a Log to a Volume

Add a log to a RAID-5 volume Adding a Log to a Volume

Maintenance Tasks:

Add space to volumes Resizing a Volume

Change volume layouts Changing a Volume Layout

Add mirrors to volumes that should be

redundant

Adding a Mirror to a Volume

Create a snapshot copy of a volume for backup Creating a Snapshot Copy of a Volume

Merge a snapshot copy of a volume with the

original volume

Merging a Snapshot Volume

Permanently break the association between a

snapshot and its original volume

Dissociating a Snapshot Volume

Abort the taking of a snapshot Aborting a Snapshot

Move portions of volumes to other disk space Moving a Subdisk

Recovery Tasks:

Attempt to recover a volume Recovering a Volume

Attempt to recover all volumes on a disk Recovering Volumes on a Disk (see Chapter 3)

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group (see

Chapter 3)

Prepare to restore a volume from backup Aborting a Snapshot

Repair or reattach a disabled volume mirror Repairing a Mirror
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Other Tasks:

Change a volume name Renaming a Volume

Temporarily prevent access to a volume Stopping a Volume

Restore access to a stopped volume Starting a Volume

Temporarily prevent access to a volume mirror Disabling a Mirror

Remove a mirror from a volume Removing a Mirror From a Volume

Remove a DRL log from a volume Removing a Log From a Volume

Remove a RAID-5 log from a volume Removing a Log From a Volume

Remove a volume Removing a Volume

To perform this task … Use this procedure …
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File System Task Roadmap
The following table provides a summary of common VERITAS Volume Manager Storage

Administrator file system tasks. Note that some of these tasks are only available for the

VERITAS File System™ (VxFS).

To perform this task … Use this procedure …

File System Setup Tasks:

Create a volume with a file system Creating a Volume

Place a file system on an existing volume Adding a File System to a Volume

Mount a file system on a volume Mounting a File System on a Volume

Mount a file system in cluster mode Cluster Mounting a File System on a Cluster

Node

Maintenance Tasks:

Add more space to a file system Removing a Cluster Mounted File System

Create a snapshot copy of a file system for

backup

Creating a Snapshot Copy of a File System

Recovery Tasks:

Perform a file system consistency check Checking a File System on a Volume

Other Tasks:

Unmount a file system Unmounting a File System on a Volume

Remove a cluster mounted file system Removing a Cluster Mounted File System
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Creating a Volume
VxVM uses logical volumes to organize and manage disk space. A volume is made up of

portions of one or more physical disks, so it does not have the physical limitations of a

physical disk.

A volume can provide greater capacity and better availability and performance than a

single physical disk. A volume can be extended (grown) across multiple disks to increase

capacity, mirrored (copied) on another disk to provide data redundancy, and/or striped

across multiple disks to improve I/O performance.

You can use VERITAS Volume Manager Storage Administrator to create the following

types of volumes:

◆ Concatenated Volume

A concatenated volume is made up of one or more disk regions that are linked

together (concatenated) in a linear fashion. A concatenated volume can consist of disk

regions on multiple disks; a concatenated volume that extends across two or more

disks is also known as a spanned volume.

Note that the data in this type of volume cannot be recovered if the underlying disk

fails. However, a concatenated volume can be mirrored (copied) onto another disks to

protect its data against disk failure.

◆ Striped Volume

Striped volume data is interleaved (striped) across two or more physical disks.

Striped volume data is spread across the disks alternately and evenly in small,

equal-sized portions of data called stripe units. Striping improves performance.

Note that the data in this type of volume cannot be recovered if one of the underlying

disks fails. However, a striped volume can be mirrored (copied) onto another disks to

protect its data against disk failure.

◆ RAID-5 Volume

RAID-5 volume data is interleaved (striped) across three or more physical disks.

Within each stripe across the set of disks, the data on one of the disks is parity data. If

one of the physical disks fails, the parity data can be used to reconstruct and recover

the lost data.

Note that RAID-5 volumes cannot be mirrored.
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◆ Mirrored Volume

Volumes with concatenated or striped layouts can be mirrored to increase data

availability. All of the data in a mirrored volume is duplicated on at least one other

physical disk. If one of the disks fails, the data can still be accessed from one of the

remaining disks.

The plexes in a mirrored volume typically have the same layout, but a volume can

consist of plexes with different layouts. A mirrored volume has a “mixed” layout if

the plexes in the volume have different layouts.

◆ Layered Volume

A layered volume is built on one or more other volumes. The underlying volumes are

typically mirrored. In layered volumes, mirroring is done at a lower level and with

smaller granularity than with non-layered volumes, so each mirror covers a relatively

small storage region.

Layered volumes tolerate disk failure better than non-layered volumes and provide

improved data redundancy. If a disk in a layered volume fails, only a portion of the

redundancy is lost and recovery time is usually quicker than it would be for a

non-layered volume. Layered volumes also reduce the chance that two disk failures

will result in lost data.

The underlying volumes in a layered volume are used exclusively by VxVM and are

not intended for user manipulation.

With VERITAS Volume Manager Storage Administrator, you can create the following

types of layered volumes:

- Concatenated Pro Volume

A concatenated pro volume is a layered volume that concatenates several

underlying mirror volumes.

- Striped Pro Volume

A striped pro volume is a layered volume that stripes several underlying mirror

volumes.
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The following table summarizes the advantages and disadvantages of each volume

layout.

Layout Comparison

Layout Advantages Disadvantages

Concatenated - The volume can consist of disk

regions that are not adjacent.

- The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

- The volume can be mirrored to

protect data against disk failure

and reduce the risk of data loss.

- There is a risk of data loss if the

volume is not mirrored.

- Spanning a volume across multiple

disks increases the chance that a

disk failure will result in the failure

of the volume.

- Concatenation does not improve

I/O performance.

Striped - Striping provides improved

read and write performance.

- Striping can help to balance the

I/O load from multi-user

applications across multiple

disks.

- The volume can be mirrored to

protect data against disk failure.

- There is a risk of data loss if the

volume is not mirrored.

- Striping a volume across multiple

disks increases the chance that a

disk failure will result in the failure

of the volume.

- A striped volume requires at least

two disks.

RAID-5 - RAID-5 provides protection

against disk failure and reduces

the risk of data loss.

- RAID-5 provides data

redundancy by storing parity (a

calculated value) on the disks. If

a disk fails, the parity is used to

reconstruct the missing data.

- RAID-5 requires less storage

space than mirroring.

- RAID-5 provides improved read

performance.

- RAID-5 provides relatively slow

write performance.

- RAID-5 volumes cannot be

mirrored.

- A RAID-5 volume requires at least

three disks. If logging is enabled, a

RAID-5 volume requires at least

four disks.

- A RAID-5 volume cannot survive

multiple disk failures. However,

optional RAID-5 logs reduce this

risk.

- If one of the volume disks is

inaccessible, performance is

degraded.
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Mirrored - Mirroring provides protection

against disk failure and reduces

the risk of data loss.

- Mirroring provides data

redundancy by maintaining

multiple complete copies of

volume data on different disks.

- Mirroring provides improved

read performance.

- A mirrored volume requires extra

disk space. Each mirror requires

enough disk space to contain a

complete copy of the volume.

Concatenated Pro - The volume is layered, and

concatenates several underlying

mirror volumes. This provides

improved data redundancy and

reduces the impact of disk

failures. This type of volume is

also known as a

concatenated-mirror volume.

- Recovery time is quicker than

with regular concatenated

volumes that are mirrored.

- The volume can consist of disk

regions that are not adjacent.

- The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

- A concatenated pro volume

requires at least two disks.

- Concatenation does not improve

I/O performance.

- Layered volumes consist of more

VERITAS Volume Manager objects

than non-layered volumes and are

likely to fill up the disk group

configuration database sooner.

When the configuration database is

full, you cannot create more

volumes in the disk group.

Striped Pro - The volume is layered, and

stripes several underlying

mirror volumes. This provides

improved data redundancy and

reduces the impact of disk

failures. This type of volume is

also known as a striped-mirror

volume.

- Recovery time is quicker than

with regular striped volumes

that are mirrored.

- Striping provides improved

read and write performance.

- Striping can help to balance the

I/O load from multi-user

applications across multiple

disks

- A striped pro volume requires at

least four disks.

- Layered volumes consist of more

VERITAS Volume Manager objects

than non-layered volumes and are

likely to fill up the disk group

configuration database sooner.

When the configuration database is

full, you cannot create more

volumes in the disk group.

Layout Comparison

Layout Advantages Disadvantages
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▼ To create a concatenated volume

The following procedure creates a concatenated volume that consists of one or more

regions of the specified disks. This procedure also gives you the options of placing a file

system on the new volume or mirroring the volume.

You can use this procedure to create a regular concatenated volume or a concatenated pro

volume. A concatenated pro volume is layered and mirrored.

1. Select the appropriate host machine.

2. Choose File  > New > Volume  (Selected  menu) or Volume Create  (Command

Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse  to select

another disk group.

Volume Name: Enter the new volume name (or accept the default name).

Size: Enter the volume size. The default size unit is sectors. To specify a

size unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize  after choosing the volume layout and options.

Layout: Choose Concatenated  or Concatenated Pro  for the volume

layout.
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After you have provided all necessary information in the dialog box, click OK.

Options - To mirror the volume, select Mirrored . In the Total Number of

Mirrors field, enter the total number of mirrors for the volume.

Note Concatenated pro volumes are mirrored by default.

To enable logging for a mirrored volume, select Enable
Logging .

- To place the volume on specific disks, click Assign Disks and

select the disk(s) and the storage layout policy that you want to

use from the Space Allocation dialog box.

- To place a file system on the volume, click Add File System
and specify the file system type and mount point in the Add

File System dialog box.

- To clear the volume before enabling it for general use, select

Initialize Zero .

- To prevent the creation of a layered volume, select No
Layered Volumes . In cases where a layered volume layout is

appropriate, VxVM can create a layered volume when a

non-layered layout is specified. This option ensures that the

volume has a non-layered layout. If a layered (Pro) layout is

selected, this option is ignored.

- To add a comment attribute for the volume, enter the

information in the Comment field.

Notes:

- The task to create a concatenated volume requires a disk group name, volume name,

volume size, and volume layout.

- The volume size should be less than or equal to the available free space on the disks.

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- The data in a concatenated volume is not protected against disk failure unless the volume

is mirrored. At least one additional disk is required to mirror a concatenated volume.

- Concatenated pro volumes are mirrored by default, so a concatenated pro volume

requires more disks than an unmirrored concatenated volume.

- You cannot use a concatenated pro volume for a root  or swap volume.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file

system table file automatically updates.

- You can use the Space Allocation dialog box to specify that the volume is to be mirrored

or striped across controllers, trays, targets, or enclosures. You can also select ordered

allocation. Ordered allocation uses the specified storage to first concatenate disks, then to

form columns, and finally to form mirrors.
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▼ To create a striped volume

The following procedure creates a striped volume that is spread across two or more disks.

This procedure also gives you the options of placing a file system on the new volume or

mirroring the volume.

You can use this procedure to create a regular striped volume or a striped pro volume. A

striped pro volume is layered and mirrored.

1. Select the appropriate host machine.

2. Choose File  > New > Volume  (Selected  menu) or Volume Create  (Command

Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse  to select

another disk group.

Volume Name: Enter the new volume name (or accept the default name).

Size: Enter the volume size. The default size unit is sectors. To specify a

size unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize after choosing the volume layout and options.

Layout: Choose Striped  or Striped Pro  for the volume layout.

In the Number of Columns field, specify the number of columns

(disks) across which the volume should be striped. A striped

volume requires at least two disks.

To specify a stripe unit size other than the default, enter the stripe

unit size in the Stripe Unit Size field. To specify a size unit, attach

an s  (sectors), k  (kilobytes), m (megabytes), or g (gigabytes) to the

size.
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Options - To mirror the volume, select Mirrored . In the Total Number of

Mirrors field, enter the total number of mirrors for the volume.

Note Striped pro volumes are mirrored by default.

To enable logging for a mirrored volume, select Enable
Logging .

- To stripe the volume across specific disks, click Assign Disks
and select the disks and the storage layout policy that you want

to use from the Space Allocation dialog box.

- To place a file system on the volume, click Add File System
and specify the file system type and mount point in the Add

File System dialog box.

- To clear the volume before enabling it for general use, select

Initialize Zero .

- To prevent the creation of a layered volume, select No
Layered Volumes . In cases where a layered volume layout is

appropriate, VxVM can create a layered volume when a

non-layered layout is specified. This option ensures that the

volume has a non-layered layout. If a layered (Pro) layout is

selected, this option is ignored.

- To add a comment attribute for the volume, enter the

information in the Comment field.
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After you have provided all necessary information in the dialog box, click OK.

▼ To create a RAID-5 volume

The following procedure creates a RAID-5 volume that is spread across two or more disks

and contains parity information. This procedure also gives you the option of placing a file

system on the new volume.

1. Select the appropriate host machine.

2. Choose File  > New > Volume  (Selected  menu) or Volume Create  (Command

Launcher).

3. Complete the New Volume dialog box as follows:

Notes:

- The task to create a striped volume requires a disk group name, volume name, volume

size, and volume layout.

- A striped volume requires at least two disks.

- The volume size should be less than or equal to the available free space on the disks.

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- The data in a striped volume is not protected against disk failure unless the volume is

mirrored. At least one additional disk is required to mirror a striped volume.

- Striped pro volumes are mirrored by default, so a striped pro volume requires more disks

than an unmirrored striped volume.

- You cannot use a striped pro volume for a root  or swap volume.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file

system table file is automatically updated.

- You can use the Space Allocation dialog box to specify that the volume is to be mirrored

or striped across controllers, trays, targets, or enclosures. You can also select ordered

allocation. Ordered allocation uses the specified storage to first concatenate disks, then to

form columns, and finally to form mirrors.

Disk Group Name: Either accept the default disk group or click Browse  to select

another disk group.

Volume Name: Enter the new volume name (or accept the default name).
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Size: Enter the volume size in the Size field. The default size unit is

sectors. To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize after choosing the volume layout and options.

Layout: Choose RAID-5 for the volume layout.

In the Number of Columns field, specify the number of columns

(disks) across which the volume should be striped. A RAID-5

volume requires at least three disks (or four disks if logging is

enabled).

To specify a stripe unit size other than the default, enter the stripe

unit size in the Stripe Unit Size field. To specify a size unit, attach

an s  (sectors), k  (kilobytes), m (megabytes), or g (gigabytes) to the

size.

Options - To stripe the volume across specific disks, click Assign Disks
and select the disks and the storage layout policy that you want

to use from the Space Allocation dialog box.

- To place a file system on the volume, click Add File System
and specify the file system type and mount point in the Add

File System dialog box.

- To enable RAID-5 logging for the volume, select Enable
Logging . VxVM adds an appropriate number of logs to the

volume.

- To clear the volume before enabling it for general use, select

Initialize Zero .

- To add a comment attribute for the volume, enter the

information in the Comment field.
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After you have provided all necessary information in the dialog box, click OK.

▼ To create a mirrored volume

The following procedure creates a concatenated or striped volume that is mirrored

(copied) on at least one other disk. If one of the disks fails, data on the volume can be

accessed from the surviving disks.

You can use this procedure to create a regular mirrored volume or a layered mirrored

volume. Concatenated pro and striped pro volumes are layered and mirrored by default.

1. Select the appropriate host machine.

2. Choose File  > New > Volume  (Selected  menu) or Volume Create  (Command

Launcher).

3. Complete the New Volume dialog box as follows:

Notes:

- The task to create a RAID-5 volume requires a disk group name, volume name, volume

size, and volume layout.

- A RAID-5 volume requires at least three disks. If logging is enabled, a RAID-5 volume

requires at least four disks.

- RAID-5 volumes cannot be mirrored.

- The volume size should be less than or equal to the available free space on the disks.

- For a RAID-5 volume, the size specified in the Size field is the usable space in the volume.

Volume Manager allocates additional space for the volume parity information. The disks

across which the RAID-5 volume is striped must, therefore, contain additional free space

for the volume parity information.

- If no disks are assigned, VxVM uses available space on disks in the selected disk group.

- If a file system is placed on the volume and the Mount at Boot option is selected, the file

system table file is automatically updated.

- You can use the Space Allocation dialog box to specify that the volume is to be mirrored

or striped across controllers, trays, targets, or enclosures. You can also select ordered

allocation. Ordered allocation uses the specified storage to first concatenate disks, then to

form columns, and finally to form mirrors.

Disk Group Name: Either accept the default disk group or click Browse  to select

another disk group.

Volume Name: Enter the new volume name (or accept the default name).



Chapter 4, Volume Tasks 133

Creating a Volume

Size: Enter the volume size in the Size field. The default size unit is

sectors. To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize after choosing the volume layout and options.

Layout: Choose Concatenated , Striped , Concatenated Pro , or

Striped Pro  for the volume layout.

For a striped or striped pro volume, provide the following

information:

- In the Number of Columns field, specify the number of

columns (disks) across which the volume should be striped. A

striped volume requires at least two disks.

- To specify a stripe unit size other than the default, enter the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.

Mirror Info: Select Mirrored . In the Total Number of Mirrors field, enter the

total number of mirrors for the volume.

Note Concatenated pro and striped pro volumes are mirrored by

default.

Options - To place the volume on a specific disks, click Assign Disks
and select the disks and the storage layout policy that you want

to use from the Space Allocation dialog box.

- To place a file system on the volume, click Add File System
and specify the file system type and mount point in the Add

File System dialog box.

- To enable Dirty Region Logging (DRL) for the volume, select

Enable Logging . VxVM adds an appropriate number of

logs to the volume.

- To clear the volume before enabling it for general use, select

Initialize Zero .

- To prevent the creation of a layered volume, select No
Layered Volumes . In cases where a layered volume layout is

appropriate, VxVM can create a layered volume when a

non-layered layout is specified. This option ensures that the

volume has a non-layered layout. If a layered (Pro) layout is

selected, this option is ignored.

- To add a comment attribute for the volume, enter the

information in the Comment field.
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After you have provided all necessary information in the dialog box, click OK.

Notes:

- The task to create a mirrored volume requires a disk group name, volume name, volume

size, and volume layout.

- A mirrored volume requires at least two disks. If logging is enabled, the volume requires

at least one additional disk.

- Only concatenated or striped volumes can be mirrored.

- You can use the Space Allocation dialog box to specify that the volume is to be mirrored

or striped across controllers, trays, targets, or enclosures. You can also select ordered

allocation. Ordered allocation uses the specified storage to first concatenate disks, then to

form columns, and finally to form mirrors.
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Resizing a Volume
The Volume Resize  procedure changes the size of a volume. If users require more space

on a volume, you can use this procedure to increase the size of the volume. If a volume

contains unused space that you need to use elsewhere, you can use this procedure to

shrink the volume. If the volume contains a file system, this procedure also resizes the file

system.

▼ To resize a volume

1. Select the volume to be resized.

2. Choose Volumes  > Resize  (Selected  menu) or Volume Resize  (Command

Launcher).

3. Complete the Resize Volume dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

New Size: Specify one of the following:

- To increase the volume size by a specific amount of space, use

the Add By field to specify how much space should be added to

the volume.

- To decrease the volume size by a specific amount of space, use

the Subtract By field to specify how much space should be

removed from the volume.

- To specify the new volume size, enter the size in the Desired

Size field.

To determine the largest possible size for the volume, click

Maxgrow after choosing options.

The default size unit is sectors. To specify a size unit, attach an s
(sectors), k  (kilobytes), m (megabytes), or g (gigabytes) to the size.

Options To use a specific disk for the additional space, click Assign Disks
and select the disk you want to use from the Space Allocation

dialog box.
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After you have provided all necessary information in the dialog box, click OK.

Notes:

- The Volume Resize  task requires a volume name and either the desired size or the

amount of space to add to or subtract from the volume size.

- A volume containing a file system other than VxFS cannot be shrunk.

- Shrinking a volume with an unmounted file system can result in data loss, so a volume

containing an unmounted file system cannot be shrunk.

- When a volume is shrunk, the resulting extra space is returned to the free space pool.

- When the volume size is increased, sufficient disk space must be available. When

increasing the size of a volume, VxVM assigns the necessary new space from available

disks.

- You cannot grow or shrink any volume associated with an encapsulated root disk

(rootvol , usr , var , opt , swapvol , and so on) because these map to a physical

underlying partition on the disk and must be contiguous. If you attempt to grow

rootvol , usrvol , varvol , or swapvol , the system could become unbootable if you

need to revert back to booting from slices. It can also prevent a successful Solaris upgrade

and you might have to do a fresh install. Additionally, the upgrade_start  script might

fail.
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Renaming a Volume
The Volume Rename procedure changes the name of a volume. If the volume has a file

system, this procedure also makes the necessary changes to the file system table file and

allows you to specify a new mount point for the file system.

▼ To rename a volume

1. Select the volume to be renamed.

2. Choose Volumes > Rename  (Selected  menu) or Volume Rename  (Command

Launcher).

3. Complete the Rename Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

New Name: Enter the new name for the volume.

Options If the volume contains a file system and you want to change the

mount point when the volume is renamed, enter a new mount

point in the New Mount Point field.

Notes:

- The Volume Rename  task requires the current volume name and a new volume name.

- The new volume name must be unique within the disk group.

- If the volume contains a file system, the file system table file is automatically updated (if

necessary).
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Changing a Volume Layout
The Volume Change Layout procedure changes the layout of a volume without

interrupting access to data. You can use this task to change the redundancy or

performance characteristics of an existing volume.

You can view the progress of the relayout task through the Relayout Status Monitor

window. You can also use the Relayout Status Monitor window to pause, abort, continue,

or reverse the relayout task. The Relayout Status Monitor appears automatically when a

relayout task begins. When a volume relayout is in progress, paused, or aborted, you can

also access the Relayout Status Monitor through the Volume Properties window.

▼ To change a volume layout

1. Select the volume to be changed to a different layout.

2. Choose Volumes  > Change Layout  (Selected  menu) or Volume Change Layout
(Command Launcher).

3. Complete the Change Volume Layout dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Layout: Choose the new volume layout:

- Concatenated
Change the volume to a simple, concatenated volume.

- Striped
Change the volume to a striped volume.

- RAID-5
Change the volume to a RAID-5 volume.

- Concatenated Pro
Change the volume to a layered concatenated volume.

- Striped Pro
Change the volume to a layered striped volume.

For a striped, RAID-5, or striped pro volume, provide the

following information:

- In the Number of Columns field, specify the number of

columns (disks) across which the volume should be striped.

- To specify a stripe unit size other than the default, enter the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.
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4. After you have provided all necessary information in the dialog box, click OK. The

Relayout Status Monitor window appears. This window provides you with the

following information and options:

Options Click Show Options  to access the optional settings for this task.

- To retain the original volume size when the volume layout

changes, click Retain Volume Size at Completion .

- To specify the size of the pieces of data that are copied to

temporary space during the volume relayout, enter the size in

the Temp Space Size field.

- To specify additional disk space to be used for the new

volume layout (if needed), specify the disk in the Disk(s) field

or click Browse  to select a disk.

- To specify the temporary disk space to be used during the

volume layout change, specify the disk in the Temp Disk(s)

field or click Browse  to select a disk.

- If the volume contains plexes with different layouts, specify the

plex to be changed to the new layout in the Target Plex field.

Volume Name: The name of the volume that is undergoing a layout change.

Initial Layout: The original layout of the volume.

Desired Layout: The new layout for the volume.

Status: The status of the relayout task.

% Complete: The progress of the relayout task.

Options - To stop the relayout task temporarily, click Pause .

- To cancel the relayout task, click Abort .

- To resume the paused or aborted relayout task, click

Continue .

- To undo the layout changes and return the volume to its

original layout, click Reverse .
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If you need to pause, abort, continue, or reverse a relayout task after you close the

Relayout Status Monitor window, you can access the Relayout Status Monitor

through the Volume Properties window.

Notes:

- The Volume Change Layout  task requires a volume name and a different volume

layout.

- Volumes remain accessible during online relayout.

- This task may take a long time, depending on the volume size and other factors. The

Relayout Status Monitor shows the progress of the layout change and allows you to abort,

pause, or reverse the task.

- If no disk space is specified, VxVM uses available space on disks in the current disk

group.

- If the temporary space size is not specified, VxVM uses an appropriate size. Specifying a

larger temporary space size speeds up the layout change process because larger pieces of

data are copied at a time. If the specified temporary space size is too small, VxVM uses a

larger size.

- If all of the plexes in the volume have identical layouts, VxVM changes all plexes (except

log plexes) to the new layout. If the volume contains plexes with different layouts, a target

plex must be specified. When a target plex is specified, VxVM changes the layout of the

target plex and leaves the other plexes in the volume alone.

- Log plex layouts do not change. VxVM removes and/or replaces log plexes, depending

on the new layout.

- If the volume length changes as a result of the layout change and the volume contains a

file system, the file system length is automatically adjusted (if possible).

- A volume cannot undergo multiple relayouts at the same time.

- This task cannot be used to change the layout of a volume with a sparse plex.

- This task may fail for volumes that were not created by VERITAS Volume Manager

Storage Administrator or the vxassist  command.

- If the relayout is reversed, the volume returns to its original layout. However, data in the

volume may not return to its original storage location.

- During a relayout, many other tasks are unavailable for the volume.

- A mirrored or striped volume requires at least two disks.

- A RAID-5 volume requires at least three disks.
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Adding a Mirror to a Volume
The Volume Add Mirror  procedure creates a mirror (copy) of a volume on a disk that is

not already being used by the volume. If one of the disks fails, the volume data can be

accessed from the surviving disks. A volume can have multiple mirrors.

▼ To add a mirror to an existing volume

1. Select the volume to be mirrored.

2. Choose Volumes > Mirror > Add (Selected menu) or Volume Add Mirror (Command

Launcher).

3. Complete the Add Mirror dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options Click Show Options  to access the optional settings for this task.

- To specify the layout for the mirror, select Concatenated  or

Striped . For a striped mirror, specify the number of columns

and stripe unit size.

- To add more than one mirror, enter the number of mirrors in

the Mirror Quantity field.

- To place the mirror on a specific disk, enter the disk name in the

Disk Name(s) field or click Browse  to select a disk.
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After you have provided all necessary information in the dialog box, click OK.

Adding a mirror requires resynchronization, so this task may take some time.

Notes:

- The Volume Add Mirror  task requires a volume name.

- Once mirrored, the data in the volume is redundant. If a disk fails, the data remains

available on the surviving mirror (on another disk).

- The new mirror cannot be created on a disk that already contains a copy of the volume.

Each mirror must reside on a separate disk.

- Sufficient disk space must be available to accommodate the additional mirrors.

- Only disks in the same disk group as the volume can be used to create the new mirror.

- If no disks are assigned, VxVM uses available disk space to create the mirror.

- A RAID-5 volume cannot be mirrored.

- To mirror the root volume (and other volumes required to boot the system) onto an

alternate boot disk, use the Mirror Disk task.

- A volume can contain up to 32 plexes (mirrors).
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Adding a Log to a Volume
The Volume Add Log procedure adds the appropriate type of log to a mirrored or RAID-5

volume.

▼ To add a DRL log to a mirrored volume

The following procedure adds a Dirty Region Logging (DRL) log to a mirrored volume.

DRL uses this log to track the regions of the volume that change due to I/O writes. If a

system failure occurs, DRL uses the information in the log to recover only the portions of

the volume that need recovery. This speeds up recovery time for mirrored volumes.

For DRL to be in effect, a mirrored volume must have at least one DRL log. You can create

additional DRL logs (on different disks) to mirror the DRL information.

1. Select the mirrored volume to contain the log.

2. Choose Volumes  > Log  > Add  (Selected  menu) or Volume Add Log  (Command

Launcher).

3. Complete the Add Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

▼ To add a log to a RAID-5 volume

The following procedure adds a log to a RAID-5 volume. RAID-5 logs speed up the

resynchronization time for RAID-5 volumes after a system failure. A RAID-5 log

maintains a copy of the data and parity being written to the volume at any given time. If a

system failure occurs, VxVM can “replay” the RAID-5 log to resynchronize the volume.

This copies the data and parity that was being written at the time of failure from the log to

the appropriate areas of the RAID-5 volume.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options To place the log on a specific disk, enter the name of the disk in the

Disk Name field or click Browse  to select a disk.

Notes:

- The Volume Add Log  task requires a volume name.

- When a log is added to a mirrored volume, DRL is activated for that volume.



Adding a Log to a Volume

144 VERITAS Volume Manager Storage Administrator Administrator’s Guide

You can create multiple RAID-5 logs (on different disks) to mirror the log information.

Ideally, each RAID-5 volume has at least two logs.

1. Select the RAID-5 volume to contain the log.

2. Choose Volumes  > Log  > Add  (Selected  menu) or Volume Add Log  (Command

Launcher).

3. Complete the Add Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options To place the log on a specific disk, enter the name of the disk in the

Disk Name field or click Browse  to select a disk.

Note:

The Volume Add Log  task requires a volume name.
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Stopping a Volume
The Volume Stop procedure disables a volume. When a volume is stopped, it is not

available for use until it is restarted (refer to “Starting a Volume” on page 146). Stopping a

volume is a safe way of temporarily preventing access to a volume.

▼ To stop a volume

1. Select the volume to be stopped.

2. Choose Volumes  > Stop  (Selected  menu) or Volume Stop  (Command Launcher).

3. Complete the Stop Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK. The

volume state changes to STOPPED.

Volume(s): If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Note:

A volume cannot be stopped if it is in use (open) or it has a mounted file system.
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Starting a Volume
The Volume Start procedure attempts to enable (start) a stopped volume. When a volume

is successfully restarted, the volume is available for use again. This procedure also

performs any appropriate resynchronization operations on the volume.

Under normal circumstances, volumes are automatically started when the system reboots.

You can use this procedure to restart a volume that you stopped manually or to attempt to

restart a volume that was stopped in some other manner. If a volume cannot be started,

the volume remains unusable.

▼ To start a volume

1. Select the (stopped) volume to be started.

2. Choose Volumes  > Start  (Selected  menu) or Volume Start  (Command Launcher).

3. Complete the Start Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK. The

volume state changes to STARTED.

Volume(s): If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Notes:

- Starting a RAID-5 volume enables the volume and resynchronizes parity, if necessary.

- Starting a mirrored volume enables the volume and resynchronizes the mirrors to ensure

that they are consistent.
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Creating a Snapshot Copy of a Volume
The Snap procedure prepares a volume for backup by creating a new volume that is a

snapshot copy of an existing volume. This is done by attaching a new mirror to the

existing volume, copying the volume data to the new mirror, detaching the new mirror,

and then creating a new (snapshot) volume from the new mirror. The snapshot volume is

an exact copy of the original volume. You can use the snapshot volume to make a backup

of the original volume at a convenient time. After the backup is made, you can remove the

snapshot volume (see “Removing a Volume.” ). You can also merge a snapshot volume

with its original volume or permanently break the link between the snapshot and the

original volume.

You can use the Snapshot Interactive menu to perform all the steps used in the Snap
procedure on a single volume. For multiple volumes, you can use individual commands

from the Snap menu to perform these steps. Working with multiple volumes makes

preparation for backup faster and easier. The commands on the menu are: snapstart ,

snapshot, snapabort , snapclear  and snapback .

▼ To create a snapshot copy of the data on a single volume

1. Select the volume to be copied to a snapshot.

2. Choose Volumes  > Snap > Snapshot Interactive (Selected  menu) or

Volume >Snapshot Interactive  (Command Launcher).

3. Complete the Volume Snapshot dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Snapshot Name: Enter the name for the snapshot copy of the volume.
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4. After you have provided all necessary information in the dialog box, click Snapstart
to start the first phase of the snapshot procedure. This creates a snapshot mirror of the

volume to be backed up. This may take some time. When the snapshot mirror is

complete, the following message appears at the bottom of the dialog box:

Click Snapshot to create the snapshot volume.

If you want to abort the Snapshot, select Volumes  > Snap > Snapabort.

5. When the snapshot mirror is ready, click Snapshot  to complete the snapshot. This

creates a snapshot copy of the original volume.

If you decide not to make a snapshot volume, you can remove the snapshot mirror

after the snapstart phase. To remove the snapshot mirror, click Remove Snapshot
Mirror .

Options - To place the snapshot on a specific disks, click Assign Disks
and select the disks you want to use.

- To enable the FastResync (FR) feature for the volume, select

Enable FastResync . FastResync speeds up the

resynchronization of mirrors in a volume. Resynchronization

is necessary when a detached/unavailable mirror is

(re)attached to a volume. Enabling FastResync on an existing

mirrored volume can also be accomplished through the

Volumes  > Properties dialog. To enable persistent or

non-persistent FastResync, you require an additional license.

- To create a read-only snapshot volume, select Read Only .

Note FR was formerly known as Fast Mirror Resynchronization

(FMR).

Notes:

- FastResync is not supported for RAID-5 volumes

- The Volume Snapshot Interactive task requires a volume name and a snapshot

name.

- The snapshot volume is an exact copy of the original volume at the time the snapshot

phase of the procedure starts.

- After you create the snapshot copy of the volume, remember to back it up to tape or some

other media. Remove the snapshot volume when it is no longer needed.

- The snapstart phase of this task may take a long time, depending on the size of the

volume.

- If you remove the snapshot mirror, you cannot create a snapshot volume until you repeat

the snapstart phase of the procedure.
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▼ To create a snapshot copy of data on multiple volumes

1. Select the volume to be copied to a snapshot.

2. Choose Volumes  > Snap > Snapstart (Selected  menu) or Volume >Snapstart
(Command Launcher).

3. Enter the volume names or names in the Volume Snapstart dialog box:

4. Click OK or Apply to start the first phase of the snapshot procedure. This creates a

snapshot mirror of the volume to be backed up. This may take some time. When the

snapshot mirror is complete, the following message appears at the bottom of the

dialog box:

Click Snapshot to create the snapshot volume.

If you want to abort the Snapshot, select Volumes  > Snap > Snapabort.

5. When the snapshot mirror is ready, click Snapshot  to complete the snapshot. This

creates a snapshot copy of the original volume.

If you decide not to make a snapshot volume, you can remove the snapshot mirror

after the snapstart phase. To remove the snapshot mirror, click Remove Snapshot
Mirror .

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options - To place the snapshot on a specific disks, click Assign Disks
and select the disks you want to use.

Notes:

- The Volume Snapshot task requires a volume name.

- The snapshot volume is an exact copy of the original volume at the time the snapshot

phase of the procedure starts.

- After you create the snapshot copy of the volume, remember to back it up to tape or some

other media. Remove the snapshot volume when it is no longer needed.

- The snapstart phase of this task may take a long time, depending on the size of the

volume.

- If you remove the snapshot mirror, you cannot create a snapshot volume until you repeat

the snapstart phase of the procedure.
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Merging a Snapshot Volume
The Volume Snapback procedure merges a snapshot copy of a volume with the original

volume. The snapshot plex is detached from the snapshot volume and attached to the

original volume. The snapshot volume is removed. This task resynchronizes the data in

the volume so that the plexes are consistent. By default, the data in the original plex is

used for the merged volume.

▼ To merge a snapshot volume with its original volume

1. Select the snapshot volume to be merged with its original volume.

2. Choose Volumes  > Snapback  (Selected  menu) or Volume Snapback  (Command

Launcher).

3. Complete the Snapback Volume dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options To replace the data in the original volume with the data from the

snapshot volume, select Resync From Replica Volume .

Note:

The Volume Snapback feature is not supported for RAID-5 volumes.
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Dissociating a Snapshot Volume
The Volume Snapclear procedure permanently breaks the association between a

snapshot and its original volume. The snapshot volume becomes an independent volume.

▼ To dissociate a snapshot volume from its original volume

1. Select the snapshot volume to be dissociated from its original volume.

2. Choose Volumes  > Snapclear  (Selected  menu) or Volume Snapclear  (Command

Launcher).

3. Complete the Snapclear Volume dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.
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Aborting a Snapshot
The Volume Snapabort procedure allows you to abort the snapshot procedure before it

completes. If you have started the procedure, through Snapstart, but have not yet clicked

on Snapshot to complete the procedure, you can select Snapabort to abort the

procedure.

▼ To abort the snapshot procedure

1. Select the snapshot volume to be dissociated from its original volume.

2. Choose Volumes  > Snapabort .

3. Complete the Snapabort Volume dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.
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Preparing to Restore a Volume From Backup
The Volume Prepare Restore procedure stops the volume, sets the volume to an

uninitialized state, and restarts the volume (without resynchronizing the volume mirrors).

The volume can then be reloaded from backup.

This procedure is intended for raw image backups and is not appropriate for file system

backups. This procedure is useful for disaster recovery. If the data on a volume is

corrupted and you know that you need to restore the volume from backup, you can use

this procedure to prepare the volume for restoration.

▼ To prepare a volume for a restore from backup

1. Select the volume to be restored from backup.

2. Choose Volumes  > Prepare For Restore  (Selected  menu) or Volume Prepare
Restore  (Command Launcher).

3. Complete the Prepare Volume For Restore dialog box as follows:

After you have provided all necessary information in the dialog box, click OK. After

you have completed this task, you can restore the volume data from backup.

Volume(s): If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Note:

If the volume contains a mounted file system, the file system must be unmounted before

this task can proceed. This task does not remount the file system.
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Recovering a Volume
The Volume Recover procedure performs any necessary volume recovery operations on

a volume. The recovery operations depend on the type of volume and include starting

disabled volumes, resynchronizing mirrors in mirrored volumes, and resynchronizing

parity in RAID-5 volumes. After successful recovery, the volume is again available for use.

Alert icons and the Alert Monitor window can provide clues to let you know that volume

recovery is needed.

▼ To recover a failed volume

1. Select the volume to be recovered.

2. Choose Volumes  > Recover  (Selected  menu) or Volume Recover  (Command

Launcher).

3. Complete the Recover Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume(s): If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Note:

In some cases, recovery is not possible. If the volume recovery fails, you can attempt to

restore the volume from backup.
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Repairing a Mirror
The Mirror Repair procedure repairs a disabled mirror by reattaching the mirror to its

volume. This involves copying data from an active mirror on the volume to the mirror

being attached. Once attached, the mirror is accessible for reads and writes again.

Alert icons and the Alert Monitor window may provide clues to let you know that a

mirror needs to be repaired.

▼ To repair a mirror

1. Select the volume that contains the mirror to be repaired.

2. Choose Volumes  > Mirror  > Repair  (Selected  menu) or Mirror Repair  (Command

Launcher).

3. Complete the Repair Mirror dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Select a mirror to repair: Select the mirror to be repaired.

Notes:

- This task recovers the mirror so that it has the same contents as other mirrors in the

volume.

- This task can take a long time, depending on the amount of data in the volume.
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Disabling a Mirror

Note Disabling a mirror can result in loss of data redundancy.

The Mirror Disable procedure disables a mirror by temporarily detaching the mirror from

its volume. A detached mirror is inaccessible for reads and writes, but is still associated

with its volume. Once disabled, the mirror remains detached from its volume until you

either reattach the mirror (see “Repairing a Mirror” on page 155) or restart the volume.

▼ To disable a mirror in a volume

1. Select the volume that contains the mirror to be disabled.

2. Choose Volumes  > Mirror  > Disable  (Selected  menu) or Mirror Disable  (Command

Launcher).

3. Complete the Disable Mirror dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Select a mirror to

disable:

Select the mirror to be disabled.

Notes:

- Volume reads and writes cannot be directed to a disabled mirror.

- If a volume only has two mirrors and one mirror is disabled, the volume is not redundant

while the mirror is disabled.

- The last mirror in a volume cannot be disabled.

- When a volume is restarted, any disabled (detached) mirrors reattach to the volume

automatically.
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Removing a Mirror From a Volume

Caution Removing a mirror can result in loss of data redundancy.

The Mirror Remove  procedure removes a mirror from its volume. This procedure breaks

the link between the mirror and its volume and returns the mirror disk space to the free

space pool for reuse. You can remove an extra mirror from a volume to make the

underlying disk space available for use elsewhere. However, this may leave the volume

unmirrored and unprotected against disk failure.

▼ To remove a mirror from a volume

1. Select the volume that contains the mirror to be removed.

2. Choose Volumes  > Mirror  > Remove  (Selected  menu) or Mirror Remove
(Command Launcher).

3. Complete the Remove Mirror dialog box as follows:

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Removal Method: Specify the mirrors and/or number of mirrors to be removed:

- To specify how many mirrors should be removed, select By

Quantity/disk. Enter the number of mirrors to be removed in

the Mirror Quantity field.

- To specify the disks on which mirrors should be preserved,

select By Quantity/disk. Enter the disk names in the

Preserved Disk(s) field or click Browse  to select a disk.

- To specify the name of the mirror to be removed, select By

Mirror. Enter the mirror name in the Mirror Name field or

click Browse  to select a mirror.



Removing a Mirror From a Volume

158 VERITAS Volume Manager Storage Administrator Administrator’s Guide

After you have provided all necessary information in the dialog box, click OK.

Notes:

- The Mirror Remove task requires a volume name. This task also requires the number of

mirrors to remove, a disk name, or a mirror name.

- If a volume only has two mirrors and one mirror is removed, the volume is no longer

redundant.

- The last mirror (plex) cannot be removed from a volume.

- When a mirror is removed, the space occupied by that mirror is returned to the free space

pool.
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Removing a Log From a Volume
The Log Remove procedure removes a log from a mirrored or RAID-5 volume. For a

mirrored volume, this removes a DRL log from the volume. For a RAID-5 volume, this

removes a RAID-5 log from the volume.

▼ To remove a log from a volume

1. Select the volume that contains the RAID-5 or DRL log to be removed.

2. Choose Volumes  > Log  > Remove  (Selected  menu) or Log Remove  (Command

Launcher).

3. Complete the Remove Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Removal Method: Specify the logs and/or number of logs to be removed:

- To specify how many logs should be removed, select By

Quantity/disk. Enter the number of logs to be removed in the

Log Quantity field.

- To specify the disks on which logs should be preserved, select

By Quantity/disk. Enter the disk names in the Preserved

Disk(s) field or click Browse  to select a disk.

- To specify the name of the log to be removed, select By Log.

Enter the log name in the Log Name field or click Browse  to

select a log.

Notes:

- This task requires a volume name.

- If the only log is removed from a volume, logging (either dirty region logging or RAID-5

logging) is no longer in effect for that volume. When logging is disabled, recovery time

increases.
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Removing a Volume

Caution Removing a volume can result in data loss.

This procedure permanently removes a volume and all of its data. You should only

remove a volume if you are sure that you do not need the data in the volume (or the data

is backed up elsewhere). You can remove a volume to make the underlying disk space

available for use elsewhere.

▼ To remove a volume

1. Select the volume to be removed.

2. Choose Volumes  > Remove  (Selected  menu) or Volume Remove  (Command

Launcher).

3. Complete the Remove Volume dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume(s): If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Notes:

- Removing a volume destroys all of the data in that volume.

- When a volume is removed, the space it occupied is returned to the free space pool.
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Associating a Plex

Associating a Plex
The Plex Associate procedure associates (attaches) a plex to a volume. This involves

copying data from an active mirror on the volume to the new plex (mirror).

▼ To associate a plex

1. Choose Plex Associate  (Command Launcher).

2. Complete the Associate Plex dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Dissociating a Plex
The Plex Dissociate  procedure dissociates a plex from its volume. This disconnects the

plex from its volume and reduces volume data redundancy.

▼ To dissociate a plex

1. Choose Plex Dissociate  (Command Launcher).

2. Complete the Dissociate Plex dialog box as follows:

Plex Name: Enter the plex name or click Browse  to select the plex.

Volume Name: Enter the name of the volume to be associated with the plex or click

Browse  to select a volume.

Notes:

- The Plex Associate  task requires a plex name and a volume name.

- The Plex Associate  task connects a plex to a volume.

- The Plex Associate task can take a long time, depending on the amount of data in the

volume.

Plex Name: Enter the plex name or click Browse  to select the plex.
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After you have provided all necessary information in the dialog box, click OK.

Notes:

- The Plex Dissociate  task requires a plex name.

- The Plex Dissociate  task breaks the link between the plex and its volume. The plex

remains inaccessible until it is (re)associated with a volume.

- Dissociating a plex from a volume can result in loss of data redundancy.
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Moving a Subdisk

Moving a Subdisk
The Subdisk Move procedure moves the contents of a volume subdisk from one disk to

another. This is useful for moving portions of a volume to a different disk for improved

performance.

You can use the Object View window (Disk Groups > Object View ) or the Volume to Disk

Mapping window (Disk Groups  > Disk/Volume Map ) to view the subdisks and gaps on

disks in a disk group. In the Object View window, you can move a subdisk by placing the

pointer over the subdisk and then pressing and holding the mouse button to drag the

subdisk to another location.

▼ To move a subdisk to another disk

1. Select the subdisk to be moved to another disk.

2. Choose Subdisks > Move (Selected menu) or Subdisk Move (Command Launcher).

3. Complete the Move Subdisk dialog box as follows:

Source Subdisks: If the correct subdisk name does not already display in this field,

enter the subdisk name or click Browse  to select the subdisk.

Target Disk Name: Enter the name of the disk to which the subdisk should be moved

or click Browse  to select a disk.

Options Click Show Options  to access the optional settings for this task.

- To specify whether the subdisk can be split into smaller

subdisks that fit in available spaces on the target disk, select

one of the Move Policy options. The One to One  options do

not split the subdisks. The Split as Required  option splits

the subdisks.

- To specify the minimum disk offset for the subdisk, enter the

offset in the Starting Offset for Gap Search field.
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After you have provided all necessary information in the dialog box, click OK.

Notes:

- The Subdisk Move  task requires a subdisk name and a disk name.

- Subdisks are typically moved to reorganize disk space.

- The disk space occupied by the original subdisk is returned to the free space pool.

- A subdisk in a mirrored, striped, or RAID-5 volume should not be moved to a disk that

already contains a copy or part of that volume.

- If the Subdisk Move task fails and leaves some unused subdisks (that is, subdisks that

are not associated with a volume) on the system, you can use the Subdisk Remove task

to free the space occupied by the unused subdisks.



Chapter 4, Volume Tasks 165

Splitting a Subdisk

Splitting a Subdisk
The Subdisk Split procedure divides a subdisk into two or more smaller subdisks. Once

split, the smaller subdisks can be moved elsewhere or rejoined later. This is useful for

reorganizing volumes and/or improving performance.

You can use the Object View window (Disk Groups > Object View ) or the Volume to Disk

Mapping window (Disk Groups  > Disk/Volume Map ) to view the subdisks in a disk

group. You can use the Volume Layout Details window (Volumes  > Show Layout ) to

view subdisks in a specific volume.

▼ To split a subdisk into multiple subdisks

1. Select the subdisk to be split into multiple subdisks.

2. Choose Subdisks  > Split  (Selected  menu) or Subdisk Split  (Command Launcher).

3. Complete the Split Subdisk dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Subdisk Name: If the correct subdisk name does not already display in this field,

enter the subdisk name or click Browse  to select the subdisk.

Number of Target

Subdisks:

Enter the number of subdisks into which the subdisk should be

split. A subdisk can be split into two or more subdisks.

Notes:

- The Subdisk Split  task requires a subdisk name and the number of subdisks to result

from the split.

- The name of the first subdisk remains the same as the selected subdisk. Other subdisks

are automatically named by VxVM.

- The new, smaller subdisks occupy the same regions of the disk that the original subdisk

occupied.

- The original subdisk must contain a sufficient number of sectors for the specified split to

work.

- A Dirty Region Logging log subdisk cannot be split.
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Joining Subdisks
The Subdisk Join procedure joins two or more subdisks together to form a single, larger

subdisk. Subdisks can only be joined together if they belong to the same volume and

occupy adjacent regions of the same disk and mirror.

You can use the Object View window (Disk Groups > Object View ) or the Volume to Disk

Mapping window (Disk Groups  > Disk/Volume Map ) to view the subdisks in a disk

group. You can use the Volume Layout Details window (Volumes  > Show Layout ) to

view subdisks in a specific volume.

▼ To join subdisks

1. Select the subdisks to be combined into a single subdisk.

2. Choose Subdisks  > Join  (Selected  menu) or Subdisk Join  (Command Launcher).

3. Complete the Join Subdisks dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Source Subdisks: If the correct subdisk names do not already display in this field,

enter the subdisk names or click Browse  to select the subdisks.

Specify at least two subdisks.

Target Subdisk Name: Enter the name of the new, combined subdisk.

Notes:

- The Subdisk Join task requires two or more existing subdisk names and a new (joined)

subdisk name.

- Only contiguous subdisks on the same disk can be joined.

- The subdisks to be joined must belong to the same volume and mirror.

- For a striped volume, the subdisks must be in the same column.

- The joined subdisk name can be the name of one of the subdisks being joined.
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Removing a Subdisk
The Subdisk Remove procedure removes a subdisk from a disk. This task applies to

subdisks that are not associated with volumes. This provides a way to return the disk

space occupied by unused subdisks to the free space pool.

You can use the Disk Properties window (Disks  > Properties ) to view subdisks that are

not associated with volumes.

▼ To remove a subdisk

1. Select the disk with the subdisk to be removed.

2. Choose Disks  > Properties  (Selected  menu).

3. In the Disk Properties window, go to the Subdisks tab and select the subdisk to be

removed.

4. Choose Remove  (popup menu) or Subdisk Remove  (Command Launcher).

5. Complete the Remove Subdisk dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Subdisks: If the correct subdisk name does not already display in this field,

enter the subdisk name or click Browse  to select the subdisk.

Notes:

- You cannot remove a subdisk that is associated with a volume.

- When a subdisk is removed, the space it occupied returns to the free space pool.
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Viewing Volume Properties
The Volume Properties window contains detailed information about the selected volume.

The Properties window contains a set of tabbed pages, each of which contains information

about the volume and related objects. You can display a different page by clicking on the

appropriate tab label.

❖ To view the properties of a volume, select the volume and then choose Properties
from the Volumes  or popup menu. You can also access the Volume Properties

window by double-clicking on the volume.

❖ To update the contents of the Properties window to reflect current properties for the

volume, click Refresh .

❖ To print the contents of the Properties window, click Print  and complete the Print

dialog box.
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Adding a File System to a Volume
The Volume Add File System procedure places a file system on an existing volume and

mounts the file system. This also updates the file system table file, if necessary.

▼ To add a file system to an existing volume

1. Select the volume to contain the file system.

2. Choose Volumes  > File System  > New (Selected  menu) or Volume Add File
System  (Command Launcher).

3. Complete the New File System dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Mount Point: Enter the mount point for the file system.

FS Type: Select the file system type.

Options - To mount the file system automatically at system startup, select

Mount at Boot . If this is selected, the file system table file is

also updated at system startup.

- To specify mount  options, click Mount Details  and specify

the appropriate options in the Mount Details dialog box.

- To specify mkfs  command options, click New File System
Details  and specify the appropriate options in the New File

System Details dialog box.

Notes:

- The Volume Add File System  task requires a volume name and a file system type. If

Mount at Boot  is selected, a file system mount point is also required.

- When the file system is mounted, the file system table file is automatically updated.

- If the path specified for the mount point does not already exist, it is created.

- The mount point must be an absolute pathname (that is, it must begin with / ).
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Mounting a File System on a Volume
The Volume Mount  procedure mounts a file system that already exists on a volume and

updates the file system table file, if necessary.

▼ To mount a file system on an existing volume

1. Select the volume that contains the file system to be mounted.

2. Choose Volumes  > File System  > Mount  (Selected  menu) or Volume Mount
(Command Launcher).

3. Complete the Mount File System dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Mount Point: Enter the mount point for the file system.

Options - To mount the file system automatically at system startup, select

Mount at Boot . If this is selected, the file system table file will

also be updated at system startup.

- To specify mount  options, click Mount Details  and specify

the appropriate options in the Mount Details dialog box.

Notes:

- The Volume Mount  task requires a volume name. If Mount at Boot  is selected, a file

system mount point is also required.

- The specified volume must contain a file system.

- The file system table file is automatically updated.

- If the path specified for the mount point does not already exist, it is created.

- The mount point must be an absolute pathname (that is, it must begin with / ).
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Cluster Mounting a File System on a Cluster Node
The Volume Cluster Mount procedure mounts a VxFS file system on a selected volume in

cluster (shared) mode. See the mount_vxfs (1M) and fsclustadm (1M) manual pages for

more information on mounting cluster file systems.

▼ To cluster mount a file system from a node

1. Select the volume that contains the file system to mount in cluster mode.

2. Choose Volumes  > File System > Cluster Mount (Selected  menu).

3. Complete the Cluster Mount dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Cluster Node: To mount a specific cluster node, enter the name of the node in the

Cluster Node field or click Browse  to select a node.

Notes:

- The specified volume must contain a file system.

- The file system table file is automatically updated.

- After you perform a cluster mount from VMSA, the mount becomes persistent; that is, the

next time the system is restarted, the file system mounts automatically.

- The first file system mounted in a cluster becomes the primary file system in that cluster.

To change the primary file system, select a file system in the cluster and choose File
Systems  > Set Primary .
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Unmounting a File System on a Volume
The Volume Unmount procedure unmounts a file system.

▼ To unmount a file system on a volume

1. Select the volume containing the file system to be unmounted.

2. Choose Volumes  > File System  > Unmount  (Selected  menu) or Volume Unmount
(Command Launcher).

3. Complete the Unmount File System dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Cluster Node: If the correct cluster node name does not already display in this

field, enter the cluster node name or click Browse  to select the

cluster node.

Notes:

- The specified volume must contain a mounted file system.

- The cluster file system primary cannot be unmounted until all the cluster file system

secondaries are unmounted.
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Removing a Cluster Mounted File System

Removing a Cluster Mounted File System
The File Systems Remove procedure unmounts a cluster file system and removes its

resource information from the cluster configuration file..

▼ To remove a cluster file system from the cluster configuration

1. Select the volume containing the file system to be removed.

2. Choose File Systems > Remove (Selected  menu) or CFS Remove (Command

Launcher).

3. Complete the Remove dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

File System(s): If the correct cluster file system does not already display in the

field, enter the device name or mount point, or click Browse  to

select the cluster file system.
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Resizing a File System
The File System Resize procedure changes the size of a file system and the underlying

volume. If users require more space, you can use this procedure to increase the size of the

file system. If a VxFS file system is too large and you need the space elsewhere, you can

use this procedure to shrink the file system.

▼ To resize a file system on a volume

1. Select the file system to be resized.

2. Choose File Systems  > Resize  (Selected  menu) or File System Resize  (Command

Launcher).

3. Complete the Resize File System dialog box as follows:

File System Name: If the correct file system name does not already display in this field,

enter the file system name or click Browse  to select the file

system.

New Size: Specify one of the following:

- To increase the file system size by a specific amount of space,

use the Add By field to specify how much space should be

added to the file system.

- To decrease the file system size by a specific amount of space,

use the Subtract By field to specify how much space should be

removed from the file system.

- To specify the new file system size, enter the size in the Desired

Size field.

To determine the largest possible size for the file system, click

Maxgrow  after choosing options.

To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

Options To use a specific disk for the additional space, click Assign Disks
and select the disk you want to use from the Space Allocation

dialog box.
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Resizing a File System

After you have provided all necessary information in the dialog box, click OK.

Notes:

- The File System Resize task requires a file system name and either the desired size or

the amount of space to add to or subtract from the file system size.

- When the file system is resized, the underlying volume is also resized.

- Only VxFS file systems can be shrunk.

- The file system to be resized must be on a volume.

- For cluster mounted file systems, resizing can only be done on the CVM master node.
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Creating a Snapshot Copy of a File System
The File System Snapshot procedure prepares VxFS for online backup by creating a

snapshot copy of the file system. This is done by creating a new volume, mounting a

snapshot file system on the new volume, and copying the contents of the original file

system to the snapshot file system. The snapshot file system is a consistent copy of the

original file system at the time the snapshot was made. You can use the snapshot file

system to make a backup of the original file system at a convenient time. After the backup

is made, you can remove the snapshot file system by removing the underlying snapshot

volume (see “Removing a Volume” on page 160).

▼ To create a snapshot copy of file system data

1. Select the file system to be backed up.

2. Choose File Systems  > Snapshot  (Selected  menu) or File System Snapshot
(Command Launcher).

3. Complete the File System Snapshot dialog box as follows:

File System Name: If the correct file system name does not already display in this field,

enter the file system name or click Browse  to select the file

system.

Snapshot Mount Point: Enter the mount point for the snapshot copy of the file system.

Snapshot Size: Enter the size of the snapshot copy of the file system.

Options To place the snapshot on a specific disks, click Assign Disks and

select the disks you want to use.
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Creating a Snapshot Copy of a File System

After you have provided all necessary information in the dialog box, click OK.

Notes:

- The File System Snapshot  task requires a file system name, a snapshot mount point,

and a snapshot size.

- The File System Snapshot  task is only available for VxFS file systems.

- The snapshot file system is an exact copy of the original file system at the time the

snapshot was created.

- After you create the snapshot copy of the file system, remember to back it up to tape or

some other media. Remove the snapshot file system when it is no longer needed.

- Users can continue to use the original file system during this snapshot backup procedure.

- Refer to the VERITAS File System Administrator’s Guide for guidelines on choosing the

snapshot file system size.

- Snapshot functionality does not work on cluster file systems.
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Checking a File System on a Volume
The File System Check procedure checks an unmounted file system on a volume for

consistency (using the fsck command). This procedure can also attempt to repair the file

system, if necessary. See the fsck_vxfs (1M) manual page for more information on file

system checking.

▼ To check a file system on a volume

1. Select the volume containing the file system to be checked.

2. Choose Volumes  > File System  > Check  (Selected  menu) or File System Check
(Command Launcher).

3. Complete the Check File System dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Options - To check and attempt to repair the file system, select Check
And Repair .

- To check the file system without repairing it, select Check
With No Repair .

- To unmount the file system, run fsck , and then mount the file

system, select Unmount And Check, Then Mount .

- To unmount the file system and then run fsck , select

Unmount And Check .

Notes:

- The specified volume must contain a file system. The file system must be unmounted.

- VERITAS Volume Manager Storage Administrator assumes that fsck  does not require

user input. If user input is required, this task fails and fsck must be run at the command

line.
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Viewing File System Properties

Viewing File System Properties
The File System Properties window contains detailed information about the selected file

system. The Properties window contains a set of tabbed pages, each of which contains

information about the file system and related objects. You can display a different page by

clicking on the appropriate tab label.

❖ To view the properties of a file system, select the file system and then choose

Properties  from the File Systems  or popup menu. You can also access the File

System Properties window by double-clicking on the file system.

❖ To update the contents of the Properties window to reflect current properties for the

file system, click Refresh .

❖ To print the contents of the Properties window, click Print  and complete the Print

dialog box.
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Creating a QuickLog Volume
The Volume Make FS Log procedure designates a volume as a QuickLogTM volume. After

setting up a QuickLog volume, you can enable a QuickLog device for a file system.

▼ To designate a volume as a QuickLog volume

1. Select the volume to be used for the QuickLog device.

2. Choose Volumes > QuickLog > Make Log (Selected menu) or QuickLog Make Log
(Command Launcher).

3. Complete the Make QuickLog Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Log Device Number: Select the number of the log device (vxlog 1-31 ) to attach to the

volume. Log devices are listed in /dev/qlog .

Notes:

- The Volume Make FS Log  task is only available if QuickLog is installed/licensed.

- The Volume Make FS Log  task requires a volume name and a log device

number (1-31).

- Only VxFS file systems can be used with a QuickLog device.

- The specified volume cannot contain a file system.

- The size of the specified volume must be at least 32MB.

- QuickLog does not operate on VxFS cluster file systems.
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Enabling a QuickLog Device for a File System

Enabling a QuickLog Device for a File System
The QuickLog Enable procedure enables a QuickLog device on a VxFS file system. Before

you enable a QuickLog device, you must designate a volume as a QuickLog volume (see

“Creating a QuickLog Volume” on page 180).

▼ To enable a QuickLog device for a file system

1. Select the file system on which to enable a QuickLog device.

2. Choose File Systems  > QuickLog  > Enable  (Selected  menu) or QuickLog Enable
(Command Launcher).

3. Complete the Enable QuickLog dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name does not already display in this field,

enter the file system name or click Browse  to select the file

system.

Log Device Number: Select the number of the log device (vxlog 1-31 ) to be enabled for

the file system. Log devices are listed in /dev/qlog .

Options To enable QuickLog on the file system automatically at system

startup, select Mount at Boot. If this is selected, the file system table

file will also be updated at system startup.

Notes:

- This task is only available if QuickLog is installed/licensed.

- This task requires a file system name.

- Only VxFS file systems can be used with a QuickLog device.

- The specified QuickLog device must already have a designated QuickLog volume.

- If no log device number is specified, the least-loaded device is used.

- QuickLog does not operate on VxFS cluster file systems.
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Disabling a QuickLog Device for a File System
The QuickLog Disable procedure disables QuickLog for a VxFS file system.

▼ To disable a QuickLog device for a file system

1. Select the file system to have QuickLog disabled.

2. Choose File Systems > QuickLog > Disable (Selected menu) or QuickLog Disable
(Command Launcher).

3. Complete the Disable QuickLog dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name does not already display in this field,

enter the file system name or click Browse  to select the file

system.

Notes:

- The QuickLog Disable task is only available if QuickLog is installed/licensed.

- The QuickLog Disable  task requires a file system name.

- QuickLog does not operate on VxFS cluster file systems.
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Removing a QuickLog Volume
The Quicklog Remove procedure detaches a QuickLog volume from a QuickLog device.

Before you remove a QuickLog volume, you must disable QuickLog for all

QuickLog-enabled file systems using that QuickLog device (see “Disabling a QuickLog

Device for a File System” on page 182).

▼ To remove a QuickLog volume

1. Select the QuickLog volume to be detached.

2. Choose Volumes > QuickLog > Remove Log (Selected menu) or Quicklog Remove
(Command Launcher).

3. Complete the QuickLog Remove Log dialog box as follows:

After you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name does not already display in this field,

enter the volume name or click Browse  to select the volume.

Notes:

- The Quicklog Remove task is only available if QuickLog is installed/licensed.

- The Quicklog Remove task requires a volume name.

- QuickLog must be disabled for all QuickLog-enabled file systems using the QuickLog

device before the QuickLog volume can be detached.

- QuickLog does not operate on VxFS cluster file systems.
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Host and Cluster Tasks 5
Introduction

This chapter describes how to access and use host machines and clusters with VERITAS

Volume Manager Storage Administrator (VERITAS Volume Manager Storage

Administrator). The Host and Cluster Task Roadmap at the beginning of this chapter

contains a summary of common host and cluster tasks.

VERITAS Volume Manager Storage Administrator can access and display multiple host

machines simultaneously. VERITAS Volume Manager Storage Administrator only

provides access to cluster-related features if the optional VERITAS Volume Manager

(VxVM) cluster functionality is present.

The following host tasks are discussed in this chapter:

◆ Connecting to a Host

◆ Disconnecting a Host

◆ Setting Up Automatic Host Connections

The following cluster tasks are discussed in this chapter:

◆ Working with Clusters

◆ Starting a Cluster

◆ Stopping a Cluster

◆ Starting a Node

◆ Stopping a Node

◆ Creating a Shared Disk Group

◆ Importing a Shared Disk Group

◆ Upgrading a Cluster
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Host and Cluster Task Roadmap
The following table provides a summary of common VERITAS Volume Manager Storage

Administrator host and cluster tasks.

To perform this task … Use this procedure…

Setup Tasks:

Connect to and administer another host

machine

Connecting to a Host

Set up a shared disk group Creating a Shared Disk Group

Start a cluster Starting a Cluster

Other Tasks:

Stop a cluster Stopping a Cluster

Add a node to a cluster Starting a Node

Prevent access to a node in a cluster Stopping a Node

Disconnect from a host machine Disconnecting a Host

Access a deported disk group for cluster use Importing a Shared Disk Group
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Connecting to a Host

Connecting to a Host
The Host Connect procedure establishes a connection to a host machine from a VERITAS

Volume Manager Storage Administrator client session. VERITAS Volume Manager

Storage Administrator can provide simultaneous access to multiple host machines.

▼ To connect to a host

1. Choose File  > Connect  (Selected  menu) or Host Connect  (Command Launcher).

2. Complete the Connect to Host dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

new host appears in the object tree in the main window.

Server Host: Enter the name of the machine to be administered. Both VxVM and

the VERITAS Volume Manager Storage Administrator server must

be running on this machine.

User Name: Enter your login name. Only users with appropriate privileges can

run VERITAS Volume Manager Storage Administrator on the

specified machine.

Password: Enter your password for the machine to be administered.

Options To use the specified user as default settings for any future host

connections from VERITAS Volume Manager Storage

Administrator, select Default User .

Notes:

- This task requires a host machine name, user name, and password.

- Both VxVM and the VERITAS Volume Manager Storage Administrator server must be

running on the machine to be administered.

- Only users with appropriate privileges can run VERITAS Volume Manager Storage

Administrator.

- Entries for the user name and password must exist in the password file or corresponding

Network Information Name Service (NIS) table on the machine to be administered.

- The user name (or the user’s group ID) must be included in the vrtsadm  group entry in

the group file or NIS group table on the machine to be administered.
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Disconnecting a Host
The Host Disconnect procedure disconnects a host machine from the current VERITAS

Volume Manager Storage Administrator session. When a host machine is disconnected,

VERITAS Volume Manager Storage Administrator cannot administer that machine. To

restore access to a disconnected host machine, you must reconnect to the host.

▼ To disconnect a host

1. Select the host machine to be disconnected from VERITAS Volume Manager Storage

Administrator.

2. Choose Hosts  > Disconnect  (Selected  menu) or Host Disconnect  (Command

Launcher).

3. Complete the Disconnect Host dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK. The

disconnected host remains in the object tree in the main window, but its icon changes

to the disconnected host icon.

Host(s): Enter the name of the host machine or click Browse  to select the

host.
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Setting Up Automatic Host Connections
The procedure to set up automatic host connections causes VERITAS Volume Manager

Storage Administrator to automatically connect to specified hosts at startup. You can

specify which hosts should connect to the VERITAS Volume Manager Storage

Administrator client at startup and how to display those hosts in the main window object

tree.

▼ To set up automatic host connections

1. Choose Options  > Customize  from the main window menu bar.

2. Click on the Hosts  tab in the Customize window.

3. To specify a host machine, click Add  and enter the host machine name in the Hosts

column of the grid.

4. To automatically connect to the specified host at VERITAS Volume Manager Storage

Administrator startup, click in the Connect  column. A check mark indicates that the

Connect preference is set for the host. If you want the object tree to display the

hierarchy of objects under the host at startup, click in the Auto-Expand  column.

5. When you have completed your selections, click OK.

6. Choose Options  > Save Customization  from the main window menu bar.

Your host settings take effect the next time you start VERITAS Volume Manager

Storage Administrator.



Working with Clusters

190 VERITAS Volume Manager Storage Administrator Administrator’s Guide

Working with Clusters
VxVM includes an optional cluster feature that enables VxVM to be used in a cluster

environment. To activate the cluster feature, you must obtain a license for the VERITAS

Volume Manager cluster functionality.

After adding a VERITAS Volume Manager cluster license to the machine, you must restart

the VERITAS Volume Manager Storage Administrator server to enable cluster support in

VERITAS Volume Manager Storage Administrator. When a cluster license is present on a

machine, VERITAS Volume Manager Storage Administrator displays a Clusters icon in

the object tree (even if the machine is not currently set up as a node in a cluster). When a

cluster is shown in the tree, all active/inactive nodes that are members of the cluster

display in the tree, as shown in “Tree/Grid View of a Cluster.”

Tree/Grid View of a Cluster

❖ To display the objects in a cluster, expand the cluster hierarchy (by clicking on the plus

sign next to the Clusters icon).

❖ To determine which node is the master in a cluster, expand the cluster hierarchy for

the appropriate cluster and select Hosts  from the cluster hierarchy. The grid displays

the names and properties of the nodes in the cluster. The Type column indicates which

node is the master.
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The Cluster Properties window also indicates which node is the master. To access this

window, select a cluster and choose Properties  from the Selected or popup window.

Notes:

- When VERITAS Volume Manager Storage Administrator is connected to a single host,

that host is auto-expanded; that is, the hierarchy of objects under that host is fully

displayed in the dialog.

- If VERITAS Volume Manager Storage Administrator is connected to more than one host,

the hierarchy of objects is not auto-expanded. You can implement expansion either by

selecting Options  > Customize > Hosts and clicking in the Auto-Expand column, or

by expanding each host individually.

- Connecting to a slave node automatically connects to a master node.

- Connecting to a master node does not automatically connect to the slave nodes, unless

you have indicated that you want this to happen by selecting Options  > Customize >

Hosts and clicking in the appropriate position.

- Until VERITAS Volume Manager Storage Administrator connects to a node in the cluster,

the host icon will appear with a red slash ‘/’ in the lower right corner.

- A non-connected node will not expand until a connection is established.
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Starting a Cluster
The Cluster Start procedure starts a cluster. If the cluster is not already started, you must

use this task to start the cluster before you can access the shared objects in the cluster.

▼ To start a cluster

1. Select the Clusters icon at the top of the cluster portion of the object tree.

2. Choose All Clusters  > Start Cluster  (Selected  menu) or Cluster Start (Command

Launcher).

3. Complete the Start Cluster dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

cluster and its objects appear in the object tree.

Cluster Node: Enter the name of any machine in the cluster or click Browse  to

select a host.

Notes:

- The Cluster Start  task is only applicable in a cluster environment.

- A cluster must be started before you can access the shared objects on the machines in the

cluster.



Chapter 5, Host and Cluster Tasks 193

Stopping a Cluster

Stopping a Cluster
The Cluster Stop procedure stops a cluster and makes the shared objects in the cluster

inaccessible from VERITAS Volume Manager Storage Administrator.

▼ To stop a cluster

1. Select the cluster to be stopped.

2. Choose Clusters  > Stop Cluster  (Selected  menu) or Cluster Stop  (Command

Launcher).

3. Complete the Stop Cluster dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster: Enter the name of the cluster or click Browse  to select a cluster.

Notes:

- The Cluster Start  task is only applicable in a cluster environment.

- A cluster must be started before you can access the shared objects on the machines in the

cluster.



Starting a Node

194 VERITAS Volume Manager Storage Administrator Administrator’s Guide

Starting a Node
The Cluster Start Node procedure activates a node (host) in a cluster. This causes the

node to join the cluster. A node must be started before it can access shared objects in the

cluster. If a node has been stopped for some reason, you can use this task to restart the

node.

▼ To start node in a cluster

1. Select the node (host) to be started.

2. Choose Cluster Nodes  > Start Node  (Selected  menu) or Cluster Start Node
(Command Launcher).

3. Complete the Start Cluster Node dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster Node: Enter the name of the host machine or click Browse  to select the

host.

Notes:

- The Cluster Start  task is only applicable in a cluster environment.

- A cluster must be started before you can access the shared objects on the machines in the

cluster.
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Stopping a Node
The Cluster Stop Node procedure stops a node (host) in a cluster and makes that node

inaccessible to the cluster. A stopped node cannot access shared objects in the cluster. If

the stopped node is the master node, another node in the cluster automatically becomes

the new master.

▼ To stop a node in a cluster

1. Select the node (host) to be stopped.

2. Choose Cluster Nodes  > Stop Node  (Selected  Menu) or Cluster Stop Node
(Command Launcher).

3. Complete the Stop Cluster Node dialog box (if applicable) as follows:

When you have provided all necessary information in the dialog box, click OK.

4. Confirm that you want to stop this node.

Cluster Node: Enter the name of the host machine or click Browse  to select the

host.

Notes:

- The Cluster Stop Node  task is only applicable in a cluster environment.

- When a node is stopped, the node cannot access the shared objects in the cluster.

- If the master node is stopped, another node in the cluster automatically becomes the

new master.
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Creating a Shared Disk Group
The Disk Group Create procedure creates a shared disk group for use in a cluster

environment. Disks must be placed in disk groups before they can be used by VxVM. The

default disk group (rootdg ) is usually created during VxVM installation and always

exists on a system running VxVM. You can create additional disk groups to organize your

disks into logical sets of disks.

When you place a disk under VxVM control, the disk is either encapsulated or initialized.

Encapsulation preserves any existing data on the disk in volumes. Initialization destroys

any existing data on the disk.

▼ To create a disk group

1. Select the host machine that is the master node.

2. Choose File  > New > Disk Group  (Selected  menu) or Disk Group Create
(Command Launcher).

3. Complete the New Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Enter the name of the disk group to be created. Click View to view

the names of existing disk groups.

To set up any new disks on the system, click Scan Disks . This

runs the disk setup commands appropriate for the operating

system.

Disk Device(s): Select the disks to be placed in the new disk group.

Cluster Settings Click Show Options  to access the optional settings for this task.

Select Create Shared to create a shared disk group.

Options Click Show Options  to access the optional settings for this task.

- To specify the VERITAS Volume Manager disk name for the

disk, enter a disk name in the Disk Name(s) field. If no

VERITAS Volume Manager disk name is specified, VxVM

assigns a default name to the disk.

- To apply a comment or attribute to disks that are placed in the

disk group, enter the information in the Comment field.
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4. Indicate whether to initialize or encapsulate the disk. If you initialize the disk, any

existing data on the disk is destroyed. If you encapsulate the disk, any existing data is

preserved in volumes.

5. If you encapsulate the disk, reboot the system.

Notes:

- The Disk Group Create  task requires a disk group name and the name of at least one

disk.

- The disk group name must be unique.

- The new disk group must contain at least one disk.

- Only disks that are online and do not belong to a disk group can be used to create a disk

group.

- When a disk is placed under VxVM control, the disk is either initialized or encapsulated.

Encapsulation preserves any existing data on the disk in the form of volumes.

Initialization destroys any existing data on the disk. Encapsulation is recommended for

the root/boot disk and any other disks that contain valuable data.

- The VERITAS Volume Manager disk name must be unique within the disk group.

- If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, VxVM appends numbers to the disk name so that each

disk name is unique within its disk group.
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Importing a Shared Disk Group
The Disk Group Import procedure makes a deported (inaccessible) disk group and its

volumes accessible in a cluster environment. To import a deported disk group as shared,

you must know the former name of the disk group and this disk group name must remain

unused. In addition, at least one disk formerly assigned to the deported disk group must

remain unused.

▼ To import a disk group

1. Select the host machine that is the master node.

2. Choose Hosts  > Import Disk Group  (Selected  menu) or Disk Group Import
(Command Launcher).

3. Complete the Import Disk Group dialog box as follows:

Disk Group Name: Enter the name of the disk group to be imported or click Browse
to select the disk group.

Cluster Settings Click Show Options to access the optional settings for this task.

Select Import Shared to import the disk group as a shared disk

group.

Options Click Show Options  to access the optional settings for this task.

- To start all volumes in the disk group at import, select Start
All Volumes .

- To clear the existing host ID stamp on all disks in the disk

group at import, select Clear Host ID . Do not use this option

if another host is using any disks in the disk group.

- To force the disk group import when the host cannot access all

disks in the disk group, select Force Import . This option can

be used to import a disk group that contains a failed disk, but

can lead to disk group inconsistency if all disks are still usable.

- To change the name of the disk group at import, enter a new

disk group name in the New Name field. To indicate that the

name change is temporary, select Use New Name as
Temporary .



Chapter 5, Host and Cluster Tasks 199

Importing a Shared Disk Group

When you have provided all necessary information in the dialog box, click OK.

Notes:

- The Disk Group Import  task requires a disk group name.

- Only deported disk groups can be imported.

- A deported disk group cannot be imported if another disk group with the same name has

been created since the disk group was deported.

- A disk group import can fail if the host cannot find one or more disks in the disk group. If

the import fails because a disk has failed, you can import the disk group by selecting the

Force Import  option. If the import fails for another reason, a forced import can cause

serious problems.

- When a disk group is imported, the system stamps its host ID on all disks in the disk

group. A disk group import should fail if one of the disks is stamped with a host ID that

does not match the others. This ensures that dual-ported disks cannot be managed (and

possibly corrupted) by two systems at the same time. If you are sure that the disk group is

not in use by another host, you can clear the host IDs and import the disk group by

selecting the Clear Host ID  option.
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Upgrading a Cluster
The Cluster Rolling Upgrade procedure upgrades a cluster and its nodes while the

cluster remains accessible. This is accomplished by upgrading one node in the cluster at a

time so that at least one node remains online at all times. When all of the nodes in the

cluster are upgraded, the cluster protocol version is upgraded to support the new version

of the software.

▼ To upgrade a cluster

1. Upgrade each node in the cluster to the new software version as follows:

a. Stop the node (as described in “Stopping a Cluster” on page 193).

b. Upgrade the software on the node.

c. Restart the node (as described in “Starting a Node” on page 194).

d. Repeat these steps for each node in the cluster, one node at a time.

2. Select the cluster to be upgraded.

3. Choose Clusters  > Rolling Upgrade  (Selected  menu) or Cluster Rolling Upgrade
(Command Launcher).

4. Complete the Rolling Upgrade dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster: Enter the name of the cluster or click Browse  to select a cluster.

Notes:

- The Cluster Rolling Upgrade  task is only applicable in a cluster environment.

- This task upgrades the cluster to a new protocol version while the cluster remains

accessible.

- All nodes in the cluster must be upgraded to the new version of the software before the

cluster is upgraded. To avoid shutting down the cluster, you must stop, upgrade, and

restart one node in the cluster at a time.

- Once the cluster is upgraded, it cannot be downgraded to the previous version.
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Troubleshooting 6
Introduction

This chapter provides information about VERITAS Volume Manager Storage

Administrator (VERITAS Volume Manager Storage Administrator) alerts, object states,

and other troubleshooting topics. This chapter also contains suggestions on how to fix

some common problems. If you are unable to resolve a problem by following the

instructions in this chapter, contact Customer Support for additional information.

The following topics are discussed in this chapter:

◆ Alerts

◆ Disk Troubleshooting

◆ Volume Troubleshooting

◆ General Troubleshooting

- Client/Server Problems

- Configuration Changes
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Alerts
When an object fails or experiences an error, an alert icon appears on the object and the

object state usually changes to an unhealthy state. The unhealthy object also appears in

the Alert Monitor window, which summarizes the problem and indicates whether any

associated objects have problems. When an object enters an unhealthy state and has an

alert, you should review the contents of the Alert Monitor window and then try to correct

the problem. For more information about an object listed in the Alert Monitor window,

review the object Properties window.

❖ To display the Alert Monitor window, click the Alert  button in the toolbar or choose

Window  > Alerts .

❖ To view the properties of an object listed in the Alert Monitor window, select the

object and choose Object Properties  from the Alert  or popup menu. You can also

access object properties by double-clicking on the object.
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Disk Troubleshooting
The disk state indicates the current condition of a disk. The disk state appears in the state

column of the grid and in the Disk Properties window. When a disk is unhealthy, an alert

icon appears on the disk and the disk is listed in the Alert Monitor window. This section

describes the following disk states and provides suggestions on how to correct problems

associated with the unhealthy states:

◆ Disk State: Imported

◆ Disk State: Free

◆ Disk State: Not Setup

◆ Disk State: Import Failed

◆ Disk State: Disconnected

◆ Disk State: Deported

◆ Disk State: Offline

◆ Disk State: Not Initialized

◆ Disk State: Locked

◆ Disk State: Inactive

◆ Disk State: Foreign Owned

Disk State: Imported

The disk is accessible and has no known problems. The disk is under VERITAS Volume

Manager (VxVM) control and belongs to a disk group. This is the normal disk state. No

user action is required.

Disk State: Free

The disk is in the Free Disk Pool. A disk in the Free Disk Pool is under VxVM control, but

does not belong to a disk group.

❖ To make the disk available for VxVM use, add the disk to a disk group.
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Disk State: Not Setup

The disk is not under VxVM control.

❖ To make the disk available for VxVM use, place the disk under VxVM control and add

the disk to a disk group.

Disk State: Import Failed

The disk was previously under VxVM control, but VxVM cannot access the disk and/or

configuration information for the disk. The disk is not available for use. This can happen

after you upgrade VxVM. This can also happen if some disks are inaccessible at system

startup.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks ) to make sure that VxVM recognizes all attached hardware. Try

to import the disk group for the disk.

❖ If the disk group is imported and the disk does not have a VERITAS Volume Manager

disk name, place the disk under VxVM control and add the disk to a disk group.

Disk State: Disconnected

The connection between the VERITAS Volume Manager disk and the underlying physical

disk (device) is broken. This can occur when a disk fails or when you disconnect a disk.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts  > Scan Disks ) to make sure that VxVM recognizes any newly attached

hardware.

❖ Try to reconnect the disconnected VERITAS Volume Manager disk to its physical disk

(using the Replace Disk  task).

❖ If you cannot fix the problem, replace the disk with another physical disk.
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Disk State: Deported

The disk belongs to a disk group that is currently deported. The disk is not available for

use in the deported disk group and cannot be added to a new disk group.

❖ To return the disk to a usable state, import the disk group for the disk.

❖ To move the disk to another disk group, import the current disk group, remove the

disk, and add the disk to a new disk group.

❖ If the disk group import fails and you want to free the disk space for use in other disk

groups, you can use the Initialize Disk task (Hosts > Initialize Disk ) or the following

command to reinitialize the disk:

# vxdisk -f init device_name

Caution This command overwrites the disk header and configuration information on

the disk. Any volume copies or regions located on the disk are not accessible

after you reinitialize the disk.

Disk State: Offline

VxVM cannot access the disk.

❖ To return the disk to an accessible state, bring the disk online.

Disk State: Not Initialized

A configuration error prevents the disk from being used.

❖ To make the disk available for VxVM use, place the disk under VxVM control and add

the disk to a disk group.

❖ If the disk cannot be added to VxVM using VERITAS Volume Manager Storage

Administrator, it can be necessary to reinitialize the disk with the Initialize Disk  task

(Hosts  > Initialize Disk ) or the following command:

# vxdisk -f init device_name

Caution This command overwrites the disk header and configuration information on

the disk. Any volume copies or regions located on the disk are not accessible

after you reinitialize the disk.
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Disk State: Locked

The disk belongs to a disk group that is currently imported by another machine or was

last imported by another machine and was not deported cleanly. The disk is not currently

usable on the local machine.

❖ To make all of the disks in the disk group available for use on the local machine,

deport the disk group on the remote machine and then import the disk group on the

local machine.

❖ To make one disk available for use on the local machine, remove the disk from its disk

group (on the other machine) and add it to a disk group on the local machine.

❖ If the disk group is not imported on another machine, it can be necessary to re-import

the disk group and clear the host ID on all disks in the disk group. You can do this by

selecting the Clear Host ID option in the Import Disk Group dialog box or by running

the following command:

# vxdg -C import disk_group

Caution If any of the disks in the disk group are in use by another machine, this

command can cause the disks to be managed by two systems at the same time,

which can lead to corruption.

Disk State: Inactive

The disk appears to belong to a disk group, but is not active in the disk group. The disk

may have become (temporarily) inaccessible. Alternatively, the disk may have been

inaccessible at disk group import, but may be accessible now.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts  > Scan Disks ) to make sure that VxVM recognizes any newly attached

hardware.

❖ It may be necessary to reattach the disk to its disk group with the Replace Disk  task

or the following command:

# /etc/vx/bin/vxreattach [ device_name ]

After a successful reattach, volume recovery can be necessary.

❖ If the reattach fails and you want to free the disk space for use, you can use the

Initialize Disk task (Hosts > Initialize Disk ) or the following command to reinitialize

the disk:

# vxdisk -f init device_name
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Caution This command overwrites the disk header and configuration information on

the disk. Any volume copies or regions located on the disk is not accessible after

you reinitialize the disk.

Disk State: Foreign Owned

The disk is under the control of another disk management product. The disk is not

available for use with VxVM.

❖ To make the disk available for VxVM use, remove the disk from the other disk

management product control and place the disk under VxVM control.
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Volume Troubleshooting
The volume state indicates the current condition of a volume. The volume state appears in

the state column of the grid and in the Volume Properties window. When a volume is

unhealthy, an alert icon appears on the volume and the volume is listed in the Alert

Monitor window. This section describes the following volume states and provides

suggestions on how to correct problems associated with the unhealthy states:

◆ Volume State: Started

◆ Volume State: Stopped

◆ Volume State: Uninitialized

◆ Volume State: Degraded

◆ Volume State: Unusable

Volume State: Started

The volume is accessible and has no known problems. This is the normal volume state. No

user action is required.

Volume State: Stopped

The volume is disabled and is not available for use.

❖ To return the volume to a usable state, start the volume.

Volume State: Uninitialized

The volume is enabled, but is not initialized. If this state appears during volume creation,

no user action is necessary.

❖ To put the volume in a usable state, start the volume.
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Volume State: Degraded

The RAID-5 volume is in a degraded mode. This usually occurs when one or more

subdisks are unavailable and read requests require data reconstruction. An underlying

disk may have failed completely or there may be I/O errors on part of a disk.

Alternatively, an underlying disk may be disconnected.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts  > Scan Disks ) to make sure that VxVM recognizes any newly attached

hardware.

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If there has been a partial or complete disk failure, either replace the disk or move the

affected subdisks to another disk.

Volume State: Unusable

The RAID-5 volume is unusable. This usually occurs when there is a double disk failure

(that is, when two subdisks in the same stripe or the parity and one subdisk in a stripe are

damaged or inaccessible). The underlying disks may have failed or become inaccessible.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks ) to ensure that VxVM recognizes any newly attached hardware.

Run the following command to reattach the disks to their disk group:

# /etc/vx/bin/vxreattach [ device_name ]

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If two of the volume disks have failed, the RAID-5 volume data is unusable. Replace

the failed disks and then try to restart the volume by running the following command:

# vxvol -f start volume_name

Restore the volume from backup.

To prevent this problem in the future, enable logging for RAID-5 volumes.
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General Troubleshooting
This section contains suggestions on how to correct some general problems that may

occur when you try to use VERITAS Volume Manager Storage Administrator.

Client/Server Problems
This section describes some VERITAS Volume Manager Storage Administrator client and

server problems and provides suggestions on how to correct these problems. For more

information about the client and server, refer to the vmsa(1M) and vmsa_server (1M)

manual pages.

User is not authorized to connect to the server.

This error can occur for the following reasons:

◆ The user name is incorrect.

◆ The password is incorrect.

◆ The user does not have an account on the machine.

◆ The password and group files or NIS tables do not contain entries for the user.

◆ The user is not listed in the vrtsadm  group entry.

❖ Enter the user name and password again. If the same error appears, ask the

administrator of the machine to make sure that your user name is included in the

vrtsadm  group entry and your user name and password are entered correctly in the

appropriate password and group files or NIS tables.

There is no such server.

The specified host machine does not exist or is not in the Domain Name System (DNS).

❖ Check the machine name and enter the machine name again.

Unable to connect to the server.

The VERITAS Volume Manager Storage Administrator server may not be running on the

machine to be administered.

❖ Make sure the server is running (vmsa_server -q ) and the client and server are

properly configured. If necessary, restart the VERITAS Volume Manager Storage

Administrator server.
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Possible client/server versions mismatch.

The VERITAS Volume Manager Storage Administrator client and server versions may be

incompatible.

❖ Check the client and server versions using the following commands:

# vmsa -V
# vmsa_server -V

If necessary, upgrade the client or server.

Server connection lost.

The VERITAS Volume Manager Storage Administrator server has been stopped.

❖ Restart the server.

The server seems to have multiple addresses.

The server (host) may be known by multiple addresses.

❖ Try to specify one of the server IP addresses as the server host name.

Configuration Changes
VERITAS Volume Manager Storage Administrator is dynamic, so VERITAS Volume

Manager Storage Administrator automatically displays new objects or changes to existing

objects on the system. These changes or additions are usually reflected in VERITAS

Volume Manager Storage Administrator immediately (or within a short time).

If you add objects (such as new disks) to the system and VERITAS Volume Manager

Storage Administrator does not display these objects within a short time, you can force

VERITAS Volume Manager Storage Administrator to check for new objects in one of the

following ways:

❖ Scan the disks on the system (Hosts  > Scan Disks ) to make sure that VxVM

recognizes any newly attached hardware.

❖ Update the VERITAS Volume Manager Storage Administrator server configuration

database (Hosts  > Reset Server ).
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Glossary

alert

An indication that an error or failure has occurred on an object on the system. When an object fails
or experiences an error, an alert icon appears.

alert icon

An icon that indicates that an error or failure has occurred on an object on the system. Alert icons
usually appear in the status area of the main window and on the group icon of the affected object.

Alert Monitor

A window that provides information about objects that have failed or experienced errors.

browse dialog box

A dialog box that is used to view and/or select existing objects on the system. Most browse dialog
boxes consist of a tree and grid.

button

A window control that the user clicks to initiate a task or display another object (such as a window
or menu).

CFS

Cluster file system. AVxFS file system mounted on a selected volume in cluster (shared)

mode.

check box

A control button used to select optional settings. A check mark usually indicates that a check box is
selected.

children

Objects that belong to an object group.
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cluster

A set of host machines (nodes) that shares a set of disks.

cluster file system

See CFS.

Command Launcher

A window that displays a list of tasks that can be performed on VERITAS Volume Manager
(VxVM) or other objects. Each task is listed with the object type, task (action), and a description of
the task. A task is launched by clicking on the task in the Command Launcher. The Command
Launcher can be separated from or attached to the main window.

command log

A log file that contains a history of VERITAS Volume Manager Storage Administrator (VMSA)
tasks performed in the current session and previous sessions. Each task is listed with the task
originator, the start/finish times, the task status, and the low-level commands used to perform the
task.

Command Log View window

A window that displays the VERITAS Volume Manager Storage Administrator command log file.

device name

The physical disk device name (ordisk access name).

dialog box

A window in which the user submits information to VMSA. Dialog boxes can contain selectable
buttons and/or fields that accept information.

disk group

A set of disks that are under VxVM control and share a common configuration. A disk group
configuration is a set of records containing detailed information on existing VERITAS Volume
Manager objects (such as disk and volume attributes) and their relationships. Each disk group has
an administrator-assigned name. The root disk group (rootdg ) is a special private disk group that
always exists. Volumes can only be created on disks that belong to disk groups.

disk name

The VERITAS Volume Manager disk name (ordisk media name). This is the logical name given to
the disk by VxVM or the administrator.
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dock

To separate or attach the main window and a subwindow.

enclosure

A disk array.

free disk pool

Disks that are under VxVM control, but do not belong to a disk group.

gap

A disk region that does not contain VERITAS Volume Manager objects (subdisks).

graphical view

A window that displays a graphical view of objects. In VMSA, the graphical views include the
Object View window and the Volume Layout Details window.

grid

A tabular display of objects and their properties. The grid lists VERITAS Volume Manager objects,
disks, controllers, or file systems. The grid displays objects that belong to the group icon that is
currently selected in the object tree. The grid is dynamic and constantly updates its contents to
reflect changes to objects.

group icon

The icon that represents a specific object group.

GUI

Graphical User Interface.

host

A machine or system.

launch

To start a task or open a window.

main window

The main VERITAS Volume Manager Storage Administrator window. This window contains a tree
and grid that display volumes, disks, and other objects on the system. The main window also has a
menu bar, a toolbar, and an optional Command Launcher.
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menu

A list of options or tasks. A menu item is selected by pointing to the item and clicking the mouse.

menu bar

A bar that contains a set of menus for the current window. The menu bar is typically placed across
the top of a window.

mirror

A copy of a volume and its data. There can be several mirrors per volume. The termsmirror and
plex are used synonymously.

node

In the Storage Administrator tree, a node is an element attached to the tree.

In a cluster environment, a node is a host machine in a cluster.

object group

A group of objects of the same type. Each object group has a group icon and a group name. In
VMSA, object groups include disk groups, disks, volumes, controllers, free disk pool disks,
uninitialized disks, and file systems.

object tree

A dynamic hierarchical display of VERITAS Volume Manager objects and other objects on the
system. Each node in the tree represents a group of objects of the same type.

Object View Window

A window that displays a graphical view of the volumes, disks, and other objects in a particular
disk group. The objects displayed in this window are automatically updated when object properties
change. This window can display detailed or basic information about volumes and disks.

plex

A copy of a volume and its data. There can be several plexes per volume. The termsmirror andplex
are used synonymously.

popup menu

A context-sensitive menu that only appears when you click on a specific object or area.

properties window

A window that displays detailed information about a selected object.
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radio buttons

A set of buttons used to select optional settings. Only one radio button in the set can be selected at
any given time. These buttons toggle on or off.

read-only mode

Read-only mode allows you to view objects on the system through VMSA, but prevents
administrative actions from taking effect.

scroll bar

A sliding control that is used to display different portions of the contents of a window.

Search window

The VERITAS Volume Manager Storage Administrator search tool. The Search window provides a
set of search options that can be used to search for objects on the system.

Selected menu

A context-sensitive menu that changes its menu options to match the type of object that is selected.
By default, theSelected menu is greyed out. When an object is selected, theSelected menu
provides access to tasks appropriate for the selected object.

splitter

A bar that separates two panes of a window (such as the object tree and the grid). A splitter can be
used to adjust the sizes of the panes.

status area

An area of the main window that displays an alert icon when an object fails or experiences some
other error.

subdisk

A set of contiguous disk blocks that form a logical disk segment. Subdisks are associated with
plexes (mirrors) to form volumes.

task properties window

A window that displays detailed information about a task listed in the Task Request Monitor
window.

Task Request Monitor

A window that displays a history of tasks performed in the current VERITAS Volume Manager
Storage Administrator session. Each task is listed with the task originator, the task status, and the
start/ finish times for the task.
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toolbar

A set of buttons used to access VERITAS Volume Manager Storage Administrator windows. These
include another main window, a task request monitor, an alert monitor, a search window, and a
customize window.

tree

A dynamic hierarchical display of objects on the system. Each node in the tree represents a group
of objects of the same type.

uninitialized disks

Disks that are not under VxVM control.

volume

A virtual disk or entity that is made up of portions of one or more physical disks.

Volume Layout Details Window

A window that displays a graphical view of a volume and its components. The objects displayed in
this window are not automatically updated when the volume properties change.

Volume to Disk Mapping Window

A window that displays a tabular view of volumes and their underlying disks. This window can also
display details such as the subdisks and gaps on each disk.

VMSA

VERITAS Volume Manager Storage Administrator.

VxFS

VERITAS File System.

VxVM

VERITAS Volume Manager.
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Index

A
accessing tasks 44

activating disk groups 113

adding

disks 73

file systems 169

alert monitor 65

alerts

detecting 65

icons 10, 66

monitoring 65

on disks 203

on volumes 208

responding to 65

Alerts button 9

associating plexes 161

auto-start mode, VMSA 24

B
backing up file systems 176

boot disk

mirroring 83

placing under VxVM control 74

browsing dialog boxes 49

buttons

in dialog boxes 48

toolbar 9

C
CFS mounting 171

changing volume layouts 138

checking file systems 178

client 23

cluster nodes

cluster mounting file system on 171

starting 194

stopping 195

clusters

accessing 17

creating shared disk groups 196

defined 7

file system in, primary 171

importing disk groups 198

starting 192

starting a node 194

stopping 193

stopping a node 195

upgrading 200

color preference settings 58, 59

Command Launcher 10, 46

command log 53

commands, viewing 50

concatenated volumes 122, 126

connecting to hosts 187, 189

controllers

disabling 95

enabling 96

creating

disk groups 98

file systems 169

shared disk groups 196

volumes 122, 126, 128, 130, 132

Customize button 10

Customize window 54

D
deporting disk groups 102

destroying disk groups 107

dialog boxes

browsing 49

buttons 48

inputting size units 50

selecting objects 49

using 48

dirty region logging 143

disabling

controllers 95

mirrors 156
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disconnecting

disks 85

hosts 188

disk arrays, renaming 97

disk group name, changing 101

disk group versions 100

disk groups

activating 113

adding disks 73, 75

clearing hot-relocation information 106

creating 98, 196

deporting 102

destroying 107

importing 103, 198

joining 112

moving objects between 108

preventing access 102

properties 115

recovering volumes 105

removing 107

removing disks 91

renaming 101

restoring access 103, 198

splitting 108, 110

task roadmap 71

upgrading 100

disks

adding 73

adding to disk group 75

adding to Volume Manager 73

alternate boot disk 83

boot 83

changing names 97

disconnecting 85

encapsulating 74

evacuating 84, 187

forced initialization 93

free disk pool 7

hot-relocation spares 78

initializing 74, 93

maintenance tasks 18

mirroring 83

moving contents 84, 187

names, changing 80

new 73

offline 81

online 82

placing under Volume Manager control

73

preventing access 81

properties 41, 94

recovering 90

reinitializing 93

removing 91

renaming 80

replacing 86

restoring access 82

scanning 73

setup tasks 17

states 203

task roadmap 71

troubleshooting 93, 203

uninitialized 7

unrelocating 88

Volume Manager 73

volume mapping 28, 39

displaying

commands 50

disk group properties 115

disk properties 94

dissociated objects 34

file system properties 179

object properties 28

Object Properties window 41

objects 28

volume properties 168

dissociated objects, displaying 34

dissociating plexes 161

E
Enabling 148

enabling controllers 96

encapsulating disks 74

enclosures, renaming 97

errors. See alerts

evacuating disks 84, 187

F
fast mirror resynchronization. See FR

fast resynchronization. See FR

File 8

File menu 8, 44

file system size, changing 174

file system task roadmap 121

file systems

and volumes 169, 170

backup 176

checking 178

cluster mounting on cluster node 171
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creating 169

maintenance tasks 18

primary in cluster 171

repair tasks 19

repairing 178

resizing 174

setup tasks 17

snapshot copies 176

task roadmap 121

unmounting 172, 173

FMR. See FR

font preference settings 57

FR 148

free disk pool 7

free space 39, 64, 94

G
graphical view

Object View window 28

object view window 32

preference settings 61

volume layout details 38

grid

and tree view 28, 29

defined 7

preference settings 60

Grid button 9

H
help 8

Help menu 8

Host button 9

hosts

accessing 17

accessing multiple hosts 4

connecting 9, 189

connecting at startup 189

connecting to 187

defined 7

disconnecting 188

preference settings 62

hot-relocation

clearing disk group information 106

designating spare disk 78

unrelocating disk 88

I
icons

alerts 66

errors 66

Storage Amininstrator 11

importing

disk groups 103

shared disk groups 198

initializing disks 74, 93

inputting size units 50

installation setup tasks 16

J
joining

disk groups 112

joining subdisks 166

L
layered volumes 123

logs

adding to volumes 143

command log 53

disabling 159

DRL 143

QuickLog 180, 181

RAID-5 143

removing 159

task log 53

M
main window

description of 5

preference settings 57

status area 10

maintenance tasks 17

menus

context-sensitive 8, 45

File 44

Help 8

Options 8, 54

popup 45

preferences 8, 54

running tasks from 44

Selected 8, 44

types of 8

Window 8

mirrored volumes 123, 132

mirroring

disks 83

volumes 132, 141

mirrors

adding to volumes 141

detaching 156

disabling 156
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removing 157

repairing 155

mixed layout volumes 123

monitoring

alerts 10, 65

performance 39

tasks 50

mounting file systems 170

moving

subdisks 34, 163

multiple host support 4

N
New button 9

O
object properties

displaying 41, 94, 115, 168, 179

in grid 29

window 41

object tree 7

Object View window preference settings 59,

62

Object View window, described 28

objects

displaying 28

searching 64

selecting 28, 49

sorting 31

viewing 28

offline disks 81

online disks 82

Options menu 8, 54

P
performance monitoring 39

placing disks under Volume Manager

control 73

plexes

See also mirrors

associating 161

dissociating 161

popup menus 45

preferences

color 58, 59

Customize window 10

fonts 57

general 56

hosts 62

main window 57

object view 59, 62

Options menu 8

setting 8, 54

toolbar 61

tree and grid 60

Volume Layout Details window 61

window size 60

primary file system in cluster 171

Print button 10

printing 10, 68

projection 34

projection window 34

properties

disk 94

Disk Group Properties window 115

disk groups 115

Disk Properties window 94

File System Properties window 179

in grid 29

Object Properties window 41

Object Properties window, described 28

Props button 9

Volume Properties window 168

volumes 168, 179

Q
QuickLog logs 180, 181

R
RAID-5 logging 143

RAID-5 volumes 122, 130

read-only mode 3

recovering

disks 90

volumes 19, 90, 105, 154

recovery tasks 18

relayout 138

remote administration 2

removing

disk groups 107

disks 91

logs 159

volumes 160

renaming

disk arrays 97

disk groups 101

disks 80

enclosures 97

volumes 137

repairing mirrors 155
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replacing disks 86

resizing

file systems 174

volumes 135

roadmap, disk task 71

root disk

mirroring 83

placing under VxVM control 74

running tasks 44

S
scanning disks 73

Search button 9

search window 64

searching 64

security 2, 23

Selected menu 8, 44

selecting objects 28, 49

server 23

setup tasks 16

shared disk groups 196, 198

size units, inputting 50

snapshot copies of file systems 176

snapshot copies of volumes 147

snapshots

copy of file system 176

copy of volume 147

dissociating 151, 152

merging 150

sorting objects 31

spare disks 78

splitter 8

splitting

disk groups 108, 110

splitting subdisks 165

starting cluster nodes 194

starting clusters 192

starting the Storage Administrator 24

starting volumes 146

status area 10

stopping cluster nodes 195

stopping clusters 193

stopping volumes 145

Storage Administrator

client 23

defined 2

features 2

installation 23

main window 5

server 23

starting 24

striped volumes 122, 128

subdisks

graphical view 38

joining 166

moving 34, 163

removing 167

splitting 165

viewing 38

T
Task button 9

task history 50

task launcher 10

task log 53

task monitor 50

task request monitor 50

tasks

accessing 44

Command Launcher 10

disk maintenance 18

disk setup 17

displaying 50

file system maintenance 18

from Command Launcher 46

from menus 44, 45

list 16

maintenance 17

monitoring 50

properties 51, 52

recovery 18

repair 18

roadmap 16

running 44

setup 16

underlying commands 51, 52

viewing 50

volume maintenance 18

volume recovery 19

volume repair 19

volume setup 17

toolbar

buttons 9

preference settings 61

tree

and grid view 28, 29

object 7

preference settings 60
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troubleshooting

disk states 203

volume states 208

U
uninitialized disks 7

unmounting file systems 172, 173

unrelocating disks 88

upgrading clusters 200

user preferences 54

V
viewing commands 50

viewing objects

and object properties 28

graphical view 38

properties 41, 94, 115, 168, 179

tree and grid 29

VMSA

auto-start mode 24

vmsa_server 23

Volume Layout Details window

described 28, 38

preference settings 61

volume layouts 122, 138

Volume Manager Storage Administrator 2

volume name, changing 137

volume size, changing 135

volume states 208

volume task roadmap 119

volume to disk mapping window 39

Volume to Disk Mapping window,

described 28

volumes

adding file systems 169

adding logs 143

adding mirrors 141

and file systems 169, 170

associating plexes 161

backup and restore 153

changing layout 138

concatenated 122, 126

concatenated pro 123

creating 9, 122, 126, 128, 130, 132

detaching mirrors 156

disabling 145

disk mapping 28, 39

dissociating plexes 161

dissociating snapshots 151, 152

enabling 146

graphical view 28, 38

joining subdisks 166

layered 123

layout 28

maintenance tasks 18

merging snapshots 150

mirrored 123, 132

mixed layout 123

mounting file systems 170

moving subdisks 163

preparing to restore 153

properties 41, 168, 179

RAID-5 122, 130

reattaching mirrors 155

recovering 90, 105, 154

recovery tasks 19

relayout 138

removing logs 159

removing mirrors 157

removing volumes 160

renaming 137

repair tasks 19

repairing mirrors 155

resizing 135

setup tasks 17

snapshot copies 147

splitting subdisks 165

starting 146

stopping 145

striped 122, 128

striped pro 123

task roadmap 119

troubleshooting 208

underlying disks 28, 39

unmounting file systems 172, 173

VRTSexplorer xv

VxVM

obtaining system information xv

W
Window menu 8

windows

alert monitor 65

command log view 53

graphical view 38

main window 5

object properties 28, 41

object view 32

preferences 54, 55
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resizing 8, 60

search 64

setting size preferences 60

task request monitor 50

volume layout details 38

volume to disk mapping window 39
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