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Preface
Introduction
This guide describes how to use the VERITAS Volume Manager™ Storage

Administrator. The Volume Manager Storage Administrator is the Graphical

User Interface (GUI) for the Volume Manager.

Audience
This guide is intended for system administrators responsible for configuring

and maintaining systems using the VERITAS Volume Manager.

This guide assumes:

• A basic understanding of system administration

• A working knowledge of the UNIX operating system

• Familiarity with the VERITAS Volume Manager and related concepts

Scope
The purpose of this guide is to provide system administrators with information

on how to use the VERITAS Volume Manager’s graphical user interface to

perform Volume Manager tasks.
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Organization
This guide is organized as follows:

• Chapter 1, “Introduction to the Storage Administrator,” describes the main

components of the Volume Manager Storage Administrator.

• Chapter 2, “Getting Started,” describes how to set up and start using the

Storage Administrator.

• Chapter 3, “Disk Tasks,” describes how to set up and use disks with the

Storage Administrator.

• Chapter 4, “Volume Tasks,” describes how to create and use volumes with

the Storage Administrator.

• Chapter 5, “Troubleshooting,” provides information about Storage

Administrator object states and alerts.

• The Glossary defines terms that relate to the Storage Administrator.

Related Documents
The following documents provide related information:

• VERITAS Volume Manager Installation Guide

• VERITAS Volume Manager Getting Started Guide

• VERITAS Volume Manager Command Line Interface Administrator’s Guide

• VERITAS Volume Manager Administrator’s Reference Guide

• VERITAS Volume Manager Release Notes

• VERITAS Volume Manager manual pages
x VERITAS Volume Manager Storage Administrator Administrator’s Guide



Conventions
The following table describes the typographic conventions used in this guide.

The following table describes terms associated with the use of the mouse:

Typeface Usage Examples

courier Computer output; user input;

names of commands, files, and

directories

$ You have mail.
The cat command displays files.

$ ls -a

italics New terms; document titles; words

to be emphasized; variables to be

substituted with a real name or

value

$ cat filename
Refer to the User’s Guide for details.

bold Glossary terms

Term Definition

Click Press and release the mouse button.

Double-click Click the mouse button twice in rapid succession.

Press and Hold Press and continue to hold down the mouse button.

Point Move the tip of the pointer onto an item on the screen.

Select Click the mouse button while the pointer is directly over

the item to be selected.
Preface xi
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The Main Window
The Volume Manager Storage Administrator’s main window (see Figure 1)

consists of:

• a hierarchical tree of objects

• a grid that lists objects and their properties

• a menu bar

• a toolbar

• a status area

• a Command Launcher (hidden by default)

The toolbar and Command Launcher can be separated from and reattached to

the main window (this is known as docking). The grid can be replicated in a

separate window.
Introduction to the Storage Administrator 3
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Figure 1 Main Window

Menu Bar

Toolbar

Object Tree

Grid

Command
Launcher

Status Area

Splitters

(optional)
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The Object Tree and Grid

The Storage Administrator’s main window is divided into two main panes:

• Left Pane (Object Tree)

The left pane contains the object tree, which is a dynamic hierarchical

display of Volume Manager objects and other objects on the system. Each

node in the tree represents a group of objects of the same type. Each object

group has a group icon and a group name.

The following object groups typically appear as nodes in the object tree:

• Disk Groups — All disk groups on the system.

• Disks — All disks on the system.

• Volumes — All volumes on the system.

• Controllers — All controllers on the system.

• Free Disk Pool — Any disks that are under Volume Manager control, but

do not belong to a disk group.

• Uninitialized Disks — Any disks that are not under Volume Manager

control.

• File Systems — All mounted file systems on the system.

You can expand these nodes (by clicking on the plus sign) to reveal the

hierarchy under each node. When you select a group icon (or node) in the

object tree, objects of that type appear in the right pane.

• Right Pane (Grid)

The right pane contains a grid, which is a tabular display of objects and

their properties. The grid displays objects that belong to the group icon that

is currently selected in the object tree (left pane). The grid is dynamic and

constantly updates its contents to reflect changes to objects.

You can sort the contents of a property column in the grid by clicking on the

column heading. You can reverse the sort order by clicking on the column

heading again.

The splitter is the vertical bar that separates the object tree from the grid. You

can resize the left and right panes by pressing and holding the mouse button

over the splitter and dragging the splitter to the left or right.
Introduction to the Storage Administrator 5
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The Menu Bar

The menu bar at the top of the main window contains the following menus:

• Console

The Console menu provides access to the New menu, which creates

volumes, disk groups, or file systems. The Console menu also closes the

main window, provides access to an object Properties window, or exits the

Storage Administrator.

• Options

The Options menu provides access to the Customize window and saves or

loads user preferences. The Customize window displays and sets user

preferences for the components of the Storage Administrator. The Options

menu also removes any alert icons from the status area.

• Window

The Window menu opens (launches) another Storage Administrator main

window, the Task Request Monitor window, the Alert Monitor window, the

Object Search window, a copy of the main grid, or the Command Launcher.

• Selected (context sensitive)

The Selected menu is a context-sensitive menu that launches tasks on a

selected object. The Selected menu is dynamic and changes its options

based on the type of object that is selected. By default, the Selected menu is

greyed out. When an object is selected, the Selected menu is renamed and

provides access to tasks appropriate for the selected object. For example,

Selected becomes Volumes when a volume is selected. The Volumes menu

provides access to volume tasks.

• Help

The Help menu provides access to online help for the Storage

Administrator.
6 VERITAS Volume Manager Storage Administrator Administrator’s Guide
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The Toolbar

The toolbar consists of the following set of buttons:

• Volume Manager Storage Administrator

The Volume Manager Storage Administrator (VMSA) button launches an

additional Storage Administrator main window.

• Task

The Task button launches the Task Request Monitor window. The Task

Request Monitor window displays a list of tasks performed in the current

session. Each task is listed with the user who performed the task, the task

status, and the start and finish times for the task.

• Alert

The Alert button launches the Alert Monitor window. The Alert Monitor

window identifies any objects that have experienced failures or errors and

describes the problem(s). When an object fails or experiences an error, an

alert icon appears in the status area of the main window and/or on the

object’s icon.

• Search

The Search button launches the Object Search window, which is used to

search for objects on the system. The Object Search window contains a set of

tabbed pages, each of which contains search options for a particular type of

object.

• Grid

The Grid button launches a window that contains a copy of the main grid.

The new grid window continues to display and update the objects shown

when the grid copy was created.

• New

The New button launches the New Volume dialog box. This dialog box is

used to create a volume.

• Properties

The Properties (Props) button launches the Object Properties window for a

selected object. The Object Properties window displays detailed information

about the selected object and related objects.
Introduction to the Storage Administrator 7
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• Customize

The Customize (Custm) button launches the Customize window, which is

used to set user preferences. The Customize window allows you to

customize the appearance of the components of the Storage Administrator.

The Customize window contains a set of tabbed pages, each of which

contains preference options for a particular aspect of the Storage

Administrator.

• Save

The Save button saves the current user preference settings for use in future

Storage Administrator sessions.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar

handle to separate the toolbar from the main window or move the toolbar to

the bottom, side, or top of the main window. To reposition the toolbar, press

and hold the mouse button over the toolbar handle and drag the toolbar to its

new location.

The Status Area

The status area is at the bottom of the main window. When an object fails or

experiences some other error, an alert (error) icon appears in the status area.

The Alert Monitor window provides details on the error. You can access the

Alert Monitor window by clicking on the alert icon in the status area.

The Command Launcher

The Command Launcher displays a list of tasks that can be performed on

objects. Each task is listed with the object type, command (action), and a

description of the task. When you click on a task in the Command Launcher

list, the task is launched (started) and the dialog box for the task appears.

The Command Launcher is hidden by default. You can display or hide the

Command Launcher by choosing Window > Command Launcher. You can

separate or attach the Command Launcher and the main window by choosing

Options > Customize > Main Window and clicking Dock Command Launcher.

You can sort the items listed in the Command Launcher by object type,

command, or task description by clicking on the appropriate column heading.

You can reverse the sort order by clicking on the column heading again.
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Storage Administrator Icons
The following table shows icons that appear in the Storage Administrator.

Icon Description

Objects:

disk

free disk

uninitialized disk

foreign disk

offline disk

disk group

deported disk group

shared disk group

volume

root/boot volume

RAID-5 volume
Introduction to the Storage Administrator 9
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plex/mirror

subdisk

controller

disk array

subpath (Dynamic Multipathing)

file system

Accelerator log file system

Accelerator log volume

system/machine

Task Status:

task in progress

successful task

failed task

Icon Description
10 VERITAS Volume Manager Storage Administrator Administrator’s Guide
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paused task

cancelled task

Toolbar:

Volume Manager window

Task Request Monitor window

Alert Monitor window

Search window

Grid Copy window

New Volume dialog box

Object Properties window

Customize window

Save Customization

Icon Description
Introduction to the Storage Administrator 11
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Miscellaneous:

alert

error

information

question

warning

Command Launcher task

customization change

Icon Description
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Task Roadmap
This section provides a summary of common Volume Manager Storage

Administrator tasks. The tasks are grouped into preliminary installation and

setup tasks, ongoing maintenance tasks, and repair or recovery tasks. The

procedures for these and other tasks are included in later chapters.

Setup Tasks

If you are using the Volume Manager and the Storage Administrator for the

first time, you need to install both products, place your disks under Volume

Manager control, and create volumes (and file systems).

▼ To install and set up the Storage Administrator

• Install and initialize the Volume Manager.

• Install the Storage Administrator.

• Start the Storage Administrator.

These tasks are described in Chapter 2, “Getting Started” and the VERITAS
Volume Manager Installation Guide.

▼ To set up disks

• Place uninitialized disks under Volume Manager control.

• Create additional disk groups for the new disks (optional).

• Designate one or more disks as hot-relocation spares (optional).

These tasks are described in Chapter 3, “Disk Tasks.”

▼ To create an alternate boot disk (optional)

• Place the boot (root) disk under Volume Manager control and choose

encapsulation to convert the contents of the disk to volumes.

• Mirror the boot (root) disk to provide an alternate boot disk.

These tasks are described in Chapter 3, “Disk Tasks.”
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▼ To set up volumes and file systems

• Create volumes.

• Place file systems on volumes (optional).

• Create mirrors for any volumes that need to be redundant.

These tasks are described in Chapter 4, “Volume Tasks.”

Maintenance Tasks

After you have set up your disks and volumes, you may need to perform some

or all of the following maintenance tasks.

▼ To monitor objects

• Use the main window’s tree (left pane) and grid (right pane) to view disks,

volumes, file systems, and other objects on the system.

• Use the Volume to Disk Mapping window to view the relationships

between volumes and their underlying disks.

• Use the Volume Layout Details window to display a graphical view of a

volume and its components.

• Use the object Properties window to view detailed information about a

selected object.

• Use the Alert Monitor window to view information about errors or failures

associated with objects that are marked with alert icons.

These windows are described in Chapter 2, “Getting Started.”

▼ To maintain disks

• Place more disks under Volume Manager control, as necessary.

• Create more disk groups, as necessary.

• Upgrade disk groups to the current disk group version.

These tasks are described in Chapter 3, “Disk Tasks.”
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▼ To maintain volumes

• Increase the size of volumes as users require more space.

• Change the layouts of volumes.

• Add mirrors to any unmirrored volumes that should be redundant.

• Create snapshot copies of volumes and then back up the volumes.

• Reorganize the space occupied by volumes (by moving subdisks to other

disks), if necessary.

These tasks are described in Chapter 4, “Volume Tasks.”

▼ To maintain file systems

• Place additional file systems on volumes, as necessary.

• Increase the size of file systems as users require more space.

• Create snapshot copies of vxfs file systems and then back up the file

systems.

These tasks are described in Chapter 4, “Volume Tasks.”

Repair/Recovery Tasks

If disk and/or system failures occur, the Volume Manager may perform any

necessary recovery operations automatically. However, depending on the

circumstances, you may need to attempt to recover from the situation as

follows.

▼ To protect volumes from disk failure

• Evacuate a failing disk.

• Replace a failed disk.

These tasks are described in Chapter 3, “Disk Tasks.”
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▼ To repair/recover volumes

• Recover a volume.

• Recover all volumes on a failed disk.

• Recover all volumes in a disk group.

• If a volume is not recoverable, restore the volume from backup.

These tasks are described in Chapter 3, “Disk Tasks” and Chapter 4, “Volume

Tasks.”

▼ To repair/recover file systems

• Perform a file system consistency check on any file systems that may be

damaged.

These tasks are described in Chapter 4, “Volume Tasks.”
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Getting Started 2
Introduction
This chapter describes how to set up and start using the Volume Manager

Storage Administrator. This chapter focuses on how to use the main

components of the Storage Administrator.

The following topics are discussed in this chapter:

• Installation and Setup

• Starting the Storage Administrator

• Running the Storage Administrator in Read-Only Mode

• Selecting Objects

• Viewing Objects and Object Properties

• Accessing Tasks

• Using Dialog Boxes

• Viewing Commands

• Setting User Preferences

• Searching for Objects or Free Space

• Responding to Alerts

• Exiting the Storage Administrator
17
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Installation and Setup
The VERITAS Volume Manager Storage Administrator consists of a server and

a client. You must install and run the Storage Administrator server on a UNIX

machine running the Volume Manager. You can install and run the Storage

Administrator client on any machine that supports the Java Runtime

Environment.

Before you can use the Volume Manager Storage Administrator, you need to do

the following:

1. Install the VERITAS Volume Manager on the machine to be administered.

Run vxinstall to create the rootdg disk group and initialize at least one

disk.

2. Install the Storage Administrator server and client on the machine to be

administered.

3. If users other than root need to access the Storage Administrator, set up

security to specify which users can run the Storage Administrator.

4. If you plan to run the Storage Administrator client from a Web browser, set

up a HyperText Transfer Protocol (HTTP) server on the machine to be

administered.

5. If you plan to run the Storage Administrator client from a machine other

than the machine to be administered, install the Storage Administrator

client on the machine where the client will run.

6. Start the Storage Administrator server on the machine to be administered.

7. Start the Storage Administrator client.

Refer to the VERITAS Volume Manager Installation Guide for details on how to

install and set up the Volume Manager and Storage Administrator.
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Starting the Storage Administrator
You can run the Volume Manager Storage Administrator as an application or

from a Web browser. Before you start the Storage Administrator, make sure

you have completed the tasks listed in “Installation and Setup.”

Note: Only users with appropriate privileges can run the Storage

Administrator. Refer to the VERITAS Volume Manager Installation Guide for

information on Storage Administrator security and access permissions.

You can use the Storage Administrator to administer the local machine or a

remote machine. The Volume Manager daemon (vxconfigd ) and the Storage

Administrator server must be running on the machine to be administered.

Start the Storage Administrator in one of the following ways:

▼ Starting the Storage Administrator as an application

UNIX

▼ To administer the local UNIX machine, type:

vmsa

Make sure that the Session Initiation dialog box (described in “The Session

Initiation Dialog Box”) contains the local machine name.

▼ To administer a remote UNIX machine, type:

vmsa remote_machine_name

Make sure that the Session Initiation dialog box (described in “The Session

Initiation Dialog Box”) contains a remote machine name.

Windows

▼ To administer a remote UNIX machine, choose Start > Programs >

VERITAS Volume Manager Storage Administrator > VERITAS Volume

Manager Storage Administrator.

Specify the remote machine name in the Session Initiation dialog box

(described in “The Session Initiation Dialog Box”).
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▼ Starting the Storage Administrator from a Web browser

Note: Although you can run the Storage Administrator from a Web browser, it

is recommended that you run it as an application. Due to the nature of Web

browsers, running the Storage Administrator from a Web browser can

significantly slow down response time.

If you want to access the Storage Administrator via a Web browser, you must

set up and run an HTTP server on the machine to be administered. See the

VERITAS Volume Manager Installation Guide for information on how to set up

the HTTP server.

▼ To access the Storage Administrator from a Web browser, start the browser

and then go to the following location (URL):

http:// machine_name/vmsa/index.html

Click on the VERITAS Volume Manager Storage Administrator link in the

browser window. Specify the appropriate machine name in the Session

Initiation dialog box (described in “The Session Initiation Dialog Box”).

Note: Currently, HotJava and Netscape (with Java Development Kit support)

are the only Web browsers that fully support the Storage Administrator. You

can download HotJava from http://www.javasoft.com ; you can download

Netscape from http://www.netscape.com .
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The Session Initiation Dialog Box

At startup, the Storage Administrator displays the Session Initiation dialog

box. To start the Storage Administrator session, complete this dialog box as

follows:

When you have provided all necessary information in the dialog box, click Ok.

The Volume Manager Storage Administrator main window appears.

Note: Entries for your user name and password must exist in the password

file or corresponding NIS (Network Information Name Service) table on the

machine to be administered. Your user name must also be included in the

VERITAS group entry (vrtsadm , by default) in the group file or NIS group

table. If the vrtsadm entry does not exist, only root can run the Storage

Administrator.

Server Host: Type the name of the machine to be administered. Both

the Volume Manager and the Storage Administrator

server must be running on this machine.

User Name: Type your login name. Only users with appropriate

privileges can run the Storage Administrator.

Password: Type your password.
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Running the Storage Administrator in Read-Only Mode
The Storage Administrator server can be run in a read-only mode that is useful

for monitoring or browsing purposes. Read-only mode allows you to view

objects on the system through the Storage Administrator, but prevents

administrative actions from taking effect. This mode is enabled via the

properties file ($VMSAHOME/vmsa/properties ).

▼ To start the Storage Administrator server in read-only mode, edit the

following line in the properties file:

vrts.server.readonly=true

▼ To restore the Storage Administrator server to full operational mode, use

the following line:

vrts.server.readonly=false

Note: You must stop and restart the server (vmsa_server ) for this change to

take effect. Use vmsa_server -k to stop the server.

The default mode for the Storage Administrator is full operational mode.
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Selecting Objects
You can select objects in most Storage Administrator windows in the following

ways:

▼ To select a single object, click on the object. To deselect the object, click on

the object again.

▼ To select/deselect multiple objects, hold down the Control key while

selecting the objects. The objects that you select in this way do not have to

be adjacent.

▼ To select a range of adjacent objects, select the first object and then hold

down the Shift key while selecting the last object in the range. You can also

select multiple adjacent objects by pressing and holding the mouse button

while dragging the pointer over the desired objects.

For information on how to select objects from dialog boxes, refer to “Using

Dialog Boxes.”

Viewing Objects and Object Properties
The Volume Manager Storage Administrator provides the following views of

objects and their properties:

• Tree and Grid View

The main window’s tree and grid view displays volumes, disks, file

systems, and other objects on the system.

• Volume Layout Details Window

The Volume Layout Details window displays a graphical view of a single

volume and its components (mirrors/plexes and subdisks).

• Volume to Disk Mapping Window

The Volume to Disk Mapping window shows the relationships between

volumes and their underlying disks.

• Object Properties Window

The object Properties window contains detailed information about a specific

object.
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This section describes how to use these views to display objects and their

properties.

The Tree and Grid View

The main window’s tree and grid view displays volumes, disks, file systems,

and other objects on the system. The object tree is a hierarchical display of

object groups. The grid is a tabular display of objects and a limited set of

properties. The Storage Administrator constantly monitors objects on the

system and makes appropriate changes to the tree and grid displays. For more

information about this view, see the description of the object tree and grid in

Chapter 1, “Introduction to the Storage Administrator.”

Figure 2 shows how a volume appears in the tree and grid view. The object tree

is in the left pane and the grid is in the right pane.

Figure 2 Tree/Grid View of Volumes

You can view objects in the tree and grid in the following ways:

▼ To expand or collapse the hierarchy under a particular object group node in

the tree, click on the plus sign (+) or minus sign (-) icon next to that node.
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▼ To display the objects in an object group, click on the appropriate object

group in the object tree. All objects that belong to the selected object group

appear in the grid.

Examples:

To display all volumes, click on Volumes in the object tree. All volumes on

the system appear in the grid. Each volume is listed with a set of properties.

To display all volumes in the rootdg disk group, expand the Disk Groups

node (by clicking +), then expand the rootdg node and click on the

Volumes group under rootdg . Only volumes in the rootdg disk group

appear in the grid.

▼ To display the objects in an object group that is listed in the grid, double-

click on the object group in the grid. All objects that belong to the object

group appear in the grid.

Example:

To display the volumes in a disk group listed in the grid, go to the grid and

double-click on the disk group name, then double-click on Volumes. All

volumes in the disk group appear in the grid.

Note that double-clicking on an object that does not contain other objects

(children) displays the object’s Properties window instead of its children.

▼ To sort the objects in the grid by a specific property, click on the appropriate

property column heading. To reverse the sort order, click on the column

heading again.

Example:

To sort volumes by size, click on the Size column heading in the grid.

▼ To resize a grid column, place the pointer over the line that divides the

column headings and then press and hold the mouse button to drag the

column divider to the desired position.

▼ To make a copy of the contents of the grid, choose Window > Copy Main

Grid. A copy of the grid appears in a separate window. The new grid

window continues to display and update the objects that were shown when

you created the grid copy. You can create multiple copies of the grid and

use these grid windows to display different sets of objects. For example,

you can display volumes in one grid window and disks in another.
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The Volume Layout Details Window

The Volume Layout Details window displays a graphical view of the selected

volume’s layout, components, and properties. You can select objects or perform

tasks on objects in the Volume Layout Details window. The Volume Layout

Details window is not dynamic, so the objects displayed in this window are not

automatically updated when the volume’s properties change.

The View menu changes the contents of the Volume Layout Details window.

The context-sensitive Selected menu accesses tasks or properties for a selected

object. Context-sensitive popup menus are also accessible in this window (by

right-clicking on an object).

Figure 3 shows how a volume appears in the Volume Layout Details view.

Figure 3 Volume Layout Details Window

You can view objects in the Volume Layout Details view in the following ways:

▼ To display the Volume Layout Details window for a volume, click on the

volume (in the main window grid) and then choose Volumes (Selected

menu) > Show Layout.

▼ To update (refresh) the graphical view to show any recent changes to the

current volume, choose View > Update. The Volume Layout Details

window does not update object properties automatically.

▼ To view a different volume, choose View > Open and then specify another

volume in the Open Volume dialog box.
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▼ To hide the detailed information within each object, choose View >

Compress Display. To show details for a particular object in the compressed

display, click on that object.

▼ To highlight objects that are related to or part of a specific object, choose

View > Projection On Selection and then click on an object. To highlight any

subdisks on the same disk as a specific subdisk, choose View >

Subdisk Projection and then click on a subdisk.

The Volume to Disk Mapping Window

The Volume to Disk Mapping window displays a tabular view of volumes and

their underlying disks. Volumes are listed in the top row of the table and disks

are listed in the left column of the table. Each circle in the table indicates that

part of the corresponding volume is located on the corresponding disk.

This window can also display details such as the subdisks and gaps on each

disk. Each subdisk or gap is listed with its disk offset and length. When

subdisks are shown, circles show the relationship between volumes and

subdisks.

The Volume to Disk Mapping window is dynamic, so the contents of this

window are automatically updated when objects are added, removed, or

changed.

Figure 4 shows how the relationships between volumes and disks are shown in

the Volume to Disk Mapping window.
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Figure 4 Volume to Disk Mapping Window

You can view volumes and their associated disks in the following ways:

▼ To display the Volume to Disk Mapping window for all volumes in a disk

group, click on the disk group (in the main window grid) and then choose

Disk Groups (Selected menu) > Disk/Volume Map.

▼ To display all of the subdisks and gaps on a particular disk, click the arrow

to the left of the disk name. Any subdisks and gaps are listed below the

disk name. To hide the subdisks and gaps, click the arrow again.

▼ To highlight a disk row, click on the disk name. To highlight a volume

column, click on the volume name. To highlight both the disk and volume

associated with a particular circle, click on the circle.
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The Object Properties Window

The object Properties window contains detailed information about the selected

object. Some object properties can be changed through the object’s Properties

window. The Properties window contains a set of tabbed pages, each of which

contains information about the object and related objects. The tab labels and

page contents vary, depending on the type of object selected. You can display a

different page by clicking on the tab label.

Figure 5 shows how a volume appears in the Volume Properties window.

Figure 5 Volume Properties Window
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You can view object properties in the following ways:

▼ To view the properties of an object, click on the object (in the main window

grid) and then choose Properties from the Selected or popup menu. You can

also access the Properties window by double-clicking on the object.

Example:

To display volume properties, either click on a volume and then choose

Volumes > Properties or double-click on a volume.

Note that double-clicking on an object that has children displays the object’s

children instead of the Properties window.

▼ To change any of the editable items in the Properties window, make the

appropriate changes and then click Ok. This changes the settings for all
properties tabs in the Properties window.

▼ To update the contents of the Properties window to reflect current

properties for the object, click Refresh.
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Accessing Tasks
Most Volume Manager Storage Administrator tasks are performed by selecting

objects and/or tasks and then completing the resulting dialog boxes. With the

Storage Administrator, you can access tasks from the following:

• the menu bar

• a context-sensitive popup menu

• the Command Launcher

This section describes how to run tasks from menus and the Command

Launcher.

Running Tasks From the Menu Bar

You can launch tasks from the Console and Selected menus in the menu bar.

The Console > New menu creates new Volume Manager objects (volumes and

disk groups) and file systems. The context-sensitive Selected menu launches

tasks on a selected object. The Selected menu is dynamic and changes its name

and options based on the type of object that is selected in the tree or grid.

Figure 6 Menu Bar

▼ To create a new object, choose the type of object to be created from the

Console > New menu. This launches a dialog box.

Example:

To create a volume, choose Console > New > Volume. Complete the New

Volume dialog box, then click Ok.

▼ To perform a task on an object with the Selected menu, select the object and

choose the appropriate task from the Selected menu. If this launches a

dialog box, complete the dialog box.
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Example:

To change a volume’s name, select the volume in the grid. Choose

Volumes > Rename from the Selected menu. Type the volume’s new name

in the Rename Volume dialog box, then click Ok.

Running Tasks From a Popup Menu

A context-sensitive popup menu launches tasks on the selected object. Popup

menus do not contain all of the tasks that can be applied to the selected object;

additional tasks are available through the menu bar or the Command

Launcher.

Figure 7 Context-Sensitive Popup Menu

▼ To perform a task on an object with the popup menu, right-click on the

object and choose the appropriate task in the popup menu. If this launches

a dialog box, complete the dialog box.
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Running Tasks From the Command Launcher

The Command Launcher window launches tasks from a list of objects and

associated Volume Manager Storage Administrator tasks. The Command

Launcher lists each task with an object type and a task description.

The Command Launcher can be displayed as part of the main window

(docked) or as a separate window. The Command Launcher can also be

hidden. When the Command Launcher is attached to the main window, tasks

are context sensitive. However, tasks are not context sensitive when the

Command Launcher is separated from the main window.

The View menu attaches (docks) the Command Launcher to the main window

and closes the Command Launcher window.

Figure 8 The Command Launcher

▼ To display the Command Launcher, choose Window > Command Launcher

(from the main window). To hide the Command Launcher, choose

Window > Command Launcher again. You can also show or hide the

Command Launcher by choosing Options > Customize > Main Window

and clicking Show Command Launcher.
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▼ To perform a task on a specific type of object, select the appropriate

object-task combination from the Command Launcher list.

Example:

To add a disk, choose Disk Add from the Command Launcher list.

Complete the Add Disk dialog box.

▼ To sort the items listed in the Command Launcher by object type,

command, or task description, click on the appropriate column heading.

To reverse the sort order in a column, click on the column heading again.

▼ To separate or attach (dock) the Command Launcher and the main window,

choose Options > Customize > Main Window and click Dock Command

Launcher.

▼ To adjust the height of the Command Launcher when it is attached to the

main window, choose Options > Customize > Main Window and specify

the new height (in pixels) in the Docked Command Launcher Height field.
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Using Dialog Boxes
The Volume Manager Storage Administrator uses dialog boxes to communicate

with the administrator. Administrators typically use dialog boxes to submit

tasks or other requests. Dialog boxes can contain selectable buttons and/or

fields that accept information. Some dialog box fields contain default values

that can be changed. Items that are not applicable are greyed out.

▼ To use a dialog box, select the appropriate items and/or type the

appropriate information and then click one of the following buttons to

initiate or cancel the task/request:

Specifying Objects in Dialog Boxes

Most Storage Administrator dialog boxes contain one or more object name

fields. If you select an object before you select the task, the resulting dialog box

may include the selected object’s name. If the object name field is empty, you

can specify an object in one of these ways:

• Type the object’s name.

• Click the Browse button next to the object name field and then select the

object from the resulting browse dialog box. Most browse dialog boxes

consist of a tree (left pane) and grid (right pane). To select an object in a

browse dialog box, click on the appropriate object group in the tree and

then click on the desired object in the grid. Figure 9 shows a sample browse

dialog box.

Ok Perform the current task/request and close the dialog box.

Apply Perform the current task/request and continue to display

the dialog box.

Cancel Close the dialog box and cancel the current task/request.

(If you have already clicked Apply, this does not cancel the

task that is in progress.)
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Figure 9 Browse Dialog Box

In some cases, you can specify multiple objects (separated by white space) in a

single field. To select multiple objects from a browse dialog box, hold down the

Control key and click on each object. To select a range of adjacent objects, select

the first object and then hold down the Shift key while selecting the last object

in the range.

Specifying Disks and Disk Groups in Dialog Boxes

You can specify the object’s disk group by preceding the object name with the

disk group name (diskgroup_name/ object_name). The disk group name is

required if there are multiple objects with the same name (in different disk

groups) on the system.

Disks in disk groups have two names:

device name The physical disk device name (or disk access name).

disk name The Volume Manager disk name (or disk media name). This is the

logical name given to the disk by the Volume Manager or the

administrator.

Some dialog box fields require the device name and others require the Volume

Manager disk name.
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Specifying Object Sizes in Dialog Boxes

When you type the size of an object in an input field, you can specify sectors,

kilobytes, megabytes, or gigabytes by appending an s , k , m, or g to the size. If

you do not specify a size unit, the size defaults to sectors.

Viewing Commands
The Volume Manager Storage Administrator logs all user requests performed

by the Storage Administrator. You can view the Storage Administrator task

history in either of these locations:

• The Task Request Monitor Window

• The Command Log File

This section describes how to use the Task Request Monitor window and the

command log file to view information about completed tasks and tasks in

progress.

The Task Request Monitor Window

The Task Request Monitor window displays a history of tasks performed in the

current session (and any other sessions running on the machine). Each task is

listed with properties such as the user who performed the task, the task status,

and the start/finish times.

The View menu removes finished tasks and closes the window. The Tasks

menu accesses task properties. Context-sensitive popup menus are also

accessible in the Task Request Monitor window (by right-clicking on a task).
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Figure 10 Task Request Monitor

▼ To display the Task Request Monitor, click on the Task button (in the

toolbar) or choose Window > Tasks from the main window.

▼ To cancel a selected task, choose Tasks > Abort. To temporarily stop a task,

choose Tasks > Pause. To continue a task, choose Tasks > Resume.

▼ To sort the tasks by task type, click on the Task heading. To sort the tasks by

property, click on the appropriate property column heading. To reverse the

sort order, click on the column heading again.

▼ To view task properties and the low-level command(s) used to perform a

task, click on the task and choose Tasks > Properties. You can also access

task properties by double-clicking on the task.

▼ To remove completed tasks from the window, choose Console > Remove

Finished Tasks.
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The Task Properties window shows the Volume Manager and other commands

that the Storage Administrator used to perform a given task. You can copy

commands from the Executed Commands field to the command line or a script

file. For failed tasks, the Task Properties window includes any relevant error

messages.

Figure 11 Task Properties Window
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The Command Log File

The command log file contains a history of Volume Manager Storage

Administrator tasks performed in the current session and previous sessions. By

default, the command log is located in /var/opt/vmsa/logs/command on

the server. The command log file contains a description of each task, along

with properties such as the user who performed the task, the task status, the

start/finish times, and the low-level commands used to perform the task. For

failed tasks, the command log includes any relevant error messages.

The following example shows some sample command log file entries:

Create Volume

Description: Create Volume

User: root

Started: Thu Aug 06 12:07:22 PDT 1998

Finished: Thu Aug 06 12:07:24 PDT 1998

State: Successful

Executed Commands:

        /usr/sbin/vxassist -g rootdg make vol04 4m layout=striped
stripeunit=128 ncolumn=2

Create Volume FAILED!

Description: Create Volume

User: root

Started: Thu Aug 06 12:07:50 PDT 1998

Finished: Thu Aug 06 12:07:51 PDT 1998

State: Failed

Executed Commands:

/usr/sbin/vxassist -g rootdg make vol05 8g layout=striped
stripeunit=128 ncolumn=2

Failed Command: /usr/sbin/vxassist  -g rootdg   make vol05 8g
layout=striped stripeunit=128 ncolumn=2

Error Message: vxvm:vxassist: ERROR: Cannot allocate space for
16777216 block volume
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Setting User Preferences
You can change the way items appear in the main window and other Storage

Administrator windows. This section describes how to use the Customize

window and preference shortcuts to customize the way the Storage

Administrator appears.

The Customize Window

The Customize window allows you to specify your preferences for how you

would like to view the components of the Storage Administrator. The

Customize window contains a set of tabbed pages, each of which contains

preference options for a particular aspect of the Storage Administrator. You can

display a different page by clicking on the tab label.

Figure 12 Customize Window
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▼ To display the Customize window, choose Options > Customize from the

main window menu bar.

▼ To change preference settings, make the appropriate selections in the

Customize window, then click Ok. This changes the settings for all tabs in

the Customize window. To reset the settings to the previous settings, click

Reset (before you click Ok).

When you change preference settings, the customization change icon

appears in the tab label of the tab that contains changes. This icon

disappears when you click Ok, Apply, or Reset.

▼ To save your preference settings and apply them to future Storage

Administrator sessions, choose Options > Save Customization. You can also

save your preference settings by clicking the Save button in the toolbar or

the customization change icon in the status area.

If the auto-save preference (Auto-Save Preferences on Exit) is set, the

Storage Administrator will save all of your preference settings when you

exit the Storage Administrator session.

When running as an application, the Storage Administrator saves user

preferences in user’s_home_directory/.vmsa/VMpreference.prf on the

machine where the client is running. When running from a Web browser,

the Storage Administrator saves user preferences in

/var/opt/vmsa/ user_name/preferences on the machine where the

server is running.

▼ To reload your previously saved preferences, choose Options > Load

Customization.
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The Customize window contains the following preference tabs:

• General

• Main Window

• Font

• Color

• Geometry

• Tree/Grid

• Toolbar

• Layout Details

The following sections summarize the preference settings available in each of

these tabs.
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General

Set the following general preferences:

Select Text in Field on

Enter

Set user input to replace mode. This highlights

any existing text in a field and replaces that text

with the new text.

Show Confirmation

Dialogs

Show/hide confirmation dialogs for tasks that

may have serious consequences (such as data

loss). Confirmation dialogs require users to

confirm that a task should be performed.

Confirmation dialogs typically appear for tasks

that remove objects.

Note: If you hide confirmation dialogs, most

tasks are performed immediately and without

any form of confirmation.

Auto-Save Preferences

on Exit

Save all current user preferences when the user

exits the Storage Administrator via Console >

Exit.

Flush Images Draw images slightly slower than usual to

prevent the X server from growing. This is

recommended if you plan to leave the Storage

Administrator running for long periods of time.

Dynamic Splitter Redraw the contents of the window panes while

the splitter is being moved to resize the panes.

Default Display Unit Set the default size unit for areas that display

object sizes. If Best Choice is set, the Storage

Administrator uses an appropriate size unit.

Summary Decimal

Precision

Set the decimal point precision for object sizes

displayed in the grid and other areas that

display summaries.

Task Decimal Precision Set the decimal point precision for object sizes

displayed in task-related dialog boxes and areas

that display detailed information.
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Main Window

Set the following preferences for the main window:

Font

Set the font size, family, and style for the following:

Show Status Bar Show/hide the status bar area (at the bottom of

the main window). The status bar displays alert

icons when failures or errors occur.

Show Command

Launcher

Show/hide the Command Launcher. The

Command Launcher contains a list of selectable

tasks.

Dock Command

Launcher

Attach/detach the Command Launcher and the

main window.

Docked Command

Launcher Height

Set the height of the Command Launcher

portion of the main window.

User Font Set the font for user input and objects displayed

in the tree and grid.

System Font Set the font for labels, menus, buttons, and

other items displayed by the Storage

Administrator.

Grid Heading Font Set the font for grid headings.

Grid Heading Highlight

Font

Set the font for grid headings that are

highlighted for sorting purposes.

Toolbar Font Set the font for the toolbar buttons.

Graphical Display Font Set the font for objects in the Volume Layout

Details window.
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▼ To access the Font Selector, click Change. Change the font size by sliding the

Size slider. Use the Family and Style menu to change the font family and

style.

Color

Set the following preferences for colors:

▼ To access the Color Selector, click Change. Change colors by clicking on a

color in the color wheel or sliding the Red, Green, Blue, and Brightness

sliders to the appropriate positions.

Background Color Set the background color for all Storage

Administrator windows.

Foreground Color Set the color for foreground text in Storage

Administrator windows.

Tree/Grid Color Set the background color for the tree and grid.

Connecting Line Color Set the color for the lines that connect items in

the tree.

Selection Color Set the color for selected items.

Selection Foreground

Color

Set the color for foreground text in selected

items.

Link Color Set the color for links (such as the links to tasks

in the Command Launcher).

Projection Color Set the color for the lines that show object

relationships in the Volume Layout Details

window.
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Geometry

Set the width and height (in pixels) for the following windows:

• Main Window

• Object Search Window

• Alert Monitor Window

• Task Request Monitor Window

• Volume Layout Details Window

• Command Launcher Window

• Grid Copy Window

If you resize one of these windows via your window manager, the Geometry

preference for that window changes to the new size automatically.

Tree/Grid

Set the following tree and grid preferences:

Display Full Path Display path information in the tree and grid.

Auto Scroll Grid When an object is added or changed, scroll

through the objects until the new/changed

object is visible in the grid.

Splitter Position Move the splitter to adjust the relative sizes of

the tree and grid panes.

Selector Tree/Grid

Width

Set the width (in pixels) of the tree and grid in

browse dialog boxes that contain a tree and a

grid.

Selector Grid Width Set the width (in pixels) of the grid in browse

dialog boxes that contain a grid only.

Visible Selector Rows Set the number of rows displayed in the tree

and grid in browse dialog boxes.
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Toolbar

Set the following preferences for the toolbar:

Layout Details

Set the following preferences for the Volume Layout Details window:

Show Toolbar Show/hide the toolbar.

Position Place the docked toolbar at the top, bottom, or

side of the main window.

Presentation Display icons and/or labels on the buttons in

the toolbar.

Compress Display Compress the graphical display of objects so

that details are hidden.

Projection on Selection When an object is selected, highlight objects that

are related to or part of that object.

Subdisk Projection When a subdisk is selected, highlight other

subdisks on the same disk.
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Preference Shortcuts

▼ To resize the left (tree) and right (grid) panes, place the pointer over the

vertical splitter and then press and hold the mouse button to drag the

splitter to the desired position. (This changes the Splitter Position setting in

the Tree/Grid preference tab.)

▼ To resize a grid column, place the pointer over the line that divides the

column headings and then press and hold the mouse button to drag the

column divider to the desired position. The column widths cannot be saved

with other user preferences.

▼ To sort the objects in a grid column, click on the column heading of the

object property to be sorted. To reverse the order of the objects, click on the

column heading again. The sort order cannot be saved with other user

preferences.

▼ To acknowledge and clear an alert icon displayed in the status area, choose

Options > Clear Alert Status.

▼ To separate the toolbar from the main window, place the pointer over the

toolbar handle (the thin bar next to the toolbar), press and hold the mouse

button, and drag the toolbar outside the main window. You can also use the

toolbar handle to move the toolbar to the bottom, side, or top of the main

window.

▼ To show or hide the Command Launcher, choose Window > Command

Launcher.

▼ To adjust the height of the Command Launcher when it is attached to the

main window, place the pointer over the horizontal splitter and then press

and hold the mouse button to drag the splitter to the desired position.

(This changes the Docked Command Launcher Height setting in the Main

Window preference tab.)
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Searching for Objects or Free Space
The Search window searches the system for objects that match the specified

search criteria. The Search window contains a set of tabbed pages, each of

which contains search options for a particular type of object. You can display a

different page by clicking on the tab label.

Any objects that match the search criteria are listed in the grid in the lower half

of the search window, along with their properties. Objects displayed in the

search window are monitored and removed from the window if they no longer

meet the current search criteria.

The Search window has menus similar to those in the main menu. The

Window menu opens other windows or a copy of the current search results

grid. The context-sensitive Selected menu accesses tasks or properties for a

selected object in the search results grid. Context-sensitive popup menus are

also accessible in the lower half of the Search window (by right-clicking on an

object). The Console menu closes the search window.
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Figure 13 Object Search Window

▼ To display the Search window, click the Search button in the toolbar or

choose Window > Search.

▼ To begin a search, enter your search criteria and then click Search Now.

▼ To sort the objects in the search results grid by name or property, click on

the appropriate column heading. To reverse the sort order, click on the

column heading again.

▼ To view the properties of an object listed in the search results grid, select the

object and choose Properties from the Selected or popup menu. You can

also access object properties by double-clicking on the object.

▼ To open a window that contains a copy of the current search results grid,

choose Window > Copy Search Grid. To open another Search window,

choose Window > Search.
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Responding to Alerts
When an object fails or experiences an error, an alert icon appears in the status

area of the main window and/or on the object’s icon (see Figure 14). If an alert

icon appears, you should review the contents of the Alert Monitor window.

The Alert Monitor window lists information about objects that have failed or

experienced other errors (see Figure 15). Each object is listed with a description

of the failure or error.

The Alert menu accesses properties for objects with alerts and closes the

window. Context-sensitive popup menus are also accessible in the Alert

Monitor window (by right-clicking on an object).

After reviewing the alert(s) in the Alert Monitor window, you should try to

correct the problem. For more information about an object listed in the Alert

Monitor window, go to the object’s Properties window.

Figure 14 Alerts for a Volume

alerts
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Figure 15 Alert Monitor Window

▼ To display the Alert Monitor window, click the Alert button in the toolbar

or choose Window > Alerts. You can also access the Alert Monitor window

by clicking on the alert icon in the status area.

▼ To sort alerts by object or description, click on the appropriate column

heading. To reverse the sort order, click on the column heading again.

▼ To view the properties of an object with an alert, select the object and

choose Object Properties from the Alert or popup menu. You can also access

object properties by double-clicking on the object.

Exiting the Storage Administrator
▼ To exit the Volume Manager Storage Administrator client, choose Console >

Exit.
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Disk Tasks 3
Introduction
This chapter describes how to set up and use disks and disk groups with the

Volume Manager Storage Administrator. The Disk Task Roadmap at the

beginning of this chapter contains a summary of common disk and disk group

tasks.

The following disk tasks are discussed in this chapter:

• Adding a Disk to the Volume Manager

• Designating a Disk as a Hot-Relocation Spare

• Reserving a Disk

• Renaming a Disk

• Offlining a Disk

• Onlining a Disk

• Mirroring a Disk

• Evacuating a Disk

• Replacing a Disk

• Recovering Volumes on a Disk

• Removing a Disk
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The following disk group tasks are discussed in this chapter:

• Creating a Disk Group

• Upgrading a Disk Group

• Renaming a Disk Group

• Deporting a Disk Group

• Importing a Disk Group

• Recovering Volumes in a Disk Group

• Destroying a Disk Group

• Moving a Disk Group
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Disk Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator disk and disk group tasks.

To do this... Use this procedure...

Disk Setup Tasks:

Place new disk(s) under Volume Manager

control

Adding a Disk to the Volume Manager

Set up new disk group(s) Creating a Disk Group

Precautionary Tasks:

Add disk(s) as hot-relocation spare(s) Designating a Disk as a Hot-Relocation

Spare

Place the boot (root) disk under Volume

Manager control

Make an alternate boot (root) disk

Adding a Disk to the Volume Manager

Mirroring a Disk

Maintenance Tasks:

Place additional disks under Volume

Manager control

Adding a Disk to the Volume Manager

Add more disk space to a disk group Adding a Disk to the Volume Manager

Create additional disk groups Creating a Disk Group

Upgrade a disk group Upgrading a Disk Group

Recovery Tasks:

Move volumes off failing disks Evacuating a Disk

Replace failed disk(s) Replacing a Disk
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Attempt to recover all volumes on a disk Recovering Volumes on a Disk

Attempt to recover all volumes in a disk

group

Recovering Volumes in a Disk Group

Other Tasks:

Change a disk’s name Renaming a Disk

Change a disk group’s name Renaming a Disk Group

Temporarily prevent access to a disk Offlining a Disk

Restore access to an offline disk Onlining a Disk

Temporarily prevent access to a disk group Deporting a Disk Group

Restore access to a deported disk group Importing a Disk Group

Remove a disk from Volume Manager

control

Removing a Disk

Move a disk group to another system Moving a Disk Group

Destroy a disk group (permanently) Destroying a Disk Group

To do this... Use this procedure...
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Adding a Disk to the Volume Manager
New disks must be set up on the system, placed under Volume Manager

control, and added to a disk group before they can be used for volumes. The

add disk(s) task performs all of these tasks to prepare new disks for Volume

Manager use. You can also use this task to place the root disk under Volume

Manager control or to add a disk to a disk group.

This task assigns a default Volume Manager disk name to the disk. Once the

disk is under Volume Manager control, you can use the Rename Disk task to

change the Volume Manager disk name (see “Renaming a Disk”).

▼ To add a disk to the Volume Manager

1. If the disk is brand new, select the Volume Manager node (at the top of the

tree) and choose System > Scan Disks (Selected menu) to set up the disk on

the system. This runs the disk setup commands appropriate for the

operating system.

2. Select the uninitialized disk to be placed under Volume Manager control.

3. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

4. Complete the Add Disk(s) dialog box as follows:

Disk Device(s): If the correct disk (device) name is not already

displayed in this field, type the disk’s device name

or click Browse to select the disk.

Add Disk(s) to: Specify where the disk(s) should be placed:

• To add the disk(s) to an existing disk group, select

Existing Disk Group. Type the disk group name in

the Disk Group Name field or click Browse to select

a disk group.

• To add the disk(s) to a new disk group, select New

Disk Group. Type the name of the new disk group

in the Disk Group Name field. The new disk group

will be created for the new disk.
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When you have provided all necessary information in the dialog box, click

Ok.

5. Indicate whether the disk should be initialized or encapsulated. If you

initialize the disk, any existing data on the disk will be destroyed. If you

encapsulate the disk, any existing data will be preserved in volumes.

6. If you chose to encapsulate the disk, reboot the system.

• To place the disk(s) in the free disk pool, select Free

Disk Pool. Disks in the free disk pool are under

Volume Manager control, but do not belong to a

disk group and cannot be used to create volumes.

Options: • To set up any new disks on the system, click Scan

Disks. This runs the disk setup commands

appropriate for the operating system.

• To create a shared disk group for the disk(s), select

New Disk Group and Create Shared. The Create

Shared option is only applicable in a cluster

environment.

• To specify the Volume Manager disk name for the

disk, type a disk name in the Disk Name(s) field.

If no Volume Manager disk name is specified, the

Volume Manager assigns a default name to the

disk.

• To apply a comment attribute to disks that are

placed in a disk group, type the information in the

Comment field.
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▼ To place the root disk under Volume Manager control

1. Select the root (boot) disk.

2. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

4. Indicate that the root disk should be encapsulated. When you encapsulate the

disk, any existing data will be preserved in volumes.

5. Reboot the system.

Disk Device(s): If the correct disk (device) name is not already

displayed in this field, type the root disk’s name or

click Browse to select the disk.

Add Disk(s) to: Specify that the root disk should be placed in the

root disk group. Select Existing Disk Group. Type

the root disk group name (rootdg ) in the Disk

Group Name field.
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▼ To add a disk to a disk group

1. Go to the free disk pool and select the disk to be added to a disk group.

2. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Device(s): If the correct disk (device) name is not already

displayed in this field, type the disk’s name or click

Browse to select the disk.

Add Disk(s) to: Specify where the disk(s) should be placed:

• To add the disk(s) to an existing disk group, select

Existing Disk Group. Type the disk group name in

the Disk Group Name field or click Browse to select

a disk group.

• To add the disk(s) to a new disk group, select New

Disk Group. Type the name of the new disk group

in the Disk Group Name field. The new disk group

will be created for the new disk.

Options: • To create a shared disk group for the disk(s), select

New Disk Group and Create Shared. The Create

Shared option is only applicable in a cluster

environment.

• To specify the Volume Manager disk name for the

disk, type a disk name in the Disk Name(s) field.

If no Volume Manager disk name is specified, the

Volume Manager assigns a default name to the

disk.

• To apply a comment attribute to the disk, type the

information in the Comment field.
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Notes:

• This task requires a disk device name and the location for the new disk (that

is, a disk group or the free space pool).

• This task sets up disks for Volume Manager use. Disks must be under

Volume Manager control and in a disk group before they can be used to

create volumes.

• When a disk is placed under Volume Manager control, the disk is either

initialized or encapsulated. Encapsulation preserves any existing data on the

disk in the form of volumes. Initialization destroys any existing data on the

disk. Encapsulation is recommended for the root/boot disk and any other

disks that contain valuable data.

• Disk encapsulation requires a system reboot.

• Disks in the free disk pool need to be added to a disk group before they can

be used to create volumes.

• Disks must be online before they can be added to a disk group or the free

disk pool.

• Disks that already belong to a disk group cannot be added to another disk

group or placed in the free disk pool.

• Disks cannot be added to deported disk groups.

• The root disk must be placed in the root disk group (rootdg ). If the root disk

is placed in any other disk group, the root disk cannot be used to boot the

system.

• After placing the root disk under Volume Manager control, it is

recommended that you create an alternate boot disk by mirroring the root

disk (see “Mirroring a Disk”).

• The Volume Manager disk name must be unique within the disk group.

• If multiple disks are specified in the Disk Device(s) field and only one disk

name is specified in Disk Name(s) field, the Volume Manager appends

numbers to the disk name so that each disk name is unique within its disk

group.
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Designating a Disk as a Hot-Relocation Spare
This procedure adds a disk to the pool of spare disks available to the hot-

relocation feature. If an I/O failure occurs, hot-relocation automatically

relocates any redundant (mirrored or RAID-5) subdisks to spare disks and

restores the affected Volume Manager objects and data. The system

administrator is notified of the failure and relocation details via electronic mail.

After successful relocation, you may want to replace the failed disk (see

“Replacing a Disk”).

▼ To designate a disk as a hot-relocation spare

1. Follow the instructions in “Adding a Disk to the Volume Manager” to place

the disk under Volume Manager control and in a disk group.

2. Select the disk to be designated as a hot-relocation spare.

3. Choose Disks > Properties (Selected menu).

4. In the Disk Properties window, go to the General tab and select Spare. Click

Ok.

If you decide that you want to remove the disk from the pool of hot-relocation

spares, open the Disk Properties window and click Spare again.

Notes:

• The disk must be under Volume Manager control and in a disk group.

• Any disk in the same disk group can use the spare disk.

• To make sure that sufficient space is available for relocation, try to provide at

least one hot-relocation spare disk per disk group.
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Reserving a Disk
This procedure designates a disk as a reserved disk. A reserved disk is not

considered part of the free space pool. If you perform a task that requires disk

space and you do not specify a disk, the Storage Administrator allocates space

from disks other than the reserved disk.

▼ To reserve a disk

1. Follow the instructions in “Adding a Disk to the Volume Manager” to place

the disk under Volume Manager control and in a disk group.

2. Select the disk to be reserved.

3. Choose Disks > Properties (Selected menu).

4. In the Disk Properties window, go to the General tab and select Reserve.

Click Ok.

If you decide that you want to return a reserved disk to the free space pool,

open the Disk Properties window and click Reserve again.

Notes:

• A reserved disk does not belong to the free space pool and is not available

for general use.

• A reserved disk can only be used if you specify the reserved disk when you

perform a task.
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Renaming a Disk
This procedure changes the Volume Manager name assigned to a disk. The

Volume Manager disk name is the name given to the disk by the administrator

or the Volume Manager. This procedure does not change the physical disk

name (device name).

▼ To rename a disk

1. Select the disk to be renamed.

2. Choose Disks > Rename (Selected menu) or Disk Rename (Command

Launcher).

3. Complete the Rename Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Name: If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

New Name: Type the new Volume Manager disk name.

Notes:

• This task requires the current disk name and a new disk name.

• The new disk name must be unique within the disk group.

• The disk must be in an imported disk group.
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Offlining a Disk
This procedure prevents the Volume Manager from accessing a disk. A disk

must be removed from its disk group before it can be taken offline (see

“Removing a Disk”). An offline disk remains unavailable until you restore

access to the disk (see “Onlining a Disk”).

▼ To take a disk offline

1. Select the disk to be taken offline.

2. Choose Disks > Offline (Selected menu) or Disk Offline (Command

Launcher).

3. Complete the Offline Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk(s): If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

Notes:

• When a disk is offline, the disk cannot be accessed by the Volume Manager.

• A disk can be taken offline to protect it from unintentional use. Disks should

be taken offline if they are not accessible and attempts to access them may

have a negative effect on the system.

• Only disks that do not belong to a disk group can be taken offline.

• Disks that are in use cannot be taken offline.
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Onlining a Disk
This procedure restores access to a disk that has been taken offline. The disk is

placed in the free disk pool and is accessible to the Volume Manager again.

After bringing a disk back online, the disk must be added to a disk group

before it can be used for volumes (see “Adding a Disk to the Volume

Manager”).

▼ To bring a disk online

1. Select the disk to be brought online.

2. Choose Disks > Online (Selected menu) or Disk Online (Command

Launcher).

3. Complete the Online Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk(s): If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

Notes:

• When a disk is brought online, the disk is accessible again.

• Only disks in the offline state can be brought online.
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Mirroring a Disk
This procedure mirrors (copies) all concatenated volumes on a disk onto

another disk and sets up the target disk as a boot disk. This is a convenient

way of creating an alternate boot (root) disk, which can be used to boot the

system if the original boot disk fails. You can use this procedure to mirror any

disk that contains concatenated volumes.

▼ To mirror all concatenated volumes on a disk

1. Select the disk that contains the concatenated volumes to be mirrored onto

another disk.

2. Choose Disks > Mirror (Selected menu) or Disk Mirror (Command

Launcher).

3. Complete the Mirror Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Name: If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

Options: To specify the disk to contain the new mirrors, click

the Browse button next to the Target Disk(s) field

and select a disk.
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Notes:

• This task requires a disk name.

• This task is typically used to mirror the contents of the boot disk onto another

disk, which can be used as an alternate boot disk. After mirroring the root

and swap volumes (which must be named rootvol  and swapvol ,

respectively), this task sets up the target disk as a boot disk.

• Only concatenated volumes that reside on a single disk are mirrored onto the

other disk. Any RAID-5, striped, or spanned volumes on the disk are

ignored.

• Only disks in the same disk group can be used to create the new mirrors.

• The target disk must contain sufficient space to accommodate the mirror(s).

• A new mirror cannot be created on a disk that already contains a copy of the

volume.

• If no disks are assigned, the Volume Manager uses available disk space to

create the mirror(s).
70 VERITAS Volume Manager Storage Administrator Administrator’s Guide



3

Evacuating a Disk
This procedure moves the contents of the volumes on a disk to another disk. If

a disk begins to fail, you can attempt to protect/preserve the volumes on that

disk by evacuating the disk. You can also evacuate a disk if you plan to remove

the disk or use the disk elsewhere.

▼ To evacuate a disk

1. Select the disk that contains the objects and data to be moved to another

disk.

2. Choose Disks > Evacuate (Selected menu) or Disk Evacuate (Command

Launcher).

3. Complete the Evacuate Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Name: If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

Options: To specify the disk(s) to which the contents of the

evacuated disk should be moved, click the Browse

button next to the Target Disk(s) field and select a

disk.
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Notes:

• This task requires a disk name.

• The contents of a disk must be evacuated/moved to another disk(s) in the

same disk group with sufficient free space.

• If no target disk is specified, the Volume Manager will use an available

disk(s) with sufficient free space.

• If the disk being evacuated contains part of a mirrored, striped, or RAID-5

volume, the contents of the disk should not be moved to another disk

containing a copy of the mirrored volume or part of the striped/RAID-5

volume.
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Replacing a Disk
This procedure replaces an existing disk with a new physical disk, moves any

volumes to the new disk, and attempts to recover any redundant (mirrored or

RAID-5) volumes on the disk. Non-redundant volumes cannot be recovered

and should be restored from backup, if possible. If the disk being replaced is a

boot disk, this procedure also sets up the new disk as a boot disk. You may

need to replace a disk if the disk fails and/or needs to be removed and

repaired.

If you replace a healthy disk, you need to remove the disk from its disk group

and place it in the free disk pool before you replace the disk (see “Removing a

Disk”). If the disk to be replaced has failed and is disconnected, you do not

need to remove the disk.

▼ To replace a disk

1. Select the disk to be replaced.

2. Choose Disks > Replace (Selected menu) or Disk Replace (Command

Launcher).

3. Complete the Replace Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Name: If the correct disk name is not already displayed in

this field, type the Volume Manager disk name for

the disk to be replaced or click Browse to select the

disk.

New Physical

Disk:

Type the physical disk name for the new

(replacement) disk or click Browse to select a disk.
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Notes:

• This task requires the name of the disk to be replaced and the replacement

disk name.

• The disk to be replaced must be disconnected or removed from its disk

group. If the disk has not failed, you need to remove the disk from its disk

group and put it in the free disk pool before you replace the disk.

• The new disk can be a disk in the free disk pool or an uninitialized disk. If the

new disk is uninitialized, this task places the disk under Volume Manager

control.

• The new disk is placed in the old disk’s disk group.
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Recovering Volumes on a Disk
This procedure performs any necessary volume recovery operations on the

volumes on a given disk. The recovery operations depend on the types of

volumes on the disk and include starting disabled volumes, resynchronizing

mirrors in mirrored volumes, and resynchronizing parity in RAID-5 volumes.

After successful recovery, the volumes should be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know

that volume recovery is needed.

▼ To recover all volumes on a disk

1. Select the disk containing the volumes to be recovered.

2. Choose Disks > Recover (Selected menu) or Disk Recover (Command

Launcher).

3. Complete the Recover Disk dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click

Ok.

Disk(s): If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you

can attempt to restore the volume from backup.
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Removing a Disk
This procedure removes a disk from its disk group and either places the disk in

the free disk pool or removes the disk from Volume Manager control. If the

disk is returned to the free space pool, the disk must be added to a disk group

before it can be used for volumes (see “Adding a Disk to the Volume

Manager”). You can use this procedure to remove a disk permanently or to

prepare a disk for replacement.

▼ To remove a disk from a disk group or Volume Manager

1. Select the disk to be removed.

2. Choose Disks > Remove (Selected menu) or Disk Remove (Command

Launcher).

3. Complete the Remove Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Name: If the correct disk name is not already displayed in

this field, type the disk’s name or click Browse to

select the disk.

After removing

disk:

Specify how to handle the disk after removal:

• To remove the disk from its disk group and place it

in the free disk pool, select Return to Free Disk

Pool. The disk will remain under Volume Manager

control.

• To remove the disk from Volume Manager control,

select Return to Uninitialized State.

Options: To move the contents of the disk to another disk(s)

before the disk is removed, select Evacuate. Click

Target Disks to specify the disk(s) to which the

contents of the disk should be moved.
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Notes:

• This task requires a disk name. You also need to specify whether the disk

should be placed in the free disk pool or removed from Volume Manager

control.

• If the disk contains a volume that has only one mirror and either has a

mounted file system or is used as a swap area, the Evacuate option is

required.

• When a disk is removed from a disk group or Volume Manager control, the

disk cannot be accessed.

• A disk that is in use (i.e. contains volumes) should not be removed.

Removing a disk with volumes can result in loss of data or data redundancy.

If volumes exist on the disk to be removed, you can select Evacuate to move

the volumes to another disk.

• The last disk in a disk group cannot be removed. To remove the last disk in a

disk group, the disk group must be destroyed. The last disk in the rootdg
disk group can never be removed.

• Any non-redundant volumes on the removed disk become disabled.

• If the disk contains data and you do not evacuate the disk, the disk removal

will cause the disk to become disconnected. If this happens, you can use the

Replace Disk task to fix the disconnected disk.
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Creating a Disk Group
This procedure creates an additional disk group. Disks must be placed in disk

groups before they can be used by the Volume Manager. The default disk

group (rootdg ) is usually created during Volume Manager installation and

always exists on a system running the Volume Manager. You can create

additional disk groups to organize your disks into logical sets of disks.

▼ To create a disk group

1. Choose Console > New > Disk Group (menu) or Disk Group New

(Command Launcher).

2. Complete the New Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: Type the name of the disk group to be created.

Click View to view the names of existing disk

groups.

Disk Device(s): Select the disk(s) to be placed in the new disk

group.

Options: • To set up any new disks on the system, click Scan

Disks. This runs the disk setup commands

appropriate for the operating system.

• To create a shared disk group, select Create Shared.

This option is only applicable in a cluster

environment.

• To specify the Volume Manager disk name for the

disk, type a disk name in the Disk Name(s) field.

If no Volume Manager disk name is specified, the

Volume Manager assigns a default name to the

disk.

• To apply a comment or attribute to disks that are

placed in the disk group, type the information in

the Comment field.
78 VERITAS Volume Manager Storage Administrator Administrator’s Guide



3

3. Indicate whether the disk should be initialized or encapsulated. If you

initialize the disk, any existing data on the disk will be destroyed. If you

encapsulate the disk, any existing data will be preserved in volumes.

4. If you chose to encapsulate the disk, reboot the system.

Notes:

• This task requires a disk group name and the name of at least one disk.

• The disk group name must be unique.

• The new disk group must contain at least one disk.

• Only disks that are online and do not belong to a disk group can be used to

create a disk group.

• When a disk is placed under Volume Manager control, the disk is either

initialized or encapsulated. Encapsulation preserves any existing data on the

disk in the form of volumes. Initialization destroys any existing data on the

disk. Encapsulation is recommended for the root/boot disk and any other

disks that contain valuable data.

• The Volume Manager disk name must be unique within the disk group.

• If multiple disks are specified in the Disk Device(s) field and only one disk

name is specified in Disk Name(s) field, the Volume Manager appends

numbers to the disk name so that each disk name is unique within its disk

group.
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Upgrading a Disk Group
This procedure upgrades a disk group to the disk group version that is

compatible with the current Volume Manager release. Some new features and

tasks only work on disk groups with the current disk group version, so you

must upgrade existing disk groups before you perform these tasks. However,

after you upgrade a disk group, you cannot access that disk group from

machines running earlier releases of the Volume Manager.

To determine if a disk group needs to be upgraded, select the disk group and

open the Disk Group Properties window. The Version field of the Properties

window indicates whether the disk group has been upgraded to the current

disk group version.

▼ To upgrade a disk group

1. Select the disk to be upgraded to the current version.

2. Choose Disks Groups > Upgrade (Selected menu) or Disk Group Upgrade

(Command Launcher).

3. Complete the Upgrade Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group(s): If the correct disk group name is not already

displayed in this field, type the disk group’s name

or click Browse to select the disk group.

Notes:

• Disk groups created with earlier releases of the Volume Manager must be

upgraded before they can take advantage of new features and tasks in the

current release.

• If a disk group is upgraded to the current disk group version, you cannot

import that disk group on a machine running an earlier Volume Manager

release. Disk groups that must remain backward compatible with earlier

releases of the Volume Manager should not be upgraded.
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Renaming a Disk Group
This procedure changes the name of an existing disk group. You might rename

a disk group to provide a more appropriate name or avoid a name conflict with

a disk group to be imported.

▼ To rename a disk group

1. Select the disk group to be renamed.

2. Choose Disks Groups > Rename (Selected menu) or Disk Group Rename

(Command Launcher).

3. Complete the Rename Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: If the correct disk group name is not already

displayed in this field, type the disk group’s name

or click Browse to select the disk group.

New Name: Type the new name for the disk group.

Notes:

• This task requires the current disk group name and a new disk group name.

• The new disk group name must be unique.

• This task deports and reimports the disk group. If volumes in the disk group

are in use, the deport fails and the disk group is not renamed.

• This task updates the file system table file, if necessary.

• If the disk group contains volumes with mounted file systems, you may need

to unmount the file systems.
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Deporting a Disk Group
This procedure makes a disk group and its volumes inaccessible. Once

deported, a disk group cannot be used until it is imported. You can deport a

disk group to make the disk group temporarily unavailable.

While a disk group is deported, you cannot remove and reuse any of its disks.

To remove disks, you must import the disk group and then either destroy the

disk group (to remove all of its disks) or remove selected disks from the disk

group.

▼ To deport a disk group

1. Select the disk group to be deported.

2. Choose Disk Groups > Deport (Selected menu) or Disk Group Deport

(Command Launcher).

3. Complete the Deport Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: If the correct disk group name is not already

displayed in this field, type the disk group’s name

or click Browse to select the disk group.

Options: Use the following options with caution:

• To change the name of the disk group at deport,

type a new disk group name in the New Name

field.

• To set up a host machine to import the deported

disk group at reboot, type the host ID in the New

Host field.
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Notes:

• This task requires a disk group name.

• A deported disk group cannot be accessed. To access a deported disk

group, the disk group must be imported.

• The rootdg  disk group cannot be deported.

• A disk group cannot be deported if any volumes in that disk group are in use

(open).

• When a disk group is deported, the host ID stored on all disks in the disk

group is cleared and the disk group is not reimported automatically when

the system is rebooted. However, if you specify a host in New Host option,

the specified host will import the disk group at reboot.
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Importing a Disk Group
This procedure makes a deported (inaccessible) disk group and its volumes

accessible again. To import a deported disk group, you must know the disk

group’s former name and this disk group name must remain unused. In

addition, at least one disk formerly assigned to the deported disk group must

remain unused.

▼ To import a disk group

1. Select the Volume Manager node (at the top of the tree).

2. Choose System > Import Disk Group (Selected menu) or Disk Group Import

(Command Launcher).

3. Complete the Import Disk Group dialog box as follows:

Disk Group Name: Type the name of the disk group to be imported or

click Browse to select the disk group.

Options: Use the following options with caution:

• To start all volumes in the disk group at import,

select Start All Volumes.

• To clear the existing host ID stamp on all disks in

the disk group at import, select Clear Host ID. Do

not use this option if another host is using any

disk(s) in the disk group.

• To force the disk group import when the host

cannot access all disks in the disk group, select

Force Import. This option can be used to import a

disk group that contains a failed disk, but can lead

to disk group inconsistency if all disks are still

usable.

• To import the disk group as a shared disk group,

select Import Shared. This option is only applicable

in a cluster environment.
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When you have provided all necessary information in the dialog box, click

Ok.

• To change the name of the disk group at import,

type a new disk group name in the New Name

field. To indicate that the name change is

temporary, select Use New Name as Temporary.

Notes:

• This task requires a disk group name.

• Only deported disk groups can be imported.

• A deported disk group cannot be imported if another disk group with the

same name has been created since the disk group was deported.

• A disk group import may fail if the host cannot find one or more disks in the

disk group. If the import fails because a disk has failed, you can import the

disk group by selecting the Force Import option. If the import fails for

another reason, a forced import can cause serious problems.

• When a disk group is imported, the system stamps its host ID on all disks in

the disk group. A disk group import should fail if one of the disks is stamped

with a host ID that does not match the others. This ensures that dual-ported

disks cannot be managed (and possibly corrupted) by two systems at the

same time. If you are sure that the disk group is not in use by another host,

you can clear the host IDs and import the disk group by selecting the Clear

Host ID option.
Disk Tasks 85



3

Recovering Volumes in a Disk Group
This procedure performs any necessary volume recovery operations on the

volumes in a given disk group. The recovery operations depend on the types of

volumes in the disk group and include starting disabled volumes,

resynchronizing mirrors in mirrored volumes, and resynchronizing parity in

RAID-5 volumes. After successful recovery, the volumes should be available

for use again.

Alert icons and the Alert Monitor window may provide clues to let you know

that volume recovery is needed.

▼ To recover all volumes in a disk group

1. Select the disk group containing the volumes to be recovered.

2. Choose Disk Groups > Recover (Selected menu) or Disk Group Recover

(Command Launcher).

3. Complete the Recover Disk Group dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group(s): If the correct disk group name is not already

displayed in this field, type the disk group’s name

or click Browse to select the disk group.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you

can attempt to restore the volume from backup.
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Destroying a Disk Group

CAUTION! Destroying a disk group can result in data loss.

This procedure permanently removes a disk group from Volume Manager

control. This also reinitializes all of the disks in the disk group as empty disks

and places them in the free disk pool for reuse.

You should only destroy a disk group if you are sure that you no longer need

the volumes and data in the disk group. Since the last disk in a disk group

cannot be removed, destroying a disk group is useful for freeing the last disk

in a disk group for reuse.

▼ To destroy a disk group

1. Select the Volume Manager node (at the top of the tree).

2. Choose System > Destroy Disk Group (Selected menu) or Disk Group

Destroy (Command Launcher).

3. Complete the Destroy Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: Type the name of the disk group to be destroyed or

click Browse to select the disk group.
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Notes:

• Destroying a disk group permanently removes the disk group from Volume

Manager control and can result in data loss. This task should be used with

caution.

• When a disk group is destroyed, its disks are returned to the free disk pool.

Any volumes in the disk group are removed.

• The rootdg  disk group cannot be destroyed.

• A disk group cannot be destroyed if any volumes in that disk group are in

use (open) and/or contain mounted file systems.
88 VERITAS Volume Manager Storage Administrator Administrator’s Guide



3

Moving a Disk Group
This procedure moves a disk group (and the Volume Manager objects in that

disk group) from one system to another. This relocates the disk group’s

configuration to the new system.

▼ To move a disk group from one machine to another

1. Unmount and stop all volumes in the disk group to be moved. (See

Chapter 4, “Volume Tasks” for information on how to unmount and stop

volumes.)

2. Follow the instructions in “Deporting a Disk Group” to deport the disk

group to be moved to the other system.

3. Attach all of the physical disks in the disk group to the new system.

4. On the new system, follow the instructions in “Importing a Disk Group” to

import the disk group.

5. Select the Volume Manager node (at the top of the tree) and choose

System > Scan Disks (Selected menu) to set up the newly attached disks on

the system. This runs the disk setup commands appropriate for the

operating system.

6. Follow the instructions in “Recovering Volumes in a Disk Group” to restart

and recover all volumes in the disk group on the new system.

Notes:

• The Volume Manager and the Storage Administrator (server) must be

running on both systems.
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Volume Tasks 4
Introduction
This chapter describes how to create and use volumes with the Volume

Manager Storage Administrator. It also includes information on how to use file

systems with volumes.The Volume Task Roadmap and File System Task

Roadmap at the beginning of this chapter contain summaries of common

volume and file system tasks.

The following volume tasks are discussed in this chapter:

• Creating a Volume

• Resizing a Volume

• Renaming a Volume

• Changing a Volume’s Layout

• Adding a Mirror to a Volume

• Adding a Log to a Volume

• Stopping a Volume

• Starting a Volume

• Creating a Snapshot Copy of a Volume

• Preparing to Restore a Volume From Backup

• Recovering a Volume

• Repairing a Mirror
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• Disabling a Mirror

• Removing a Mirror From a Volume

• Removing a Log From a Volume

• Removing a Volume

• Moving a Subdisk

• Splitting a Subdisk

• Joining Subdisks

• Removing a Subdisk

The following file system tasks are discussed in this chapter:

• Adding a File System to a Volume

• Mounting a File System on a Volume

• Resizing a File System

• Creating a Snapshot Copy of a File System

• Unmounting a File System on a Volume

• Checking a File System on a Volume

The following VERITAS Accelerator tasks are discussed in this chapter:

• Creating an Accelerator Log on a Volume

• Enabling the Accelerator Log for a File System

• Disabling the Accelerator Log for a File System

• Removing an Accelerator Log

Note: VERITAS Accelerator is an optionally licensable product.
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Volume Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator volume tasks.

To do this... Use this procedure...

Volume Setup Tasks:

Create new volume(s) Creating a Volume

Precautionary Tasks:

Mirror (copy) volumes onto other disks for

redundancy

Adding a Mirror to a Volume

Create mirrored volumes Creating a Volume

Add a log to a mirrored volume Adding a Log to a Volume

Add a log to a RAID-5 volume Adding a Log to a Volume

Maintenance Tasks:

Add space to volumes Resizing a Volume

Change volume layouts Changing a Volume’s Layout

Add mirrors to volumes that should be

redundant

Adding a Mirror to a Volume

Create a snapshot copy of a volume for

backup

Creating a Snapshot Copy of a Volume

Move portions of volumes to other disk

space

Moving a Subdisk
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Recovery Tasks:

Attempt to recover a volume Recovering a Volume

Attempt to recover all volumes on a disk Recovering Volumes on a Disk (see

Chapter 3, “Disk Tasks”)

Attempt to recover all volumes in a disk

group

Recovering Volumes in a Disk Group (see

Chapter 3, “Disk Tasks”)

Prepare to restore a volume from backup Preparing to Restore a Volume From Backup

Repair or reattach a volume’s disabled

mirror

Repairing a Mirror

Other Tasks:

Change a volume’s name Renaming a Volume

Temporarily prevent access to a volume Stopping a Volume

Restore access to a stopped volume Starting a Volume

Temporarily prevent access to a volume’s

mirror

Disabling a Mirror

Remove a mirror from a volume Removing a Mirror From a Volume

Remove a DRL log from a volume Removing a Log From a Volume

Remove a RAID-5 log from a volume Removing a Log From a Volume

Remove a volume Removing a Volume

To do this... Use this procedure...
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File System Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator file system tasks. Note that some of these tasks are only

available for the VERITAS File System™ (referred to as VxFS® or vxfs ).

To do this... Use this procedure...

File System Setup Tasks:

Create a volume with a file system Creating a Volume

Place a file system on an existing volume Adding a File System to a Volume

Mount a file system on a volume Mounting a File System on a Volume

Maintenance Tasks:

Add more space to a file system Resizing a File System

Create a snapshot copy of a file system for

backup

Creating a Snapshot Copy of a File System

Recovery Tasks:

Perform a file system consistency check Checking a File System on a Volume

Other Tasks:

Unmount a file system Unmounting a File System on a Volume
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Creating a Volume
The Volume Manager uses logical volumes to organize and manage disk space.

A volume is made up of portions of one or more physical disks, so it does not

have the physical limitations of a physical disk.

A volume can provide greater capacity and better availability and performance

than a single physical disk. A volume can be extended (grown) across multiple

disks to increase capacity, mirrored (copied) on another disk to provide data

redundancy, and/or striped across multiple disks to improve I/O performance.

You can use the Volume Manager Storage Administrator to create the following

types of volumes:

• Concatenated Volume

A concatenated volume is made up of one or more disk regions that are

linked together (concatenated) in a linear fashion. A concatenated volume

can consist of disk regions on multiple disks; a concatenated volume that

extends across two or more disks is also known as a spanned volume.

Note that the data in this type of volume cannot be recovered if the

underlying disk fails. However, a concatenated volume can be mirrored

(copied) onto another disk(s) to protect its data against disk failure.

• Striped Volume

A striped volume’s data is interleaved (striped) across two or more physical

disks. A striped volume’s data is spread across the disks alternately and

evenly in small, equal-sized portions of data called stripe units. Striping

improves performance.

Note that the data in this type of volume cannot be recovered if one of the

underlying disks fails. However, a striped volume can be mirrored (copied)

onto another disk(s) to protect its data against disk failure.

• RAID-5 Volume

A RAID-5 volume’s data is interleaved (striped) across three or more

physical disks. Within each stripe across the set of disks, the data on one of

the disks is parity data. If one of the physical disks fails, the parity data can

be used to reconstruct and recover the lost data.

Note that RAID-5 volumes cannot be mirrored.
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• Mirrored Volume

Volumes with concatenated or striped layouts can be mirrored to increase

data availability. All of the data in a mirrored volume is duplicated on at

least one other physical disk. If one of the disks fails, the data can still be

accessed from one of the remaining disks.

• Layered Volume

A layered volume is built on one or more other volumes. The underlying

volumes are typically mirrored. In layered volumes, mirroring is done at a

lower level and with smaller granularity than with non-layered volumes, so

each mirror covers a relatively small storage region.

Layered volumes tolerate disk failure better than non-layered volumes and

provide improved data redundancy. If a disk in a layered volume fails, only

a portion of the redundancy is lost and recovery time is usually quicker

than it would be for a non-layered volume. Layered volumes also reduce

the chance that two disk failures will result in lost data.

The underlying volumes in a layered volume are used exclusively by the

Volume Manager and are not intended for user manipulation.

With the Storage Administrator, you can create the following types of

layered volumes:

• Concatenated Pro Volume

A concatenated pro volume is a layered concatenated volume that is

mirrored.

• Striped Pro Volume

A striped pro volume is a layered striped volume that is mirrored.

The following table summarizes the advantages and disadvantages of each

volume layout.
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Table 1 Layout Comparison

Layout Advantages Disadvantages

Concatenated • The volume can consist of disk

regions that are not adjacent.

• The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

• The volume can be mirrored to

protect data against disk

failure and reduce the risk of

data loss.

• There is a risk of data loss if the

volume is not mirrored.

• Spanning a volume across

multiple disks increases the

chance that a disk failure will

result in the failure of the volume.

• Concatenation does not improve

I/O performance.

Striped • Striping provides improved

read and write performance.

• Striping can help to balance the

I/O load from multi-user

applications across multiple

disks.

• The volume can be mirrored to

protect data against disk

failure.

• There is a risk of data loss if the

volume is not mirrored.

• Striping a volume across multiple

disks increases the chance that a

disk failure will result in the

failure of the volume.

• A striped volume requires at least

two disks.
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RAID-5 • RAID-5 provides protection

against disk failure and

reduces the risk of data loss.

• RAID-5 provides data

redundancy by storing parity

(a calculated value) on the

disks. If a disk fails, the parity

is used to reconstruct the

missing data.

• RAID-5 requires less storage

space than mirroring.

• RAID-5 provides improved

read performance.

• RAID-5 provides relatively slow

write performance.

• RAID-5 volumes cannot be

mirrored.

• A RAID-5 volume requires at

least three disks.

• A RAID-5 volume cannot survive

multiple disk failures. However,

optional RAID-5 logs reduce this

risk.

• If one of the volume’s disks is

inaccessible, performance is

degraded.

Mirrored • Mirroring provides protection

against disk failure and

reduces the risk of data loss.

• Mirroring provides data

redundancy by maintaining

multiple complete copies of a

volume’s data on different

disks.

• Mirroring provides improved

read performance.

• A mirrored volume requires extra

disk space. Each mirror requires

enough disk space to contain a

complete copy of the volume.

Table 1 Layout Comparison

Layout Advantages Disadvantages
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Concatenated Pro • The volume is layered and

mirrored. This provides

improved data redundancy

and reduces the impact of disk

failures.

• Recovery time is quicker than

with regular concatenated

volumes that are mirrored.

• The volume can consist of disk

regions that are not adjacent.

• The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

• A concatenated pro volume

requires at least two disks.

• Concatenation does not improve

I/O performance.

• Layered volumes consist of more

Volume Manager objects than

non-layered volumes and are

likely to fill up the disk group’s

configuration database sooner.

When the configuration database

is full, you cannot create more

volumes in the disk group.

Striped Pro • The volume is layered and

mirrored. This provides

improved data redundancy

and reduces the impact of disk

failures.

• Recovery time is quicker than

with regular striped volumes

that are mirrored.

• Striping provides improved

read and write performance.

• Striping can help to balance the

I/O load from multi-user

applications across multiple

disks.

• A striped pro volume requires at

least four disks.

• Layered volumes consist of more

Volume Manager objects than

non-layered volumes and are

likely to fill up the disk group’s

configuration database sooner.

When the configuration database

is full, you cannot create more

volumes in the disk group.

Table 1 Layout Comparison

Layout Advantages Disadvantages
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▼ To create a concatenated volume

This procedure creates a concatenated volume that consists of one or more

regions of the specified disk(s). This procedure also gives you the options of

placing a file system on the new volume or mirroring the volume.

You can use this procedure to create a regular concatenated volume or a

concatenated pro volume. A concatenated pro volume is layered and mirrored.

1. Choose Console > New > Volume (menu) or Volume New (Command

Launcher).

2. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse

to select another disk group.

Volume Name: Type the new volume’s name (or accept the default

name).

Size: Type the volume size. To specify a size unit, attach

an s (sectors), k (kilobytes), m(megabytes), or g
(gigabytes) to the size.

To determine the largest possible size for the

volume, click Maxsize.

Layout: Choose Concatenated or Concatenated Pro for the

volume layout.
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When you have provided all necessary information in the dialog box, click

Ok.

Options: • To mirror the volume, select Mirrored. In the Total

Number of Mirrors field, type the total number of

mirrors for the volume. (Note: Concatenated pro

volumes are mirrored by default.)

• To place the volume on a specific disk, click Assign

Disks and select the disk you want to use from the

Space Allocation - New Volume dialog box.

• To place a file system on the volume, click Add File

System and specify the file system type and mount

point in the Add File System dialog box.

• To add a comment attribute for the volume, type

the information in the Comment field.

Notes:

• This task requires a disk group name, volume name, volume size, and

volume layout.

• The volume size should be less than or equal to the available free space on

the disk(s).

• If no disks are assigned, the Volume Manager uses available space on disks in

the selected disk group.

• The data in a concatenated volume is not protected against disk failure unless

the volume is mirrored. At least one additional disk is required to mirror a

concatenated volume.

• Concatenated pro volumes are mirrored by default, so a concatenated pro

volume requires more disks than an unmirrored concatenated volume.

• You cannot use a concatenated pro volume for a root  or swap volume.

• If a file system is placed on the volume and the Mount at Boot option is

selected, the file system table file is automatically updated.
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▼ To create a striped volume

This procedure creates a striped volume that is spread across two or more

disks. This procedure also gives you the options of placing a file system on the

new volume or mirroring the volume.

You can use this procedure to create a regular striped volume or a striped pro

volume. A striped pro volume is layered and mirrored.

1. Choose Console > New > Volume (menu) or Volume New (Command

Launcher).

2. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse

to select another disk group.

Volume Name: Type the new volume’s name (or accept the default

name).

Size: Type the volume size. To specify a size unit, attach

an s (sectors), k (kilobytes), m(megabytes), or g
(gigabytes) to the size.

To determine the largest possible size for the

volume, click Maxsize.

Layout: Choose Striped or Striped Pro for the volume

layout.

In the Number of Columns field, specify the

number of columns (disks) across which the

volume should be striped. A striped volume

requires at least two disks.

To specify a stripe unit size other than the default,

type the stripe unit size in the Stripe Unit Size field.

To specify a size unit, attach an s (sectors), k
(kilobytes), m(megabytes), or g (gigabytes) to the

size.
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When you have provided all necessary information in the dialog box, click

Ok.

Options: • To mirror the volume, select Mirrored. In the Total

Number of Mirrors field, type the total number of

mirrors for the volume. (Note: Striped pro volumes

are mirrored by default.)

• To stripe the volume across specific disks, click

Assign Disks and select the disks you want to use

from the Space Allocation - New Volume dialog

box.

• To place a file system on the volume, click Add File

System and specify the file system type and mount

point in the Add File System dialog box.

• To add a comment attribute for the volume, type

the information in the Comment field.

Notes:

• This task requires a disk group name, volume name, volume size, and

volume layout.

• A striped volume requires at least two disks.

• The volume size should be less than or equal to the available free space on

the disk(s).

• If no disks are assigned, the Volume Manager uses available space on disks in

the selected disk group.

• The data in a striped volume is not protected against disk failure unless the

volume is mirrored. At least one additional disk is required to mirror a

striped volume.

• Striped pro volumes are mirrored by default, so a striped pro volume

requires more disks than an unmirrored striped volume.

• You cannot use a striped pro volume for a root  or swap volume.

• If a file system is placed on the volume and the Mount at Boot option is

selected, the file system table file is automatically updated.
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▼ To create a RAID-5 volume

This procedure creates a RAID-5 volume that is spread across two or more

disks and contains parity information. This procedure also gives you the

option of placing a file system on the new volume.

1. Choose Console > New > Volume (menu) or Volume New (Command

Launcher).

2. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse

to select another disk group.

Volume Name: Type the new volume’s name (or accept the default

name).

Size: Type the volume size in the Size field. To specify a

size unit, attach an s (sectors), k (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the

volume, click Maxsize.

Layout: Choose RAID-5 for the volume layout.

In the Number of Columns field, specify the

number of columns (disks) across which the

volume should be striped. A RAID-5 volume

requires at least three disks.

To specify a stripe unit size other than the default,

type the stripe unit size in the Stripe Unit Size field.

To specify a size unit, attach an s (sectors), k
(kilobytes), m(megabytes), or g (gigabytes) to the

size.
Volume Tasks 105



4

When you have provided all necessary information in the dialog box, click

Ok.

Options: • To stripe the volume across specific disks, click

Assign Disks and select the disks you want to use

from the Space Allocation - New Volume dialog

box.

• To place a file system on the volume, click Add File

System and specify the file system type and mount

point in the Add File System dialog box.

• To enable RAID-5 logging for the volume, select

Enable Logging.

• To add a comment attribute for the volume, type

the information in the Comment field.

Notes:

• This task requires a disk group name, volume name, volume size, and

volume layout.

• A RAID-5 volume requires at least three disks.

• RAID-5 volumes cannot be mirrored.

• The volume size should be less than or equal to the available free space on

the disk(s).

• For a RAID-5 volume, the size specified in the Size field is the usable space in

the volume. The Volume Manager allocates additional space for the volume’s

parity information. The disks across which the RAID-5 volume will be

striped should therefore contain additional free space for the volume’s parity

information.

• If no disks are assigned, the Volume Manager uses available space on disks in

the selected disk group.

• If a file system is placed on the volume and the Mount at Boot option is

selected, the file system table file is automatically updated.

• If logging is enabled, the volume requires at least one additional disk. The

Volume Manager adds an appropriate number of logs to the volume.
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▼ To create a mirrored volume

This procedure creates a concatenated or striped volume that is mirrored

(copied) on at least one other disk. If one of the disks fails, the volume’s data

can be accessed from the surviving disk(s).

You can use this procedure to create a regular mirrored volume or a layered

mirrored volume. Concatenated pro and striped pro volumes are layered and

mirrored by default.

1. Choose Console > New > Volume (menu) or Volume New (Command

Launcher).

2. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse

to select another disk group.

Volume Name: Type the new volume’s name (or accept the default

name).

Size: Type the volume size in the Size field. To specify a

size unit, attach an s (sectors), k (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the

volume, click Maxsize.

Layout: Choose Concatenated, Striped, Concatenated Pro,

or Striped Pro for the volume layout.

For a striped volume, provide the following

information:

In the Number of Columns field, specify the

number of columns (disks) across which the

volume should be striped. A striped volume

requires at least two disks.

To specify a stripe unit size other than the default,

type the stripe unit size in the Stripe Unit Size field.

To specify a size unit, attach an s (sectors), k
(kilobytes), m(megabytes), or g (gigabytes) to the

size.
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When you have provided all necessary information in the dialog box, click

Ok.

Mirror Info: • Select Mirrored. In the Total Number of Mirrors

field, type the total number of mirrors for the

volume. (Note: Concatenated pro and striped pro

volumes are mirrored by default.)

Options: • To place the volume on a specific disk(s), click

Assign Disks and select the disks you want to use

from the Space Allocation - New Volume dialog

box.

• To place a file system on the volume, click Add File

System and specify the file system type and mount

point in the Add File System dialog box.

• To add a comment attribute for the volume, type

the information in the Comment field.

• To enable Dirty Region Logging (DRL) for the

volume, select Enable Logging.

Notes:

• This task requires a disk group name, volume name, volume size, and

volume layout.

• A mirrored volume requires at least two disks.

• Only concatenated or striped volumes can be mirrored.

• If logging is enabled, the volume requires at least one additional disk. The

Volume Manager adds an appropriate number of logs to the volume.
108 VERITAS Volume Manager Storage Administrator Administrator’s Guide



4

Resizing a Volume
This procedure changes the size of a volume. If users require more space on a

volume, you can use this procedure to increase the size of the volume. If a

volume contains unused space that you need to use elsewhere, you can use

this procedure to shrink the volume. If the volume contains a file system, this

procedure also resizes the file system.

▼ To resize a volume

1. Select the volume to be resized.

2. Choose Volumes > Resize (Selected menu) or Volume Resize (Command

Launcher).

3. Complete the Resize Volume dialog box as follows:

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

New Size: Specify one of the following:

• To increase the volume size by a specific amount of

space, use the Add By field to specify how much

space should be added to the volume.

• To decrease the volume size by a specific amount of

space, use the Subtract By field to specify how

much space should be removed from the volume.

• To specify the new volume size, type the size in the

Desired Size field.

To specify a size unit, attach an s (sectors), k
(kilobytes), m(megabytes), or g (gigabytes) to the

size.

Options: • To use a specific disk for the additional space, click

Assign Disks and select the disk you want to use

from the Space Allocation - Resize dialog box.
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When you have provided all necessary information in the dialog box, click

Ok.

Notes:

• This task requires a volume name and either the desired size or the amount

of space to add to or subtract from the volume size.

• A volume containing file system other than vxfs  cannot be shrunk.

• Shrinking a volume with an unmounted file system can result in data loss, so

a volume containing an unmounted file system cannot be shrunk.

• When a volume is shrunk, the resulting extra space is returned to the free

space pool.

• When the volume size is increased, sufficient disk space must be available.

When increasing the size of a volume, the Volume Manager assigns the

necessary new space from available disks.
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Renaming a Volume
This procedure changes the name of a volume. If the volume has a file system,

this procedure also makes the necessary changes to the file system table file

and allows you to specify a new mount point for the file system.

▼ To rename a volume

1. Select the volume to be renamed.

2. Choose Volumes > Rename (Selected menu) or Volume Rename (Command

Launcher).

3. Complete the Rename Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

New Name: Type the new name for the volume.

Options: If the volume contains a file system and you want

to change the mount point when the volume is

renamed, type a new mount point in the New

Mount Point field.

Notes:

• This task requires the current volume name and a new volume name.

• The new volume name must be unique within the disk group.

• If the volume contains a file system, the file system table file is automatically

updated (if necessary).
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Changing a Volume’s Layout
This procedure changes the layout of a volume without interrupting access to

data. You can use this task to change the redundancy or performance

characteristics of an existing volume.

You can view the progress of the relayout task through the Relayout Status

Monitor window. You can also use the Relayout Status Monitor window to

pause, abort, continue, or reverse the relayout task. The Relayout Status

Monitor appears automatically when a relayout task begins. When a volume

relayout is in progress, paused, or aborted, you can also access the Relayout

Status Monitor through the Volume Properties window.

▼ To change a volume’s layout

1. Select the volume to be changed to a different layout.

2. Choose Volumes > Change Layout (Selected menu) or Volume Change

Layout (Command Launcher).

3. Complete the Change Volume Layout dialog box as follows:

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Layout: Choose the new volume layout:

• Concatenated

Change the volume to a simple, concatenated

volume.

• Striped

Change the volume to a striped volume.

• RAID-5

Change the volume to a RAID-5 volume.

• Concatenated Pro

Change the volume to a layered concatenated

volume.

• Striped Pro

Change the volume to a layered striped volume.
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For a striped, RAID-5, or Striped Pro volume,

provide the following information:

• In the Number of Columns field, specify the

number of columns (disks) across which the

volume should be striped.

• To specify a stripe unit size other than the default,

type the stripe unit size in the Stripe Unit Size field.

To specify a size unit, attach an s  (sectors), k
(kilobytes), m (megabytes), or g (gigabytes) to the

size.

Options: • To retain the original volume size when the

volume layout changes, click Retain Volume Size

at Completion.

• To specify the size of the pieces of data that are

copied to temporary space during the volume

relayout, type the size in the Temp Space Size

field.

• To specify additional disk space to be used for the

new volume layout (if needed), specify the disk in

the Disk(s) field or click Browse to select a disk.

• To specify the temporary disk space to be used

during the volume layout change, specify the disk

in the Temp Disk(s) field or click Browse to select

a disk.

• If the volume contains plexes with different

layouts, specify the plex to be changed to the new

layout in the Target Plex field.
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When you have provided all necessary information in the dialog box, click

Ok. The Relayout Status Monitor window appears. This window provides

you with the following information and options:

If you need to pause, abort, continue, or reverse a relayout task after you

close the Relayout Status Monitor window, you can access the Relayout

Status Monitor through the Volume Properties window.

Volume Name: The name of the volume that is undergoing a

layout change.

Initial Layout: The original layout of the volume.

Desired Layout: The new layout for the volume.

Status: The status of the relayout task.

% Complete: The progress of the relayout task.

Options: •  To stop the relayout task temporarily, click Pause.

• To cancel the relayout task, click Abort.

• To resume the paused or aborted relayout task,

click Continue.

• To undo the layout changes and return the volume

to its original layout, click Reverse.
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Notes:

• This task requires a volume name and a different volume layout.

• Volumes remain accessible during online relayout.

• This task may take a long time, depending on the volume size and other

factors. The Relayout Status Monitor shows the progress of the layout change

and allows you to abort, pause, or reverse the task.

• If no disk space is specified, the Volume Manager uses available space on

disks in the current disk group.

• If the temporary space size is not specified, the Volume Manager uses an

appropriate size. Specifying a larger temporary space size speeds up the

layout change process because larger pieces of data are copied at a time. If

the specified temporary space size is too small, the Volume Manager uses a

larger size.

• If all of the plexes in the volume have identical layouts, the Volume Manager

changes all plexes (except log plexes) to the new layout. If the volume

contains plexes with different layouts, a target plex must be specified. When

a target plex is specified, the Volume Manager changes the layout of the

target plex and leaves the other plexes in the volume alone.

• Log plex layouts do not change. The Volume Manager may remove and/or

replace log plexes, depending on the new layout.

• If the volume length changes as a result of the layout change and the volume

contains a file system, the file system length is automatically adjusted (if

possible).

• A volume cannot undergo multiple relayouts at the same time.

• This task cannot be used to change the layout of a volume with a sparse plex.

• This task may fail for volumes that were not created by the Storage

Administrator or the vxassist  command.

• If the relayout is reversed, the volume returns to its original layout. However,

data in the volume may not return to its original storage location.

• During a relayout, many other tasks are unavailable for the volume.

• A mirrored or striped volume requires at least two disks.

• A RAID-5 volume requires at least three disks.
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Adding a Mirror to a Volume
This procedure creates a mirror (copy) of a volume on a disk that is not already

being used by the volume. If one of the disks fails, the volume’s data can be

accessed from the surviving disk(s). A volume can have multiple mirrors.

▼ To add a mirror to an existing volume

1. Select the volume to be mirrored.

2. Choose Volumes > Mirror > Add (Selected menu) or Volume Add Mirror

(Command Launcher).

3. Complete the Add Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok. Adding a mirror requires resynchronization, so this task may take some

time.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Options: • To specify the layout for the mirror, click Layout

and complete the Mirror Layout Details dialog box.

• To add more than one mirror, click Layout and

specify the number of mirrors in the Mirror Layout

Details dialog box.

• To place the mirror on a specific disk(s), click

Assign Disks and select the disks you want to use.
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Notes:

• This task requires a volume name.

• Once mirrored, the data in the volume is redundant. If a disk fails, the data

will remain available on the surviving mirror (on another disk).

• The new mirror cannot be created on a disk that already contains a copy of

the volume. Each mirror must reside on a separate disk.

• Sufficient disk space must be available to accommodate the additional

mirror(s).

• Only disks in the same disk group as the volume can be used to create the

new mirror.

• If no disks are assigned, the Volume Manager uses available disk space to

create the mirror.

• A RAID-5 volume cannot be mirrored.

• To mirror the root volume (and other volumes required to boot the system)

onto an alternate boot disk, use the Mirror Disk task.

• A volume can contain up to 32 plexes (mirrors).
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Adding a Log to a Volume
This procedure adds the appropriate type of log to a mirrored or RAID-5

volume.

▼ To add a DRL log to a mirrored volume

This procedure adds a Dirty Region Logging (DRL) log to a mirrored volume.

DRL uses this log to track the regions of the volume that change due to I/O

writes. If a system failure occurs, DRL uses the information in the log to

recover only the portions of the volume that need recovery. This speeds up

recovery time for mirrored volumes.

For DRL to be in effect, a mirrored volume must have at least one DRL log.

You can create additional DRL logs (on different disks) to mirror the DRL

information.

1. Select the mirrored volume to contain the log.

2. Choose Volumes > Log > Add (Selected menu) or Volume Add Log

(Command Launcher).

3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Options: To place the log on a specific disk, type the name of

the disk in the Disk Name field or click Browse to

select a disk.

Notes:

• This task requires a volume name.

• When a log is added to a mirrored volume, dirty region logging is activated

for that volume.
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▼ To add a log to a RAID-5 volume

This procedure adds a log to a RAID-5 volume. RAID-5 logs speed up the

resynchronization time for RAID-5 volumes after a system failure. A RAID-5

log maintains a copy of the data and parity being written to the volume at any

given time. If a system failure occurs, the Volume Manager can “replay” the

RAID-5 log to resynchronize the volume. This copies the data and parity that

was being written at the time of failure from the log to the appropriate areas of

the RAID-5 volume.

You can create multiple RAID-5 logs (on different disks) to mirror the log

information. Ideally, each RAID-5 volume should have at least two logs.

1. Select the RAID-5 volume to contain the log.

2. Choose Volumes > Log > Add (Selected menu) or Volume Add Log

(Command Launcher).

3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Options: To place the log on a specific disk, type the name of

the disk in the Disk field or click Browse to select a

disk.
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Stopping a Volume
This procedure disables a volume. When a volume is stopped, it is not

available for use until it is restarted (refer to “Starting a Volume”). Stopping a

volume is a safe way of temporarily preventing access to a volume.

▼ To stop a volume

1. Select the volume to be stopped.

2. Choose Volumes > Stop (Selected menu) or Volume Stop (Command

Launcher).

3. Complete the Stop Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

The volume’s state should change to Stopped.

Volume(s): If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• A volume cannot be stopped if it is in use (open) or it has a mounted file

system.
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Starting a Volume
This procedure attempts to enable (start) a stopped volume. When a volume is

successfully restarted, the volume is available for use again. This procedure

also performs any appropriate resynchronization operations on the volume.

Under normal circumstances, volumes are automatically started when the

system reboots. You can use this procedure to restart a volume that you

stopped manually or to attempt to restart a volume that was stopped in some

other manner. If a volume cannot be started, the volume remains unusable.

▼ To start a volume

1. Select the (stopped) volume to be started.

2. Choose Volumes > Start (Selected menu) or Volume Start (Command

Launcher).

3. Complete the Start Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

The volume’s state should change to Started.

Volume(s): If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• Starting a RAID-5 volume enables the volume and resynchronizes parity, if

necessary.

• Starting a mirrored volume enables the volume and resynchronizes the

mirrors to ensure that they are consistent.
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Creating a Snapshot Copy of a Volume
This procedure prepares a volume for backup by creating a new volume that is

a snapshot copy of an existing volume. This is done by attaching a new mirror

to the existing volume, copying the volume’s data to the new mirror, detaching

the new mirror, and then creating a new (snapshot) volume from the new

mirror. The snapshot volume is an exact copy of the original volume. You can

use the snapshot volume to make a backup of the original volume at a

convenient time. After the backup is made, you can remove the snapshot

volume (see “Removing a Volume”).

▼ To create a snapshot copy of a volume’s data

1. Select the volume to be copied to a snapshot.

2. Choose Volumes > Snapshot (Selected menu) or Volume Snapshot

(Command Launcher).

3. Complete the Volume Snapshot dialog box as follows:

4. When you have provided all necessary information in the dialog box, click

Snapstart to start the first phase of the snapshot procedure. This creates a

snapshot mirror of the volume to be backed up. This may take some time.

When the snapshot mirror is complete, the following message appears at

the bottom of the dialog box:

Click Snapshot to create the snapshot volume.

5. When the snapshot mirror is ready, click Snapshot to complete the

snapshot. This creates a snapshot copy of the original volume.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Snapshot Name: Type the name for the snapshot copy of the

volume.

Options: To place the snapshot on a specific disk(s), click

Assign Disks and select the disks you want to use.
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If you decide not to make a snapshot volume, you can remove the snapshot

mirror after the snapstart phase. To remove the snapshot mirror, click Remove

Snapshot Mirror.

Notes:

• This task requires a volume name and a snapshot name.

• The snapshot volume is an exact copy of the original volume at the time the

snapshot phase of the procedure starts.

• After you create the snapshot copy of the volume, remember to back it up to

tape or some other media. Remove the snapshot volume when it is no longer

needed.

• The snapstart phase of this task may take a long time, depending on the size

of the volume.

• If you remove the snapshot mirror, you cannot create a snapshot volume

until you repeat the snapstart phase of the procedure.
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Preparing to Restore a Volume From Backup
This procedure stops the volume, sets the volume to an uninitialized state, and

restarts the volume (without resynchronizing the volume’s mirrors). The

volume can then be reloaded from backup.

This procedure is intended for raw image backups and is not appropriate for

file system backups. This procedure is useful for disaster recovery. If a

volume’s data is corrupted and you know that you need to restore the volume

from backup, you can use this procedure to prepare the volume for restoration.

▼ To prepare a volume for a restore from backup

1. Select the volume to be restored from backup.

2. Choose Volumes > Prepare For Restore (Selected menu) or Volume Prep

Restore (Command Launcher).

3. Complete the Prepare Volume For Restore dialog box as follows (if

applicable):

When you have provided all necessary information in the dialog box, click

Ok.

When you have completed this task, you can restore the volume’s data from

backup.

Volume(s): If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• If the volume contains a mounted file system, the file system must be

unmounted before this task can proceed. This task does not remount the file

system.
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Recovering a Volume
This procedure performs any necessary volume recovery operations on a

volume. The recovery operations depend on the type of volume and include

starting disabled volumes, resynchronizing mirrors in mirrored volumes, and

resynchronizing parity in RAID-5 volumes. After successful recovery, the

volume should be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know

that volume recovery is needed.

▼ To recover a failed volume

1. Select the volume to be recovered.

2. Choose Volumes > Recover (Selected menu) or Volume Recover (Command

Launcher).

3. Complete the Recover Volume dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click

Ok.

Volume(s): If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• In some cases, recovery may not be possible. If the volume recovery fails, you

can attempt to restore the volume from backup.
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Repairing a Mirror
This procedure repairs a disabled mirror by reattaching the mirror to its

volume. This involves copying data from an active mirror on the volume to the

mirror being attached. Once attached, the mirror is accessible for reads and

writes again.

Alert icons and the Alert Monitor window may provide clues to let you know

that a mirror needs to be repaired.

▼ To repair a mirror

1. Select the volume that contains the mirror to be repaired.

2. Choose Volumes > Mirror > Repair (Selected menu) or Mirror Repair

(Command Launcher).

3. Complete the Repair Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Select the mirror to

repair:

Select the mirror to be repaired.

Notes:

• This task recovers the mirror so that it has the same contents as other mirrors

in the volume.

• This task may take a long time, depending on the amount of data in the

volume.
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Disabling a Mirror

Note: Disabling a mirror can result in loss of data redundancy.

This procedure disables a mirror by temporarily detaching the mirror from its

volume. A detached mirror is inaccessible for reads and writes, but is still

associated with its volume. Once disabled, the mirror remains detached from

its volume until you either reattach the mirror (refer to “Repairing a Mirror”)

or restart the volume.

▼ To disable a mirror in a volume

1. Select the volume that contains the mirror to be disabled.

2. Choose Volumes > Mirror > Disable (Selected menu) or Mirror Disable

(Command Launcher).

3. Complete the Disable Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Select the mirror to

disable:

Select the mirror to be disabled.

Notes:

• When a mirror is disabled, volume reads and writes cannot be directed to the

mirror.

• If a volume only has two mirrors and one mirror is disabled, the volume is

not redundant while the mirror is disabled.

• The last mirror in a volume cannot be disabled.

• When a volume is restarted, any disabled (detached) mirrors should be

reattached to the volume automatically.
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Removing a Mirror From a Volume

Note: Removing a mirror can result in loss of data redundancy.

This procedure removes a mirror from its volume. This breaks the link between

the mirror and its volume and returns the mirror’s disk space to the free space

pool for reuse. You can remove an extra mirror from a volume to make the

underlying disk space available for use elsewhere. However, this may leave the

volume unmirrored and unprotected against disk failure.

▼ To remove a mirror from a volume

1. Select the volume that contains the mirror to be removed.

2. Choose Volumes > Mirror > Remove (Selected menu) or Mirror Remove

(Command Launcher).

3. Complete the Remove Mirror dialog box as follows:

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Removal Method: Specify the mirrors and/or number of mirrors to be

removed:

• To specify how many mirrors should be removed,

select By quantity/disk. Type the number of

mirrors to be removed in the Mirror Quantity field.

• To specify the disk(s) on which mirrors should be

preserved, select By quantity/disk. Type the disk

name(s) in the Preserved Disk(s) field or click

Browse to select a disk.

• To specify the name of the mirror to be removed,

select By mirror. Type the mirror name in the

Mirror Name field or click Browse to select a

mirror.
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When you have provided all necessary information in the dialog box, click

Ok.

Notes:

• This task requires a volume name. This task also requires the number of

mirrors to remove, a disk name, or a mirror name.

• If a volume only has two mirrors and one mirror is removed, the volume is

no longer redundant.

• The last mirror (plex) cannot be removed from a volume.

• When a mirror is removed, the space occupied by that mirror is returned to

the free space pool.
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Removing a Log From a Volume
This procedure removes a log from a mirrored or RAID-5 volume. For a

mirrored volume, this removes a DRL log from the volume. For a RAID-5

volume, this removes a RAID-5 log from the volume.

▼ To remove a log from a volume

1. Select the volume that contains the RAID-5 or DRL log to be removed.

2. Choose Volumes > Log > Remove (Selected menu) or Log Remove

(Command Launcher).

3. Complete the Remove Log dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Removal Method: Specify the logs and/or number of logs to be

removed:

• To specify how many logs should be removed,

select By quantity/disk. Type the number of logs to

be removed in the Log Quantity field.

• To specify the disk(s) on which logs should be

preserved, select By quantity/disk. Type the disk

name(s) in the Preserved Disk(s) field or click

Browse to select a disk.

• To specify the name of the log to be removed, select

By log. Type the log name in the Log Name field or

click Browse to select a log.
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Notes:

• This task requires a volume name.

• If the only log is removed from a volume, logging (either dirty region logging

or RAID-5 logging) is no longer in effect for that volume. When logging is

disabled, recovery time increases.
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Removing a Volume

CAUTION! Removing a volume can result in data loss.

This procedure permanently removes a volume and all of its data. You should

only remove a volume if you are sure that you do not need the data in the

volume (or the data is backed up elsewhere). You can remove a volume to

make the underlying disk space available for use elsewhere.

▼ To remove a volume

1. Select the volume to be removed.

2. Choose Volumes > Remove (Selected menu) or Volume Remove (Command

Launcher).

3. Complete the Remove Volume dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click

Ok.

Volume(s): If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• Removing a volume destroys all of the data in that volume.

• When a volume is removed, the space it occupied is returned to the free

space pool.
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Moving a Subdisk
This procedure moves the contents of a volume’s subdisk from one disk to

another. This is useful for moving portions of a volume to a different disk for

improved performance.

You can use the Volume to Disk Mapping window to view the subdisks and

gaps on disks. To display the Volume to Disk Mapping window for all volumes

in a disk group, click on the disk group and then choose Disk Groups (Selected

menu) > Disk/Volume Map. To display the subdisks and gaps on a disk, click

on the arrow to the left of the disk name.

▼ To move a subdisk to another disk

1. Select the volume with the subdisk to be moved.

2. Choose Volumes > Show Layout (Selected menu).

3. In the Volume Layout Details window, select the subdisk to be moved to

another disk.

4. Choose Subdisks > Move (Selected menu) or Subdisk Move (Command

Launcher).

5. Complete the Move Subdisk dialog box as follows:

Disk Group Name: The name of the disk group that contains the

subdisk to be moved.

Source Subdisks: If the correct subdisk name is not already displayed

in this field, type the subdisk’s name or click

Browse to select the subdisk.

Target Disk Name: Type the name of the disk to which the subdisk

should be moved or click Browse to select a disk.
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When you have provided all necessary information in the dialog box, click

Ok.

Options: • To specify whether the subdisk can be split into

smaller subdisks that fit in available space(s) on the

target disk, select one of the Move Policy options.

The One to One options do not split the subdisk(s).

The Split as Required option splits the subdisk(s).

• To specify the minimum disk offset for the subdisk,

type the offset in the Starting Offset for Gap Search

field.

Notes:

• This task requires a subdisk name and a disk name.

• Subdisks are typically moved to reorganize disk space.

• The disk space occupied by the original subdisk is returned to the free space

pool.

• A subdisk in a mirrored, striped, or RAID-5 volume should not be moved to

a disk that already contains a copy or part of that volume.

• If this task fails and leaves some unused subdisks (that is, subdisks that are

not associated with a volume) on the system, you can use the Remove

Subdisk task to free the space occupied by the unused subdisks.
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Splitting a Subdisk
This procedure divides a subdisk into two or more smaller subdisks. Once

split, the smaller subdisks can be moved elsewhere or rejoined later. This is

useful for reorganizing volumes and/or improving performance.

▼ To split a subdisk into multiple subdisks

1. Select the volume with the subdisk to be split.

2. Choose Volumes > Show Layout (Selected menu).

3. In the Volume Layout Details window, select the subdisk to be split into

multiple subdisks.

4. Choose Subdisks > Split (Selected menu) or Subdisk Split (Command

Launcher).

5. Complete the Split Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Subdisk Name: If the correct subdisk name is not already displayed

in this field, type the subdisk’s name or click

Browse to select the subdisk.

Number of Target

Subdisks:

Type the number of subdisks into which the

subdisk should be split. A subdisk can be split into

two or more subdisks.
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Notes:

• This task requires a subdisk name and the number of subdisks that will result

from the split.

• The name of the first subdisk remains the same as the selected subdisk. Other

subdisks are automatically named by the Volume Manager.

• The new, smaller subdisks occupy the same regions of the disk that the

original subdisk occupied.

• The original subdisk must contain a sufficient number of sectors for the

specified split to work.

• A log subdisk cannot be split.
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Joining Subdisks
This procedure joins two or more subdisks together to form a single, larger

subdisk. Subdisks can only be joined together if they belong to the same

volume and occupy adjacent regions of the same disk and mirror.

▼ To join subdisks

1. Select the volume with the subdisks to be joined.

2. Choose Volumes > Show Layout (Selected menu).

3. In the Volume Layout Details window, select the subdisks to be combined

into a single subdisk.

4. Choose Subdisks > Join (Selected menu) or Subdisk Join (Command

Launcher).

5. Complete the Join Subdisks dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: The name of the disk group that contains the

subdisks to be joined.

Source Subdisks: If the correct subdisk names are not already

displayed in this field, type the subdisk names or

click Browse to select the subdisks. Specify at least

two subdisks.

Target Subdisk

Name:

Type the name of the new, combined subdisk.
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Notes:

• This task requires two or more existing subdisk names and a new (joined)

subdisk name.

• Only contiguous subdisks on the same disk can be joined.

• The subdisks to be joined must belong to the same volume and mirror.

• For a striped volume, the subdisks must be in the same column.

• The joined subdisk name can be the name of one of the subdisks being joined.
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Removing a Subdisk
This procedure removes a subdisk from a disk. This task applies to subdisks

that are not associated with volumes. This provides a way to return the disk

space occupied by unused subdisks to the free space pool.

▼ To remove a subdisk

1. Select the disk with the subdisk to be moved.

2. Choose Disks > Properties (Selected menu).

3. In the Disk Properties window, go to the Subdisks tab and select the

subdisk to be removed.

4. Choose Remove (popup menu) or Subdisk Remove (Command Launcher).

5. Complete the Remove Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Disk Group Name: The name of the disk group that contains the

subdisk to be removed.

Subdisks: If the correct subdisk name is not already displayed

in this field, type the subdisk’s name or click

Browse to select the subdisk.

Notes:

• This task requires a subdisk name.

• You cannot remove a subdisk that is associated with a volume.

• When a subdisk is removed, the space it occupied is returned to the free

space pool.
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Adding a File System to a Volume
This procedure places a file system on an existing volume and mounts the file

system. This also updates the file system table file, if necessary.

▼ To add a file system to an existing volume

1. Select the volume to contain the file system.

2. Choose Volumes > File System > New (Selected menu) or Volume New File

System (Command Launcher).

3. Complete the New File System dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Mount Point: Type the mount point for the file system.

FS Type: Select the file system type.

Options • To mount the file system automatically at system

startup, select Mount at Boot. If this is selected, the

file system table file will also be updated at system

startup.

• To specify mount  options, click Mount Details and

specify the appropriate options in the Mount

Details dialog box.

• To specify mkfs  command options, click Mkfs

Details and specify the appropriate options in the

Mkfs Details dialog box.
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Notes:

• This task requires a volume name and a file system type. If Mount at Boot is

selected, a file system mount point is also required.

• When the file system is mounted, the file system table file is automatically

updated.

• If the path specified for the mount point does not already exist, it is created.

• The mount point must be an absolute pathname (that is, it must begin with

/ ).
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Mounting a File System on a Volume
This procedure mounts a file system that already exists on a volume and

updates the file system table file, if necessary.

▼ To mount a file system on an existing volume

1. Select the volume that contains the file system to be mounted.

2. Choose Volumes > File System > Mount (Selected menu) or Volume Mount

File System (Command Launcher).

3. Complete the Mount File System dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Mount Point: Type the mount point for the file system.

Options: • To mount the file system automatically at system

startup, select Mount at Boot. If this is selected, the

file system table file will also be updated at system

startup.

• To specify mount  options, click Mount Details and

specify the appropriate options in the Mount

Details dialog box.
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Notes:

• This task requires a volume name. If Mount at Boot is selected, a file system

mount point is also required.

• The specified volume must contain a file system.

• The file system table file is automatically updated.

• If the path specified for the mount point does not already exist, it will be

created.

• The mount point must be an absolute pathname (that is, it must begin with

/ ).
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Resizing a File System
This procedure changes the size of a file system and the underlying volume. If

users require more space, you can use this procedure to increase the size of the

file system. If a vxfs file system is too large and you need the space elsewhere,

you can use this procedure to shrink the file system.

▼ To resize a file system on a volume

1. Select the file system to be resized.

2. Choose File Systems > Resize (Selected menu) or File System Resize

(Command Launcher).

3. Complete the Resize File System dialog box as follows:

File System Name: If the correct file system name is not already

displayed in this field, type the file system’s name

or click Browse to select the file system.

New Size: Specify one of the following:

• To increase the file system size by a specific amount

of space, use the Add By field to specify how much

space should be added to the file system.

• To decrease the file system size by a specific

amount of space, use the Subtract By field to

specify how much space should be removed from

the file system.

• To specify the new file system size, type the size in

the Desired Size field.

To specify a size unit, attach an s (sectors), k
(kilobytes), m(megabytes), or g (gigabytes) to the

size.

Options: • To use a specific disk for the additional space, click

Assign Disks and select the disk you want to use

from the Space Allocation - Resize dialog box.
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When you have provided all necessary information in the dialog box, click

Ok.

Notes:

• This task requires a file system name and either the desired size or the

amount of space to add to or subtract from the file system size.

• When the file system is resized, the underlying volume is also resized.

• Only vxfs  file systems can be shrunk.

• The file system to be resized must be on a volume.
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Creating a Snapshot Copy of a File System
This procedure prepares a vxfs file system for online backup by creating a

snapshot copy of the file system. This is done by creating a new volume,

mounting a snapshot file system on the new volume, and copying the contents

of the original file system to the snapshot file system. The snapshot file system

is a consistent copy of the original file system at the time the snapshot was

made. You can use the snapshot file system to make a backup of the original

file system at a convenient time. After the backup is made, you can remove the

snapshot file system by removing the underlying snapshot volume (see

“Removing a Volume”).

▼ To create a snapshot copy of a file system’s data

1. Select the file system to be backed up.

2. Choose File Systems > Snapshot (Selected menu) or File System Snapshot

(Command Launcher).

3. Complete the File System Snapshot dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

File System Name: If the correct file system name is not already

displayed in this field, type the file system’s name

or click Browse to select the file system.

Snapshot Mount

Point:

Type the mount point for the snapshot copy of the

file system.

Snapshot Size: Type the size of the snapshot copy of the file

system.

Options: To place the snapshot on a specific disk(s), click

Assign Disks and select the disks you want to use.
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Notes:

• This task requires a file system name, a snapshot mount point, and a

snapshot size.

• The file system snapshot task is only available for vxfs  file systems.

• The snapshot file system is an exact copy of the original file system at the

time the snapshot was created.

• After you create the snapshot copy of the file system, remember to back it up

to tape or some other media. Remove the snapshot file system when it is no

longer needed.

• Users can continue to use the original file system during this snapshot

backup procedure.

• Refer to the vxfs documentation for guidelines on choosing the snapshot file

system size.
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Unmounting a File System on a Volume
This procedure unmounts a file system.

▼ To unmount a file system on a volume

1. Select the volume containing the file system to be unmounted.

2. Choose Volumes > File System > Unmount (Selected menu) or Volume

Unmount (Command Launcher).

3. Complete the Unmount File System dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• The specified volume must contain a mounted file system.
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Checking a File System on a Volume
This procedure checks an unmounted file system on a volume for consistency

(using the fsck command). This procedure can also attempt to repair the file

system, if necessary.

▼ To check a file system on a volume

1. Select the volume containing the file system to be checked.

2. Choose Volumes > File System > Check (Selected menu) or File System

Check (Command Launcher).

3. Complete the Check File System dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Options: • To check and attempt to repair the file system,

select Check And Repair.

• To check the file system without repairing it, select

Check With No Repair.

Notes:

• The specified volume must contain a file system. The file system should be

unmounted.
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Creating an Accelerator Log on a Volume
This procedure designates a volume as a vxfs file system Accelerator log.

After setting up a volume as an Accelerator log, you can enable the Accelerator

log device for a file system.

▼ To designate a volume as an Accelerator log

1. Select the volume to be used for the file system Accelerator log.

2. Choose Volumes > Accelerator > Make Log (Selected menu) or Volume

Make Log (Command Launcher).

3. Complete the Accelerator Make Log dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Log Device

Number:

Select the number of the log device to be attached

to the volume. Log devices are listed in

/dev/vxld .

Notes:

• This task is only available if the VERITAS Accelerator is installed.

• This task requires a volume name and a log device number.

• Only vxfs  file systems can be used with an Accelerator log.

• The specified volume cannot contain a file system.

• The size of the specified volume must be at least 32M.
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Enabling the Accelerator Log for a File System
This procedure enables the Accelerator log device for a vxfs file system and

remounts the file system. Before you enable an Accelerator log, you need to

designate a volume as an Accelerator log (see “Creating an Accelerator Log on

a Volume”).

▼ To enable an Accelerator log for a file system

1. Select the file system to be remounted with an Accelerator log device

enabled.

2. Choose File Systems > Accelerator > Enable (Selected menu) or File System

Enable Accelerator (Command Launcher).

3. Complete the Enable Accelerator dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

File System

Name:

If the correct file system name is not already

displayed in this field, type the file system’s name or

click Browse to select the file system.

Log Device

Number:

Select the number of the log device to be enabled for

the file system. Log devices are listed in /dev/vxld .

Options: To mount the file system automatically at system

startup, select Mount at Boot.

Notes:

• This task is only available if the VERITAS Accelerator is installed.

• This task requires a file system name.

• Only vxfs  file systems can be used with an Accelerator log.

• The specified log device should already have a designated log volume.

• If no log device number is specified, the least-loaded device is used.
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Disabling the Accelerator Log for a File System
This procedure disables Accelerator logging for a file system and remounts the

file system.

▼ To disable an Accelerator log for a file system

1. Select the file system with the Accelerator log device to be disabled.

2. Choose File Systems > Accelerator > Disable (Selected menu) or File System

Disable Accelerator (Command Launcher).

3. Complete the Disable Accelerator dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

File System Name: If the correct file system name is not already

displayed in this field, type the file system’s name

or click Browse to select the file system.

Notes:

• This task is only available if the VERITAS Accelerator is installed.

• This task requires a file system name.
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Removing an Accelerator Log
This procedure detaches an Accelerator log device from a volume. Before you

remove an Accelerator log, you must disable the log (see “Disabling the

Accelerator Log for a File System”).

▼ To remove an Accelerator log from a volume

1. Select the volume with the Accelerator log device to be detached.

2. Choose Volumes > Accelerator > Remove Log (Selected menu) or Volume

Remove FS Log (Command Launcher).

3. Complete the Accelerator Remove Log dialog box as follows:

When you have provided all necessary information in the dialog box, click

Ok.

Volume Name: If the correct volume name is not already displayed

in this field, type the volume’s name or click

Browse to select the volume.

Notes:

• This task is only available if the VERITAS Accelerator is installed.

• This task requires a volume name.

• The Accelerator log for the file system must be disabled before the

Accelerator log can be detached from a volume.
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Troubleshooting 5
Introduction
This chapter provides information about Storage Administrator object states.

Each state is listed with a brief description and suggestions on how to fix any

underlying problems. If you are unable to resolve a problem by following the

instructions in this chapter, contact Customer Support for additional

information.

The following topics are discussed in this chapter:

• Alerts

• Disk Troubleshooting

• Volume Troubleshooting

Alerts
When an object fails or experiences an error, an alert icon appears on the object

and the object’s state usually changes to an unhealthy state. The unhealthy

object also appears in the Alert Monitor window, which summarizes the

problem and indicates whether any associated objects have problems. When an

object enters an unhealthy state and has an alert, you should review the

contents of the Alert Monitor window and then try to correct the problem. For

more information about an object listed in the Alert Monitor window, review

the object’s Properties window.

▼ To display the Alert Monitor window, click the Alert button in the toolbar

or choose Window > Alerts.
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▼ To view the properties of an object listed in the Alert Monitor window,

select the object and choose Object Properties from the Alert or popup

menu. You can also access object properties by double-clicking on the

object.

Disk Troubleshooting
The disk state indicates the current condition of a disk. The disk state appears

in the state column of the grid and in the Disk Properties window. When a disk

is unhealthy, an alert icon appears on the disk and the disk is listed in the Alert

Monitor window. This section describes each disk state and provides

suggestions on how to correct problems associated with the unhealthy states.

This section provides information about the following disk states:

• Disk State: Imported

• Disk State: Free

• Disk State: Not Setup

• Disk State: Import Failed

• Disk State: Disconnected

• Disk State: Deported

• Disk State: Offline

• Disk State: Not Initialized

• Disk State: Locked

• Disk State: Inactive

• Disk State: Foreign Owned

Disk State: Imported

The disk is accessible and has no known problems. The disk is under Volume

Manager control and belongs to a disk group. This is the normal disk state.

No user action is required.
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Disk State: Free

The disk is in the Free Disk Pool. A disk in the Free Disk Pool is under Volume

Manager control, but has not been added to a disk group.

▼ To make the disk available for Volume Manager use, add the disk to a disk

group.

Disk State: Not Setup

The disk is not under Volume Manager control.

▼ To make the disk available for Volume Manager use, place the disk under

Volume Manager control and add the disk to a disk group.

Disk State: Import Failed

The disk was previously under Volume Manager control, but the Volume

Manager cannot access the disk and/or configuration information for the disk.

The disk is not available for use. This may happen after you upgrade the

Volume Manager.

▼ If the disk group is imported and the disk does not have a Volume Manager

disk name, place the disk under Volume Manager control and add the disk

to a disk group.

Disk State: Disconnected

The connection between the Volume Manager disk and the underlying physical

disk (device) is broken. This can occur when a disk fails or when you remove a

disk from its disk group.

▼ Make sure that the physical disk is turned on, plugged in, and attached to

the computer. Repair any disk, controller, or cable problems. Scan the disks

on the system (using the Scan Disks task) to make sure that the Volume

Manager recognizes any newly attached hardware.

▼ If you cannot fix the problem, replace the disk with another physical disk.
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Disk State: Deported

The disk belongs to a disk group that is currently deported. The disk is not

available for use in the deported disk group and cannot be added to a new

disk group.

▼ To return the disk to a usable state, import the disk’s disk group.

▼ To move the disk to another disk group, import the current disk group,

remove the disk, and add the disk to a new disk group.

▼ If the disk group import fails and you want to free the disk’s space for use

in other disk groups, you can use the following command to reinitialize the

disk:

vxdisk -f init device_name

Note: This command overwrites the disk header and configuration

information on the disk. Any volume copies or regions located on the disk will

not be accessible after you reinitialize the disk.

Disk State: Offline

The disk cannot be accessed by the Volume Manager.

▼ To return the disk to an accessible state, bring the disk online.

Disk State: Not Initialized

A configuration error is preventing the disk from being used.

▼ To make the disk available for Volume Manager use, place the disk under

Volume Manager control and add the disk to a disk group.

▼ If the disk cannot be added to the Volume Manager via the Storage

Administrator, it may be necessary to reinitialize the disk with the

following command:

vxdisk -f init device_name

Note: This command overwrites the disk header and configuration

information on the disk. Any volume copies or regions located on the disk will

not be accessible after you reinitialize the disk.
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Disk State: Locked

The disk belongs to a disk group that is currently imported by another

machine or was last imported by another machine and was not deported

cleanly. The disk is not currently usable on the local machine.

▼ To make all of the disks in the disk group available for use on the local

machine, deport the disk group on the remote machine and then import the

disk group on the local machine.

▼ To make one disk available for use on the local machine, remove the disk

from its disk group (on the other machine) and add it to a disk group on the

local machine.

▼ If the disk group is not imported on another machine, it may be necessary to

reimport the disk group and clear the host ID on all disks in the disk group.

You can do this by selecting the Clear Host ID option in the Import Disk

Group dialog box or by running the following command:

vxdg -C import disk_group

Note: If any of the disks in the disk group are in use by another machine, this

command can cause the disks to be managed by two systems at the same time

(which could lead to corruption).

Disk State: Inactive

The disk appears to belong to a disk group, but is not active in the disk group.

The disk may have become (temporarily) inaccessible. Alternatively, the disk

may have been inaccessible at disk group import, but may be accessible now.

▼ Make sure that the physical disk is turned on, plugged in, and attached to

the computer. Repair any disk, controller, or cable problems. Scan the disks

on the system (using the Scan Disks task) to make sure that the Volume

Manager recognizes any newly attached hardware.

▼ It may be necessary to reattach the disk to its disk group by running the

following command:

/etc/vx/bin/vxreattach [ device_name]

After a successful reattach, volume recovery may be necessary.
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▼ If the reattach fails and you want to free the disk’s space for use, you can

use the following command to reinitialize the disk:

vxdisk -f init device_name

Note: This command overwrites the disk header and configuration

information on the disk. Any volume copies or regions located on the disk will

not be accessible after you reinitialize the disk.

Disk State: Foreign Owned

The disk is under the control of another disk management product. The disk is

not available for use with the Volume Manager.

▼ To make the disk available for Volume Manager use, remove the disk from

the other disk management product’s control and place the disk under

Volume Manager control.
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Volume Troubleshooting
The volume state indicates the current condition of a volume. The volume state

appears in the state column of the grid and in the Volume Properties window.

When a volume is unhealthy, an alert icon appears on the volume and the

volume is listed in the Alert Monitor window. This section describes each

volume state and provides suggestions on how to correct problems associated

with the unhealthy states.

This section provides information about the following volume states:

• Volume State: Started

• Volume State: Stopped

• Volume State: Uninitialized

• Volume State: Degraded

• Volume State: Unusable

Volume State: Started

The volume is accessible and has no known problems. This is the normal

volume state. No user action is required.

Volume State: Stopped

The volume is disabled and is not available for use.

▼ To return the volume to a usable state, start the volume.

Volume State: Uninitialized

The volume is enabled, but is not initialized. If this state appears during

volume creation, no user action is necessary.

▼ To put the volume in a usable state, start the volume.
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Volume State: Degraded

The RAID-5 volume is in a degraded mode. This usually occurs when one or

more subdisks are unavailable and read requests require data reconstruction.

An underlying disk may have failed completely or there may be I/O errors on

part of a disk. Alternatively, an underlying disk may be disconnected.

▼ Make sure that the physical disks are turned on, plugged in, and attached to

the computer. Repair any disk, controller, or cable problems. Scan the disks

on the system (using the Scan Disks task) to make sure that the Volume

Manager recognizes any newly attached hardware.

To return the RAID-5 volume to a healthy state, recover the volume.

▼ If there has been a partial or complete disk failure, either replace the disk or

move the affected subdisks to another disk.

Volume State: Unusable

The RAID-5 volume is unusable. This usually occurs when there is a double

disk failure (that is, when two subdisks in the same stripe or the parity and one

subdisk in a stripe are damaged or inaccessible). The underlying disks may

have failed or become inaccessible.

▼ Make sure that the physical disks are turned on, plugged in, and attached to

the computer. Repair any disk, controller, or cable problems. Scan the disks

on the system (using the Scan Disks task) to make sure that the Volume

Manager recognizes any newly attached hardware.

Run the following command to reattach the disks to their disk group:

/etc/vx/bin/vxreattach [ device_name]

To return the RAID-5 volume to a healthy state, recover the volume.

▼ If two of the volume’s disks have failed, the RAID-5 volume’s data is

unusable. Replace the failed disks and then try to restart the volume by

running the following command:

vxvol -f start volume_name

Restore the volume from backup.

To prevent this problem in the future, enable logging for RAID-5 volumes.
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alert
An indication that an error or failure has occurred on an object on the system.

When an object fails or experiences an error, an alert icon appears.

alert icon
An icon that indicates that an error or failure has occurred on an object on the

system. Alert icons usually appear in the status area of the main window and

on the affected object’s group icon.

Alert Monitor
A window that provides information about objects that have failed or

experienced errors.

browse dialog box
A dialog box that is used to view and/or select existing objects on the system.

Most browse dialog boxes consist of a tree and grid.

button
A window control that the user clicks to initiate a task or display another

object (such as a window or menu).

check box
A control button used to select optional settings. A check mark usually

indicates that a check box is selected.

children
Objects that belong to an object group.
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Command Launcher

A window that displays a list of tasks that can be performed on Volume

Manager or other objects. Each task is listed with the object type, task (action),

and a description of the task. A task is launched by clicking on the task in the

Command Launcher. The Command Launcher can be separated from or

attached to the main window.

command log
A log file that contains a history of Volume Manager Storage Administrator

tasks performed in the current session and previous sessions. Each task is

listed with the task originator, the start/finish times, the task status, and the

low-level commands used to perform the task.

dialog box
A window in which the user submits information to the Volume Manager

Storage Administrator. Dialog boxes can contain selectable buttons and/or

fields that accept information.

dock
To separate or attach the main window and a subwindow.

graphical view
A window that displays a graphical view of objects. In the Storage

Administrator, the graphical view is called the Volume Layout Details window.

See Volume Layout Details window.

grid
A tabular display of objects and their properties. The grid lists Volume

Manager objects, disks, controllers, or file systems. The grid displays objects

that belong to the group icon that is currently selected in the object tree. The

grid is dynamic and constantly updates its contents to reflect changes to

objects.

group icon
The icon that represents a specific object group.

launch
To start a task or open a window.

main window
The main Volume Manager Storage Administrator window. This window

contains a tree and grid that display volumes, disks, and other objects on the

system. The main window also has a menu bar, a toolbar, and an optional

Command Launcher.
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menu
A list of options or tasks. A menu item is selected by pointing to the item and

clicking the mouse.

menu bar
A bar that contains a set of menus for the current window. The menu bar is

typically placed across the top of a window.

object group
A group of objects of the same type. Each object group has a group icon and a

group name. In the Storage Administrator, object groups include disk groups,

disks, volumes, controllers, free disk pool disks, uninitialized disks, and file

systems.

object tree
A dynamic hierarchical display of Volume Manager objects and other objects

on the system. Each node in the tree represents a group of objects of the same

type.

popup menu
A context-sensitive menu that only appears when you click on a specific object

or area.

properties window
A window that displays detailed information about a selected object.

radio buttons
A set of buttons used to select optional settings. Only one radio button in the

set can be selected at any given time. These buttons toggle on or off.

scroll bar
A sliding control that is used to display different portions of the contents of a

window.

Search window
The Storage Administrator search tool. The Search window provides a set of

search options that can be used to search for objects on the system.

Selected menu
A context-sensitive menu that changes its menu options to match the type of

object that is selected. By default, the Selected menu is greyed out. When an

object is selected, the Selected menu provides access to tasks appropriate for

the selected object.

splitter
A bar that separates two panes of a window (such as the object

tree and the grid). A splitter can be used to adjust the sizes of the panes.
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status area
An area of the main window that displays an alert icon when an object fails or

experiences some other error.

task properties window
A window that displays detailed information about a task listed in the Task

Request Monitor window.

Task Request Monitor

A window that displays a history of tasks performed in the current Storage

Administrator session. Each task is listed with the task originator, the task

status, and the start/ finish times for the task.

toolbar
A set of buttons used to access Volume Manager Storage Administrator

windows. These include another main window, a task request monitor, an alert

monitor, a search window, and a customization window.

tree
A dynamic hierarchical display of objects on the system.

See object tree.

Volume Layout Details window
A window that displays a graphical view of a volume and its components.

Tasks can be performed on objects in this window. The objects displayed in this

window are not automatically updated when the volume’s properties change.
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A
Accelerator logs, 150, 151

accessing tasks, 31

adding disks, 59

adding file systems, 140

alert monitor, 52

alerts, 8, 52, 155

detecting, 52

icons, 52

monitoring, 52

on disks, 156

on volumes, 161

Alerts button, 7

B
backup

file system, 146

boot disk, 61

mirroring, 69

setup tasks, 13

browse dialog boxes, 35

buttons

in dialog boxes, 35

toolbar, 7

C
changing volume layouts, 112
checking file systems, 149

color

preference settings, 46

Command Launcher, 8, 33

command log, 40

commands

displaying, 37

viewing, 37

concatenated volumes, 96, 97, 101

Console menu, 6

Create button, 7

Create menu, 31

creating disk groups, 78

creating file systems, 140

creating volumes, 96, 101, 103, 105, 107

Customize button, 8

D
deporting disk groups, 82

destroying disk groups, 87

dialog boxes, 35

browse, 35

buttons, 35

input size units, 37

selecting objects, 35

dirty region logging, 118

disabling mirrors, 127

disk group name
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changing, 81

disk group tasks, 55

roadmap, 57

disk group versions, 80

disk groups

adding disks, 59, 62

creating, 78

deporting, 82

destroying, 87

importing, 84

moving, 89

preventing access, 82

recovering volumes, 86

removing, 87

removing disks, 76

renaming, 81

restoring access, 84

task roadmap, 57

upgrading, 80

disk names

changing, 66

disk setup tasks, 13

disk states, 156

disk task roadmap, 57

disk tasks, 55

roadmap, 57

disks

adding, 59

adding to disk group, 62

adding to Volume Manager, 59

alternate boot disk, 69

boot, 61, 69

encapsulating, 60

evacuating, 71

free disk pool, 5

hot-relocation spares, 64

initializing, 60

maintenance tasks, 14

mirroring, 69

moving contents, 71

new, 59

offline, 67

online, 68

placing under Volume Manager

control, 59

preventing access, 67

recovering, 75

removing, 76

renaming, 66

replacing, 73

restoring access, 68

root, 61

scanning, 59

task roadmap, 57

uninitialized, 5

Volume Manager, 59

volume mapping, 23

displaying commands, 37

displaying object properties, 29

displaying objects, 23

E
encapsulating disks, 60

errors

see alerts
evacuating disks, 71

F
file system size

changing, 144

file system task roadmap, 95

file system tasks, 91

roadmap, 95

file systems

and volumes, 140, 142

backup, 146

checking, 149

creating, 140

maintenance tasks, 15

repair tasks, 16

repairing, 149

resizing, 144
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setup tasks, 14

snapshot copies, 146

task roadmap, 95

unmounting, 148

fonts

preference settings, 45

free disk pool, 5

G
graphical view, 23, 26

preference settings, 48

grid, 5, 23, 24

preference settings, 47

Grid button, 7

H
help, 6

Help menu, 6

hot-relocation, 64

I
icons, 9

alerts, 52

errors, 52

importing disk groups, 84

initializing disks, 60

input

size units, 37

installation, 13

J
joining subdisks, 137

L
layered volumes, 97

logging, 118

disabling, 130

logs

Accelerator, 150, 151

adding to volumes, 118

command log, 40

disabling, 130

DRL, 118

RAID-5, 119

removing, 130

task log, 40

M
main window, 3

preference settings, 45

main window status area, 8

maintenance tasks, 14

menu bar, 6

accessing tasks, 31

menus, 6, 31

Console, 6

context-sensitive, 6, 32

Create, 31

Help, 6

Options, 6, 41

popup, 32

preferences, 6, 41

Selected, 6, 31

Window, 6

mirror tasks, 91

mirrored volumes, 97, 107

mirroring disks, 69

mirroring volumes, 107, 116

mirrors

adding to volumes, 116

detaching, 127

disabling, 127

removing, 128

repairing, 126

monitoring alerts, 8, 52

monitoring tasks, 37

mounting file systems, 142
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moving disk groups, 89

moving subdisks, 133

O
object properties

displaying, 29

in grid, 24

object properties window, 23, 29

object states, 155

object tree, 5

objects

displaying, 23

searching, 50

selecting, 23, 35

sorting, 25

viewing, 23

offline disks, 67

online disks, 68

Options menu, 6, 41

P
placing disks under Volume Manager

control, 59

plexes

see mirrors
popup menus, 32

preferences, 8, 41

color, 46

fonts, 45

general, 44

main window, 45

Options menu, 6

saving, 8

setting, 6, 41

shortcuts, 49

toolbar, 48

tree and grid, 47

volume layout details window, 48

window size, 47

preferences window, 41

properties, 29

in grid, 24

in properties window, 29

Properties button, 7

properties window, 23, 29

R
RAID-5 logging, 118

RAID-5 volumes, 96, 105

recovering disks, 75

recovering volumes, 75, 86, 125

recovery, 16

disk, 75

volume, 75, 86, 125

recovery tasks, 15

relayout, 112

remote administration, 2

removing disk groups, 87

removing disks, 76

removing logs, 130

removing mirrors, 128

removing volumes, 132

renaming disk groups, 81

renaming disks, 66

renaming volumes, 111

repairing mirrors, 126

replacing disks, 73

resizing file systems, 144

resizing volumes, 109

root disk, 61

mirroring, 69

setup tasks, 13

running tasks, 31

S
Save button, 8

scanning disks, 59

Search button, 7
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search window, 50

searching, 50

security, 2, 18

Selected menu, 6, 31

selecting objects, 23, 35

setup tasks, 13

shortcuts

for preference settings, 49

size units

input, 37

snapshot copies of file systems, 146

snapshot copies of volumes, 122

snapshots, 122, 146

sorting objects, 25

spare disks, 64

splitter, 5

splitting subdisks, 135

starting the Storage Administrator, 19

starting volumes, 121

states

object, 155

status area, 8

stopping volumes, 120

Storage Administrator, 1

features, 2

installation, 18

main window, 3

starting, 19

striped volumes, 96, 97, 103

subdisk tasks, 91

subdisks

graphical view, 26

joining, 137

moving, 133

removing, 139

splitting, 135

viewing, 26

T
Task button, 7

task history, 37

task launcher, 8

task log, 40

task monitor, 37

task request monitor, 37

tasks

accessing, 31

Command Launcher, 8

disk, 55

disk group, 55

disk maintenance, 14

disk setup, 13

displaying, 37

file system, 91

file system maintenance, 15

from Command Launcher, 33

from menus, 31, 32

list, 13

maintenance, 14

mirror, 91

monitoring, 37

properties, 38, 39

recovery, 15

repair, 15

roadmap, 13

running, 31

setup, 13

subdisk, 91

underlying commands, 38, 39

viewing, 37

volume, 91

volume maintenance, 15

volume recovery, 16

volume repair, 16

volume setup, 14

toolbar, 7

Alerts button, 7

Create button, 7

Customize button, 8

Grid button, 7
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preference settings, 48

Properties button, 7

Save button, 8

Search button, 7

Storage Administrator button, 7

Task button, 7

VMSA button, 7

tree, 5, 23, 24

preference settings, 47

troubleshooting, 155

disk states, 156

volume states, 161

U
uninitialized disks, 5

unmounting file systems, 148

user preferences, 41

V
viewing commands, 37

viewing objects, 23

graphical view, 26

properties, 29

tree/grid, 24

volume layout details window, 23, 26

preference settings, 48

volume layouts, 96, 112

Volume Manager Storage Administrator, 1

volume name

changing, 111

volume size

changing, 109

volume states, 161

volume task roadmap, 93

volume tasks, 91

roadmap, 93

volume to disk mapping window, 23

volumes

adding file systems, 140

adding logs, 118

adding mirrors, 116

and file systems, 140, 142

backup and restore, 124

changing layout, 112

concatenated, 96, 97, 101

creating, 7, 96, 101, 103, 105, 107

detaching mirrors, 127

disabling, 120

disk mapping, 23

enabling, 121

graphical view, 23, 26

joining subdisks, 137

layered, 97

layout, 23

maintenance tasks, 15

mirrored, 97, 107

mounting file systems, 142

moving subdisks, 133

preparing to restore, 124

RAID-5, 96, 105

reattaching mirrors, 126

recovering, 75, 86, 125

recovery tasks, 16

relayout, 112

removing, 132

removing logs, 130

removing mirrors, 128

renaming, 111

repair tasks, 16

repairing mirrors, 126

resizing, 109

setup tasks, 14

snapshot copies, 122

splitting subdisks, 135

starting, 121

stopping, 120

striped, 96, 97, 103

task roadmap, 93

underlying disks, 23

unmounting file systems, 148
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W
Window menu, 6

windows

alert monitor, 52

graphical view, 26

main window, 3

object properties, 23, 29

preferences, 41, 43

resizing, 5, 47

search, 50

setting size preferences, 47

task request monitor, 37

volume layout details, 26

volume to disk mapping window, 23
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