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Preface
Introduction
This guide describes how to use the VERITAS Volume Manager Storage Administrator™.

The Volume Manager Storage Administrator (VMSA) is the Graphical User Interface

(GUI) for the VERITAS Volume Manager™.

Audience
This guide is intended for system administrators responsible for configuring and

maintaining systems using the VERITAS Volume Manager.

This guide assumes:

◆ A basic understanding of system administration

◆ A working knowledge of the UNIX operating system

◆ Familiarity with the VERITAS Volume Manager and related concepts

Organization
This guide is organized as follows:

◆ Chapter 1, “Introduction to the Storage Administrator,” describes the main

components of the Volume Manager Storage Administrator.

◆ Chapter 2, “Getting Started,” describes how to set up and start using the Storage

Administrator.

◆ Chapter 3, “Disk Tasks,” describes how to set up and use disks with the Storage

Administrator.

◆ Chapter 4, “Volume Tasks,” describes how to create and use volumes and related

objects with the Storage Administrator.

◆ Chapter 5, “Host and Cluster Tasks,” describes how to access and use hosts and

clusters with the Storage Administrator.
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Related Documents
◆ Chapter 6, “Troubleshooting,” provides information about Storage Administrator

alerts, object states, and other troubleshooting topics.

◆ The Glossary defines terms that relate to the Storage Administrator.

Related Documents
The following documents provide related information:

◆ VERITAS Volume Manager Administrator’s Guide

◆ VERITAS Volume Manager Reference Guide

◆ VERITAS Volume Manager Installation Guide

◆ VERITAS Volume Manager and Storage Administrator manual pages
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Conventions
Conventions
The following table describes the typographic conventions used in this guide.

The following table describes terms associated with the use of the mouse:

Typeface Usage Examples

courier Computer output;  user input;

names of commands, files, and

directories

$ You have mail.

The cat  command displays files.

$ ls -a

italics New terms;  document titles;

words to be emphasized; variables

to be substituted with a real name

or value

$ cat filename

Refer to the User’s Guide for details.

Term Definition

Click Press and release the mouse button.

Double-click Click the mouse button twice (quickly).

Right-click Press and release the right mouse button.

Press and Hold Press and continue to hold down the mouse button.

Point Move the tip of the pointer onto an item on the screen.

Select Click the mouse button while the pointer is directly over the item

to be selected.

Drag Slide the mouse while pressing a mouse button.
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Introduction to the
Storage Administrator
 1

Introduction

This chapter provides a brief introduction to the VERITAS Volume Manager Storage

Administrator. This chapter describes the main components of the Storage Administrator

and contains a summary of common tasks.

The following topics are discussed in this chapter:

◆ The Volume Manager Storage Administrator

◆ Storage Administrator Features

◆ The Main Window

◆ The Object Tree and Grid

◆ The Menu Bar

◆ The Toolbar

◆ The Status Area

◆ The Command Launcher

◆ Storage Administrator Icons

◆ Task Roadmap

◆ Setup Tasks

◆ Maintenance Tasks

◆ Repair/Recovery Tasks
1



The Volume Manager Storage Administrator
The Volume Manager Storage Administrator
The VERITAS Volume Manager Storage Administrator is the graphical user interface for

the Volume Manager. You can use the Storage Administrator to administer disks,

volumes, and file systems on local or remote machines.

The Storage Administrator is a Java based interface that consists of a server and a client.

The Storage Administrator server runs on a UNIX machine that is running the VERITAS

Volume Manager. The Storage Administrator client runs on any machine that supports the

Java Runtime Environment.

Storage Administrator Features

The Volume Manager Storage Administrator provides the following features:

◆ Ease of Use

The Storage Administrator is a task-based user interface that provides access to tasks

through menus or a task list. With the Storage Administrator, administrators can

easily navigate and configure their systems. Administrators can use the Storage

Administrator to browse through all of the objects on the system or view detailed

information about a specific object.

◆ Remote Administration

With the Storage Administrator, administrators can perform Volume Manager

administration remotely or locally. The Storage Administrator client runs on UNIX or

Windows machines.

◆ Java Based Interface

The Storage Administrator client is a pure Java based interface. Administrators can

run the Storage Administrator as a Java application.

◆ Scalability

The Storage Administrator can handle systems containing a large number of disks.

Administrators can view all of the objects on the system or focus on a specific object or

set of objects.

◆ Security

The Storage Administrator can only be run by users with appropriate privileges.

Administrators can restrict the use of the Storage Administrator to a specific set of

users. The Storage Administrator does not support communication between the client

and server across a firewall.
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The Volume Manager Storage Administrator
◆ Read-only Mode

Administrators can run the Storage Administrator in read-only mode, which is useful

for monitoring, training, or browsing purposes. Read-only mode allows

administrators to view objects on the system, but prevents administrative actions

from taking effect.

◆ Multiple Host Support

The Storage Administrator client can provide simultaneous access to multiple host

machines. The administrator can use a single Storage Administrator client session to

connect to multiple hosts, view the objects on each host, and perform administrative

tasks on each host. Each host machine must be running the Storage Administrator

server.

◆ Multiple Views of Objects

The Storage Administrator provides multiple views of objects:

◆ The main window’s tree and grid view lists objects on the system.

◆ The Object View window displays a graphical view of volumes, disks, and other

objects in a disk group.

◆ The Volume Layout Details window displays a close-up graphical view of a single

volume and its components.

◆ The Volume to Disk Mapping window shows the relationships between volumes

and their underlying disks.
Chapter 1, Introduction to the Storage Administrator 3



The Main Window
The Main Window
The Volume Manager Storage Administrator’s main window (see Figure 1) consists of:

◆ a hierarchical tree of objects

◆ a grid that lists objects and their properties

◆ a menu bar

◆ a toolbar

◆ a status area

◆ a Command Launcher (hidden by default)

The toolbar and Command Launcher can be separated from and reattached to the main

window (this is known as docking). The grid can be replicated in a separate window.
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The Main Window
Figure 1. Main Window

Menu Bar

Toolbar

Object Tree

Grid

Command
Launcher

Status Area

Splitters

(optional)
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The Main Window
The Object Tree and Grid

The Storage Administrator’s main window is divided into two main panes:

◆ Left Pane (Object Tree)

The left pane contains the object tree, which is a dynamic hierarchical display of

Volume Manager objects and other objects on the system. Each node in the tree

represents a group of objects of the same type. Each object group has a group icon and

a group name.

The following object groups typically appear as nodes in the object tree:

◆ Hosts – Any host machines connected to the current Storage Administrator client

session.

◆ Controllers – All controllers on the system.

◆ Disk Groups – All disk groups on the system.

◆ Disks – All disks on the system.

◆ Enclosures – All enclosures (disk arrays) on the system.

◆ File Systems – All mounted file systems on the system.

◆ Free Disk Pool – Any disks that are under Volume Manager control, but do not

belong to a disk group.

◆ Uninitialized Disks – Any disks that are not under Volume Manager control.

◆ Volumes – All volumes on the system.

◆ Clusters (optional) – Sets of hosts that share sets of disks. Clusters are only visible

in a cluster environment with the optional Volume Manager cluster functionality.

You can expand nodes (by clicking on the plus sign) to reveal the hierarchy under

each node. When you select a group icon (or node) in the object tree, objects of that

type appear in the right pane.

◆ Right Pane (Grid)

The right pane contains a grid, which is a tabular display of objects and their

properties. The grid displays objects that belong to the group icon that is currently

selected in the object tree (left pane). The grid is dynamic and constantly updates its

contents to reflect changes to objects.

You can sort the contents of a property column in the grid by clicking on the column

heading. You can reverse the sort order by clicking on the column heading again.

The splitter is the vertical bar that separates the object tree from the grid. You can resize

the left and right panes by pressing and holding the mouse button over the splitter and

dragging the splitter to the left or right.
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The Main Window
The Menu Bar

The menu bar at the top of the main window contains the following menus:

◆ File

The File menu provides access to the New menu, which creates volumes, disk groups,

and file systems. The File menu also establishes new host connections, prints the

contents of the main window, closes the main window, provides access to an object

Properties window, or exits the Storage Administrator.

◆ Options

The Options menu provides access to the Customize window, which displays and sets

user preferences for the components of the Storage Administrator. The Options menu

also saves or loads user preferences, removes any alert icons from the status area, and

sets the Storage Administrator to read-only mode.

◆ Window

The Window menu opens (launches) another Storage Administrator main window,

the Task Request Monitor window, the Alert Monitor window, the Object Search

window, a copy of the main grid, or the Command Launcher.

◆ Selected (context sensitive)

The Selected menu is a context-sensitive menu that launches tasks on a selected

object. The Selected menu is dynamic and changes its options based on the type of

object that is selected. By default, the Selected menu is greyed out. When an object is

selected, the Selected menu is renamed and provides access to tasks appropriate for

the selected object. For example, Selected becomes Volumes when a volume is

selected. The Volumes menu provides access to volume tasks.

◆ Help

The Help menu provides access to online help for the Storage Administrator.
Chapter 1, Introduction to the Storage Administrator 7



The Main Window
The Toolbar

The toolbar consists of the following set of buttons:

◆ Volume Manager Storage Administrator

The Volume Manager Storage Administrator (VMSA) button launches an additional

Storage Administrator main window.

◆ Task

The Task button launches the Task Request Monitor window. The Task Request

Monitor window displays a list of tasks performed in the current session. Each task is

listed with the user who performed the task, the task status, and the start and finish

times for the task.

◆ Alert

The Alert button launches the Alert Monitor window. The Alert Monitor window

identifies any objects that have experienced failures or errors and describes the

problem(s). When an object fails or experiences an error, an alert icon appears in the

status area of the main window and/or on the object’s icon.

◆ Search

The Search button launches the Object Search window, which is used to search for

objects on the system. The Object Search window contains a set of tabbed pages, each

of which contains search options for a particular type of object.

◆ Grid

The Grid button launches a window that contains a copy of the main grid. The new

grid window continues to display and update the objects shown when the grid copy

was created.

◆ New

The New button launches the New Volume dialog box. This dialog box is used to

create a volume.

◆ Host

The Host button launches the Connect to Host dialog box. This dialog box is used to

establish a connection to a host machine.

◆ Properties

The Properties (Props) button launches the Object Properties window for a selected

object. The Object Properties window displays detailed information about the

selected object and related objects.
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The Main Window
◆ Print

The Print button launches the Print dialog box for a selected object. This dialog box is

used to print details about a specific object.

◆ Customize

The Customize (Custm) button launches the Customize window, which is used to set

user preferences. The Customize window allows you to customize the appearance of

the components of the Storage Administrator. The Customize window contains a set

of tabbed pages, each of which contains preference options for a particular aspect of

the Storage Administrator.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to

separate the toolbar from the main window or move the toolbar to the bottom, side, or top

of the main window. To reposition the toolbar, press and hold the mouse button over the

toolbar handle and drag the toolbar to its new location.

The Status Area

The status area is at the bottom of the main window. When an object fails or experiences

an error, an alert (error) icon appears in the status area. The Alert Monitor window

provides details about the error. You can access the Alert Monitor window by clicking on

the alert icon in the status area.

The Command Launcher

The Command Launcher displays a list of tasks that can be performed on objects. Each

task is listed with the object type, the command (action), and a description of the task.

When you click on a task in the Command Launcher list, the task is launched (started) and

the dialog box for the task appears.

The Command Launcher is hidden by default. You can display or hide the Command

Launcher by choosing Window > Command Launcher. You can separate or attach the

Command Launcher and the main window by choosing Options > Customize and

clicking Dock Command Launcher in the Customize window’s Main Window tab.

The splitter is the horizontal bar that separates the Command Launcher from the object

tree and grid. When the Command Launcher is attached to the main window, you can

adjust the Command Launcher height by placing the pointer over the horizontal splitter

and then pressing and holding the mouse button to drag the splitter to the desired

position.

You can sort the items listed in the Command Launcher by object type, command, or task

description by clicking on the appropriate column heading. You can reverse the sort order

by clicking on the column heading again.
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Storage Administrator Icons
Storage Administrator Icons
The following table shows icons that appear in the Storage Administrator.

Icon Description

Object Icons:

Volume Manager

host

disconnected host

disk

free disk

uninitialized disk

foreign disk

offline disk

disk group

deported disk group

shared disk group
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Storage Administrator Icons
volume

root/boot volume

plex

mirror

log

subdisk

controller

enclosure (disk array)

subpath (Dynamic Multipathing)

file system

cluster

cluster node (host)

QuickLog file system

Icon Description
Chapter 1, Introduction to the Storage Administrator 11



Storage Administrator Icons
QuickLog volume

Object View Icons:

concatenated layout

striped layout

RAID-5 layout

concatenated pro layout

striped pro layout

mirrored layout

mixed layout

Toolbar Icons:

Storage Administrator window

Task Request Monitor window

Alert Monitor window

Icon Description
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Storage Administrator Icons
Search window

Grid Copy window

New Volume dialog box

Host connection dialog box

Object Properties window

Print dialog box

Customize window

expand disks

collapse disks

expand volumes

collapse volumes

Icon Description
Chapter 1, Introduction to the Storage Administrator 13



Storage Administrator Icons
projection

Task Status Icons:

task in progress

successful task

failed task

paused task

cancelled task

exited task

Performance Monitoring Icons:

slowest response time

slow response time

default

Icon Description
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Storage Administrator Icons
Miscellaneous Icons:

alert

error message

information

question

warning

Command Launcher task

customization change

check mark

Icon Description
Chapter 1, Introduction to the Storage Administrator 15



Task Roadmap
Task Roadmap
This section provides a summary of common Volume Manager Storage Administrator

tasks. The tasks are grouped into setup tasks, ongoing maintenance tasks, and repair or

recovery tasks. The procedures for these and other tasks are included in later chapters.

Setup Tasks

If you are using the Volume Manager and the Storage Administrator for the first time, you

need to install both products, place your disks under Volume Manager control, and create

volumes.

▼ To install and set up the Storage Administrator

◆ Install and initialize the Volume Manager.

◆ Install the Storage Administrator.

◆ Start the Storage Administrator.

These tasks are described in Chapter 2 and the VERITAS Volume Manager Installation
Guide.

▼ To set up disks

◆ Place uninitialized disks under Volume Manager control.

◆ Create additional disk groups for the new disks (optional).

◆ Designate one or more disks as hot-relocation spares (optional).

These tasks are described in Chapter 3.

▼ To set up volumes and file systems

◆ Create volumes.

◆ Place file systems on volumes (optional).

◆ Create mirrors for any volumes that need to be redundant.

These tasks are described in Chapter 4.

▼ To access hosts and clusters

◆ Connect to additional host machine(s).

◆ Create shared disk groups.

These tasks are described in Chapter 5.
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Task Roadmap
Maintenance Tasks

After you have set up your disks and volumes, you may need to perform some or all of

the following maintenance tasks.

▼ To monitor objects

◆ Use the main window’s tree (left pane) and grid (right pane) to view disks, volumes,

file systems, and other objects on the system.

◆ Use the Object View window to display a graphical view of disks, volumes, and other

objects in a particular disk group.

◆ Use the Volume to Disk Mapping window to view the relationships between volumes

and their underlying disks.

◆ Use the Volume Layout Details window to display a graphical view of a particular

volume and its components.

◆ Use the object Properties window to view detailed information about a selected

object.

◆ Use the Alert Monitor window to view information about errors or failures associated

with objects that are marked with alert icons.

These windows are described in Chapter 2.

▼ To maintain disks

◆ Place more disks under Volume Manager control.

◆ Create more disk groups.

◆ Upgrade disk groups to the current disk group version.

These tasks are described in Chapter 3.

▼ To maintain volumes

◆ Increase the size of volumes as users and applications require more space.

◆ Change the layouts of volumes.

◆ Add mirrors to any unmirrored volumes that should be redundant.

◆ Create snapshot copies of volumes and then back up the volumes.

◆ Reorganize the space occupied by volumes (by moving subdisks to other disks).

These tasks are described in Chapter 4.
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Task Roadmap
▼ To maintain file systems

◆ Place additional file systems on volumes.

◆ Increase the size of file systems as users and applications require more space.

◆ Create snapshot copies of vxfs  file systems and then back up the file systems.

These tasks are described in Chapter 4.

Repair/Recovery Tasks

If disk and/or system failures occur, the Volume Manager may perform any necessary

recovery operations automatically. However, depending on the circumstances, you may

need to attempt to recover from the situation as follows.

▼ To protect volumes from disk failure

◆ Evacuate a failing disk.

◆ Replace a failed disk.

These tasks are described in Chapter 3.

▼ To repair/recover volumes

◆ Recover a volume.

◆ Recover all volumes on a failed disk.

◆ Recover all volumes in a disk group.

◆ Start a volume.

◆ If a volume is not recoverable, restore the volume from backup.

These tasks are described in Chapter 3, Chapter 4, and Chapter 6.

▼ To repair/recover file systems

◆ Perform a file system consistency check on any file systems that may be damaged.

These tasks are described in Chapter 4.
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Getting Started
 2

Introduction

This chapter describes how to set up and start using the Volume Manager Storage

Administrator. This chapter focuses on how to use the main components of the Storage

Administrator.

The following topics are discussed in this chapter:

◆ Installation and Setup

◆ Starting the Storage Administrator

◆ Running the Storage Administrator in Read-Only Mode

◆ Selecting Objects

◆ Viewing Objects and Object Properties

◆ The Tree and Grid View

◆ The Object View Window

◆ The Volume Layout Details Window

◆ The Volume to Disk Mapping Window

◆ The Object Properties Window

◆ Accessing Tasks

◆ Running Tasks From the Menu Bar

◆ Running Tasks From a Popup Menu

◆ Running Tasks From the Command Launcher

◆ Using Dialog Boxes

◆ Specifying Objects in Dialog Boxes

◆ Viewing Commands

◆ The Task Request Monitor Window

◆ The Command Log
19
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◆ Setting User Preferences

◆ The Customize Window

◆ Searching for Objects or Free Space

◆ Responding to Alerts

◆ Printing

◆ Exiting the Storage Administrator
20 VERITAS Volume Manager Storage Administrator Administrator’s Guide



Installation and Setup
Installation and Setup
The Volume Manager Storage Administrator consists of a server (vmsa_server ) and a

client (vmsa). You must install and run the Storage Administrator server on a UNIX

machine running the Volume Manager. You can install and run the Storage Administrator

client on any machine that supports the Java Runtime Environment.

Before you can use the Storage Administrator, you need to do the following:

1. Install the VERITAS Volume Manager on the machine to be administered. Run

vxinstall  to create the rootdg  disk group and initialize at least one disk.

2. Install the Storage Administrator server and client on the machine to be administered.

3. If users other than root need to access the Storage Administrator, set up security to

specify which users can run the Storage Administrator.

4. If you plan to run the Storage Administrator client from a machine other than the

machine to be administered, install the Storage Administrator client on the machine

where the client will run.

5. Start the Storage Administrator server on the machine to be administered.

6. Start the Storage Administrator client.

Refer to the VERITAS Volume Manager Installation Guide for details on how to install and

set up the Volume Manager and Storage Administrator.
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Starting the Storage Administrator
Starting the Storage Administrator

Note Only users with appropriate privileges can run the Storage Administrator. Refer to

the VERITAS Volume Manager Installation Guide for information on Storage

Administrator security and access permissions.

You can use the Storage Administrator to administer the local machine or a remote

machine. The Volume Manager daemon (vxconfigd ) and the Storage Administrator

server (vmsa_server ) must be running on the machine to be administered. Once the

Storage Administrator is installed, the Storage Administrator server starts up

automatically at system startup.

▼ To start the Storage Administrator server

❖ If the Storage Administrator server is not already running, type the following to start

it:

vmsa_server &

❖ To confirm that the Storage Administrator server is running, type:

vmsa_server -q

▼ To start the Storage Administrator client

UNIX

❖ To administer the local UNIX machine, type:

vmsa

❖ To administer a remote UNIX machine, type:

vmsa remote_machine_name

Windows

❖ To administer a remote UNIX machine, choose Start > Programs >

VERITAS Volume Manager Storage Administrator > VERITAS Volume Manager

Storage Administrator.
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Starting the Storage Administrator
At startup, the Storage Administrator client displays the Connect to Host dialog box. To

start the Storage Administrator session, complete this dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

Volume Manager Storage Administrator main window appears.

Note Entries for your user name and password must exist in the password file or

corresponding NIS (Network Information Name Service) table on the machine to be

administered. Your user name must also be included in the VERITAS group entry

(vrtsadm , by default) in the group file or NIS group table. If the vrtsadm  entry

does not exist, only root  can run the Storage Administrator.

The Storage Administrator client can provide simultaneous access to multiple host

machines. After you have started the Storage Administrator on one host, you can connect

to additional hosts from the same session. Each host machine must be running the Storage

Administrator server.

Server Host: Type the name of the machine to be administered. Both the Volume

Manager and the Storage Administrator server must be running on

this machine.

User Name: Type your login name. Only users with appropriate privileges can

run the Storage Administrator.

Password: Type your password.

Options To use the specified user and password as default settings for any

future host connections from this Storage Administrator client

session, select Default User.
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Running the Storage Administrator in Read-Only Mode
Running the Storage Administrator in Read-Only Mode
The Storage Administrator can be run in a read-only mode that is useful for monitoring,

training, or browsing purposes. Read-only mode allows you to view objects on the system

through the Storage Administrator, but prevents administrative actions from taking effect.

When the Storage Administrator is in read-only mode, the main window and dialog box

title bars contain the string [Read-only Mode] .

The default mode for the Storage Administrator is full operational mode. Read-only mode

can be enabled on a per-host or per-user basis. The Storage Administrator server and/or

client can be set to read-only mode. All client connections to a read-only server are in

read-only mode.

To specify a list of users with permission to run the Storage Administrator in read-only

mode only, add a group named vrtsro  to the /etc/group  file or NIS (Network

Information Name Service) group table on the machine to be administered. The vrtsro
group should include the names of any users who are allowed to run the Storage

Administrator in read-only mode, but are not allowed to run it in full operational mode.

You can run the Storage Administrator in read-only mode in one of the following ways:

❖ From the main window, choose Options > Read-Only Mode to turn read-only mode

on (or off) for the current session.

❖ Start the server in read-only mode:

vmsa_server -r

Read-only mode will remain in effect until you stop and restart the server. Use

vmsa_server -k  to stop the server.

❖ Start the client in read-only mode:

vmsa -r

❖ Connect to a host machine as a user who only has permission to run the Storage

Administrator in read-only mode on that host. This enables read-only mode on the

specified host machine.
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Selecting Objects
You can select objects in most Storage Administrator windows in the following ways:

❖ To select a single object, click on the object.

❖ To select multiple objects, hold down the Control key while selecting the objects. The

objects that you select in this way do not have to be adjacent.

❖ To select a range of adjacent objects, select the first object and then hold down the

Shift key while selecting the last object in the range. You can also select multiple

adjacent objects by pressing and holding the mouse button while dragging the pointer

over the desired objects.

For information on how to select objects from dialog boxes, refer to “Using Dialog Boxes.”

Viewing Objects and Object Properties
The Storage Administrator provides the following views of objects and their properties:

◆ Tree and Grid View

The main window’s tree and grid view displays volumes, disks, file systems, and

other objects on the system. The grid also displays a limited set of properties for listed

objects.

◆ Object View Window

The Object View window displays a graphical view of disks, volumes, and other

objects in a particular disk group.

◆ Volume Layout Details Window

The Volume Layout Details window displays a close-up graphical view of a single

volume and its components (mirrors/plexes and subdisks).

◆ Volume to Disk Mapping Window

The Volume to Disk Mapping window shows the relationships between volumes and

their underlying disks.

◆ Object Properties Window

The object Properties window contains detailed information about a specific object.

This section describes how to use these views to display objects and their properties.
Chapter 2, Getting Started 25



Viewing Objects and Object Properties
The Tree and Grid View

The main window’s tree and grid view displays volumes, disks, file systems, and other

objects on the system. The object tree is a hierarchical display of object groups. The grid is

a tabular display of objects and a limited set of properties. The Storage Administrator

constantly monitors objects on the system and makes appropriate changes to the tree and

grid displays.

The File menu creates new objects or connections, prints information from the window, or

accesses an object properties window. The File menu also closes the window or exits the

Storage Administrator. The Options menu accesses user preferences and sets the Storage

Administrator to read-only mode. The Window menu and the toolbar buttons launch

other Storage Administrator windows. The context-sensitive Selected and popup menus

access tasks or properties for a selected object. To access the popup menu for an object,

right-click on the object.

For more information about this view, see the description of the object tree and grid in

Chapter 1.

Figure 2 shows how a volume appears in the tree and grid view. The object tree is in the

left pane and the grid is in the right pane.

Figure 2. Tree/Grid View of Volumes
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You can view objects in the tree and grid in the following ways:

❖ To expand or collapse the hierarchy under a particular object group node in the tree,

click on the plus sign (+) or minus sign (-) icon next to that node.

❖ To display the objects in an object group, click on the appropriate object group in the

object tree. All objects that belong to the selected object group appear in the grid.

Examples:

To display all volumes, click on Volumes in the object tree. All volumes on the system

appear in the grid. Each volume is listed with a set of properties.

To display all volumes in the rootdg  disk group, expand the Disk Groups node (by

clicking +), then expand the rootdg  node and click on the Volumes group under

rootdg . Only volumes in the rootdg  disk group appear in the grid.

❖ To display the objects in an object group that is listed in the grid, double-click on the

object group in the grid. All objects that belong to the object group appear in the grid.

Example:

To display the volumes in a disk group listed in the grid, go to the grid and

double-click on the disk group name, then double-click on Volumes. All volumes in

the disk group appear in the grid.

Note that double-clicking on an object that does not contain other objects (children)

displays the object’s Properties window instead of its children.

❖ To sort the objects in the grid by a specific property, click on the appropriate property

column heading. To reverse the sort order, click on the column heading again.

Example:

To sort volumes by size, click on the Size column heading in the grid.

❖ To resize a grid column, place the pointer over the line that divides the column

headings and then press and hold the mouse button to drag the column divider to the

desired position.

❖ To resize the left (tree) and right (grid) panes, place the pointer over the vertical

splitter and then press and hold the mouse button to drag the splitter to the desired

position.

❖ To make a copy of the contents of the grid, choose Window > Copy Main Grid. A copy

of the grid appears in a separate window. The new grid window continues to display

and update the objects that were shown when you created the grid copy. You can
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create multiple copies of the grid and use these grid windows to display different sets

of objects. For example, you can display volumes in one grid window and disks in

another.

❖ To print the contents of the grid, choose File > Print Grid and complete the Print

dialog box. To print details about a specific object displayed in the grid, select the

object, choose File > Print, and then complete the Print dialog box.

The Object View Window

The Object View window displays a graphical view of the volumes, disks, and other

objects in a particular disk group. The Object View window is dynamic, so the objects

displayed in this window are automatically updated when object properties change. You

can select objects or perform tasks on objects in the Object View window.

The Object View window consists of two main panes:

◆ Volume Pane (top)

The volume pane is a graphical display of volumes in a particular disk group. This

pane can display various levels of detail for volumes. You can display volumes in one

of the following modes:

◆ Basic mode shows minimal information about a volume. This mode displays a

compressed view of volumes.

◆ Layout mode shows a volume’s components and layout. This mode displays a

volume’s subdisks and mirrors, as well as any columns or logs.

◆ Detailed mode shows detailed information about a volume and its components.

This mode displays properties of the volume and its components.

◆ Disk Pane (bottom)

The disk pane is a graphical display of disks in a particular disk group. This pane can

display various levels of detail for disks. You can display disks in one of the following

modes:

◆ Basic mode shows minimal information about a disk. This mode displays a

compressed view of disks.

◆ Layout mode shows a disk’s regions and layout. This mode displays the subdisks

and free space on a disk.

◆ Detailed mode shows detailed information about a disk and its subdisks and free

space. This mode displays properties of the disk and its regions.

You can move the horizontal splitter to adjust the relative heights of both panes. To resize

the volume and disk panes, place the pointer over the horizontal splitter and then press

and hold the mouse button to drag the splitter to the desired position.
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The menu bar at the top of the Object View window contains the following menus:

◆ File

The File menu provides access to the New menu, which creates volumes and file

systems. The File menu also displays another disk group, prints the properties of a

selected object, closes the Object View window, or provides access to an object

Properties window.

◆ Options

The Options menu provides access to the Volumes and Disks menus, which set the

display mode for all volumes or disks in the Object View and expand or collapse all

volumes or disks. The Options menu also clears projection settings.

◆ Window

The Window menu launches a window that displays any dissociated objects or

launches the Projection window.

◆ Selected (context sensitive)

The context-sensitive Selected menu accesses tasks or properties for a selected object.

The Selected menu’s name and options depend on the type of object that is selected.

The toolbar at the top of the Object View window has the following set of buttons:

◆ Expand Volume

The Expand Volume button shows more detailed information about all volumes in the

Object View. This button displays objects in layout mode or detailed mode,

depending on the previous mode.

◆ Collapse Volume

The Collapse Volume button hides details for all volumes in the Object View. This

button displays objects in layout mode or basic mode, depending on the previous

mode.

◆ Expand Disk

The Expand Disk button shows more detailed information about all disks in the

Object View. This button displays objects in layout mode or detailed mode,

depending on the previous mode.

◆ Collapse Disk

The Collapse Disk button hides details for all disks in the Object View. This button

displays objects in layout mode or basic mode, depending on the previous mode.

◆ Project

The Project button launches the Projection window.
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◆ Print

The Print button prints the properties of a selected object.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar handle to

separate the toolbar from the window or move the toolbar to the bottom, side, or top of

the window. To reposition the toolbar, press and hold the mouse button over the toolbar

handle and drag the toolbar to its new location.

Projection shows the relationships between objects by highlighting objects that are related

to or part of a specific object. When both disks and volumes are in layout mode or detailed

mode, clicking on a subdisk in a volume (or disk) highlights the location of the subdisk on

the corresponding disk (or volume). To access additional projection options, select an

object in the Object View and then use the Projection window (Window > Projection) to

choose the type of object to be highlighted.

In the Object View, you can move subdisks by dragging the subdisk icons to their new

locations. You can drag a subdisk to another disk or a gap on the same disk. To move a

subdisk, place the pointer over the subdisk and then press and hold the mouse button to

drag the subdisk to another location. Note that moving subdisks reorganizes a volume’s

disk space and should be done with caution.

The Object View window displays plexes and subdisks that are associated with volumes.

To view Volume Manager objects that are not associated with volumes (such as

dissociated plexes), open the Dissociated Object View window (Window > Show

Dissociated).

Figure 3 shows how volumes and disks appear in the Object View.
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Figure 3. Object View Window
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Figure 4 show how the components of a volume appear in the Object View.

Figure 4. Volume in Object View

You can view objects in the Object View window in the following ways:

❖ To display the Object View window, select a disk group (in the main window grid)

and then choose Disk Groups (Selected menu) > Object View.

❖ To show the layouts and components of all volumes in the Object View window

(layout mode), choose Options > Volumes > Layout.

❖ To compress all volumes in the Object View and show minimal information about

each volume (basic mode), choose Options > Volumes > Basic.

❖ To show detailed information about all volumes in the Object View (detailed mode),

choose Options > Volumes > Layout and then Options > Volumes > Expand All. To

hide some of the details about the volumes, choose Options > Volumes > Collapse All.

❖ To show or hide details about a particular volume in the Object View, click on the

volume icon on the left side of the volume. This expands or collapses the volume.

❖ To show the layouts and regions of all disks in the Object View window (layout

mode), choose Options > Disks > Layout.

❖ To compress all disks in the Object View and show minimal information about each

disk (basic mode), choose Options > Disk > Basic.

Layout

Columns

Mirrors

Log

Subdisk
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❖ To show detailed information about all disks in the Object View (detailed mode),

choose Options > Disks > Layout and then Options > Disks > Expand All. To hide

some of the details about the disks, choose Options > Disks > Collapse All.

❖ To show or hide details about a particular disk in the Object View, click on the disk

icon on the left side of the disk. This expands or collapses the disk.

❖ To perform a task on an object in the Object View window, select the object and choose

a task from the Selected or popup menu. To access the popup menu for an object,

right-click on the object.

❖ To refresh the Object View window, right-click on the background area of the window

and choose Reset Server from the popup window. Click OK in the Reset Server dialog

box. This should update the contents of the Object View window and fix any display

problems. Under normal circumstances, the Object View window automatically

updates its contents to reflect object changes and does not require a manual refresh.

❖ To view the properties window for an object in the Object View window, select the

object and choose Properties from the Selected or popup menu.

❖ To print the properties of a particular object, select the object and then choose File >

Print.

❖ To close the Object View window, choose File > Close.
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The Volume Layout Details Window

The Volume Layout Details window displays a graphical view of the selected volume’s

layout, components, and properties. You can select objects or perform tasks on objects in

the Volume Layout Details window. The Volume Layout Details window is not dynamic,

so the objects displayed in this window are not automatically updated when the volume’s

properties change.

The File menu changes or updates the contents of the Volume Layout Details window,

prints information from the window, or closes the window. The View menu changes the

way objects are displayed in this window. The context-sensitive Selected and popup

menus access tasks or properties for a selected object. To access the popup menu for an

object, right-click on the object.

Figure 5 shows how a volume appears in the Volume Layout Details view.

Figure 5. Volume Layout Details Window

You can view objects in the Volume Layout Details window in the following ways:

❖ To display the Volume Layout Details window for a volume, click on the volume (in

the main window grid) and then choose Volumes (Selected menu) > Show Layout.

❖ To update (refresh) the graphical view to show any recent changes to the current

volume, choose File > Update. The Volume Layout Details window does not update

object properties automatically.

❖ To view a different volume, choose File > Open and then specify another volume in

the Open Volume dialog box.

❖ To hide the detailed information within each object, choose View > Compress Display.

To show details for a particular object in the compressed display, click on that object.
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❖ To highlight objects that are related to or part of a specific object, choose View >

Project On Selection and then click on an object. To highlight any subdisks on the

same disk as a specific subdisk, choose View >

Subdisk Projection and then click on a subdisk.

❖ To print the properties of a particular object, select the object and then choose File >

Print and complete the Print dialog box.

The Volume to Disk Mapping Window

The Volume to Disk Mapping window displays a tabular view of volumes and their

underlying disks. Volumes are listed in the top row of the table and disks are listed in the

left column of the table. Each circle icon in the table indicates that part of the

corresponding volume is located on the corresponding disk.

This window can also display details such as the subdisks and gaps (free space) on each

disk. Each subdisk or gap is listed with its disk offset and length. When subdisks are

shown, circles show the relationship between volumes and subdisks.

The Volume to Disk Mapping window is dynamic, so the contents of this window are

automatically updated when objects are added, removed, or changed.

The File menu prints information from the window or closes the window. The View menu

changes the way objects appear in the Volume to Disk Mapping window. The

context-sensitive Selected and popup menus access tasks or properties for a selected

object. To access the popup menu for an object, right-click on the object.

The Volume to Disk Mapping window has a performance monitoring feature that ranks

volume response time. When performance monitoring is turned on (View > Performance

Monitoring), the icons in the table change. The volumes with the slowest reads/writes are

shown as red icons. Volumes with relatively slow response time are shown as yellow

icons. All other volumes are shown as green icons.

Figure 6 shows how the relationships between volumes and disks are shown in the

Volume to Disk Mapping window.
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Figure 6. Volume to Disk Mapping Window

You can view volumes and their associated disks in the following ways:

❖ To display the Volume to Disk Mapping window for all volumes in a disk group, click

on the disk group (in the main window grid) and then choose Disk Groups (Selected

menu) > Disk/Volume Map.

❖ To display all of the subdisks and gaps on a particular disk, click the arrow to the left

of the disk name. Any subdisks and gaps are listed below the disk name. To hide the

subdisks and gaps, click the arrow again.

❖ To display all of the subdisks and gaps on all disks, choose View > Expand All. To

hide all of the subdisks and gaps on all disks, choose View > Collapse All.

❖ To highlight a disk row, click on the disk name. To highlight a volume column, click

on the volume name. To highlight both the disk and volume associated with a

particular circle, click on the circle.

❖ To activate the performance monitoring feature, choose View > Performance

Monitoring. Volumes with relatively slow reads/writes are shown as red circles.

❖ To print the properties of a particular object, select the object and then choose File >

Print and complete the Print dialog box.
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The Object Properties Window

The object Properties window contains detailed information about the selected object. The

Properties window contains a set of tabbed pages, each of which contains information

about the object and related objects. The tab labels and page contents vary, depending on

the type of object selected. You can display a different page by clicking on the appropriate

tab label. Some object properties can be changed through the object’s Properties window.

Figure 7 shows how a volume appears in the Volume Properties window.

Figure 7. Volume Properties Window

You can view object properties in the following ways:

❖ To view the properties of an object, click on the object (in the main window grid) and

then choose Properties from the Selected or popup menu. You can also access the

Properties window by double-clicking on the object.

Example:

To display volume properties, either click on a volume and then choose Volumes >

Properties or double-click on a volume.
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Note that double-clicking on an object that has children may display the object’s

children instead of the Properties window.

❖ To go to a tab in a properties window, click the appropriate tab label.

❖ To update the contents of the Properties window to reflect current properties for the

object, click Refresh.

❖ To change any of the editable items in the Properties window, make the appropriate

changes and then click OK. This changes the settings for all properties tabs in the

Properties window.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
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Accessing Tasks
Most Volume Manager Storage Administrator tasks are performed by selecting objects

and/or tasks and then completing the resulting dialog boxes. With the Storage

Administrator, you can access tasks from the following:

◆ the menu bar

◆ a context-sensitive popup menu

◆ the Command Launcher

This section describes how to run tasks from menus and the Command Launcher.

Running Tasks From the Menu Bar

You can launch tasks from the File and Selected menus in the main window’s menu bar.

The File > New menu creates new Volume Manager objects (volumes and disk groups)

and file systems. The context-sensitive Selected menu launches tasks on a selected object.

The Selected menu is dynamic and changes its name and options based on the type of

object that is selected in the tree or grid.

Figure 8. Menu Bar

❖ To create a new object, choose the type of object to be created from the

File > New menu. This launches a dialog box.

Example:

To create a volume, choose File > New > Volume. Complete the New Volume dialog

box.

❖ To perform a task on an object with the Selected menu, select the object and choose the

appropriate task from the Selected menu. If this launches a dialog box, complete the

dialog box.

Example:

To change a volume’s name, select the volume in the grid. Choose

Volumes > Rename from the Selected menu. Type the volume’s new name in the

Rename Volume dialog box, then click OK.
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Running Tasks From a Popup Menu

A context-sensitive popup menu launches tasks on the selected object. A popup menu

provides access to tasks or options appropriate for the selected object. Popup menus are

available in the main window and most other windows.

Figure 9. Context-Sensitive Popup Menu

❖ To perform a task on an object with the popup menu, right-click on the object and

choose the appropriate task in the popup menu. If this launches a dialog box,

complete the dialog box.

Running Tasks From the Command Launcher

The Command Launcher window launches tasks from a list of objects and associated

Storage Administrator tasks. The Command Launcher lists each task with an object type

and a task description.

The Command Launcher can be displayed as part of the main window (docked) or as a

separate window. The Command Launcher can also be hidden. When the Command

Launcher is attached to the main window, tasks are context sensitive. However, tasks are

not context sensitive when the Command Launcher is separated from the main window.

The File menu attaches (docks) the Command Launcher to the main window and closes

the Command Launcher window.
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Figure 10. Command Launcher

You can use the Command Launcher as follows:

❖ To display the Command Launcher, choose Window > Command Launcher (from the

main window). To hide the Command Launcher, choose

Window > Command Launcher again. You can also show or hide the Command

Launcher by choosing Options > Customize and clicking Show Command Launcher

in the Customize window’s Main Window tab.

❖ To perform a task on a specific type of object, select the appropriate

object-task combination from the Command Launcher list. Make sure that the Hosts

field contains the name of the host machine where the task will be performed.

Example:

To add a disk, choose Disk Add from the Command Launcher list. Complete the Add

Disk dialog box.

❖ To sort the items listed in the Command Launcher by object type, command, or task

description, click on the appropriate column heading.

To reverse the sort order in a column, click on the column heading again.

❖ To separate or attach (dock) the Command Launcher and the main window, choose

Options > Customize and click Dock Command Launcher in the Customize window’s

Main Window tab.
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❖ To adjust the height of the Command Launcher when it is attached to the main

window, choose Options > Customize and specify the new height (in pixels) in the

Docked Command Launcher Height field in the Customize window’s Main Window

tab. Alternatively, you can place the pointer over the horizontal splitter and then press

and hold the mouse button to drag the splitter to the desired position.

Using Dialog Boxes
Administrators typically use dialog boxes to submit tasks or other requests to the Storage

Administrator. Dialog boxes can contain selectable buttons and/or fields that accept

information. Some dialog box fields contain default values that can be changed. Items that

are not applicable are greyed out.

❖ To use a dialog box, select the appropriate items and/or type the appropriate

information and then click one of the following buttons to initiate or cancel the

task/request:

Some dialog boxes contain the following buttons:

OK Perform the current task/request and close the dialog box.

Apply Perform the current task/request and continue to display the dialog

box.

Cancel Cancel the current task/request and close the dialog box. (If you

have already clicked Apply, this does not cancel the task that is in

progress.)

Browse View and select existing objects.

View View existing objects.

Show Options Show optional settings for this task.

Reset Reset the contents of the dialog box (and any associated dialog

boxes) to the default settings.

Help Display information about the contents of the dialog box.
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Specifying Objects in Dialog Boxes

Most Storage Administrator dialog boxes contain one or more object name fields. If you

select an object before you launch the task, the resulting dialog box may include the

selected object’s name. If the object name field is empty, you can specify an object in one of

these ways:

◆ Type the object’s name.

◆ Click the Browse button next to the object name field and then select the object from

the resulting browse dialog box. Most browse dialog boxes consist of a tree (left pane)

and grid (right pane). To select an object in a browse dialog box, click on the

appropriate object group in the tree and then click on the desired object in the grid.

Figure 11 shows a sample browse dialog box.

Figure 11. Browse Dialog Box

In some cases, you can specify multiple objects (separated by white space) in a single field.

To select multiple objects from a browse dialog box, hold down the Control key and click

on each object. To select a range of adjacent objects, select the first object and then hold

down the Shift key while selecting the last object in the range.

Specifying Disks and Disk Groups in Dialog Boxes

You can specify the object’s disk group by preceding the object name with the disk group

name (diskgroup_name/ object_name). The disk group name is required if there are

multiple objects with the same name (in different disk groups) on the system.
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Disks in disk groups have two names:

◆ device name

The physical disk device name (or disk access name).

◆ disk name

The Volume Manager disk name (or disk media name). This is the logical name given to

the disk by the Volume Manager or the administrator.

Some dialog box fields require the device name and others require the Volume Manager

disk name.

Specifying Object Sizes in Dialog Boxes

When you type the size of an object in an input field, you can specify sectors, kilobytes,

megabytes, or gigabytes by appending an s , k , m, or g to the size. If you do not specify a

size unit, the size defaults to sectors.

Viewing Commands
The Storage Administrator logs all task requests. You can view the Storage Administrator

task history (including tasks in progress) in either of these locations:

◆ The Task Request Monitor Window

◆ The Command Log File

The Task Request Monitor Window

The Task Request Monitor window displays a history of tasks performed in the current

session (and any other sessions running on the machine). Each task is listed with

properties such as the user who performed the task, the task status, and the start/finish

times.

The File menu removes finished tasks or closes the window. The Tasks and popup menus

stop/restart tasks and access task properties.
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Figure 12. Task Request Monitor

You can use the Task Request Monitor window as follows:

❖ To display the Task Request Monitor, choose Window > Tasks (from the main

window) or click on the Task button in the toolbar.

❖ To cancel a selected task, choose Tasks > Abort. To temporarily stop a task, choose

Tasks > Pause. To continue a task, choose Tasks > Resume.

❖ To view task properties and the low-level command(s) used to perform a task, select

the task and choose Properties from the Tasks or popup menu. You can also access

task properties by double-clicking on the task.

❖ To sort the tasks by task type, click on the Task column heading. To sort the tasks by

property, click on the appropriate property column heading. To reverse the sort order,

click on the column heading again.

❖ To remove completed tasks from the window, choose File > Remove Finished Tasks.

❖ To print the contents of this window, choose File > Print Grid and complete the Print

dialog box. To print details about a specific task, select the task, choose File > Print,

and then complete the Print dialog box.
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The Task Properties window shows information about a specific task. Task properties

include the user who performed the task, the task status, the start/finish times, and the

low-level commands used to perform the task. For failed tasks, the Task Properties

window includes any relevant error messages. You can copy commands from the

Executed Commands field to the command line or a script file.

Figure 13. Task Properties Window
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The Command Log

The command log file contains a history of Volume Manager Storage Administrator tasks

performed in the current session and previous sessions. The command log file contains a

description of each task, along with properties such as the user who performed the task,

the task status, the start/finish times, and the low-level commands used to perform the

task. For failed tasks, the command log includes any relevant error messages.

By default, the command log is located in /var/opt/vmsa/logs/command  on the

server. You can view the command log file through the Storage Administrator’s

Command Log View window.

The following example shows some sample command log file entries:

Create Volume
Description: Create Volume
User: root
Started: November 18, 1999 4:36:11 PM PDT
Finished: November 18, 1999 4:36:12 PM PDT
State: Successful
Executed Commands:
        /usr/sbin/vxassist  -g rootdg   make vol15 3m layout=nostripe

Create Volume  FAILED!
Description: Create Volume
User: root
Started: November 18, 1999 4:36:56 PM PDT
Finished: November 18, 1999 4:36:56 PM PDT
State: Failed
Executed Commands:

/usr/sbin/vxassist -g rootdg make vol16 13g layout=nostripe
Failed Command: /usr/sbin/vxassist  -g rootdg   make vol16 13g
layout=nostripe
Error Message: vxvm:vxassist: ERROR: Cannot allocate space for
27262976 block volume

❖ To access the Command Log View window, select a host and choose

Hosts > View Command Log.

❖ To update the contents of the Command Log View window, choose

File > Refresh.

❖ To search for some specific text in the Command Log View window, choose Window

> Find and complete the Find dialog box.
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❖ To close the Command Log View window, choose File > Close.

Setting User Preferences
You can change the way items appear in Storage Administrator windows. This section

describes how to use the Customize window to customize the way the Storage

Administrator appears.

The Customize Window

The Customize window displays current user preferences for the components of the

Storage Administrator and allows you to change these settings. The Customize window

contains a set of tabbed pages, each of which contains preference options for a particular

aspect of the Storage Administrator. You can display a different page by clicking on the

appropriate tab label.

Figure 14. Customize Window
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You can use the Customize window as follows:

❖ To display the Customize window, choose Options > Customize (from the main

window) or click on the Customize button in the toolbar.

❖ To change preference settings, make the appropriate selections in the Customize

window, then click OK. This changes the settings for all tabs in the Customize

window. To reset the settings to the previous settings, click Reset (before you click

OK).

When you change preference settings, the customization change icon appears in the

tab label of the tab that contains changes. This icon disappears when you click OK,

Apply, or Reset. The customization change icon also appears in the status area of the

main window.

❖ To save your preference settings and apply them to future Storage Administrator

sessions, choose Options > Save Customization. You can also save your preference

settings by clicking the customization change icon in the status area.

If the Auto-Save Preferences on Exit preference is set (in the General tab), the Storage

Administrator will save all of your preference settings when you exit the Storage

Administrator session via the File menu.

The Storage Administrator saves user preferences in

user’s_home_directory/.vmsa/VMpreference.prf  on the machine where the

client is running.

❖ To reload your previously saved preferences, choose Options > Load Customization.
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The Customize window contains the following preference tabs:

◆ General

◆ Main Window

◆ Font

◆ Color

◆ Object View Color

◆ Geometry

◆ Tree/Grid

◆ Toolbar

◆ Layout Details

◆ Object View

◆ Hosts

The following sections summarize the preference settings available in each of these tabs.
50 VERITAS Volume Manager Storage Administrator Administrator’s Guide



Setting User Preferences
General

Set the following general preferences:

Set Text Field Input to

Replace Mode

Set user input to replace mode. This highlights any

existing text in a field and replaces that text with the

new text.

Show Task Options Show/hide optional settings in task dialog boxes.

Show Confirmation Dialogs Show/hide confirmation dialogs for tasks that may

have serious consequences (such as data loss).

Confirmation dialogs require users to confirm that a

task should be performed. Confirmation dialogs

typically appear for tasks that remove objects.

Note: If you hide confirmation dialogs, most tasks are

performed immediately and without any form of

confirmation.

Auto-Save Preferences on

Exit

Save all current user preferences when the user exits

the Storage Administrator via File > Exit.

Flush Images Draw images slightly slower than usual to prevent the

X server from growing. This is recommended if you

plan to leave the Storage Administrator running for

long periods of time.

Dynamic Splitter Redraw the contents of the window panes while the

splitter is being moved to resize the panes.

Default Display Unit Set the default size unit for areas that display object

sizes. If Best Choice is set, the Storage Administrator

uses an appropriate size unit.

Summary Decimal

Precision

Set the decimal point precision for object sizes

displayed in the grid and other areas that display

summaries.

Task Decimal Precision Set the decimal point precision for object sizes

displayed in task-related dialog boxes and areas that

display detailed information.
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Main Window

Set the following preferences for the main window:

Font

Set the font size, family, and style for the following:

❖ To access the Font Selector, click Change. Change the font size by sliding the Size

slider. Use the Family and Style menu to change the font family and style.

Show Status Bar Show/hide the status bar area (at the bottom of the

main window). The status bar displays alert icons

when failures or errors occur.

Show Command Launcher Show/hide the Command Launcher. The Command

Launcher contains a list of selectable tasks.

Dock Command Launcher Attach/detach the Command Launcher and the main

window.

Docked Command

Launcher Height

Set the height of the Command Launcher portion of the

main window.

User Font Set the font for user input and objects displayed in the

tree and grid.

System Font Set the font for labels, menus, buttons, and other items

displayed by the Storage Administrator.

Grid Heading Font Set the font for grid headings.

Grid Heading Highlight

Font

Set the font for grid headings that are highlighted for

sorting purposes.

Toolbar Font Set the font for the toolbar buttons.

Graphical Display Font Set the font for objects in the Volume Layout Details

window.
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Color

Set the following preferences for colors:

❖ To access the Color Selector, click Change. Change colors by clicking on a color in the

color wheel or sliding the Red, Green, Blue, and Brightness sliders to the appropriate

positions.

Object View Color

Set the following preferences for colors in the Object View window:

Background Color Set the background color for all Storage Administrator

windows.

Foreground Color Set the color for foreground text in Storage

Administrator windows.

Tree/Grid Color Set the background color for the tree and grid.

Connecting Line Color Set the color for the lines that connect items in the tree.

Selection Color Set the color for selected items.

Selection Foreground Color Set the color for foreground text in selected items.

Focus Highlight Color Set the color for the item that has input focus.

Link Color Set the color for links (such as the links to tasks in the

Command Launcher).

Projection Color Set the color for the lines that show object relationships

in the Volume Layout Details window.

Disk Titlebar Color Set the color of the titlebar for disks in the Object View.

Disk Body Color Set the background color for disks in the Object View.

Disk Gap Color Set the color for gaps (free space) on disks in the Object

View.

Plex Gap Color Set the color for gaps in plexes in the Object View.
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❖ To access the Color Selector, click Change. Change colors by clicking on a color in the

color wheel or sliding the Red, Green, Blue, and Brightness sliders to the appropriate

positions.

Geometry

Set the width and height (in pixels) for the following windows:

◆ Main Window

◆ Object Search Window

◆ Alert Monitor Window

◆ Task Request Monitor Window

◆ Volume Layout Details Window

◆ Command Launcher Window

◆ Grid Copy Window

◆ Object View Window

◆ Dissociated Object View Window

Dissociated Subdisk Color Set the color for dissociated subdisks in the Object

View.

Odd Column Color Set the color for odd-numbered columns in volumes in

the Object View.

Even Column Color Set the color for even-numbered columns in volumes in

the Object View.

Plex Body Color Set the background color for plexes in the Object View.

Dissociated Plex Color Set the color for dissociated plexes in the Object View.

Volume Titlebar Color Set the color of the titlebar for volumes in the Object

View.

Volume Body Color Set the background color for volumes in the Object

View.

Unavailable Volume Color Set the color for inaccessible volumes in the Object

View.

Object Border Color Set the color for object borders in the Object View.
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If you resize one of these windows via your window manager, the Geometry preference

for that window changes to the new size automatically.

Tree/Grid

Set the following tree and grid preferences:

Toolbar

Set the following preferences for the toolbar:

Display Full Path Display path information in the tree and grid.

Auto Scroll Grid When an object is added or changed, scroll through the

objects until the new/changed object is visible in the

grid.

Double-Click Always

Displays Properties

When the administrator double-clicks on an object,

always display the properties window for the object. If

this preference is not set, double-clicking on an object

with children (such as a disk group) displays the

object’s children instead of its properties window.

Splitter Position Move the splitter to adjust the relative sizes of the tree

and grid panes.

Column Header Alignment Align column headings above the data in each column

(best fit) or at the left, right, or center of each column.

Selector Tree/Grid Width Set the width (in pixels) of the tree and grid in browse

dialog boxes that contain a tree and a grid.

Selector Grid Width Set the width (in pixels) of the grid in browse dialog

boxes that contain a grid only.

Visible Selector Rows Set the number of rows displayed in the tree and grid

in browse dialog boxes.

Show Toolbar Show/hide the toolbar.

Position Place the docked toolbar at the top, bottom, or side of

the main window.

Presentation Display icons and/or labels on the buttons in the

toolbar.
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Layout Details

Set the following preferences for the Volume Layout Details window:

Object View

Set the following preferences for the Object View window:

Compress Display Compress the graphical display of objects so that

details are hidden.

Projection on Selection When an object is selected, highlight objects that are

related to or part of that object.

Subdisk Projection When a subdisk is selected, highlight other subdisks on

the same disk.

Use Volume Basic Mode Display volumes in basic mode by default.

Expand Volumes Within

Mode

Display expanded view of volumes (layout mode) by

default.

Use Disk Basic Mode Display disks in basic mode by default.

Expand Disks Within Mode Display expanded view of disks (layout mode) by

default.

Enable Drag and Drop Allow administrators to move subdisks by dragging

subdisk icons to new locations within the Object View.

Splitter Position Move the splitter to adjust the relative sizes of the

volume and disk panes.

Start Drag Tolerance Set the number of pixels the mouse must move before

drag and drop is activated.
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Hosts

Set the following preferences for accessing and displaying host machines:

❖ To specify a host machine, click Add and type the host machine name in the Hosts

column of the grid. To select a preference for the host, click in the appropriate column.

Check marks indicate which preferences are selected for the corresponding host. To

turn off a host preference setting, click on the appropriate check mark.

❖ To remove a host machine from the host preferences list, select the host and and click

Delete.

❖ To clear the settings for all hosts in the preferences list, click Clear.

❖ To turn on the Connect setting for all listed hosts, click Connect All.

❖ To change a host name, select the host and either click the Edit button or use the

following keys:

Connect Automatically connect to the specified host(s) at

Storage Administrator startup.

Default Host Use this host machine as the default host.

Auto-Expand In the main window’s object tree, expand the specified

host node and display the hierarchy under that host.

F2 Insert mode

Any key Replace mode

Return Apply change

Esc Cancel change
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Searching for Objects or Free Space
The Search window searches the specified host machine(s) for objects that match the

specified search criteria. Any objects that match the search criteria are listed in the grid in

the lower half of the search window, along with their properties. Objects displayed in the

search window are monitored and removed from the window if they no longer meet the

current search criteria.

The Search window contains a set of tabbed pages, each of which contains search options

for a particular type of object. You can display a different page by clicking on the tab label.

The Search window has menus similar to those in the main menu. The File menu prints

information from the window or closes the window. The Window menu opens other

windows or a copy of the current search results grid. The context-sensitive Selected and

popup menus access tasks or properties for a selected object in the search results grid. To

access the popup menu for an object, right-click on the object in the lower half of the

Search window.

Figure 15. Object Search Window
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You can use the Search window as follows:

❖ To display the Search window, choose Window > Search (from the main window) or

click on the Search button in the toolbar.

❖ To begin a search, enter your search criteria and then click Search. Make sure that the

Host(s) field contains the name of the host machine(s) where the search will be

performed.

❖ To sort the objects in the search results grid by name or property, click on the

appropriate column heading. To reverse the sort order, click on the column heading

again.

❖ To view the properties of an object listed in the search results grid, select the object

and choose Properties from the Selected or popup menu. You can also access object

properties by double-clicking on the object.

❖ To open a window that contains a copy of the current search results grid, choose

Window > Copy Search Grid. To open another Search window, choose Window >

Search.

❖ To perform a task on an object listed in the search results grid, select the object and

choose a task from the Selected or popup menu.

❖ To print the contents of the search results grid, choose File > Print Grid and complete

the Print dialog box. To print details about a specific object displayed in the search

results grid, select the object, choose File > Print, and then complete the Print dialog

box.

Responding to Alerts
When an object fails or experiences an error, an alert icon appears in the status area of the

main window and/or on the object’s icon (see Figure 16). If an alert icon appears, you

should review the contents of the Alert Monitor window. The Alert Monitor window lists

information about objects that have failed or experienced other errors (see Figure 17).

Each object is listed with a description of the failure or error.

After you review the alerts listed in the Alert Monitor window, the alert icon at the bottom

of the main window changes to a check mark to let you know that you have reviewed

current alerts. If more alerts are added to the Alert Monitor window, the check mark icon

changes to the alert icon to let you know that there are new alerts.

The File menu accesses properties for objects with alerts or closes the window.

Context-sensitive popup menus also access properties for objects with alerts. To access a

popup menu, right-click on an object with an alert.
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After reviewing the alert(s) in the Alert Monitor window, you should try to correct the

problem. For more information about an object listed in the Alert Monitor window, go to

the object’s Properties window.

Figure 16. Alerts for a Volume

alerts
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Figure 17. Alert Monitor Window

You can use the Alert Monitor window as follows:

❖ To display the Alert Monitor window, choose Window > Alerts (from the main

window) or click on the Alert button in the toolbar. You can also access the Alert

Monitor window by clicking on the alert icon in the status area.

❖ To sort alerts by object or description, click on the appropriate column heading. To

reverse the sort order, click on the column heading again.

❖ To view the properties of an object with an alert, select the object and choose Object

Properties from the File or popup menu. You can also access object properties by

double-clicking on the object.

❖ To acknowledge and clear the alert icon displayed in the status area of the main

window, choose Options > Clear Alert Status.
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Printing
You can print the contents of some Storage Administrator windows. In some cases, you

can print information about a specific object instead of the contents of the window.

❖ To print the contents of a Storage Administrator window, choose File > Print Grid and

complete the Print dialog box.

❖ To print details about a specific object displayed in the window, select the object,

choose File > Print, and then complete the Print dialog box.

❖ To print the contents of a Properties window, click the Print button and complete the

Print dialog box.

Exiting the Storage Administrator

❖ To exit the Volume Manager Storage Administrator client, choose File > Exit.
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Disk Tasks
 3

Introduction

This chapter describes how to set up and use disks and disk groups with the Volume

Manager Storage Administrator. The Disk Task Roadmap at the beginning of this chapter

contains a summary of common disk and disk group tasks.

The following disk tasks are discussed in this chapter:

◆ Adding a Disk to the Volume Manager

◆ Scanning Disks

◆ Designating a Disk as a Hot-Relocation Spare

◆ Reserving a Disk

◆ Renaming a Disk

◆ Offlining a Disk

◆ Onlining a Disk

◆ Mirroring a Disk

◆ Evacuating a Disk

◆ Disconnecting a Disk

◆ Replacing a Disk

◆ Unrelocating a Disk

◆ Recovering Volumes on a Disk

◆ Removing a Disk

◆ Forcing Initialization of a Disk

◆ Viewing Disk Properties

◆ Disabling a Controller

◆ Enabling a Controller

◆ Renaming an Enclosure
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Introduction
The following disk group tasks are discussed in this chapter:

◆ Creating a Disk Group

◆ Upgrading a Disk Group

◆ Renaming a Disk Group

◆ Deporting a Disk Group

◆ Importing a Disk Group

◆ Recovering Volumes in a Disk Group

◆ Clearing Relocation Information for a Disk Group

◆ Destroying a Disk Group

◆ Moving a Disk Group

◆ Viewing Disk Group Properties
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Disk Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator disk and disk group tasks.

To do this... Use this procedure...

Disk Setup Tasks:

Place new disk(s) under Volume Manager control Adding a Disk to the Volume Manager

Set up new disk group(s) Creating a Disk Group

Precautionary Tasks:

Add disk(s) as hot-relocation spare(s) Designating a Disk as a Hot-Relocation Spare

Place the boot (root) disk under Volume Manager

control

Make an alternate boot (root) disk

Adding a Disk to the Volume Manager

Mirroring a Disk

Maintenance Tasks:

Place additional disks under Volume Manager

control

Adding a Disk to the Volume Manager

Add more disk space to a disk group Adding a Disk to the Volume Manager

Create additional disk groups Creating a Disk Group

Upgrade a disk group Upgrading a Disk Group

Recovery Tasks:

Move volumes off failing disks Evacuating a Disk

Replace failed disk(s) Replacing a Disk

Attempt to recover all volumes on a disk Recovering Volumes on a Disk

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group
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Other Tasks:

Change a disk’s name Renaming a Disk

Change a disk group’s name Renaming a Disk Group

Temporarily prevent access to a disk Offlining a Disk

Restore access to an offline disk Onlining a Disk

Temporarily prevent access to a disk group Deporting a Disk Group

Restore access to a deported disk group Importing a Disk Group

Remove a disk from Volume Manager control Removing a Disk

Move a disk group to another system Moving a Disk Group

Destroy a disk group (permanently) Destroying a Disk Group

To do this... Use this procedure...
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Adding a Disk to the Volume Manager
New disks must be set up on the system, placed under Volume Manager control, and

added to a disk group before they can be used for volumes. The add disk(s) task performs

these tasks to prepare new disks for Volume Manager use. You can also use this task to

add a disk to a disk group.

When you place a disk under Volume Manager control, the disk is either encapsulated or

initialized. Encapsulation preserves any existing data on the disk in volumes.

Initialization destroys any existing data on the disk.

If you place the root disk under Volume Manager control, you must encapsulate the disk.

If you want to create an alternate boot disk, you can mirror the encapsulated root disk (see

“Mirroring a Disk”).

This task assigns a default Volume Manager disk name to the disk. Once the disk is under

Volume Manager control, you can use the Rename Disk task to change the Volume

Manager disk name (see “Renaming a Disk”).

▼ To add a disk to the Volume Manager

1. If the disk is brand new, select the appropriate host machine node and choose Hosts >

Scan Disks (Selected menu) to set up the disk on the system. This runs the disk setup

commands appropriate for the operating system.

2. Select the uninitialized disk to be placed under Volume Manager control.

3. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

4. Complete the Add Disk(s) dialog box as follows:

Disk Device(s): If the correct disk (device) name is not already displayed in

this field, type the disk’s device name or click Browse to select

the disk.

To set up any new disks on the system, click Scan Disks. This

runs the disk setup commands appropriate for the operating

system.
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When you have provided all necessary information in the dialog box, click OK.

5. Indicate whether the disk should be initialized or encapsulated. If you initialize the

disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any

existing data will be preserved in volumes.

6. If you chose to encapsulate the disk, reboot the system.

▼ To place the root disk under Volume Manager control

1. Select the root (boot) disk.

2. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

Add Disk(s) to: Specify where the disk(s) should be placed:

◆ To add the disk(s) to an existing disk group, select Existing

Disk Group. Type the disk group name in the Disk Group

Name field or click Browse to select a disk group.

◆ To add the disk(s) to a new disk group, select New Disk

Group. Type the name of the new disk group in the Disk

Group Name field. The new disk group will be created for

the new disk.

◆ To place the disk(s) in the free disk pool, select Free Disk

Pool. Disks in the free disk pool are under Volume

Manager control, but do not belong to a disk group and

cannot be used to create volumes.

Options Click Show Options to access the optional settings for this task.

◆ To create a shared disk group for the disk(s), select New

Disk Group and Create Shared. The Create Shared option

is only applicable in a cluster environment.

◆ To specify the Volume Manager disk name for the disk,

type a disk name in the Disk Name(s) field. If no Volume

Manager disk name is specified, the Volume Manager

assigns a default name to the disk.

◆ To apply a comment attribute to disks that are placed in a

disk group, type the information in the Comment field.
68 VERITAS Volume Manager Storage Administrator Administrator’s Guide



Adding a Disk to the Volume Manager
3. Complete the Add Disk(s) dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

4. Indicate that the root disk should be encapsulated. When you encapsulate the disk, any

existing data will be preserved in volumes.

5. Reboot the system.

After placing the root disk under Volume Manager control, it is recommended that you

create an alternate boot disk by mirroring the root disk (see “Mirroring a Disk”).

▼ To add a disk to a disk group

1. Select the disk to be added to a disk group.

2. Choose Disks > Add (Selected menu) or Disk Add (Command Launcher).

3. Complete the Add Disk(s) dialog box as follows:

Disk Device(s): If the correct disk (device) name is not already displayed in

this field, type the root disk’s name or click Browse to select

the disk.

Add Disk(s) to: Specify that the root disk should be placed in the root disk

group. Select Existing Disk Group. Type the root disk group

name (rootdg ) in the Disk Group Name field.

Disk Device(s): If the correct disk (device) name is not already displayed in

this field, type the disk’s name or click Browse to select the

disk.

Add Disk(s) to: Specify where the disk(s) should be placed:

◆ To add the disk(s) to an existing disk group, select Existing

Disk Group. Type the disk group name in the Disk Group

Name field or click Browse to select a disk group.

◆ To add the disk(s) to a new disk group, select New Disk

Group. Type the name of the new disk group in the Disk

Group Name field. The new disk group will be created for

the new disk.
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When you have provided all necessary information in the dialog box, click OK.

Options Click Show Options to access the optional settings for this task.

◆ To create a shared disk group for the disk(s), select New

Disk Group and Create Shared. The Create Shared option

is only applicable in a cluster environment.

◆ To specify the Volume Manager disk name for the disk,

type a disk name in the Disk Name(s) field. If no Volume

Manager disk name is specified, the Volume Manager

assigns a default name to the disk.

◆ To apply a comment attribute to the disk, type the

information in the Comment field.

Notes:

◆ This task requires a disk device name and the location for the new disk (that is, a

disk group or the free space pool).

◆ This task sets up disks for Volume Manager use. Disks must be under Volume

Manager control and in a disk group before they can be used to create volumes.

◆ When a disk is placed under Volume Manager control, the disk is either initialized

or encapsulated. Encapsulation preserves any existing data on the disk in the form

of volumes. Initialization destroys any existing data on the disk. Encapsulation is

recommended for the root/boot disk and any other disks that contain valuable data.

◆ Disk encapsulation requires a system reboot.

◆ Disks in the free disk pool need to be added to a disk group before they can be used

to create volumes.

◆ Disks must be online before they can be added to a disk group or the free disk pool.

◆ Disks that already belong to a disk group cannot be added to another disk group or

placed in the free disk pool.

◆ Disks cannot be added to deported disk groups.

◆ The root disk must be placed in the root disk group (rootdg ). If the root disk is

placed in any other disk group, the root disk cannot be used to boot the system.

◆ The Volume Manager disk name must be unique within the disk group.

◆ If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, the Volume Manager appends numbers to the disk

name so that each disk name is unique within its disk group.
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Scanning Disks
This procedure checks for new disks and runs the appropriate commands to set up any

new disks. You can use this task to make sure that the Volume Manager recognizes any

new hardware.

▼ To scan disks

1. Select the host machine to be scanned for new disks.

2. Choose Hosts > Scan Disks (Selected menu) or Disk Scan (Command Launcher).

3. Complete the Scan Disk dialog box as follows:

Host(s): If the correct host name is not already displayed in this field,

type the host’s name or click Browse to select the host.

Notes:

◆ New disks must be set up on the system before they can be used by the Volume

Manager.

◆ The Scan Disks task scans the system for new disks. If any new disks are found, this

task runs the appropriate commands to set up the new disks on the system.
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Designating a Disk as a Hot-Relocation Spare
This procedure adds a disk to the pool of spare disks available to the hot-relocation

feature. If an I/O failure occurs, hot-relocation automatically relocates any redundant

(mirrored or RAID-5) subdisks to spare disks and restores the affected Volume Manager

objects and data. The system administrator is notified of the failure and relocation details

via electronic mail. After successful relocation, you may want to replace the failed disk

(see “Replacing a Disk”).

▼ To designate a disk as a hot-relocation spare

1. Follow the instructions in “Adding a Disk to the Volume Manager” to place the disk

under Volume Manager control and in a disk group.

2. Select the disk to be designated as a hot-relocation spare.

3. Choose Disks > Properties (Selected menu).

4. In the Disk Properties window, go to the General tab and select Spare. Click OK.

If you decide that you want to remove the disk from the pool of hot-relocation spares,

open the Disk Properties window and click Spare again.

Notes:

◆ The disk must be under Volume Manager control and in a disk group.

◆ Any disk in the same disk group can use the spare disk.

◆ To make sure that sufficient space is available for relocation, try to provide at least

one hot-relocation spare disk per disk group.
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Reserving a Disk
This procedure designates a disk as a reserved disk. A reserved disk is not considered part

of the free space pool. If you perform a task that requires disk space and you do not

specify a disk, the Storage Administrator allocates space from disks other than the

reserved disk.

▼ To reserve a disk

1. Follow the instructions in “Adding a Disk to the Volume Manager” to place the disk

under Volume Manager control and in a disk group.

2. Select the disk to be reserved.

3. Choose Disks > Properties (Selected menu).

4. In the Disk Properties window, go to the General tab and select Reserve. Click OK.

If you decide that you want to return a reserved disk to the free space pool, open the Disk

Properties window and click Reserve again.

Notes:

◆ A reserved disk does not belong to the free space pool and is not available for

general use.

◆ A reserved disk can only be used if you specify the reserved disk when you

perform a task.
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Renaming a Disk
This procedure changes the Volume Manager name assigned to a disk. The Volume

Manager disk name is the name given to the disk by the administrator or the Volume

Manager. This procedure does not change the physical disk name (device name).

▼ To rename a disk

1. Select the disk to be renamed.

2. Choose Disks > Rename (Selected menu) or Disk Rename (Command Launcher).

3. Complete the Rename Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

New Name: Type the new Volume Manager disk name.

Notes:

◆ This task requires the current disk name and a new disk name.

◆ The new disk name must be unique within the disk group.

◆ The disk must be in an imported disk group.
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Offlining a Disk
This procedure prevents the Volume Manager from accessing a disk. A disk must be

removed from its disk group before it can be taken offline (see “Removing a Disk”). An

offline disk remains unavailable until you restore access to the disk (see “Onlining a

Disk”).

▼ To take a disk offline

1. Select the disk to be taken offline.

2. Choose Disks > Offline (Selected menu) or Disk Offline (Command Launcher).

3. Complete the Offline Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Notes:

◆ When a disk is offline, the disk cannot be accessed by the Volume Manager.

◆ A disk can be taken offline to protect it from unintentional use. Disks should be

taken offline if they are not accessible and attempts to access them may have a

negative effect on the system.

◆ Only disks that do not belong to a disk group can be taken offline.

◆ Disks that are in use cannot be taken offline.
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Onlining a Disk
This procedure restores access to a disk that has been taken offline. The disk is placed in

the free disk pool and is accessible to the Volume Manager again. After bringing a disk

back online, the disk must be added to a disk group before it can be used for volumes (see

“Adding a Disk to the Volume Manager”).

▼ To bring a disk online

1. Select the disk to be brought online.

2. Choose Disks > Online (Selected menu) or Disk Online (Command Launcher).

3. Complete the Online Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Notes:

◆ When a disk is brought online, the disk is accessible again.

◆ Only disks in the offline state can be brought online.
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Mirroring a Disk
This procedure mirrors (copies) all concatenated volumes on a disk onto another disk and

sets up the target disk as a boot disk. This is a convenient way of creating an alternate boot

(root) disk, which can be used to boot the system if the original boot disk fails. You can use

this procedure to mirror any disk that contains concatenated volumes.

▼ To mirror all concatenated volumes on a disk

1. Select the disk that contains the concatenated volumes to be mirrored onto another

disk.

2. Choose Disks > Mirror (Selected menu) or Disk Mirror (Command Launcher).

3. Complete the Mirror Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Options To specify the disk to contain the new mirrors, click the Browse

button next to the Target Disk(s) field and select a disk.

Notes:

◆ This task requires a disk name.

◆ This task is typically used to mirror the contents of the boot disk onto another disk,

which can be used as an alternate boot disk. After mirroring the root and swap

volumes (which must be named rootvol and swapvol , respectively), this task sets

up the target disk as a boot disk.

◆ Only concatenated volumes that reside on a single disk are mirrored onto the other

disk. Any RAID-5, striped, or spanned volumes on the disk are ignored.

◆ Only disks in the same disk group can be used to create the new mirrors.

◆ The target disk must contain sufficient space to accommodate the mirror(s).

◆ A new mirror cannot be created on a disk that already contains a copy of the

volume.

◆ If no disks are assigned, the Volume Manager uses available disk space to create the

mirror(s).
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Evacuating a Disk
This procedure moves the contents of the volumes on a disk to another disk. If a disk

begins to fail, you can attempt to protect/preserve the volumes on that disk by evacuating

the disk. You can also evacuate a disk if you plan to remove the disk or use the disk

elsewhere.

▼ To evacuate a disk

1. Select the disk that contains the objects and data to be moved to another disk.

2. Choose Disks > Evacuate (Selected menu) or Disk Evacuate (Command Launcher).

3. Complete the Evacuate Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Options To specify the disk(s) to which the contents of the evacuated

disk should be moved, click the Browse button next to the

Target Disk(s) field and select a disk.

Notes:

◆ This task requires a disk name.

◆ The contents of a disk must be evacuated/moved to another disk(s) in the same disk

group with sufficient free space.

◆ If no target disk is specified, the Volume Manager will use an available disk(s) with

sufficient free space.

◆ If the disk being evacuated contains part of a mirrored, striped, or RAID-5 volume,

the contents of the disk should not be moved to another disk containing a copy of

the mirrored volume or part of the striped/RAID-5 volume.
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Disconnecting a Disk
This procedure disconnects a Volume Manager disk from its underlying physical disk.

You can disconnect a disk in preparation for the replacement of a physical disk. After

disconnecting a disk, you can use the Replace Disk task to reconnect the disk (see

“Replacing a Disk”).

▼ To disconnect a disk

1. Select the disk to be disconnected.

2. Choose Hosts > Disconnect Disk (Selected menu) or Disk Disconnect (Command

Launcher).

3. Complete the Disconnect Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk: If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Notes:

◆ This task requires a disk name.

◆ Disconnecting a disk that contains volumes can result in loss of data or redundancy.
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Replacing a Disk
This procedure replaces an existing disk with a new physical disk, moves any volumes to

the new disk, and attempts to recover any redundant (mirrored or RAID-5) volumes on

the disk. Non-redundant volumes cannot be recovered and should be restored from

backup, if possible. If the disk being replaced is a boot disk, this procedure also sets up the

new disk as a boot disk.

You may need to replace a disk if the disk fails and/or needs to be removed and repaired.

You can use this task to reconnect a disk that has been disconnected in preparation for

replacement (see “Disconnecting a Disk”).

If you replace a healthy disk, you need to remove the disk from its disk group and place it

in the free disk pool before you replace the disk (see “Removing a Disk”). If the disk to be

replaced has failed and is disconnected, you do not need to remove the disk.

▼ To replace a disk

1. Select the disk to be replaced.

2. Choose Disks > Replace (Selected menu) or Disk Replace (Command Launcher).

3. Complete the Replace Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name is not already displayed in this field,

type the Volume Manager disk name for the disk to be

replaced or click Browse to select the disk.

New Physical Disk: Type the physical disk name for the new (replacement) disk or

click Browse to select a disk.

Options To set up any new disks on the system, click Scan Disks. This

runs the disk setup commands appropriate for the operating

system.
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Notes:

◆ This task requires the name of the disk to be replaced and the replacement disk

name.

◆ The disk to be replaced must be disconnected or removed from its disk group. If the

disk has not failed, you need to remove the disk from its disk group and put it in the

free disk pool before you replace the disk.

◆ The new disk can be a disk in the free disk pool or an uninitialized disk. If the new

disk is uninitialized, this task places the disk under Volume Manager control.

◆ The new disk is placed in the old disk’s disk group.
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Unrelocating a Disk
This procedure moves relocated subdisks back to their original disk. When a disk fails, the

hot-relocation feature attempts to move subdisks from the failed disk to other disks. The

Unrelocate Disk task can be used to return the relocated subdisks to their original disk

locations after the original disk is repaired or replaced.

▼ To move relocated subdisks back to a disk

1. Select the disk that contained the subdisks before hot-relocation.

2. Choose Disks > Unrelocate (Selected menu) or Disk Unrelocate (Command

Launcher).

3. Complete the Unrelocate Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the original disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk. This is

the disk that contained the subdisks before they were

relocated.

Options ◆ To view subdisks that were relocated by the

hot-relocation feature, click View Relocations.

◆ To move the relocated subdisks to a disk other than the

original disk, specify an alternate disk in the Alternate

Destination Disk field.

◆ To move the subdisks back to their original locations on

the original disk, click Use Exact Offsets. If the original

locations are not available, it may be necessary to turn off

this option so that the subdisks can be moved to any

available space on the disk.
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Notes:

◆ This task requires the name of the original disk (even if an alternate disk is

specified).

◆ When a disk fails, the hot-relocation feature attempts to move subdisks from the

failed disk to other disks. The Unrelocate Disk task can be used to return the

relocated subdisks to their original disk locations after the original disk is repaired

or replaced.

◆ It is not possible to return relocated subdisks to their original disks after their disk

group’s relocation information has been cleared with the Clear Disk Group

Relocation Information task.
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Recovering Volumes on a Disk
This procedure performs any necessary volume recovery operations on the volumes on a

given disk. The recovery operations depend on the types of volumes on the disk and

include starting disabled volumes, resynchronizing mirrors in mirrored volumes, and

resynchronizing parity in RAID-5 volumes. After successful recovery, the volumes should

be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know that volume

recovery is needed.

▼ To recover all volumes on a disk

1. Select the disk containing the volumes to be recovered.

2. Choose Disks > Recover (Selected menu) or Disk Recover (Command Launcher).

3. Complete the Recover Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk(s): If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Notes:

◆ In some cases, recovery may not be possible. If the volume recovery fails, you can

attempt to restore the volume from backup.
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Removing a Disk
This procedure removes a disk from its disk group and either places the disk in the free

disk pool or removes the disk from Volume Manager control. If the disk is returned to the

free space pool, the disk must be added to a disk group before it can be used for volumes

(see “Adding a Disk to the Volume Manager”).

If the disk to be removed contains volumes, you must evacuate the disk before you

remove the disk.

▼ To remove a disk from a disk group or Volume Manager

1. Select the disk to be removed.

2. Choose Disks > Remove (Selected menu) or Disk Remove (Command Launcher).

3. Complete the Remove Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name(s): If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Select a destination for

the disks:

Specify where to place the disk after removal:

◆ To remove the disk from its disk group and place it in the

free disk pool, select Free Disk Pool. The disk will remain

under Volume Manager control.

◆ To remove the disk from Volume Manager control, select

Uninitialized State.
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Notes:

◆ This task requires a disk name. You also need to specify whether the disk should be

placed in the free disk pool or removed from Volume Manager control.

◆ If the disk contains a volume that has only one mirror and either has a mounted file

system or is used as a swap area, you must evacuate the disk before you remove it.

◆ When a disk is removed from a disk group or Volume Manager control, the disk

cannot be accessed.

◆ A disk that is in use (i.e. contains volumes) should not be removed. Removing a disk

with volumes can result in loss of data or data redundancy. If volumes exist on the

disk to be removed, you can use the Evacuate Disks task to move the volumes to

another disk.

◆ The last disk in a disk group cannot be removed. To remove the last disk in a disk

group, the disk group must be destroyed. The last disk in the rootdg  disk group

can never be removed.

◆ Any non-redundant volumes on the removed disk become disabled.
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Forcing Initialization of a Disk

Caution Forcing the (re)initialization of a disk can result in data loss.

This procedure forces the initialization of a disk. This procedure can be used to reinitialize

a disk. This task is intended for use in troubleshooting disks that have already been placed

under Volume Manager control. To initialize a disk for Volume Manager use, use the Add

Disks task instead (see “Adding a Disk to the Volume Manager”).

▼ To (re)initialize a disk

1. Select the disk to be initialized.

2. Choose Hosts > Initialize Disk (Selected menu) or Disk Initialize (Command

Launcher).

3. Complete the Initialize Disk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Name: If the correct disk name is not already displayed in this field,

type the disk’s name or click Browse to select the disk.

Notes:

◆ This task requires a disk name.

◆ This task forces the (re)initialization of a disk and may result in data loss.

◆ This task overwrites existing disk header and configuration information on the

disk. Any volume copies or regions located on the disk will not be accessible after

you reinitialize the disk.
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Viewing Disk Properties
The Disk Properties window contains detailed information about the selected disk. The

Properties window contains a set of tabbed pages, each of which contains information

about the disk and related objects. You can display a different page by clicking on the

appropriate tab label.

❖ To view the properties of a disk, select the disk and then choose Properties from the

Disks or popup menu. You can also access the Disk Properties window by

double-clicking on the disk.

❖ To find available space on the disk, click on the Subdisks tab. Areas of free space are

listed as “gaps” in the Subdisks tab. To sort the subdisks and gaps by their location on

the disk, click the Disk Offset column heading.

❖ To update the contents of the Properties window to reflect current properties for the

disk, click Refresh.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
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Disabling a Controller
This procedure disables I/O to a controller. This procedure also prevents the Dynamic

Multipathing feature from accessing the paths associated with a controller. You can

disable access to a controller in preparation for hardware maintenance.

▼ To enable a controller

1. Select the controller to be disabled.

2. Choose Controller Disable (Command Launcher).

3. Complete the Disable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Controller Name(s): If the correct controller name is not already displayed in this

field, type the controller’s name or click Browse to select the

controller.

Options Click Show Options to access the optional settings for this task.

◆ To disable all enclosures (disk arrays) associated with this

controller, select All Enclosures.

◆ To disable specific enclosures associated with this

controller, type the enclosure names in the Selected

Enclosures field or click Browse to select the enclosures.

Notes:

◆ This task requires a controller name.

◆ This task prevents I/O and the Volume Manager Dynamic Multipathing feature

from accessing the paths associated with the specified controller.

◆ The specified controller cannot contain the last enabled path to the root disk.
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Enabling a Controller
This procedure enables I/O to a controller. If the Dynamic Multipathing feature is

enabled, this procedure also restores access to the paths associated with a controller.

▼ To enable a controller

1. Select the controller to be enabled.

2. Choose Controller Enable (Command Launcher).

3. Complete the Enable Controller dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Controller Name(s): If the correct controller name is not already displayed in this

field, type the controller’s name or click Browse to select the

controller.

Options Click Show Options to access the optional settings for this task.

◆ To enable all enclosures (disk arrays) associated with this

controller, select All Enclosures.

◆ To enable specific enclosures associated with this

controller, type the enclosure names in the Selected

Enclosures field or click Browse to select the enclosures.

Notes:

◆ This task requires a controller name.

◆ This task makes the paths associated with the specified controller available to I/O

and the Volume Manager Dynamic Multipathing feature.
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Renaming an Enclosure
This procedure changes the name of an enclosure (disk array).

▼ To rename an enclosure

1. Select the enclosure to be renamed.

2. Choose Enclosures > Rename (Selected menu) or Enclosure Rename (Command

Launcher).

3. Complete the Rename Enclosure dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Enclosure Name: If the correct enclosure name is not already displayed in this

field, type the name or click Browse to select the enclosure.

New Name: Type the new enclosure name.

Notes:

◆ This task requires the current enclosure name and a new enclosure name.

◆ The new enclosure name must be unique within the disk group.
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Creating a Disk Group
This procedure creates an additional disk group. Disks must be placed in disk groups

before they can be used by the Volume Manager. The default disk group (rootdg ) is

usually created during Volume Manager installation and always exists on a system

running the Volume Manager. You can create additional disk groups to organize your

disks into logical sets of disks.

When you place a disk under Volume Manager control, the disk is either encapsulated or

initialized. Encapsulation preserves any existing data on the disk in volumes.

Initialization destroys any existing data on the disk.

▼ To create a disk group

1. Select the appropriate host machine.

2. Choose File > New > Disk Group (menu) or Disk Group Create (Command

Launcher).

3. Complete the New Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

4. Indicate whether the disk should be initialized or encapsulated. If you initialize the

disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any

existing data will be preserved in volumes.

Disk Group Name: Type the name of the disk group to be created. Click View to

view the names of existing disk groups.

To set up any new disks on the system, click Scan Disks. This

runs the disk setup commands appropriate for the operating

system.

Disk Device(s): Select the disk(s) to be placed in the new disk group.

Options Click Show Options to access the optional settings for this task.

◆ To create a shared disk group, select Create Shared. This

option is only applicable in a cluster environment.

◆ To specify the Volume Manager disk name for the disk,

type a disk name in the Disk Name(s) field. If no Volume

Manager disk name is specified, the Volume Manager

assigns a default name to the disk.

◆ To apply a comment or attribute to disks that are placed in

the disk group, type the information in the Comment field.
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5. If you chose to encapsulate the disk, reboot the system.

Notes:

◆ This task requires a disk group name and the name of at least one disk.

◆ The disk group name must be unique.

◆ The new disk group must contain at least one disk.

◆ Only disks that are online and do not belong to a disk group can be used to create a

disk group.

◆ When a disk is placed under Volume Manager control, the disk is either initialized

or encapsulated. Encapsulation preserves any existing data on the disk in the form

of volumes. Initialization destroys any existing data on the disk. Encapsulation is

recommended for the root/boot disk and any other disks that contain valuable data.

◆ The Volume Manager disk name must be unique within the disk group.

◆ If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, the Volume Manager appends numbers to the disk

name so that each disk name is unique within its disk group.
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Upgrading a Disk Group
This procedure upgrades a disk group to the disk group version that is compatible with

the current Volume Manager release. Some new features and tasks only work on disk

groups with the current disk group version, so you must upgrade existing disk groups

before you perform these tasks. However, after you upgrade a disk group, you cannot

access that disk group from machines running earlier releases of the Volume Manager.

To determine if a disk group needs to be upgraded, select the disk group and open the

Disk Group Properties window. The Version field of the Properties window indicates

whether the disk group has been upgraded to the current disk group version.

▼ To upgrade a disk group

1. Select the disk to be upgraded to the current version.

2. Choose Disks Groups > Upgrade (Selected menu) or Disk Group Upgrade (Command

Launcher).

3. Complete the Upgrade Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name is not already displayed in this

field, type the disk group’s name or click Browse to select the

disk group.

Notes:

◆ Disk groups created with earlier releases of the Volume Manager must be

upgraded before they can take advantage of new features and tasks in the current

release.

◆ If a disk group is upgraded to the current disk group version, you cannot import

that disk group on a machine running an earlier Volume Manager release. Disk

groups that must remain backward compatible with earlier releases of the Volume

Manager should not be upgraded.
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Renaming a Disk Group
This procedure changes the name of an existing disk group. You might rename a disk

group to provide a more appropriate name or avoid a name conflict with a disk group to

be imported.

▼ To rename a disk group

1. Select the disk group to be renamed.

2. Choose Disks Groups > Rename (Selected menu) or Disk Group Rename (Command

Launcher).

3. Complete the Rename Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: If the correct disk group name is not already displayed in this

field, type the disk group’s name or click Browse to select the

disk group.

New Name: Type the new name for the disk group.

Notes:

◆ This task requires the current disk group name and a new disk group name.

◆ The new disk group name must be unique.

◆ This task deports and reimports the disk group. If volumes in the disk group are in

use, the deport fails and the disk group is not renamed.

◆ This task updates the file system table file, if necessary.

◆ If the disk group contains volumes with mounted file systems, you may need to

unmount the file systems.
Chapter 3, Disk Tasks 95



Deporting a Disk Group
Deporting a Disk Group
This procedure makes a disk group and its volumes inaccessible. Once deported, a disk

group cannot be used until it is imported. You can deport a disk group to make the disk

group temporarily unavailable.

While a disk group is deported, you cannot remove and reuse any of its disks. To remove

disks, you must import the disk group and then either destroy the disk group (to remove

all of its disks) or remove selected disks from the disk group.

▼ To deport a disk group

1. Select the disk group to be deported.

2. Choose Disk Groups > Deport (Selected menu) or Disk Group Deport (Command

Launcher).

3. Complete the Deport Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: If the correct disk group name is not already displayed in this

field, type the disk group’s name or click Browse to select the

disk group.

Options Click Show Options to access the optional settings for this task.

◆ To change the name of the disk group at deport, type a new

disk group name in the New Name field.

◆ To set up a host machine to import the deported disk group

at reboot, type the host ID in the New Host field.

Notes:

◆ This task requires a disk group name.

◆ A deported disk group cannot be accessed. To access a deported disk group, the

disk group must be imported.

◆ The rootdg  disk group cannot be deported.

◆ A disk group cannot be deported if any volumes in that disk group are in use (open).

◆ When a disk group is deported, the host ID stored on all disks in the disk group is

cleared and the disk group is not reimported automatically when the system is

rebooted. However, if you specify a host in New Host option, the specified host will

import the disk group at reboot.
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Importing a Disk Group
This procedure makes a deported (inaccessible) disk group and its volumes accessible

again. To import a deported disk group, you must know the disk group’s former name

and this disk group name must remain unused. In addition, at least one disk formerly

assigned to the deported disk group must remain unused.

▼ To import a disk group

1. Select the appropriate host machine node.

2. Choose Hosts > Import Disk Group (Selected menu) or Disk Group Import

(Command Launcher).

3. Complete the Import Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Type the name of the disk group to be imported or click

Browse to select the disk group.

Options Click Show Options to access the optional settings for this task.

◆ To start all volumes in the disk group at import, select Start

All Volumes.

◆ To clear the existing host ID stamp on all disks in the disk

group at import, select Clear Host ID. Do not use this

option if another host is using any disk(s) in the disk

group.

◆ To force the disk group import when the host cannot access

all disks in the disk group, select Force Import. This option

can be used to import a disk group that contains a failed

disk, but can lead to disk group inconsistency if all disks

are still usable.

◆ To import the disk group as a shared disk group, select

Import Shared. This option is only applicable in a cluster

environment.

◆ To change the name of the disk group at import, type a new

disk group name in the New Name field. To indicate that

the name change is temporary, select Use New Name as

Temporary.
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Notes:

◆ This task requires a disk group name.

◆ Only deported disk groups can be imported.

◆ A deported disk group cannot be imported if another disk group with the same

name has been created since the disk group was deported.

◆ A disk group import may fail if the host cannot find one or more disks in the disk

group. If the import fails because a disk has failed, you can import the disk group by

selecting the Force Import option. If the import fails for another reason, a forced

import can cause serious problems.

◆ When a disk group is imported, the system stamps its host ID on all disks in the disk

group. A disk group import should fail if one of the disks is stamped with a host ID

that does not match the others. This ensures that dual-ported disks cannot be

managed (and possibly corrupted) by two systems at the same time. If you are sure
that the disk group is not in use by another host, you can clear the host IDs and

import the disk group by selecting the Clear Host ID option.
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Recovering Volumes in a Disk Group
This procedure performs any necessary volume recovery operations on the volumes in a

given disk group. The recovery operations depend on the types of volumes in the disk

group and include starting disabled volumes, resynchronizing mirrors in mirrored

volumes, and resynchronizing parity in RAID-5 volumes. After successful recovery, the

volumes should be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know that volume

recovery is needed.

▼ To recover all volumes in a disk group

1. Select the disk group containing the volumes to be recovered.

2. Choose Disk Groups > Recover (Selected menu) or Disk Group Recover (Command

Launcher).

3. Complete the Recover Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name is not already displayed in this

field, type the disk group’s name or click Browse to select the

disk group.

Notes:

◆ In some cases, recovery may not be possible. If the volume recovery fails, you can

attempt to restore the volume from backup.
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Clearing Relocation Information for a Disk Group
This procedure clears hot-relocation alerts and removes relocation data from a disk group.

▼ To clear relocation information for a disk group

1. Select the disk group containing hot-relocation information to be cleared.

2. Choose Disk Groups > Clear Relocation Information (Selected menu) or Disk Group

Clear Relocation Info (Command Launcher).

3. Complete the Clear Disk Group Relocation Information dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group(s): If the correct disk group name is not already displayed in this

field, type the disk group’s name or click Browse to select the

disk group.

Notes:

◆ Hot-relocation automatically relocates subdisks from a failed disk to other disks.

The disk group records information about the hot-relocation and former subdisk

locations. After successful hot-relocation, alerts may remain on objects in the Storage

Administrator. The Clear Disk Group Relocation Information task removes all

records of the former subdisk locations from the disk group and clears any alerts.

◆ After clearing the disk group relocation information, it is not possible to use the

Unrelocate Disk task to return the relocated subdisks to their original disks.
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Destroying a Disk Group

Caution Destroying a disk group can result in data loss.

This procedure permanently removes a disk group from Volume Manager control. This

also reinitializes all of the disks in the disk group as empty disks and places them in the

free disk pool for reuse.

You should only destroy a disk group if you are sure that you no longer need the volumes

and data in the disk group. Since the last disk in a disk group cannot be removed,

destroying a disk group is useful for freeing the last disk in a disk group for reuse.

▼ To destroy a disk group

1. Select the appropriate host machine node.

2. Choose Hosts > Destroy Disk Group (Selected menu) or Disk Group Destroy

(Command Launcher).

3. Complete the Destroy Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Type the name of the disk group to be destroyed or click

Browse to select the disk group.

Notes:

◆ Destroying a disk group permanently removes the disk group from Volume

Manager control and can result in data loss. This task should be used with caution.

◆ When a disk group is destroyed, its disks are returned to the free disk pool. Any

volumes in the disk group are removed.

◆ The rootdg  disk group cannot be destroyed.

◆ A disk group cannot be destroyed if any volumes in that disk group are in use

(open) and/or contain mounted file systems.
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Moving a Disk Group
This procedure moves a disk group (and the Volume Manager objects in that disk group)

from one system to another. This relocates the disk group’s configuration to the new

system.

▼ To move a disk group from one machine to another

1. Unmount and stop all volumes in the disk group to be moved. (See Chapter 4 for

information on how to unmount and stop volumes.)

2. Follow the instructions in “Deporting a Disk Group” to deport the disk group to be

moved to the other system.

3. Attach all of the physical disks in the disk group to the new system.

4. On the new system, follow the instructions in “Importing a Disk Group” to import the

disk group.

5. Select the appropriate host machine node and choose Hosts > Scan Disks (Selected

menu) to set up the newly attached disks on the system. This runs the disk setup

commands appropriate for the operating system.

6. Follow the instructions in “Recovering Volumes in a Disk Group” to restart and

recover all volumes in the disk group on the new system.

Notes:

◆ The Volume Manager and the Storage Administrator (server) must be running on

both systems.
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Viewing Disk Group Properties
The Disk Group Properties window contains detailed information about the selected disk

group. The Properties window contains a set of tabbed pages, each of which contains

information about the disk group and related objects. You can display a different page by

clicking on the appropriate tab label.

❖ To view the properties of a disk group, select the disk group and then choose

Properties from the Disk Groups or popup menu.

❖ To update the contents of the Properties window to reflect current properties for the

disk group, click Refresh.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
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Volume Tasks
 4

Introduction

This chapter describes how to create and use volumes with the Volume Manager Storage

Administrator. It also includes information on how to use file systems with volumes. The

Volume Task Roadmap and File System Task Roadmap at the beginning of this chapter

contain summaries of common volume and file system tasks.

The following volume tasks are discussed in this chapter:

◆ Creating a Volume

◆ Resizing a Volume

◆ Renaming a Volume

◆ Changing a Volume’s Layout

◆ Adding a Mirror to a Volume

◆ Adding a Log to a Volume

◆ Stopping a Volume

◆ Starting a Volume

◆ Creating a Snapshot Copy of a Volume

◆ Merging a Snapshot Volume

◆ Dissociating a Snapshot Volume

◆ Preparing to Restore a Volume From Backup

◆ Recovering a Volume

◆ Repairing a Mirror

◆ Disabling a Mirror

◆ Removing a Mirror From a Volume

◆ Removing a Log From a Volume

◆ Removing a Volume
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◆ Associating a Plex

◆ Dissociating a Plex

◆ Moving a Subdisk

◆ Splitting a Subdisk

◆ Joining Subdisks

◆ Removing a Subdisk

◆ Viewing Volume Properties

The following file system tasks are discussed in this chapter:

◆ Adding a File System to a Volume

◆ Mounting a File System on a Volume

◆ Unmounting a File System on a Volume

◆ Resizing a File System

◆ Creating a Snapshot Copy of a File System

◆ Checking a File System on a Volume

◆ Viewing File System Properties

The following VERITAS QuickLog tasks are discussed in this chapter:

◆ Creating a QuickLog Log on a Volume

◆ Enabling the QuickLog Log for a File System

◆ Disabling the QuickLog Log for a File System

◆ Removing a QuickLog Log
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Volume Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator volume tasks.

To do this... Use this procedure...

Volume Setup Tasks:

Create new volume(s) Creating a Volume

Precautionary Tasks:

Mirror (copy) volumes onto other disks for

redundancy

Adding a Mirror to a Volume

Create mirrored volumes Creating a Volume

Add a log to a mirrored volume Adding a Log to a Volume

Add a log to a RAID-5 volume Adding a Log to a Volume

Maintenance Tasks:

Add space to volumes Resizing a Volume

Change volume layouts Changing a Volume’s Layout

Add mirrors to volumes that should be redundant Adding a Mirror to a Volume

Create a snapshot copy of a volume for backup Creating a Snapshot Copy of a Volume

Move portions of volumes to other disk space Moving a Subdisk
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Recovery Tasks:

Attempt to recover a volume Recovering a Volume

Attempt to recover all volumes on a disk Recovering Volumes on a Disk (see Chapter 3)

Attempt to recover all volumes in a disk group Recovering Volumes in a Disk Group (see

Chapter 3)

Prepare to restore a volume from backup Preparing to Restore a Volume From Backup

Repair or reattach a volume’s disabled mirror Repairing a Mirror

Other Tasks:

Change a volume’s name Renaming a Volume

Temporarily prevent access to a volume Stopping a Volume

Restore access to a stopped volume Starting a Volume

Temporarily prevent access to a volume’s mirror Disabling a Mirror

Remove a mirror from a volume Removing a Mirror From a Volume

Remove a DRL log from a volume Removing a Log From a Volume

Remove a RAID-5 log from a volume Removing a Log From a Volume

Remove a volume Removing a Volume

To do this... Use this procedure...
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File System Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator file system tasks. Note that some of these tasks are only available for the

VERITAS File System™ (referred to as VxFS or vxfs ).

To do this... Use this procedure...

File System Setup Tasks:

Create a volume with a file system Creating a Volume

Place a file system on an existing volume Adding a File System to a Volume

Mount a file system on a volume Mounting a File System on a Volume

Maintenance Tasks:

Add more space to a file system Resizing a File System

Create a snapshot copy of a file system for backup Creating a Snapshot Copy of a File System

Recovery Tasks:

Perform a file system consistency check Checking a File System on a Volume

Other Tasks:

Unmount a file system Unmounting a File System on a Volume
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Creating a Volume
The Volume Manager uses logical volumes to organize and manage disk space. A volume

is made up of portions of one or more physical disks, so it does not have the physical

limitations of a physical disk.

A volume can provide greater capacity and better availability and performance than a

single physical disk. A volume can be extended (grown) across multiple disks to increase

capacity, mirrored (copied) on another disk to provide data redundancy, and/or striped

across multiple disks to improve I/O performance.

You can use the Volume Manager Storage Administrator to create the following types of

volumes:

◆ Concatenated Volume

A concatenated volume is made up of one or more disk regions that are linked

together (concatenated) in a linear fashion. A concatenated volume can consist of disk

regions on multiple disks; a concatenated volume that extends across two or more

disks is also known as a spanned volume.

Note that the data in this type of volume cannot be recovered if the underlying disk

fails. However, a concatenated volume can be mirrored (copied) onto another disk(s)

to protect its data against disk failure.

◆ Striped Volume

A striped volume’s data is interleaved (striped) across two or more physical disks. A

striped volume’s data is spread across the disks alternately and evenly in small,

equal-sized portions of data called stripe units. Striping improves performance.

Note that the data in this type of volume cannot be recovered if one of the underlying

disks fails. However, a striped volume can be mirrored (copied) onto another disk(s)

to protect its data against disk failure.

◆ RAID-5 Volume

A RAID-5 volume’s data is interleaved (striped) across three or more physical disks.

Within each stripe across the set of disks, the data on one of the disks is parity data. If

one of the physical disks fails, the parity data can be used to reconstruct and recover

the lost data.

Note that RAID-5 volumes cannot be mirrored.
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◆ Mirrored Volume

Volumes with concatenated or striped layouts can be mirrored to increase data

availability. All of the data in a mirrored volume is duplicated on at least one other

physical disk. If one of the disks fails, the data can still be accessed from one of the

remaining disks.

The plexes in a mirrored volume typically have the same layout, but a volume can

consist of plexes with different layouts. A mirrored volume has a “mixed” layout if

the plexes in the volume have different layouts.

◆ Layered Volume

A layered volume is built on one or more other volumes. The underlying volumes are

typically mirrored. In layered volumes, mirroring is done at a lower level and with

smaller granularity than with non-layered volumes, so each mirror covers a relatively

small storage region.

Layered volumes tolerate disk failure better than non-layered volumes and provide

improved data redundancy. If a disk in a layered volume fails, only a portion of the

redundancy is lost and recovery time is usually quicker than it would be for a

non-layered volume. Layered volumes also reduce the chance that two disk failures

will result in lost data.

The underlying volumes in a layered volume are used exclusively by the Volume

Manager and are not intended for user manipulation.

With the Storage Administrator, you can create the following types of layered

volumes:

◆ Concatenated Pro Volume

A concatenated pro volume is a layered concatenated volume that is mirrored.

◆ Striped Pro Volume

A striped pro volume is a layered striped volume that is mirrored.

The following table summarizes the advantages and disadvantages of each volume

layout.
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Table 1. Layout Comparison

Layout Advantages Disadvantages

Concatenated ◆ The volume can consist of disk

regions that are not adjacent.

◆ The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

◆ The volume can be mirrored to

protect data against disk failure

and reduce the risk of data loss.

◆ There is a risk of data loss if the

volume is not mirrored.

◆ Spanning a volume across multiple

disks increases the chance that a disk

failure will result in the failure of the

volume.

◆ Concatenation does not improve

I/O performance.

Striped ◆ Striping provides improved read

and write performance.

◆ Striping can help to balance the

I/O load from multi-user

applications across multiple

disks.

◆ The volume can be mirrored to

protect data against disk failure.

◆ There is a risk of data loss if the

volume is not mirrored.

◆ Striping a volume across multiple

disks increases the chance that a disk

failure will result in the failure of the

volume.

◆ A striped volume requires at least

two disks.

RAID-5 ◆ RAID-5 provides protection

against disk failure and reduces

the risk of data loss.

◆ RAID-5 provides data

redundancy by storing parity (a

calculated value) on the disks. If

a disk fails, the parity is used to

reconstruct the missing data.

◆ RAID-5 requires less storage

space than mirroring.

◆ RAID-5 provides improved read

performance.

◆ RAID-5 provides relatively slow

write performance.

◆ RAID-5 volumes cannot be

mirrored.

◆ A RAID-5 volume requires at least

three disks. If logging is enabled, a

RAID-5 volume requires at least four

disks.

◆ A RAID-5 volume cannot survive

multiple disk failures. However,

optional RAID-5 logs reduce this

risk.

◆ If one of the volume’s disks is

inaccessible, performance is

degraded.
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Mirrored ◆ Mirroring provides protection

against disk failure and reduces

the risk of data loss.

◆ Mirroring provides data

redundancy by maintaining

multiple complete copies of a

volume’s data on different disks.

◆ Mirroring provides improved

read performance.

◆ A mirrored volume requires extra

disk space. Each mirror requires

enough disk space to contain a

complete copy of the volume.

Concatenated Pro ◆ The volume is layered and

mirrored. This provides

improved data redundancy and

reduces the impact of disk

failures.

◆ Recovery time is quicker than

with regular concatenated

volumes that are mirrored.

◆ The volume can consist of disk

regions that are not adjacent.

◆ The volume can span multiple

disks. A spanned volume can

have a greater capacity than a

single disk.

◆ A concatenated pro volume requires

at least two disks.

◆ Concatenation does not improve

I/O performance.

◆ Layered volumes consist of more

Volume Manager objects than

non-layered volumes and are likely

to fill up the disk group’s

configuration database sooner.

When the configuration database is

full, you cannot create more

volumes in the disk group.

Striped Pro ◆ The volume is layered and

mirrored. This provides

improved data redundancy and

reduces the impact of disk

failures.

◆ Recovery time is quicker than

with regular striped volumes

that are mirrored.

◆ Striping provides improved read

and write performance.

◆ Striping can help to balance the

I/O load from multi-user

applications across multiple

disks.

◆ A striped pro volume requires at

least four disks.

◆ Layered volumes consist of more

Volume Manager objects than

non-layered volumes and are likely

to fill up the disk group’s

configuration database sooner.

When the configuration database is

full, you cannot create more

volumes in the disk group.

Table 1. Layout Comparison

Layout Advantages Disadvantages
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▼ To create a concatenated volume

This procedure creates a concatenated volume that consists of one or more regions of the

specified disk(s). This procedure also gives you the options of placing a file system on the

new volume or mirroring the volume.

You can use this procedure to create a regular concatenated volume or a concatenated pro

volume. A concatenated pro volume is layered and mirrored.

1. Select the appropriate host machine.

2. Choose File > New > Volume (menu) or Volume Create (Command Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse to select

another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size. The default size unit is sectors. To

specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize.

Layout: Choose Concatenated or Concatenated Pro for the volume

layout.
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When you have provided all necessary information in the dialog box, click OK.

Options ◆ To mirror the volume, select Mirrored. In the Total Number

of Mirrors field, type the total number of mirrors for the

volume. (Note: Concatenated pro volumes are mirrored by

default.)

To enable logging for a mirrored volume, select Enable

Logging.

◆ To place the volume on a specific disk, click Assign Disks

and select the disk you want to use from the Space

Allocation dialog box.

◆ To place a file system on the volume, click Add File System

and specify the file system type and mount point in the

Add File System dialog box.

◆ To clear the volume before enabling it for general use,

select Initialize Zero.

◆ To prevent the creation of a layered volume, select No

Layered Volumes. In cases where a layered volume layout

is appropriate, the Volume Manager can create a layered

volume when a non-layered layout is specified. This option

ensures that the volume has a non-layered layout. If a

layered (Pro) layout is selected, this option is ignored.

◆ To add a comment attribute for the volume, type the

information in the Comment field.

Notes:

◆ This task requires a disk group name, volume name, volume size, and volume

layout.

◆ The volume size should be less than or equal to the available free space on the

disk(s).

◆ If no disks are assigned, the Volume Manager uses available space on disks in the

selected disk group.

◆ The data in a concatenated volume is not protected against disk failure unless the

volume is mirrored. At least one additional disk is required to mirror a concatenated

volume.

◆ Concatenated pro volumes are mirrored by default, so a concatenated pro volume

requires more disks than an unmirrored concatenated volume.

◆ You cannot use a concatenated pro volume for a root  or swap volume.

◆ If a file system is placed on the volume and the Mount at Boot option is selected, the

file system table file is automatically updated.
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▼ To create a striped volume

This procedure creates a striped volume that is spread across two or more disks. This

procedure also gives you the options of placing a file system on the new volume or

mirroring the volume.

You can use this procedure to create a regular striped volume or a striped pro volume. A

striped pro volume is layered and mirrored.

1. Select the appropriate host machine.

2. Choose File > New > Volume (menu) or Volume Create (Command Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse to select

another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size. The default size unit is sectors. To

specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize.

Layout: Choose Striped or Striped Pro for the volume layout.

In the Number of Columns field, specify the number of

columns (disks) across which the volume should be striped. A

striped volume requires at least two disks.

To specify a stripe unit size other than the default, type the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.
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When you have provided all necessary information in the dialog box, click OK.

Options ◆ To mirror the volume, select Mirrored. In the Total Number

of Mirrors field, type the total number of mirrors for the

volume. (Note: Striped pro volumes are mirrored by

default.)

To enable logging for a mirrored volume, select Enable

Logging.

◆ To stripe the volume across specific disks, click Assign

Disks and select the disks you want to use from the Space

Allocation dialog box.

◆ To place a file system on the volume, click Add File System

and specify the file system type and mount point in the

Add File System dialog box.

◆ To clear the volume before enabling it for general use,

select Initialize Zero.

◆ To prevent the creation of a layered volume, select No

Layered Volumes. In cases where a layered volume layout

is appropriate, the Volume Manager can create a layered

volume when a non-layered layout is specified. This option

ensures that the volume has a non-layered layout. If a

layered (Pro) layout is selected, this option is ignored.

◆ To add a comment attribute for the volume, type the

information in the Comment field.

Notes:

◆ This task requires a disk group name, volume name, volume size, and volume

layout.

◆ A striped volume requires at least two disks.

◆ The volume size should be less than or equal to the available free space on the

disk(s).

◆ If no disks are assigned, the Volume Manager uses available space on disks in the

selected disk group.

◆ The data in a striped volume is not protected against disk failure unless the volume

is mirrored. At least one additional disk is required to mirror a striped volume.

◆ Striped pro volumes are mirrored by default, so a striped pro volume requires more

disks than an unmirrored striped volume.

◆ You cannot use a striped pro volume for a root  or swap volume.

◆ If a file system is placed on the volume and the Mount at Boot option is selected, the

file system table file is automatically updated.
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▼ To create a RAID-5 volume

This procedure creates a RAID-5 volume that is spread across two or more disks and

contains parity information. This procedure also gives you the option of placing a file

system on the new volume.

1. Select the appropriate host machine.

2. Choose File > New > Volume (menu) or Volume Create (Command Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse to select

another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size in the Size field. The default size unit is

sectors. To specify a size unit, attach an s  (sectors), k
(kilobytes), m (megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize.

Layout: Choose RAID-5 for the volume layout.

In the Number of Columns field, specify the number of

columns (disks) across which the volume should be striped. A

RAID-5 volume requires at least three disks (or four disks if

logging is enabled).

To specify a stripe unit size other than the default, type the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s  (sectors), k  (kilobytes), m (megabytes), or g
(gigabytes) to the size.
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When you have provided all necessary information in the dialog box, click OK.

Options ◆ To stripe the volume across specific disks, click Assign

Disks and select the disks you want to use from the Space

Allocation dialog box.

◆ To place a file system on the volume, click Add File System

and specify the file system type and mount point in the

Add File System dialog box.

◆ To enable RAID-5 logging for the volume, select Enable

Logging. The Volume Manager adds an appropriate

number of logs to the volume.

◆ To clear the volume before enabling it for general use,

select Initialize Zero.

◆ To add a comment attribute for the volume, type the

information in the Comment field.

Notes:

◆ This task requires a disk group name, volume name, volume size, and volume

layout.

◆ A RAID-5 volume requires at least three disks. If logging is enabled, a

RAID-5 volume requires at least four disks.

◆ RAID-5 volumes cannot be mirrored.

◆ The volume size should be less than or equal to the available free space on the

disk(s).

◆ For a RAID-5 volume, the size specified in the Size field is the usable space in the

volume. The Volume Manager allocates additional space for the volume’s parity

information. The disks across which the RAID-5 volume will be striped should

therefore contain additional free space for the volume’s parity information.

◆ If no disks are assigned, the Volume Manager uses available space on disks in the

selected disk group.

◆ If a file system is placed on the volume and the Mount at Boot option is selected, the

file system table file is automatically updated.
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▼ To create a mirrored volume

This procedure creates a concatenated or striped volume that is mirrored (copied) on at

least one other disk. If one of the disks fails, the volume’s data can be accessed from the

surviving disk(s).

You can use this procedure to create a regular mirrored volume or a layered mirrored

volume. Concatenated pro and striped pro volumes are layered and mirrored by default.

1. Select the appropriate host machine.

2. Choose File > New > Volume (menu) or Volume Create (Command Launcher).

3. Complete the New Volume dialog box as follows:

Disk Group Name: Either accept the default disk group or click Browse to select

another disk group.

Volume Name: Type the new volume’s name (or accept the default name).

Size: Type the volume size in the Size field. The default size unit is

sectors. To specify a size unit, attach an s  (sectors), k
(kilobytes), m (megabytes), or g (gigabytes) to the size.

To determine the largest possible size for the volume, click

Maxsize.

Layout: Choose Concatenated, Striped, Concatenated Pro, or Striped

Pro for the volume layout.

For a striped or striped pro volume, provide the following

information:

◆ In the Number of Columns field, specify the number of

columns (disks) across which the volume should be

striped. A striped volume requires at least two disks.

◆ To specify a stripe unit size other than the default, type the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s (sectors), k (kilobytes), m(megabytes), or g
(gigabytes) to the size.

Mirror Info: ◆ Select Mirrored. In the Total Number of Mirrors field, type

the total number of mirrors for the volume. (Note:

Concatenated pro and striped pro volumes are mirrored by

default.)
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When you have provided all necessary information in the dialog box, click OK.

Options ◆ To place the volume on a specific disk(s), click Assign

Disks and select the disks you want to use from the Space

Allocation dialog box.

◆ To place a file system on the volume, click Add File System

and specify the file system type and mount point in the

Add File System dialog box.

◆ To enable Dirty Region Logging (DRL) for the volume,

select Enable Logging. The Volume Manager adds an

appropriate number of logs to the volume.

◆ To clear the volume before enabling it for general use,

select Initialize Zero.

◆ To prevent the creation of a layered volume, select No

Layered Volumes. In cases where a layered volume layout

is appropriate, the Volume Manager can create a layered

volume when a non-layered layout is specified. This option

ensures that the volume has a non-layered layout. If a

layered (Pro) layout is selected, this option is ignored.

◆ To add a comment attribute for the volume, type the

information in the Comment field.

Notes:

◆ This task requires a disk group name, volume name, volume size, and volume

layout.

◆ A mirrored volume requires at least two disks. If logging is enabled, the volume

requires at least one additional disk.

◆ Only concatenated or striped volumes can be mirrored.
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Resizing a Volume
This procedure changes the size of a volume. If users require more space on a volume, you

can use this procedure to increase the size of the volume. If a volume contains unused

space that you need to use elsewhere, you can use this procedure to shrink the volume. If

the volume contains a file system, this procedure also resizes the file system.

▼ To resize a volume

1. Select the volume to be resized.

2. Choose Volumes > Resize (Selected menu) or Volume Resize (Command Launcher).

3. Complete the Resize Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

New Size: Specify one of the following:

◆ To increase the volume size by a specific amount of space,

use the Add By field to specify how much space should be

added to the volume.

◆ To decrease the volume size by a specific amount of space,

use the Subtract By field to specify how much space should

be removed from the volume.

◆ To specify the new volume size, type the size in the Desired

Size field.

To determine the largest possible size for the volume, click

Maxgrow.

The default size unit is sectors. To specify a size unit, attach an

s (sectors), k (kilobytes), m(megabytes), or g (gigabytes) to the

size.

Options ◆ To use a specific disk for the additional space, click Assign

Disks and select the disk you want to use from the Space

Allocation dialog box.
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Notes:

◆ This task requires a volume name and either the desired size or the amount of space

to add to or subtract from the volume size.

◆ A volume containing file system other than vxfs  cannot be shrunk.

◆ Shrinking a volume with an unmounted file system can result in data loss, so a

volume containing an unmounted file system cannot be shrunk.

◆ When a volume is shrunk, the resulting extra space is returned to the free space

pool.

◆ When the volume size is increased, sufficient disk space must be available. When

increasing the size of a volume, the Volume Manager assigns the necessary new

space from available disks.
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Renaming a Volume
This procedure changes the name of a volume. If the volume has a file system, this

procedure also makes the necessary changes to the file system table file and allows you to

specify a new mount point for the file system.

▼ To rename a volume

1. Select the volume to be renamed.

2. Choose Volumes > Rename (Selected menu) or Volume Rename (Command

Launcher).

3. Complete the Rename Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

New Name: Type the new name for the volume.

Options If the volume contains a file system and you want to change

the mount point when the volume is renamed, type a new

mount point in the New Mount Point field.

Notes:

◆ This task requires the current volume name and a new volume name.

◆ The new volume name must be unique within the disk group.

◆ If the volume contains a file system, the file system table file is automatically

updated (if necessary).
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Changing a Volume’s Layout
This procedure changes the layout of a volume without interrupting access to data. You

can use this task to change the redundancy or performance characteristics of an existing

volume.

You can view the progress of the relayout task through the Relayout Status Monitor

window. You can also use the Relayout Status Monitor window to pause, abort, continue,

or reverse the relayout task. The Relayout Status Monitor appears automatically when a

relayout task begins. When a volume relayout is in progress, paused, or aborted, you can

also access the Relayout Status Monitor through the Volume Properties window.

▼ To change a volume’s layout

1. Select the volume to be changed to a different layout.

2. Choose Volumes > Change Layout (Selected menu) or Volume Change Layout

(Command Launcher).

3. Complete the Change Volume Layout dialog box as follows:

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Layout: Choose the new volume layout:

◆ Concatenated

Change the volume to a simple, concatenated volume.

◆ Striped

Change the volume to a striped volume.

◆ RAID-5

Change the volume to a RAID-5 volume.

◆ Concatenated Pro

Change the volume to a layered concatenated volume.

◆ Striped Pro

Change the volume to a layered striped volume.

For a striped, RAID-5, or striped pro volume, provide the

following information:

◆ In the Number of Columns field, specify the number of

columns (disks) across which the volume should be

striped.
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When you have provided all necessary information in the dialog box, click OK. The

Relayout Status Monitor window appears. This window provides you with the

following information and options:

◆ To specify a stripe unit size other than the default, type the

stripe unit size in the Stripe Unit Size field. To specify a size

unit, attach an s (sectors), k (kilobytes), m(megabytes), or g
(gigabytes) to the size.

Options Click Show Options to access the optional settings for this task.

◆ To retain the original volume size when the volume layout

changes, click Retain Volume Size at Completion.

◆ To specify the size of the pieces of data that are copied to

temporary space during the volume relayout, type the

size in the Temp Space Size field.

◆ To specify additional disk space to be used for the new

volume layout (if needed), specify the disk in the Disk(s)

field or click Browse to select a disk.

◆ To specify the temporary disk space to be used during the

volume layout change, specify the disk in the Temp

Disk(s) field or click Browse to select a disk.

◆ If the volume contains plexes with different layouts,

specify the plex to be changed to the new layout in the

Target Plex field.

Volume Name: The name of the volume that is undergoing a layout change.

Initial Layout: The original layout of the volume.

Desired Layout: The new layout for the volume.

Status: The status of the relayout task.

% Complete: The progress of the relayout task.

Options ◆ To stop the relayout task temporarily, click Pause.

◆ To cancel the relayout task, click Abort.

◆ To resume the paused or aborted relayout task, click

Continue.

◆ To undo the layout changes and return the volume to its

original layout, click Reverse.
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If you need to pause, abort, continue, or reverse a relayout task after you close the

Relayout Status Monitor window, you can access the Relayout Status Monitor

through the Volume Properties window.

Notes:

◆ This task requires a volume name and a different volume layout.

◆ Volumes remain accessible during online relayout.

◆ This task may take a long time, depending on the volume size and other factors. The

Relayout Status Monitor shows the progress of the layout change and allows you to

abort, pause, or reverse the task.

◆ If no disk space is specified, the Volume Manager uses available space on disks in

the current disk group.

◆ If the temporary space size is not specified, the Volume Manager uses an

appropriate size. Specifying a larger temporary space size speeds up the layout

change process because larger pieces of data are copied at a time. If the specified

temporary space size is too small, the Volume Manager uses a larger size.

◆ If all of the plexes in the volume have identical layouts, the Volume Manager

changes all plexes (except log plexes) to the new layout. If the volume contains

plexes with different layouts, a target plex must be specified. When a target plex is

specified, the Volume Manager changes the layout of the target plex and leaves the

other plexes in the volume alone.

◆ Log plex layouts do not change. The Volume Manager may remove and/or replace

log plexes, depending on the new layout.

◆ If the volume length changes as a result of the layout change and the volume

contains a file system, the file system length is automatically adjusted (if possible).

◆ A volume cannot undergo multiple relayouts at the same time.

◆ This task cannot be used to change the layout of a volume with a sparse plex.

◆ This task may fail for volumes that were not created by the Storage Administrator or

the vxassist  command.

◆ If the relayout is reversed, the volume returns to its original layout. However, data

in the volume may not return to its original storage location.

◆ During a relayout, many other tasks are unavailable for the volume.

◆ A mirrored or striped volume requires at least two disks.

◆ A RAID-5 volume requires at least three disks.
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Adding a Mirror to a Volume
This procedure creates a mirror (copy) of a volume on a disk that is not already being used

by the volume. If one of the disks fails, the volume’s data can be accessed from the

surviving disk(s). A volume can have multiple mirrors.

▼ To add a mirror to an existing volume

1. Select the volume to be mirrored.

2. Choose Volumes > Mirror > Add (Selected menu) or Volume Add Mirror (Command

Launcher).

3. Complete the Add Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Adding a mirror requires resynchronization, so this task may take some time.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Options Click Show Options to access the optional settings for this task.

◆ To specify the layout for the mirror, select Concatenated or

Striped. For a striped mirror, specify the number of

columns and stripe unit size.

◆ To add more than one mirror, type the number of mirrors

in the Mirror Quantity field.

◆ To place the mirror on a specific disk, type the disk name in

the Disk Name(s) field or click Browse to select a disk.
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Notes:

◆ This task requires a volume name.

◆ Once mirrored, the data in the volume is redundant. If a disk fails, the data will

remain available on the surviving mirror (on another disk).

◆ The new mirror cannot be created on a disk that already contains a copy of the

volume. Each mirror must reside on a separate disk.

◆ Sufficient disk space must be available to accommodate the additional mirror(s).

◆ Only disks in the same disk group as the volume can be used to create the new

mirror.

◆ If no disks are assigned, the Volume Manager uses available disk space to create the

mirror.

◆ A RAID-5 volume cannot be mirrored.

◆ To mirror the root volume (and other volumes required to boot the system) onto an

alternate boot disk, use the Mirror Disk task.

◆ A volume can contain up to 32 plexes (mirrors).
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Adding a Log to a Volume
This procedure adds the appropriate type of log to a mirrored or RAID-5 volume.

▼ To add a DRL log to a mirrored volume

This procedure adds a Dirty Region Logging (DRL) log to a mirrored volume. DRL uses

this log to track the regions of the volume that change due to I/O writes. If a system

failure occurs, DRL uses the information in the log to recover only the portions of the

volume that need recovery. This speeds up recovery time for mirrored volumes.

For DRL to be in effect, a mirrored volume must have at least one DRL log. You can create

additional DRL logs (on different disks) to mirror the DRL information.

1. Select the mirrored volume to contain the log.

2. Choose Volumes > Log > Add (Selected menu) or Volume Add Log (Command

Launcher).

3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

▼ To add a log to a RAID-5 volume

This procedure adds a log to a RAID-5 volume. RAID-5 logs speed up the

resynchronization time for RAID-5 volumes after a system failure. A RAID-5 log

maintains a copy of the data and parity being written to the volume at any given time. If a

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Options To place the log on a specific disk, type the name of the disk in

the Disk Name field or click Browse to select a disk.

Notes:

◆ This task requires a volume name.

◆ When a log is added to a mirrored volume, dirty region logging is activated for that

volume.
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system failure occurs, the Volume Manager can “replay” the RAID-5 log to resynchronize

the volume. This copies the data and parity that was being written at the time of failure

from the log to the appropriate areas of the RAID-5 volume.

You can create multiple RAID-5 logs (on different disks) to mirror the log information.

Ideally, each RAID-5 volume should have at least two logs.

1. Select the RAID-5 volume to contain the log.

2. Choose Volumes > Log > Add (Selected menu) or Volume Add Log (Command

Launcher).

3. Complete the Add Log dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Options To place the log on a specific disk, type the name of the disk in

the Disk Name field or click Browse to select a disk.

Notes:

◆ This task requires a volume name.
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Stopping a Volume
This procedure disables a volume. When a volume is stopped, it is not available for use

until it is restarted (refer to “Starting a Volume”). Stopping a volume is a safe way of

temporarily preventing access to a volume.

▼ To stop a volume

1. Select the volume to be stopped.

2. Choose Volumes > Stop (Selected menu) or Volume Stop (Command Launcher).

3. Complete the Stop Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

The volume’s state should change to Stopped.

Volume(s): If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ A volume cannot be stopped if it is in use (open) or it has a mounted file system.
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Starting a Volume
This procedure attempts to enable (start) a stopped volume. When a volume is

successfully restarted, the volume is available for use again. This procedure also performs

any appropriate resynchronization operations on the volume.

Under normal circumstances, volumes are automatically started when the system reboots.

You can use this procedure to restart a volume that you stopped manually or to attempt to

restart a volume that was stopped in some other manner. If a volume cannot be started,

the volume remains unusable.

▼ To start a volume

1. Select the (stopped) volume to be started.

2. Choose Volumes > Start (Selected menu) or Volume Start (Command Launcher).

3. Complete the Start Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

The volume’s state should change to Started.

Volume(s): If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ Starting a RAID-5 volume enables the volume and resynchronizes parity, if

necessary.

◆ Starting a mirrored volume enables the volume and resynchronizes the mirrors to

ensure that they are consistent.
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Creating a Snapshot Copy of a Volume
This procedure prepares a volume for backup by creating a new volume that is a snapshot

copy of an existing volume. This is done by attaching a new mirror to the existing volume,

copying the volume’s data to the new mirror, detaching the new mirror, and then creating

a new (snapshot) volume from the new mirror. The snapshot volume is an exact copy of

the original volume. You can use the snapshot volume to make a backup of the original

volume at a convenient time. After the backup is made, you can remove the snapshot

volume (see “Removing a Volume”). You can also merge a snapshot volume with its

original volume (see “Merging a Snapshot Volume”) or permanently break the link

between the snapshot and the original volume (see “Dissociating a Snapshot Volume”).

▼ To create a snapshot copy of a volume’s data

1. Select the volume to be copied to a snapshot.

2. Choose Volumes > Snapshot (Selected menu) or Volume Snapshot (Command

Launcher).

3. Complete the Volume Snapshot dialog box as follows:

4. When you have provided all necessary information in the dialog box, click Snapstart

to start the first phase of the snapshot procedure. This creates a snapshot mirror of the

volume to be backed up. This may take some time. When the snapshot mirror is

complete, the following message appears at the bottom of the dialog box:

Click Snapshot to create the snapshot volume.

5. When the snapshot mirror is ready, click Snapshot to complete the snapshot. This

creates a snapshot copy of the original volume.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Snapshot Name: Type the name for the snapshot copy of the volume.

Options ◆ To place the snapshot on a specific disk(s), click Assign

Disks and select the disks you want to use.

◆ To enable the Fast Mirror Resynchronization (FMR) feature

for the volume, select Enable FMR. FMR speeds up the

resynchronization of mirrors in a volume.

Resynchronization is necessary when a

detached/unavailable mirror is (re)attached to a volume.

◆ To create a read-only snapshot volume, select Read Only.
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If you decide not to make a snapshot volume, you can remove the snapshot mirror after

the snapstart phase. To remove the snapshot mirror, click Remove Snapshot Mirror.

Notes:

◆ This task requires a volume name and a snapshot name.

◆ The snapshot volume is an exact copy of the original volume at the time the

snapshot phase of the procedure starts.

◆ After you create the snapshot copy of the volume, remember to back it up to tape or

some other media. Remove the snapshot volume when it is no longer needed.

◆ The snapstart phase of this task may take a long time, depending on the size of the

volume.

◆ If you remove the snapshot mirror, you cannot create a snapshot volume until you

repeat the snapstart phase of the procedure.
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Merging a Snapshot Volume
This procedure merges a snapshot copy of a volume with the original volume. The

snapshot plex is detached from the snapshot volume and attached to the original volume.

The snapshot volume is removed. This task resynchronizes the data in the volume so that

the plexes are consistent. By default, the data in the original plex is used for the merged

volume.

▼ To merge a snapshot volume with its original volume

1. Select the snapshot volume to be merged with its original volume.

2. Choose Volumes > Snapback (Selected menu) or Volume Snapback (Command

Launcher).

3. Complete the Snapback Volume dialog box as follows:

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Options To replace the data in the original volume with the data from

the snapshot volume, select Resync From Replica Volume.
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Dissociating a Snapshot Volume
This procedure permanently breaks the association between a snapshot and its original

volume. The snapshot volume becomes an independent volume.

▼ To dissociate a snapshot volume from its original volume

1. Select the snapshot volume to be dissociated from its original volume.

2. Choose Volumes > Snapclear (Selected menu) or Volume Snapclear (Command

Launcher).

3. Complete the Snapclear Volume dialog box as follows:

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.
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Preparing to Restore a Volume From Backup
This procedure stops the volume, sets the volume to an uninitialized state, and restarts the

volume (without resynchronizing the volume’s mirrors). The volume can then be

reloaded from backup.

This procedure is intended for raw image backups and is not appropriate for file system

backups. This procedure is useful for disaster recovery. If a volume’s data is corrupted

and you know that you need to restore the volume from backup, you can use this

procedure to prepare the volume for restoration.

▼ To prepare a volume for a restore from backup

1. Select the volume to be restored from backup.

2. Choose Volumes > Prepare For Restore (Selected menu) or Volume Prepare Restore

(Command Launcher).

3. Complete the Prepare Volume For Restore dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

When you have completed this task, you can restore the volume’s data from backup.

Volume(s): If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ If the volume contains a mounted file system, the file system must be unmounted

before this task can proceed. This task does not remount the file system.
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Recovering a Volume
This procedure performs any necessary volume recovery operations on a volume. The

recovery operations depend on the type of volume and include starting disabled volumes,

resynchronizing mirrors in mirrored volumes, and resynchronizing parity in RAID-5

volumes. After successful recovery, the volume should be available for use again.

Alert icons and the Alert Monitor window may provide clues to let you know that volume

recovery is needed.

▼ To recover a failed volume

1. Select the volume to be recovered.

2. Choose Volumes > Recover (Selected menu) or Volume Recover (Command

Launcher).

3. Complete the Recover Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume(s): If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ In some cases, recovery may not be possible. If the volume recovery fails, you can

attempt to restore the volume from backup.
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Repairing a Mirror
This procedure repairs a disabled mirror by reattaching the mirror to its volume. This

involves copying data from an active mirror on the volume to the mirror being attached.

Once attached, the mirror is accessible for reads and writes again.

Alert icons and the Alert Monitor window may provide clues to let you know that a

mirror needs to be repaired.

▼ To repair a mirror

1. Select the volume that contains the mirror to be repaired.

2. Choose Volumes > Mirror > Repair (Selected menu) or Mirror Repair (Command

Launcher).

3. Complete the Repair Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Select a mirror to

repair:

Select the mirror to be repaired.

Notes:

◆ This task recovers the mirror so that it has the same contents as other mirrors in the

volume.

◆ This task may take a long time, depending on the amount of data in the volume.
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Disabling a Mirror

Note Disabling a mirror can result in loss of data redundancy.

This procedure disables a mirror by temporarily detaching the mirror from its volume. A

detached mirror is inaccessible for reads and writes, but is still associated with its volume.

Once disabled, the mirror remains detached from its volume until you either reattach the

mirror (see “Repairing a Mirror”) or restart the volume.

▼ To disable a mirror in a volume

1. Select the volume that contains the mirror to be disabled.

2. Choose Volumes > Mirror > Disable (Selected menu) or Mirror Disable (Command

Launcher).

3. Complete the Disable Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Select a mirror to

disable:

Select the mirror to be disabled.

Notes:

◆ When a mirror is disabled, volume reads and writes cannot be directed to the mirror.

◆ If a volume only has two mirrors and one mirror is disabled, the volume is not

redundant while the mirror is disabled.

◆ The last mirror in a volume cannot be disabled.

◆ When a volume is restarted, any disabled (detached) mirrors should be reattached

to the volume automatically.
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Removing a Mirror From a Volume

Note Removing a mirror can result in loss of data redundancy.

This procedure removes a mirror from its volume. This breaks the link between the mirror

and its volume and returns the mirror’s disk space to the free space pool for reuse. You

can remove an extra mirror from a volume to make the underlying disk space available

for use elsewhere. However, this may leave the volume unmirrored and unprotected

against disk failure.

▼ To remove a mirror from a volume

1. Select the volume that contains the mirror to be removed.

2. Choose Volumes > Mirror > Remove (Selected menu) or Mirror Remove (Command

Launcher).

3. Complete the Remove Mirror dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Removal Method: Specify the mirrors and/or number of mirrors to be removed:

◆ To specify how many mirrors should be removed, select By

Quantity/disk. Type the number of mirrors to be removed

in the Mirror Quantity field.

◆ To specify the disk(s) on which mirrors should be

preserved, select By Quantity/disk. Type the disk name(s)

in the Preserved Disk(s) field or click Browse to select a

disk.

◆ To specify the name of the mirror to be removed, select By

Mirror. Type the mirror name in the Mirror Name field or

click Browse to select a mirror.
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Notes:

◆ This task requires a volume name. This task also requires the number of mirrors to

remove, a disk name, or a mirror name.

◆ If a volume only has two mirrors and one mirror is removed, the volume is no

longer redundant.

◆ The last mirror (plex) cannot be removed from a volume.

◆ When a mirror is removed, the space occupied by that mirror is returned to the free

space pool.
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Removing a Log From a Volume
This procedure removes a log from a mirrored or RAID-5 volume. For a mirrored volume,

this removes a DRL log from the volume. For a RAID-5 volume, this removes a RAID-5

log from the volume.

▼ To remove a log from a volume

1. Select the volume that contains the RAID-5 or DRL log to be removed.

2. Choose Volumes > Log > Remove (Selected menu) or Log Remove (Command

Launcher).

3. Complete the Remove Log dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Removal Method: Specify the logs and/or number of logs to be removed:

◆ To specify how many logs should be removed, select By

Quantity/disk. Type the number of logs to be removed in

the Log Quantity field.

◆ To specify the disk(s) on which logs should be preserved,

select By Quantity/disk. Type the disk name(s) in the

Preserved Disk(s) field or click Browse to select a disk.

◆ To specify the name of the log to be removed, select By Log.

Type the log name in the Log Name field or click Browse to

select a log.

Notes:

◆ This task requires a volume name.

◆ If the only log is removed from a volume, logging (either dirty region logging or

RAID-5 logging) is no longer in effect for that volume. When logging is disabled,

recovery time increases.
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Removing a Volume

Caution Removing a volume can result in data loss.

This procedure permanently removes a volume and all of its data. You should only

remove a volume if you are sure that you do not need the data in the volume (or the data

is backed up elsewhere). You can remove a volume to make the underlying disk space

available for use elsewhere.

▼ To remove a volume

1. Select the volume to be removed.

2. Choose Volumes > Remove (Selected menu) or Volume Remove (Command

Launcher).

3. Complete the Remove Volume dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume(s): If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ Removing a volume destroys all of the data in that volume.

◆ When a volume is removed, the space it occupied is returned to the free space pool.
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Associating a Plex
This procedure associates (attaches) a plex to a volume. This involves copying data from

an active mirror on the volume to the new plex (mirror).

▼ To associate a plex

1. Choose Plex Associate (Command Launcher).

2. Complete the Associate Plex dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Plex Name: Type the plex name or click Browse to select the plex.

Volume Name: Type the name of the volume to be associated with the plex or

click Browse to select a volume.

Notes:

◆ This task requires a plex name and a volume name.

◆ This task connects a plex to a volume.

◆ This task may take a long time, depending on the amount of data in the volume.
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Dissociating a Plex
Dissociating a Plex
This procedure dissociates a plex from its volume. This disconnects the plex from its

volume and reduces the volume’s data redundancy.

▼ To dissociate a plex

1. Choose Plex Dissociate (Command Launcher).

2. Complete the Dissociate Plex dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Plex Name: Type the plex name or click Browse to select the plex.

Notes:

◆ This task requires a plex name.

◆ This task breaks the link between the plex and its volume. The plex remains

inaccessible until it is (re)associated with a volume.

◆ Dissociating a plex from a volume can result in loss of data redundancy.
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Moving a Subdisk
Moving a Subdisk
This procedure moves the contents of a volume’s subdisk from one disk to another. This is

useful for moving portions of a volume to a different disk for improved performance.

You can use the Object View window (Disk Groups > Object View) or the Volume to Disk

Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks and gaps on

disks in a disk group. In the Object View window, you can move a subdisk by placing the

pointer over the subdisk and then pressing and holding the mouse button to drag the

subdisk to another location.

▼ To move a subdisk to another disk

1. Select the subdisk to be moved to another disk.

2. Choose Subdisks > Move (Selected menu) or Subdisk Move (Command Launcher).

3. Complete the Move Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Source Subdisks: If the correct subdisk name is not already displayed in this

field, type the subdisk’s name or click Browse to select the

subdisk.

Target Disk Name: Type the name of the disk to which the subdisk should be

moved or click Browse to select a disk.

Options Click Show Options to access the optional settings for this task.

◆ To specify whether the subdisk can be split into smaller

subdisks that fit in available space(s) on the target disk,

select one of the Move Policy options. The One to One

options do not split the subdisk(s). The Split as Required

option splits the subdisk(s).

◆ To specify the minimum disk offset for the subdisk, type

the offset in the Starting Offset for Gap Search field.
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Moving a Subdisk
Notes:

◆ This task requires a subdisk name and a disk name.

◆ Subdisks are typically moved to reorganize disk space.

◆ The disk space occupied by the original subdisk is returned to the free space pool.

◆ A subdisk in a mirrored, striped, or RAID-5 volume should not be moved to a disk

that already contains a copy or part of that volume.

◆ If this task fails and leaves some unused subdisks (that is, subdisks that are not

associated with a volume) on the system, you can use the Remove Subdisk task to

free the space occupied by the unused subdisks.
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Splitting a Subdisk
Splitting a Subdisk
This procedure divides a subdisk into two or more smaller subdisks. Once split, the

smaller subdisks can be moved elsewhere or rejoined later. This is useful for reorganizing

volumes and/or improving performance.

You can use the Object View window (Disk Groups > Object View) or the Volume to Disk

Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks in a disk

group. You can use the Volume Layout Details window (Volumes > Show Layout) to view

subdisks in a specific volume.

▼ To split a subdisk into multiple subdisks

1. Select the subdisk to be split into multiple subdisks.

2. Choose Subdisks > Split (Selected menu) or Subdisk Split (Command Launcher).

3. Complete the Split Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Subdisk Name: If the correct subdisk name is not already displayed in this

field, type the subdisk’s name or click Browse to select the

subdisk.

Number of Target

Subdisks:

Type the number of subdisks into which the subdisk should be

split. A subdisk can be split into two or more subdisks.

Notes:

◆ This task requires a subdisk name and the number of subdisks that will result from

the split.

◆ The name of the first subdisk remains the same as the selected subdisk. Other

subdisks are automatically named by the Volume Manager.

◆ The new, smaller subdisks occupy the same regions of the disk that the original

subdisk occupied.

◆ The original subdisk must contain a sufficient number of sectors for the specified

split to work.

◆ A Dirty Region Logging log subdisk cannot be split.
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Joining Subdisks
Joining Subdisks
This procedure joins two or more subdisks together to form a single, larger subdisk.

Subdisks can only be joined together if they belong to the same volume and occupy

adjacent regions of the same disk and mirror.

You can use the Object View window (Disk Groups > Object View) or the Volume to Disk

Mapping window (Disk Groups > Disk/Volume Map) to view the subdisks in a disk

group. You can use the Volume Layout Details window (Volumes > Show Layout) to view

subdisks in a specific volume.

▼ To join subdisks

1. Select the subdisks to be combined into a single subdisk.

2. Choose Subdisks > Join (Selected menu) or Subdisk Join (Command Launcher).

3. Complete the Join Subdisks dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Source Subdisks: If the correct subdisk names are not already displayed in this

field, type the subdisk names or click Browse to select the

subdisks. Specify at least two subdisks.

Target Subdisk

Name:

Type the name of the new, combined subdisk.

Notes:

◆ This task requires two or more existing subdisk names and a new (joined) subdisk

name.

◆ Only contiguous subdisks on the same disk can be joined.

◆ The subdisks to be joined must belong to the same volume and mirror.

◆ For a striped volume, the subdisks must be in the same column.

◆ The joined subdisk name can be the name of one of the subdisks being joined.
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Removing a Subdisk
Removing a Subdisk
This procedure removes a subdisk from a disk. This task applies to subdisks that are not

associated with volumes. This provides a way to return the disk space occupied by

unused subdisks to the free space pool.

You can use the Disk Properties window (Disks > Properties) to view subdisks that are not

associated with volumes.

▼ To remove a subdisk

1. Select the disk with the subdisk to be removed.

2. Choose Disks > Properties (Selected menu).

3. In the Disk Properties window, go to the Subdisks tab and select the subdisk to be

removed.

4. Choose Remove (popup menu) or Subdisk Remove (Command Launcher).

5. Complete the Remove Subdisk dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Subdisks: If the correct subdisk name is not already displayed in this

field, type the subdisk’s name or click Browse to select the

subdisk.

Notes:

◆ You cannot remove a subdisk that is associated with a volume.

◆ When a subdisk is removed, the space it occupied is returned to the free space pool.
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Viewing Volume Properties
Viewing Volume Properties
The Volume Properties window contains detailed information about the selected volume.

The Properties window contains a set of tabbed pages, each of which contains information

about the volume and related objects. You can display a different page by clicking on the

appropriate tab label.

❖ To view the properties of a volume, select the volume and then choose Properties

from the Volumes or popup menu. You can also access the Volume Properties window

by double-clicking on the volume.

❖ To update the contents of the Properties window to reflect current properties for the

volume, click Refresh.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
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Adding a File System to a Volume
This procedure places a file system on an existing volume and mounts the file system.

This also updates the file system table file, if necessary.

▼ To add a file system to an existing volume

1. Select the volume to contain the file system.

2. Choose Volumes > File System > New (Selected menu) or Volume Add File System

(Command Launcher).

3. Complete the New File System dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Mount Point: Type the mount point for the file system.

FS Type: Select the file system type.

Options ◆ To mount the file system automatically at system startup,

select Mount at Boot. If this is selected, the file system table

file will also be updated at system startup.

◆ To specify mount  options, click Mount Details and specify

the appropriate options in the Mount Details dialog box.

◆ To specify mkfs  command options, click New File System

Details and specify the appropriate options in the New File

System Details dialog box.

Notes:

◆ This task requires a volume name and a file system type. If Mount at Boot is

selected, a file system mount point is also required.

◆ When the file system is mounted, the file system table file is automatically updated.

◆ If the path specified for the mount point does not already exist, it is created.

◆ The mount point must be an absolute pathname (that is, it must begin with / ).
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Mounting a File System on a Volume
Mounting a File System on a Volume
This procedure mounts a file system that already exists on a volume and updates the file

system table file, if necessary.

▼ To mount a file system on an existing volume

1. Select the volume that contains the file system to be mounted.

2. Choose Volumes > File System > Mount (Selected menu) or Volume Mount

(Command Launcher).

3. Complete the Mount File System dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Mount Point: Type the mount point for the file system.

Options ◆ To mount the file system automatically at system startup,

select Mount at Boot. If this is selected, the file system table

file will also be updated at system startup.

◆ To specify mount  options, click Mount Details and specify

the appropriate options in the Mount Details dialog box.

Notes:

◆ This task requires a volume name. If Mount at Boot is selected, a file system mount

point is also required.

◆ The specified volume must contain a file system.

◆ The file system table file is automatically updated.

◆ If the path specified for the mount point does not already exist, it will be created.

◆ The mount point must be an absolute pathname (that is, it must begin with / ).
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Unmounting a File System on a Volume
Unmounting a File System on a Volume
This procedure unmounts a file system.

▼ To unmount a file system on a volume

1. Select the volume containing the file system to be unmounted.

2. Choose Volumes > File System > Unmount (Selected menu) or Volume Unmount

(Command Launcher).

3. Complete the Unmount File System dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ The specified volume must contain a mounted file system.
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Resizing a File System
This procedure changes the size of a file system and the underlying volume. If users

require more space, you can use this procedure to increase the size of the file system. If a

vxfs  file system is too large and you need the space elsewhere, you can use this

procedure to shrink the file system.

▼ To resize a file system on a volume

1. Select the file system to be resized.

2. Choose File Systems > Resize (Selected menu) or File System Resize (Command

Launcher).

3. Complete the Resize File System dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name is not already displayed in this

field, type the file system’s name or click Browse to select the

file system.

New Size Specify one of the following:

◆ To increase the file system size by a specific amount of

space, use the Add By field to specify how much space

should be added to the file system.

◆ To decrease the file system size by a specific amount of

space, use the Subtract By field to specify how much space

should be removed from the file system.

◆ To specify the new file system size, type the size in the

Desired Size field.

To determine the largest possible size for the file system, click

Maxgrow.

To specify a size unit, attach an s  (sectors), k  (kilobytes), m
(megabytes), or g (gigabytes) to the size.

Options ◆ To use a specific disk for the additional space, click Assign

Disks and select the disk you want to use from the Space

Allocation dialog box.
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Resizing a File System
Notes:

◆ This task requires a file system name and either the desired size or the amount of

space to add to or subtract from the file system size.

◆ When the file system is resized, the underlying volume is also resized.

◆ Only vxfs  file systems can be shrunk.

◆ The file system to be resized must be on a volume.
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Creating a Snapshot Copy of a File System
This procedure prepares a vxfs file system for online backup by creating a snapshot copy

of the file system. This is done by creating a new volume, mounting a snapshot file system

on the new volume, and copying the contents of the original file system to the snapshot

file system. The snapshot file system is a consistent copy of the original file system at the

time the snapshot was made. You can use the snapshot file system to make a backup of the

original file system at a convenient time. After the backup is made, you can remove the

snapshot file system by removing the underlying snapshot volume (see “Removing a

Volume”).

▼ To create a snapshot copy of a file system’s data

1. Select the file system to be backed up.

2. Choose File Systems > Snapshot (Selected menu) or File System Snapshot (Command

Launcher).

3. Complete the File System Snapshot dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name is not already displayed in this

field, type the file system’s name or click Browse to select the

file system.

Snapshot Mount

Point:

Type the mount point for the snapshot copy of the file system.

Snapshot Size: Type the size of the snapshot copy of the file system.

Options To place the snapshot on a specific disk(s), click Assign Disks

and select the disks you want to use.
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Creating a Snapshot Copy of a File System
Notes:

◆ This task requires a file system name, a snapshot mount point, and a snapshot size.

◆ The file system snapshot task is only available for vxfs  file systems.

◆ The snapshot file system is an exact copy of the original file system at the time the

snapshot was created.

◆ After you create the snapshot copy of the file system, remember to back it up to tape

or some other media. Remove the snapshot file system when it is no longer needed.

◆ Users can continue to use the original file system during this snapshot backup

procedure.

◆ Refer to the vxfs  documentation for guidelines on choosing the snapshot file

system size.
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Checking a File System on a Volume
Checking a File System on a Volume
This procedure checks an unmounted file system on a volume for consistency (using the

fsck  command). This procedure can also attempt to repair the file system, if necessary.

▼ To check a file system on a volume

1. Select the volume containing the file system to be checked.

2. Choose Volumes > File System > Check (Selected menu) or File System Check

(Command Launcher).

3. Complete the Check File System dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Options ◆ To check and attempt to repair the file system, select Check

And Repair.

◆ To check the file system without repairing it, select Check

With No Repair.

◆ To unmount the file system, run fsck , and then mount the

file system, select Unmount And Check, Then Mount.

◆ To unmount the file system and then run fsck , select

Unmount And Check.

Notes:

◆ The specified volume must contain a file system. The file system should be

unmounted.

◆ The Storage Administrator assumes that fsck  will not require user input. If user

input is required, this task fails and fsck  must be run at the command line.
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Viewing File System Properties
The File System Properties window contains detailed information about the selected file

system. The Properties window contains a set of tabbed pages, each of which contains

information about the file system and related objects. You can display a different page by

clicking on the appropriate tab label.

❖ To view the properties of a file system, select the file system and then choose

Properties from the File Systems or popup menu. You can also access the File System

Properties window by double-clicking on the file system.

❖ To update the contents of the Properties window to reflect current properties for the

file system, click Refresh.

❖ To print the contents of the Properties window, click Print and complete the Print

dialog box.
162 VERITAS Volume Manager Storage Administrator Administrator’s Guide



Creating a QuickLog Log on a Volume
Creating a QuickLog Log on a Volume
This procedure designates a volume as a vxfs  file system QuickLog log. After setting up

a volume as a QuickLog log, you can enable the QuickLog log device for a file system.

▼ To designate a volume as a QuickLog log

1. Select the volume to be used for the file system QuickLog log.

2. Choose Volumes > QuickLog > Make Log (Selected menu) or Volume Make FS Log

(Command Launcher).

3. Complete the Make QuickLog Log dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Log Device Number: Select the number of the log device to be attached to the

volume. Log devices are listed in /dev/vxld .

Notes:

◆ This task is only available if VERITAS QuickLog is installed.

◆ This task requires a volume name and a log device number.

◆ Only vxfs  file systems can be used with a QuickLog log.

◆ The specified volume cannot contain a file system.

◆ The size of the specified volume must be at least 32M.
Chapter 4, Volume Tasks 163



Enabling the QuickLog Log for a File System
Enabling the QuickLog Log for a File System
This procedure enables the QuickLog log device for a vxfs  file system and remounts the

file system. Before you enable a QuickLog log, you need to designate a volume as a

QuickLog log (see “Creating a QuickLog Log on a Volume”).

▼ To enable a QuickLog log for a file system

1. Select the file system to be remounted with a QuickLog log device enabled.

2. Choose File System > QuickLog > Enable (Selected menu) or File System Enable

QuickLog (Command Launcher).

3. Complete the Enable QuickLog dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name is not already displayed in this

field, type the file system’s name or click Browse to select the

file system.

Log Device Number: Select the number of the log device to be enabled for the file

system. Log devices are listed in /dev/vxld .

Options To mount the file system automatically at system startup,

select Mount at Boot. If this is selected, the file system table file

will also be updated at system startup.

Notes:

◆ This task is only available if VERITAS QuickLog is installed.

◆ This task requires a file system name.

◆ Only vxfs  file systems can be used with a QuickLog log.

◆ The specified log device should already have a designated log volume.

◆ If no log device number is specified, the least-loaded device is used.
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Disabling the QuickLog Log for a File System
Disabling the QuickLog Log for a File System
This procedure disables QuickLog logging for a file system and remounts the file system.

▼ To disable a QuickLog log for a file system

1. Select the file system with the QuickLog log device to be disabled.

2. Choose File System > QuickLog > Disable (Selected menu) or File System Disable

QuickLog (Command Launcher).

3. Complete the Disable QuickLog dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

File System Name: If the correct file system name is not already displayed in this

field, type the file system’s name or click Browse to select the

file system.

Notes:

◆ This task is only available if VERITAS QuickLog is installed.

◆ This task requires a file system name.
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Removing a QuickLog Log
Removing a QuickLog Log
This procedure detaches a QuickLog log device from a volume. Before you remove a

QuickLog log, you must disable the log (see “Disabling the QuickLog Log for a File

System”).

▼ To remove a QuickLog log from a volume

1. Select the volume with the QuickLog log device to be detached.

2. Choose Volumes > QuickLog > Remove Log (Selected menu) or Volume Remove FS

Log (Command Launcher).

3. Complete the QuickLog Remove Log dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Volume Name: If the correct volume name is not already displayed in this

field, type the volume’s name or click Browse to select the

volume.

Notes:

◆ This task is only available if VERITAS QuickLog is installed.

◆ This task requires a volume name.

◆ The QuickLog log for the file system must be disabled before the QuickLog log can

be detached from a volume.
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Host and Cluster Tasks
 5

Introduction

This chapter describes how to access and use host machines and clusters with the Volume

Manager Storage Administrator. The Host and Cluster Task Roadmap at the beginning of

this chapter contains a summary of common host and cluster tasks.

The Storage Administrator can access and display multiple host machines simultaneously.

The Storage Administrator only provides access to cluster-related features if the optional

Volume Manager cluster functionality is present.

The following host tasks are discussed in this chapter:

◆ Connecting to a Host

◆ Disconnecting a Host

◆ Setting Up Automatic Host Connections

The following cluster tasks are discussed in this chapter:

◆ Working with Clusters

◆ Starting a Cluster

◆ Stopping a Cluster

◆ Starting a Node

◆ Stopping a Node

◆ Creating a Shared Disk Group

◆ Importing a Shared Disk Group

◆ Upgrading a Cluster
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Host and Cluster Task Roadmap
Host and Cluster Task Roadmap
The following table provides a summary of common Volume Manager Storage

Administrator host and cluster tasks.

To do this... Use this procedure...

Setup Tasks:

Connect to and administer another host machine Connecting to a Host

Set up a shared disk group Creating a Shared Disk Group

Start a cluster Starting a Cluster

Other Tasks:

Stop a cluster Stopping a Cluster

Add a node to a cluster Starting a Node

Prevent access to a node in a cluster Stopping a Node

Disconnect from a host machine Disconnecting a Host

Access a deported disk group for cluster use Importing a Shared Disk Group
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Connecting to a Host
Connecting to a Host
This procedure establishes a connection to a host machine from the current Storage

Administrator session. A Storage Administrator client session can provide simultaneous

access to multiple host machines.

▼ To connect to a host

1. Choose File > Connect (menu) or Host Connect (Command Launcher).

2. Complete the Connect to Host dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

new host appears in the object tree in the main window.

Server Host: Type the name of the machine to be administered. Both the

Volume Manager and the Storage Administrator server must be

running on this machine.

User Name: Type your login name. Only users with appropriate privileges

can run the Storage Administrator on the specified machine.

Password: Type your password for the machine to be administered.

Options To use the specified user and password as default settings for

any future host connections from this Storage Administrator

client session, select Default User.

Notes:

◆ This task requires a host machine name, user name, and password.

◆ Both the Volume Manager and the Volume Manager Storage Administrator server

must be running on the machine to be administered.

◆ Only users with appropriate privileges can run the Volume Manager Storage

Administrator.

◆ Entries for the user name and password must exist in the password file or

corresponding NIS (Network Information Name Service) table on the machine to be

administered.

◆ The user name (or the user’s group ID) must be included in the vrtsadm  group

entry in the group file or NIS group table on the machine to be administered.
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Disconnecting a Host
Disconnecting a Host
This procedure disconnects a host machine from the current Storage Administrator

session. When a host machine is disconnected, the Storage Administrator cannot

administer that machine. To restore access to a disconnected host machine, you must

reconnect to the host.

▼ To disconnect a host

1. Select the host machine to be disconnected from the Storage Administrator session.

2. Choose Hosts > Disconnect (Selected menu) or Host Disconnect (Command

Launcher).

3. Complete the Disconnect Host dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK. The

disconnected host remains in the object tree in the main window, but its icon changes

to the disconnected host icon.

Host(s): Type the name of the host machine or click Browse to select the

host.
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Setting Up Automatic Host Connections
Setting Up Automatic Host Connections
This procedure causes the Storage Administrator to automatically connect to specified

hosts at startup. You can specify which hosts should connect to the Storage Administrator

client at startup and how to display those hosts in the main window’s object tree.

▼ To set up automatic host connections

1. Choose Options > Customize from the main window menu bar.

2. Click on the Hosts tab in the Customize window.

3. To specify a host machine, click Add and type the host machine name in the Hosts

column of the grid.

4. To automatically connect to the specified host at Storage Administrator startup, click

in the Connect column. A check mark indicates that the Connect preference is set for

the host. If you want the object tree to display the hierarchy of objects under the host

at startup, click in the Auto-Expand column.

5. When you have completed your selection(s), click OK.

6. Choose Options > Save Customization from the main window menu bar.

Your host settings will take effect the next time you start the Storage Administrator

client.
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Working with Clusters
Working with Clusters
The VERITAS Volume Manager includes an optional cluster feature that enables the

Volume Manager to be used in a cluster environment. To activate the cluster feature, you

must obtain a license for the Volume Manager cluster functionality.

After adding a Volume Manager cluster license to the machine, you must restart the

Storage Administrator server to enable cluster support in the Storage Administrator.

When a cluster license is present on a machine, the Storage Administrator displays a

Clusters icon in the object tree (even if the machine is not currently set up as a node in a

cluster). When a cluster is shown in the tree, all active/inactive nodes that are members of

the cluster are displayed in the tree.

Figure 18. Tree/Grid View of a Cluster

❖ To display the objects in a cluster, expand the cluster hierarchy (by clicking on the plus

sign next to the Clusters icon).

❖ To determine which node is the master in a cluster, expand the cluster hierarchy for

the appropriate cluster and select Hosts from the cluster hierarchy. The grid displays

the names and properties of the nodes in the cluster. The Type column indicates which

node is the master.

The Cluster Properties window also indicates which node is the master. To access this

window, select a cluster and choose Properties from the Selected or popup window.
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Starting a Cluster
This procedure starts a cluster. If the cluster is not already started, you must use this task

to start the cluster before you can access the shared objects in the cluster.

▼ To start a cluster

1. Select the Clusters icon at the top of the cluster portion of the object tree.

2. Choose All Clusters > Start Cluster (Selected menu) or Cluster Start (Command

Launcher).

3. Complete the Start Cluster dialog box as follows:

When you have provided all necessary information in the dialog box, click OK. The

cluster and its objects appear in the object tree.

Cluster Node: Type the name of any machine in the cluster or click Browse to

select a host.

Notes:

◆ This task is only applicable in a cluster environment.

◆ A cluster must be started before you can access the shared objects on the machines

in the cluster.
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Stopping a Cluster
This procedure stops a cluster and makes the shared objects in the cluster inaccessible

from the current Storage Administrator session.

▼ To stop a cluster

1. Select the cluster to be stopped.

2. Choose Clusters > Stop Cluster (Selected menu) or Cluster Stop (Command

Launcher).

3. Complete the Stop Cluster dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster: Type the name of the cluster or click Browse to select a cluster.

Notes:

◆ This task is only applicable in a cluster environment.

◆ When a cluster is stopped, you cannot access the shared objects in the cluster.
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Starting a Node
This procedure activates a node (host) in a cluster. This causes the node to join the cluster.

A node must be started before it can access shared objects in the cluster. If a node has been

stopped for some reason, you can use this task to restart the node.

▼ To start node in a cluster

1. Select the node (host) to be started.

2. Choose Cluster Nodes > Start Node (Selected menu) or Cluster Start Node

(Command Launcher).

3. Complete the Start Cluster Node dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster Node: Type the name of the host machine or click Browse to select the

host.

Notes:

◆ This task is only applicable in a cluster environment.

◆ When a node is started, the node joins the cluster and has access to the shared

objects in the cluster.
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Stopping a Node
This procedure stops a node (host) in a cluster and makes that node inaccessible to the

cluster. A stopped node cannot access shared objects in the cluster. If the stopped node is

the master node, another node in the cluster automatically becomes the new master.

▼ To stop a node in a cluster

1. Select the node (host) to be stopped.

2. Choose Cluster Nodes > Stop Node (Selected Menu) or Cluster Stop Node (Command

Launcher).

3. Complete the Stop Cluster Node dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

4. Confirm that you want to stop this node.

Cluster Node: Type the name of the host machine or click Browse to select the

host.

Notes:

◆ This task is only applicable in a cluster environment.

◆ When a node is stopped, the node cannot access the shared objects in the cluster.

◆ If the master node is stopped, another node in the cluster automatically becomes

the new master.
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Creating a Shared Disk Group
This procedure creates a shared disk group for use in a cluster environment. Disks must

be placed in disk groups before they can be used by the Volume Manager. The default disk

group (rootdg ) is usually created during Volume Manager installation and always exists

on a system running the Volume Manager. You can create additional disk groups to

organize your disks into logical sets of disks.

When you place a disk under Volume Manager control, the disk is either encapsulated or

initialized. Encapsulation preserves any existing data on the disk in volumes.

Initialization destroys any existing data on the disk.

▼ To create a disk group

1. Select the host machine that is the master node.

2. Choose File > New > Disk Group (menu) or Disk Group Create (Command

Launcher).

3. Complete the New Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Type the name of the disk group to be created. Click View to

view the names of existing disk groups.

To set up any new disks on the system, click Scan Disks. This

runs the disk setup commands appropriate for the operating

system.

Disk Device(s): Select the disk(s) to be placed in the new disk group.

Cluster Settings Click Show Options to access the optional settings for this task.

Select Create Shared to create a shared disk group.

Options Click Show Options to access the optional settings for this task.

◆ To specify the Volume Manager disk name for the disk,

type a disk name in the Disk Name(s) field. If no Volume

Manager disk name is specified, the Volume Manager

assigns a default name to the disk.

◆ To apply a comment or attribute to disks that are placed in

the disk group, type the information in the Comment field.
Chapter 5, Host and Cluster Tasks 177



Creating a Shared Disk Group
4. Indicate whether the disk should be initialized or encapsulated. If you initialize the

disk, any existing data on the disk will be destroyed. If you encapsulate the disk, any

existing data will be preserved in volumes.

5. If you chose to encapsulate the disk, reboot the system.

Notes:

◆ This task requires a disk group name and the name of at least one disk.

◆ The disk group name must be unique.

◆ The new disk group must contain at least one disk.

◆ Only disks that are online and do not belong to a disk group can be used to create a

disk group.

◆ When a disk is placed under Volume Manager control, the disk is either initialized

or encapsulated. Encapsulation preserves any existing data on the disk in the form

of volumes. Initialization destroys any existing data on the disk. Encapsulation is

recommended for the root/boot disk and any other disks that contain valuable data.

◆ The Volume Manager disk name must be unique within the disk group.

◆ If multiple disks are specified in the Disk Device(s) field and only one disk name is

specified in Disk Name(s) field, the Volume Manager appends numbers to the disk

name so that each disk name is unique within its disk group.
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Importing a Shared Disk Group
This procedure makes a deported (inaccessible) disk group and its volumes accessible in a

cluster environment. To import a deported disk group as shared, you must know the disk

group’s former name and this disk group name must remain unused. In addition, at least

one disk formerly assigned to the deported disk group must remain unused.

▼ To import a disk group

1. Select the host machine that is the master node.

2. Choose Hosts > Import Disk Group (Selected menu) or Disk Group Import

(Command Launcher).

3. Complete the Import Disk Group dialog box as follows:

When you have provided all necessary information in the dialog box, click OK.

Disk Group Name: Type the name of the disk group to be imported or click

Browse to select the disk group.

Cluster Settings Click Show Options to access the optional settings for this task.

Select Import Shared to import the disk group as a shared disk

group.

Options Click Show Options to access the optional settings for this task.

◆ To start all volumes in the disk group at import, select Start

All Volumes.

◆ To clear the existing host ID stamp on all disks in the disk

group at import, select Clear Host ID. Do not use this

option if another host is using any disk(s) in the disk

group.

◆ To force the disk group import when the host cannot access

all disks in the disk group, select Force Import. This option

can be used to import a disk group that contains a failed

disk, but can lead to disk group inconsistency if all disks

are still usable.

◆ To change the name of the disk group at import, type a new

disk group name in the New Name field. To indicate that

the name change is temporary, select Use New Name as

Temporary.
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Notes:

◆ This task requires a disk group name.

◆ Only deported disk groups can be imported.

◆ A deported disk group cannot be imported if another disk group with the same

name has been created since the disk group was deported.

◆ A disk group import may fail if the host cannot find one or more disks in the disk

group. If the import fails because a disk has failed, you can import the disk group by

selecting the Force Import option. If the import fails for another reason, a forced

import can cause serious problems.

◆ When a disk group is imported, the system stamps its host ID on all disks in the disk

group. A disk group import should fail if one of the disks is stamped with a host ID

that does not match the others. This ensures that dual-ported disks cannot be

managed (and possibly corrupted) by two systems at the same time. If you are sure
that the disk group is not in use by another host, you can clear the host IDs and

import the disk group by selecting the Clear Host ID option.
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Upgrading a Cluster
This procedure upgrades a cluster and its nodes while the cluster remains accessible. This

is accomplished by upgrading one node in the cluster at a time so that at least one node

remains online at all times. When all of the nodes in the cluster are upgraded, the cluster

protocol version is upgraded to support the new version of the software.

▼ To upgrade a cluster

1. Upgrade each node in the cluster to the new software version as follows:

a. Stop the node (as described in “Stopping a Cluster”).

b. Upgrade the software on the node.

c. Restart the node (as described in “Starting a Node”).

d. Repeat these steps for each node in the cluster, one node at a time.

2. Select the cluster to be upgraded.

3. Choose Clusters > Rolling Upgrade (Selected menu) or Cluster Rolling Upgrade

(Command Launcher).

4. Complete the Rolling Upgrade dialog box as follows (if applicable):

When you have provided all necessary information in the dialog box, click OK.

Cluster: Type the name of the cluster or click Browse to select a cluster.

Notes:

◆ This task is only applicable in a cluster environment.

◆ This task upgrades the cluster to a new protocol version while the cluster remains

accessible.

◆ All nodes in the cluster must be upgraded to the new version of the software before

the cluster is upgraded. To avoid shutting down the cluster, you must stop, upgrade,

and restart one node in the cluster at a time.

◆ Once the cluster is upgraded, it cannot be downgraded to the previous version.
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Troubleshooting
 6

Introduction

This chapter provides information about Storage Administrator alerts, object states, and

other troubleshooting topics. This chapter also contains suggestions on how to fix some

common problems. If you are unable to resolve a problem by following the instructions in

this chapter, contact Customer Support for additional information.

The following topics are discussed in this chapter:

◆ Alerts

◆ Disk Troubleshooting

◆ Volume Troubleshooting

◆ General Troubleshooting

◆ Client/Server Problems

◆ Configuration Changes
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Alerts
Alerts
When an object fails or experiences an error, an alert icon appears on the object and the

object’s state usually changes to an unhealthy state. The unhealthy object also appears in

the Alert Monitor window, which summarizes the problem and indicates whether any

associated objects have problems. When an object enters an unhealthy state and has an

alert, you should review the contents of the Alert Monitor window and then try to correct

the problem. For more information about an object listed in the Alert Monitor window,

review the object’s Properties window.

❖ To display the Alert Monitor window, click the Alert button in the toolbar or choose

Window > Alerts.

❖ To view the properties of an object listed in the Alert Monitor window, select the

object and choose Object Properties from the Alert or popup menu. You can also

access object properties by double-clicking on the object.
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Disk Troubleshooting
The disk state indicates the current condition of a disk. The disk state appears in the state

column of the grid and in the Disk Properties window. When a disk is unhealthy, an alert

icon appears on the disk and the disk is listed in the Alert Monitor window. This section

describes the following disk states and provides suggestions on how to correct problems

associated with the unhealthy states:

◆ Disk State: Imported

◆ Disk State: Free

◆ Disk State: Not Setup

◆ Disk State: Import Failed

◆ Disk State: Disconnected

◆ Disk State: Deported

◆ Disk State: Offline

◆ Disk State: Not Initialized

◆ Disk State: Locked

◆ Disk State: Inactive

◆ Disk State: Foreign Owned

Disk State: Imported

The disk is accessible and has no known problems. The disk is under Volume Manager

control and belongs to a disk group. This is the normal disk state.

No user action is required.

Disk State: Free

The disk is in the Free Disk Pool. A disk in the Free Disk Pool is under Volume Manager

control, but has not been added to a disk group.

❖ To make the disk available for Volume Manager use, add the disk to a disk group.
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Disk State: Not Setup

The disk is not under Volume Manager control.

❖ To make the disk available for Volume Manager use, place the disk under Volume

Manager control and add the disk to a disk group.

Disk State: Import Failed

The disk was previously under Volume Manager control, but the Volume Manager cannot

access the disk and/or configuration information for the disk. The disk is not available for

use. This may happen after you upgrade the Volume Manager. This can also happen if

some disks are inaccessible at system startup.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks) to make sure that the Volume Manager recognizes all attached

hardware. Try to import the disk’s disk group.

❖ If the disk group is imported and the disk does not have a Volume Manager disk

name, place the disk under Volume Manager control and add the disk to a disk group.

Disk State: Disconnected

The connection between the Volume Manager disk and the underlying physical disk

(device) is broken. This can occur when a disk fails or when you disconnect a disk.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks) to make sure that the Volume Manager recognizes any newly

attached hardware.

❖ Try to reconnect the disconnected Volume Manager disk to its physical disk (using the

Replace Disk task).

❖ If you cannot fix the problem, replace the disk with another physical disk.
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Disk State: Deported

The disk belongs to a disk group that is currently deported. The disk is not available for

use in the deported disk group and cannot be added to a new disk group.

❖ To return the disk to a usable state, import the disk’s disk group.

❖ To move the disk to another disk group, import the current disk group, remove the

disk, and add the disk to a new disk group.

❖ If the disk group import fails and you want to free the disk’s space for use in other

disk groups, you can use the Initialize Disk task (Hosts > Initialize Disk) or the

following command to reinitialize the disk:

vxdisk -f init  device_name

Note This command overwrites the disk header and configuration information on the

disk. Any volume copies or regions located on the disk will not be accessible after

you reinitialize the disk.

Disk State: Offline

The disk cannot be accessed by the Volume Manager.

❖ To return the disk to an accessible state, bring the disk online.

Disk State: Not Initialized

A configuration error is preventing the disk from being used.

❖ To make the disk available for Volume Manager use, place the disk under Volume

Manager control and add the disk to a disk group.

❖ If the disk cannot be added to the Volume Manager via the Storage Administrator, it

may be necessary to reinitialize the disk with the Initialize Disk task (Hosts > Initialize

Disk) or the following command:

vxdisk -f init  device_name

Note This command overwrites the disk header and configuration information on the

disk. Any volume copies or regions located on the disk will not be accessible after

you reinitialize the disk.
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Disk State: Locked

The disk belongs to a disk group that is currently imported by another machine or was

last imported by another machine and was not deported cleanly. The disk is not currently

usable on the local machine.

❖ To make all of the disks in the disk group available for use on the local machine,

deport the disk group on the remote machine and then import the disk group on the

local machine.

❖ To make one disk available for use on the local machine, remove the disk from its disk

group (on the other machine) and add it to a disk group on the local machine.

❖ If the disk group is not imported on another machine, it may be necessary to reimport

the disk group and clear the host ID on all disks in the disk group. You can do this by

selecting the Clear Host ID option in the Import Disk Group dialog box or by running

the following command:

vxdg -C import disk_group

Note If any of the disks in the disk group are in use by another machine, this command

can cause the disks to be managed by two systems at the same time (which could

lead to corruption).

Disk State: Inactive

The disk appears to belong to a disk group, but is not active in the disk group. The disk

may have become (temporarily) inaccessible. Alternatively, the disk may have been

inaccessible at disk group import, but may be accessible now.

❖ Make sure that the physical disk is turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks) to make sure that the Volume Manager recognizes any newly

attached hardware.

❖ It may be necessary to reattach the disk to its disk group with the Replace Disk task or

the following command:

/etc/vx/bin/vxreattach [ device_name]

After a successful reattach, volume recovery may be necessary.

❖ If the reattach fails and you want to free the disk’s space for use, you can use the

Initialize Disk task (Hosts > Initialize Disk) or the following command to reinitialize

the disk:

vxdisk -f init  device_name
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Note This command overwrites the disk header and configuration information on the

disk. Any volume copies or regions located on the disk will not be accessible after

you reinitialize the disk.

Disk State: Foreign Owned

The disk is under the control of another disk management product. The disk is not

available for use with the Volume Manager.

❖ To make the disk available for Volume Manager use, remove the disk from the other

disk management product’s control and place the disk under Volume Manager

control.
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Volume Troubleshooting
The volume state indicates the current condition of a volume. The volume state appears in

the state column of the grid and in the Volume Properties window. When a volume is

unhealthy, an alert icon appears on the volume and the volume is listed in the Alert

Monitor window. This section describes the following volume states and provides

suggestions on how to correct problems associated with the unhealthy states:

◆ Volume State: Started

◆ Volume State: Stopped

◆ Volume State: Uninitialized

◆ Volume State: Degraded

◆ Volume State: Unusable

Volume State: Started

The volume is accessible and has no known problems. This is the normal volume state. No

user action is required.

Volume State: Stopped

The volume is disabled and is not available for use.

❖ To return the volume to a usable state, start the volume.

Volume State: Uninitialized

The volume is enabled, but is not initialized. If this state appears during volume creation,

no user action is necessary.

❖ To put the volume in a usable state, start the volume.
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Volume State: Degraded

The RAID-5 volume is in a degraded mode. This usually occurs when one or more

subdisks are unavailable and read requests require data reconstruction. An underlying

disk may have failed completely or there may be I/O errors on part of a disk.

Alternatively, an underlying disk may be disconnected.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks) to make sure that the Volume Manager recognizes any newly

attached hardware.

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If there has been a partial or complete disk failure, either replace the disk or move the

affected subdisks to another disk.

Volume State: Unusable

The RAID-5 volume is unusable. This usually occurs when there is a double disk failure

(that is, when two subdisks in the same stripe or the parity and one subdisk in a stripe are

damaged or inaccessible). The underlying disks may have failed or become inaccessible.

❖ Make sure that the physical disks are turned on, plugged in, and attached to the

computer. Repair any disk, controller, or cable problems. Scan the disks on the system

(Hosts > Scan Disks) to make sure that the Volume Manager recognizes any newly

attached hardware.

Run the following command to reattach the disks to their disk group:

/etc/vx/bin/vxreattach [ device_name]

To return the RAID-5 volume to a healthy state, recover the volume.

❖ If two of the volume’s disks have failed, the RAID-5 volume’s data is unusable.

Replace the failed disks and then try to restart the volume by running the following

command:

vxvol -f start  volume_name

Restore the volume from backup.

To prevent this problem in the future, enable logging for RAID-5 volumes.
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General Troubleshooting
This section contains suggestions on how to correct some general problems that may

occur when you try to use the Storage Administrator.

Client/Server Problems

This section describes some Storage Administrator client and server problems and

provides suggestions on how to correct these problems. For more information about the

client and server, refer to the vmsa(1M) and vmsa_server (1M) manual pages.

User is not authorized to connect to the server.

This error can occur for the following reasons:

◆ The user name is incorrect.

◆ The password is incorrect.

◆ The user does not have an account on the machine.

◆ The password and group files or NIS tables do not contain entries for the user.

◆ The user is not listed in the vrtsadm  group entry.

❖ Type the user name and password again. If the same error appears, ask the

administrator of the machine to make sure that your user name is included in the

vrtsadm  group entry and your user name and password are entered correctly in the

appropriate password and group files or NIS tables.

There is no such server.

The specified host machine does not exist or is not in the Domain Name System (DNS).

❖ Check the machine name and type the machine name again.

Unable to connect to the server.

The Storage Administrator server may not be running on the machine to be administered.

❖ Make sure the server is running (vmsa_server -q ) and the client and server are

properly configured. If necessary, restart the Storage Administrator server.

Possible client/server versions mismatch.

The Storage Administrator client and server versions may be incompatible.
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❖ Check the client and server versions:

vmsa -V

vmsa_server -V

If necessary, upgrade the client or server.

Server connection lost.

The Storage Administrator server has been stopped.

❖ Restart the server.

The server seems to have multiple addresses.

The server (host) may be known by multiple addresses.

❖ Try to specify one of the server’s IP addresses as the server host name.

Configuration Changes

The Storage Administrator is dynamic, so the Storage Administrator automatically

displays new objects or changes to existing objects on the system. These changes or

additions are usually reflected in the Storage Administrator immediately (or within a

short time).

If you add objects (such as new disks) to the system and the Storage Administrator does

not display these objects within a short time, you can force the Storage Administrator to

check for new objects in one of the following ways:

❖ Scan the disks on the system (Hosts > Scan Disks) to make sure that the Volume

Manager recognizes any newly attached hardware.

❖ Update the Storage Administrator server’s configuration database (Hosts > Reset

Server).
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Glossary
alert

An indication that an error or failure has occurred on an object on the system. When an

object fails or experiences an error, an alert icon appears.

alert icon

An icon that indicates that an error or failure has occurred on an object on the system.

Alert icons usually appear in the status area of the main window and on the affected

object’s group icon.

Alert Monitor

A window that provides information about objects that have failed or experienced errors.

browse dialog box

A dialog box that is used to view and/or select existing objects on the system. Most

browse dialog boxes consist of a tree and grid.

button

A window control that the user clicks to initiate a task or display another object (such as a

window or menu).

check box

A control button used to select optional settings. A check mark usually indicates that a

check box is selected.

children

Objects that belong to an object group.

cluster

A set of host machines (nodes) that share a set of disks.
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Command Launcher

A window that displays a list of tasks that can be performed on Volume Manager or other

objects. Each task is listed with the object type, task (action), and a description of the task.

A task is launched by clicking on the task in the Command Launcher. The Command

Launcher can be separated from or attached to the main window.

command log

A log file that contains a history of Storage Administrator tasks performed in the current

session and previous sessions. Each task is listed with the task originator, the start/finish

times, the task status, and the low-level commands used to perform the task.

Command Log View window

A window that displays the Storage Administrator command log file.

device name

The physical disk device name (or disk access name).

dialog box

A window in which the user submits information to the Storage Administrator. Dialog

boxes can contain selectable buttons and/or fields that accept information.

disk group

A set of disks that are under Volume Manager control and share a common configuration.

A disk group configuration is a set of records containing detailed information on existing

Volume Manager objects (such as disk and volume attributes) and their relationships.

Each disk group has an administrator-assigned name. The root disk group (rootdg ) is a

special private disk group that always exists. Volumes can only be created on disks that

belong to disk groups.

disk name

The Volume Manager disk name (or disk media name). This is the logical name given to the

disk by the Volume Manager or the administrator.

dock

To separate or attach the main window and a subwindow.

enclosure

A disk array.
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free disk pool

Disks that are under Volume Manager control, but do not belong to a disk group.

gap

A disk region that does not contain Volume Manager objects (subdisks).

graphical view

A window that displays a graphical view of objects. In the Storage Administrator, the

graphical views include the Object View window and the Volume Layout Details window.

grid

A tabular display of objects and their properties. The grid lists Volume Manager objects,

disks, controllers, or file systems. The grid displays objects that belong to the group icon

that is currently selected in the object tree. The grid is dynamic and constantly updates its

contents to reflect changes to objects.

group icon

The icon that represents a specific object group.

GUI

Graphical User Interface.

host

A machine or system.

launch

To start a task or open a window.

main window

The main Volume Manager Storage Administrator window. This window contains a tree

and grid that display volumes, disks, and other objects on the system. The main window

also has a menu bar, a toolbar, and an optional Command Launcher.

menu

A list of options or tasks. A menu item is selected by pointing to the item and clicking the

mouse.
Glossary 197



menu bar

A bar that contains a set of menus for the current window. The menu bar is typically

placed across the top of a window.

mirror

A copy of a volume and its data. There can be several mirrors per volume. The terms

mirror and plex are used synonymously.

node

In the Storage Administrator tree, a node is an element attached to the tree.

In a cluster environment, a node is a host machine in a cluster.

object group

A group of objects of the same type. Each object group has a group icon and a group

name. In the Storage Administrator, object groups include disk groups, disks, volumes,

controllers, free disk pool disks, uninitialized disks, and file systems.

object tree

A dynamic hierarchical display of Volume Manager objects and other objects on the

system. Each node in the tree represents a group of objects of the same type.

Object View Window

A window that displays a graphical view of the volumes, disks, and other objects in a

particular disk group. The objects displayed in this window are automatically updated

when object properties change. This window can display detailed or basic information

about volumes and disks.

plex

A copy of a volume and its data. There can be several plexes per volume. The terms mirror
and plex are used synonymously.

popup menu

A context-sensitive menu that only appears when you click on a specific object or area.

properties window

A window that displays detailed information about a selected object.
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radio buttons

A set of buttons used to select optional settings. Only one radio button in the set can be

selected at any given time. These buttons toggle on or off.

read-only mode

Read-only mode allows you to view objects on the system through the Storage

Administrator, but prevents administrative actions from taking effect.

scroll bar

A sliding control that is used to display different portions of the contents of a window.

Search window

The Storage Administrator search tool. The Search window provides a set of search

options that can be used to search for objects on the system.

Selected menu

A context-sensitive menu that changes its menu options to match the type of object that is

selected. By default, the Selected menu is greyed out. When an object is selected, the

Selected menu provides access to tasks appropriate for the selected object.

splitter

A bar that separates two panes of a window (such as the object

tree and the grid). A splitter can be used to adjust the sizes of the panes.

status area

An area of the main window that displays an alert icon when an object fails or experiences

some other error.

subdisk

A set of contiguous disk blocks that form a logical disk segment. Subdisks are associated

with plexes (mirrors) to form volumes.

task properties window

A window that displays detailed information about a task listed in the Task Request

Monitor window.
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Task Request Monitor

A window that displays a history of tasks performed in the current Storage Administrator

session. Each task is listed with the task originator, the task status, and the start/ finish

times for the task.

toolbar

A set of buttons used to access Storage Administrator windows. These include another

main window, a task request monitor, an alert monitor, a search window, and a customize

window.

tree

A dynamic hierarchical display of objects on the system. Each node in the tree represents

a group of objects of the same type.

uninitialized disks

Disks that are not under Volume Manager control.

volume

A virtual disk or entity that is made up of portions of one or more physical disks.

Volume Layout Details Window

A window that displays a graphical view of a volume and its components. The objects

displayed in this window are not automatically updated when the volume’s properties

change.

Volume to Disk Mapping Window

A window that displays a tabular view of volumes and their underlying disks. This

window can also display details such as the subdisks and gaps on each disk.

VMSA

Volume Manager Storage Administrator.
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help 7
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disconnecting 170
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File 7, 39

Help 7

Options 7, 48

popup 40

preferences 7, 48

Selected 7, 39

Window 7
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repairing 140
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multiple host support 3
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O
object properties
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