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Audience

Preface

The Legato NetWorker® Power Edition™ Performance Tuning Guide tells you how
to configure and maximize the performance of NetWorker Power Edition
software.

This guide also discusses the enhancements in the Power Edition product and
shows you how to configure and measure the performance of your NetWorker
system. Use this guide in conjunction with your NetWorker documentation,
which is included in Adobe PDF format on the NetWorker product CD.

The information in this guide is intended for system administrators who are
responsible for installing software and maintaining the servers and clients on
a network. Operators who monitor the daily backups might also find this
manual useful.

About This Guide

To use the information presented in this guide, you must install the NetWorker
software on your server and NetWorker client software on your client
machines. If the software is not installed, refer to your platform’s Installation
Guide for installation instructions.



Legato Product Manuals and Documentation

Legato Product Manuals and Documentation

Legato offers an extensive archive of product documentation at our web site
(www.legato.com). You can search the archive by part number, title, publication
date, version, or OS/platform. Most of the documents are in Portable Document
Format (PDF) that you can easily view by downloading Adobe Acrobat
Reader, which is also available from our web site. To access the archive, select
Document Library from our home page, then make your selection from the
Legato Product Manuals and Documentation search choices.

Conventions

This guide uses the following typographic conventions and symbols to make
information easier to access and understand.

boldface - Indicates DOS or UNIX line commands. For example:
Run the jbconfig command to add and configure the autochanger.

italic — Indicates directory pathnames, files, machine names, new terms
defined in the Glossary or chapter, and words or ideas that require
emphasis. For example:

Rename the original \nsr\res directory to \nsr\res.orig.

fixed-w dt h —Represents examples and information displayed on the
screen. For example:

medi a waiting: recover waiting for 8mm 5GB t ape
vol ume nane

Pull-down_menu>Command>Command - Depicts a path or an order to
follow for making selections in the GUI For example:

Volume>Change Mode>Appendable

fi xed-wi dth, bol df ace - Represents commands and text you type
exactly as shown. For example:

% dki nf o sdOa

fixed-width, boldface italic —Represents commands and text
that is replaced with user-defined text. For example:

C:\win32app\nsr\bin scanner -B ||. | Tape0

Important: Important information and cautionary notes that
prevent you from making a mistake.




Preface

Year 2000 Compliance

NetWorkerPower Edition supports dates in the year 2000 and beyond. For
additional information and details about related test cases, see the Year 2000
Compliance (Y2K) section on the Legato web site at www. legato.com.

Information and Services

Table 1 provides a list of Legato’s services, including electronic, telephone, and
fax support that provide company, product, and technical information.

Table 1. Legato Services and Resources

Company &

Technical |Binary |Product Training
Legato Service or Resource Bulletins |Patches |Information |Programs
www.legato.com Yes Yes Yes Yes
ftp.legato.com, Yes Yes
Internet address 137.69.200.1
(log in as anonymous)
Legato Inside Sales, Yes
(408) 530-3000 or sales@legato.com
Legato Education Services, Yes
(650) 812-6096 or training@legato.com
Note: For detailed information about our services, support policies, and software
subscriptions, please refer to the Legato Customer Service and Support Guide included in the
media package.

Technical Support

Table 2 provides a list of Legato’s sources available to fulfill your technical

support needs.

Table 2. Legato Technical Support Services

Technical Support Service

Address

Hotline

(650) 812-6100

e-mail

support@legato.com

Tech Dialog (requires password)

wwuw.legato.com/tech_dialog




Customer Service

Customer Service

Table 3 lists the Legato customer services resources available to you. Contact
Legato Customer Service if you have questions about licensing, registering, or
authorizing your Legato products. Customer Service also supplies
instructions for transferring licenses to a different server (rehosting) and
provides status on product orders.

Table 3. Legato Customer Services

Customer Service Address

telephone number (650) 812-6000 (option 3)
fax number (650) 812-6220

e-mail service@legato.com
e-mail for order status orderadmin@legato.com

Customer Feedback

10

Legato welcomes your comments and suggestions about software features,
disaster recovery procedures, and documentation. Please send any
suggestions and comments to feedback@legato.com. You will receive a notice
confirming receipt of your e-mail. Although we cannot respond personally to
every request, we consider all your comments and suggestions during product
design.



Chapter 1. Power Edition Features

Legato NetWorker is an enhanced NetWorker server product for Windows NT
and UNIX operating systems. It is optimized for high-speed backup and
recover operations on large amounts of complex data.

Power Edition Advantages

Power Edition addresses the storage management and data protection needs
of enterprises that have high-performance database servers and file servers. To
protect very large database (VLDB) applications, online transaction processing
(OLTP) applications, data warehouses, and web servers, the backup software
has to work quickly, often while the data and application are online and
available to other users.

Power Edition takes advantage of the high throughput of the leading
enterprise-class tape devices. Performance is scaled linearly as additional fast
storage devices are added to the system, up to the limit of the server's I/O
bandwidth.

In order to allow the server to maintain high data transfer rates, Power Edition
uses a minimum of the processor capacity. In benchmarking tests, Power
Edition rarely uses more than 15 percent of the CPU capacity during backup.

11
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Performance Enhancements in Power Edition

The major performance enhancements of Power Edition include:

Immediate save and recover

When you back up data from the Power Edition server or storage node,
this automatic feature speeds up data transfer. CPU load is reduced
because data is transferred within memory. Power Edition enables local
backup and recover to bypass the CPU overhead of networking protocols.

Storage nodes

A Power Edition server can have several storage nodes attached, each with
multiple devices, enabling the transmission of up to a maximum of 512
parallel backup sessions with a maximum of 256 devices. Because Power
Edition storage nodes store data locally and maintain all of the metadata
associated with the controlling Power Edition server, backup speed and
efficiency is enhanced. You can use immediate save and immediate
recover to back up and recover data hosted on a storage node.

High-speed device support

Power Edition supports a broad range of autochangers and silo tape
library models. Autochangers and silos can contain multiple storage
devices (tape drives or optical drives). They also can automate the tasks of
loading, unloading, and labeling storage media, so backups can proceed
without your intervention. High-speed devices are configured for higher
throughput, so they can write data to media faster, in larger blocks.

File device type and save set staging

Support for the file device type enables backup to disk. Save set staging
enables automated transfer of data from one medium to another according
to user-defined policies.

Remote procedure call (RPC) enhancements

Power Edition includes improvements to RPC, the communications
between processes, to improve the efficiency of both local and remote
backup and recover operations.

Power Edition reduces the time it takes to back up data locally, because the
data and the Power Edition server are hosted on the same computer. Data does
not have to travel through a protocol, such as TCP/IP, before it is directed to a
storage device. Instead, data is transferred within memory on the server. Thus,
network throughput is eliminated as a potential blockage. The same is true for
recover operations.



Chapter 1: Power Edition Features

When you back up data from remote clients, the data travels over the network
through a protocol, such as TCP/IP. Enhancements to RPC and high-speed
devices improve the performance of both remote and local backups.

Architecture Shared with the NetWorker Base Product

The Power Edition server, like the NetWorker server, schedules backup of data
and automates the process so that you do not have to change media or start the
backup procedure manually. You can create schedules that back up your data
at times when it is least used, for instance, at night or on weekends.

The Power Edition server also maintains records of the data backed up by the
Power Edition server and its storage nodes, to make recover operations easier.
In client file indexes, the server records the filename of each piece of data. In
the media database, the server records the contents of each media volume.
Browse policies and retention policies determine how long these records are
kept. Backups you make on a Power Edition server or storage node can be read
by a NetWorker server, and vice versa.

Power Edition also supports the file device type, for backup to disk, as well as
save set staging, which enables automated transfer of data from one medium
to another according to policies you define.

Because these functions are the same for Power Edition as for the NetWorker
base product, refer to your platform’s Administrator’s Guide for more
information about the scheduling, media management, and index
management features of the NetWorker product line.

Overview of Performance

Performance is the speed and efficiency with which a task is completed.
Backup and recover performance is dependent on several hardware and
software variables, but in general, your backup can go no faster than the speed
of your slowest component.

This guide provides tests you can use to measure and maximize the
performance of your computer. When you find the slowest component in the
data path between the location of the data and the storage device, you can
change software settings or replace a hardware component to improve backup
and recover performance.

13
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Hardware performance is limited by the lowest data rate of the following
computer components and related performance factors:
* Server speed
- Cru
- Memory
- Input/output (I/O) bandwidth
- SCSI bandwidth
—  Number of ports
¢ Device speed (combined for all storage devices used concurrently)
— I/0 transfer rate
—  Built-in compression and initialization characteristics
If you back up clients over a network, the following hardware performance
factors can also affect performance:
¢ (Client speeds (combined for all clients active at a point in time)
- CPU
- Memory
— Disk speed
¢ Network speed
— Network I/O bandwidth
- Network path
- Network load

Software performance factors include:

e Filesystem performance
¢ Application-specific optimization
* Backup application (for example, Power Edition)



Chapter 2. Power Edition Configuration

This chapter provides the details on the features and functionality unique to
the Power Edition version of NetWorker, including details on how Power
Edition works.

Power Edition Configuration

Power Edition is a specialized NetWorker server, so the configurations you
implement for Power Edition are somewhat different than for the NetWorker
server. This section describes immediate save and recovery, a special feature of
Power Edition. It also provides examples and illustrations that describe
configuration considerations that are specific to Power Edition.

How Immediate Save and Recover Works

During a backup session on a Power Edition server or storage node, Power
Edition can recognize whether the data resides on the same computer or a
remote computer. When the data resides on the same computer, immediate
saves and immediate recovers are invoked automatically. Instead of
transferring data across the network, data is transferred within memory on the
Power Edition server or storage node.

Immediate saves and recovers are available only in the case of local data
transfer, where the data and the Power Edition server or storage node are
hosted on the same computer. If the data is on a remote client, the data is
transferred over the network using TCP/IP.

Performance for remote backup is improved through RPC enhancements. The
examples in the following sections illustrate when immediate save is invoked,
and when it cannot be invoked.

15
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Power Edition Local Backup and Recover

When one computer includes both client and server or storage node software,
with storage devices attached, the data is backed up using immediate save.
Figure 1 shows an example of local backup of a Power Edition server. Power
Edition can back up data of any type supported by a NetWorker client,
including a range of databases.

Figure 1. Local Backup and Recover

NetWorker BusinesSuite Module Client
(X/Open Backup Services API Library)

Power Edition Server Storage Device

LS - O
— SCSI Connection

! NO
Database Server

Power Edition
NetWorker Client

Backup is faster in this setup for Power Edition than for the NetWorker base
product, because Power Edition can use the immediate save technology.
Processes and data that travel through a protocol stack in a standard
NetWorker setup are instead passed in memory on the same computer. The
network transmission blockage is eliminated. The same is true for recover
operations.

If the database is offline, any database can take advantage of immediate save
for local backup with a NetWorker client. Some NetWorker BusinesSuite
Module clients can also take advantage of immediate save for online database
backups. Refer to the documentation you received with your BusinesSuite
Module to determine whether immediate save for online backup is currently
supported.
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Power Edition Backup and Recover of Remote Client Data

Figure 2 shows an example of the Power Edition server installed on a different
computer than the data. To back up data from a fileserver of a particular
platform, the NetWorker client for that platform is installed on the fileserver
computer. The Power Edition server software and a NetWorker client (to back
up data that resides on the Power Edition server itself) are installed on the
Power Edition server.

Figure 2. Remote Backup and Recover

Fileserver Power Edition Storage
Server Device

[ TCP/IP scsl —'ﬂTg
Q_I Connection L —i| Connection @
=g o —100

Fileserver Power Edition
NetWorker Client NetWorker Client

Because the NetWorker client and the fileserver data reside on a remote
computer, the data is transferred across the network during backup.

For a recovery, the process is reversed. When the NetWorker client on the
fileserver computer makes a recover request, the data is again transferred
across the network.

Backup and recover performance over the network is enhanced for the Power
Edition server compared to standard NetWorker servers, because of RPC
enhancements that keep slower clients from slowing down the backup of
faster clients. Data that resides on the Power Edition server is automatically
backed up using immediate save (or automatically recovered using immediate
recover).

If the data is backed up to a high-speed device, performance is improved
because the device can transfer data faster and write data in larger blocks.

17
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Power Edition Storage Nodes

Figure 3 shows an example of a Power Edition server using a storage node for
backup and recover operations. Data hosted on each Power Edition storage
node is backed up and recovered using immediate save and immediate
recover technology. The metadata associated with backups is transferred over
the network to the controlling Power Edition server, and the data is transferred
directly to devices attached to the storage node.

Power Edition storage nodes enable you to design scalable configurations,
since multiple devices can be attached to multiple storage nodes, and data
transfer operations can run in parallel.

Figure 3. Power Edition Storage Node Backup and Recover

Power Edition Storage Storage
Server Node Device

.
] TCP/IP scsl ’:ﬁél
— Connection D Connection @)

i [
i

S NO

Power Edition PowerEdition Storage Node
NetWorker Client NetWorker Client

Power Edition Local Backup to a Silo

When you add a silo (specialized high-speed storage device) to the local
backup scenario, performance increases because of the speed and number of
devices in the silo. The silo requires another computer to be the silo server,
which controls the robotics in the silo. The silo server cannot be the same
computer as the NetWorker server.

In Figure 4, a silo and its silo server are added to a Power Edition local backup
and recover configuration.
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Figure 4. Local Backup to a Silo
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During backup, immediate save is invoked to transfer data from the
NetWorker client processes to the Power Edition server processes in the

memory of the Power Edition server computer. If the data is written to a device

in a silo, the nsrmmd service initiates an STLI call to the silo server, for

example, to mount a tape.

The STLI call is transferred across the network connection to the silo server,
then over a SCSI connection to the device in the silo. The data is transferred

over a SCSI connection from the Power Edition server to the device.

During a recover, the process is similar. Media handling information is

transferred across the network connection from the Power Edition server to
the silo. The silo mounts the tapes, and then the data is transferred over the

SCSI connection to the Power Edition server computer, where the data is

transferred in memory to the NetWorker client process.

For more information about silos and how they interact with Power Edition,

see your NetWorker Administrator’s Guide.
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How NetWorker Power Edition Works

Because Power Edition is a NetWorker server product, it shares a similar
architecture with the NetWorker base product. This section provides an
overview of how the NetWorker products perform backup and recover
operations.

All NetWorker servers consist of services and programs that oversee the
backup and recover processes and manage storage management client
configurations, client file indexes, and the media database. The NetWorker
client software includes a client service and user interface programs. The
services and programs in NetWorker products communicate using the RPC
(remote procedure call) protocol.

NetWorker Services and Programs

The services and programs in the NetWorker software coordinate the tasks
associated with a backup or recover operation, record information about what
was backed up, and track the media that contains the backed-up data.

Services and Programs on the NetWorker Server

This section describes the services and programs on the NetWorker server,
which contact the client for a backup and maintain the client file indexes and
media database on the server.

Table 4 lists these services and programs.

Table 4. Services and Programs on the Server

Service/

Program Function

ansrd This service monitors an active save or recover program session. This is an
agent process spawned by nsrd in response to a save or recover session.

asavegrp This service monitors the progress of individual save sets. This is an agent
process invoked by the savegrp program.

nsrck This service checks the consistency of the client file index. It is invoked by
nsrd whenever the consistency of the client file index needs to be confirmed.

nsrd This service provides an RPC-based save and recover program function to
NetWorker clients. This is the master NetWorker service.
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Table 4. Services and Programs on the Server (Continued)

Service/
Program Function
nsrim This service automatically manages the server’s media database. This

service is invoked by nsrmmdbd when it starts up, at the end of the savegrp
program, and by nsrd when a user removes the oldest backup cycle.

nsrindexd | This service provides a method for inserting entries into the client file index
based on information passed by the save program.

nsrmmd This service provides device support, generates mount requests, and
multiplexes save set data during a multi-client backup. The nsrd service can
start several nsrmmd services, up to twice the number of devices specified in
the server.

nsrmmdbd | This service provides media database management services to the local nsrd
and nsrmmd services and records entries in the media database. This is the
media management database service.

savegrp This program runs a group of NetWorker clients through the save process.

The NetWorker master service, nsrd:

e Starts other services

e Allocates media services on server computers

* Authorizes backup and recover services for the client
e Contacts clients for scheduled backups

¢ Maintains NetWorker configuration information

®  Monitors backup and recover sessions

* Maintains server statistics and message logs

Services and Programs on the NetWorker Client

The nsrd service calls upon the NetWorker client service, nsrexecd, and
several programs on the client when a scheduled or on-demand backup
request is received. A temporary server agent service, ansrd, starts on the
NetWorker server to monitor the progress of the backup session.
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Table 5 describes the services and programs on the NetWorker client.

Table 5. Services and Programs on the Client

Service/

Program Function

nsrexecd This service authenticates the NetWorker server’s remote execution request
and executes the save and savefs commands on the client.

recover This program browses the NetWorker server’s client file index and restores
the specified file to primary disk storage.

save This program sends specified files in a multiplexed data stream to the
NetWorker server for backup to media by nsrmmd and entry in the client file
indexes and media database by nsrindexd.

savefs This program sends information about the save sets to back up for the client
and identifies save set data modified since the previous level save.

How NetWorker Backs Up Data
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When you configure a backup group on the NetWorker server, you schedule a
start time for the backup group. The nsrd service starts the server’s savegrp
program for the backup group at the scheduled time.

The savegrp program queries the client resources configured on the
NetWorker server to determine:

e Which clients configured on the server are members of the scheduled
group
¢ What level of backup (save) to perform

e How many save sets to run concurrently, determined by the parallelism
value set on the NetWorker server

¢ When the most recent backup of the group occurred

If any of this information is not available on the NetWorker server, the savegrp
program sends a request (sometimes called a probe) to the nsrexecd client
service to run savefs on each client assigned to the backup group to gather the
necessary details.

The savefs program tells savegrp which objects to back up for the client. After
savegrp receives information about the objects to back up, savegrp assembles
a work list for the server. The work list specifies the order in which clients are




Chapter 2: Power Edition Configuration

contacted for backup. The order of the work list is determined by the Client
Priority attribute in the Clients resource. The client with the lowest value in the
Client Priority attribute is contacted first.

If problems were encountered with the client file index during the previous
backup session, nsrd invokes the nsrck service to check the consistency and
state of the NetWorker server’s client file indexes. Then, nsrd starts the
nsrindexd client file index insertion service.

The savegrp program contacts the first client on the server’s work list. The
client’s nsrexecd is invoked and starts a save session of the first save set listed
on the server’s work list. The saveprogram passes to nsrd all save criteria, such
as group, client, save sets, and level of the save data. With this information,
nsrd determines the pool of volumes that will store the data and forwards the
information to the appropriate media service, on the NetWorker server.

The media service, nsrmmd:

¢ Sends a message to the NetWorker server console, requesting a mount of
the media assigned to the volume pool indicated by nsrd

*  Writes the data sent by save to storage media

¢ Forwards storage information to nsrmmdbd for recording in the
NetWorker server’s media database

Any time there is a lull in save set activity from the client, the NetWorker
server attempts to find another save set in the group to keep the process
moving. The savegrp program attempts to concurrently back up as many save
sets as possible, up to the limit set by the parallelism attribute in the
NetWorker server’s configuration, to utilize the backup devices to their
maximum potential.

The savegrp program repeats the process for each item on the server’s work
list until all clients in the group are backed up. Before the savegrp program
finishes, if the NetWorker server is part of the group backing up or the server
is not part of any enabled group, the NetWorker server’s bootstrap file is
backed up.

If you have set up the bootstrap notification and you have installed and
configured TCP/IP print services, a bootstrap printout is sent to the default
printer configured for the NetWorker server after the bootstrap backup
finishes. Keep the bootstrap printout in a safe place in case you need to restore
the NetWorker server.

On Windows NT systems, the final results of the savegrp execution are
returned to the server and appended to the \nsr\logs\savegrp.log file. On UNIX
systems, the results are appended to the /nsr/logs/savegrp.log file.
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Figure 5. How NetWorker Services and Programs Interact During a Scheduled Backup
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Figure 5 shows how all of the NetWorker client and server services and
programs interact during a scheduled save.
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How NetWorker Recovers Data

When NetWorker receives a recover request from a client, the server’s nsrd
master service contacts the server’s nsrmmd media service. The nsrmmd
service contacts the server’s nsrmmdbd media database service to determine
which media contain the save set requested by the recover program. After
nsrmmd finds the save set on media, nsrmmd issues a mount request, the
media is positioned to the beginning of the save set, and the save set stored on
the mounted media is passed to nsrmmd. The media service forwards the save
set to the client’s recover program, which restores the data to the client’s
filesystem.

Figure 6 shows how the NetWorker server and client services and programs
interact while recovering data to a NetWorker client.

Figure 6. How NetWorker Services and Programs Interact During a Recover Session
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Chapter 3: Testing and Tuning Basics

Improving the performance of data storage management is more an art than a
science. If the data storage management process is operating very poorly or
not at all, the cause can be traced to a single problem. If your storage
management environment seems generally OK, but is not reaching the
performance levels you want, you might need to investigate and tune multiple
elements in the environment.

This chapter identifies the different hardware and software components that
make up your data storage management environment, discusses their impact
on storage management tasks, and provides general guidelines for locating
problems and solutions. The two subsequent chapters address specific
performance tests and fixes, particularly those that pertain to the specific
operating system on which you are using Power Edition.

Overview of Performance Testing and Tuning

The benchmark tests used in the computer industry are done in controlled
environments, to simplify analysis and show products at their greatest
advantage. When you test the performance of Power Edition in your
environment, you must decide how controlled a test to run.

To run a controlled test, turn off all extraneous processes to isolate the
performance of Power Edition. The results of this type of test show you the
optimal performance of Power Edition with your current hardware and
software configuration.

To run a less controlled test, do not shut down other applications and network
traffic. The results of this type of test show you how Power Edition performs
while the computer is running other programs and processes.
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If you run both a controlled test and a test with normal or simulated load, the
difference between the results can help you decide how to schedule your
backups and whether to run other programs on your Power Edition server.

The tests in this and the following chapters follow a basic strategy:
1. Measure the current performance of Power Edition server.
2. View the results to find a blockage or limiting factor.
3. Adjust the hardware and software to correct the blockage.
4. Measure the performance of the Power Edition server.

Although there will always be some blockage in a system, you can use this
process to eliminate the greatest obstacles to fast backup performance.

Meeting Minimum System Requirements

Before installing and using Power Edition or other storage management
products, read the minimum system requirements to ensure you have
sufficient computer and network hardware installed to support the
application.

System requirement information is usually located in your NetWorker
installation documentation. Failing to meet the system requirements,
particularly for memory, free space, and CPU speed, will have an obvious and
immediate negative impact on your storage management processes.

Server Hardware

The following sections address different hardware components of the Power
Edition server, including providing tests on improving the performance of
these components.

Physical Disks

The physical disks in a computer system are in constant motion, reading and
writing data for storage and recovery and for maintaining the client file
indexes and media database. Problems with the disks can negatively affect
every level of performance within your storage management environment.

The type of data you back up and how it is laid out on disk can cause backup
performance to vary. If you have large files that are fragmented, or if you have
many small files, the disk performance suffers because the disk head has to
move to go from one fragment or file to another. Backup is most efficient for
large files with minimal fragmentation.
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If the data is compressed on the disk, the operating system or application has
to decompress the data before transferring it for backup. The CPU spends
cycles to decompress the files, and the disk can rarely go at its maximum
speed.

Disk Read Speed Testing Methods
Follow these guidelines to determine the read speed of your disks:

o Test the read speed of each individual disk, without NetWorker running.
¢ Test the read speed of all disks, without NetWorker running.
e Test the read speed of each individual disk, while NetWorker is running.
¢ Test the read speed of all disks, while NetWorker is running.

You can use the NetWorker uasm module, which saves and recovers
filesystem data, to test how fast your system can read from your disk.

The syntax is as follows:
uasm-s [-benov] [-ix] [-t tinme] [-f proto] [-p ppath] path
uasm-r [-dnv] [-i {nNyYrR}] [-m src = dst] [-z suffiXx]
path
uasm-c [-nv] path

For example, enter the following command at the command prompt:

uasm-s filenane > NJUL

The uasm module reads from the disk at the maximum speed. In this example,
the data is written to a null location so the disk read is not slowed down to
allow time for writing.

The uasm module has three modes: save, recover, and compare.

* Insave mode, uasm walks directory trees and generates a save stream on
its stdout representing the files and organization of the directory tree.
Symbolic links are never followed by application specific modules
(ASMs), except rawasm.

¢ Inrecover mode, uasm reads a save stream from its stdin and creates the
corresponding directories and files.

* Incompare mode, uasm reads a save stream from its stdin and compares
the save stream with the files already on the filesystem.

In save mode, uasm can be controlled by directive files. Directive files control
how descendent directories are searched, which files are ignored, how the save
stream is generated, and how to process subsequent directive files.
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All ASMs accept the options described below. These options are generally
referred to as the “standard asm arguments.” ASMs can also have additional
options. A particular ASM’s additional options are in capital letters.

Either -s(save), - (recover) or -C (compare) mode must be specified and must
precede any other options. When saving, at least one path argument must be
specified. The path argument can be either a directory or a filename.

Options Valid for All Modes of uasm

* Use the -n option to perform a dry run. When saving, walk the filesystem
but do not attempt to open files and produce the save stream. When
recovering or comparing, consume the input save stream and do basic
checks, but do not actually create any directories or files when recovering
or do the work of comparing the actual file data.

® Use the -v option to turn on verbose mode. The current ASM, its
arguments, and the file it is processing are displayed. When a filtering
ASM operating in filtering mode (that is, processing another ASM’s save
stream) modifies the stream, its name, arguments, and the current file are
displayed within square brackets.

Options for Save Mode

® Use the -b option to produce a byte count. This option is like the -n
option, but byte count mode estimates the amount of data to be
produced, instead of actually reading file data, so this option is faster but
less accurate than the -n option. Byte count mode produces three
numbers: the number of records (files and directories), the number of
bytes of header information, and the approximate number of bytes of file
data. Byte count mode does not produce a save stream, so its output
cannot be used as input to another ASM in recover mode.

* Use the -0 option to produce an “old style” save stream that can be
handled by older NetWorker servers.

* Do not specify the -e option, because uasm does not generate the final
“end of save stream” boolean. This option should be used only when an
ASM invokes an external ASM and when an optimization chooses not to
consume the generated save stream itself.

® Use the -i option to ignore all save directives from .nsr directive files
found in the directory tree.

* Use the -f proto option to specify the location of a .nsr directive file to
interpret before processing any files. Within the directive file specified by
proto, <<path>> directives must resolve to files within the directory tree
being processed, otherwise their subsequent directives will be ignored.
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Use the -p option to specify <<path>> with ppath. When you specify -p
ppath, this string is added to the beginning of each file’s name as it is
output. This argument is used internally when one ASM exec’s another
external ASM. The path you enter for ppath must be a properly formatted
path that is either the current working directory or a trailing component
of the current working directory.

Specify a date with -t date to set the date after which files must have been
modified before they are saved.

Specify -x to cross filesystem boundaries. Normally, filesystem
boundaries are not crossed during walking. Symbolic links are never
followed, except in the case of rawasm.

Options for Recover Mode

Specify -i {nNyYrR} to define the initial default overwrite response
option. Only one letter is allowed. When the name of the file being
recovered conflicts with an existing file, the user is prompted for
overwrite permission. The default response option, selected by pressing
[Return], is displayed within square brackets.

Unless otherwise specified with the - i option, n is the initial default
overwrite response option. Each time a response option other than the
default is specified, the new response option becomes the default.

When you specify either N, R, or Y, you are prompted only when
NetWorker cannot auto-rename a file that already ends with the rename
suffix, and each subsequent conflict is resolved as if the corresponding
lower-case letter had been selected.

Table 6 lists the overwrite response options and their meanings:

31



Server Hardware

Table 6. Overwrite Response Options

Option

Meaning

Do not recover the current file.

Do not recover any files with conflicting names.

Overwrite the existing file with the recovered file.

=< |Z |3

Overwrite all files with conflicting names.

-

7

Rename the conflicting file. A dot, “.”, and a suffix (by default “R”) are
appended to the recovered file’s name. If a conflict still exists, NetWorker
prompts you again.

7

Automatically renames conflicting files by appending a dot, “.”, and a suffix. If a

conflicting filename already ends in a “.” suffix, NetWorker prompts you to
avoid potential auto-rename looping conditions.

32

¢ Use the -m src=dst option to map the filenames to be created. Any files
that start exactly with src are mapped to have the path of dst replacing the
leading src component of the pathname. This option is useful if you want
to perform relocation of the recovered files that were saved using
absolute pathnames into an alternate directory (for example,
-m c:\win32app=.).

¢ Enter -z suffix to specify the suffix to append when renaming conflicting
files. The default suffix is R.

Disk Performance Tuning Methods

If you find a performance blockage in your disk system, you can make the
following changes to improve performance:

* Defragment files to reduce the number of disk seeks.

* Use larger files or fewer files to reduce the number of disk seeks.

e Change to a faster SCSI adapter, with synchronous I/O support and bus
mastering.

*  Use stripe sets on multiple disks to accommodate large files and
databases, so the physical disks can work in parallel to read data.

® Spread disk-intensive programs onto different servers.
¢ Purchase disks with higher transfer rates.
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Memory

CPU

Each backup session requires CPU and memory resources on your Power
Edition server. If other applications are running concurrently with the backup,
they impose an additional load on the system. Heavy swapping or paging
activities indicate that the server is CPU- or memory-bound.

A Power Edition server or storage node computer can never have too much
memory. Data transfer within memory is much faster than over a network.
Memory holds frequently used data so the disk does not have to be read as
often. Open applications, running processes, and disk cache all use memory. If
the operating system is capable, disk storage space can be used as simulated
memory, often known as virtual memory.

For best results, install the maximum amount of memory that your computers
will sustain, especially for your Power Edition server and storage nodes.

Each backup session also requires CPU and memory resources on your Power
Edition server. If other applications are running concurrently with the backup,
they impose an additional load on the system. Heavy swapping or paging
activities are indicative that the server is CPU- or memory-bound.

To increase CPU performance and bandwidth, upgrade to a faster CPU or add
additional CPUs if your Power Edition server supports multiple processors.
You can also shut down other processes during backup time to see if that
reduces the processor load and improves backup performance.

Similarly, you should always set scheduled backups for low-traffic periods to
avoid performance degradation or excessive network traffic. The default
NetWorker backup start time is 3:33 a.m.

Your computer’s operating system might contain various utilities for testing
and tuning CPU speed. Additionally, you can check the CPU utilization of
each NetWorker function. The processes involved in a Power Edition backup
are the following:
¢ NetWorker services

— nsrexecd

- nsrd

- nsrmmd

- nsrmmdbd

— nsrindexd
¢ save, the NetWorker backup program

33



Server Hardware

34

* Application-specific services, such as for a database server

You can use the Windows NT Performance Monitor to measure and record
CPU speed for your NetWorker for Windows NT Power Edition server. See
“Test CPU Performance” on page 59.

Server Input/Output

The following performance variables relate to the input/output (I/O)
throughput on your Power Edition server:

Input/Output Backplane

On a well-configured Power Edition server, the maximum data transfer rate of
the server's I/O backplane is the limiting factor for backup throughput. The
theoretical backup throughput limitation is the following formula:

Backup throughput = Maximum I/O throughput/2
At minimum, Power Edition requires two I/O transactions per data block:
* Aread from the disk to memory
¢ A write from memory to media
SCSI I/0 Bandwidth

SCSI bus performance depends on the technology deployed. Some
specifications for different types of SCSI technology are:

® S5CSI-2 single-ended, 10 MB/sec

e FWD (fast-wide-differential), 20 MB/sec

e UltraSCSI, 40 MB/sec

e Fibre

Note, however, the following:

¢ The rated speeds of SCSI buses are defined at best-case.

e The selection of UltraSCSI-compatible devices is currently limited.
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Power Edition Settings

Power Edition has several attributes that control the speed and volume of data
being backed up. You can adjust these attribute’s settings to modify backup
levels to attain the best performance on your Power Edition server.

The following sections address the various Power Edition settings in principle.
Because these attributes appear in different locations in the Windows NT and
UNIX versions of Power Edition, look in the subsequent chapters for specific
instructions on how to access these settings based on the server platform.

Server Parallelism

The server parallelism attribute controls how many savestreams the server
accepts at the same time. The more savestreams the server can accept, the
faster the devices and clients’ disks run, up to the limit of their performance or
the limits of the connections between them.

Client Parallelism

The client parallelism attribute controls how many savestreams a client can
send at the same time. To avoid disk contention, do not set a value for client
parallelism that is higher than the number of physical disks on the client.

Multiplexing

The target sessions attribute sets the target number of savestreams to write to
a device at the same time. Because this value is not a limit, a device might
receive more sessions than the target sessions attribute specifies. The larger the
number of sessions you specify for target sessions, the more save sets are
multiplexed, or interleaved, onto the same volume.

Some performance testing and evaluation is helpful in deciding whether
multiplexing is appropriate for your system. Follow these guidelines when
evaluating the use of multiplexing:

e Find the backup rate of each disk on the client. Use the uasm test
described in “Disk Read Speed Testing Methods” on page 29.

¢ Find the maximum rate of each device. Use the bigasm test described in
“Device Performance While Running NetWorker” on page 41.

If the sum of the backup rates from all disks involved in a backup is greater
than the maximum rate of the device, do not increase server parallelism. If you
multiplex more save groups in this case, backup performance does not
improve, and recover performance could slow down.
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Immediate Save and Immediate Recover

The Power Edition server selects immediate save technology automatically for
local backup and recover operations. There are no settings to adjust for
immediate save or immediate recover.

To verify that the immediate save function is working when you expect, run a
local backup in debug mode, and look at the output for using immediate save.

For example, on a Windows NT computer named mars, you would enter the
following command at the prompt:

save -D 1 -s nmars c:\autoexec. bat

The output is would be as follows:

save: using "C:\AUTOEXEC.BAT for “c:\autoexec.bat’
save: ssid 56420 using immediate save to “mars’
asm -s CAAUTOEXEC.BAT

save: access(C:\nsn\debug\NSR_NTBUFFERED) sets
NT_bufferedto 0

asm-s C:\

save: mars.legato.com:C:\AUTOEXEC.BAT size 3 KB, 2
file(s), took 0 min 2 sec

save: CNAUTOEXEC.BAT 3 KB 00:00:09  2files
save completion time: 7-24-97 5:25p

Power Edition Settings Performance Tuning Methods

Here are some measures related to Power Edition settings that can improve
your server performance:

Set the server Parallelism and Target Sessions attributes so that the total

of the performance of the disk drives equals the total performance of the
tape drives. If you set the Parallelism attribute to a higher value, there is
no benefit.

To select the right values for the Parallelism and Target Sessions attributes,
use the following equation:

Parallelism = Number of Devices * Target Sessions

For example, if you have three tape drives available for backup, and you
want each tape drive to accept two savestreams, set the value of server
parallelism to 6 and the value of target sessions to 2.
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Decrease the server Parallelism and Target Sessions attributes to unload
an overworked Power Edition server. With the correct settings, the
computer’s normal operation should not be interrupted by backups or
other Power Edition activities.

Add more memory to handle a higher parallelism setting.

Increase CPU power by upgrading the CPU or adding additional CPUs to
the server (if possible)

Reduce server load by spreading backups across multiple servers or
storage nodes.

Balance the number of disks and devices, so the backups finish at about
the same time. For instructions on how to change these settings, refer to
your Administrator’s Guide.

Here are some methods of balancing the work load on disks and devices:

— In general, start backups for the slowest or the biggest disk volumes
first, because other disks can join in later to match the maximum
bandwidth of the device.

— Use pools of media to force the bigger and faster disk volumes to
back up to faster devices.

- If youhave a very large and fast disk volume and many tape drives,
you can manually divide the volume into several save sets, such that
each of them can go to each tape drive in parallel.

— Balance data load for simultaneous sessions more evenly across
available devices by adjusting the Target Sessions attribute. This
parameter specifies the minimum number of save sessions that must
be established before Power Edition attempts to assign save sessions
to another device.

To fully use the bandwidth of a high-speed device when you have many
slow clients or disks, multiplex the save sets on media. You maximize the
performance of your devices when they do not have to start and stop to
wait for data.

To improve recover performance, multiplex save sets that you will
recover together onto the same tape. For example, multiplex the disks of
the same computer onto the same media, because it is likely that the data
would be recovered at the same time.
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In cases where you back up data across a network, the following suggestions
can also improve performance:

* Increase the client parallelism attribute, especially for clients with a
logical volume manager and several physical disks. The bandwidth of
your network could limit the number of savestreams you can transmit at
one time.

* To reduce server load, split backups across multiple servers.

¢ Turn on data compression in the NetWorker client to improve effective
data throughput and reduce network traffic.

e Configure clients with high transfer rate requirements to have a
preference for a particular backup server on the same subnet; avoid
router hops between the NetWorker server and its clients.

Backup Devices
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Backup devices are used by Power Edition and other storage management
products to write backed-up data to the storage media volume, and for
reading saved data from the storage media during recoveries. Devices pass
data to and from the Power Edition server itself, or a NetWorker storage node,
through a SCSI connection. Backup devices can include optical disks, and in
most cases, tape drives. When a backup device has multiple drives, such as for
autochangers, each drive is considered a separate device.

Device Write Performance Tuning Methods

If the disk read speed is noticeably faster than the device’s ability to write, that
might indicate a problem with the device’s write performance. To be thorough
in evaluating your device’s performance, follow these testing guidelines:

* Measure the write speed of each individual device, without NetWorker.
* Measure the write speed of all devices, without NetWorker.

* Measure the write speed of each individual device, while NetWorker is
running.

* Measure the write speed of all devices, while NetWorker is running.
It is recommended that you evaluate your device performance without

NetWorker running first, and then evaluate your devices again with
NetWorker running.

Ensure that you use the same tape drives for your tests both when NetWorker
is running and when it is not, to ensure consistency in the measurements.
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Device Performance Without Running NetWorker

Use the mt program to determine device performance when NetWorker is not
running. Using the mt program allows you to evaluate your device
performance without considering the overhead incurred when using
NetWorker.

The mt program allows you to operate a magnetic tape device, such as
rewinding, fast-forwarding, and ejecting tapes. The mt program cannot be
used to measure the writing data rate, but can indicate performance rates
related to having tapes start off loaded and rewound prior to measuring write
speeds to tape.

The mt program comes with NetWorker and is entered at the command line,
using the following syntax:

m -f devi cenane conmand count

By default, the mt program performs the requested operation once. To perform
the operation more than once, specify a value in place of count.

The available commands are listed below:
e eof, weof

Writes count end of file (EOF) marks at the current position on the tape.
o fsf

Forward spaces over count EOF marks. The tape is positioned on the first
block of the file.

o fsr
Forward spaces count records.
* bsf

Backspaces over count EOF marks. The tape is positioned on the
beginning-of-tape side of the EOF mark.

*  Dbsr
Backspaces count records.
¢ nbsf

Backspaces count files. The tape is positioned on the first block of the file.
This is equivalent to count + 1 bsf followed by one fsf.

39



Backup Devices

40

asf

Absolute space to count file number. This is equivalent to a rewind
followed by fsf count.

For the following commands, count is ignored:

eom

Spaces to the end of recorded media on the tape.This is useful for
appending files onto previously written tapes.

rewind
Rewinds the tape.
offline, rewoffl

Rewinds the tape and, if appropriate, takes the drive unit offline by
unloading the tape.

status
Prints status information about the tape unit.
retension

Rewinds the cartridge tape completely, then winds it forward to the end of
the reel and back to beginning-of-tape to smooth out tape tension.

erase
Erases the entire tape.
format

Formats the tape at a low level.

The mt program returns a 0 exit status when the operations were successful, 1
if the command was unrecognized or if mt was unable to open the specified
tape drive, and 2 if an operation failed.

Not all devices support all options. Some options are hardware-dependent.
For example, by entering the following command:

D\>nt -f \\.\TapeO status

the following output is displayed:

\\ .\ TapeO:
Medi a Capacity = 2.12@Byte
Medi a Renai ning = 3. 06@Byt e
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Medi a Block size = 0

Media Partition Count =0
Media is not wite protected
default bl ock size = 8192

maxi mum bl ock size = 1040384

The maximum block size value limits the maximum number of bytes per SCSI
transfer on disk reads and volume writes.

Device Performance While Running NetWorker

To measure SCSI throughput and the write speed of a device while NetWorker
is running, use the bigasm module provided with NetWorker. The bigasm
module generates a file of the specified size, transfers it over a SCSI
connection, and writes it to a tape or optical device.

The description and options of bigasm (and all other application specific
modules) are the same as for the usam module. See “Disk Read Speed Testing
Methods” on page 29 for a full description of the uasm module.

To set up a bigasm test, follow these steps:
1. Create a directive file, nsr.dir, that contains the following command:
bi gasm - Ssize : fil enane
For example:
bi gasm - S100M : bigfile

2. Create a file with the name you specified in your directive, for example,
bidfile, in the same directory as your directive.

3. Back up the file using Power Edition. For example, if your file is called
bigfile and your Power Edition server is called jupiter, enter:

save -s jupiter bigfile
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Device Performance Tuning Methods

The following sections address specific device-related areas where you can
improve performance.

Input/Output Transfer Rate

Input/output (I/O) transfer rates can affect device performance. The I/O rate
is the rate at which data can be written to the device. Depending on the device
and media technology, device transfer rates can range from 500 KB per second
to 20 MB per second. Default block size and buffer size of a device affect its
transfer rate. If you believe that I/O limitations are hampering improved
performance of Power Edition, try upgrading your equipment to affect a better
transfer rate.

Built-In Compression

Turn on a device’s compression to increase effective throughput to the device.
Some devices have a built-in hardware compression feature. Depending on
how compressible the backup data is, this can improve effective data
throughput, from a ratio of 1.5:1 to 3:1.

Drive Streaming

To obtain peak performance from most devices, stream the drive at its
maximum sustained throughput. Without drive streaming, the drive must
stop to wait for its buffer to refill or to reposition the media before the drive
can resume writing. This can cause a delay in the cycle time of a drive,
depending on the device.

Device Drives

Add more tape drives or upgrade to higher speed tape devices for increased
throughput.

Device Load Balancing

Balance data load for simultaneous sessions more evenly across available
devices by adjusting sessions per device. This parameter specifies the
minimum number of save sessions that must be established before NetWorker
attempts to assign save sessions to another device.
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File Type Device and Staging

NetWorker includes the file type device and save set staging features, which
you can use to improve backup performance. Use the file type device feature
to direct your backups to disk media instead of tape or optical media, since
reading and writing data to disk is generally faster than to tape or optical
media.

Use save set staging in conjunction with backups to the file type device. Save
set staging lets you move save sets you have backed up from one medium to
another according to criteria you set, such as space remaining on the disk or
the age of the save set. With staging, you can automate transferring older
backups from the file type device to a less expensive storage media and free up
hard disk space for new backups.

A possible configuration to maximize performance of file type devices would
be the following:

1. Create one directory per user, preferably with a mnemonic name
matching a client.

2. Create one file type device per directory, setting the volume size to 1 GB.

3. Create one client per system, setting the device that is always used to have
the matching mnemonic device name.

This configuration limits your system to 64 users with Power Edition, since
one user equals one device, and that is how many devices Power Edition
supports. However, if you use storage nodes, then you can have 64 devices per
each node up to a maximum of 256 devices total for NetWorker and all
attached storage nodes.

If you back up your data to file type devices, you get high-speed backups to a
hard drive in near real time, but the disk tends to fill quickly with backups.
Without save set staging, you would have to closely monitor disk usage to
avoid running out of space for your backups, and you would either have to
move save sets manually or create very short browse and retention policies.

With save set staging, the process of moving data from disk storage to tape or
optical disk is automated, and the space that was occupied by the save set is
freed to make space for new backups. The browse and retention policies for the
save sets on tape or optical disk can be as long as you like. You can also use
save set staging to move files from other types of media, but the space is only
reclaimed on the file type device.

If you are worried about disk contention when you back up to file type
devices, you can use many smaller drives (for example, 6 drives of 4 GB each
and 4 users per drive, instead of one 23 GB drive).
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You can also use a RAID array, which provides redundancy in case of a drive
failure. Windows NT includes a software RAID capability that works well, but
uses many CPU cycles. A hardware RAID solution is more efficient, but this
solution is more expensive.

Network Hardware
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If you back up data from remote clients, the routers, network cables, and
network interface cards you use affect the performance you get. This section
lists the performance variables in network hardware and suggests some basic
tuning for networks. The following section address specific network
performance areas.

Network Input/Output Bandwidth

The maximum data transfer rate across a network rarely approaches the
manufacturer’s specification because of network protocol overhead.

Network Path

Networking components such as routers, bridges, and hubs consume some
overhead bandwidth, which degrades network throughput performance.

Network Load

Other network traffic limits the bandwidth available to Power Edition and
degrades backup performance. As network load reaches a saturation
threshold, data packet collisions degrade performance even more.

How to Tune NetWork Hardware Performance
Employ the following measures to improve network hardware performance:

* Add additional network interface cards to client systems to expand
network bandwidth available to clients.

¢ Upgrade to faster LAN media, such as 100 MB Ethernet or FDDI, to
improve network bandwidth. Note, however, that TCP packet overhead
can reduce the total transfer rate.

e Configure clients that have high transfer rate requirements to show a
preference for a particular backup server (or storage node) on the same
subnet; avoid router hops between NetWorker server and clients.

¢ Minimize the number of network components in the data path between
the client and server.
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This chapter provides additional performance testing and tuning information
for your Power Edition server on UNIX. The information provided in this
chapter supplements the material on general Power Edition performance
issues covered in the previous chapter. See “: Testing and Tuning Basics” on
page 27 to familiarize yourself with these general issues before continuing on
to this chapter. In some cases, information pertaining to a specific performance
issue or tuning method is covered in both chapters. The information here is
specifically written for the UNIX environment, and provides UNIX-based
examples.

Given the multitude of platform- and network-specific variables that can
impact UNIX system performance, it is not possible to discuss them all
comprehensively in a single chapter. Instead, the scope of this chapter is
limited to the detection and analysis of processes that have an impact on the
ability of Power Edition to efficiently perform backups.

While there are no simple solutions to performance issues, this chapter
provides a general testing strategy for locating performance blockages. The
testing strategy uses benchmarks and baselines derived from common UNIX
utilities.

The information in this chapter assumes that you are familiar with the UNIX
system infrastructure, including networking and devices. In addition, you
should be familiar with writing UNIX shell scripts and using UNIX utilities
such as tar.

The scripts in this chapter use standard UNIX utilities. The examples are
specific to Solaris, but the scripts can be applied to most UNIX platforms with
minimal changes.
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The testing strategy and scripts use the following scenario:

e All backup processes are local (that is, not over a network).
¢ All tape devices operate at the same speed.
* Data is stored on a filesystem (no databases are used).

Physical Disks

The following sections provide information and suggestions on testing and
evaluating the read speed performance on your Power Edition server’s
physical disks. The UNIX operating system provides several utilities for
determining disk read speed. The following sections detail their usage.

Apply the following testing strategy to collect baselines to measure tape drive
performance:

o Test the read speed of each individual disk, without NetWorker running.
o Test the read speed of all disks, without NetWorker running.
¢ Test the read speed of each individual disk, while NetWorker is running.
o Test the read speed of all disks, while NetWorker is running.

Benchmark Evaluation

The UNIX utility /bin/time reports the amount of time required to execute a
program, breaking down the total time into three components: real time, user
time, and system time. Real time is the time that the program takes to run as it
would be measured by a user sitting at the terminal using a stopwatch. User
time is the actual time that the computer spent executing code in the user state.

System time is the time the computer spent executing UNIX system code on
behalf of the user.

For example, the result of running the /bin/time tar cvf - /space2 > /dev/null
command on a Solaris computer named passport provides the following result
for the mount point /space2:

RESULTS:

real 6:53.4
user 18. 2
Sys 1:48.1
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How to Test the Read Speed of a Single Disk
To test the read speed of an individual disk, follow these steps:

1. Use the df command to display a list of mounted filesystems and their
respective sizes.

2. Run the /bin/time utility to determine how long it takes to read each
filesystem. For example, on Solaris, enter:

/bin/time tar cf - nount_point > /dev/null
To achieve a consistent result, no other disk or system activity should be
running when you run this command.

How to Test the Read Speed of Several Disks

After you execute the /bin/time utility for each individual filesystem, measure
the read time for all the filesystems on each SCSI bus. If you are running the
disks in parallel, develop a baseline for the number of parallel disks. For
example, if there are 300 disks, and 10 are in parallel, measure the baseline for
the 10 disks.

To streamline this task, create a shell script using the editor of your choice.
Following is an example shell script from a Solaris computer that was created
for multiple disks (/space, /space2, etc.):

/bin/time tar cf - /space > /dev/null &
/bin/time tar cf - /space2 > /dev/null &
/bin/time tar cf - /space3 > /dev/null &

How to Test the Read Speed of a Single Disk While Running NetWorker

To test the read speed of an individual disk using NetWorker, follow these
steps:

1. Use the df command to display a list of mounted filesystems and their
respective sizes.

2. Run the uasm command for each disk. For example, on Solaris, enter:
/bin/time vasm-s nount_point > [dev/null

Depending on the configuration of your computer, you might need to
specify the path for uasm in the command above.

See “Disk Read Speed Testing Methods” on page 29 for more information on
the uasm command.
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How to Test the Read Speed of Several Disks While Running NetWorker
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Test the read speed for all the disks on a SCSI channel. If you are running the
disks in parallel, develop a baseline for the number of parallel disks. For
example, if there are 300 disks, and 10 are in parallel, measure the baseline for
the 10 disks.

To streamline this task, create a shell script using the editor of your choice.
Following is an example shell script for a Solaris computer that was created for
multiple disks (/space, /space2, etc.):

/bin/time uasm-s /space > /dev/null &
/bin/time uasm-s /space2 > /dev/null &
/bin/time uasm-s /space3 > /dev/null &

To calculate the read speed of your disk, follow these steps:
1. Use the df command to obtain the file size (in kilobytes) of /space2:
% df

Fi | esystem kbyt es used capacity Mountedon
/ dev/ dsk/ cOt 1d0OsO 1952573 797935 46% / space2

2. Divide the real time by the size (in kilobytes) of /space2.

For example, based on the result and size of /space2 above, the read speed
of /space2 is 1932 KB/ sec.

Compare the results of the benchmarks generated from individual disks
without NetWorker to the results of individual disks running NetWorker.
Then, compare the results of the benchmarks generated from multiple disks
without NetWorker to the results of multiple disks running NetWorker.

Apply the following testing strategy to collect baselines to measure tape drive
performance:

¢ Test the write speed of each individual tape drive, without running
NetWorker.
e Test the write speed of all tape drives, without running NetWorker.

¢ Test the write speed of each individual tape drive, while NetWorker is
running.

o Test the write speed of all tape drives, while NetWorker is running.

Ensure that you test the same tape drives both when NetWorker is running
and when it is not, to ensure consistency in the measurements.
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Benchmark Evaluation

Compare the results of the benchmarks generated from individual drives
writing data without NetWorker to the results of individual drives writing
data when NetWorker is running. Then, compare the results of the
benchmarks generated from multiple drives writing data without NetWorker
to the results of multiple drives writing data while running NetWorker.

How to Test the Write Speed of a Single Tape Drive

To test the write speed of a single tape drive, run the following commands for
each tape drive:

m -f /dev/rmt/drive name rew nd

dd if=/dev/zero of=/dev/rm/ drive_nane \
bs=bl ock_si ze count =1;\

/bin/time dd if=/dev/zero of=/dev/rnt/drive nane \

bs=bl ock_si ze count =1000

Although the block size can vary depending on your environment, we use a
block size value of 32 for our testing and examples.

A

Important: Using the mt rewind command, followed by the dd command, can
cause the erasure of a tape. Exercise caution when using these commands.

How to Test the Write Speed of Several Tape Drives

Test the write speed of all the tape drives on your SCSI channel. To streamline
this task, create a shell script using the command above. The following is an

example of a shell script for a Solaris computer that was created for multiple
drives (Ombn, 1mbn, 2mbn, etc.):

m -f /dev/rnt/Onbn rewind; dd if=/dev/zero \
of =/ dev/rm /0Onbn bs=32k count=1; \

/bin/time dd if=/dev/zero of=/dev/rnt/0nbn \
bs=32k count=1000 &

m -f /dev/rmt/1nbn rewind; dd if=/dev/zero \
of =/ dev/rm/1nbn bs=32k count=1; \

/bin/time dd if=/dev/zero of=/dev/rnt/1nbn \
bs=32k count=1000 &
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m -f /dev/rmt/2nbn rewi nd; dd if=/dev/zero \
of =/ dev/rnt/2nbn bs=32k count=1; \

/bin/tinme dd if=/dev/zero of=/dev/rnt/2nbn \
bs=32k count=1000 &

How to Test the Write Speed of a Single Drive While Running NetWorker

To test the write speed of a single drive while running NetWorker, follow these
steps:

1. Set target sessions to 1.
2. Label the tape.
3. Set up bigasm:

a. Enter the following command at the prompt to create an empty
directory:

nkdi r /enpty

b. Enter the following command at the prompt to go to the directory
empty:
cd /emty

c. Enter the following command at the prompt to create an empty file:
touch e

d. Enter the following command at the prompt to create a .nsr file with a
bigasm directive in the empty directory:

bi gasm - S1I00M : e
This command results in writing a 100 MB file to the tape.
4. Run the following script to determine the baseline:

save -s server_nane [etc/motd; /bin/time save -s \
server_nane -f [enptyl/e

Note: In the command above, there is a space between /.nsr and /empty.

NetWorker automatically assigns each command to a tape, since target
sessions are set to 1.

How to Test the Write Speed of Several Drives While Running NetWorker

To test the write speed of several drives, repeat steps 1-4 in “Test the Write
Speed of a Single Drive While Running NetWorker” for every drive on the
SCSI channel at the same time.
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This chapter addresses specific performance testing and tuning tasks you can
perform on your NetWorker for Windows NT Power Edition server. For a
discussion of general performance issues affecting all versions of Power
Edition, see “Chapter 3: Testing and Tuning Basics” on page 27.

Windows NT Performance Monitor

Use the Windows NT Performance Monitor program to test system
performance. In the Performance Monitor, you can choose which objects (for
example, the processor or memory) to watch, which counters to test (for
example, available bytes of memory), and how to display the data. The default
view of the data is a real-time line chart. However, you can also choose to log
the data, format it as a report, or create alerts that warn you when a counter
reaches a certain limit.

How to How to Start the Windows NT Performance Monitor

To start the Windows NT Performance Monitor on your NetWorker for
Windows NT Power Edition server, follow these steps:

1. Select Start>Programs>Administrative Tools>Performance Monitor to
open the Performance Monitor window.

2. Select Report from the View menu.

The default viewing mode of Performance Monitor is Chart, but the
Performance Monitor-related tasks in this chapter use the Report mode.

3. Select Add To Report from the Edit menu to open the Add to Report dialog
box.
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4. Select what component of your NetWorker for Windows NT Power
Edition server you want the Performance Monitor to track from the Object
drop-down list. The Object choice you make determines the Counter and
Instance choices available to you.

5. Select a choice from the Counter list box. Click Explain to view
descriptions of each counter.

6. Select a choice from the Instances list box.

7. Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor.

8. Repeat Steps 4-7 for each component on the Power Edition server whose
performance you want to test. Each component is listed separately under
the Power Edition server’s name in the Performance Monitor window.

9. Click Done when you have completed adding all the Power Edition server
component you want to test.

10. Start a backup and view or capture the results.

You can save the performance monitoring information in log form by placing
the Performance Monitor in Log mode and selecting Options from the Log
menu.

Later in this chapter you will use the Performance Monitor to test and evaluate
specific areas of your NetWorker for Windows NT Power Edition server.

To test the maximum performance of Power Edition, shut down all extraneous
processes, and run just the necessary software on your Power Edition server.

How to Test a Power Edition Server from Another Computer

Because the Performance Monitor uses system resources, you might want to
run the Performance Monitor on a different Windows NT computer on the
network during controlled tests of your Power Edition server.

When you run the Performance Monitor on a different Windows NT system,
the Performance Monitor still uses some resources on the Power Edition
system. It especially adds to network traffic during remote backup. But the
performance of the processor and SCSI throughput on the Power Edition
system are not affected.
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To test the performance on one or more Power Edition servers from another
Windows NT computer, follow these steps:

1.

10.

11.

12.

Select Start>Programs>Administrative Tools>Performance Monitor on
the monitoring Windows NT computer to open the Performance Monitor
window on that computer.

Select Report from the View menu.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.

. Enter the name of the Power Edition server you want to test in the

Computer text box, either by entering it directly or by clicking the “...”
button that allows you to browse to the appropriate Power Edition server.

. Select a choice from the Object drop-down list. The Object choice you

make determines the Counter and Instance choices available to you.

Select a choice from the Counter list box. Click Explain to view
descriptions of each counter.

Select a choice from the Instances list box.

. Click Add when you complete all your choices. The Performance Monitor

window now reflects the Power Edition server and the component whose
performance you want to monitor.

. Repeat Steps 5-8 for each component on the Power Edition server whose

performance you want to test. Each component is listed separately under
the Power Edition server’s name in the Performance Monitor window.

Repeat Steps 4-8 if you want to monitor the performance of any other
Power Edition servers (or any other Windows NT computers in general).

Click Done when you have completed adding all the Power Edition server
components you want to test.

Start a backup and view or capture the results.

You can save, add to, and redirect the performance monitoring information
you receive from this procedure. For more detailed information about the
Performance Monitor and Windows NT, refer to your Windows NT operating
system documentation.
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Physical Disk

This section describes using the Windows NT Performance Monitor to test and
evaluate physical disk performance problems related to your NetWorker for
Windows NT Power Edition server. For a general discussion of disk-related
performance problems and solutions, see “Physical Disks” on page 28.
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How to Test Disk Performance

To test the disk performance of your NetWorker for Windows NT Power
Edition server using the Windows NT Performance Monitor, follow these
steps:

1.

7.

Select Start>Programs>Administrative Tools>Performance Monitor to
open the Performance Monitor window.

Select Report from the View menu.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.

Select Physical Disk from the Object drop-down list.

. Select the following counters from the Counter list box:

— % Disk Time
—  Current Disk Queue Length

Click Explain to view details on each counter.

You can select multiple items in the Counter list box by holding down the
[Shift] or [Ctr]] key while selecting each item.

If your Power Edition server has more than one physical disk, select these
counters for each disk.

Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor. Click Done.

Start a backup and view or capture the results.

Note: If the disk performance counters do not work, you must instruct
Windows NT to turn them on. Open an MS-DOS window and enter the
following Windows NT command at the prompt:

di skperf -y

You must restart your Power Edition server after using this command in order
to turn on the counters.
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Disk Performance Evaluation Methods

Use the values gathered from your performance testing as follows to
determine if your Power Edition server has a disk-related blockage.

If the value for the Percent Disk Time counter exceeds 90 percent:

This counter measures the percentage of operating time your disk is
occupied with read or write requests.

If the value for the Disk Queue Length counter exceeds 2:

This counter measures the average number of read or write requests that
were waiting to be serviced during the sampling interval.

Disk Tuning Methods

The methods for tuning disk performance in your NetWorker for Windows NT
Power Edition server is the same for tuning computer disks in general,
including the following:

Memory

Defragment files to reduce the number of disk seeks.
Use larger files or fewer files to reduce the number of disk seeks.

Change to a faster SCSI adapter, with synchronous I/O support and bus
mastering.

Use stripe sets on multiple disks to accommodate large files and
databases, so the physical disks can work in parallel to read data.

Spread disk-intensive programs onto different servers.

Purchase disks with higher transfer rates.

This section describes using the Windows NT Performance Monitor to test and
evaluate memory-related performance problems related to your NetWorker
for Windows NT Power Edition server. For a general discussion of memory-
related performance problems and solutions, see “Memory” on page 33.

How to Test Memory Performance

To test the memory-related performance of your Power Edition server, follow
these steps:

1. Select Start>Programs>Administrative Tools>Performance Monitor to

open the Performance Monitor window.

2. Select Report from the View menu.
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7.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.

Select Memory from the Object drop-down list.

. Select the following counters from the Counter list box:

— Available Bytes

- DPages/sec

- Committed Bytes

— Commit Limit

Click Explain to view details on each counter.

You can select multiple items in the Counters list box by holding down the
[Shift] or [Ctrl] key while selecting each item.

Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor. Click Done.

Start a backup and view or capture the results.

To learn more about the Windows NT Performance Monitor, see “How to Start
the Windows NT Performance Monitor” on page 51.

Memory Performance Evaluation Methods

Use the values gathered from your performance testing as follows to
determine if your Power Edition server has a memory-related blockage:

If the value for Available Bytes is less than 4 MB:

This counter measures how much memory is not already occupied. The
smaller the value of Available Bytes, the slower your performance.

If the value for Pages/sec is greater than 20:

This counter measures virtual memory activity; that is, how often the
memory writes to disk. When your computer is memory-bound, it pages
to the virtual memory on disk more often.

If the value for Committed Bytes is greater than the amount of physical
memory on your computer.

This counter is the total memory of all applications in use at the moment.
Applications generally reserve more memory than they use during
regular operation. But an application does not write data to memory
without committing the memory first. So the value for Committed Bytes
shows the amount of memory the applications currently need.
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If more memory is committed than you have physical memory to
accommodate, your computer pages memory contents to disk (virtual
memory), and your computer works more slowly, because physical
memory is faster than virtual memory.

e If the value for Committed Bytes consistently exceeds the value for
Commit Limit

The Commit Limit counter is the size of virtual memory that can be
committed without having to extend the paging file. Every time Windows
NT extends the paging file, it goes to disk and searches for more space to
use for virtual memory. This process has a high performance cost, and you
might run out of disk space.

How to Tune Memory Performance in Windows NT

The following section explains how to tune memory performance on your
NetWorker for Windows NT Power Edition server.

Virtual Memory

To adjust the allocated size of virtual memory on your Power Edition server,
follow these steps:

1. Select Start>Settings>Control Panel to open the Control Panel window.
2. Double-click the System icon to open the System Properties dialog box.
3. Click the Performance tab to make it active.

4. Click Change to open the Virtual Memory dialog box.

5

. Change the size and location of the disk space allocated to virtual memory
to meet your needs. Click OK.

To determine a good baseline size for the virtual memory file (pagefile.sys), log
the Committed Bytes counter over a period of time, add 10 to 20 percent to the
maximum value, and enter that value in the Initial Size (MB) text box in the
Virtual Memory dialog box.

Physical Memory Allocation

To adjust physical memory allocation on your Power Edition server, follow
these steps:

1. Select Start>Settings>Control Panel to open the Control Panel window.
2. Double-click the Network icon to open the Network dialog box.

3. Click the Services tab to make it active.
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4. Select Server from the Network Services list box.
5. Click Properties to open the Server dialog box.
6. Select one of the following options:

- Minimize Memory Used: Use when the server has fewer than 10
users, for example, Power Edition local backup.

— Balance: Use when the server has 10 to 64 users.

- Maximize Throughput for File Sharing: Allocate most of the memory
to the file server module, for systems with more than 64 users.

- Maximize Throughput for Network Application: Use for a client-
server application server, such as a NetWorker server with remote
clients.

7. Click OK.

Memory-Related Server Tuning Methods

To speed up virtual memory, you can implement the disk recommendations in
“Disk Tuning Methods” on page 55. You can also defragment the disks where
pagefile.sys resides. It is not recommended to put pagefile.sys on a stripe set,
because virtual memory is less efficient when it is fragmented. It is also not
recommended to put pagefile.sys on a mirrored drive, because every write is
done twice, which slows down writes to virtual memory.

You can also reduce the memory your Power Edition server uses. Suggestions
to reduce memory requirements include the following:

¢ Reduce the number of other applications that run on the Power Edition
server. Dedicate your Power Edition server to run the database server,
NetWorker client, BusinesSuite Module client, and Power Edition server.

* Stop services that you do not use. For example, if you have only SCSI
devices, stop the ATDISK service, which is for IDE devices only.

* Remove communications protocols you do not use. For example, if you
only use TCP/IP but you also have SPX installed, remove SPX.
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CPU

The following sections address testing and tuning issues for your NetWorker
for Windows NT Power Edition server CPU(s). For a general discussion of
how CPU issues affect Power Edition performance, see “CPU” on page 33.

How to Test CPU Performance

You can determine your NetWorker for Windows NT Power Edition server’s
CPU performance by total CPU utilization and by CPU utilization for each
individual process.

Total CPU Utilization

To test total CPU utilization of your NetWorker for Windows NT Power
Edition server during backup, follow these steps:

1.

8.

Select Start>Programs>Administrative Tools>Performance Monitor to
open the Performance Monitor window.

Select Report from the View menu.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.

Select Processor from the Object drop-down list.

. Select % Processor Time from the Counter list box. Click Explain to view

details on this counter.

Select the processors you want to test from the Instance list box if your
Power Edition server has more than one processor.

You can select multiple items in the Instance list box by holding down the
[Shift] or [Ctr]] key while selecting each item.

Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor. Click Done.

Start a backup and view or capture the results.

To learn more about the Windows NT Performance Monitor, see “How to Start
the Windows NT Performance Monitor” on page 51.
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CPU Performance by Process

You can also test CPU utilization for each process involved in the backup, to
determine which processes use most of the CPU capacity. The processes
involved in a Power Edition backup are the following:

NetWorker services

— nsrd: Server process

- nsrexecd: Client process

— nsrindexd: Client file index process

- nsrmmd: Device process

- nsrmmdbd: Media database process

save: The NetWorker backup program
Application-specific services, such as for a database server

To test total CPU utilization of your NetWorker for Windows NT Power
Edition server during backup, follow these steps:

1.

Select Start>Programs>Administrative Tools>Performance Monitor to
open the Performance Monitor window.

Select Report from the View menu.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.

Select Process from the Object drop-down list.

. Select the % Processor Time from the Counter list box. Click Explain to

view details on this counter.

Select the individual services, programs, or other processes you want to
test from the Instance list box.

You can select multiple items in the Instance list box by holding down the
[Shift] or [Ctr]] key while selecting each item.

Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor. Click Done.

. Start a backup and view or capture the results.
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CPU Performance Evaluation Methods

You know you have a CPU blockage if total CPU utilization remains above
90% for long periods during the backup process.

Server Input/Output

The following sections address testing and tuning issues for theNetWorker for
Windows NT Power Edition server input/output (I/O). For a general
discussion of how I/0 issues affect Power Edition performance, see “Server
Input/Output” on page 34.

How to Test Input/Output Performance

To test the I/O of your NetWorker for Windows NT Power Edition server most
effectively, you must start and configure the Windows NT Performance
Monitor, and then run specific NetWorker I/O-related tests. These tests are
detailed in the chapter of this guide covering general performance guidelines.

To start and configure the Windows NT Performance Monitor to test your
NetWorker for Windows NT Power Edition server I/O, follow these steps:

1.

Select Start>Programs>Administrative Tools>Performance Monitor to
open the Performance Monitor window.

Select Report from the View menu.

. Select Add To Report from the Edit menu to open the Add to Report dialog

box.
Select System from the Object drop-down list.

Select File Write Bytes/sec from the Counter list box. Click Explain to view
details on this counter.

Click Add when you complete all your choices. The Performance Monitor
window now reflects your Power Edition server and the component
whose performance you want to monitor. Click Done.

Run the following tests, and view or capture the results:

— uasm: See “Disk Read Speed Testing Methods” on page 29.

- mt: See “Device Performance Without Running NetWorker” on
page 39.

— bigasm: See “Device Performance While Running NetWorker” on
page 41.
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How to Tune Input/Output Performance

The rate at which a SCSI device can write data to media is limited by the
amount of data that transfers over the SCSI bus in a single I/O operation. To
tune SCSI performance, change the number of memory pages the SCSI host
bus adapter (HBA) can scatter/gather in a single direct memory access (DMA).
In Windows NT, the number of bytes that can be transferred in a single SCSI
I/Ois limited by the number of memory pages that the SCSI host bus adapter
can scatter/gather in a single DMA.

Each vendor’s SCSI driver specifies the maximum number of pages that the
HBA can scatter/gather for the DMA transfer. When you multiply the page
size by the number of scatter/gather entries, the product is the effective limit
to the number of bytes that can be transmitted in a single I/O operation.

The equation is the following;:
I/0 operation size = Page size * (# of scatter/gather entries -1)
User memory is not necessarily page-aligned; therefore:
If MaximumSGList = 255 then the I/O transfer size is 4K * 254 = 1016K.

For the drivers of some SCSI host adapters, you can change the maximum
number of scatter/gather pages. Many tape drives and disk drives perform
better with a larger I/O limit. A change in the number of scatter/ gather pages
can make a large performance difference. For example:

¢ The Ampex DST tape drive writes only 3 MB per second with 64 KB SCSI
transfers and 20 MB per second with 992 KB SCSI transfers.

e The SCSI disk “CYBERNET 10XP” reads 1.7 MB per second with a 32 KB
read buffer size and 17 MB per second with a 200 KB read buffer size.

To change the maximum scatter/gather pages setting in the Windows NT
Registry, add the following new Registry subkey to specify the maximum
number of scatter/gather list elements for each device on a given bus:

HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Services\
DriverName\Parameters\ Device number\MaximumSGList

A

Important: Modifying the Registry is very dangerous. Do not attempt to
modify the Registry unless you have an up-to-date backup of the Registry to
which you can revert and you are convinced that the modification you are
about to make is correct. Inappropriate changes to the Registry can result in
the need to re-install Windows NT.
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To add the subkey entry to the Windows NT Registry, follow these steps:

1. Start the Windows NT Registry Editor program by selecting Start>Run
and entering the following value in the Open text box and pressing
[Enter]:

regedt 32
You can also open this program at the following location:
% SystemRoot %\ Winnt\ System32\ regest32.exe
2. Select Window>HKEY_LOCAL_MACHINE to make that window active.

3. Expand the following folders within the directory tree of the
HKEY_LOCAL_MACHINE window to display their contents:

SYSTEMN\ CurrentControlSet\Services

4. Select the appropriate driver for your SCSI controller; for example,
AIC78xx for Adaptec’s 294x/394x series.

5. Select Edit>Subkey to open the Add Key dialog box.

6. Enter the name of the miniport driver in the Key Name text box and click
OK. The name of the miniport driver now appears as a subkey to the
Services folder.

7. Select the newly added miniport driver entry in the
HKEY_LOCAL_MACHINE window and repeat Step 6 for each of the
following subkey terms in sequence:

— Parameters

—  Device number (where number is the bus number assigned at
initialization)

-  MaximumSGList

When completed, these terms form the following path:

HKEY_LOCAL_MACHI NE\ Cur r ent Cont r ol Set\ Ser vi ces\ Dri veNane\
Par anet er s\ Devi ce nunber\ Maxi nunBSGL.i st

Remember that both “DriveName” and the number for the “Device”
entries are variables whose values you must determine.

If a value is defined for MaximumSGList in this subkey when the device
initializes, the SCSI port driver uses MaximumSGList as the initial value
for NumberOfPhysicalBreaks. The miniport driver can set
NumberOfPhysicalBreaks to a lower value, if appropriate. The maximum
value for MaximumSGList is 255, but you should use this adjustment
sparingly because scatter/gather lists consume non-paged memory.
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8. Restart your Power Edition server.
9. Open an MS-DOS window and enter the following command at the
prompt:
n -f \\.\TapeO stat
Entering this command displays the new value for maximum block size.
Other suggestions for tuning I/O performance are as follows:
* Move the hardware configuration around; for example, move some disks

off a SCSI bus that is overloaded.

e If possible, use PCI adapters in your Power Edition server. If you must
use other adapters, EISA adapters are better than ISA adapters, because
ISA adapters have bus contention problems that degrade system
performance.

¢ Use a dual PCI backplane system, rather than a bridged PCI backplane.

e Use multiple SCSI buses with devices of the same type (for example,
UltraSCSI) on the same bus.

* Use short, high-quality cables with active terminators.

e Ensure that SCSI communications are occurring synchronously, not
asynchronously.

The following sections address testing and tuning issues for the Power Edition
backup devices within the Windows NT environment. For a general
discussion of how device issues affect Power Edition performance, see
“Backup Devices” on page 38.

How to Test Device Performance

To test device input/output, see the bigasm module test described in “How to
Test Input/Output Performance” on page 61.

How to Tune Device Performance
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Most tape drives come with hardware data compression enabled by default.

When compression is enabled, device performance and media capacity can
double.

Hardware data compression is controlled by the NSR_NO_HW_COMPRESS
environment variable. When you set this environment variable to “Yes,” data
is not compressed by the hardware before it is written to media.
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Note: For data that is already compressed before it reaches the device,
however, additional compression might actually increase the size of the data.
If the data comes to the device already compressed, you might want to disable
compression on the storage device.

To tune the hardware compression system variable, follow these steps:

1.

2
3.
4

Select Start>Settings>Control Panel to open the Control Panel window.

. Double-click the System icon to open the System Properties dialog box.

Select the Environment tab to make it active.

. Review the variables and values listed in the System Variables list box.

Depending on whether the NSR_NO_HW_COMPRESS variable already
exists or not, follow the appropriate step:

If the NSR_NO_HW_COMPRESS variable is already listed, and you
simply want to change its value, select it. The variable name and its
value appear in the Variable and Value text boxes. Change its value to
“yes” and click Set to confirm the change. The
NSR_NO_HW_COMPRESS variable’s updated value is now
reflected in the System Variables list box.

If the NSR_NO_HW_COMPRESS variable is not listed, you need to
create it. Select any variable so that its name and value are displayed
in the Variable and Value text boxes. Change the existing variable
name to “NSR_NO_HW_COMPRESS,” enter the value “yes,” and
and click Set to confirm the new variable.

When you change the name of an existing variable, Windows NT
treats it as a new variable and does not overwrite or delete the
original variable. The new variable and its value is now reflected in
the System Variables list box, and the original one you selected
remains unchanged.

5. Click OK when you have completed adding or modifying the
NSR_NO_HW_COMPRESS variable and/or its value.

6. Restart your NetWorker for Windows NT Power Edition server.

To see the device compression setting, open an MS-DOS window and enter the
following at the prompt:

n -f \\.\TapeO stat

In the output of a device with compression enabled, you see a line that says the
following:

Conpr ess Enabl ed
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The following variables affect the overall Windows NT operating system
performance and the speed of backup:
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Filesystem overhead

Filesystem input/output (I/O) can degrade I/O performance. If you
integrate logical volume managers with the filesystem, you can increase
disk performance and add a host of other features to improve
manageability of large filesystems. Also, depending on the level of RAID
(Redundant Array of Independent Disks) you implement, RAID can
improve or adversely affect backup performance.

Server memory usage setting

You can set Windows NT server memory use to be optimized for a small
number of clients, a large number of clients, a file server, or a domain
controller. See “Physical Memory Allocation” on page 57 for more
information.

Page file size

You can adjust the size and location of the virtual memory file (pagefile.sys)
on your local disks. See “How to Tune Memory Performance in Windows
NT” on page 57 for more information.
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This glossary contains terms and definitions found in this manual. Most of the
terms are specific to NetWorker products.

1-9
active group

Administrators

group

annotation

Application Specific
Module (ASM)

archive

See level [1-9].
A group with its autostart attribute enabled.

A Windows NT user group whose members have
all the rights and abilities of users in other groups,
plus the ability to create and manage all the users
and groups in the domain. Only members of the
Administrators group can modify Windows NT
OS files, maintain the built-in groups, and grant
additional rights to groups.

A comment that you associate with an archive
save set, to help identify that data later on.
Annotations are stored in the media index for ease
of searching and are limited to 1024 characters.

A program that, when used in a directive,
specifies the way that a set of files or directories is
to be backed up and recovered.

The process by which NetWorker backs up
directories or files to an archive volume and then
optionally deletes them to free up disk space.
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archive clone pool

archive pool

archive volume

ASM

attribute

auto media
management

autochanger

backup cycle

backup group

Glossary
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A volume pool composed exclusively of archive
clone save sets.

A volume pool composed exclusively of archive
save sets.

A tape or other storage medium used for
NetWorker archives, as opposed to a backup
volume.

See Application Specific Module (ASM).

A property of a resource, shown in the graphical
user interface as an entry field, push button, or a
list from which you select. See also resource.

A feature that enables NetWorker to automatically
label, mount, and overwrite a volume it considers
unlabeled. NetWorker also automatically recycles
volumes eligible for reuse.

A mechanism that uses a robotic arm to move
media among various components located in a
device, including slots, media drives, media
access ports, and transports. Autochangers
automate media loading and mounting functions
during backups and recovers. The term
“autochanger” refers to a variety of backup
devices, including jukebox, carousel, library, near-
line storage, datawheel, and autoloader.

The period of time from one level full backup to
the next level full backup.

A group of NetWorker clients that begin their
scheduled backups at the same time.
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backup levels

backup volume

benchmarking

Backup Operators
group

bootstrap

bottleneck

browse policy

carousel

client

Backup settings that determine how much data
NetWorker saves during a scheduled or manual
backup. The backup levels are:

full - backs up all files, regardless of whether they
have changed.

levels 1-9 - back up files that have changed since
the last lower numbered backup level.
incremental (incr) - backs up only files that have
changed since the most recent backup.

Backup media, such as magnetic tape or optical
disk.

Tests in a controlled environment to measure the
performance of a product as it performs specific
tasks.

A Windows NT group whose members have the
capability of logging on to a domain from a
workstation or a server, backing it up, and
restoring the data. Backup Operators also can shut
down servers or workstations.

Information that includes the server index, media
index, and configuration files needed for
recovering NetWorker after a disk crash.

The slowest point in a system, which restricts the
system from operating any faster.

A policy that determines how long entries for
your backup data remain in the client file index.

A tray or tape cartridge that holds multiple
backup volumes.

A computer that accesses the NetWorker server to
back up or recover files. Clients may be
workstations, PCs, or fileservers.
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client file index

clone

clone volume

command line
interface

compressasm

database

device

directed recover

directive

enabler codes

file index

A database of information maintained by the
NetWorker server that tracks every file or
filesystem backed up. The NetWorker server
maintains a single client index file for each client
computer.

The process by which NetWorker makes an exact
copy of saved data (save sets). NetWorker can
clone individual save sets or the entire contents of
a backup volume.

A duplicated volume. NetWorker can track four
types of volumes: backup, archive, backup clone,
and archive clone. Save sets of different types may
not be intermixed on one volume.

An interface with the NetWorker software, based
on command text entered from the shell prompt.
See also shell prompt.

A NetWorker directive used for compressing and
decompressing files.

A collection of related data that can serve multiple
purposes and support multiple users.

The backup device (tape drive, optical drive, or
autochanger) connected to the NetWorker server;
used for backing up and recovering client files.

A method of recovery that recovers data and re-
creates it, either on the machine where the backup
originated, or on the machine where the
administrator requests the directed recover.

An instruction directing NetWorker to take special
actions on a given set of files.

Special codes provided by Legato that allow you
to run your NetWorker software product.

A database of information maintained by
NetWorker that tracks every file or filesystem
backed up.
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fileserver

filesystem

full ()

grooming

group

heterogeneous
network

immediate save

incremental (i)

interoperability

level [1-9]

manual backup

media

A computer with disks that provides services to
other computers on the network.

1. A file tree is on a specific disk partition or other
mount point (for example, the C: drive). 2. The
entire set of all files. 3. A method of storing files.

A backup level in which all files are backed up,
regardless of when they last changed.

The process of removing files after a successful
archive.

A client or group of clients that starts backing up
files at a designated time.

Networks with systems of different platforms that
interact meaningfully across the network.

A technology employed in NetWorker that makes
the local backup process faster. Data is transferred
in memory instead of through a networking
protocol.

A backup level in which only files that have
changed since the last backup are backed up.

The ability of software and hardware on multiple
machines from multiple vendors to communicate
meaningfully.

A backup level that backs up files that have
changed since the last backup of any lower level.

A type of backup that a user requests from the
client’s save program. The user specifies
participating files, filesystems, and directories. A
manual backup does not generate a bootstrap save
set.

Magnetic tape or optical disks used to back up
files.
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media database

media manager

multiplexing

NetWorker

NetWorker client

NetWorker server

notice

notification

nsrhost

online indexes

operator

override

A database of information maintained by
NetWorker that tracks every backup volume.

The NetWorker component that tracks save sets to
backup volumes.

A NetWorker feature that permits data from more
than one save set to be interleaved and then
written to one storage volume.

The Legato network-based software product for
backing up and recovering filesystems.

A computer that can access the backup and
recover services from a NetWorker server.

The computer on a network running the

NetWorker software, containing the online
indexes and providing backup and recover
services to the clients on the same network.

A response to a NetWorker event.

A message generated by the NetWorker server to
alert the administrator when the NetWorker
server needs attention, for example, to clean a
device or mount a tape.

The logical hostname of the computer that is the
NetWorker server.

The databases located on the server that contain
all the information pertaining to the client
backups and backup volumes.

The person who monitors the server status, loads
backup volumes into the server devices, and
otherwise executes day-to-day tasks using
NetWorker.

A backup level that takes place instead of the
scheduled one.
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parallelism

pathname

performance

pool

preconfigured

print

qic

recover

recovery

recycle

A NetWorker feature that enables the NetWorker
server to back up save sets from several clients, or
many save sets from one client, at the same time.
Parallelism is also available during recovers.

Instructions for accessing a file. An absolute
pathname tells you how to find a file beginning at
the root directory and working down the
directory tree. A relative pathname tells you how to
find the file starting where you are now.

The speed and efficiency with which an operation
is performed.

A feature that allows the NetWorker
administrator to sort backup data to selected
volumes. A volume pool contains a collection of
backup volumes to which specific data has been
backed up.

Existing selections or configurations for different
NetWorker features.

To send data to a printer.

A choice in the Devices window; represents
quarter-inch cartridge tape.

The NetWorker command used to browse the
server index and recover files from a backup
volume to a client’s disk.

A method that recreates an image of the client
filesystems and database on the NetWorker server
machine.

A volume whose data has passed both its browse
and retention policies and is available for
relabeling.
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Registry

resource

retention policy

retrieval

save

save group

save set

save set ID

save set recover

save set status

savestream

A database of configuration information central to
Windows NT operations. The overall effect
centralizes all Windows NT settings and provides
security and control over system, security, and
user account settings.

An entity that describes a NetWorker server state.
In the NetWorker administration program,
resources are represented as windows or dialog
boxes that contain attributes, which you can use to
view or set features of NetWorker. See also
attribute.

A NetWorker policy that determines how long
entries will be retained in the media database and
thus be recoverable.

The process of locating and copying back files and
directories that NetWorker has archived.

The NetWorker command that backs up client
files to backup volumes and makes data entries in
the online index.

A group of backup clients sharing the same save
characteristics.

A set of files or a filesystem backed up onto
backup media using NetWorker.

An internal identification number that NetWorker
assigns to a save set.

The recovery of specified save sets to the
NetWorker server.

An indication of whether a given save set is
restorable, recoverable, or recyclable. The save set
status also indicates whether or not the save set
has been successfully backed up.

The data and save set information being written to
a storage volume during a backup. A savestream
originates from a single save set.
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scanner

server

service

shell prompt

silo

skip (s)

stand-alone device

storage device

system administrator

user

versions

volume

The NetWorker command used to read a backup
volume when the online indexes are no longer
available.

The computer on a network running the
NetWorker software, containing the online
indexes and providing backup and recover
services to the clients on a network.

A program that is not invoked explicitly, but lies
dormant waiting for a specified condition(s) to
occur.

A cue for input in a shell window where you enter
a command. See also command line interface.

A storage peripheral that can hold hundreds or
thousands of volumes. Silo volumes are identified
by barcodes, not by slot numbers. The robotics in
a silo are controlled by silo management software
on a silo server machine.

A backup level in which files are skipped and not
backed up.

A storage device that contains a single drive for
backing up data.

The hardware that reads and writes data during
backup, recover, or other NetWorker operations.

The person normally responsible for installing,
configuring, and maintaining NetWorker and the
system software.

A person who can use NetWorker from his or her
workstation to back up and recover files.

The date-stamped collection of available backups
for any single file.

Backup media, such as magnetic tape or optical
disk.
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volume ID

volume name

volume pool

The internal identification assigned to a backup
volume by NetWorker.

The name you assign to a backup volume when it
is labeled.

A feature that allows you to sort backup data to
selected volumes. A volume pool contains a
collection of backup volumes to which specific
data has been backed up.
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