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Preface

This manual describes how to use the SunForum™ 3D software for optimized
collaboration of Sun OpenGL® for Solaris applications between systems. It is also for
users who want to collaborate over intranets and the internet with both UNIX® and
PC-based participants through data conferencing.

How This Book Is Organized
Chapter 1 provides an overview of the SunForum 3D software.

Chapter 2 describes how to use the SunForum 3D product, including audio and
video features and the SunForum 3D Whiteboard.

Chapter 3 describes the SunForum 3D application sharing controls.

Chapter 4 describes the SunForum 3D phone feature.

Chapter 5 describes the SunForum 3D gateway access.

Chapter 6 describes using SunForum 3D on a Sun Ray™ system.

Chapter 7 provides technical information about the SunForum 3D software.
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Using UNIX Commands
This document does not contain information on basic UNIX commands and
procedures such as shutting down the system, booting the system, and configuring
devices.

See one or more of the following for this information:

■ Solaris Handbook for Sun Peripherals

■ AnswerBook2™ online documentation for the Solaris™ 2.x operating
environment

■ Other software documentation that you received with your system

Typographic Conventions

Typeface Meaning Examples

AaBbCc123 The names of commands, files,
and directories; on-screen
computer output.

Edit your .login file.
Use ls -a to list all files.
% You have mail.

AaBbCc123 What you type, when
contrasted with on-screen
computer output.

% su
Password:

AaBbCc123 Book titles, new words, or
terms; words to be emphasized;
command-line variable: replace
with a real name or value.

Read Chapter 6 in the User’s Guide.
These are called class options.
You must be root to do this.
To delete a file, type rm filename.
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Shell Prompts

Accessing Sun Documentation
You can view, print, or purchase a broad selection of Sun documentation, including
localized versions, at:

http://www.sun.com/documentation

Contacting Sun Technical Support
If you have technical questions about this product that are not answered in this
document, go to:

http://www.sun.com/service/contacting

Shell Prompt

C shell %

C shell superuser #

Bourne shell and Korn shell $

Bourne shell and Korn shell
superuser

#
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Sun Welcomes Your Comments
Sun is interested in improving its documentation and welcomes your comments and
suggestions. You can submit your comments by going to:

http://www.sun.com/hwdocs/feedback

Please include the title and part number of your document with your feedback:

SunForum 3D Software User’s Guide, part number 817-2668-10.
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CHAPTER 1

Introduction to SunForum 3D

SunForum 3D software is a conferencing product for Sun computer systems which
uses SunForum technology. SunForum technology is based on the T.120 and H.323
standards which enables your Sun system to conference over intranets and the
Internet with other T.120 and H.323 products.

SunForum 3D provides users with high performance (accelerated) sharing of 3D
OpenGL applications. The SunForum 3D conference manager contains controls for
the accelerated sharing of 3D applications.

SunForum 3D will interoperate with earlier versions of SunForum as well as
other H.323/T.120 based conferencing applications, but accelerated sharing will
be available only from a SunForum 3D host sharing the application to the
SunForum 3D participant(s) in the conference.

■ SunForum 3D Features
■ Notes on Using SunForum 3D
■ Online Help

SunForum 3D Features
SunForum 3D software features include:

■ Highly optimized application sharing and collaboration of OpenGL based 3D
graphics applications

■ Viewing and controlling applications shared from other UNIX or PC machines
that are based on the T.120 protocol

■ Sharing local Solaris applications, which can be viewed and controlled by any
conference participant

■ Exchanging ideas and data using the whiteboard, clipboard, chat, and file transfer
facilities
1



■ Using audio and video communications through the H.323 protocol

Other features include:

■ DTMF tone generation, in-band and out-of-band through H.245 protocol

■ Testing and workarounds for ambiguously specified Voice-over IP (VoIP) and
H.323 equipment

■ SunForum 3D phone GUI

■ Ability to automatically place calls through a gateway

■ Sun Gatekeeper

■ Lightweight Directory Access Protocol (LDAP) server configuration tool

■ G.729a audio encoding

Notes on Using SunForum 3D
■ Accelerated sharing is available only between the SunForum 3D nodes in a

conference. Non-SunForum 3D nodes in the conference will see a static image for
the shared OpenGL application when 3D sharing is enabled.

■ SunForum 3D (on the remote/client) side needs a 24-bit visual for accelerated
sharing; that is, the Xserver must be running in the 24-bit or (8+24)-bit mode.

■ Sun Ray systems cannot be SunForum 3D hosts.

■ SunForum 3D needs to be running in the T.120 compatibility mode,
(Options ➤ Tool Settings ➤ Compatibility mode).

■ For better performance of video displays, increase the shared memory pool size to
at least 16 Mbytes and the maximum number of per process shared memory
segments to at least 32. (See the SunForum 3D Software Installation Guide, 817-2669,
for details.)

To find whether the system requirements, or the above requirements, are met, run
the following:

/opt/SUNWdat/bin/sunforum -check3d
2 SunForum 3D Software User’s Guide • July 2003



Online Help
You can read information about the SunForum 3D software online by accessing help
from the Help menu located on the SunForum 3D conference manager menu bar.
Chapter 1 Introduction to SunForum 3D 3
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CHAPTER 2

Using SunForum 3D

This chapter contains the following topics:

■ SunForum 3D Basics
■ Using Directories
■ Making Calls and Sharing Applications
■ Using the SunForum 3D Audio and Video
■ Using the SunForum 3D Whiteboard

See Chapter 3, SunForum 3D Controls, for SunForum 3D application sharing control
features.

SunForum 3D Basics

▼ To Start the SunForum 3D Software
1. After installing SunForum 3D software packages, type the following at your

system prompt:

Note – If the SunForum 3D directory is not set in your path, type the full path name
(for example, /opt/SUNWdat/bin/sunforum).

Note – Type sunforum -help to see available options.

% sunforum
5



The SunForum 3D conference manager is displayed. When you start SunForum 3D
for the first time, however, the My Information window is displayed (FIGURE 2-1).

FIGURE 2-1 My Information Window

2. Type your name and email address in the My Information window.

Note – You must type your name and email address. You cannot collaborate unless
this minimum information is entered.

The SunForum Name and the SunForum Number are two items which other users
can use when placing calls to you when the respective instances of SunForum are
registered with a gatekeeper. There is complete freedom in choosing these, but they
should be consistent within an organization, and meaningful. For example, the
SunForum Name could be the email address, or the user name, or a combination of
last name and first name, while the SunForum Number could be the telephone
number or employee ID.
6 SunForum 3D Software User’s Guide • July 2003



The next time you start the SunForum 3D software, the My Information window will
not display automatically. However, you can change the information in the My
Information window anytime by choosing Call ➤ Change My Information to open
the information window.

When completing the My Information window, the Configuration Wizard window is
displayed for configuring audio/video.

When complete, the SunForum 3D conference manager is displayed as the active
window (FIGURE 2-2).

FIGURE 2-2 SunForum 3D Conference Manager
Chapter 2 Using SunForum 3D 7



SunForum 3D Menus
There are five menus on the SunForum 3D menu bar: Call, View, Tools, Options, and
Help.

Note – You can also use the SunForum 3D conference manager buttons to access
most of the functions in the Call, View, and Tools menus. See “Making Calls and
Sharing Applications” for more information.

Call Menu

TABLE 2-1 Call Menu

Menu Description

Place Call Places a call to an indicated address. You can also click the Call
button.

Stop Placing Call Cancels an in-progress call request.

Host Conference Starts a conference.

Hang Up Ends your call. (Same as clicking the Hang Up button.)

Do Not Disturb Blocks incoming calls. You may, however, call out.

Create SpeedDial Creates speed dial files for use in your address book or for
exchange with other users.

Run In Background Allows SunForum 3D to continue running in the background
when you exit.

Log On To Directory Server Logs in to a directory server. You are prompted for the server
name.

Change My Information Makes changes to your profile information.

Address listing Calls recently accessed addresses.

Exit Exits or places in background the current SunForum 3D session.
8 SunForum 3D Software User’s Guide • July 2003



View Menu
Use the View buttons to change these items viewed in the SunForum 3D conference
manager.

Note – To remove an item from the Address Book and History lists, select the item
and press the Delete key.

Tools Menu

TABLE 2-2 View Menu

Menu Item Description

Compact View Turns the Conference Manager into menu bar.

Always On Top Causes the Conference Manager window to always be on top.

Directory Views the directory server. It lists who you can conference with.

Address Book Displays addresses that you have conferenced with and added to
your address book.

Call Status Used during a call to view the status of conference participants and
the status of the application sharing, whiteboard, and chatting
features.

History Lists the status of received calls.

Refresh Directory Queries the directory server for an immediate update of the
directory listings.

Call Information Views audio/video bandwidth usage in the current call.

TABLE 2-3 Tools Menu

Menu Item Description

Switch Audio and
Video

Switches audio and video to another participant. Present only while
in a conference.

Video Selects video windows to be displayed.

Configuration
Wizard

Starts the Configuration Wizard program.

Share Application Shares your applications with others on the call. A submenu lists
the shareable applications you have running on your desktop.
Chapter 2 Using SunForum 3D 9



Note – When you have allowed collaboration and someone else in the conference
takes control, you cannot use your mouse or your keyboard. Pressing a key or a
mouse button will cause you to regain control of the application. Pressing the Esc
(escape) key, will cause regaining control and ending the collaboration.

Options Menu

Share Selects an application window on your desktop for sharing. (Same
as clicking the Share button.)

Unshare Unshares the application. (Same as clicking the Unshare button.)

Collaborate Shifts a shared application from view-only to collaborate. When you
collaborate an application, you enable others to take control of the
application. (Same as clicking the Collaborate button.)

Send File Selects a file to send to everyone in the conference. (Same as
clicking the Send button.)

Cancel All Sends Cancels sending of files.

Cancel All Receives Cancels receipt of files.

Shared Desktop
Viewer

Shows an overview of all user desktops and the location of shared
applications.

Whiteboard Starts the whiteboard graphical application. The whiteboard
automatically starts on other user systems in the conference. (Same
as clicking the Whiteboard button.)

Chat Starts the chat application. The chat window automatically starts on
other user systems in the conference. (Same as clicking the Chat
button.)

Share Clipboard Copies and pastes clipboard data between systems.

TABLE 2-4 Options Menu

Menu Item Description

Call Settings Configures SunForum 3D options for handling calls.

Tool Settings Configures general SunForum 3D options.

TABLE 2-3 Tools Menu (Continued)

Menu Item Description
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Help Menu
You can access help from the Help menu, located on the SunForum 3D menu bar.
Choose Help ➤ Help Topics for information on using SunForum 3D.

Using Directories
To set up your directory entry, you must specify your own details, including name,
location, and email address. You are prompted for these details the first time you run
SunForum 3D. You can choose whether to list these details for access by everyone; if
you do not, then only those people who know your email address will be able to call
you by using the directory.

Directories are used to list people who are currently running SunForum 3D and are
logged in to the respective directory. You can place a call to another user very
conveniently by double-clicking on the user’s directory entry.

Note – Users running SunForum 3D on a Sun desktop can log in to an LDAP
directory server or to an ILS directory server. However, users running SunForum 3D
on a Sun Ray server can only log in to a LDAP server.

This section contains the following topics:

■ To Change Your Directory Information
■ To Log In to a Directory Server
■ To Refresh the Directory List
■ To Automatically Log In to a Directory Server at Startup
■ To Remove Your Name From the Directory Server
■ To Call a User in the Directory List
■ To Call a User on a Directory Server Using an Email Address

3DAppShareSettings Configures SunForum 3D options which are specific to optimized
OpenGL 3D application sharing.

Audio/Video
Settings

Configures audio/video conference attributes.

Audio/Video Device
Settings

Configures the audio input and output devices and video input
device, including the Sun Ray and Sun 1394 Camera.

TABLE 2-4 Options Menu (Continued)

Menu Item Description
Chapter 2 Using SunForum 3D 11



▼ To Change Your Directory Information
1. Choose Call ➤ Change My Information.

2. Fill in the following fields:

■ First Name and Last Name. This name identifies you in a conference.

■ E-mail address. This address identifies you when you are logging in to a directory
server.

■ SunForum Name and SunForum Number. SunForum users, especially those using
the product for the first time, need to be aware that the SunForum Name and
SunForum Number values need to be unique. The Directory Server currently has
no way to otherwise uniquely identify users as they are logged onto the server.
Additionally, there is no connection between these entities and a person’s system
username, office telephone number, and so on. However, users can choose to
make their SunForum Name identical to their username, and their SunForum
Number identical to their office phone extension, if they wish.

It is important to remember that, when using the “standard” mode of placing a
SunForum call, the number used in the call is the SunForum Number as entered
in the call recipient’s SunForum user information. By contrast, when you enter a
number when placing a call through the gateway, SunForum attempts to make a
connection over the local telephone system, if the SunForum system configuration
is setup to do so. This distinction is important to remember when placing calls to
a recipient whose SunForum and office telephone numbers are identical.

■ Category. This is used by servers to narrow down the list of names when
querying or choosing a directory server.

3. Change the details as required and click OK.

▼ To Log In to a Directory Server
1. To view the directory listing, choose Call ➤ Log On To Directory Server.

2. Type the name of the directory server you want to log in to and click OK.

When SunForum 3D has successfully logged in to the directory server, the server is
automatically queried for other users also logged in to that directory.

▼ To Log Out From a Directory Server
● To log out from a directory server, choose Call ➤ Log Off From Directory Server.
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Note – You can configure an LDAP server as a SunForum 3D directory server. To do
this, refer to the SunForum 3D Help for these system administrator procedures.

▼ To Refresh the Directory List
● Choose View ➤ Refresh Directory.

This option can be selected only when the directory list is displayed.

▼ To Automatically Log In to a Directory Server at
Startup

1. Choose Call ➤ Change My information.

2. Select “At startup, log on to the directory server.”

3. Specify the directory server name in the Server Name field.

4. Type the name of the directory server you want to log in to in the Server Name
field.

The next time you start SunForum 3D, it will log in to the directory server you
specified.

▼ To Remove Your Name From the Directory
Server

1. Choose Call ➤ Change My Information.

2. Select “Do not list my name when logged on to the directory server.”

The next time you log in to a directory server, your name and details will not be
visible to users browsing the directory.

If you are currently logged in and your name is displayed when you select this
option, SunForum 3D automatically updates your entry at the directory server so
that your name is not displayed.
Chapter 2 Using SunForum 3D 13



▼ To Call a User in the Directory List
● To call a user shown in the directory list, double-click that entry in the directory

view.

Note – If “Add to address book” in the Place Call window (Call ➤ Place Call) is
selected, any users you call through the directory list will be added to the address
book list.

▼ To Call a User on a Directory Server Using an
Email Address
The SunForum 3D software enables you to call a user who is logged in to a directory
server by specifying the user’s email address.

● Type the name of the directory server the user is logged in to and the user email
address, separated by a slash (/).

The SunForum 3D software queries the specified directory server for a user with the
email address you entered. If the user is logged in to the directory server, SunForum
3D tries to start a call with them.

Making Calls and Sharing Applications
Refer to the SunForum 3D conference manager as you read the procedures in this
section.

This section contains the following topics:

■ Making a Call
■ Setting Parameters for 3D Application Sharing
■ Sharing Applications

Making a Call

▼ To Make a Quick Connection

1. Choose View ➤ Address Book, or click the Address Book button.
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2. Double-click on the address book entry that you want to connect to.

You can also simply click the Directory or History view buttons and double-click the
entry you want to connect to.

▼ To Connect Manually

1. Choose Call ➤ Place Call, or click the Call button.

The Place Call window is displayed. The Place Call window enables you to join a
conference.

2. Type the address with which you want to conference.

In the Place Call window, you can add the address you are calling to your address
book. You can also specify a named meeting to join (for example, if you are calling a
conference server).

3. Click OK.

The view will shift to Call Status if the connection is made, or a prompt will inform
you why the attempt was unsuccessful.

▼ To End a Connection

● Choose Call ➤ Hang Up, or click the Hang Up button.

This ends your participation in a conference.

Note – When you hang up, you can also disconnect others from the conference. This
includes all the participants you invited into the conference, or anyone who called
you. If you initiated the conference, the whole conference will be terminated. You
will get a warning message if you are about to disconnect others by hanging up.

Note – You can also place calls through a gateway, see Chapter 5 “Configuring
Gateway Software.”

Setting Parameters for 3D Application Sharing

▼ To Set 3D Sharing and Related Parameters
■ The 3D toggle switches back and forth between 3D sharing or T.120 sharing.

■ The slider balances loss of detail in images versus the size of compressed images;
for some CODECs or applications it may not make a difference, but for others it
will.
Chapter 2 Using SunForum 3D 15



■ The “Allow frame skip (send)” toggle, when set on the application sharing host,
causes the SunForum 3D which initiated application sharing to skip sending
some/certain frames in the application if the sending of the compressed frames
falls behind; this can be used to let the application run as fast as possible, and not
be slowed down by the requirement of it being shared. Setting this toggle on a
viewer system will have no effect on the application sharing host, that is, this
toggle is effective only for the application sharing host.

■ The “Allow frame skip (rec)” toggle, when set, causes the SunForum 3D which is
on the receiving end of application sharing to skip the decoding and displaying of
some received frames when it falls behind with decoding and displaying them;
this can be used by one low end system with a slow CPU or display frame buffer
to not slow down everybody in a conference to the rate at which this system’s
SunForum 3D can decode and display the frames. Setting this toggle on a viewer
system will have no effect on the application sharing host, that is, this toggle is
effective only for the application sharing host.

▼ To Set the CODEC Format

The compression/decompression (CODEC) format option is available under the
SunForum 3D conference manager menu bar.

1. Choose Options ➤ 3D App Share Settings.

2. Select the applicable CODEC format.

The following CODECs are currently supported:

■ Sun DCT (444 YUV-sampling)
■ Sun DCT (422 YUV-sampling)
■ Sun DCT (420 YUV-sampling)
■ JPEG (444 YUV-sampling)
■ JPEG (422 YUV-sampling)
■ JPEG (420 YUV-sampling)
■ YUV-422
■ YUV-420
■ Zlib (lossless)
■ RAW (uncompressed,lossless)

The Sun Discrete Cosine Transform (DCT) CODECs are highly optimized CODECs
based on DCT (very similar to JPEG) which limit the quality loss so as to be visually
lossless. This CODEC provides the best quality to compression ratio while being
faster than the JPEG CODEC for equivalent quality.

The JPEG CODECs are similar to the Sun DCT CODECs but provide a greater range
of quality control so that the user may sacrifice quality for much greater
compression.
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Both the Sun-DCT and the JPEG CODECs are reasonably compute intensive.
Therefore, in cases where there is sufficient network bandwidth available but the
host or client compute power is insufficient, it might be best to use the YUV (lossy),
Zlib, or Raw (lossless) CODECs.

When sharing an application, the CODEC used for encoding by the SunForum 3D
which initiated the application sharing will be used by the other participants’
SunForum 3D for decoding. SunForum 3D takes care of this automatically; there is
no need for the other users to set the CODEC in their instances of SunForum 3D.

Sharing Applications

▼ To Share Applications

When you are using the SunForum 3D software, the applications on your entire
desktop screen can be shared with other conference participants. This results in the
following:

■ If a controlling user within a SunForum 3D conference moves an application
window on their desktop, it is actually moved on the host desktop. Other
applications on the host desktop may obscure the window being shared. If a
portion of the shared application window is obscured on the host desktop, that
same portion is also obscured on the controlling user’s desktop.

■ Sun and PC desktops in a SunForum 3D conference might have different desktop
screen sizes. When controlling users move shared windows around on their
desktop, the windows might move outside the viewing area of a user in the
conference with a smaller desktop screen. A participant with a smaller desktop
screen can move (scroll) the active (view) region of the screen by moving the
mouse pointer to that area of the desktop where the entire application can be
viewed. (To set the scrolling feature, choose Tools ➤ Options from the SunForum
3D conference manager.)

1. While in a conference call, choose Tools ➤ Share, or click the Share button.

Or, choose Tools ➤ Share Application to select the application you want to share.

2. Place your mouse pointer (now a hand symbol) over the desktop application
window you want to share.

3. Click anywhere in that application window.

All conference participants can now see that application on their system as if it were
running locally. SunForum 3D can share almost any application, including terminal
windows, word processors, and CAD design packages. Exceptions include
SunForum and applications using certain X extensions that are not supported.
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Note – The window is labeled with the name of the user who shared the
application. At this point, only that person can control it; others can only view the
output on their desktop.

▼ To Unshare Applications

1. Choose Tools ➤ Unshare, or double-click Unshare, to stop sharing the application.

2. Click on the application window that was being shared.

Now, only you can view and control that application.

▼ To Collaborate Applications

Once an application is being shared, the Collaborate button is activated and you can
open the application to conference participants for collaborative use.

1. Share an application (see To Share Applications).

2. Choose Tools ➤ Collaborate, or click Collaborate.

The shared application that was view-only by the conference participants is now
open for collaboration.

When you collaborate your shared application, other conference participants can
take control. For a conference participant to take control of the shared application,
they only need to click on that application on their desktop.

Note – When another conference participant clicks the shared application window
and is then in control of it, that person effectively take over your mouse and
keyboard. Only one user can be in control at a time. Any other user, including the
host, can gain control by just clicking the mouse.

3. To stop collaborating, click Collaborate again.

The shared application is returned to view-only for the conference participants.

▼ To Transfer Files

1. Choose Tools ➤ Send File, or click Send File.

The Select a File to Send window is displayed.

2. Go to the directory and select the file you want to send.

3. Click OK.

The file is sent to all the participants in the conference.
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Files sent to you by other conference participants are received automatically. While
the file is being received, another window shows the progress of the transfer. When
the transfer is complete, the file is saved. The default directory for saving files is
/tmp. To change the default directory where files are saved, choose Options ➤ Tools
Settings.

▼ To Chat

1. Choose Tools ➤ Chat, or click the Chat button to start the chat application.

This action also automatically starts the chat application on other user systems in the
conference.

2. Select the recipient of your message.

■ To send to all participants, choose Send to ➤ Everyone in conference.

■ To send to a single participant, choose Send to ➤ user name.

The names of those conference participants who are running chat are listed in the
Send to menu.

3. Type your message in the message field and press Return.

The message is displayed in your chat window and on the other participants’ chat
windows.

You can list the date, time, and name with the message. To do this, click View on the
Chat menu bar and select or deselect your choice.

You can save chat sessions to a file as a record of the conference. You are prompted
to do so when you exit the Chat window.

Note – Though other conferencing products may have T.120 text chatting capability,
they might not work with SunForum 3D chat. Check the chatting status in the
SunForum 3D conference manager to see who is running chat.

▼ To Transfer Data Using the Shared Clipboard

1. Ensure that Shared Clipboard is enabled on both systems.

2. Choose Tools ➤ Shared Clipboard.

The Shared Clipboard menu item should be active (checked).

Note – To automatically enable Shared Clipboard, choose Tools ➤ Options.

3. Select text from an application (for example, a Command Tool) on one system.

4. Choose Edit ➤ Copy.
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5. In an application (for example, a text editor) on another system, choose
Edit ➤ Paste.

Using the SunForum 3D Audio and
Video
The H.323 audio and video communications protocol is the standard for
audio/video conferencing. SunForum 3D conforms to the H.323 standard.

This section contains the following topics:

■ Types of Audio/Video Conferences
■ Configuring Audio and Video Capabilities
■ Controlling Audio Within the Conference
■ Controlling Your Video Image Over a Conference
■ Controlling Video Image Within a Multipoint Conference
■ Controlling Video Within a Point-To-Point Conference
■ Displaying Remote Video in a Point-To-Point Conference
■ Displaying Remote Video in a Point-To-Point Conference

Types of Audio/Video Conferences
Conferencing products may provide one of three different levels of audio/video
support.

■ Multipoint - You can see and hear many people in the call at the same time. Each
person’s video image appears in a separate window, and the audio information
from each person is mixed together so that you hear a single audio channel
including everyone’s voice.

■ Point-to-point - You can see and hear one other person in the call at a time, and
can switch from one to another.

■ No audio/video - You cannot see or hear other people in the conference. Users of
conferencing products that do not support audio/video often set up a telephone-
based conference call in parallel with the SunForum 3D conference.

SunForum 3D provides multipoint support, but can also operate in point-to-point
mode or without audio/video to support conferences with other products:

■ If everyone in the conference is using a product that supports multipoint
audio/video, you can use either multipoint or point-to-point. (You may prefer to
use point-to-point if people are familiar with products that operate only in this
mode.)
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■ If some people are using a product that supports only point-to-point
audio/video, you should use point-to-point. SunForum 3D can be configured to
force a conference to use point-to-point thus insuring that the products that only
support point-to-point can establish audio/video links.

■ Anyone who is using a product that does not support audio/video can still
participate in the conference, but will not be able to see or hear other people. You
can still use audio/video to communicate with anyone in the conference who has
support for it.

When you start a call to another person, SunForum 3D initially creates a point-to-
point link for audio/video support regardless of the capabilities of the other
product. Should a third person join the conference, their capabilities will determine
if the conference becomes a multipoint conference or remains a point-to-point
conference. Once a conference has become a multipoint conference, products that do
not support multipoint will not be able to establish an audio/video link in the
conference.

If you want to start a conference explicitly in point-to-point mode, you can specify
this in the Audio/Video Settings dialog box. See To Set Audio/Video Device
Options for more information.

In the current call window, the audio/video icons indicate an audio/video link to a
participant in the conference.

FIGURE 2-3 Conference Manager Audio and Video Icons
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Configuring Audio and Video Capabilities

▼ To Set Audio/Video Options

● Choose Options ➤ Audio/Video Settings.

Or, choose View ➤ Audio/Video Settings in your video display window or the video
display windows of others if you are in a conference.

TABLE 2-5 Audio and Video Options

Menu Item Description

Use point-to-point
Audio/Video
connections

This option enables you to only use point-to-point connections for
your audio/video conferences. This guarantees that users who only
support point-to-point will be able to use audio and video as part of
the conference.

Send image size Specify the size of your video image as it appears to other people.
This also determines the size of the My Video window on your
screen. The range of window sizes that you can use depends on the
capabilities of the conferencing products being used by other
people. If you are already in a conference, one or more of these
options may be grayed if other people are using conferencing
products that cannot support them. You might find that the window
size changes when you start a call, or when another person joins or
leaves the conference. This is because another person might not be
able to use the size that you originally selected; SunForum 3D
cooperates with the other conferencing products to select the best
compromise between the requirements of everyone currently in the
conference.

Default video
magnification

This option specifies the default magnification (100% - 400%) used
to display video on your system.

I prefer to receive This option allows you to tune the picture quality of the video
images of other people as they appear on your screen.
• Move the slider towards Faster Video to view the video with

more updates per second. This gives a smoother display, but
reduces the resolution of the image.

• Move the slider towards Better Quality to view the video with
higher resolution. This gives a better-quality video image, but
may mean that the video appears less smooth.
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▼ To Set Audio/Video Device Options

● Choose Options ➤ Audio/Video Device Settings.

Using the Sun 1394 Camera Snap Feature

You can snap a video image directly from the camera with the Sun 1394 Camera.
This allows you to capture an image at any location within a 3.0 meter range (1394
cable length) away from your workstation. This feature is activated through
SunForum 3D (see Capturing and Copying Video Images).

Connection speed Select the option that best describes the network over which you are
using SunForum 3D.

Echo suppression If selected, SunForum 3D disables your microphone when it is
playing back audio. Also called half-duplex, this is useful when
using a speaker and not a headset.

Auto Gain Control If selected, SunForum 3D will automatically adjust the sensitivity of
your microphone based on the input level.

TABLE 2-6 Audio and Video Device Options

Menu Item Description

Audio Device Enables you to choose the audio device to use for conferencing and
the attributes associated with that device. First you select the audio
device you want to use from the menu and then you push the
“Settings” button to configure the device specific attributes. Each
device is a unique attribute that can be configured.

Video Device Enables you to choose the video device to use for conferencing and
the attributes associated with that device. One choice is None for
systems without video capture capabilities or for those who are
capable but choose to disable it. First you select the video device
you want to use from the menu and then you push the Settings
button to configure the device specific attributes. Each device is a
unique attribute that can be configured.

TABLE 2-5 Audio and Video Options (Continued)

Menu Item Description
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Controlling Audio Within the Conference
You can adjust your own audio and adjust the audio you receive from the conference
participants.

▼ To Adjust Your Audio Over a Conference

The checkbox to the left of the Conference Manager Microphone icon indicates
whether your audio is being played to other people in the call.

● To start or stop playing your audio to other people in the call, click on the
checkbox to the left of the icon.

■ To control the output level of your audio, move the slider to the right to make
your audio louder, or to the left to make it quieter. This is important in a
multipoint conference, where this slider determines the volume of your audio
relative to other people’s audio.

■ If you are using point-to-point audio/video, only the person that you are
currently switched to will be able to hear you. To switch to a different person in
the call, see Controlling Video Within a Point-To-Point Conference.

▼ To Adjust Conference Audio on Your Computer

The checkbox to the left of the Speaker icon indicates whether other participant’s
audio is being played on your computer.

● To start or stop listening to other people in the call, click on the checkbox to the
left of the icon.

■ To control the volume, move the slider to the right to increase the volume, or to
the left to decrease it.

■ If you are using point-to-point audio/video, you will hear only the person that
you are currently switched to. To switch to a different person in the call, see
Controlling Video Within a Point-To-Point Conference.

Controlling Your Video Image Over a Conference
Before starting a call using video, you can check the video image of yourself that
will appear on other participant’s screens (for example, to make sure that the camera
on your system is aligned correctly). The video image appears on your screen in a
window with the title My Video. You can show or hide the My Video window at any
time.
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▼ To Control Your Video Image Before a Conference

● Choose Tools ➤ Video ➤ Display My Video.

You can also hide the window by closing it. Prior to entering a call, you see the
message Not Sending beneath the My Video window.

Note – SunForum 3D software enables you to zoom your video display window.

▼ To Control Your Video Image During a Conference

Once in a call, a button is displayed in addition to the status message at the bottom
of the My Video window. The status message reflects the current state of video
transmission. The button is used to change that state as follows:

● If the video status is “Sending”, the Pause button is shown. Click on this button
to pause the video display. When you pause the display, a “freeze frame” image
appears in the window and the status message becomes “Paused.”

● If video status is “Paused”, the Play button is shown. Click on this button to
activate the video display. When you activate the display, video transmission is
restarted and the status message becomes “Sending”.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play
option that appears in the View menu of this window. These options only appear
when in a call.

You can control whether your video image is automatically sent to other people as
soon as you start a call; see To Set Audio/Video Device Options for more
information.
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Controlling Video Image Within a Multipoint
Conference
If you are using multipoint audio/video, a video image of each person in the call is
displayed automatically when he or she starts sending video.

■ Each participant’s image is displayed in a separate window, with the participant’s
name as the window title. As other people join or leave the call, new windows
appear or existing windows disappear.

■ You can choose which of these windows are displayed on your screen.

▼ To Control Video Image Within a Multipoint Conference

● Choose Tools ➤ Video ➤ Display Others.

Click on an entry for the window you want to display or hide. Alternatively, you can
hide a displayed window by closing the window using the system menu.

At the bottom of each of these windows, a button indicates whether the video is
being displayed, as follows:

■ If the video status is “Receiving”, the Pause button is shown. Click on this button
to pause the video display. When you pause the display, a “freeze frame” image
appears in the window and the status message becomes “Paused”.

■ If video status is “Paused”, the Play button is shown. Click on this button to
activate the video display. When you activate the display, video transmission is
restarted and the status message becomes “Receiving”.

You can control whether you automatically display video images of other people as
soon as they start sending video; see To Set Audio/Video Options for more
information. If you do not display these images, the window for a remote user on
your screen remains blank until you use the Play button to start the video display.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play
option that appears in the View menu of this window.

Note – The window size used for other people’s video is determined by the
sender’s conferencing product and capabilities.
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Controlling Video Within a Point-To-Point
Conference
In point-to-point audio/video, you can see and hear only one other person in the
conference at a time. You can switch between different people in the conference; if
you switch to a different person, the person you were previously seeing and hearing
remains in the conference but is not switched to anyone.

Note – The switch attempt will fail if you try to switch to a person who is already
switched to someone else.

▼ To Switch to Another Person

● Choose from the Tools ➤ Switch Audio and Video.

This displays a list of people that you can switch to, including the person you are
currently switched to (with a selection marker next to that person’s name). The list
does not include people who do not have audio/video support.

■ To switch to a different person, click on that person’s name in the list.

■ To “switch out” so that you remain in the conference but are no longer switched
to anyone, click on the name of the person you are currently switched to (the
name with the selection marker next to it).

The Switch Audio and Video menu item only appears if you are in a conference with
more than one audio/video capable person and are using point-to-point
connections.

Displaying Remote Video in a Point-To-Point
Conference
If you are using point-to-point audio/video, the Remote Video window displays a
video image of the person you are currently switched to (if any).

■ To switch to a different person in the call, see Controlling Video Within a Point-
To-Point Conference.

■ You can choose whether to display this window on your screen by displaying
Remote Video.
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▼ To Display Remote Video

● Choose Tools ➤ Video ➤ Display Others’ Video.

This displays or stops displaying the window. Alternatively, you can close the
window by clicking on the Close button for the window.

Using the SunForum 3D Whiteboard
The SunForum 3D Whiteboard enables all conference participants to exchange ideas
and graphics. You do not need to be in a conference, however, to use the whiteboard.

There are two types of whiteboards available through SunForum 3D:

■ T.126 mode, which allows you to interoperate with any computer system or
appliance using the T.126 protocol, regardless of platform software

■ SunForum 1.0 mode, which allows you to interoperate with certain collaboration
software running on PCs.

This section contains the following topics:

■ Starting the Whiteboard
■ Creating and Manipulating Graphical Objects
■ Capturing and Copying Video Images
■ Adding Screen Captures to the Whiteboard
■ Importing and Exporting Graphics
■ Copying to the Clipboard
■ Using Pages
■ Zooming and Locking the Whiteboard
■ Saving and Printing Whiteboard Contents
■ Using Other Tools
■ Starting the Whiteboard
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Starting the Whiteboard

▼ To Select a Whiteboard Mode

1. Choose Options ➤ Tool Settings.

2. Choose the desired whiteboard mode: T.126 or SunForum 1.0 mode.

3. Click OK.

Note – Once you select a whiteboard in the Options window, this whiteboard will
open each time you select Whiteboard from either the Tools menu or from the
Whiteboard button on the SunForum 3D conference manager. See To Start the
Whiteboard.

▼ To Start the Whiteboard

● Choose Tools ➤ Whiteboard, or click the Whiteboard button, from the SunForum
3D conference manager.

The whiteboard mode you selected in the Options window is displayed. This
example shows the SunForum 3D T.126 mode whiteboard.

FIGURE 2-4 SunForum 3D Whiteboard
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Whiteboard Menus

Whiteboard Tool Panel

Familiarize yourself with the whiteboard by experimenting with the drawing
features in the drawing tool panel to the left of the whiteboard. You do not need to
be in a conference to do this.

FIGURE 2-5 Whiteboard Tool Panel

TABLE 2-7 Whiteboard Menu Bar Descriptions

Menu Description

File For file handling functions such as New, Open, Save, Import,
Export, and Print.

Edit To edit functions such as copy, paste, clearing, deleting, inserting
pages, and so on.

Tools To select drawing functions. You can also click the icon on the draw
tool panel on the left side of the whiteboard.

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window

Lock

SunForum 1.0 mode

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

Select area

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window Select area

Snap My Video Enable camera

T.126 mode

Snap My Video Enable camera
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Creating and Manipulating Graphical Objects
1. Click the tool type in the whiteboard tool panel.

For example, click the freehand pen or choose Tools ➤ Pen from the menu bar.

2. Choose your pen color and line thickness.

a. Click the Whiteboard Options button located on the bottom of the whiteboard.

FIGURE 2-6 Whiteboard Options Button

The Whiteboard Options panel is displayed.

FIGURE 2-7 Whiteboard Options Panel

b. Choose your pen color and pen width, then click OK.

3. Click and drag your mouse button to draw the object.

As you release the mouse button, the object is seen by all other conference
participants.
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▼ To Create Text Objects

1. Click the Text tool button, or choose Tools ➤ Text.

2. Place your mouse pointer in the whiteboard where you want to enter text.

3. Click at that location.

A text field appears in the whiteboard.

4. Enter the text and click OK.

▼ To Edit Text Objects

1. Click the Text tool button, or choose Tool ➤ Text.

2. Click the text in your whiteboard that you want to edit.

A text field appears in the whiteboard.

3. Edit the text and click OK.

▼ To Set the Font and Style of Text Objects

You can set font options in two ways:

■ By changing settings in the Whiteboard Options tool before creating a new text
object

■ By selecting a text object, then changing the settings in the Whiteboard Options
tool.

■ By selecting a text object, then changing the settings when the text field is visible.

1. Click the Whiteboard Option button.

The Whiteboard Options window is displayed.

2. Click the Text Font, Text Size, and Text Style menus and choose the font setting.

Note – Only a small number of fonts are available to ensure that text objects are able
to display on all user systems in the conference.

3. Click OK on the Whiteboard Options window.

▼ To Move and Delete Objects

1. Click the Selector tool button, or choose Tools ➤ Selector.

2. Click the graphic or text that you want to move or delete.

A border is highlighted on the selected object.
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a. To move the graphic or text, drag it with the mouse pointer to its new position.

b. To delete the graphic or text, press Delete on your keyboard, or choose
Edit ➤ Delete.

Note – If you delete an object by mistake, you can undelete and retrieve the last
deletion by choosing Edit ➤ Undelete.

▼ To Highlight Text and Images

1. Click the Highlight button, or choose Tools ➤ Highlighter.

2. Draw on the whiteboard area you want to highlight.

Capturing and Copying Video Images
You may snap a camera video image from either the whiteboard tools panel, or from
the Sun 1394 Camera snap button, and copy it as an image to the whiteboard.

▼ To Capture an Image From the Whiteboard Tools Panel

1. Select the camera video image you wish to capture.

2. Click the Snap My Video from the Whiteboard tools panel (FIGURE 2-5), or choose
Tools ➤ Snap My Video from the Tools menu.

The image appears and is copied in the top left corner of the Whiteboard window.

▼ To Capture an Image Using the Sun 1394 Camera

1. Click the Enable Camera button on the whiteboard tools panel (FIGURE 2-5).

This enables the Sun 1394 Camera snap button so that each time you press the
camera snap button, the image is captured on the Whiteboard.

2. Focus on the image to be captured and press the Sun 1394 Camera snap button.

If you do not use the camera snap button for a period of 60 seconds, then the snap
button becomes disabled again.

Note – If you want to disable the snap button on the camera before the timeout
period expires, simply press the Escape key.
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Adding Screen Captures to the Whiteboard
You can capture the contents of a window, or an area of the desktop, to add to your
whiteboard for conferencing.

▼ To Select and Capture a Window

1. Click the Select window button, or choose Tools ➤ Select Window.

The whiteboard becomes an icon and the mouse pointer becomes a hand symbol.

2. Place the mouse pointer on the window you want to add to your whiteboard.

3. Click the window.

The window is captured and placed in your whiteboard.

▼ To Select and Capture an Area of the Screen

1. Click the Select window button, or choose Tools ➤ Select Area.

The whiteboard becomes an icon and the mouse pointer becomes a pair of
crosshairs.

2. Drag the mouse pointer over the area of your desktop screen that you want to
capture.

The image area is captured and placed in your whiteboard as you release the mouse
button.

Note – Once the image is captured in the whiteboard, you can use the Selector tool
to select the image and move or delete it across your whiteboard. See To Move and
Delete Objects.

Importing and Exporting Graphics

▼ To Import Graphics

1. Choose File ➤ Import.

The Select a file to import window is displayed.

2. Specify the file you want to import and click OK.

The image is added to the current page.
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Note – You need the shareware filter ghostscript to import PostScript files into
the whiteboard. The location of ghostscript must be separately specified in
/etc/opt/SUNWdat/config/system-config as Whiteboard.GSPath.

▼ To Export Graphics

1. Choose File ➤ Export.

The Export file window is displayed.

2. Specify the file you want to export.

3. Choose an image format from the Save file as type menu.

4. Click OK.

The contents of the current page is written to the file in the selected format.

Copying to the Clipboard
You can cut and paste to and from a clipboard in two ways:

■ Using the quick method to copy text

■ Using the Edit commands to cut and paste text and graphics

▼ To Use the Quick Method to Copy Text

1. Select text in the whiteboard (or another text source window) or from another
application.

2. Place the mouse pointer in the whiteboard and click the middle mouse button to
paste the text selection.

▼ To Use the Edit Commands

1. Select the text or object you want to copy.

2. Choose Edit ➤ Cut or Edit ➤ Copy.

3. Go to a new whiteboard page and choose Edit ➤ Paste.
Chapter 2 Using SunForum 3D 35



Using Pages

▼ To Navigate and Organize Pages

● To navigate pages, use the navigation arrows at the bottom of the whiteboard to
change pages; or, use the Edit menu to clear, delete, insert, and go to specific
pages.

● To organize pages, choose Edit ➤ Bring to Front or Edit ➤ Send to Back to move
the current page accordingly.

▼ To Add a New Page

● Click the new page button or choose Edit ➤ Insert Page, located in the bottom
right corner of the whiteboard.

A new page is added after the current page.

FIGURE 2-8 New Page Button

Note – Using the menu to insert a page enables you to place the new page before or
after the current page.

Zooming and Locking the Whiteboard

▼ To Zoom the Whiteboard

● Click the Zoom button, or choose Tools ➤ Zoom.

This changes the magnification of the whiteboard contents you are viewing.

▼ To Lock the Whiteboard

You can lock the whiteboard so that no one else in the conference can make any
changes to the contents.
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1. Click the Lock button, or choose Tools ➤ Lock.

After a short delay, either you will have successfully locked the whiteboard
(indicated by the lock “down” position), or you will be notified that it could not be
locked. You may not be able to lock it because another user in the conference has
already locked the whiteboard or is in the middle of an operation that cannot be
interrupted.

2. Click the lock button a second time to release the lock.

Note – Locking feature cannot be used in a T.120 whiteboard.

Saving and Printing Whiteboard Contents

▼ To Save the Whiteboard Contents to a File

● Choose File ➤ Open.

or

● Choose File ➤ Save (or File ➤ Save As).

▼ To Print the Whiteboard Contents

● Click the Print button, or choose File ➤ Print.

FIGURE 2-9 Print Button

In the print window, specify the printer or file name to print to, and which pages
you want to print.

Note – The printer name must be a valid printer device. The SunForum 3D software
allows you to also specify a networked printer name.
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Using Other Tools

▼ To Use the Remote Pointer

The remote pointer is a pointing hand that everyone in the conference can see. When
you have the Select tool enabled, you can click on the pointer and drag it around, so
that you can point out areas of interest on the page.

1. Click the Remote Pointer button, or choose Tools ➤ Remote Pointer.

A hand symbol pointer is displayed on your whiteboard.

2. Click and drag the remote pointer to move to selected areas of interest.

▼ To Use Whiteboard Stamps

The Whiteboard Stamps window offers a number of images you can “stamp” on the
whiteboard. These are user configurable. The SunForum 3D software enables you to
use bitmap files (such as GIF) in user-defined locations.

1. Click the Rubber Stamp button.

FIGURE 2-10 Rubber Stamp Button

The Whiteboard Stamps window is displayed.
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FIGURE 2-11 Whiteboard Stamps Window

2. Click on a stamp image and click OK.

When you place the pointer in the whiteboard, the pointer is a stamp.

3. Place the stamp pointer in the whiteboard where you want the image to appear
and click.

The stamp image is displayed.
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CHAPTER 3

SunForum 3D Controls

This chapter contains the following topics:

■ Overview
■ OpenGL Application Requirements
■ SunForum 3D Control Panel
■ SunForum 3D Configuration Files

Overview
When SunForum 3D sharing is enabled, the OpenGL image data is grabbed,
compressed, and sent to all participants in a conference over a private channel. The
participants in turn receive the data, decompress it, and display the image. Various
options are available to configure this pipeline that displays the 3D application. You
can change some of these options dynamically (from the SunForum 3D GUI) while a
conference or sharing is in progress. You set other options in a system or user
specific configuration file.

There might be a noticeable slowdown in the frame rate of the 3D OpenGL
application being shared. This is expected behavior, since each frame needs to be
grabbed, compressed, sent to all receivers, decompressed, and displayed. You can
control this behavior and performance using the SunForum 3D conference manager
interface 3D controls.
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OpenGL Application Requirements
There are limitations on the types of OpenGL applications that are supported for
SunForum 3D accelerated sharing.

■ Single buffered applications are not fully supported. There is some limited
support (on non-Xinerama configurations) for single buffered applications that
call glFinish or glFlush at the appropriate times.

To enable this limited support, set one or both of sf3d.opengl.enable-flush
or sf3d.opengl.enable-finish to TRUE in the SunForum 3D system or user
configuration files.

■ The system configuration file is located in:
/opt/SUNWsf3d/config/system-config

■ The user configuration file is located in:
$HOME/.sunforum/.sf3d-user-config

If a user configuration file does not exist, the system configuration file can be
copied to the above filename and then modified.

■ When Stereo applications are shared, the remote side will not receive stereo;
instead, they only see the left eye image.

■ OpenGL applications that use transparent overlays are not supported.

■ OpenGL applications that are being remotely displayed (using GLX) are not
supported for accelerated sharing (that is, rlogin graphics-host ; setenv
DISPLAY client:0.0).

Note – For 3D application sharing when using Xinerama, set the environment
variable SUN_OGL_IS_MT before running OpenGL applications.

To set this environment variable,

1. Go to the shell window where you are going to run the OpenGL application.

2. In the shell (csh or tcsh) window, type:

In a Bourne shell window, type:

% setenv SUN_OGL_IS_MT

% SUN_OGL_IS_MT=y
% export SUN_OGL_IS_MT
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SunForum 3D Control Panel
The SunForum 3D conference manager 3D controls (FIGURE 3-1) include:

■ 3D Toggle Button
■ Higher speed — Better quality slider
■ Allow frame skip (send)
■ Allow frame skip (rec)

FIGURE 3-1 SunForum 3D Controls

SunForum 3D Controls
TABLE 3-1 lists and describes the SunForum 3D controls. See “SunForum 3D Control
Descriptions” on page 44 for details.

TABLE 3-1 SunForum 3D Controls

Menu Item Description

3D toggle button Activates or deactivates SunForum 3D application sharing.

Higher speed, Better quality slider Adjusts 3D application display depending on performance and
image quality.

Allow frame skip (send) Skips transmissions of some frames for better OpenGL
application performance.

Allow frame skip (rec) Skips the display of some frames so as to show the most recent
frame (generated at the host) sooner.
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SunForum 3D Control Descriptions
This section describes the SunForum 3D controls.

3D Toggle Button
When this button is turned on (checked), the SunForum 3D application sharing is
enabled. When it is turned off (unchecked), the SunForum 3D application sharing is
disabled. In the latter case, application sharing still takes place (as it does with
SunForum). There is a significant degradation, however, in the frame rate and the
integrity of frames on the viewers as compared to the SunForum 3D application
sharing mode.

Toggle this button off when there are non-SunForum 3D compliant parties in a
conference who need to see the application at some moments during the conference.
Turning the 3D application sharing toggle button off impairs performance, but it
makes the frames visible to the non-SunForum 3D nodes.

Higher speed — Better quality slider
Frames are compressed at one end and decompressed at the other. The CODECs
used for compression/decompression is discussed in Setting Parameters for 3D
Application Sharing, but some of the CODECs allow for a parameter which balances
the compression ratio versus the loss in image detail. If the currently selected
CODEC has such a parameter, then the slider will be enabled, otherwise the slider is
inactive.

Depending on the CODEC, on the size of the frames, CPU processing capabilities,
and the available bandwidth, the effects of moving the slider might or might not be
visible. It is best for users to set the slider in the middle, and then adjust it left or
right depending on the performance, image quality, and other needs.

Note – The slider is effective for the sending side of the application (application
sharing host) only.
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Allow frame skip (send)
Frames are grabbed, compressed, sent over the network, decompressed, and
displayed. By default (when this button is not checked), every frame generated on
the host is sent and seen on all other SunForum 3D participants in the conference.
Selecting “Allow frame skip (send)” slows down the application being shared to
whatever the bottleneck might be (typically, either the compression or the network
congestion).

When you select “Allow frame skip (send),” SunForum 3D is allowed to skip the
transmission of some/certain frames in the application (if the rest of the pipeline is
busy) so that the OpenGL application is not slowed down as much.

Setting this toggle on a viewer system will have no effect on the application sharing
host, that is, this toggle is effective only for the application sharing host.

Allow frame skip (rec)
This toggle button is the equivalent of the frame skip toggle button on the receiving
end. By default (when this button is not checked), every frame received is
decompressed and displayed.

When you select the “Allow frame skip (rec),” SunForum 3D skips the display of
some frames so as to show the most recent frame (generated at the host) sooner.

For example, if the system is a low end system and decoding and/or displaying are
relatively slow compared to the other systems in a conference, then the low end
system would, in principle, slow down the frame rate for everybody in the
conference. In this case, the user at the low end system could press and select this
toggle button, thus enabling frame skipping and not slowing down the host and the
others in the conference as much.

Setting this toggle on a viewer system will have no effect on the application sharing
host, that is, this toggle is effective only for the application sharing host.
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SunForum 3D Configuration Files
The entries in the /opt/SUNWsf3d/config/system-config configuration file
contain various parameters that control the behavior of the 3D application sharing.
This file can be edited, although you need to be superuser to edit the file. The
parameters are explained in the configuration file.

A user editable copy of this file exists in $HOME/.sunforum/.sf3d-user-config.
If this file does not exist, make a copy of the system-config file. This file will also
be updated by SunForum 3D, depending on GUI selections made by the user while
running SunForum 3D.

Note – When entries are in both .sf3d-user-config and system-config files,
then the values of the parameters in .sf3d-user-config take precedence over
those in system-config.
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CHAPTER 4

SunForum 3D Phone

This chapter contains the following topics:

■ Starting the SunForum 3D Phone
■ SunForum 3D Phone Menus
■ Using the SunForum 3D Phone
■ My Video
■ Audio and Video Device Settings
■ Media Configuration Wizard
■ Preferences

Starting the SunForum 3D Phone
● After installing SunForum 3D software packages, type the following at your

system prompt:

Note – If the SunForum 3D directory is not set in your path, type the correct path
name (for example, /opt/SUNWdat/bin/phone).

The SunForum 3D Phone is displayed (FIGURE 4-1).

% phone
47



FIGURE 4-1 SunForum 3D Phone

Note – Once the SunForum 3D Phone displays, you can toggle the SunForum 3D
conference manager from the Phone user interface Controls menu. You cannot start
the Phone from the SunForum 3D conference manager; however, if SunForum 3D is
started first.

Note – The SunForum 3D Phone interface is used for audio and video calls. For data
collaboration or advanced settings, you must toggle to the SunForum 3D conference
manager interface (see Chapter 2 “Using SunForum 3D”).

Call edit field

Phone keypad

Place Call button

Hang Up button

Clear button

Volume indicator

Phone mic

Volume button

Volume control buttons

Name field

My Video button
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SunForum 3D Phone Menus
There are four menus on the SunForum 3D Phone menu bar: Call, Controls, Address
Book, and Help. The following tables describe each of the Phone menu options.

Call Menu

Note – The Place Call menu item and Call button on the Phone interface are
disabled until you enter an address in the Call Edit field (FIGURE 4-1).

TABLE 4-1 Call Menu

Menu Description

Place Call Places a call to an indicated address. You can also click the
Phone Call button.

Hang Up Ends your call. (Same as clicking the Hang Up button.)

Change My Information Makes changes to your SunForum 3D profile information.

Directory Views the directory server. It lists those with whom you can
conference.

List of phone numbers Lists a history of the last dialed numbers (lists a maximum of
10 phone numbers)

Exit Exits the SunForum 3D Phone software.
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Controls Menu

Address Book Menu
The SunForum 3D Phone Address Book menu lists the addresses in the user’s
address book. The history portion of the Call menu contains a list of the 10 most
previously used addresses, however.

There are three types of addresses a user can create in the Add Address and New
Address windows:

■ Telephone: A telephone number to be used with a gateway
■ Network (TCP/IP): A call alias used with a Sun Gatekeeper
■ Directory: An LDAP directory to use with the address

TABLE 4-2 Controls Menu

Menu Item Description

Volume Increases, decreases, or mutes volume.

Microphone Toggles the microphone on or off.

Toggle SunForum 3D Opens and close the SunForum 3D conference manager.

Audio/Video Device
Settings

Selects audio and video devices and to configure the settings of
each.

Media Config
Wizard

Provides help in configuring your audio and video device settings.

Preferences Sets preference conditions for Incoming Calls, Telephone Key, and
Cursor.

TABLE 4-3 Address Book Menu

Menu Item Description

Add Address Adds an address to the Address Book. This is only available when a
conference participant is selected in the Phone roster, during a
conference. This fills the address information for the user.

New Address Adds a new address. This is always available.

Edit Address Book Displays a list of addresses in your address book and enables
addresses to be created, edited, or deleted.

List of addresses Lists addresses that are frequently conferenced.
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Help Menu
You can access help information from the Help menu located on the SunForum 3D
Phone menu bar:

● Choose Help ➤ Phone Help for online SunForum 3D Phone information.

or

● Choose Help ➤ Popup Help.

Popup Help toggles Help messages that are displayed underneath the cursor when
the cursor is positioned on many of the Phone GUI controls.

Using the SunForum 3D Phone
Once your SunForum 3D Phone is displayed and you have configured the audio and
video device settings and phone preferences to your needs (TABLE 4-1 and TABLE 4-2),
you are ready to place a call.

Placing a Call
Besides using the Phone menu bar to place calls, you can use the Phone user
interface.

▼ To Place a Call Through the Phone Interface

● Click the phone number you wish to call on the phone interface keypad.

The number is displayed in the field just above the keypad. Then click the Place Call
icon to place the call (FIGURE 4-1).

or

● Type the phone number, or alias name, from your computer keyboard.

The number is displayed in the field just above the keypad. Press Return on your
keyboard (or click the Place Call icon) to place the call.

Once you have placed the call, an Outgoing Call window displays as it dials the
number. You can also cancel the call from the Outgoing Call window. See FIGURE 4-1.
Chapter 4 SunForum 3D Phone 51



▼ To Clear a Number That You Have Entered

● Clear the number from your keyboard by selecting the entire Call edit field and
pressing Delete.

or

● Click the Clear button until the number is erased.

▼ To Turn On the Phone Microphone

● Click the Phone mic button.

Note – A computer phone microphone/headset is recommended for each
participant in the conference.

My Video
You can view your video that is being broadcast over a conference and configure
your audio and video settings. To do this:

1. Double click the My Video button (FIGURE 4-1) next to your name in the Name
field.

The My Video window is displayed.
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2. From the My Video menu bar, choose View ➤ Audio/Video Settings.

The Audio/Video Settings window is displayed. TABLE 4-4 describes the setting
options.

TABLE 4-4 Audio and Video Settings

Setting Description

Use point-to-point
Audio/Video
connections

Enables you to only use point-to-point connections for your
audio/video conferences. This guarantees that only users who
support point-to-point will be able to utilize Audio and Video as
part of the conference.

Send image size Specifies the size of your video image as it appears to other people.
This also determines the size of the My Video window on your
screen. The range of window sizes that you can use depends on the
capabilities of the conferencing products being used by other
people. If you are already in a conference, one or more of these
options might be disabled if other people are using conferencing
products that cannot support them. You might find that the window
size changes when you start a call, or when another person joins or
leaves the conference. This is because another person might not be
able to use the size that you originally selected; SunForum 3D
cooperates with the other conferencing products to select the best
compromise between the requirements of everyone currently in the
conference.

Default video
magnification

Specifies the default magnification (100% – 400%) used to display
video on your system.

I prefer to receive Enables you to tune the picture quality of the video images of other
people as they appear on your screen.
- Move the slider towards Faster Video to view the video with

more updates per second. This gives a smoother display, but
reduces the resolution of the image.

- Move the slider towards Better Quality to view the video with
higher resolution. This gives a better quality video image, but
might mean that the video appears less smooth.

Connection speed Selects the option that best describes the network over which you
are using SunForum 3D.

Echo suppression If selected, SunForum 3D disables your microphone when it is
playing back audio (half-duplex).

Auto Gain Control If selected, SunForum 3D automatically and continuously adjusts
the sensitivity of your microphone based on the input level.
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Audio and Video Device Settings

▼ To Set Audio/Video Device Options

● Choose Controls ➤ Audio/Video Device Settings from the Phone menu bar.

TABLE 4-5 Audio and Video Device Options

Setting Description

Audio Device Enables you to choose the audio device to use for conferencing and
the attributes associated with that device. First select the audio
device you want to use from the menu and then click the “Settings”
button to configure the device specific attributes. Each device is a
unique attribute that can be configured.

Video Device Enables you to choose the video device to use for conferencing and
the attributes associated with that device. One choice is “None” for
systems without video capture capabilities or for those who are
capable but choose to disable it. First select the video device you
want to use from the menu and then click the “Settings” button to
configure the device-specific attributes. Each device is a unique
attribute that can be configured.
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Media Configuration Wizard
The SunForum 3D Phone Configuration Wizard helps you configure your audio and
video settings. TABLE 4-6 describes the Configuration Wizard device settings and
tests.

1. Choose Controls ➤ Media Configuration Wizard from the Phone menu bar.

Be sure to close all other applications that use audio and video.

2. Click Next at each window to progress through the configuration pages (TABLE 4-6).

3. Click Finish on the last page when done.

Note – While in a call, the Media Configuration Wizard is unavailable.

TABLE 4-6 Media Configuration Wizard

Setting Description

Media Device Setting Enables you to choose which audio and video device SunForum 3D
will use for conferencing and the attributes associated with that
device. First select the audio and video device you want to use from
the Audio and Video Device menu. Click the Settings button to
configure the device-specific attributes. Each device is a unique
attribute that can be configured.

Audio Output Enables you to check that your speakers and headphones are
working properly. Click the Test button to play test audio and
adjust the volume slider accordingly.

Microphone Level Enables you to confirm that your microphone is working correctly
and automatically adjusts it to an acceptable level.
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Preferences
The SunForum 3D Phone Preferences window (FIGURE 4-2) enables you to configure
incoming calls, telephone key, and cursor action. TABLE 4-7 describes the Preferences
configuration window.

FIGURE 4-2 SunForum 3D Phone Preferences Window
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● Choose Controls ➤ Preferences from the Phone menu bar.

TABLE 4-7 SunForum 3D Phone Preferences

Menu Item Description

Incoming Calls To enable type of ring for incoming calls, to set continuous or
number of rings, to set interval of rings in seconds, and to set the
ring through your speaker. Ring Through Speaker forces the ringer
to play through the external speaker on incoming calls. This enables
you to still hear the ringer if a headset is being used.

Telephone Key Enables you to assign a key which you can use to answer incoming
calls. You can select to use either the Control, Alt, Meta keys as your
function keys (for example, Alt-F5).

Cursor Provides the option in a call address field of blinking, steady, or no
cursor action.
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CHAPTER 5

Configuring Gateway Software

This chapter describes how to configure gateway software in order to place calls
over the network using the SunForum 3D Phone. This chapter includes:

■ Gateway Configuration File
■ Using SunForum 3D Phone Gateway

The gateway software enables you to connect to a designated server that provides
the phone line connections required to place calls over a network when using the
SunForum 3D Phone (see Chapter 4 “SunForum 3D Phone”). Once you have
updated your gateway configuration file, you can then call the gateway server
phone lines that connect your calls over the network.

Gateway Configuration File
To update your gateway configuration file:

1. Become superuser in a shell window.

2. Go to the SunForum 3D configuration directory:

3. Open the SunForum 3D system configuration file:

# cd /opt/SUNWdat/config

# vi system-config
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4. Locate the gateway settings portion of the configuration file and type the required
information.

In this example, the server name to be designated as the gateway server is Server 1
and 011# is the gateway prefix that might be required to place the call to a gateway
server.

5. Save the file, exit superuser, and start SunForum 3D Phone (see Chapter 4
“SunForum 3D Phone”).

The SunForum 3D Phone Controls menu now lists Gateway Mode.

6. Toggle Gateway Mode from the Controls menu.

The SunForum 3D Phone display changes to the gateway mode (FIGURE 5-1).

FIGURE 5-1 SunForum 3D Phone GUI in Gateway PBX Mode

!
! Gateway settings
!
H323.CallViaGateway: TRUE
H323.GatewayName: server1
H323.GatewayPrefix: 011#
58 SunForum 3D Software User’s Guide • July 2003



Using SunForum 3D Phone Gateway
FIGURE 5-2 shows an example of a networked system accessing a gateway server.
This example shows Sun Ultra workstations and Sun Ray systems connected to the
network. (For more information on SunForum 3D and Sun Ray systems, see
Chapter 6 “SunForum 3D on a Sun Ray System.” Sun Ray systems require Sun
Gatekeeper software to place calls over a wide area network.)

FIGURE 5-2 Gateway Network Example of Systems Running SunForum 3D

In this example, Sun workstations and Sun Ray systems are running SunForum 3D
and SunForum 3D Phone. Server 1 is a two-line gateway server and indicates the
phone lines required when making your calls to telephones. In order to place a call
over the network from your SunForum 3D Phone, you must first dial and connect
with the designated gateway server. (Sun Ray systems, as shown, go through the
Sun Ray server and Sun Gatekeeper to dial into the network. See “Sun Gatekeeper
Software” on page 62.)

To dial your SunForum 3D Phone into a network:

1. Start SunForum 3D Phone.

2. Update the SunForum 3D system configuration file.

See “Gateway Configuration File” on page 57.

LAN

Sun Ray

Ultra 10

Server 1

Ultra 10

Ultra 80

Sun Ray

Sun Ray server with
Sun Gatekeeper

Gateway
server

011# phone line
022# phone lineserver

PBX or
Telephone
company
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3. Choose Controls ➤ Gateway Mode.

The SunForum 3D Phone display changes to the gateway mode.

FIGURE 5-3 Gateway Mode

4. In the Call edit field (FIGURE 5-3), enter the number you are calling.

5. Press Return, or click the Place Call button, to make the connection.

Note – This is similar to calling the gateway directly by using extension 011# at the
dial tone, dialing the phone number (in this example, 46953) using DTMF.

Call edit field
60 SunForum 3D Software User’s Guide • July 2003



CHAPTER 6

SunForum 3D on a Sun Ray System

This chapter contains the following topics:

■ Sun Ray Requirements
■ Sun Gatekeeper Software

Sun Ray Requirements
Your Sun system server requires Sun Ray Server Software 1.2 to support
SunForum 3D software. Refer to your Sun Ray system documentation for installation
procedures of this software.

If Sun Ray 1.2 software patches for SunForum 3D are available, install these patches
instead of the procedure in the following “Sun Ray Libraries.”

Sun Ray Libraries

Note – The following instruction is only required when adding SunForum 3D
support to Sun Ray Server 1.2 software.

Two Sun Ray libraries are required for installations using Sun Ray clients. The
libraries are: libutmedia.so and libutadmin.so.

To install these libraries:

● Copy both libraries from the CD-ROM supplementary directory into the Sun Ray
library directory /opt/SUNWut/lib/.
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Sun Gatekeeper Software
SunForum 3D includes a H.323 gatekeeper that is required when using the
SunForum 3D software with a Sun Ray system. After installing the SUNWkeep
package, the gatekeeper option is available. The SUNWkeep package is installed with
the SunForum 3D software (see the SunForum 3D Software Installation Guide,
817-2669, for details).

A gatekeeper is software that is used for call control and management of voice, video,
and data networks. After the gatekeeper is installed and started, H.323 users
(including SunForum 3D users) register with it. IP addresses, along with H.323
aliases (names and numbers) are used; all calls are then routed through this central
location.

Though the gatekeeper software is required for using SunForum 3D on Sun Ray
systems, it is also required in a Sun workstation conferencing environment when at
least one Sun Ray system wishes to join the workstation environment.

The Sun gatekeeper provided with SunForum 3D only provides address translation
and aliasing with port numbers. For this reason, the daemon is called a “registrar.”
(Sun gatekeeper does not support bandwidth management.)

A gatekeeper requires that each registrant have a unique alias or aliases. It is
suggested that each SunForum 3D client use a telephone extension, email address, or
other unique name.

Starting Sun Gatekeeper

Note – Only one gatekeeper is allowed to run in any installation. You can install the
package in multiple locations, but only one server can start the gatekeeper daemon.

1. Decide which server will start the gatekeeper software.

2. Become superuser.
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3. Start Sun gatekeeper:

Note – If the SunForum 3D directory is not set in your path, type the correct path
name (for example, /opt/SUNWkeep/bin/registrar start).

Editing the System Configuration File
The SunForum 3D clients are set up for “auto discovery” of the gatekeeper server as
a default. This auto discovery uses IP Multicast and may not penetrate routers going
across subnets. In this case, you need to specify the gatekeeper by name. To specify
the gatekeeper server, you need to edit the configuration file:

1. Become superuser.

2. Go to your system configuration file:

3. Change the configuration file default settings.

The following example uses “GK-server” as your selected server name.

Note – If a gatekeeper becomes unavailable (either by system or network failure),
incoming calls will fail. You should choose a gatekeeper server to be a reliable
machine on a reliable subnet.

4. To view who is registered in the gatekeeper, type:

# registrar start

# cd /opt/SUNWdat/config/
# vi system-config

Default setting: for auto discovery
H323.GKDiscovery: 1
H323.GKName: None

Change to: for manual gatekeeper specification
H323.GKDiscover: 2
H323.GKName: GK-server

% registrar -q
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CHAPTER 7

Technical Information

This chapter contains the following topics:

■ SunForum 3D Architecture
■ SunForum 3D Conferencing Topology
■ SunForum 3D Whiteboard and Compatibility Mode
■ Using the SunForum Software Through a Network Security Mechanism
■ Using TrueType Fonts With SunForum 3D Software
■ Calling Into a Multipoint Control Unit
■ Calling Into Password-Protected Conferences
■ Optimizing Video Display
■ Solving Color Problems
■ SunForum 3D Software Support

SunForum 3D Architecture
The SunForum 3D architecture is based on the International Telecommunications
Union (ITU) protocol standards H.323, which defines a set of multimedia
communications and conferencing over packet-based networks. The H.323
architecture includes the foundations for audio (G.7xx standards), video (H.26x
standards), and data communications (T.120 family of standards). T.120 contains a
series of communication and application protocols and services that provide support
for real-time, multipoint data communications.

The G.7xx standards contain G.711, G.723, and G.729 for audio.

The H.26x standards contain the H.261 and H.263 standards for video compression.

The T.120 architecture is a multilayered design, with defined protocols and service
definitions between layers. The upper-level layers require the lower-level layers of
the architecture to function.
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The lower-level layers (T.122 through T.125) specify an application-independent
mechanism for providing multipoint data communication services to any application
that can use these facilities.

The upper-level layers define protocols for specific conferencing applications, such
as T.126 for viewing and annotating still images, T.127 for multipoint file transfer
and T.128 for application sharing.

Applications that use these standardized protocols can coexist in the same
conference with applications that use proprietary protocols. In fact, SunForum 3D
software users can use a mix of standardized and nonstandardized protocols.

SunForum 3D Conferencing Topology
In a SunForum 3D conference, the topology and hierarchy of the connections is
conforming to the topologies for H.323 conferences and T.120 conferences. In a
multipoint H.323 conference, one endpoint is the Multipoint Controller, and every
other endpoint has a single direct connection to that Multipoint Controller. In a
point-to-point H.323 conference, there is no Multipoint Controller, and the two
endpoints simply have a direct connection. In the T.120 conference there is a more
complicated hierarchal topology, and this determines the behavior of the
connections. We will describe this in more detail.

In a T.120 conference, a hierarchy exists where the person starting the conference is
at the top and those joining the conference are underneath. Where a caller is in this
topology affects the conference connection of those who joined that particular caller
in the conference. This is illustrated in the following figure.

In this example,

■ If B hangs up, all those that B called are disconnected as well, leaving A and D in
the conference.

■ If D hangs up, only D is disconnected, leaving A, B, and C in the conference.

■ If A hangs up, the entire conference ends.
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FIGURE 7-1 T.120 Conference Hierarchy

The way you create a conference is to establish one system, the conference host, for
conference participants to call in to. A star (as in a star networking protocol)
topology is created where anyone except the host can leave the conference
independently. (This host can actually be a dedicated conference server machine,
supporting several conferences simultaneously.)

SunForum 3D Whiteboard and
Compatibility Mode
There are several types of whiteboards available through SunForum 3D:

■ SunForum 1.0 mode, which enables you to interoperate with certain collaboration
software running on PCs. This is chosen through the menu system Options ➤ Tool
Settings ➤ SunForum 1.0 mode.

■ True T.126 mode, which enables you to interoperate with any computer system or
appliance using the T.126 protocol, regardless of platform software. This is chosen
by setting the T.126 mode and T.120 buttons in the Options ➤ Tool Settings...
panel.

Caller A

Caller B

Caller A Caller A

Caller DCaller C

Caller B Caller B

Caller C

A calls B B calls C (or C calls B) A calls D (or D calls A)

A begins conference
with B

C joins conference D joins conference
through Athrough B
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■ NetMeeting 3.x style T.126 mode, which enables you to interoperate with the
NetMeeting 3.x whiteboard. This is chosen by setting the T.126 mode and
NetMeeting 3 buttons in the Options ➤ Tool Settings panel.

Note that the choice of Compatibility mode in the Options ➤ Tool Settings... panel
affects other areas of SunForum 3D as well. The most visible difference between the
two modes is in Application Sharing.

■ T.120 mode, complies with the T.120 standard, and in this mode, SunForum 3D
should interoperate with other systems using the T.120 protocol stack. This mode
should be used for interoperating with NetMeeting 2.x.

■ NetMeeting 3 mode, which enables you to interoperate with certain collaboration
software running on PCs (NetMeeting 3.x in particular), and makes Application
Sharing resemble that of NetMeeting 3.01.

The selection of compatibility mode is made through the Options ➤ Tool Settings.
menu item.

Using the SunForum Software Through a
Network Security Mechanism
If you are connected to the internet through a network security mechanism, or
firewall (as is usual in most corporate/LAN environments), you can use SunForum to
communicate with others located inside the firewall.

Note – SunForum 3D application sharing does not work across firewalls.

To enable full external communication, the firewall (that is, network security
mechanism) needs to be set up to allow communication through certain ports (that
is, the ports need to be “opened up”):

■ Ensure your workstation has its default gateway set to the internal address of the
network security mechanism computer.

■ Configure the network security mechanism to enable primary TCP connections
over the following IP ports:

■ 389 – for communication with Internet Locator Servers, if this is desired

■ 1503 – for T.120 data, i.e. application sharing, file transfer, whiteboard, and chat

■ 1718 (UDP) – for locating H.323 gatekeepers (required only if automatic
gatekeeper discovery is used)

■ 1719 (UDP) – for communication with H.323 gatekeepers
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■ 1720 (TCP) – for H.323 call setup

■ Ensure that the firewall is configured to enable the use of dynamic IP ports (both
TCP ports for H.323 call control, and UDP ports for audio and video streams).
This may require the use of a special H.323-capable firewall product.

■ Configure the firewall to map internal IP addresses to external Internet addresses.
This is not possible with all firewalls. If your firewall cannot do this, you will be
able to call out from inside the firewall, but you will not be able to receive
incoming calls from computers outside the firewall.

If you are unsure whether you are connecting to the Internet by means of a network
security mechanism, consult your system administrator or Internet service provider.

Using TrueType Fonts With
SunForum 3D Software
SunForum 3D software is designed to take advantage of a TrueType font server if
one is installed on your system (or accessible to your system across a local area
network). Solaris 2.6 operating environment and subsequent compatible versions
support TrueType fonts.

With a TrueType font server installed, SunForum 3D software has more fonts in
common with PC systems, resulting in better quality output and improved
performance in sharing sessions involving both UNIX and PC systems.

Calling Into a Multipoint Control Unit
SunForum 3D software supports Multipoint Control Unit (MCU) hosted conferences,
and has been tested with some of the MCUs available at the time of this release.

When calling an MCU, specify the address of the MCU as normal. If SunForum 3D
software detects that the machine called is currently hosting more than one
conference, you will be prompted to specify which conference to join. Also, see
“Calling Into Password-Protected Conferences.”
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Calling Into Password-Protected
Conferences
You cannot create a password-protected conference with SunForum 3D software.

When you call into a conference that has been designated as password-protected,
SunForum 3D software prompts you to specify the password.

Some T.120 implementations incorrectly list conferences as password-protected, even
when no password has been specified. In this case, just click OK without specifying
a password; the conference will be established as normal.

Optimizing Video Display
For better performance of video displays, you need to increase the shared memory
pool size to at least 16 Mbytes and the maximum number of shared memory
segments per process to at least 32. To do this,

1. Add the following line to the /etc/system file:

2. Reboot your system.

See the SunForum 3D Software Installation Guide, 817-2669, for details.

Solving Color Problems
If you experience problems with color operations (such as text highlighting) with
shared PC applications, try the following:

■ If your X Server is running with a Static or DirectColor default visual, switch it to
run with PseudoColor or GrayScale. See your X Server documentation for
information on how to do this.

■ Close any local color-intensive X applications (such as bitmap editors and web
browsers) to make more colors available for the SunForum 3D software.

set shmsys:shminfo_shmmax=16777216
set shmsys:shminfo_shmseg=32
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SunForum 3D Software Support
If you have any problems installing or using the SunForum 3D software:

■ Refer to the written or online documentation included with the software.

■ Read the rest of the online help, especially the README page, for a list of known
problems with this release.

■ If you are unable to find an answer, contact your Sun representative and have the
following information available:

■ Your system configuration (system hardware, operating system version,
graphics hardware)

■ A complete description of what you were doing when the problem occurred

■ Any core file generated (check the /opt/SUNWdat directory)

■ The contents of any error log files generated (look for hostname.trc1 and
hostname.trc2, located in the $HOME/.sunforum/trc directory)
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Index
A
application sharing, 14, 17, 43
audio and video conferencing

conference manager icons, 21
configuring, 22
controlling audio in a conference, 24
controlling video image in multipoint

conference, 26
controlling video image in point-to-point

conference, 27
controlling video image over a conference, 24
displaying remote video in point-to-point

conference, 27
types, 20

C
chat, using, 19
collaborating applications, 18
color problems, solving, 70
compression/decompression (CODEC), 16
conference hierarchy, 67
conference manager, 7
configuration files, SunForum 3D, 46

D
directories, using, 11
directory list, refresh, 13
directory server

calling user on directory list, 14
changing directory information, 12
logging in automatically, 13
logging off, 12
logging on, 12
refreshing directory list, 13
removing name, 13
using directories, 11

drawing graphical objects, 31

F
file transfers, 18

H
help, online, 3
hierarchy, SunForum 3D topology, 66

I
information window, 6

M
making a call, 14

manual connections, 15
manual connections, 15
MCU, multipoint conferencing unit, 69
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menus
SunForum 3D conference manager, 8
SunForum 3D phone, 49

multipoint conferencing unit (MCU), 69

N
network security mechanism, using SunForum 3D

through, 68

O
online help, 3

P
password-protected conferences, 70
phone display, 48
place call window, 15

R
refreshing directory list, 13

S
shared clipboard, 19
sharing applications, 14, 17, 43
starting SunForum 3D, 5
starting SunForum 3D phone, 47
SunForum 3D, 3

3D toggle button, 44
allow frame skip (rec), 45
allow frame skip (send), 45
application sharing, 17, 43
audio and video conferencing, 20, 21
chat, 19
compression/decompression (CODEC)

formats, 16
conference manager, 6, 7, 8
configuration files, 46
control panel, 43
higher speed, better quality slider, 44

introduction, 1
making a call, 14
menus, 8
notes on using, 2
overview of 3D feature, 41
starting, 5
starting phone, 47
whiteboard, 28

SunForum 3D phone
menus, 49
phone display, 48
starting, 47

T
technical tips, 65

multipoint conferencing unit, 69
network security mechanism, 68
password-protected conferences, 70
TrueType fonts, 69

topology, 66
transfer data, shared clipboard, 19
transferring files, 18
TrueType fonts, 69

U
using directories, 11

W
whiteboard

drawing graphical objects, 31
highlight text and images, 33
locking, 36
moving and deleting objects, 32
options panel, 31
saving and loading contents to disk, 37
selecting and capturing windows, 34
SunForum 1.0 mode, 28
T.126 mode, 28
tool panel, 30
using, 28
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