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Preface

This manual describes how to install and use the SunForum™ data conferencing

software with your Sun Workstation™. It is for users who want to collaborate over

intranets and the Internet with both UNIX® and PC-based participants through data

conferencing.

How This Book Is Organized

Chapter 1 describes the SunForum product.

Chapter 2 discusses installation requirements and procedures for installing

SunForum.

Chapter 3 describes how to use SunForum.

Chapter 4 provides technical information about SunForum.

Using UNIX Commands

This document does not contain information on basic UNIX commands and

procedures such as shutting down the system, booting the system, and configuring

devices.

See one or more of the following for this information:

■ Solaris 2.x Handbook for SMCC Peripherals

■ AnswerBook™ online documentation for the Solaris™ 2.x software environment
xi



■ Other software documentation that you received with your system

Typographic Conventions

Shell Prompts

TABLE P-1 Typographic Conventions

Typeface Meaning Examples

AaBbCc123 The names of commands, files,

and directories; on-screen

computer output.

Edit your .login file.

Use ls -a to list all files.

% You have mail .

AaBbCc123 What you type, when

contrasted with on-screen

computer output.

% su
Password:

AaBbCc123 Book titles, new words, or

terms; words to be emphasized;

command-line variable: replace

with a real name or value.

Read Chapter 6 in the User’s Guide.

These are called class options.

You must be root to do this.

To delete a file, type rm filename.

TABLE P-2 Shell Prompts

Shell Prompt

C shell %

C shell superuser #

Bourne shell and Korn shell $

Bourne shell and Korn shell

superuser

#
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Sun Documentation on the Web

The docs.sun.com web site enables you to access Sun technical documentation on

the Web. You can browse the docs.sun.com archive or search for a specific book

title or subject at:

http://docs.sun.com

Sun Welcomes Your Comments

We are interested in improving our documentation and welcome your comments

and suggestions. You can email your comments to us at:

docfeedback@sun.com

Please include the part number of your document in the subject line of your email.
xiii
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CHAPTER 1

Introduction to SunForum

SunForum 3.0 software is a conferencing product for Sun workstations. It is based on

the T.120 and H.323 standards, which enables your Sun system to conference over

intranets and the Internet with other T.120 and H.323 products, such as Microsoft

NetMeeting and PictureTel LiveShare Plus, version 4.0.

SunForum Features
SunForum features enable you to:

■ View and control applications shared from other UNIX or PC machines that are

based on the T.120 protocol.

■ Share local Solaris applications, which can be viewed and controlled by any

conference participant.

■ Exchange ideas and data using the whiteboard, clipboard, chat, and file transfer

facilities.

■ Use audio and video communications via the H.323 protocol.

SunForum and ShowMe 2.0.1
Differences
The ShowMe™ 2.0.1 product is not T.120 nor H.323 compliant and will not work

with SunForum software. ShowMe 2.0.1 is an X Window multiplier that creates

multiple copies of a window and sends them across the network. The SunForum

software, however, is an extension of the X Server.
1



The key differences are:

■ Both products have whiteboards; however, SunForum features also include the

T.126 protocol whiteboard, Internet Locator Server (ILS), a clipboard, chat, and

file transfer capability.

■ The SunForum software intercepts mouse and keyboard input, sends the output

to a frame buffer, and translates it into the T.128 application-sharing protocol.

■ With SunForum software, direct graphics access (DGA) applications can be

shared.

■ The SunForum software enables you to view PC applications on a Sun system and

X Server applications on a PC.

■ Because SunForum architecture involves X Server protocol layers, when you are

controlling an application during a conference, you have control of the entire

desktop of the host.

■ The ShowMe 2.0.1 product is not H.323 compliant and, therefore, will not work

with SunForum software. ShowMe was developed prior to the International

Telecommuncations Union (ITU) standard and cannot use the control and

capabilites exchange required for the H.323 protocol. In addition, the video

compression/decompression format for ShowMe is CellB. This is different from

the SunForum formats, H.261 and H.263, which requires less bandwidth while

achieving higher quality.

Online Help
You can read information about SunForum online. You can access help from the

Help menu located on any SunForum menu bar.
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CHAPTER 2

Installing SunForum

This chapter contains the following topics:

■ Installation Requirements

■ SunForum CD Directories

■ Installing SunForum

■ Online Documentation

■ Accessing the English and Localized Documentation

You must be able to become superuser to install SunForum. If you do not know the

root password of the system on which you are installing SunForum, contact your

system administrator.

Installation Requirements
To install SunForum, you must have the following hardware and software

configuration:

■ Solaris 2.6 or Solaris 7 operating environment, or a subsequent compatible version

■ 20 Mbytes of available disk space

■ Sun Ultra™ 1 workstation, or more advanced Sun workstation

■ PCI Multimedia Kit, for video capabilities (SunForum does not support

SunVideo)

■ A TCP/IP connection

Note – If there is a network security mechanism between the two machines, T.120

data uses port 1503 and the Internet Locator Server (ILS) uses port 389. Contact your

system administrator.
3



SunForum CD Directories

Installing SunForum
You must remove any previous releases of SunForum before installing new software

packages.

▼ To Remove Previous Software Releases

1. Log out of (exit) the window system.

2. Log in as superuser at the command line prompt.

TABLE 2-1 SunForum CD Directories

Directory Name Description

Copyright U.S. version of copyright

FR_Copyright French version of copyright

Docs HTML and PostScript™ user guide files

Product Contains the SunForum packages: SUNWdat, SUNWdatu, SUNWxxdat.

TABLE 2-2 SunForum Software Package Directory Location

SunForum Package Directory Location

SUNWdat /opt

SUNWdatu /usr/openwin
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3. Remove previous SunForum software releases by typing:

If the pre-release xdcs version of this product is installed, type:

▼ To Install SunForum

1. Remove any previous release of SunForum.

2. Log in to the windowing system (if you are not already in it).

3. Become superuser in a shell window.

4. Insert the SunForum CD into the CD-ROM drive connected to your system.

■ If your system is running Volume Manager, it should automatically mount the

CD-ROM to the /cdrom/sunforum_3_0 directory.

■ If your system is not running Volume Manager, mount the CD-ROM as follows:

5. Use pkgadd to add the SunForum packages.

■ To add the English version only, type:

■ To add the localized SunForum packages, type:

# pkgrm SUNWdatr SUNWdat SUNWdatu

# pkgrm xdcs

# mkdir -p /cdrom/sunforum_3_0
# mount -F hsfs -r /dev/dsk/c0t6d0s2 /cdrom/sunforum_3_0

# pkgadd -d /cdrom/sunforum_3_0/Product SUNWdat SUNWdatu

# pkgadd -d /cdrom/sunforum_3_0/Product SUNWdat SUNWdatu SUNWxxdat
5



Where the last package entered is the localization package and xx indicates the

specific language identifier (see the following table).

Note – Other Asian encodings (non-EUC) may be available. Check your CD-ROM

for additional packages.

During installation, pkgadd may issue a warning prompt and ask whether you want

to continue with the installation; type y for yes.

1. After all SunForum packages are installed, type q to quit pkgadd .

2. Log out of (exit) your workstation. This will restart your X Server.

3. Log in to your window system as user at the main prompt.

4. (Optional) Set the directory path for SunForum in a file (.profile or .cshrc
files) or shell.

■ You can put this command at the end of a .cshrc file or, when using a csh
environment, type it at your user prompt:

■ If you choose to run a sh or ksh environment, type:

TABLE 2-3 Localized Package Names

Language Package Name

French SUNWfrdat

German SUNWdedat

Italian SUNWitdat

Spanish SUNWesdat

Swedish SUNWsvdat

Japanese (ja-EUC) SUNWjadat

Korean (ko-EUC) SUNWkodat

Simplified Chinese (zh-EUC) SUNWcdat

Traditional Chinese (zh_TW-EUC) SUNWhdat

% set path = ($path /opt/SUNWdat/bin)

% path=$path:/opt/SUNWdat/bin
% export path
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5. Start sunforum to verify installation.

■ To start SunForum if you added SunForum to your user file, type:

■ To start SunForum as an absolute file name (not from your user path file), type:

If you installed SunForum in a directory that is not the default (/opt/SUNWdat ), you

must alter the directory paths in these steps to reflect the correct directory.

Online Documentation

▼ To View theSunForum 3.0 Software User’s Guide
Online

1. Choose Help ➤ Help Topics from any SunForum window.

This opens the HTML help page.

2. Click Online Docs at the title bar.

Accessing the English and Localized
Documentation
The CD contains the localized SunForum 3.0 Software User’s Guide in the following

languages:

■ English

■ French

■ German

■ Spanish

■ Italian

% sunforum

% /opt/SUNWdat/bin/sunforum
7



■ Swedish

■ Japanese

■ Korean

■ Simplified Chinese

■ Traditional Chinese

These language versions are contained in the /cdrom/sunforum_3_0/Docs/HTML
directory in the following files:

● To view a manual that is in HTML format, use a web browser and type the
following in the address field:

Where directory is the directory that contains the HTML files.

TABLE 2-4 Names for Translated Documents

Language Directory Name File Type

English C/ HTML file

French fr/ HTML file

German de/ HTML file

Spanish es/ HTML file

Italian it/ HTML file

Swedish sv/ HTML file

Japanese ja/ HTML files

Korean ko/ HTML files

Simplified Chinese zh/ HTML files

Traditional Chinese zh_TW/ HTML files

file://cdrom/ sunforum_3_0 /Docs/HTML/ directory
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CHAPTER 3

Using SunForum

This chapter contains the following topics:

■ SunForum Basics

■ Using Directories

■ Using the SunForum Software

■ Using the SunForum Audio and Video

■ Using the SunForum Whiteboard

SunForum Basics
■ To Start the SunForum Software

■ SunForum Menus

▼ To Start the SunForum Software

● Type the following at your system prompt:

Note – If the SunForum directory is not set in your path, enter the correct path

name (that is, /opt/SUNWdat/bin/sunforum ). See Chapter <$elemparanumonly2

for more information.

% sunforum
9



The SunForum conference manager is displayed. When you start SunForum for the

first time, however, the My Information window is displayed.

FIGURE 3-1 My Information Window

● Type your name and email address in the My Information window.

Note – You must enter your name and email address. You cannot collaborate unless

this minimum information is entered.

The next time you start the SunForum software, the My Information window will

not display automatically. However, you can change the information in the My

Information window anytime by choosing Call ➤ Change My Information to open

the information window.

When you close the My Information window, the SunForum conference manager is

displayed as the active window.
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FIGURE 3-2 SunForum 3.0 Conference Manager

SunForum Menus
There are four menus on the SunForum menu bar: Call, View, Tools, Options, and

Help.

Note – You can also use the SunForum conference manager buttons to access most

of the functions in the Call, View, and Tools menus. See Using the SunForum

Software for more information.
11



Call Menu

View Menu

You can use the View buttons to change these listings viewed in the SunForum

conference manager.

TABLE 3-1 Call Menu

Menu Description

Place Call To place a call to an indicated address. You can also click the

Call button.

Stop Placing Call To cancel an in-progress call request.

Host Conference To start a conference.

Hang Up To end your call. (Same as clicking the Hang Up button.)

Do Not Disturb To block incoming calls. You may, however, call out.

Create SpeedDial To create speed dial files for use in your address book or for

exchange with other users.

Run In Background To allow SunForum to continue running in the background

when you exit.

Log Onto Directory Server To log in to a directory server. You will be prompted for the

server name.

Change My Information To make changes to your profile information.

Address listing To call recently accessed addresses.

Exit To exit or place in background the current SunForum session.

TABLE 3-2 View Menu

Menu Item Description

Directory To view the directory server. It lists who you can conference.

Address Book To display addresses that you have conferenced and added to your

address book.

Call Status Use during a call to view the status of conference participants and

the status of the application sharing, whiteboard, and chatting

features.
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Note – To remove an item from the Address Book and History lists, select the item

and press the Delete key.

History To list the status of received calls.

Refresh Directory To query the directory server for an immediate update of the

directory listings.

Call Information To view audio/video bandwidth usage in the current call.

TABLE 3-2 View Menu

Menu Item Description
13



Tools Menu

TABLE 3-3 Tools Menu Descriptions

Menu Item Description

Video To select video windows to be displayed.

Share Application To share your applications with others on the call. A submenu lists

the shareable applications you have running on your desktop.

Share To select an application window on your desktop for sharing. (Same

as clicking the Share button.)

Unshare To unshare the application. (Same as clicking the Unshare button.)

Collaborate To shift a shared application from view-only to collaborate. When

you collaborate an application, you enable others to have control of

it. (Same as clicking the Collaborate button.)

Send File To select a file to send to everyone in the conference. (Same as

clicking the Send button.)

Cancel All Sends To cancel sending of files.

Cancel All Receives To cancel receipt of files.

Shared Desktop

Viewer

To show an overview of all user desktops and the location of shared

applications.

Collaborate To shift a shared application from view-only to collaborate. When

you collaborate an application, you enable others to have control of

it. (Same as clicking the Collaborate button.)

Send File To select a file to send to everyone in the conference. (Same as

clicking the Send button.)

Cancel All Sends To cancel sending of files.

Whiteboard To start whiteboard graphical application. The whiteboard

automatically starts on other user systems in the conference. (Same

as clicking the Whiteboard button.)

Chat To start the chat application. The chat window automatically starts

on other user systems in the conference. (Same as clicking the Chat

button.)

Share Clipboard To copy and paste clipboard data between systems.
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Options Menu

Help Menu

You can access help from the Help menu, located on the SunForum menu bar.

Choose Help → Help Topics for online SunForum information.

Note – The Help Topics menu is on each of the SunForum window menu bars.

Using Directories
An Internet Locator Server (ILS) directory contains an address listing of people who

are currently using SunForum, Microsoft NetMeeting, or ILS-compatible

conferencing. This makes it easy to locate and connect to other people, either by

simply browsing to see who is currently listed or by looking up people by their

email address.

To log in to a directory, you must specify your own details, including name, location,

and email address. You are prompted for these details the first time you run

SunForum. You can choose whether to list these details for access by everyone; if

you do not, then only those people who know your email address will be able to call

you via the directory.

This section contains the following topics:

■ To Change Your Directory Information

■ To Log in to a Directory Server

TABLE 3-4 Options Menu Descriptions

Menu Item Description

Call Settings To configure SunForum options for handling calls.

Tool Settings To configure general SunForum options.

Audio/Video

Settings

To configure Audio/Video conference attributes.

Audio/Video Device

Settings

To configure the Audio input and output devices and Video input

device.
15



■ To Refresh the Directory List

■ To Automatically Log In to a Directory Server at Startup

■ To Remove Your Name from the Directory Server

■ To Call Someone in the Directory List

■ To Call Someone at a Using Their Email Address

▼ To Change Your Directory Information

1. Choose Call → Change My Information.

The fields that you need to fill in are:

■ First Name and Last Name. This is the name used to identify you in a conference.

■ email address. This is used to identify you when you are logging on at a directory

server.

■ Category. This is used by ILS servers to narrow down the list of names they see

when querying or choosing a directory server.

2. Change the details as required and click OK.

The new details will be used the next time you log in to an ILS server. If you are

currently logged in to an ILS server, your information is automatically updated.

▼ To Log In to a Directory Server

1. To view the directory listing, choose Call → Log Onto Directory Server.

2. Enter the name of the directory server you want to log in to and click OK.

When SunForum has successfully logged in to the directory server, the server is

automatically queried for other users also logged in to that directory.

Public directory servers that you can log in to may include:

■ ils.microsoft.com

■ ils1.microsoft.com

■ ils2.microsoft.com

■ ils3.microsoft.com

■ ils4.microsoft.com

■ ils5.microsoft.com

■ ils.four11.com

■ ils.business.four11.com
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■ ils.family.four11.com

To log out from a directory server: choose Call → Log Off From Directory Server.

▼ To Refresh the Directory List

● Choose View → Refresh Directory.

This option can be selected only when the directory list is displayed.

▼ To Automatically Log in to a Directory Server at
Startup

1. Choose Call → Change My information.

2. Select “At startup, log in to the directory server.”

3. Type the name of the directory server you want to log in to in the Server Name
field.

The next time you start SunForum, it will log in to the directory server you specified.

▼ To Remove Your Name from the Directory Server

1. Choose Call → Change My Information.

2. Select “Do not list my name when logged in to the directory server.”

The next time you log in to a directory server, your details will not be visible to users

browsing the directory.

If you are currently logged in and your name is displayed when you select this

option, SunForum automatically updates your entry at the directory server so that

your name is not displayed.

To Call Someone in the Directory List

You can call a user shown in the directory list by double-clicking on that entry in the

directory view.
17



Note – If Add to address book in the Place Call window (Call ➤ Place Call) is

selected, any users you call via the directory list will be added to the address book

list.

▼ To Call Someone at a Server Using Their Email Address

The SunForum software enables you to call someone who is logged in to a directory

server by specifying their email address.

● Type the name of the directory server they are logged in to and the user email
address, separated by a slash (/).

ils.four11.com/bob@acme.com

The SunForum software queries the specified directory server for a user with the

email address you entered. If the user is logged in to the directory server, SunForum

tries to start a call with them.

Using the SunForum Software
Refer to the SunForum conference manager as you read the procedures in this

section.

This section contains the following topics:

■ To Make a Call

■ To Share Applications

■ To Collaborate Applications

■ To Transfer Files

■ To Chat

■ To Transfer Data Using the Shared Clipboard

Manual Connection

1. Choose Call → Place Call, or click the Call button.

The Place Call window is displayed. The Place Call window enables you to join a

conference.
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2. Type the address with which you want to conference.

There are three types of addresses: IP (internet protocol), machine name (with DNS

handler), and ILS address (server and email address).

Note – There are currently no ILS server products for UNIX.

In the Place Call window, you can add the address you are calling to your Address

Book. You can also specify a named meeting to join (for example, if you are calling a

conference server).

3. Click OK.

The view will shift to Call Status if the connection is made, or a prompt will inform

you why the attempt was unsuccessful.

To Make a Call

Quick Connection

1. Choose View → Address Book, or click the Address Book button.

2. Double-click on the address book entry that you want to connect.

You can also simply click the Directory or History view buttons and double-click the

entry you want to connect.

Ending a Connection

● Choose Call → Hang Up, or click the Hang Up button.

This ends your participation in a conference.

Note – When you hang up, you may also disconnect others from the conference.

This includes all the participants you invited into the conference, or anyone who

called you. If you initiated the conference, the whole conference will be terminated.

You will get a warning message if you are about to disconnect others by hanging up.

▼ To Share Applications

When you are using the SunForum software, the applications on your entire desktop

screen can be shared with other conference participants. This results in the

following:
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■ If a controlling user within a SunForum conference moves an application window

on their desktop, it is actually moved on the host desktop. Other applications on

the host desktop may obscure the window being shared. Also, if a portion of the

shared application window is obscured on the host desktop, that same portion is

also obscured on the controlling user’s desktop.

■ Sun and PC desktops in a SunForum conference may have different desktop

screen sizes. When controlling users move shared windows around on their

desktop, the windows may move outside the viewing area of a user in the

conference with a smaller desktop screen. A participant with a smaller desktop

screen can move (scroll) the active (view) region of the screen by moving the

mouse pointer to that area of the desktop where the entire application can be

viewed. (To set the scrolling feature, choose Tools → Options from the SunForum

conference manager.)

1. While in a conference call, choose Tools → Share, or click the Share button.

Or, choose Tools → Share Application to select the application you want to share.

2. Place your mouse pointer (now a hand symbol) over the desktop application
window you want to share.

3. Click anywhere in that application window.

All conference participants can now see that application on their system as if it were

running locally. SunForum can share almost any application, including terminal

windows, word processors, and CAD design packages. Exceptions include

SunForum and applications using certain X extensions that are not supported.

Note – The window is labeled with the name of the user who shared the

application. At this point, only that person can control it; others can only view the

output on their desktop.

1. Choose Tools → Unshare, or click Unshare, to stop sharing the application.

2. Click on the application window that was being shared.

Now, only you can view and control that application.

▼ To Collaborate Applications

Once an application is being shared, the Collaborate button is activated and you can

open the application to conference participants for collaborative use.

1. Share an application (see To Share Applications).

2. Choose Tools → Collaborate, or click Collaborate.

The shared application that was view-only by the conference participants is now

open for collaboration.
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When you collaborate your shared application, other conference participants can

take control. For a conference participant to take control of the shared application,

they only need to click on that application on their desktop.

Note – When another conference participant clicks the shared application window

and is then in control of it, that person effectively take over your mouse and

keyboard. Only one user can be in control at a time. Any other user, including the

host, can gain control by just clicking the mouse.

● To stop collaborating, click Collaborate again.

The shared application is returned to view-only for the conference participants.

▼ To Transfer Files

1. Choose Tools → Send File, or click Send File.

The Select a File to Send window is displayed.

2. Go to the directory and select the file you want to send.

3. Click OK.

The file is sent to all participants in the conference.

Files sent to you by other conference participants are received automatically. While

the file is being received, another window shows the progress of the transfer. When

the transfer is complete, the file is saved. The default directory for saving files is

/tmp . To change the default directory where files are saved, choose To Options.

▼ To Chat

1. Choose Tools → Chat, or click the Chat button to start the chat application.

This also automatically starts the chat application on other user systems in the

conference.

2. Select the recipient of your message.

■ To send to all participants, choose Send to → Everyone in conference.

■ To send to a single participant, choose Send to → user name.

The names of those conference participants who are running chat are listed in the

Send to menu.

3. Type your message in the message field and press Return.

The message is displayed in your chat window and on the other participants’ chat

windows.
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You can list the date, time, and name with the message. To do this, click View on the

Chat menu bar and select or deselect your choice.

You can save chat sessions to file as a record of the conference. You are prompted to

do so when you exit the Chat window.

Note – Though other conferencing products may have T.120 text chatting capability,

they may not necessarily work with SunForum chat. Check the chatting status in the

SunForum conference manager to see who is running chat.

▼ To Transfer Data Using the Shared Clipboard

1. Ensure that Shared Clipboard is enabled on both systems.

2. Choose Tools → Shared Clipboard.

The Shared Clipboard menu item should be active (checked).

Note – To automatically enable Shared Clipboard, choose Tools → Options.

3. Select text from an application (for example, a Command Tool) on one system.

4. Choose Edit → Copy.

5. In an application (for example, a text editor) on another system, choose
Edit → Paste.

Using the SunForum Audio and Video
The H.323 audio and video communications protocol is the standard for audio/

video conferencing. SunForum conforms to the H.323 standard.

This section contains the following topics:

■ Types of Audio/Video Conferences

■ Configuring Audio and Video Capabilities

■ To Set Audio/Video Options

■ To Set Audio/Video Device Options

■ Controlling Audio Within the Conference

■ Controlling Your Video Image Over a Conference

■ Controlling Video Image Within a Multipoint Conference
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■ Controlling Video Within a Point-To-Point Conference

Types of Audio/Video Conferences

Conferencing products may provide one of three different levels of audio/video

support.

■ Multipoint - You can see and hear many people in the call at the same time. Each

person’s video image appears in a separate window, and the audio information

from each person is mixed together so that you hear a single audio channel

including everyone’s voice. Microsoft NetMeeting 2.0 and 2.1 do not support

multipoint audio and video.

■ Point-to-point - You can see and hear one other person in the call at a time, and can

switch from one to another. Microsoft NetMeeting 2.0 and 2.1 provide point-to-

point audio and video.

■ No audio/video - You cannot see or hear other people in the conference. Users of

conferencing products that do not support audio/video often set up a telephone-

based conference call in parallel with the SunForum conference.

SunForum provides multipoint support, but can also operate in point-to-point mode

or without audio/video to support conferences with other products:

■ If everyone in the conference is using a product that supports multipoint audio/

video, you can use either multipoint or point-to-point. (You may prefer to use

point-to-point if people are familiar with products that operate only in this

mode.)

■ If some people are using a product that supports only point-to-point audio/

video, you should use point-to-point. SunForum can be configured to force a

conference to use point-to-point thusly insuring that the products that only

support point-to-point can establish audio/video links.

■ Anyone who is using a product that does not support audio/video can still

participate in the conference, but will not be able to see or hear other people. You

can still use audio/video to communicate with anyone in the conference who has

support for it.

When you start a call to another person, SunForum initially creates a point-to-point

link for audio/video support regardless of the capabilities of the other product.

Should a third person join the conference, their capabilities will determine if the

conference becomes a multipoint conference or remains a point-to-point conference.

Once a conference has become a multipoint conference, products that do not support

multipoint will not be able to establish an audio/video link in the conference.

If you want to start a conference explicitly in point-to-point mode, you can specify

this in the Audio/Video Settings dialog box. See To Set Audio/Video Device

Options for more information.
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In the current call window, the audio/video icons indicate an audio/video link to a

participant in the conference.

FIGURE 3-3 Conference Manager Audio and Video Icons
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Configuring Audio and Video Capabilities

▼ To Set Audio/Video Options

● Choose Options → Audio/Video Settings.

Or, choose View → Audio/Video Settings in the View window.

TABLE 3-5 Audio and Video Options

Menu Item Description

Use point-to-point

Audio/Video

connections

This option allows you to only use point-to-point connections for

your audio/video conferences. This guarantees that users who only

support point-to-point will be able to utilize Audio and Video as

part of the conference.

Send image size Specify the size of your video image as it appears to other people.

This also determines the size of the My Video window on your

screen. The range of window sizes that you can use depends on the

capabilities of the conferencing products being used by other

people. If you are already in a conference, one or more of these

options may be grayed if other people are using conferencing

products that cannot support them. You may find that the window

size changes when you start a call, or when another person joins or

leaves the conference. This is because another person may not be

able to use the size that you originally selected; SunForum

cooperates with the other conferencing products to select the best

compromise between the requirements of everyone currently in the

conference.

I prefer to receive... This option allows you to tune the picture quality of the video

images of other people as they appear on your screen.

- Move the slider towards Faster Video to view the video with

more updates per second. This gives a smoother display, but

reduces the resolution of the image.

- Move the slider towards Better Quality to view the video with

higher resolution. This gives a better-quality video image, but may

mean that the video appears less smooth.
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▼ To Set Audio/Video Device Options

● Choose Options → Audio/Video Device Settings.

Set Video quality

based on my

network speed of

This option allows you to provide SunForum with the bandwidth of

the network connections you will be using for the conferences.

SunForum software uses the information to configure the audio and

video processing to sustain the conference in an optimal manner.

Automatically send

video at the start of

each call

If this option is selected, your video image is automatically sent to

other people as soon as you start or accept a call (although their

conferencing product may not be set up to display it immediately).

You can preview your video image if you want to check how it

appears before you start the call.

If this option is not selected, your video image is not displayed to

other people until you press the Play button in the My Video

window to start it.

Automatically

receive video sent by

others

If this option is selected, video images of other people appear on

your screen as soon as they start to send video to other users. If this

option is not selected, a blank window appears on your screen for

the remote user. The video image is not displayed on your screen

until you press the Play button in the video display window to start

it.

TABLE 3-6 Audio and Video Device Options

Menu Item Description

Audio Device Allows you to choose the audio device to use for conferencing and

the attributes associated with that device. First you select the audio

device you want to use from the menu and then you push the

“Settings” button to configure the device specific attributes. Each

device is a unique attribute that can be configured.

Video Device Allows you to choose the video device to use for conferencing and

the attributes associated with that device. One choice is “None” for

systems without video capture capabilities or for those who are

capable but choose to disable it. First you select the video device

you want to use form the menu and then you push the “Settings”

button to configure the device specific attributes. Each device is a

unique attribute that can be configured.

TABLE 3-5 Audio and Video Options

Menu Item Description
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Controlling Audio Within the Conference

You may adjust your audio on other computers in the conference and adjust the

audio you receive from conference participants.

To Adjust Your Audio Over a Conference

The checkbox to the left of the Conference Manager Microphone icon indicates

whether your audio is being played to other people in the call.

■ To start or stop playing your audio to other people in the call, click on the

checkbox to the left of the icon.

■ To control the output level of your audio, move the slider to the right to make

your audio louder, or to the left to make it quieter. This is important in a

multipoint conference, where this slider determines the volume of your audio

relative to other people’s audio.

■ If you are using point-to-point audio/video, only the person that you are

currently switched to will be able to hear you. To switch to a different person

in the call, see Controlling Video Within a Point-To-Point Conference.

To Adjust Conference Audio on Your Computer

The checkbox to the left of the Speaker icon indicates whether other people’s audio

is being played on your computer.

■ To start or stop listening to other people in the call, click on the checkbox to the

left of the icon.

■ To control the volume, move the slider to the right to increase the volume, or to

the left to decrease it.

■ If you are using point-to-point audio/video, you will hear only the person that

you are currently switched to. To switch to a different person in the call, see

Controlling Video Within a Point-To-Point Conference.

Controlling Your Video Image Over a Conference

Before starting a call using video, you can check the video image of yourself that

will appear on other people’s screens (for example to make sure that the camera on

your system is aligned correctly). The video image appears on your screen in a

window with the title My Video. You can show or hide the My Video window at any

time.
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▼ To Control Your Video Image Before a Conference

● Choose Tools → Video → Display My Video.

You can also hide the window by closing it. Prior to entering a call you will see the

message Not Sending beneath the My Video window.

To Control Your Video Image During a

Conference

Once in a call, a button is displayed in addition to the status message at the bottom

of the My Video window. The status message reflects the current state of video

transmission. The button is used to change that state as follows:

■ If the video status is “Sending”, the Pause button is shown. Click on this button to

pause the video display. When you pause the display, a “freeze frame” image

appears in the window and the status message becomes “Paused.”

■ If video status is “Paused”, the Play button is shown. Click on this button to

activate the video display. When you activate the display, video transmission is

restarted and the status message becomes “Sending”.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play

option that appears in the View menu of this window. These options only appear

when in a call.

You can control whether your video image is automatically sent to other people as

soon as you start a call; see To Set Audio/Video Device Options for more

information.

Controlling Video Image Within a Multipoint

Conference

If you are using multipoint audio/video, a video image of each person in the call is

displayed automatically when he or she starts sending video.

■ Each person’s image is displayed in a separate window, with their name as the

window title. As other people join or leave the call, new windows appear or

existing windows disappear.

■ You can choose which of these windows are displayed on your screen.
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▼ To Control Video Image Within a Multipoint Conference

● Choose Tools → Video → Display Others.

Click on an entry for the window you want to display or hide. Alternatively, you can

hide a displayed window by closing the window using the system menu.

At the bottom of each of these windows, a button indicates whether the video is

being displayed, as follows:

■ If the video status is “Receiving”, the Pause button is shown. Click on this button

to pause the video display. When you pause the display, a “freeze frame” image

appears in the window and the status message becomes “Paused”.

■ If video status is “Paused”, the Play button is shown. Click on this button to

activate the video display. When you activate the display, video transmission is

restarted and the status message becomes “Receiving”.

You can control whether you automatically display video images of other people as

soon as they start sending video; see To Set Audio/Video Options for more

information. If you do not display these images, the window for a remote user on

your screen remains blank until you use the Play button to start the video display.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play

option that appears in the View menu of this window.

Note – The window size used for other people’s video is determined by the

sender’s conferencing product.

Controlling Video Within a Point-To-Point

Conference

In point-to-point audio/video, you can see and hear only one other person in the

conference at a time. You can switch between different people in the conference; if

you switch to a different person, the person you were previously seeing and hearing

remains in the conference but is not switched to anyone.

Note – The switch attempt will fail if you try to switch to a person who is already

switched to someone else.

▼ To Switch to Another Person

● Choose from the Tools → Switch Audio and Video.
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This displays a list of people that you can switch to, including the person you are

currently switched to (with a selection marker next to that person’s name). The list

does not include people who do not have audio/video support.

■ To switch to a different person, click on that person’s name in the list.

■ To “switch out” so that you remain in the conference but are no longer switched

to anyone, click on the name of the person you are currently switched to (the

name with the selection marker next to it).

The Switch Audio and Video menu item only appears if you are in a conference with

more than one audio/video capable person and are using point-to-point

connections.

Displaying Remote Video in a Point-To-Point

Conference

If you are using point-to-point audio/video, the Remote Video window displays a

video image of the person you are currently switched to (if any).

■ To switch to a different person in the call, see Controlling Video Within a Point-

To-Point Conference.

■ You can choose whether to display this window on your screen by displaying

Remote Video.

▼ To Display Remote Video

● Choose Tools → Video → Display Remote Video.

This displays or stops displaying the window. Alternatively, you can close the

window by clicking on the Close button for the window.

Using the SunForum Whiteboard
The SunForum Whiteboard enables all conference participants to exchange ideas and

graphics. You do not need to be in a conference, however, to use the whiteboard.

There are two types of whiteboards available through SunForum:

■ T.126 mode, which allows you to interoperate with any computer system or

appliance using the T.126 protocol, regardless of platform software

■ SunForum 1.0 mode, which allows you to interoperate with PCs running the base

NetMeeting collaboration or PictureTel LiveShare Plus 4.0 products
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This section contains the following topics:

■ To Select a Whiteboard Mode

■ To Draw Graphical Objects

■ To Use Text Objects

■ To Move and Delete Objects

■ To Highlight Text and Images

■ To Add Screen Captures to the Whiteboard

■ To Import Graphics

■ To Export Graphics

■ To Use the Remote Pointer

■ To Use Whiteboard Stamps

■ To Copy to the Clipboard

■ To Navigate and Organize Pages

■ To Add a New Page

■ To Zoom the Whiteboard

■ To Lock the Whiteboard

■ To Save the Whiteboard Contents to a File

■ To Print the Whiteboard Contents

▼ To Select a Whiteboard Mode

1. Choose Tools → Options.

2. Choose the desired whiteboard mode: T.126 or SunForum 1.0 mode.

3. Click OK.

Note – Once you select a whiteboard in the Options window, this whiteboard will

open each time you select Whiteboard from either the Tools menu or from the

Whiteboard button on the SunForum conference manager. See To Start the

Whiteboard.
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▼ To Start the Whiteboard

● Choose Tools → Whiteboard, or click the Whiteboard button, from the SunForum
conference manager.

The whiteboard mode you selected in the Options window is displayed. This

example shows the SunForum 1.0 mode whiteboard.

FIGURE 3-4 SunForum 1.0 Whiteboard
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Whiteboard Menus

Whiteboard Tool Panel

Familiarize yourself with the whiteboard by experimenting with the drawing

features in the drawing tool panel to the left of the whiteboard. You do not need to

be in a conference to do this.

FIGURE 3-5 Whiteboard Tool Panel

TABLE 3-7 Whiteboard Menu Bar Descriptions

Menu Description

File For file handling functions such as New, Open, Save, Import,

Export, and Print.

Edit To edit functions such as copy, paste, clearing, deleting, inserting

pages, and so on.

Tools To select drawing functions. You can also click the icon on the draw

tool panel on the left side of the whiteboard.

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window

Lock

SunForum 1.0 mode

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

Select area

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

T.126 mode

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window

Select area
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▼ To Draw Graphical Objects

1. Click the tool type in the whiteboard tool panel.

For example, click freehand pen or choose Tools → Pen from the menu bar.

2. Choose your pen color and line thickness.

a. Click the Whiteboard Options button located on the bottom of the whiteboard.

FIGURE 3-6 Whiteboard Options Button

The Whiteboard Options panel is displayed.

FIGURE 3-7 Whiteboard Options Panel

b. Choose your pen color and pen width, then click OK.
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3. Click and drag your mouse button to draw the object.

As you release the mouse button, the object is seen by all other conference

participants.

To Use Text Objects

Creating Text Objects

1. Click the Text tool button, or choose Tools → Text.

2. Place your mouse pointer in the whiteboard where you want to enter text.

3. Click at that location.

A text field appears in the whiteboard.

4. Enter the text and click OK.

Editing Text Objects

1. Click the Text tool button, or choose Tool → Text.

2. Click the text in your whiteboard that you want to edit.

A text field appears in the whiteboard.

3. Edit the text and click OK.

Setting the Font and Style of Text Objects

You can set font options in two ways:

■ By changing settings in the Whiteboard Options tool before creating a new text

object

■ By selecting a text object, then changing the settings in the Whiteboard Options

tool.

■ By selecting a text object, then changing the settings when the text field is visible.

1. Click the Whiteboard Option button.

The Whiteboard Options window is displayed.

2. Click the Text Font, Text Size, and Text Style menus and choose the font setting.
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Note – Only a small number of fonts are available to ensure that text objects are able

to display on all user systems in the conference.

3. Click OK on the Whiteboard Options window.

▼ To Move and Delete Objects

1. Click the Selector tool button, or choose Tools → Selector.

2. Click the graphic or text that you want to move or delete.

A border is highlighted on the selected object.

a. To move the graphic or text, drag it with the mouse pointer to its new position.

b. To delete the graphic or text, press Delete on your keyboard, or choose
Edit ➤ Delete.

Note – If you delete an object by mistake, you can undelete and retrieve the last

deletion by choosing Edit ➤ Undelete.

▼ To Highlight Text and Images

1. Click the Highlight button, or choose Tools → Highlighter.

2. Draw on the whiteboard area you want to highlight.

To Add Screen Captures to the Whiteboard

You can capture the contents of a window, or an area of the desktop, to add to your

whiteboard for conferencing.

Selecting and Capturing a Window

1. Click the Select window button, or choose Tools → Select Window.

The whiteboard becomes an icon and the mouse pointer becomes a hand symbol.

2. Place the mouse pointer on the window you want to add to your whiteboard.

3. Click the window.

The window is captured and placed in your whiteboard.
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Note – Large graphical objects may take some time to transfer to all participant

systems.

Selecting and Capturing an Area of the Screen

1. Click the Select window button, or choose Tools → Select Area.

The whiteboard becomes an icon and the mouse pointer becomes a pair of

crosshairs.

2. Drag the mouse pointer over the area of your desktop screen that you want to
capture.

The image area is captured and placed in your whiteboard as you release the mouse

button.

Note – Once the image is captured in the whiteboard, you can use the Selector tool

to select the image and move or delete it across your whiteboard. See To Move and

Delete Objects.

▼ To Import Graphics

1. Choose File → Import.

The Select a file to import window is displayed.

2. Specify the file you want to import and click OK.

The image is added to the current page.

Note – You need the shareware filter ghostscript to import PostScript files into

the whiteboard. The location of ghostscript is specified in

/etc/opt/SUNWdat/config/dcgx as Whiteboard.GSPath.

▼ To Export Graphics

1. Choose File → Export.

The Export file window is displayed.

2. Specify the file you want to export.

3. Choose an image format from the Save file as type menu.
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4. Click OK.

The contents of the current page is written to the file in the selected format.

▼ To Use the Remote Pointer

The remote pointer is a pointing hand that everyone in the conference can see. When

you have the Select tool enabled, you can click on the pointer and drag it around, so

that you can point out areas of interest on the page.

1. Click the Remote Pointer button, or choose Tools → Remote Pointer.

A hand symbol pointer is displayed on your whiteboard.

2. Click and drag the remote pointer to move to selected areas of interest.

▼ To Use Whiteboard Stamps

The Whiteboard Stamps window offers a number of images you can “stamp” on the

whiteboard. These are user configurable. The SunForum software enables you to use

bitmap files (such as GIF) in user-defined locations.

Note – The location is /etc/opt/SUNWdat/config/dcgx , listed as

Whiteboard.StampFilename.1 through Whiteboard.StampFilename.12 . You

may have more than 12 stamps, however.

1. Click the rubber stamp button.

FIGURE 3-8 Rubber Stamps Button

The Whiteboard Stamps window is displayed.
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FIGURE 3-9 Whiteboard Stamps Window

2. Click on a stamp image and click OK.

When you place the pointer in the whiteboard, the pointer is a stamp.

3. Place the stamp pointer in the whiteboard where you want the image to appear
and click.

The stamp image is displayed.

To Copy to the Clipboard

You can cut and paste to and from a clipboard in two ways:

■ Using the quick method to copy text

■ Using the Edit commands to cut and paste text and graphics

Using the Quick Method to Copy Text

1. Select text in the whiteboard (or another text source window) or from another
application.

2. Place the mouse pointer in the whiteboard and click the middle mouse button to
paste the text selection.
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Using the Edit Commands

1. Select the text or object you want to copy.

2. Choose Edit → Cut or Edit → Copy.

3. Go to a new whiteboard page and choose Edit ➤ Paste.

▼ To Navigate and Organize Pages

● To navigate pages, use the navigation arrows at the bottom of the whiteboard to
change pages; or, use the Edit menu to clear, delete, insert, and to go to specific
pages.

● To organize pages, choose Edit → Bring to Front or Edit → Send to Back to move
the current page accordingly.

▼ To Add a New Page

● Click the new page button or choose Edit → Insert Page, located in the bottom
right corner of the whiteboard.

A new page is added after the current page.

FIGURE 3-10 New Page Button

Note – Using the menu to insert a page enables you to place the new page before or

after the current page.

▼ To Zoom the Whiteboard

● Click the Zoom button, or choose Tools → Zoom.

This changes the magnification of the whiteboard contents you are viewing.

▼ To Lock the Whiteboard

You can lock the whiteboard so that no one else in the conference can make any

changes to the contents.
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1. Click the Lock button, or choose Tools → Lock.

After a short delay, either you will have successfully locked the whiteboard

(indicated by the lock “down” position), or you will be notified that it could not be

locked. You may not be able to lock it because another user in the conference has

already locked the whiteboard or is in the middle of an operation that cannot be

interrupted.

2. Click the lock button a second time to release the lock.

Note – Locking feature cannot be used in a T.120 whiteboard.

▼ To Save the Whiteboard Contents to a File

● Choose File → Open.

or

● Choose File → Save (or File → Save As).

Note – Since the SunForum 1.0 whiteboard is compatible with Microsoft

NetMeeting whiteboard, SunForum software can read files created by NetMeeting

and NetMeeting can read files created by the SunForum software.

▼ To Print the Whiteboard Contents

● Click the Print button, or choose File → Print.

FIGURE 3-11 Print Button

In the print window, specify the printer or file name to print to, and which pages

you want to print.

Note – The printer name must be a valid printer device. The SunForum software

allows you to also specify a networked printer name.
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CHAPTER 4M

Technical Information

This chapter contains the following topics:

■ SunForum Architecture

■ T.120 Topology

■ T.126 Whiteboard

■ Using the SunForum Software Through a Network Security Mechanism

■ Installing and Using TrueType Fonts With SunForum Software

■ Calling Into a Multipoint Conferencing Unit

■ Password-Protected Conference

■ Solving Color Problems

■ SunForum Software Support

SunForum Architecture
The SunForum architecture consists of the International Technical Communications

Union (ITCU) protocol standard, T.120, which contains a series of communication

and application protocols and services that provide support for real-time, multipoint

data communications.

The T.120 architecture is a multilayered design, with defined protocols and service

definitions between layers. The upper-level layers require the lower-level layers of

the architecture to function.

The lower-level layers (T.122 through T.125) specify an application-independent

mechanism for providing multipoint data communication services to any application

that can use these facilities.
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The upper-level layers define protocols for specific conferencing applications, such

as T.127 for multipoint file transfer and T.128 for application sharing.

Applications that use these standardized protocols can coexist in the same

conference with applications that use proprietary protocols. In fact, SunForum

software users can use a mix of standardized and nonstandardized protocols.

T.120 Topology
In a conference, a hierarchy exists where the person starting the conference is at the

top and those joining the conference are underneath. Where a caller is in this

topology affects the conference connection of those who joined that particular caller

in the conference. This is illustrated in the following figure.

In this example,

■ If B hangs up, all those that B called are disconnected as well, leaving A and D in

the conference

■ If D hangs up, only D is disconnected, leaving A, B, and C in the conference

■ If A hangs up, the entire conference ends

FIGURE 4-1 T.120 Conference Hierarchy

Caller A

Caller B

Caller A Caller A

Caller DCaller C

Caller B Caller B

Caller C

A calls B B calls C (or C calls B) A calls D (or D calls A)

A begins conference
with B

C joins conference D joins conference
through Athrough B
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The way you create a conference is to establish one system, the conference host, for

conference participants to call in. A star (as in a star networking protocol) topology

is created where anyone except the host can leave the conference independently.

(This host can actually be a dedicated conference server machine, running a product

such as DataBeam neT.120, which can support several conferences simultaneously.)

T.126 Whiteboard
T.126 defines a protocol for viewing and annotating still images transmitted between

two or more applications. This capability is often referred to as document

conferencing or shared whiteboarding. T.126 readily shares visual information between

applications that are running on dramatically different platforms. For example, a

Windows-based desktop application could easily interoperate with a collaboration

program running on a UNIX workstation. Similarly, a group-oriented conferencing

system, without a PC-style interface, could share data with multiple users running

common PC desktop software.

T.126 presents the concept of shared virtual workspaces that are manipulated by the

endpoint applications. Each workspace may contain a collection of objects that

include bitmap images and annotation primitives, such as rectangles and freehand

lines. Bitmaps typically originate from application information, such as a word

processing document or a presentation slide. Because of their size, bitmaps are often

compressed to improve performance over bandwidth-limited communication links.

T.126 is designed to provide a feature-rich set of capabilities required to share

information between disparate applications. SunForum software, as does other T.126

implementations, only offers a subset of these features. To date, only two other

commercially available T.126 products exist. The subset of features in SunForum

software match those supported in DataBeam’s Meeting Tools and Polycon’s

Showstation IP.

Using the SunForum Software Through a
Network Security Mechanism
If you are connected to the Internet via a network security mechanism, or firewall,

(as is usual in most corporate/LAN environments), you can use SunForum software

to communicate with others located both inside and outside the network security

mechanism. To enable full external communication:
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■ Ensure your workstation has its default gateway set to the internal address of the

network security mechanism computer.

■ Configure the network security mechanism to enable primary TCP connections

over the following IP ports:

■ 389 (for communication with Internet Locator Servers)

■ 1503 (for T.120 data)

Note – If this is not possible with your network security mechanism, you will not be

able to communicate with computers outside the network security mechanism.

Consult your network security mechanism vendor about upgrading to a version

compatible with SunForum software.

■ Configure the network security mechanism to map internal IP addresses to

external Internet addresses.

Note – This is not possible with all network security mechanisms. If yours cannot

do this, you will be able to call out from inside the network security mechanism, but

you will not be able to receive incoming calls from computers outside the network

security mechanism.

If you are unsure whether you are connecting to the Internet via a network security

mechanism, consult your system administrator or Internet service provider.

Installing and Using TrueType Fonts
With SunForum Software
SunForum software is designed to take advantage of a TrueType fonts/font server if

one is installed on your system (or accessible to your system across a local area

network). Solaris 2.6 operating environment supports TrueType fonts.

With a TrueType font server installed, SunForum software will have more fonts in

common with PC systems, resulting in better quality output and improved

performance in sharing sessions involving both UNIX and PC systems.
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Calling Into a Multipoint Conferencing
Unit
SunForum software fully supports MCU-hosted conferences, and has been tested

with Outreach ConferEase and DataBeam neT.120.

When calling an MCU, specify the address of the MCU as normal. If SunForum

software detects that the machine called is currently hosting more than one

conference, you will be prompted to specify which conference to join. Also, see

Password-Protected Conferences.

Password-Protected Conferences
You cannot create a password-protected conference with SunForum software.

When you call into a conference that has been designated as password-protected,

SunForum software will prompt you to specify the password.

Some T.120 implementations incorrectly advertise conferences as password

protected, even when no password has been specified. In this case, just click OK

without specifying a password; the conference will be established as normal.

Solving Color Problems
If you experience problems with color operations (such as text highlighting) with

shared PC applications, try the following:

■ If your X Server is running with a Static or DirectColor default visual, switch it to

run with PseudoColor or GrayScale. See your X Server documentation for

information on how to do this.

■ Close any local color-intensive X applications (such as bitmap editors and web

browsers) to make more colors available for the SunForum software.
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SunForum Software Support
If you have any problems installing or using the SunForum software:

■ Refer to the written or online documentation included with the software.

■ Read the rest of the online help, especially the READMEpage, for a list of known

problems with this release.

■ Check the up-to-date “Troubleshooting guide” at www.sun.com .

■ If you are unable to find an answer, contact your Sun representative and have the

following information available:

■ Your system configuration (system hardware, operating system version,

graphics hardware)

■ A complete description of what you were doing when the problem occurred

■ Any core file generated (check the /opt/SUNWdat directory)

■ The contents of any error log files generated (called TRC1 and/or TRC2 in the

/var/opt/SUNWdat/trc directory)
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